]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- new macro pyrequires_eq so modules can have requirement only for main
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        RPM Package Manager
4 Summary(de):    RPM Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami RPM
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        63
11 License:        GPL
12 Group:          Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Source14:       %{name}-groups-po.awk
28 Patch0:         %{name}-rpmrc.patch
29 Patch1:         %{name}-macros.patch
30 Patch2:         %{name}-arch.patch
31 Patch3:         %{name}-rpmpopt.patch
32 Patch4:         %{name}-perl-macros.patch
33 Patch5:         %{name}-db3.patch
34 Patch6:         %{name}-segv.patch
35 Patch7:         %{name}-am_fix.patch
36 Patch8:         %{name}-perl-req-perlfile.patch
37 Patch9:         %{name}-installplatform.patch
38 Patch10:        %{name}-cache.patch
39 Patch11:        %{name}-suggestions.patch
40 Patch12:        %{name}-rh-lame.patch
41 Patch13:        %{name}-glob.patch
42 Patch14:        %{name}-header_h.patch
43 Patch15:        %{name}-fast-alAddPackage.patch
44 Patch16:        %{name}-byKey.patch
45 Patch17:        %{name}-perlprov.patch
46 Patch18:        %{name}-noperldir.patch
47 Patch19:        popt-cvs20010530.patch
48 Patch20:        %{name}-noexpand.patch
49 Patch21:        %{name}-scripts-closefds.patch
50 Patch22:        %{name}-python-amfix.patch
51 Patch23:        %{name}-non-english-man-pages.patch
52 Patch24:        %{name}-progress-nontty.patch
53 Patch25:        %{name}-am_ac.patch
54 Patch26:        %{name}-python-macros.patch
55 Patch27:        %{name}-hardlink-fixes.patch
56 Patch28:        %{name}-perlprov-regonly.patch
57 Patch29:        %{name}-cxx.patch
58 Patch30:        %{name}-athlon.patch
59 Patch31:        %{name}-athlon-identify.patch
60 Patch32:        %{name}-gettext-in-header.patch
61 Patch33:        %{name}-perlprov-perl5.6.patch
62 Patch34:        %{name}-ac25x.patch
63 Patch35:        %{name}-signverify-fix.patch
64 Patch37:        %{name}-short_circuit.patch
65 Patch38:        %{name}-section_test.patch
66 URL:            http://www.rpm.org/
67 Icon:           rpm.gif
68 BuildRequires:  autoconf >= 2.50
69 BuildRequires:  automake
70 BuildRequires:  bzip2-devel >= 1.0.1
71 BuildRequires:  db1-devel >= 1.85
72 BuildRequires:  db3-devel >= 3.1.17-9
73 BuildRequires:  gettext-devel >= 0.10.38-3
74 BuildRequires:  python-devel >= 2.2
75 BuildRequires:  python-modules >= 2.2
76 BuildRequires:  python-devel >= 2.2.1
77 BuildRequires:  python-modules >= 2.2.1
78 BuildRequires:  zlib-devel >= 1.1.4
79 %if %{!?_without_static:1}%{?_without_static:0}
80 # Require static library only for static build
81 BuildRequires:  bzip2-static >= 1.0.1
82 BuildRequires:  db1-static >= 1.85
83 BuildRequires:  db3-static >= 3.1.17-9
84 BuildRequires:  glibc-static >= 2.2.0
85 BuildRequires:  zlib-static >= 1.1.4
86 %endif
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88 Obsoletes:      rpm-libs
89 Conflicts:      glibc < 2.2
90
91 %define         __find_provides %{SOURCE4}
92 %define         _binary_payload w9.gzdio
93
94 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
95 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
96 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
97 %define         py_sitedir      %{py_libdir}/site-packages
98 %define         py_dyndir       %{py_libdir}/lib-dynload
99 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
100
101 %description
102 RPM is a powerful package manager, which can be used to build,
103 install, query, verify, update, and uninstall individual software
104 packages. A package consists of an archive of files, and package
105 information, including name, version, and description.
106
107 %description -l de
108 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
109 Installation, Anfrage, Verifizierung, Aktualisierung und
110 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
111 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
112 Beschreibung.
113
114 %description -l es
115 RPM es un poderoso administrador de paquetes, que puede ser usado para
116 construir, instalar, pesquisar, verificar, actualizar y desinstalar
117 paquetes individuales de software. Un paquete consiste en un
118 almacenaje de archivos, y información sobre el paquete, incluyendo
119 nombre, versión y descripción.
120
121 %description -l pl
122 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
123 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
124 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
125 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
126 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
127 odpytywania programu rpm.
128
129 %description -l pt_BR
130 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
131 construir, instalar, pesquisar, verificar, atualizar e desinstalar
132 pacotes individuais de software. Um pacote consiste de um conjunto de
133 arquivos e informações adicionais, incluindo nome, versão e descrição
134 do pacote, permissões dos arquivos, etc.
135
136 %package devel
137 Summary:        Header files and libraries
138 Summary(de):    Header-Dateien uns Libraries
139 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
140 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
141 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
142 Group:          Development/Libraries
143 Requires:       %{name} = %{version}
144 Requires:       popt-devel
145
146 %description devel
147 The RPM packaging system includes a C library that makes it easy to
148 manipulate RPM packages and databases. It is intended to ease the
149 creation of graphical package managers and other tools that need
150 intimate knowledge of RPM packages.
151
152 %description devel -l de
153 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
154 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
155 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
156 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
157
158 %description devel -l es
159 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
160 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
161 facilitar la creación de administradores gráficos de paquetes y otras
162 herramientas que necesiten un conocimiento profundo de paquetes RPM.
163
164 %description devel -l pl
165 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
166 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
167 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
168 szczegó³owej wiedzy na temat pakietów RPM.
169
170 %description devel -l pt_BR
171 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
172 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
173 facilitar a criação de gerenciadores gráficos de pacotes e outras
174 ferramentas que precisem de conhecimento profundo de pacotes RPM.
175
176 %package static
177 Summary:        RPM static libraries
178 Summary(de):    RPMs statische Libraries
179 Summary(pl):    Biblioteki statyczne RPM-a
180 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
181 Group:          Development/Libraries
182 Requires:       %{name}-devel = %{version}
183
184 %description static
185 RPM static libraries.
186
187 %description static -l de
188 RPMs statische Libraries.
189
190 %description static -l pl
191 Biblioteki statyczne RPM-a.
192
193 %description static -l pt_BR
194 Bibliotecas estáticas para desenvolvimento.
195
196 %package utils
197 Summary:        Additional utilities for managing rpm packages and database
198 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
199 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
200 Group:          Applications/File
201 Requires:       %{name} = %{version}
202
203 %description utils
204 Additional utilities for managing rpm packages and database.
205
206 %description utils -l de
207 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
208
209 %description utils -l pl
210 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
211
212 %package perlprov
213 Summary:        Additional utilities for checking perl provides/requires in rpm packages
214 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
215 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
216 Group:          Applications/File
217 Requires:       %{name} = %{version}
218 Requires:       perl-modules
219 Requires:       findutils
220
221 %description perlprov
222 Additional utilities for checking perl provides/requires in rpm
223 packages.
224
225 %description perlprov -l de
226 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
227
228 %description perlprov -l pl
229 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
230 pakietach rpm.
231
232 %package pythonprov
233 Summary:        Python macros, which simplifies creation of rpm packages with Python software
234 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
235 Group:          Applications/File
236 Requires:       %{name} = %{version}
237 Requires:       python-modules
238
239 %description pythonprov
240 Python macros, which simplifies creation of rpm packages with Python
241 software.
242
243 %description pythonprov -l pl
244 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
245 Pythonie.
246
247 %package -n python-rpm
248 Summary:        Python interface to RPM library
249 Summary(pl):    Pythonowy interfejs do biblioteki RPM-a
250 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
251 Group:          Libraries/Python
252 Requires:       %{name} = %{version}
253 %pyrequires_eq  python
254 Obsoletes:      rpm-python
255
256 %description -n python-rpm
257 The rpm-python package contains a module which permits applications
258 written in the Python programming language to use the interface
259 supplied by RPM (RPM Package Manager) libraries.
260
261 This package should be installed if you want to develop Python
262 programs that will manipulate RPM packages and databases.
263
264 %description -n python-rpm -l pl
265 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
266 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
267
268 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
269 Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
270
271 %description -n python-rpm -l pt_BR
272 O pacote rpm-python contém um módulo que permite que aplicações
273 escritas em Python utilizem a interface fornecida pelas bibliotecas
274 RPM (RPM Package Manager).
275
276 Esse pacote deve ser instalado se você quiser desenvolver programas em
277 Python para manipular pacotes e bancos de dados RPM.
278
279 %package build
280 Summary:        Scripts for building binary RPM packages
281 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
282 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
283 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
284 Group:          Applications/File
285 Requires:       %{name} = %{version}
286 Requires:       /bin/id
287 Requires:       awk
288 Requires:       binutils
289 Requires:       diffutils
290 Requires:       file >= 3.31
291 Requires:       fileutils
292 Requires:       findutils
293 %ifarch athlon
294 Requires:       gcc >= 3.0.3
295 %else
296 Requires:       gcc
297 %endif
298 Requires:       glibc-devel
299 Requires:       grep
300 Requires:       gzip
301 Requires:       make
302 Requires:       patch
303 Requires:       popt >= 1.6.2-2
304 Requires:       sed
305 Requires:       sh-utils
306 Requires:       tar
307 Requires:       textutils
308
309 %description build
310 Scripts for building binary RPM packages.
311
312 %description build -l de
313 Scripts fürs Bauen binärer RPM-Pakete.
314
315 %description build -l pl
316 Skrypty pomocnicze do budowania binarnych RPM-ów.
317
318 %description build -l pt_BR
319 Este pacote contém scripts e programas executáveis que são usados para
320 construir pacotes usando o RPM.
321
322 %prep
323 %setup -q -a12
324 %patch0 -p1
325 %patch1 -p1
326 %patch2 -p1
327 %patch3 -p1
328 %patch4 -p1
329 %patch5 -p1
330 %patch6 -p1
331 %patch7 -p1
332 %patch8 -p1
333 %patch9 -p1
334 %patch10 -p1
335 %patch11 -p0
336 %patch12 -p0
337 %patch13 -p1
338 %patch14 -p1
339 %patch15 -p0
340 %patch16 -p0
341 %patch17 -p1
342 %patch18 -p1
343 %patch19 -p1
344 %patch20 -p1
345 %patch21 -p1
346 %patch22 -p1
347 %patch23 -p1
348 %patch24 -p1
349 %patch25 -p1
350 %patch26 -p0
351 %patch27 -p1
352 %patch28 -p1
353 %patch29 -p1
354 %patch30 -p1
355
356 %ifarch athlon
357 %patch31 -p1
358 %endif
359
360 %patch32 -p1
361 %patch33 -p1
362 %patch35 -p1
363 %patch36 -p1
364 %patch37 -p1
365 %patch38 -p1
366
367 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
368 cp -f platform.in macros.pld.in
369 install %{SOURCE5} macros.perl.in
370 install %{SOURCE13} macros.python.in
371 install %{SOURCE6} scripts/find-perl-provides
372 install %{SOURCE7} scripts/find-perl-requires
373 install %{SOURCE9} scripts/find-lang.sh
374
375 (cd scripts;
376 mv -f perl.req perl.req.in
377 mv -f perl.prov perl.prov.in)
378
379 chmod +x %{SOURCE4}
380
381 %build
382 # generate Group translations to *.po
383 awk -f %{SOURCE14} %{SOURCE1}
384
385 cd popt
386 autoconf
387 automake -a -c -f
388 aclocal
389 autoheader
390 automake -a -c -f
391 %{__automake}
392 cd ..
393
394 rm -f missing
395 libtoolize --force --copy
396 autoconf
397 aclocal
398 autoupdate
399 autoheader || :
400 %{__autoconf}
401 automake -a -c -f
402 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
403         lib/Makefile.am > lib/Makefile.am.new
404 mv -f lib/Makefile.am.new lib/Makefile.am
405 %{__automake}
406 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
407         lib/Makefile.in > lib/Makefile.in.new
408 mv -f lib/Makefile.in.new lib/Makefile.in
409
410 sed -e 's#python1.5#python%{py_ver}#g' \
411         python/Makefile.in > python/Makefile.in.new
412 mv -f python/Makefile.in.new python/Makefile.in
413
414 # config.guess doesn't handle athlon, so we have to change it by hand.
415 # rpm checks for CPU type at runtime, but it looks better
416 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
417         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
418 mv -f macros.tmp macros.in
419
420 %configure \
421         --enable-shared \
422         --enable-v1-packages \
423         --with-python
424
425
426 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
427
428 %install
429 rm -rf $RPM_BUILD_ROOT
430
431 %{__make} install \
432         DESTDIR=$RPM_BUILD_ROOT \
433         pkgbindir="%{_bindir}"
434
435 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
436 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
437
438 install %{SOURCE1} doc/manual/groups
439 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
440 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
441 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
442 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
443 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
444
445 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
446
447 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
448 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
449 # customized rpm macros - global for host
450 #
451 #%%_install_langs pl_PL:en_US
452 %%distribution PLD
453 EOF
454
455 %find_lang %{name}
456
457 # DON'T BREAK BUILD TREE!!!
458 # rm -f doc/manual/Makefile*
459
460 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
461
462 %clean
463 rm -rf $RPM_BUILD_ROOT
464
465 %post   -p /sbin/ldconfig
466 %postun -p /sbin/ldconfig
467
468 %files -f %{name}.lang
469 %defattr(644,root,root,755)
470 %doc RPM-PGP-KEY.gz CHANGES.gz doc/manual/*
471
472 %attr(755,root,root) /bin/rpm
473 %attr(755,root,root) %{_bindir}/rpmdb
474 %attr(755,root,root) %{_bindir}/rpmquery
475 %attr(755,root,root) %{_bindir}/rpmsign
476 %attr(755,root,root) %{_bindir}/rpmverify
477 %attr(755,root,root) %{_libdir}/rpm/rpmdb
478 %attr(755,root,root) %{_libdir}/rpm/rpmq
479 %attr(755,root,root) %{_libdir}/rpm/rpmk
480 %attr(755,root,root) %{_libdir}/rpm/rpmv
481 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
482
483 %dir %{_sysconfdir}/rpm
484 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
485
486 %{_mandir}/man8/rpm.8*
487 %lang(fr) %{_mandir}/fr/man8/rpm.8*
488 %lang(ja) %{_mandir}/ja/man8/rpm.8*
489 %lang(ko) %{_mandir}/ko/man8/rpm.8*
490 %lang(pl) %{_mandir}/pl/man8/rpm.8*
491 %lang(ru) %{_mandir}/ru/man8/rpm.8*
492 %lang(sk) %{_mandir}/sk/man8/rpm.8*
493
494 %dir /var/lib/rpm
495 %dir %{_libdir}/rpm
496
497 %{_libdir}/rpm/macros.python
498 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
499
500 %{_libdir}/rpm/rpmrc
501 %{_libdir}/rpm/rpmpopt*
502 %{_libdir}/rpm/macros
503 %{_libdir}/rpm/noarch-linux
504 %{_libdir}/rpm/noarch-pld-linux
505 %ifarch i386 i486 i586 i686 athlon
506 %{_libdir}/rpm/i?86*
507 %{_libdir}/rpm/athlon*
508 %endif
509 %ifarch sparc sparc64
510 %{_libdir}/rpm/sparc*
511 %endif
512 %ifarch alpha
513 %{_libdir}/rpm/alpha*
514 %endif
515 %ifarch ppc
516 %{_libdir}/rpm/ppc*
517 %endif
518
519
520 %files build
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{_bindir}/rpmbuild
523 %attr(755,root,root) %{_bindir}/rpme
524 %attr(755,root,root) %{_bindir}/rpmi
525 %attr(755,root,root) %{_bindir}/rpmu
526 %attr(755,root,root) %{_libdir}/rpm/find-requires
527 %attr(755,root,root) %{_libdir}/rpm/find-provides
528 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
529 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
530 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
531 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
532 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
533 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
534 %attr(755,root,root) %{_libdir}/rpm/brp-*
535 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
536 %attr(755,root,root) %{_libdir}/rpm/compress-doc
537 %attr(755,root,root) %{_libdir}/rpm/cpanflute
538 %attr(755,root,root) %{_libdir}/rpm/http.req
539 %attr(755,root,root) %{_libdir}/rpm/magic.*
540 %attr(755,root,root) %{_libdir}/rpm/rpmdiff*
541 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
542 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
543 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
544 %attr(755,root,root) %{_libdir}/rpm/rpmb
545 %attr(755,root,root) %{_libdir}/rpm/rpmi
546 %attr(755,root,root) %{_libdir}/rpm/rpmt
547 %attr(755,root,root) %{_libdir}/rpm/rpme
548 %attr(755,root,root) %{_libdir}/rpm/rpmu
549
550 %files devel
551 %defattr(644,root,root,755)
552 %{_includedir}/rpm
553 %attr(755,root,root) %{_libdir}/librpm*.la
554 %attr(755,root,root) %{_libdir}/librpm*.so
555
556 %files static
557 %defattr(644,root,root,755)
558 %{_libdir}/librpm*.a
559
560 %files utils
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_bindir}/gendiff
563 %attr(755,root,root) %{_bindir}/javadeps
564 %attr(755,root,root) %{_bindir}/rpm2cpio
565
566 %{_mandir}/man8/rpm2cpio.8*
567 %{_mandir}/man1/*
568 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
569 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
570 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
571 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
572
573 %files perlprov
574 %defattr(644,root,root,755)
575 %attr(755,root,root) %{_libdir}/rpm/perl*
576 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
577 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
578 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
579 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
580 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
581
582 %{_libdir}/rpm/macros.perl
583
584 %files pythonprov
585 %defattr(644,root,root,755)
586 %{_libdir}/rpm/macros.python
587
588 %files -n python-rpm
589 %defattr(755,root,root,755)
590 %{py_sitedir}/*.so
This page took 0.081907 seconds and 4 git commands to generate.