]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- update to new snapshots
[packages/rpm.git] / rpm.spec
1 %define date    19990513
2
3 Summary:        Red Hat & PLD Package Manager
4 Summary(pl):    Aplikacja do zarz±dzania pakietami
5 Name:           rpm
6 Version:        3.0.1
7 Release:        5.%{date}
8 Group:          Base
9 Group(pl):      Bazowe
10 Copyright:      GPL
11 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/%{name}-%{version}.%{date}.tar.gz
12 Source1:        rpm.groups
13 Source2:        rpm.8pl
14 Source3:        rpm.macros
15 Source4:        rpm.pl.po
16 Patch0:         rpm-rpmrc.patch
17 Patch1:         rpm-i18n.patch
18 Patch2:         rpm-find-requires.patch
19 Patch3:         rpm-macros.patch
20 Patch4:         rpm-po.patch
21 Patch37:        %{name}-short_circuit.patch
22 Patch38:        %{name}-section_test.patch
23 BuildPrereq:    bzip2-static
24 BuildPrereq:    gdbm-static
25 BuildPrereq:    zlib-static
26 BuildPrereq:    patch >= 2.2
27 BuildPrereq:    libtool
28 BuildPrereq:    automake
29 BuildPrereq:    autoconf >= 2.13-8
30 BuildPrereq:    gettext
31 Requires:       glibc >= 2.1
32 BuildRoot:      /tmp/%{name}-%{version}-root
33 Obsoletes:      rpm-libs
34 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
35 RPM is a powerful package manager, which can be used to build, install, 
36 query, verify, update, and uninstall individual software packages. A 
37 package consists of an archive of files, and package information, including 
38 name, version, and description.
39 packages. A package consists of an archive of files, and package
40 nombre, versión y descripción.
41 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³ przebudowaæ,
42 zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego 
43 pakietu s± przechowywane w bazie danych i dostêpne tylko dla administratora 
44 systemu.
45 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
46 do pacote, permissões dos arquivos, etc.
47 Summary:        Header files and libraries 
48 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
49 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
50 Group(pl):      Programowanie/Biblioteki
51 Requires:       %{name} = %{version}
52 Requires:       %{name} = %{version}
53 Requires:       popt-devel
54
55 %description devel
56 The RPM packaging system includes a C library that makes it easy to
57 manipulate RPM packages and databases. It is intended to ease the
58 creation of graphical package managers and other tools that need
59 %description -l pl devel
60 Pliki nag³ówkowe i biblioteki statyczne.
61 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
62 construir pacotes usando o RPM.
63 %setup  -q
64 %patch0 -p1 
65 %patch1 -p1
66 %patch2 -p1
67 %patch1 -p1
68 %patch4 -p1 
69 %patch31 -p1
70 install %{SOURCE4} po/pl.po
71 install %{SOURCE13} macros.python.in
72 mv -f perl.prov perl.prov.in)
73 LDFLAGS="-s"; export LDFLAGS
74
75 ( cd popt; 
76 %GNUconfigure
77 )
78
79 %GNUconfigure 
80 %configure \
81 make
82         --with-python
83
84
85 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
86 install -d $RPM_BUILD_ROOT/var/db/rpm \
87         $RPM_BUILD_ROOT/usr/share/man/{ru,pl}/man8 \
88         $RPM_BUILD_ROOT/etc/skel/C/rpm/{SRPMS,RPMS,SOURCES,SPECS,BUILD}
89
90 make DESTDIR="$RPM_BUILD_ROOT" pkgbindir="/usr/bin" install
91
92 install %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/rpm/macros.pld
93         pkgbindir="%{_bindir}"
94 install rpm.8ru $RPM_BUILD_ROOT/usr/share/man/ru/man8/rpm.8
95 install rpm2cpio.8ru $RPM_BUILD_ROOT/usr/share/man/ru/man8/rpm2cpio.8
96 install %{SOURCE2} $RPM_BUILD_ROOT/usr/share/man/pl/man8/rpm.8
97
98 install %{SOURCE1} docs/groups
99 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
100 strip  $RPM_BUILD_ROOT/{bin/rpm,usr/bin/*} || :
101
102 gzip -9fn $RPM_BUILD_ROOT/usr/share/man/{{ru,pl}/man8/*,man8/*} \
103         RPM-PGP-KEY CHANGES docs/*
104
105 %pre
106 if [ -e /var/lib/rpm ] && [ ! -L /var/lib/rpm ]; then
107         mkdir -p /var/db/rpm /var/db/rpm.old
108         cp -a /var/lib/rpm/* /var/db/rpm
109         cp -a /var/lib/rpm/* /var/db/rpm.old
110         echo "Yours old rpm database backuped in /var/db/rpm.old" >&2
111         echo "Run \'rpm --rebuilddb\' to update rpm database" >&2
112 fi
113
114 %post
115 /bin/rpm --initdb
116 if [ -e /var/lib/rpm ] && [ ! -L /var/lib/rpm ]; then
117         rm -rf /var/lib/rpm/
118         ln -s ../db/rpm /var/lib/rpm
119 fi
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125
126 %doc RPM-PGP-KEY.gz CHANGES.gz docs/*
127 %postun -p /sbin/ldconfig
128
129 %attr(755,root,root) /usr/bin/*
130 %attr(755,root,root) %{_libdir}/rpm/rpmdb
131 /usr/share/man/man8/*
132 %lang(ru) /usr/share/man/ru/man8/*
133 %lang(pl) /usr/share/man/pl/man8/*
134
135 %lang(cs)    /usr/share/locale/cs/LC_MESSAGES/rpm.mo
136 %lang(de)    /usr/share/locale/de/LC_MESSAGES/rpm.mo
137 %lang(fi)    /usr/share/locale/fi/LC_MESSAGES/rpm.mo
138 %lang(fr)    /usr/share/locale/fr/LC_MESSAGES/rpm.mo
139 %lang(pl)    /usr/share/locale/pl/LC_MESSAGES/rpm.mo
140 %lang(pt_BR) /usr/share/locale/pt_BR/LC_MESSAGES/rpm.mo
141 %lang(ru)    /usr/share/locale/ru/LC_MESSAGES/rpm.mo
142 %lang(sk)    /usr/share/locale/sk/LC_MESSAGES/rpm.mo
143 %lang(sr)    /usr/share/locale/sr/LC_MESSAGES/rpm.mo
144 %lang(sv)    /usr/share/locale/sv/LC_MESSAGES/rpm.mo
145 %lang(tr)    /usr/share/locale/tr/LC_MESSAGES/rpm.mo
146 %lang(ru) %{_mandir}/ru/man8/rpm.8*
147 %attr(755,root,root) %dir /var/db/rpm
148
149 %dir /usr/lib/rpm
150 %attr(755,root,root) /usr/lib/rpm/find-*
151 %attr(755,root,root) /usr/lib/rpm/freshen.sh
152 %attr(755,root,root) /usr/lib/rpm/mkinstalldirs
153 %attr(755,root,root) /usr/lib/rpm/config.*
154 %attr(755,root,root) /usr/lib/rpm/getpo.sh
155
156 /usr/lib/rpm/rpm*
157 /usr/lib/rpm/macros*
158
159 /etc/skel/C/rpm
160 %attr(755,root,root) %{_libdir}/rpm/rpmb
161 %attr(755,root,root) %{_libdir}/rpm/rpmi
162 %attr(755,root,root) %{_libdir}/rpm/rpmt
163 /usr/include/rpm
164 /usr/lib/librpm*.a
165 /usr/lib/librpm*.la
166 %files utils
167 %files -n python-rpm
168 * Fri Apr 30 1999 Artur Frysiak <wiget@pld.org.pl>
169   [3.0.1-4]
170 - added 4 macros:
171 -- %GNUconfigure and %GNUconfigureS to complete remake autoconf/automake stuff
172 -- %configure and %configureS to corect run ./configure
173 -- *S add "-s" to LDFLAGS
174 - added user skelet dirs (for adduser)
175
176 * Mon Apr 19 1999 Artur Frysiak <wiget@pld.org.pl>
177   [3.0-7]
178 - upgraded to 3.0
179 - added polish man page
180 - added macros for PLD
181
182 * Wed Mar 10 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
183   [2.5.6-5]
184 - added rpm-find-requires.patch with beter finding list packages containing
185   required shared libraries (Artur Frysiak <wiget@usa.net>),
186 - added ru man pages,
187 - added "Requires: glibc >= 2.1" (rpm is linked statically but it use by
188   dlopen() some shared glibc libraries),
189 - removed man group from man pages.
190
191 * Fri Feb 19 1999 Marcin Dalecki <dalecki@cs.net.pl>
192   [2.5.6-4d]
193 - fixed ignorance about international character sets.
194
195 * Fri Jan 15 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
196   [2.5.6-1d]
197 - updated to latest stable version,
198 - added URL,
199 - added Group(pl) && changed gropup to Base,
200 - added small patch against GNU libc-2.1.
201
202 * Sun Nov 08 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
203   [2.5.5-1d]
204 - updated to 2.5.5. 
205
206 * Tue Sep 01 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
207   [2.5.2-2d]
208 - translation modified for pl,
209 - compressed man pages && documentation,
210 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
211 - moved /usr/src/redhat to /usr/src/rpm.
212
213 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
214   [2.5.2-2]
215 - fixed tr.po,
216 - added -q %setup parameter,
217 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
218 - added using %%{name} and %%{version} in Source,
219 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
220 - added %attr and %defattr macros in %files (allow build package from
221   non-root account),
222 - build against GNU libc-2.1.
223
224 Revision 1.79  2000/02/17 03:42:17  kloczek
225 - release 25,
226 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
227   /bin.
This page took 0.037524 seconds and 4 git commands to generate.