]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- added check_files patch and check-files script to
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        RPM Package Manager
4 Summary(de):    RPM Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami RPM
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        74
11 License:        GPL
12 Group:          Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Source14:       %{name}-groups-po.awk
28 Source15:       %{name}-compress-doc
29 Source16:       %{name}-check-files
30 Patch0:         %{name}-rpmrc.patch
31 Patch1:         %{name}-macros.patch
32 Patch2:         %{name}-arch.patch
33 Patch3:         %{name}-rpmpopt.patch
34 Patch4:         %{name}-perl-macros.patch
35 Patch5:         %{name}-db3.patch
36 Patch6:         %{name}-segv.patch
37 Patch7:         %{name}-am_fix.patch
38 Patch8:         %{name}-perl-req-perlfile.patch
39 Patch9:         %{name}-installplatform.patch
40 Patch10:        %{name}-cache.patch
41 Patch11:        %{name}-suggestions.patch
42 Patch12:        %{name}-rh-lame.patch
43 Patch13:        %{name}-glob.patch
44 Patch14:        %{name}-header_h.patch
45 Patch15:        %{name}-fast-alAddPackage.patch
46 Patch16:        %{name}-byKey.patch
47 Patch17:        %{name}-perlprov.patch
48 Patch18:        %{name}-noperldir.patch
49 Patch19:        popt-cvs20010530.patch
50 Patch20:        %{name}-noexpand.patch
51 Patch21:        %{name}-scripts-closefds.patch
52 Patch22:        %{name}-python-amfix.patch
53 Patch23:        %{name}-non-english-man-pages.patch
54 Patch24:        %{name}-progress-nontty.patch
55 Patch25:        %{name}-am_ac.patch
56 Patch26:        %{name}-python-macros.patch
57 Patch27:        %{name}-hardlink-fixes.patch
58 Patch28:        %{name}-perlprov-regonly.patch
59 Patch29:        %{name}-cxx.patch
60 Patch30:        %{name}-athlon.patch
61 Patch31:        %{name}-athlon-identify.patch
62 Patch32:        %{name}-gettext-in-header.patch
63 Patch33:        %{name}-perlprov-perl5.6.patch
64 Patch34:        %{name}-ac25x.patch
65 Patch35:        %{name}-signverify-fix.patch
66 Patch36:        %{name}-compress-doc.patch
67 Patch37:        %{name}-short_circuit.patch
68 Patch38:        %{name}-test_stage.patch
69 Patch39:        %{name}-exclude.patch
70 Patch40:        %{name}-check_files.patch
71 URL:            http://www.rpm.org/
72 Icon:           rpm.gif
73 BuildRequires:  autoconf >= 2.50
74 BuildRequires:  automake
75 BuildRequires:  bzip2-devel >= 1.0.1
76 BuildRequires:  db1-devel >= 1.85
77 BuildRequires:  db3-devel >= 3.1.17-9
78 BuildRequires:  gettext-devel >= 0.10.38-3
79 BuildRequires:  libtool
80 BuildRequires:  patch >= 2.2
81 BuildRequires:  python-devel >= 2.2.1
82 BuildRequires:  python-modules >= 2.2.1
83 BuildRequires:  zlib-devel >= 1.1.4
84 %if %{!?_without_static:1}%{?_without_static:0}
85 # Require static library only for static build
86 BuildRequires:  bzip2-static >= 1.0.1
87 BuildRequires:  db1-static >= 1.85
88 BuildRequires:  db3-static >= 3.1.17-9
89 BuildRequires:  glibc-static >= 2.2.0
90 BuildRequires:  zlib-static >= 1.1.4
91 %endif
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93 Obsoletes:      rpm-libs
94 Conflicts:      glibc < 2.2
95
96 %define         __find_provides %{SOURCE4}
97 %define         _binary_payload w9.gzdio
98
99 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
100 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
101 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
102 %define         py_sitedir      %{py_libdir}/site-packages
103 %define         py_dyndir       %{py_libdir}/lib-dynload
104 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
105
106 %description
107 RPM is a powerful package manager, which can be used to build,
108 install, query, verify, update, and uninstall individual software
109 packages. A package consists of an archive of files, and package
110 information, including name, version, and description.
111
112 %description -l de
113 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
114 Installation, Anfrage, Verifizierung, Aktualisierung und
115 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
116 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
117 Beschreibung.
118
119 %description -l es
120 RPM es un poderoso administrador de paquetes, que puede ser usado para
121 construir, instalar, pesquisar, verificar, actualizar y desinstalar
122 paquetes individuales de software. Un paquete consiste en un
123 almacenaje de archivos, y información sobre el paquete, incluyendo
124 nombre, versión y descripción.
125
126 %description -l pl
127 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
128 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
129 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
130 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
131 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
132 odpytywania programu rpm.
133
134 %description -l pt_BR
135 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
136 construir, instalar, pesquisar, verificar, atualizar e desinstalar
137 pacotes individuais de software. Um pacote consiste de um conjunto de
138 arquivos e informações adicionais, incluindo nome, versão e descrição
139 do pacote, permissões dos arquivos, etc.
140
141 %package devel
142 Summary:        Header files and libraries
143 Summary(de):    Header-Dateien uns Libraries
144 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
145 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
146 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
147 Group:          Development/Libraries
148 Requires:       %{name} = %{version}
149 Requires:       popt-devel
150
151 %description devel
152 The RPM packaging system includes a C library that makes it easy to
153 manipulate RPM packages and databases. It is intended to ease the
154 creation of graphical package managers and other tools that need
155 intimate knowledge of RPM packages.
156
157 %description devel -l de
158 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
159 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
160 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
161 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
162
163 %description devel -l es
164 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
165 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
166 facilitar la creación de administradores gráficos de paquetes y otras
167 herramientas que necesiten un conocimiento profundo de paquetes RPM.
168
169 %description devel -l pl
170 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
171 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
172 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
173 szczegó³owej wiedzy na temat pakietów RPM.
174
175 %description devel -l pt_BR
176 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
177 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
178 facilitar a criação de gerenciadores gráficos de pacotes e outras
179 ferramentas que precisem de conhecimento profundo de pacotes RPM.
180
181 %package static
182 Summary:        RPM static libraries
183 Summary(de):    RPMs statische Libraries
184 Summary(pl):    Biblioteki statyczne RPM-a
185 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
186 Group:          Development/Libraries
187 Requires:       %{name}-devel = %{version}
188
189 %description static
190 RPM static libraries.
191
192 %description static -l de
193 RPMs statische Libraries.
194
195 %description static -l pl
196 Biblioteki statyczne RPM-a.
197
198 %description static -l pt_BR
199 Bibliotecas estáticas para desenvolvimento.
200
201 %package utils
202 Summary:        Additional utilities for managing rpm packages and database
203 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
204 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
205 Group:          Applications/File
206 Requires:       %{name} = %{version}
207
208 %description utils
209 Additional utilities for managing rpm packages and database.
210
211 %description utils -l de
212 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
213
214 %description utils -l pl
215 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
216
217 %package perlprov
218 Summary:        Additional utilities for checking perl provides/requires in rpm packages
219 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
220 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
221 Group:          Applications/File
222 Requires:       %{name} = %{version}
223 Requires:       perl-modules
224 Requires:       findutils
225
226 %description perlprov
227 Additional utilities for checking perl provides/requires in rpm
228 packages.
229
230 %description perlprov -l de
231 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
232
233 %description perlprov -l pl
234 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
235 pakietach rpm.
236
237 %package pythonprov
238 Summary:        Python macros, which simplifies creation of rpm packages with Python software
239 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
240 Group:          Applications/File
241 Requires:       %{name} = %{version}
242 Requires:       python-modules
243
244 %description pythonprov
245 Python macros, which simplifies creation of rpm packages with Python
246 software.
247
248 %description pythonprov -l pl
249 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
250 Pythonie.
251
252 %package -n python-rpm
253 Summary:        Python interface to RPM library
254 Summary(pl):    Pythonowy interfejs do biblioteki RPM-a
255 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
256 Group:          Libraries/Python
257 Requires:       %{name} = %{version}
258 %pyrequires_eq  python
259 Obsoletes:      rpm-python
260
261 %description -n python-rpm
262 The rpm-python package contains a module which permits applications
263 written in the Python programming language to use the interface
264 supplied by RPM (RPM Package Manager) libraries.
265
266 This package should be installed if you want to develop Python
267 programs that will manipulate RPM packages and databases.
268
269 %description -n python-rpm -l pl
270 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
271 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
272
273 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
274 Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
275
276 %description -n python-rpm -l pt_BR
277 O pacote rpm-python contém um módulo que permite que aplicações
278 escritas em Python utilizem a interface fornecida pelas bibliotecas
279 RPM (RPM Package Manager).
280
281 Esse pacote deve ser instalado se você quiser desenvolver programas em
282 Python para manipular pacotes e bancos de dados RPM.
283
284 %package build
285 Summary:        Scripts for building binary RPM packages
286 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
287 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
288 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
289 Group:          Applications/File
290 Requires:       %{name} = %{version}
291 Requires:       /bin/id
292 Requires:       awk
293 Requires:       binutils
294 Requires:       diffutils
295 Requires:       file >= 3.31
296 Requires:       fileutils
297 Requires:       findutils
298 %ifarch athlon
299 Requires:       gcc >= 3.0.3
300 %else
301 Requires:       gcc
302 %endif
303 Requires:       glibc-devel
304 Requires:       grep
305 Requires:       gzip
306 Requires:       make
307 Requires:       patch
308 Requires:       popt >= 1.6.2-2
309 Requires:       sed
310 Requires:       sh-utils
311 Requires:       tar
312 Requires:       textutils
313
314 %description build
315 Scripts for building binary RPM packages.
316
317 %description build -l de
318 Scripts fürs Bauen binärer RPM-Pakete.
319
320 %description build -l pl
321 Skrypty pomocnicze do budowania binarnych RPM-ów.
322
323 %description build -l pt_BR
324 Este pacote contém scripts e programas executáveis que são usados para
325 construir pacotes usando o RPM.
326
327 %prep
328 %setup -q -a12
329 %patch0 -p1
330 %patch1 -p1
331 %patch2 -p1
332 %patch3 -p1
333 %patch4 -p1
334 %patch5 -p1
335 %patch6 -p1
336 %patch7 -p1
337 %patch8 -p1
338 %patch9 -p1
339 %patch10 -p1
340 %patch11 -p0
341 %patch12 -p0
342 %patch13 -p1
343 %patch14 -p1
344 %patch15 -p0
345 %patch16 -p0
346 %patch17 -p1
347 %patch18 -p1
348 %patch19 -p1
349 %patch20 -p1
350 %patch21 -p1
351 %patch22 -p1
352 %patch23 -p1
353 %patch24 -p1
354 %patch25 -p1
355 %patch26 -p0
356 %patch27 -p1
357 %patch28 -p1
358 %patch29 -p1
359 %patch30 -p1
360
361 %ifarch athlon
362 %patch31 -p1
363 %endif
364
365 %patch32 -p1
366 %patch33 -p1
367 %patch34 -p1
368 %patch35 -p1
369 %patch36 -p1
370 %patch37 -p1
371 %patch38 -p1
372 %patch39 -p1
373 %patch40 -p1
374
375 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
376 cp -f platform.in macros.pld.in
377 install %{SOURCE5} macros.perl.in
378 install %{SOURCE13} macros.python.in
379 install %{SOURCE6} scripts/find-perl-provides
380 install %{SOURCE7} scripts/find-perl-requires
381 install %{SOURCE9} scripts/find-lang.sh
382
383 (cd scripts;
384 mv -f perl.req perl.req.in
385 mv -f perl.prov perl.prov.in)
386
387 chmod +x %{SOURCE4}
388
389 %build
390 # generate Group translations to *.po
391 awk -f %{SOURCE14} %{SOURCE1}
392
393 cd popt
394 rm -f missing
395 libtoolize --force --copy
396 aclocal
397 autoheader
398 %{__autoconf}
399 %{__automake}
400 cd ..
401
402 rm -f missing
403 libtoolize --force --copy
404 gettextize --copy --force
405 aclocal
406 autoupdate
407 autoheader || :
408 %{__autoconf}
409 # ugly workaround for automake
410 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
411         lib/Makefile.am > lib/Makefile.am.new
412 mv -f lib/Makefile.am.new lib/Makefile.am
413 %{__automake}
414 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
415         lib/Makefile.in > lib/Makefile.in.new
416 mv -f lib/Makefile.in.new lib/Makefile.in
417
418 sed -e 's#python1.5#python%{py_ver}#g' \
419         python/Makefile.in > python/Makefile.in.new
420 mv -f python/Makefile.in.new python/Makefile.in
421
422 # config.guess doesn't handle athlon, so we have to change it by hand.
423 # rpm checks for CPU type at runtime, but it looks better
424 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
425         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
426 mv -f macros.tmp macros.in
427
428 %configure \
429         --enable-shared \
430         --enable-v1-packages \
431         --with-python
432
433
434 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
435
436 %install
437 rm -rf $RPM_BUILD_ROOT
438
439 %{__make} install \
440         DESTDIR=$RPM_BUILD_ROOT \
441         pkgbindir="%{_bindir}"
442
443 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
444 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
445
446 install %{SOURCE1} doc/manual/groups
447 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
448 install %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/rpm/find-rpm-provides
449 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
450 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
451 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
452 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
453 install %{SOURCE16} $RPM_BUILD_ROOT%{_libdir}/rpm/check-files
454
455 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
456
457 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
458 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
459 # customized rpm macros - global for host
460 #
461 #%%_install_langs pl_PL:en_US
462 %%distribution PLD
463 EOF
464
465 %find_lang %{name}
466
467 %clean
468 rm -rf $RPM_BUILD_ROOT
469
470 %post   -p /sbin/ldconfig
471 %postun -p /sbin/ldconfig
472
473 %files -f %{name}.lang
474 %defattr(644,root,root,755)
475 %doc RPM-PGP-KEY CHANGES doc/manual/[a-z]*
476
477 %attr(755,root,root) /bin/rpm
478 %attr(755,root,root) %{_bindir}/rpmdb
479 %attr(755,root,root) %{_bindir}/rpmquery
480 %attr(755,root,root) %{_bindir}/rpmsign
481 %attr(755,root,root) %{_bindir}/rpmverify
482 %attr(755,root,root) %{_libdir}/rpm/rpmdb
483 %attr(755,root,root) %{_libdir}/rpm/rpmq
484 %attr(755,root,root) %{_libdir}/rpm/rpmk
485 %attr(755,root,root) %{_libdir}/rpm/rpmv
486 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
487
488 %dir %{_sysconfdir}/rpm
489 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
490
491 %{_mandir}/man8/rpm.8*
492 %lang(fr) %{_mandir}/fr/man8/rpm.8*
493 %lang(ja) %{_mandir}/ja/man8/rpm.8*
494 %lang(ko) %{_mandir}/ko/man8/rpm.8*
495 %lang(pl) %{_mandir}/pl/man8/rpm.8*
496 %lang(ru) %{_mandir}/ru/man8/rpm.8*
497 %lang(sk) %{_mandir}/sk/man8/rpm.8*
498
499 %dir /var/lib/rpm
500 %dir %{_libdir}/rpm
501
502 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
503
504 %{_libdir}/rpm/rpmrc
505 %{_libdir}/rpm/rpmpopt*
506 %{_libdir}/rpm/macros
507 %{_libdir}/rpm/noarch-linux
508 %{_libdir}/rpm/noarch-pld-linux
509 %ifarch i386 i486 i586 i686 athlon
510 %{_libdir}/rpm/i?86*
511 %{_libdir}/rpm/athlon*
512 %endif
513 %ifarch sparc sparc64
514 %{_libdir}/rpm/sparc*
515 %endif
516 %ifarch alpha
517 %{_libdir}/rpm/alpha*
518 %endif
519 %ifarch ppc
520 %{_libdir}/rpm/ppc*
521 %endif
522
523
524 %files build
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{_bindir}/rpmbuild
527 %attr(755,root,root) %{_bindir}/rpme
528 %attr(755,root,root) %{_bindir}/rpmi
529 %attr(755,root,root) %{_bindir}/rpmu
530 %attr(755,root,root) %{_libdir}/rpm/find-requires
531 %attr(755,root,root) %{_libdir}/rpm/find-provides
532 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
533 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
534 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
535 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
536 %attr(755,root,root) %{_libdir}/rpm/config.*
537 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
538 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
539 %attr(755,root,root) %{_libdir}/rpm/brp-*
540 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
541 %attr(755,root,root) %{_libdir}/rpm/check-files
542 %attr(755,root,root) %{_libdir}/rpm/compress-doc
543 %attr(755,root,root) %{_libdir}/rpm/cpanflute
544 %attr(755,root,root) %{_libdir}/rpm/http.req
545 %attr(755,root,root) %{_libdir}/rpm/magic.*
546 %attr(755,root,root) %{_libdir}/rpm/rpmdiff*
547 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
548 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
549 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
550 %attr(755,root,root) %{_libdir}/rpm/rpmb
551 %attr(755,root,root) %{_libdir}/rpm/rpmi
552 %attr(755,root,root) %{_libdir}/rpm/rpmt
553 %attr(755,root,root) %{_libdir}/rpm/rpme
554 %attr(755,root,root) %{_libdir}/rpm/rpmu
555
556 %files devel
557 %defattr(644,root,root,755)
558 %{_includedir}/rpm
559 %attr(755,root,root) %{_libdir}/librpm*.la
560 %attr(755,root,root) %{_libdir}/librpm*.so
561
562 %files static
563 %defattr(644,root,root,755)
564 %{_libdir}/librpm*.a
565
566 %files utils
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_bindir}/gendiff
569 %attr(755,root,root) %{_bindir}/javadeps
570 %attr(755,root,root) %{_bindir}/rpm2cpio
571
572 %{_mandir}/man8/rpm2cpio.8*
573 %{_mandir}/man1/*
574 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
575 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
576 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
577 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
578
579 %files perlprov
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_libdir}/rpm/perl*
582 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
583 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
584 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
585 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
586 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
587
588 %{_libdir}/rpm/macros.perl
589
590 %files pythonprov
591 %defattr(644,root,root,755)
592 %{_libdir}/rpm/macros.python
593
594 %files -n python-rpm
595 %defattr(755,root,root,755)
596 %{py_sitedir}/*.so
This page took 0.080918 seconds and 4 git commands to generate.