]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- release 39; should be ok even on alpha
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat (and now also PLD) Package Manager
2 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
3 Summary(pl):    Aplikacja do zarz±dzania pakietami
4 Name:           rpm
5 Version:        4.0.2
6 Release:        39
7 License:        GPL
8 Group:          Base
9 Group(de):      Gründsätzlich
10 Group(es):      Base
11 Group(pl):      Podstawowe
12 Group(pt_BR):   Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.gz
26 Patch0:         %{name}-rpmrc.patch
27 Patch1:         %{name}-macros.patch
28 Patch2:         %{name}-arch.patch
29 Patch3:         %{name}-rpmpopt.patch
30 Patch4:         %{name}-perl-macros.patch
31 Patch5:         %{name}-db3.patch
32 Patch6:         %{name}-segv.patch
33 Patch7:         %{name}-am_fix.patch
34 Patch8:         %{name}-perl-req-perlfile.patch
35 Patch9:         %{name}-installplatform.patch
36 Patch10:        %{name}-cache.patch
37 Patch11:        %{name}-suggestions.patch
38 Patch12:        %{name}-rh-lame.patch
39 Patch13:        %{name}-glob.patch
40 Patch14:        %{name}-header_h.patch
41 Patch15:        %{name}-fast-alAddPackage.patch
42 Patch16:        %{name}-byKey.patch
43 Patch17:        %{name}-perlprov.patch
44 Patch18:        %{name}-noperldir.patch
45 Patch19:        popt-cvs20010530.patch
46 Patch20:        %{name}-noexpand.patch
47 Patch21:        %{name}-scripts-closefds.patch
48 Patch22:        %{name}-python-amfix.patch
49 Patch23:        %{name}-non-english-man-pages.patch
50 Patch24:        %{name}-progress-nontty.patch
51 Patch25:        %{name}-am_ac.patch
52 Patch37:        %{name}-short_circuit.patch
53 Patch38:        %{name}-section_test.patch
54 BuildRequires:  gettext-devel >= 0.10.38-3
55 BuildRequires:  automake
56 BuildRequires:  db3-devel >= 3.1.17-9
57 BuildRequires:  bzip2-devel >= 1.0.1
58 BuildRequires:  zlib-devel
59 BuildRequires:  gettext-devel >= 0.10.38-3
60 BuildRequires:  libtool
61 BuildRequires:  automake
62 BuildRequires:  autoconf >= 2.50
63 BuildRequires:  python-devel
64 BuildRequires:  python-modules >= 2.2.1
65 BuildRequires:  zlib-devel >= 1.1.4
66 # Require static library only for static build
67 BuildRequires:  db3-static >= 3.1.17-9
68 BuildRequires:  bzip2-static >= 1.0.1
69 BuildRequires:  zlib-static
70 BuildRequires:  glibc-static >= 2.2.0
71 %endif
72 BuildRequires:  zlib-static >= 1.1.4
73 Obsoletes:      rpm-libs
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75 Obsoletes:      rpm-libs
76 %define __find_provides %{SOURCE4}
77 %define _binary_payload w9.gzdio
78 %define         __find_provides %{SOURCE4}
79 %define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
80 %define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
81 %define python_includedir  %{_includedir}/python%{python_version}
82 %define python_libdir      %{python_prefix}/lib/python%{python_version}
83 %define python_sitedir     %{python_libdir}/site-packages
84 %define         py_dyndir       %{py_libdir}/lib-dynload
85 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
86
87 %description
88 RPM is a powerful package manager, which can be used to build,
89 install, query, verify, update, and uninstall individual software
90 packages. A package consists of an archive of files, and package
91 information, including name, version, and description.
92
93 %description -l de
94 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
95 Installation, Anfrage, Verifizierung, Aktualisierung und
96 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
97 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
98 nombre, versión y descripción.
99
100 %description -l pl
101 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
102 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
103 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
104 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
105 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
106 do pacote, permissões dos arquivos, etc.
107
108 %package devel
109 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
110 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
111 Group(de):      Entwicklung/Libraries
112 Group(es):      Desarrollo/Bibliotecas
113 Group(fr):      Development/Librairies
114 Group(pl):      Programowanie/Biblioteki
115 Group(pt_BR):   Desenvolvimento/Bibliotecas
116 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
117 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
118 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
119 Group:          Development/Libraries
120 Requires:       %{name} = %{version}
121 Requires:       popt-devel
122
123 %description devel
124 The RPM packaging system includes a C library that makes it easy to
125 manipulate RPM packages and databases. It is intended to ease the
126 creation of graphical package managers and other tools that need
127 intimate knowledge of RPM packages.
128
129 %description devel -l de
130 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
131 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
132 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
133 herramientas que necesiten un conocimiento profundo de paquetes RPM.
134 Pliki nag³ówkowe i biblioteki statyczne.
135 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
136 ferramentas que precisem de conhecimento profundo de pacotes RPM.
137
138 %package static
139 Summary(pl):    Biblioteki statyczne rpm-a
140 Summary(pl):    Biblioteki statyczne RPM-a
141 Group(de):      Entwicklung/Libraries
142 Group(es):      Desarrollo/Bibliotecas
143 Group(fr):      Development/Librairies
144 Group(pl):      Programowanie/Biblioteki
145 Group(pt_BR):   Desenvolvimento/Bibliotecas
146 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
147 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
148 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
149 Group:          Development/Libraries
150 Requires:       %{name}-devel = %{version}
151
152 %description static
153 RPM static libraries.
154
155 %description static -l de
156 RPMs statische Libraries.
157 Biblioteki statyczne rpm-a.
158 %description static -l pl
159 Bibliotecas estáticas para desenvolvimento.
160
161 %package utils
162 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami
163 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
164 Group(de):      Applikationen/Datei
165 Group(pl):      Aplikacje/Pliki
166 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
167 Group:          Applications/File
168 Requires:       %{name} = %{version}
169
170 %description utils
171 Additional utilities for managing rpm packages and database.
172
173 %description utils -l de
174 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
175 Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami.
176 %description utils -l pl
177 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
178
179 %package perlprov
180 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w pakietach rpm
181 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
182 Group(de):      Applikationen/Datei
183 Group(pl):      Aplikacje/Pliki
184 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
185 Group:          Applications/File
186 Requires:       perl-modules
187 Requires:       findutils
188
189 %description perlprov
190 Additional utilities for checking perl provides/requires in rpm
191 packages.
192
193 %description perlprov -l de
194 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
195 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w
196 %description perlprov -l pl
197 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
198 %package python
199
200 Group:          Development/Languages/Python
201 Group(de):      Entwicklung/Sprachen/Python
202 Group(pl):      Programowanie/Jêzyki/Python
203 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
204 %pyrequires_eq  python
205 %description python
206
207 %description -n python-rpm
208 The rpm-python package contains a module which permits applications
209 written in the Python programming language to use the interface
210 supplied by RPM (RPM Package Manager) libraries.
211
212 This package should be installed if you want to develop Python
213 Python para manipular pacotes e bancos de dados RPM.
214
215 %package build
216 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPMów
217 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
218 Group(de):      Applikationen/Datei
219 Group(pl):      Aplikacje/Pliki
220 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
221 Group:          Applications/File
222 Requires:       sh-utils
223 Requires:       binutils
224 Requires:       patch
225 Requires:       texinfo
226 Requires:       file >= 3.31
227 Requires:       binutils
228 Requires:       make
229 Requires:       gcc >= 3.0.3
230 Requires:       gcc
231 Requires:       diffutils
232 Requires:       glibc-devel
233 Requires:       sed
234 Requires:       sed
235 Requires:       popt >= 1.6.2-2
236 Requires:       tar
237 Requires:       textutils
238
239 %description build
240 Scripts for building binary RPM packages.
241
242 %description build -l de
243 Scripts fürs Bauen binärer RPM-Pakete.
244 Skrypty pomocnicze do budowania binarnych RPMów.
245 %description build -l pl
246 construir pacotes usando o RPM.
247
248 %prep
249 %setup -q -a12
250 %patch0 -p1
251 %patch1 -p1
252 %patch2 -p1
253 %patch3 -p1
254 %patch4 -p1
255 %patch5 -p1
256 %patch6 -p1
257 %patch7 -p1
258 %patch8 -p1
259 %patch11 -p0
260 %patch12 -p0
261 %patch11 -p0
262 %patch12 -p0
263 %patch15 -p0
264 %patch16 -p0
265 %patch15 -p0
266 %patch16 -p0
267 %patch17 -p1
268 %patch18 -p1
269 %patch19 -p1
270 %patch22 -p1
271 %patch23 -p1
272 %patch24 -p1
273 %patch25 -p1
274 %patch31 -p1
275 %patch36 -p1
276 %patch37 -p1
277 %patch38 -p1
278 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
279 cp -f platform.in macros.pld.in
280 install %{SOURCE9} scripts/find-lang.sh
281 install %{SOURCE13} macros.python.in
282 install %{SOURCE6} scripts/find-perl-provides
283 install %{SOURCE7} scripts/find-perl-requires
284 install %{SOURCE9} scripts/find-lang.sh
285
286 (cd scripts;
287 mv -f perl.req perl.req.in
288 mv -f perl.prov perl.prov.in)
289 %build
290 awk -f %{SOURCE14} %{SOURCE1}
291
292 cd popt
293 autoconf
294 automake -a -c
295 aclocal
296 autoheader
297 %{__automake}
298 cd ..
299
300 rm -f missing
301 libtoolize --force --copy
302 autoconf
303 # ugly workaround for automake
304 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
305         lib/Makefile.am > lib/Makefile.am.new
306 mv -f lib/Makefile.am.new lib/Makefile.am
307 automake -a -c
308 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
309         lib/Makefile.in > lib/Makefile.in.new
310 mv -f lib/Makefile.in.new lib/Makefile.in
311
312 sed -e 's#python1.5#python%{python_version}#g' \
313         python/Makefile.in > python/Makefile.in.new
314 mv -f python/Makefile.in.new python/Makefile.in
315
316 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
317         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
318         --enable-v1-packages \
319         --with-python
320 %configure \
321         --enable-v1-packages \
322         --with-python
323
324
325 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
326
327         DESTDIR="$RPM_BUILD_ROOT" \
328 rm -rf $RPM_BUILD_ROOT
329
330 %{__make} install \
331         pkgbindir="%{_bindir}"
332
333 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
334 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
335
336 install %{SOURCE1} doc/manual/groups
337 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
338 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
339 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
340 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
341 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
342
343 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
344
345 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
346 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
347 # customized rpm macros - global for host
348 #
349 #%%_install_langs pl_PL:en_US
350 %%distribution PLD
351 EOF
352
353 %find_lang %{name}
354
355 # DON'T BREAK BUILD TREE!!!
356 # rm -f doc/manual/Makefile*
357
358 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
359
360 %clean
361 rm -rf $RPM_BUILD_ROOT
362
363 %post   -p /sbin/ldconfig
364 %postun -p /sbin/ldconfig
365
366 %attr(755,root,root) %{_libdir}/rpm/rpmdb
367 %attr(755,root,root) %{_libdir}/rpm/rpmq
368 %attr(755,root,root) %{_libdir}/rpm/rpmk
369 %attr(755,root,root) %{_libdir}/rpm/rpmv
370 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
371 %attr(755,root,root) %{_libdir}/rpm/rpmdb
372 %attr(755,root,root) %{_libdir}/rpm/rpmq
373 %attr(755,root,root) %{_libdir}/rpm/rpmk
374 %attr(755,root,root) %{_libdir}/rpm/rpmv
375 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
376
377 %dir %{_sysconfdir}/rpm
378 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
379
380 %{_mandir}/man8/rpm.8*
381 %lang(fr) %{_mandir}/fr/man8/rpm.8*
382 %lang(ja) %{_mandir}/ja/man8/rpm.8*
383 %lang(ko) %{_mandir}/ko/man8/rpm.8*
384 %lang(pl) %{_mandir}/pl/man8/rpm.8*
385 %lang(ru) %{_mandir}/ru/man8/rpm.8*
386 %lang(sk) %{_mandir}/sk/man8/rpm.8*
387
388 %dir /var/lib/rpm
389 %dir %{_libdir}/rpm
390
391 %{_libdir}/rpm/noarch-linux
392 %{_libdir}/rpm/noarch-pld-linux
393 %ifarch i386 i486 i586 i686
394 %{_libdir}/rpm/rpmpopt*
395 %{_libdir}/rpm/noarch-linux
396 %{_libdir}/rpm/noarch-pld-linux
397 %ifarch i386 i486 i586 i686 athlon
398 %{_libdir}/rpm/i?86*
399 %{_libdir}/rpm/athlon*
400 %endif
401 %ifarch sparc sparc64
402 %endif
403 %ifarch ppc
404 %{_libdir}/rpm/ppc*
405 %defattr(644,root,root,755)
406 %attr(755,root,root) %{_bindir}/rpmbuild
407 %attr(755,root,root) %{_bindir}/rpme
408 %attr(755,root,root) %{_bindir}/rpmi
409 %attr(755,root,root) %{_bindir}/rpmu
410 %attr(755,root,root) %{_libdir}/rpm/find-requires
411 %attr(755,root,root) %{_libdir}/rpm/find-provides
412 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
413 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
414 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
415 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
416 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
417 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
418 %attr(755,root,root) %{_libdir}/rpm/brp-*
419 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
420 %attr(755,root,root) %{_libdir}/rpm/compress-doc
421 %attr(755,root,root) %{_libdir}/rpm/cpanflute
422 %attr(755,root,root) %{_libdir}/rpm/http.req
423 %attr(755,root,root) %{_libdir}/rpm/magic.*
424 %attr(755,root,root) %{_libdir}/rpm/rpmi
425 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
426 %attr(755,root,root) %{_libdir}/rpm/rpme
427 %attr(755,root,root) %{_libdir}/rpm/rpmu
428 %attr(755,root,root) %{_libdir}/rpm/rpmb
429 %attr(755,root,root) %{_libdir}/rpm/rpmi
430 %attr(755,root,root) %{_libdir}/rpm/rpmt
431 %attr(755,root,root) %{_libdir}/rpm/rpme
432 %attr(755,root,root) %{_libdir}/librpm*.la
433 %attr(755,root,root) %{_libdir}/librpm*.so
434 %files devel
435 %defattr(644,root,root,755)
436 %{_includedir}/rpm
437 %attr(755,root,root) %{_libdir}/librpm*.la
438 %attr(755,root,root) %{_libdir}/librpm*.so
439
440 %files static
441 %attr(755,root,root) %{_bindir}/*
442 %files utils
443 %defattr(644,root,root,755)
444 %{_mandir}/man1/*
445 %attr(755,root,root) %{_bindir}/javadeps
446 %attr(755,root,root) %{_bindir}/rpm2cpio
447
448 %{_mandir}/man8/rpm2cpio.8*
449 %{_mandir}/man1/*
450 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
451 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
452 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
453 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
454
455 %files perlprov
456 %defattr(644,root,root,755)
457 %attr(755,root,root) %{_libdir}/rpm/perl*
458 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
459 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
460 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
461 %files python
462 %defattr(644,root,root,755)
463 %{python_sitedir}/*.so
464 %{_libdir}/rpm/macros.python
465
466 %files -n python-rpm
467 * %{date} PLD Team <pld-list@pld.org.pl>
468 %{py_sitedir}/*.so
This page took 0.076842 seconds and 4 git commands to generate.