]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- rel 69
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        RPM Package Manager
4 Summary(de):    RPM Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami RPM
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        69
11 License:        GPL
12 Group:          Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Source14:       %{name}-groups-po.awk
28 Source15:       %{name}-compress-doc
29 Patch0:         %{name}-rpmrc.patch
30 Patch1:         %{name}-macros.patch
31 Patch2:         %{name}-arch.patch
32 Patch3:         %{name}-rpmpopt.patch
33 Patch4:         %{name}-perl-macros.patch
34 Patch5:         %{name}-db3.patch
35 Patch6:         %{name}-segv.patch
36 Patch7:         %{name}-am_fix.patch
37 Patch8:         %{name}-perl-req-perlfile.patch
38 Patch9:         %{name}-installplatform.patch
39 Patch10:        %{name}-cache.patch
40 Patch11:        %{name}-suggestions.patch
41 Patch12:        %{name}-rh-lame.patch
42 Patch13:        %{name}-glob.patch
43 Patch14:        %{name}-header_h.patch
44 Patch15:        %{name}-fast-alAddPackage.patch
45 Patch16:        %{name}-byKey.patch
46 Patch17:        %{name}-perlprov.patch
47 Patch18:        %{name}-noperldir.patch
48 Patch19:        popt-cvs20010530.patch
49 Patch20:        %{name}-noexpand.patch
50 Patch21:        %{name}-scripts-closefds.patch
51 Patch22:        %{name}-python-amfix.patch
52 Patch23:        %{name}-non-english-man-pages.patch
53 Patch24:        %{name}-progress-nontty.patch
54 Patch25:        %{name}-am_ac.patch
55 Patch26:        %{name}-python-macros.patch
56 Patch27:        %{name}-hardlink-fixes.patch
57 Patch28:        %{name}-perlprov-regonly.patch
58 Patch29:        %{name}-cxx.patch
59 Patch30:        %{name}-athlon.patch
60 Patch31:        %{name}-athlon-identify.patch
61 Patch32:        %{name}-gettext-in-header.patch
62 Patch33:        %{name}-perlprov-perl5.6.patch
63 Patch34:        %{name}-ac25x.patch
64 Patch35:        %{name}-signverify-fix.patch
65 Patch36:        %{name}-compress-doc.patch
66 Patch37:        %{name}-short_circuit.patch
67 Patch38:        %{name}-section_test.patch
68 URL:            http://www.rpm.org/
69 Icon:           rpm.gif
70 BuildRequires:  autoconf >= 2.50
71 BuildRequires:  automake
72 BuildRequires:  bzip2-devel >= 1.0.1
73 BuildRequires:  db1-devel >= 1.85
74 BuildRequires:  db3-devel >= 3.1.17-9
75 BuildRequires:  gettext-devel >= 0.10.38-3
76 BuildRequires:  libtool
77 BuildRequires:  patch >= 2.2
78 BuildRequires:  python-devel >= 2.2.1
79 BuildRequires:  python-modules >= 2.2.1
80 BuildRequires:  zlib-devel >= 1.1.4
81 %if %{!?_without_static:1}%{?_without_static:0}
82 # Require static library only for static build
83 BuildRequires:  bzip2-static >= 1.0.1
84 BuildRequires:  db1-static >= 1.85
85 BuildRequires:  db3-static >= 3.1.17-9
86 BuildRequires:  glibc-static >= 2.2.0
87 BuildRequires:  zlib-static >= 1.1.4
88 %endif
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90 Obsoletes:      rpm-libs
91 Conflicts:      glibc < 2.2
92
93 %define         __find_provides %{SOURCE4}
94 %define         _binary_payload w9.gzdio
95
96 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
97 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
98 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
99 %define         py_sitedir      %{py_libdir}/site-packages
100 %define         py_dyndir       %{py_libdir}/lib-dynload
101 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
102
103 %description
104 RPM is a powerful package manager, which can be used to build,
105 install, query, verify, update, and uninstall individual software
106 packages. A package consists of an archive of files, and package
107 information, including name, version, and description.
108
109 %description -l de
110 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
111 Installation, Anfrage, Verifizierung, Aktualisierung und
112 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
113 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
114 Beschreibung.
115
116 %description -l es
117 RPM es un poderoso administrador de paquetes, que puede ser usado para
118 construir, instalar, pesquisar, verificar, actualizar y desinstalar
119 paquetes individuales de software. Un paquete consiste en un
120 almacenaje de archivos, y información sobre el paquete, incluyendo
121 nombre, versión y descripción.
122
123 %description -l pl
124 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
125 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
126 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
127 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
128 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
129 odpytywania programu rpm.
130
131 %description -l pt_BR
132 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
133 construir, instalar, pesquisar, verificar, atualizar e desinstalar
134 pacotes individuais de software. Um pacote consiste de um conjunto de
135 arquivos e informações adicionais, incluindo nome, versão e descrição
136 do pacote, permissões dos arquivos, etc.
137
138 %package devel
139 Summary:        Header files and libraries
140 Summary(de):    Header-Dateien uns Libraries
141 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
142 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
143 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
144 Group:          Development/Libraries
145 Requires:       %{name} = %{version}
146 Requires:       popt-devel
147
148 %description devel
149 The RPM packaging system includes a C library that makes it easy to
150 manipulate RPM packages and databases. It is intended to ease the
151 creation of graphical package managers and other tools that need
152 intimate knowledge of RPM packages.
153
154 %description devel -l de
155 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
156 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
157 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
158 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
159
160 %description devel -l es
161 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
162 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
163 facilitar la creación de administradores gráficos de paquetes y otras
164 herramientas que necesiten un conocimiento profundo de paquetes RPM.
165
166 %description devel -l pl
167 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
168 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
169 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
170 szczegó³owej wiedzy na temat pakietów RPM.
171
172 %description devel -l pt_BR
173 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
174 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
175 facilitar a criação de gerenciadores gráficos de pacotes e outras
176 ferramentas que precisem de conhecimento profundo de pacotes RPM.
177
178 %package static
179 Summary:        RPM static libraries
180 Summary(de):    RPMs statische Libraries
181 Summary(pl):    Biblioteki statyczne RPM-a
182 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
183 Group:          Development/Libraries
184 Requires:       %{name}-devel = %{version}
185
186 %description static
187 RPM static libraries.
188
189 %description static -l de
190 RPMs statische Libraries.
191
192 %description static -l pl
193 Biblioteki statyczne RPM-a.
194
195 %description static -l pt_BR
196 Bibliotecas estáticas para desenvolvimento.
197
198 %package utils
199 Summary:        Additional utilities for managing rpm packages and database
200 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
201 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
202 Group:          Applications/File
203 Requires:       %{name} = %{version}
204
205 %description utils
206 Additional utilities for managing rpm packages and database.
207
208 %description utils -l de
209 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
210
211 %description utils -l pl
212 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
213
214 %package perlprov
215 Summary:        Additional utilities for checking perl provides/requires in rpm packages
216 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
217 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
218 Group:          Applications/File
219 Requires:       %{name} = %{version}
220 Requires:       perl-modules
221 Requires:       findutils
222
223 %description perlprov
224 Additional utilities for checking perl provides/requires in rpm
225 packages.
226
227 %description perlprov -l de
228 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
229
230 %description perlprov -l pl
231 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
232 pakietach rpm.
233
234 %package pythonprov
235 Summary:        Python macros, which simplifies creation of rpm packages with Python software
236 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
237 Group:          Applications/File
238 Requires:       %{name} = %{version}
239 Requires:       python-modules
240
241 %description pythonprov
242 Python macros, which simplifies creation of rpm packages with Python
243 software.
244
245 %description pythonprov -l pl
246 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
247 Pythonie.
248
249 %package -n python-rpm
250 Summary:        Python interface to RPM library
251 Summary(pl):    Pythonowy interfejs do biblioteki RPM-a
252 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
253 Group:          Libraries/Python
254 Requires:       %{name} = %{version}
255 %pyrequires_eq  python
256 Obsoletes:      rpm-python
257
258 %description -n python-rpm
259 The rpm-python package contains a module which permits applications
260 written in the Python programming language to use the interface
261 supplied by RPM (RPM Package Manager) libraries.
262
263 This package should be installed if you want to develop Python
264 programs that will manipulate RPM packages and databases.
265
266 %description -n python-rpm -l pl
267 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
268 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
269
270 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
271 Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
272
273 %description -n python-rpm -l pt_BR
274 O pacote rpm-python contém um módulo que permite que aplicações
275 escritas em Python utilizem a interface fornecida pelas bibliotecas
276 RPM (RPM Package Manager).
277
278 Esse pacote deve ser instalado se você quiser desenvolver programas em
279 Python para manipular pacotes e bancos de dados RPM.
280
281 %package build
282 Summary:        Scripts for building binary RPM packages
283 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
284 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
285 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
286 Group:          Applications/File
287 Requires:       %{name} = %{version}
288 Requires:       /bin/id
289 Requires:       awk
290 Requires:       binutils
291 Requires:       diffutils
292 Requires:       file >= 3.31
293 Requires:       fileutils
294 Requires:       findutils
295 %ifarch athlon
296 Requires:       gcc >= 3.0.3
297 %else
298 Requires:       gcc
299 %endif
300 Requires:       glibc-devel
301 Requires:       grep
302 Requires:       gzip
303 Requires:       make
304 Requires:       patch
305 Requires:       popt >= 1.6.2-2
306 Requires:       sed
307 Requires:       sh-utils
308 Requires:       tar
309 Requires:       textutils
310
311 %description build
312 Scripts for building binary RPM packages.
313
314 %description build -l de
315 Scripts fürs Bauen binärer RPM-Pakete.
316
317 %description build -l pl
318 Skrypty pomocnicze do budowania binarnych RPM-ów.
319
320 %description build -l pt_BR
321 Este pacote contém scripts e programas executáveis que são usados para
322 construir pacotes usando o RPM.
323
324 %prep
325 %setup -q -a12
326 %patch0 -p1
327 %patch1 -p1
328 %patch2 -p1
329 %patch3 -p1
330 %patch4 -p1
331 %patch5 -p1
332 %patch6 -p1
333 %patch7 -p1
334 %patch8 -p1
335 %patch9 -p1
336 %patch10 -p1
337 %patch11 -p0
338 %patch12 -p0
339 %patch13 -p1
340 %patch14 -p1
341 %patch15 -p0
342 %patch16 -p0
343 %patch17 -p1
344 %patch18 -p1
345 %patch19 -p1
346 %patch20 -p1
347 %patch21 -p1
348 %patch22 -p1
349 %patch23 -p1
350 %patch24 -p1
351 %patch25 -p1
352 %patch26 -p0
353 %patch27 -p1
354 %patch28 -p1
355 %patch29 -p1
356 %patch30 -p1
357
358 %ifarch athlon
359 %patch31 -p1
360 %endif
361
362 %patch32 -p1
363 %patch33 -p1
364 %patch34 -p1
365 %patch35 -p1
366 %patch36 -p1
367 %patch37 -p1
368 %patch38 -p1
369
370 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
371 cp -f platform.in macros.pld.in
372 install %{SOURCE5} macros.perl.in
373 install %{SOURCE13} macros.python.in
374 install %{SOURCE6} scripts/find-perl-provides
375 install %{SOURCE7} scripts/find-perl-requires
376 install %{SOURCE9} scripts/find-lang.sh
377
378 (cd scripts;
379 mv -f perl.req perl.req.in
380 mv -f perl.prov perl.prov.in)
381
382 chmod +x %{SOURCE4}
383
384 %build
385 # generate Group translations to *.po
386 awk -f %{SOURCE14} %{SOURCE1}
387
388 cd popt
389 autoconf
390 automake -a -c -f
391 aclocal
392 autoheader
393 automake -a -c -f
394 %{__automake}
395 cd ..
396
397 rm -f missing
398 libtoolize --force --copy
399 autoconf
400 aclocal
401 autoupdate
402 autoheader || :
403 %{__autoconf}
404 automake -a -c -f
405 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
406         lib/Makefile.am > lib/Makefile.am.new
407 mv -f lib/Makefile.am.new lib/Makefile.am
408 %{__automake}
409 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
410         lib/Makefile.in > lib/Makefile.in.new
411 mv -f lib/Makefile.in.new lib/Makefile.in
412
413 sed -e 's#python1.5#python%{py_ver}#g' \
414         python/Makefile.in > python/Makefile.in.new
415 mv -f python/Makefile.in.new python/Makefile.in
416
417 # config.guess doesn't handle athlon, so we have to change it by hand.
418 # rpm checks for CPU type at runtime, but it looks better
419 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
420         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
421 mv -f macros.tmp macros.in
422
423 %configure \
424         --enable-shared \
425         --enable-v1-packages \
426         --with-python
427
428
429 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
430
431 %install
432 rm -rf $RPM_BUILD_ROOT
433
434 %{__make} install \
435         DESTDIR=$RPM_BUILD_ROOT \
436         pkgbindir="%{_bindir}"
437
438 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
439 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
440
441 install %{SOURCE1} doc/manual/groups
442 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
443 install %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/rpm/find-rpm-provides
444 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
445 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
446 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
447 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
448
449 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
450
451 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
452 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
453 # customized rpm macros - global for host
454 #
455 #%%_install_langs pl_PL:en_US
456 %%distribution PLD
457 EOF
458
459 %find_lang %{name}
460
461 # DON'T BREAK BUILD TREE!!!
462 # rm -f doc/manual/Makefile*
463
464 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
465
466 %clean
467 rm -rf $RPM_BUILD_ROOT
468
469 %post   -p /sbin/ldconfig
470 %postun -p /sbin/ldconfig
471
472 %files -f %{name}.lang
473 %defattr(644,root,root,755)
474 %doc RPM-PGP-KEY.gz CHANGES.gz doc/manual/*
475
476 %attr(755,root,root) /bin/rpm
477 %attr(755,root,root) %{_bindir}/rpmdb
478 %attr(755,root,root) %{_bindir}/rpmquery
479 %attr(755,root,root) %{_bindir}/rpmsign
480 %attr(755,root,root) %{_bindir}/rpmverify
481 %attr(755,root,root) %{_libdir}/rpm/rpmdb
482 %attr(755,root,root) %{_libdir}/rpm/rpmq
483 %attr(755,root,root) %{_libdir}/rpm/rpmk
484 %attr(755,root,root) %{_libdir}/rpm/rpmv
485 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
486
487 %dir %{_sysconfdir}/rpm
488 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
489
490 %{_mandir}/man8/rpm.8*
491 %lang(fr) %{_mandir}/fr/man8/rpm.8*
492 %lang(ja) %{_mandir}/ja/man8/rpm.8*
493 %lang(ko) %{_mandir}/ko/man8/rpm.8*
494 %lang(pl) %{_mandir}/pl/man8/rpm.8*
495 %lang(ru) %{_mandir}/ru/man8/rpm.8*
496 %lang(sk) %{_mandir}/sk/man8/rpm.8*
497
498 %dir /var/lib/rpm
499 %dir %{_libdir}/rpm
500
501 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
502
503 %{_libdir}/rpm/rpmrc
504 %{_libdir}/rpm/rpmpopt*
505 %{_libdir}/rpm/macros
506 %{_libdir}/rpm/noarch-linux
507 %{_libdir}/rpm/noarch-pld-linux
508 %ifarch i386 i486 i586 i686 athlon
509 %{_libdir}/rpm/i?86*
510 %{_libdir}/rpm/athlon*
511 %endif
512 %ifarch sparc sparc64
513 %{_libdir}/rpm/sparc*
514 %endif
515 %ifarch alpha
516 %{_libdir}/rpm/alpha*
517 %endif
518 %ifarch ppc
519 %{_libdir}/rpm/ppc*
520 %endif
521
522
523 %files build
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_bindir}/rpmbuild
526 %attr(755,root,root) %{_bindir}/rpme
527 %attr(755,root,root) %{_bindir}/rpmi
528 %attr(755,root,root) %{_bindir}/rpmu
529 %attr(755,root,root) %{_libdir}/rpm/find-requires
530 %attr(755,root,root) %{_libdir}/rpm/find-provides
531 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
532 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
533 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
534 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
535 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
536 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
537 %attr(755,root,root) %{_libdir}/rpm/brp-*
538 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
539 %attr(755,root,root) %{_libdir}/rpm/compress-doc
540 %attr(755,root,root) %{_libdir}/rpm/cpanflute
541 %attr(755,root,root) %{_libdir}/rpm/http.req
542 %attr(755,root,root) %{_libdir}/rpm/magic.*
543 %attr(755,root,root) %{_libdir}/rpm/rpmdiff*
544 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
545 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
546 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
547 %attr(755,root,root) %{_libdir}/rpm/rpmb
548 %attr(755,root,root) %{_libdir}/rpm/rpmi
549 %attr(755,root,root) %{_libdir}/rpm/rpmt
550 %attr(755,root,root) %{_libdir}/rpm/rpme
551 %attr(755,root,root) %{_libdir}/rpm/rpmu
552
553 %files devel
554 %defattr(644,root,root,755)
555 %{_includedir}/rpm
556 %attr(755,root,root) %{_libdir}/librpm*.la
557 %attr(755,root,root) %{_libdir}/librpm*.so
558
559 %files static
560 %defattr(644,root,root,755)
561 %{_libdir}/librpm*.a
562
563 %files utils
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_bindir}/gendiff
566 %attr(755,root,root) %{_bindir}/javadeps
567 %attr(755,root,root) %{_bindir}/rpm2cpio
568
569 %{_mandir}/man8/rpm2cpio.8*
570 %{_mandir}/man1/*
571 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
572 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
573 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
574 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
575
576 %files perlprov
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_libdir}/rpm/perl*
579 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
580 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
581 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
582 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
583 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
584
585 %{_libdir}/rpm/macros.perl
586
587 %files pythonprov
588 %defattr(644,root,root,755)
589 %{_libdir}/rpm/macros.python
590
591 %files -n python-rpm
592 %defattr(755,root,root,755)
593 %{py_sitedir}/*.so
This page took 0.066793 seconds and 4 git commands to generate.