]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- rel 80.
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        RPM Package Manager
4 Summary(de):    RPM Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami RPM
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        80
11 License:        GPL
12 Group:          Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Source14:       %{name}-groups-po.awk
28 Source15:       %{name}-compress-doc
29 Source16:       %{name}-check-files
30 Source17:       %{name}-php-provides
31 Source18:       %{name}-php-requires
32 Source19:       %{name}-find-php-provides
33 Source20:       %{name}-find-php-requires
34 Source21:       %{name}-macros.php
35 Patch0:         %{name}-rpmrc.patch
36 Patch1:         %{name}-macros.patch
37 Patch2:         %{name}-arch.patch
38 Patch3:         %{name}-rpmpopt.patch
39 Patch4:         %{name}-perl-macros.patch
40 Patch5:         %{name}-db3.patch
41 Patch6:         %{name}-segv.patch
42 Patch7:         %{name}-am_fix.patch
43 Patch8:         %{name}-perl-req-perlfile.patch
44 Patch9:         %{name}-installplatform.patch
45 Patch10:        %{name}-cache.patch
46 Patch11:        %{name}-suggestions.patch
47 Patch12:        %{name}-rh-lame.patch
48 Patch13:        %{name}-glob.patch
49 Patch14:        %{name}-header_h.patch
50 Patch15:        %{name}-fast-alAddPackage.patch
51 Patch16:        %{name}-byKey.patch
52 Patch17:        %{name}-perlprov.patch
53 Patch18:        %{name}-noperldir.patch
54 Patch19:        popt-cvs20010530.patch
55 Patch20:        %{name}-noexpand.patch
56 Patch21:        %{name}-scripts-closefds.patch
57 Patch22:        %{name}-python-amfix.patch
58 Patch23:        %{name}-non-english-man-pages.patch
59 Patch24:        %{name}-progress-nontty.patch
60 Patch25:        %{name}-am_ac.patch
61 Patch26:        %{name}-python-macros.patch
62 Patch27:        %{name}-hardlink-fixes.patch
63 Patch28:        %{name}-perlprov-regonly.patch
64 Patch29:        %{name}-cxx.patch
65 Patch30:        %{name}-athlon.patch
66 Patch31:        %{name}-athlon-identify.patch
67 Patch32:        %{name}-gettext-in-header.patch
68 Patch33:        %{name}-perlprov-perl5.6.patch
69 Patch34:        %{name}-ac25x.patch
70 Patch35:        %{name}-signverify-fix.patch
71 Patch36:        %{name}-compress-doc.patch
72 Patch37:        %{name}-short_circuit.patch
73 Patch38:        %{name}-test_stage.patch
74 Patch39:        %{name}-exclude.patch
75 Patch40:        %{name}-check_files.patch
76 URL:            http://www.rpm.org/
77 Icon:           rpm.gif
78 BuildRequires:  autoconf >= 2.50
79 BuildRequires:  automake
80 BuildRequires:  bzip2-devel >= 1.0.1
81 BuildRequires:  db1-devel >= 1.85
82 BuildRequires:  db3-devel >= 3.1.17-9
83 BuildRequires:  gettext-devel >= 0.10.38-3
84 BuildRequires:  libtool
85 BuildRequires:  patch >= 2.2
86 BuildRequires:  python-devel >= 2.2.1
87 BuildRequires:  python-modules >= 2.2.1
88 BuildRequires:  zlib-devel >= 1.1.4
89 %if %{!?_without_static:1}%{?_without_static:0}
90 # Require static library only for static build
91 BuildRequires:  bzip2-static >= 1.0.1
92 BuildRequires:  db1-static >= 1.85
93 BuildRequires:  db3-static >= 3.1.17-9
94 BuildRequires:  glibc-static >= 2.2.0
95 BuildRequires:  zlib-static >= 1.1.4
96 %endif
97 Requires:       zlib >= 1.1.4
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99 Obsoletes:      rpm-libs
100 Conflicts:      glibc < 2.2
101
102 %define         __find_provides %{SOURCE4}
103 %define         _binary_payload w9.gzdio
104
105 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
106 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
107 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
108 %define         py_sitedir      %{py_libdir}/site-packages
109 %define         py_dyndir       %{py_libdir}/lib-dynload
110 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
111
112 %description
113 RPM is a powerful package manager, which can be used to build,
114 install, query, verify, update, and uninstall individual software
115 packages. A package consists of an archive of files, and package
116 information, including name, version, and description.
117
118 %description -l de
119 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
120 Installation, Anfrage, Verifizierung, Aktualisierung und
121 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
122 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
123 Beschreibung.
124
125 %description -l es
126 RPM es un poderoso administrador de paquetes, que puede ser usado para
127 construir, instalar, pesquisar, verificar, actualizar y desinstalar
128 paquetes individuales de software. Un paquete consiste en un
129 almacenaje de archivos, y información sobre el paquete, incluyendo
130 nombre, versión y descripción.
131
132 %description -l pl
133 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
134 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
135 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
136 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
137 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
138 odpytywania programu rpm.
139
140 %description -l pt_BR
141 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
142 construir, instalar, pesquisar, verificar, atualizar e desinstalar
143 pacotes individuais de software. Um pacote consiste de um conjunto de
144 arquivos e informações adicionais, incluindo nome, versão e descrição
145 do pacote, permissões dos arquivos, etc.
146
147 %package devel
148 Summary:        Header files and libraries
149 Summary(de):    Header-Dateien uns Libraries
150 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
151 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
152 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
153 Group:          Development/Libraries
154 Requires:       %{name} = %{version}
155 Requires:       popt-devel
156
157 %description devel
158 The RPM packaging system includes a C library that makes it easy to
159 manipulate RPM packages and databases. It is intended to ease the
160 creation of graphical package managers and other tools that need
161 intimate knowledge of RPM packages.
162
163 %description devel -l de
164 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
165 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
166 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
167 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
168
169 %description devel -l es
170 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
171 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
172 facilitar la creación de administradores gráficos de paquetes y otras
173 herramientas que necesiten un conocimiento profundo de paquetes RPM.
174
175 %description devel -l pl
176 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
177 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
178 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
179 szczegó³owej wiedzy na temat pakietów RPM.
180
181 %description devel -l pt_BR
182 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
183 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
184 facilitar a criação de gerenciadores gráficos de pacotes e outras
185 ferramentas que precisem de conhecimento profundo de pacotes RPM.
186
187 %package static
188 Summary:        RPM static libraries
189 Summary(de):    RPMs statische Libraries
190 Summary(pl):    Biblioteki statyczne RPM-a
191 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
192 Group:          Development/Libraries
193 Requires:       %{name}-devel = %{version}
194
195 %description static
196 RPM static libraries.
197
198 %description static -l de
199 RPMs statische Libraries.
200
201 %description static -l pl
202 Biblioteki statyczne RPM-a.
203
204 %description static -l pt_BR
205 Bibliotecas estáticas para desenvolvimento.
206
207 %package utils
208 Summary:        Additional utilities for managing rpm packages and database
209 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
210 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
211 Group:          Applications/File
212 Requires:       %{name} = %{version}
213
214 %description utils
215 Additional utilities for managing rpm packages and database.
216
217 %description utils -l de
218 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
219
220 %description utils -l pl
221 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
222
223 %package perlprov
224 Summary:        Additional utilities for checking perl provides/requires in rpm packages
225 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
226 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
227 Group:          Applications/File
228 Requires:       %{name} = %{version}
229 Requires:       perl-modules
230 Requires:       findutils
231
232 %description perlprov
233 Additional utilities for checking perl provides/requires in rpm
234 packages.
235
236 %description perlprov -l de
237 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
238
239 %description perlprov -l pl
240 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
241 pakietach rpm.
242
243 %package pythonprov
244 Summary:        Python macros, which simplifies creation of rpm packages with Python software
245 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
246 Group:          Applications/File
247 Requires:       %{name} = %{version}
248 Requires:       python-modules
249
250 %description pythonprov
251 Python macros, which simplifies creation of rpm packages with Python
252 software.
253
254 %description pythonprov -l pl
255 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
256 Pythonie.
257
258 %package php-pearprov
259 Summary:        Additional utilities for managing rpm packages and database
260 Summary(pl):    Dodatkowe narzêdzia do sprawdzania zale¿no¶ci skryptów php w rpm.
261 Group:          Applications/File
262 Requires:       %{name} = %{version}
263
264 %description php-pearprov
265 Additional utilities for checking php pear provides/requires in rpm
266 packages.
267
268 %description php-pearprov -l pl
269 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów php pear w
270 pakietach rpm.
271
272 %package -n python-rpm
273 Summary:        Python interface to RPM library
274 Summary(pl):    Pythonowy interfejs do biblioteki RPM-a
275 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
276 Group:          Libraries/Python
277 Requires:       %{name} = %{version}
278 %pyrequires_eq  python
279 Obsoletes:      rpm-python
280
281 %description -n python-rpm
282 The rpm-python package contains a module which permits applications
283 written in the Python programming language to use the interface
284 supplied by RPM (RPM Package Manager) libraries.
285
286 This package should be installed if you want to develop Python
287 programs that will manipulate RPM packages and databases.
288
289 %description -n python-rpm -l pl
290 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
291 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
292
293 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
294 Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
295
296 %description -n python-rpm -l pt_BR
297 O pacote rpm-python contém um módulo que permite que aplicações
298 escritas em Python utilizem a interface fornecida pelas bibliotecas
299 RPM (RPM Package Manager).
300
301 Esse pacote deve ser instalado se você quiser desenvolver programas em
302 Python para manipular pacotes e bancos de dados RPM.
303
304 %package build
305 Summary:        Scripts for building binary RPM packages
306 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
307 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
308 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
309 Group:          Applications/File
310 Requires:       %{name} = %{version}
311 Requires:       /bin/id
312 Requires:       awk
313 Requires:       binutils
314 Requires:       diffutils
315 Requires:       file >= 3.31
316 Requires:       fileutils
317 Requires:       findutils
318 %ifarch athlon
319 Requires:       gcc >= 3.0.3
320 %else
321 Requires:       gcc
322 %endif
323 Requires:       glibc-devel
324 Requires:       grep
325 Requires:       gzip
326 Requires:       make
327 Requires:       patch
328 Requires:       popt >= 1.6.2-2
329 Requires:       sed
330 Requires:       sh-utils
331 Requires:       tar
332 Requires:       textutils
333
334 %description build
335 Scripts for building binary RPM packages.
336
337 %description build -l de
338 Scripts fürs Bauen binärer RPM-Pakete.
339
340 %description build -l pl
341 Skrypty pomocnicze do budowania binarnych RPM-ów.
342
343 %description build -l pt_BR
344 Este pacote contém scripts e programas executáveis que são usados para
345 construir pacotes usando o RPM.
346
347 %prep
348 %setup -q -a12
349 %patch0 -p1
350 %patch1 -p1
351 %patch2 -p1
352 %patch3 -p1
353 %patch4 -p1
354 %patch5 -p1
355 %patch6 -p1
356 %patch7 -p1
357 %patch8 -p1
358 %patch9 -p1
359 %patch10 -p1
360 %patch11 -p0
361 %patch12 -p0
362 %patch13 -p1
363 %patch14 -p1
364 %patch15 -p0
365 %patch16 -p0
366 %patch17 -p1
367 %patch18 -p1
368 %patch19 -p1
369 %patch20 -p1
370 %patch21 -p1
371 %patch22 -p1
372 %patch23 -p1
373 %patch24 -p1
374 %patch25 -p1
375 %patch26 -p0
376 %patch27 -p1
377 %patch28 -p1
378 %patch29 -p1
379 %patch30 -p1
380
381 %ifarch athlon
382 %patch31 -p1
383 %endif
384
385 %patch32 -p1
386 %patch33 -p1
387 %patch34 -p1
388 %patch35 -p1
389 %patch36 -p1
390 %patch37 -p1
391 %patch38 -p1
392 %patch39 -p1
393 #%patch40 -p1
394
395 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
396 cp -f platform.in macros.pld.in
397 install %{SOURCE5} macros.perl.in
398 install %{SOURCE13} macros.python.in
399 install %{SOURCE21} macros.php.in
400 install %{SOURCE6} scripts/find-perl-provides
401 install %{SOURCE7} scripts/find-perl-requires
402 install %{SOURCE9} scripts/find-lang.sh
403 install %{SOURCE17} scripts/php.prov.in
404 install %{SOURCE18} scripts/php.req.in
405 install %{SOURCE19} scripts/find-php-provides
406 install %{SOURCE20} scripts/find-php-requires
407
408
409 (cd scripts;
410 mv -f perl.req perl.req.in
411 mv -f perl.prov perl.prov.in)
412
413 chmod +x %{SOURCE4}
414
415 %build
416 # generate Group translations to *.po
417 awk -f %{SOURCE14} %{SOURCE1}
418
419 cd popt
420 rm -f missing
421 libtoolize --force --copy
422 aclocal
423 autoheader
424 %{__autoconf}
425 %{__automake}
426 cd ..
427
428 rm -f missing
429 libtoolize --force --copy
430 %{__gettextize}
431 aclocal
432 autoupdate
433 autoheader || :
434 %{__autoconf}
435 # ugly workaround for automake
436 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
437         lib/Makefile.am > lib/Makefile.am.new
438 mv -f lib/Makefile.am.new lib/Makefile.am
439 %{__automake}
440 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
441         lib/Makefile.in > lib/Makefile.in.new
442 mv -f lib/Makefile.in.new lib/Makefile.in
443
444 sed -e 's#python1.5#python%{py_ver}#g' \
445         python/Makefile.in > python/Makefile.in.new
446 mv -f python/Makefile.in.new python/Makefile.in
447
448 # config.guess doesn't handle athlon, so we have to change it by hand.
449 # rpm checks for CPU type at runtime, but it looks better
450 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
451         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
452 mv -f macros.tmp macros.in
453
454 %configure \
455         --enable-shared \
456         --enable-v1-packages \
457         --with-python
458
459
460 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
461
462 %install
463 rm -rf $RPM_BUILD_ROOT
464
465 %{__make} install \
466         DESTDIR=$RPM_BUILD_ROOT \
467         pkgbindir="%{_bindir}"
468
469 install macros.perl     $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
470 install macros.python   $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
471 install macros.php      $RPM_BUILD_ROOT%{_libdir}/rpm/macros.php
472
473 install %{SOURCE1} doc/manual/groups
474 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
475 install %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/rpm/find-rpm-provides
476 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
477 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
478 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
479 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
480 #install %{SOURCE16} $RPM_BUILD_ROOT%{_libdir}/rpm/check-files
481 install scripts/find-php*       $RPM_BUILD_ROOT%{_libdir}/rpm/
482 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_libdir}/rpm/
483
484 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
485
486 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
487 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
488 # customized rpm macros - global for host
489 #
490 #%%_install_langs pl_PL:en_US
491 %%distribution PLD
492 EOF
493
494 %find_lang %{name}
495
496 %clean
497 rm -rf $RPM_BUILD_ROOT
498
499 %post   -p /sbin/ldconfig
500 %postun -p /sbin/ldconfig
501
502 %files -f %{name}.lang
503 %defattr(644,root,root,755)
504 %doc RPM-PGP-KEY CHANGES doc/manual/[a-z]*
505
506 %attr(755,root,root) /bin/rpm
507 %attr(755,root,root) %{_bindir}/rpmdb
508 %attr(755,root,root) %{_bindir}/rpmquery
509 %attr(755,root,root) %{_bindir}/rpmsign
510 %attr(755,root,root) %{_bindir}/rpmverify
511 %attr(755,root,root) %{_libdir}/rpm/rpmdb
512 %attr(755,root,root) %{_libdir}/rpm/rpmq
513 %attr(755,root,root) %{_libdir}/rpm/rpmk
514 %attr(755,root,root) %{_libdir}/rpm/rpmv
515 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
516
517 %dir %{_sysconfdir}/rpm
518 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
519
520 %{_mandir}/man8/rpm.8*
521 %lang(fr) %{_mandir}/fr/man8/rpm.8*
522 %lang(ja) %{_mandir}/ja/man8/rpm.8*
523 %lang(ko) %{_mandir}/ko/man8/rpm.8*
524 %lang(pl) %{_mandir}/pl/man8/rpm.8*
525 %lang(ru) %{_mandir}/ru/man8/rpm.8*
526 %lang(sk) %{_mandir}/sk/man8/rpm.8*
527
528 %dir /var/lib/rpm
529 %dir %{_libdir}/rpm
530
531 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
532
533 %{_libdir}/rpm/rpmrc
534 %{_libdir}/rpm/rpmpopt*
535 %{_libdir}/rpm/macros
536 %{_libdir}/rpm/noarch-linux
537 %{_libdir}/rpm/noarch-pld-linux
538 %ifarch i386 i486 i586 i686 athlon
539 %{_libdir}/rpm/i?86*
540 %{_libdir}/rpm/athlon*
541 %endif
542 %ifarch sparc sparc64
543 %{_libdir}/rpm/sparc*
544 %endif
545 %ifarch alpha
546 %{_libdir}/rpm/alpha*
547 %endif
548 %ifarch ppc
549 %{_libdir}/rpm/ppc*
550 %endif
551
552
553 %files build
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_bindir}/rpmbuild
556 %attr(755,root,root) %{_bindir}/rpme
557 %attr(755,root,root) %{_bindir}/rpmi
558 %attr(755,root,root) %{_bindir}/rpmu
559 %attr(755,root,root) %{_libdir}/rpm/find-requires
560 %attr(755,root,root) %{_libdir}/rpm/find-provides
561 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
562 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
563 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
564 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
565 %attr(755,root,root) %{_libdir}/rpm/config.*
566 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
567 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
568 %attr(755,root,root) %{_libdir}/rpm/brp-*
569 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
570 #%attr(755,root,root) %{_libdir}/rpm/check-files
571 %attr(755,root,root) %{_libdir}/rpm/compress-doc
572 %attr(755,root,root) %{_libdir}/rpm/cpanflute
573 %attr(755,root,root) %{_libdir}/rpm/http.req
574 %attr(755,root,root) %{_libdir}/rpm/magic.*
575 %attr(755,root,root) %{_libdir}/rpm/rpmdiff*
576 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
577 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
578 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
579 %attr(755,root,root) %{_libdir}/rpm/rpmb
580 %attr(755,root,root) %{_libdir}/rpm/rpmi
581 %attr(755,root,root) %{_libdir}/rpm/rpmt
582 %attr(755,root,root) %{_libdir}/rpm/rpme
583 %attr(755,root,root) %{_libdir}/rpm/rpmu
584
585 %files devel
586 %defattr(644,root,root,755)
587 %{_includedir}/rpm
588 %attr(755,root,root) %{_libdir}/librpm*.la
589 %attr(755,root,root) %{_libdir}/librpm*.so
590
591 %files static
592 %defattr(644,root,root,755)
593 %{_libdir}/librpm*.a
594
595 %files utils
596 %defattr(644,root,root,755)
597 %attr(755,root,root) %{_bindir}/gendiff
598 %attr(755,root,root) %{_bindir}/javadeps
599 %attr(755,root,root) %{_bindir}/rpm2cpio
600
601 %{_mandir}/man8/rpm2cpio.8*
602 %{_mandir}/man1/*
603 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
604 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
605 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
606 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
607
608 %files perlprov
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_libdir}/rpm/perl*
611 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
612 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
613 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
614 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
615 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
616
617 %{_libdir}/rpm/macros.perl
618
619 %files pythonprov
620 %defattr(644,root,root,755)
621 %{_libdir}/rpm/macros.python
622
623 %files php-pearprov
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_libdir}/rpm/php*
626 %attr(755,root,root) %{_libdir}/rpm/find-php*
627 %{_libdir}/rpm/macros.php
628
629 %files -n python-rpm
630 %defattr(755,root,root,755)
631 %{py_sitedir}/*.so
This page took 0.071015 seconds and 4 git commands to generate.