- BR update
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4 #   returns -ENOSYS
5 # - add macros for some ppc, mipsel, alpha and sparc
6 #
7 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
8 #
9 # Conditional build:
10 %bcond_with     static          # build static rpm+rpmi
11 %bcond_without  apidocs         # don't generate documentation with doxygen
12 %bcond_without  python          # don't build python bindings
13 %bcond_without  selinux         # build without selinux support
14 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
15 %bcond_with     db61            # use DB 6.1 instead of 5.2
16 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
17 %bcond_with     sqlite          # build with SQLite support
18 %bcond_with     system_lua      # use system lua
19 %bcond_with     keyutils        # build with keyutils support
20 # force_cc              - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
21 # force_cxx             - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
22 # force_cpp             - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
23 #
24
25 %if %{with sqlite}
26 # Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
27 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
28 %endif
29
30 # versions of required libraries
31 %if %{with db61}
32 %define         reqdb_pkg       db6.1
33 %define         reqdb_ver       6.1
34 %define         reqdb_pkgver    6.1.19
35 %else
36 %define         reqdb_pkg       db5.2
37 %define         reqdb_ver       5.2
38 %define         reqdb_pkgver    5.2.36.0-4
39 %endif
40 %define         reqpopt_ver     1.15
41 %define         beecrypt_ver    2:4.2.0
42 %define         sover           5.4
43
44 Summary:        RPM Package Manager
45 Summary(de.UTF-8):      RPM Packet-Manager
46 Summary(es.UTF-8):      Gestor de paquetes RPM
47 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
48 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
49 Summary(ru.UTF-8):      Менеджер пакетов от RPM
50 Summary(uk.UTF-8):      Менеджер пакетів від RPM
51 Name:           rpm
52 Version:        5.4.15
53 Release:        0.1
54 License:        LGPL v2.1
55 Group:          Base
56 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
57 Source0:        %{name}-%{version}.tar.gz
58 # Source0-md5:  4067f83ca8b5bf1a21e443c0cff3efa0
59 Source100:      cpu-os-macros.tar.gz
60 # Source100-md5:        928034a5bdceb398881bc14b5f29973b
61 Source1:        %{name}.groups
62 Source2:        macros.pld.in
63 Source3:        %{name}-install-tree
64 Source4:        %{name}-find-spec-bcond
65 Source5:        %{name}-hrmib-cache
66 Source6:        %{name}-groups-po.awk
67 Source7:        %{name}-compress-doc
68 Source8:        %{name}-php-provides
69 Source9:        %{name}-php-requires
70 Source10:       %{name}.sysinfo
71 Source11:       perl.prov
72 Source12:       %{name}-user_group.sh
73 Source13:       %{name}.sysconfig
74 Source14:       %{name}-java-requires
75 # http://svn.pld-linux.org/banner.sh/
76 Source15:       banner.sh
77 Source16:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
78 # Source16-md5: 08b29584dd349aac9caa7610131a0a88
79 Source17:       %{name}-mimetypedeps
80 Source18:       macros.local
81 Source19:       %{name}.noautocompressdoc
82 Source20:       %{name}.noautoprov
83 Source21:       %{name}.noautoprovfiles
84 Source22:       %{name}.noautoreq
85 Source24:       %{name}.noautoreqfiles
86 Source25:       %{name}-php-requires.php
87 Source26:       %{name}db_checkversion.c
88 Source27:       macros.lang
89 Source28:       %{name}db_reset.c
90 Source29:       dbupgrade.sh
91 Source30:       rubygems.rb
92 Patch0:         %{name}-branch.patch
93 Patch1:         %{name}-man_pl.patch
94 Patch2:         %{name}-popt-aliases.patch
95 Patch3:         %{name}-nosetproctitle.patch
96 Patch4:         %{name}-perl-macros.patch
97 Patch5:         %{name}-perl-req-perlfile.patch
98 Patch6:         %{name}-scripts-closefds.patch
99 Patch7:         %{name}-php-macros.patch
100 Patch8:         %{name}-gettext-in-header.patch
101 Patch9:         %{name}-lua.patch
102 Patch10:        %{name}-php-deps.patch
103 Patch11:        %{name}-notsc.patch
104 Patch12:        %{name}-hack-norpmlibdep.patch
105 Patch13:        %{name}-dont-copy-descriptive-tags.patch
106 Patch14:        %{name}-perl_req-INC_dirs.patch
107 Patch15:        %{name}-debuginfo.patch
108 Patch16:        vendor-pld.patch
109 Patch17:        %{name}-old-fileconflicts-behaviour.patch
110 Patch18:        %{name}-javadeps.patch
111 Patch19:        %{name}-truncate-cvslog.patch
112 Patch20:        %{name}-libtool-deps.patch
113 Patch21:        %{name}-mimetype.patch
114 Patch22:        %{name}-sparc64.patch
115 Patch23:        %{name}-gendiff.patch
116 Patch24:        openmp.patch
117 Patch25:        %{name}-URPM-build-fix.patch
118 Patch27:        %{name}-helperEVR-noassert.patch
119 Patch28:        %{name}-unglobal.patch
120 Patch29:        %{name}-builddir-readlink.patch
121 Patch30:        %{name}-changelog_order_check_nonfatal.patch
122 Patch31:        %{name}-cleanbody.patch
123 Patch32:        %{name}-dirdeps-macro.patch
124 Patch33:        %{name}-installbeforeerase.patch
125 Patch34:        %{name}-libmagic-locale.patch
126 Patch35:        %{name}-namespace-compare.patch
127 Patch36:        %{name}-popt-coreutils.patch
128 Patch37:        %{name}-postun-nofail.patch
129 Patch38:        %{name}-silence-RPM_CHAR_TYPE.patch
130 Patch39:        %{name}-fix-missing-types-in-headers.patch
131 Patch40:        %{name}-fix--p-interpreter-and-empty-script.patch
132 Patch41:        %{name}-db_buffer_small.patch
133 Patch42:        %{name}-pattern_Release.patch
134 Patch43:        %{name}-fix-___build_pre-macro.patch
135 Patch44:        %{name}-missing-patch-file-fails-build.patch
136 Patch45:        %{name}-remove-misleading-missing-patch-message.patch
137 Patch46:        %{name}-file-magic-can-be-mixed-case.patch
138 Patch47:        %{name}-query-always-noisy.patch
139 Patch48:        %{name}-verify-ghosts-broken-logic.patch
140 Patch49:        %{name}-python-enable-compat-RPMSENSE.patch
141 Patch50:        %{name}-dont-treat-gstreamer-modules-as-font.patch
142 Patch51:        %{name}-gst-inspect-typo.patch
143 Patch52:        %{name}-null-term-ascii-digest.patch
144 Patch53:        %{name}-lua-enable-extra-libs.patch
145 Patch54:        %{name}-fix-filedigests-verify.patch
146 Patch55:        %{name}-disable-hmac-verify.patch
147 Patch56:        %{name}-macros.patch
148 Patch57:        %{name}-db5.2.patch
149 Patch58:        %{name}-preserve-iterator.patch
150 Patch60:        %{name}-python-sitescriptdir.patch
151 Patch61:        %{name}-clean-docdir.patch
152 Patch62:        %{name}-DB_CONFIG.patch
153 Patch63:        %{name}-pythoneggs.patch
154 Patch64:        %{name}-fix-compress-doc.patch
155 Patch65:        %{name}-parseSpec-skip-empty-tags.patch
156 Patch66:        %{name}-payload-use-hashed-inode.patch
157 Patch67:        %{name}-repackage-dont-force-max-compression.patch
158 Patch70:        python-%{name}sense-missingok.patch
159 Patch71:        %{name}-changelog-encoding.patch
160 Patch72:        %{name}-preserve-tag-type.patch
161 Patch73:        gem_helper-spec-arg.patch
162 Patch74:        %{name}-fix-internal-lua-build.patch
163 Patch75:        %{name}-double_check_file_deps.patch
164 Patch77:        %{name}-lua-expat.patch
165 Patch78:        %{name}-double_check_unpackaged_subdirs.patch
166 Patch79:        %{name}-rpmspec.patch
167 Patch80:        %{name}-revert-gpg-argv-parsing.patch
168 Patch81:        %{name}-perl-magic.patch
169
170 # Patches imported from Mandriva
171
172 # status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
173 # would basically just mean backporting it..
174 Patch1000:      %{name}-5.4.4-add-_specfile-macro.patch
175 # status: needs to be cleaned up and properly reviewed together with rest
176 # of the patches related to dependency generation
177 Patch1001:      %{name}-5.4.9-avoid-dependencies-on-self.patch
178 # status: probably ready to merge
179 Patch1002:      %{name}-5.4.4-pkgconfigdeps-check-path.patch
180 # status: probably okay to merge, but discuss on rpm-devel first
181 Patch1003:      %{name}-5.4.4-glob-wildcards-for-loading-macro-files.patch
182 # status: needs to be discussed
183 Patch1004:      %{name}-5.4.4-allow-installation-of-repackaged-rpms.patch
184 # status: ready to merge
185 Patch1005:      %{name}-5.4.8-dont-show-suggests-with-requires.patch
186 # status: ready for merge
187 Patch1006:      %{name}-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
188 # status: probably okay to merge, but discuss on rpm-devel first
189 Patch1007:      %{name}-5.4.10-duplicate_files_terminate_build.patch
190 # status: same as above
191 Patch1008:      %{name}-5.4.10-unpackaged_subdirs_terminate_build.patch
192 # mdvbz#64898
193 # status: uncertain, might be okay to merge, discuss on rpm-devel first
194 Patch1009:      %{name}-5.4.4-rpmbuild-withoutclean.patch
195 # no sense in having an additional dependency on 'pkgconfig' on all packages that
196 # have a pkgconfig file, it's not needed for them to be made useful and anything
197 # actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
198 # status: might be okay to merge, but discuss on rpm-devel first
199 Patch1010:      %{name}-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
200 # status: ready for merge
201 Patch1011:      %{name}-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
202 # $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
203 # %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
204 # status: needs to be discussed and investigated a bit better..
205 Patch1012:      %{name}-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
206 # status: probably okay to merge, but discuss on rpm-devel first
207 Patch1013:      %{name}-5.4.10-files-listed-twice-terminates-build.patch
208 # status: probably okay to merge
209 Patch1014:      %{name}-5.4.9-ruby1.9-fixes.patch
210 # status: keep locally
211 Patch1015:      %{name}-5.4.9-keep-loading-script-macros.patch
212 # status: same as for other dep gen patches
213 Patch1016:      %{name}-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
214 # status: idem
215 Patch1017:      %{name}-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
216 # status: probably okay to merge
217 Patch1019:      %{name}-5.4.5-python-export-spec-macros.patch
218 # status: idem
219 Patch1020:      %{name}-5.4.9-font-provides.patch
220 # stauus: idem
221 Patch1021:      %{name}-5.4.7-kmod-dependencies.patch
222 # status: probably okay to merge, discuss on rpm-devel first
223 Patch1022:      %{name}-5.4.5-skip-dependencies-for-character-devices.patch
224 # status: probably okay to merge
225 Patch1024:      %{name}-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
226 # status: probably okay to merge
227 Patch1026:      %{name}-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
228 # status: ready
229 Patch1027:      %{name}-5.4.7-fix-generation-of-ruby-abi-provides.patch
230 # crash reproducable with 'rpm -qa --triggers'
231 # status: ready
232 Patch1028:      %{name}-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
233 # status: same as for other dep gen patches
234 Patch1029:      %{name}-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
235 # status: ready
236 Patch1030:      %{name}-5.4.7-fix-minor-memleaks.patch
237 # status: ready
238 Patch1031:      %{name}-5.4.9-mire-fix-strings-lacking-null-terminator.patch
239 # status: ready
240 Patch1032:      %{name}-5.4.9-rpmpython-fix-input.patch
241 # status: ready
242 Patch1033:      %{name}-5.4.7-no-seqid_init-on-rdonly-database.patch
243 # status: probably ready for merging
244 Patch1034:      %{name}-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
245 # status: probably ready to merge, discuss on rpm-devel first
246 Patch1035:      %{name}-5.4.9-fix-verify-segfault.patch
247 # Due to rpmdav/neon being written in a different fashion than other rpmio clients,
248 # the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
249 # with the result being that when unable to download files, neon will save error
250 # page as the target file.
251 # status: should go upstream, but uncertain about "correct" fix, ie. this is
252 # more of a workaround, while rewriting rpmdav code to behave consistently
253 # would be "the right thing to do". Yet I'm not fully able to grasp all of the
254 # code and don't want to spend more time just to get the API..
255 Patch1037:      %{name}-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
256 # As the transaction flags for ignoring arch & os are no longer used, there's
257 # currently no way to ignore arch & os of packages anymore. This patch adds
258 # support for doing this again by defining rpm variables and overriding
259 # --ignorearch & --ignoreos to set these.
260 # status: needs to be discussed upstream before thinking about merging
261 Patch1038:      %{name}-5.4.10-support-ignore-arch-and-os-again.patch
262 # status: ready for merge
263 Patch1039:      %{name}-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
264 # we want that patch too, a bit of builder infrastructure relies on NOSIGNATURES
265 Patch1040:      %{name}-5.4.9-support-signatures-and-digest-disablers.patch
266 # lack insight on actual functionality, which anyways seems broken, so let's
267 # disable it to avoid errors from berkeley db..
268 # status: keep locally
269 Patch1041:      %{name}-5.4.9-disable-l10ndir.patch
270 # status: ready for merge
271 Patch1042:      %{name}-5.4.9-fix-rpm_qa-pattern.patch
272 # warning: introduces memory leak
273 Patch1043:      %{name}-5.4.12-copy-Value-string.patch
274 Patch1044:      %{name}-5.4.12-fix-rpmlua-print.patch
275 Patch1045:      %{name}-5.4.12-fix-rpmpython-module-import-init.patch
276 Patch1046:      %{name}-5.4.12-truncate-output-buffer-after-use.patch
277 Patch1047:      %{name}-5.4.13-perl-bindings-do-not-use-xmalloc.patch
278
279 URL:            http://rpm5.org/
280 BuildRequires:  %{reqdb_pkg}-devel >= %{reqdb_pkgver}
281 %if %{with sqlite}
282 BuildRequires:  sqlite3-devel
283 %else
284 BuildRequires:  %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
285 %endif
286 BuildRequires:  autoconf >= 2.63
287 BuildRequires:  automake >= 1.4
288 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
289 BuildRequires:  bzip2-devel >= 1.0.2-17
290 BuildRequires:  elfutils-devel >= 0.108
291 BuildRequires:  gettext-devel >= 0.19.2
292 %{?with_keyutils:BuildRequires: keyutils-devel}
293 BuildRequires:  libmagic-devel
294 %if %{with selinux}
295 BuildRequires:  libselinux-devel >= 2.1.0
296 BuildRequires:  libsemanage-devel >= 2.1.0
297 BuildRequires:  libsepol-devel >= 2.1.0
298 %endif
299 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
300 BuildRequires:  libstdc++-devel
301 BuildRequires:  libtool >= 1:1.4.2-9
302 %if %{with neon}
303 BuildRequires:  libxml2-devel
304 BuildRequires:  neon-devel >= 0.25.5
305 %endif
306 %{?with_system_lua:BuildRequires:       lua52-devel >= 5.2.2}
307 BuildRequires:  ossp-uuid-devel
308 BuildRequires:  patch >= 2.2
309 BuildRequires:  popt-devel >= %{reqpopt_ver}
310 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
311 BuildRequires:  python-modules >= 1:2.3
312 %{?with_python:BuildRequires:   rpm-pythonprov}
313 BuildRequires:  tcl
314 BuildRequires:  xz-devel
315 BuildRequires:  zlib-devel
316 %if %{with apidocs}
317 BuildRequires:  doxygen
318 BuildRequires:  ghostscript
319 BuildRequires:  graphviz
320 BuildRequires:  tetex-pdftex
321 %endif
322 %if %{with static}
323 # Require static library only for static build
324 BuildRequires:  %{reqdb_pkg}-static >= %{reqdb_pkgver}
325 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
326 BuildRequires:  bzip2-static >= 1.0.2-17
327 BuildRequires:  elfutils-static
328 BuildRequires:  glibc-static >= 2.2.94
329 BuildRequires:  libmagic-static
330 %if %{with selinux}
331 BuildRequires:  libselinux-static >= 2.1.0
332 BuildRequires:  libsemanage-static >= 2.1.0
333 BuildRequires:  libsepol-static >= 2.1.0
334 %endif
335 BuildRequires:  popt-static >= %{reqpopt_ver}
336 BuildRequires:  zlib-static
337 %endif
338 Requires(posttrans):    coreutils
339 Requires:       %{name}-base = %{version}-%{release}
340 Requires:       %{name}-lib = %{version}-%{release}
341 Requires:       beecrypt >= %{beecrypt_ver}
342 Requires:       popt >= %{reqpopt_ver}
343 Provides:       rpm-db-ver = %{reqdb_ver}
344 Obsoletes:      rpm-getdeps
345 %{!?with_static:Obsoletes:      rpm-utils-static}
346 Conflicts:      glibc < 2.2.92
347 # db4.6 poldek needed
348 Conflicts:      poldek < 0.21-0.20070703.00.3
349 # segfaults with lzma 0.42.2
350 Conflicts:      lzma-libs < 4.999.3
351 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
352 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
353
354 %define         _binary_payload         w9.gzdio
355
356 # don't require very fresh rpm.macros to build
357 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
358 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
359 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
360 %define         ppc     ppc ppc7400 ppc7450
361 %define         x8664   amd64 ia32e x86_64
362
363 # stabilize new build environment
364 %define         __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
365 %define         __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
366 %define         __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
367
368 %define         _rpmlibdir /usr/lib/rpm
369 %define         _noautocompressdoc      RPM-GPG-KEY
370
371 %description
372 RPM is a powerful package manager, which can be used to build,
373 install, query, verify, update, and uninstall individual software
374 packages. A package consists of an archive of files, and package
375 information, including name, version, and description.
376
377 %description -l de.UTF-8
378 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
379 Installation, Anfrage, Verifizierung, Aktualisierung und
380 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
381 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
382 Beschreibung.
383
384 %description -l es.UTF-8
385 RPM es un poderoso administrador de paquetes, que puede ser usado para
386 construir, instalar, pesquisar, verificar, actualizar y desinstalar
387 paquetes individuales de software. Un paquete consiste en un
388 almacenaje de archivos, y información sobre el paquete, incluyendo
389 nombre, versión y descripción.
390
391 %description -l pl.UTF-8
392 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
393 przebudowanie, instalację czy weryfikację dowolnego pakietu.
394 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
395 plików wchodzących w skład pakietu, zależności od innych pakietów, są
396 przechowywane w bazie danych i można je uzyskać za pomocą opcji
397 odpytywania programu rpm.
398
399 %description -l pt_BR.UTF-8
400 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
401 construir, instalar, pesquisar, verificar, atualizar e desinstalar
402 pacotes individuais de software. Um pacote consiste de um conjunto de
403 arquivos e informações adicionais, incluindo nome, versão e descrição
404 do pacote, permissões dos arquivos, etc.
405
406 %description -l ru.UTF-8
407 RPM - это мощный менеджер пакетов, который может быть использован для
408 создания, инсталляции, запросов (query), проверки, обновления и
409 удаления программных пакетов. Пакет состоит из файлового архива и
410 служебной информации, включающей название, версию, описание и другие
411 данные о пакете.
412
413 %description -l uk.UTF-8
414 RPM - це потужний менеджер пакетів, що може бути використаний для
415 створення, інсталяції, запитів (query), перевірки, поновлення та
416 видалення програмних пакетів. Пакет складається з файлового архіву та
417 службової інформації, що містить назву, версію, опис та іншу
418 інформацію про пакет.
419
420 %package base
421 Summary:        RPM base package - scripts used by rpm packages themselves
422 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
423 Group:          Base
424 Requires:       filesystem
425 Obsoletes:      rpm-scripts
426 Obsoletes:      vserver-rpm
427
428 %description base
429 The RPM base package contains scripts used by rpm packages themselves.
430 These include:
431 - scripts for adding/removing groups and users needed for rpm
432   packages,
433 - banner.sh to display %%banner messages from rpm scriptlets.
434
435 %description base -l pl.UTF-8
436 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
437 Zawiera on:
438 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
439 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
440
441 %package lib
442 Summary:        RPMs library
443 Summary(pl.UTF-8):      Biblioteki RPM-a
444 Group:          Libraries
445 Requires:       %{reqdb_pkg} >= %{reqdb_pkgver}
446 %if %{with sqlite}
447 Requires:       sqlite3 >= %{sqlite_build_version}
448 %else
449 Requires:       %{reqdb_pkg}-sql >= %{reqdb_pkgver}
450 %endif
451 Requires:       beecrypt >= %{beecrypt_ver}
452 Requires:       libmagic >= 1.15-2
453 %{?with_selinux:Requires:       libselinux >= 2.1.0}
454 Requires:       popt >= %{reqpopt_ver}
455 Obsoletes:      rpm-libs
456 # avoid SEGV caused by mixed db versions
457 Conflicts:      poldek < 0.18.1-16
458
459 %description lib
460 RPMs library.
461
462 %description lib -l pl.UTF-8
463 Biblioteki RPM-a.
464
465 %package devel
466 Summary:        Header files for rpm libraries
467 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
468 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
469 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
470 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
471 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
472 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
473 Group:          Development/Libraries
474 Requires:       %{name}-lib = %{version}-%{release}
475 Requires:       %{reqdb_pkg}-devel >= %{reqdb_pkgver}
476 Requires:       beecrypt-devel >= %{beecrypt_ver}
477 Requires:       bzip2-devel
478 Requires:       elfutils-devel
479 %{?with_keyutils:Requires:      keyutils-devel}
480 Requires:       libmagic-devel
481 %if %{with selinux}
482 Requires:       libselinux-devel
483 Requires:       libsemanage-devel
484 Requires:       libsepol-devel
485 %endif
486 Requires:       popt-devel >= %{reqpopt_ver}
487 Requires:       zlib-devel
488
489 %description devel
490 The RPM packaging system includes C libraries that make it easy to
491 manipulate RPM packages and databases. They are intended to ease the
492 creation of graphical package managers and other tools that need
493 intimate knowledge of RPM packages. This package contains header files
494 for these libraries.
495
496 %description devel -l de.UTF-8
497 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
498 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
499 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
500 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
501
502 %description devel -l es.UTF-8
503 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
504 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
505 facilitar la creación de administradores gráficos de paquetes y otras
506 herramientas que necesiten un conocimiento profundo de paquetes RPM.
507
508 %description devel -l pl.UTF-8
509 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
510 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
511 graficznych programów zarządzających pakietami oraz innych narzędzi,
512 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
513 zawiera pliki nagłówkowe wspomnianych bibliotek.
514
515 %description devel -l pt_BR.UTF-8
516 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
517 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
518 facilitar a criação de gerenciadores gráficos de pacotes e outras
519 ferramentas que precisem de conhecimento profundo de pacotes RPM.
520
521 %description devel -l ru.UTF-8
522 Система управления пакетами RPM содержит библиотеку C, которая
523 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
524 Эта библиотека предназначена для облегчения создания графических
525 пакетных менеджеров и других утилит, которым необходимо работать с
526 пакетами RPM.
527
528 %description devel -l uk.UTF-8
529 Система керування пакетами RPM містить бібліотеку C, котра спрощує
530 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
531 призначена для полегшення створення графічних пакетних менеджерів та
532 інших утиліт, що працюють з пакетами RPM.
533
534 %package static
535 Summary:        RPM static libraries
536 Summary(de.UTF-8):      RPMs statische Libraries
537 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
538 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
539 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
540 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
541 Group:          Development/Libraries
542 Requires:       %{name}-devel = %{version}-%{release}
543 Requires:       %{reqdb_pkg}-static >= %{reqdb_pkgver}
544 Requires:       beecrypt-static >= %{beecrypt_ver}
545 Requires:       bzip2-static
546 Requires:       elfutils-static
547 %{?with_keyutils:Requires:      keyutils-static}
548 Requires:       libmagic-static
549 %if %{with selinux}
550 Requires:       libselinux-static
551 Requires:       libsemanage-static
552 Requires:       libsepol-static
553 %endif
554 Requires:       popt-static >= %{reqpopt_ver}
555 Requires:       zlib-static
556
557 %description static
558 RPM static libraries.
559
560 %description static -l de.UTF-8
561 RPMs statische Libraries.
562
563 %description static -l pl.UTF-8
564 Biblioteki statyczne RPM-a.
565
566 %description static -l pt_BR.UTF-8
567 Bibliotecas estáticas para desenvolvimento.
568
569 %description static -l ru.UTF-8
570 Система управления пакетами RPM содержит библиотеку C, которая
571 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
572 Это статическая библиотека RPM.
573
574 %description static -l uk.UTF-8
575 Система керування пакетами RPM містить бібліотеку C, котра спрощує
576 роботу з пакетами RPM та відповідними базами даних. Це статична
577 бібліотека RPM.
578
579 %package utils
580 Summary:        Additional utilities for managing RPM packages and database
581 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
582 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
583 Group:          Applications/File
584 Requires:       %{name} = %{version}-%{release}
585 Requires:       popt >= %{reqpopt_ver}
586 %if %{with suggest_tags}
587 Suggests:       bzip2
588 Suggests:       gzip
589 %endif
590 Conflicts:      filesystem-debuginfo < 3.0-16
591
592 %description utils
593 Additional utilities for managing RPM packages and database.
594
595 %description utils -l de.UTF-8
596 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
597
598 %description utils -l pl.UTF-8
599 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
600
601 %package utils-perl
602 Summary:        Additional utilities for managing RPM packages and database
603 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
604 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
605 Group:          Applications/File
606 Requires:       %{name}-utils = %{version}-%{release}
607 Requires:       popt >= %{reqpopt_ver}
608
609 %description utils-perl
610 Additional utilities for managing RPM packages and database.
611
612 %description utils-perl -l de.UTF-8
613 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
614
615 %description utils-perl -l pl.UTF-8
616 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
617
618 %package utils-static
619 Summary:        Static rpm utilities
620 Summary(pl.UTF-8):      Statyczne narzędzia rpm
621 Group:          Applications/System
622 Requires:       %{name} = %{version}-%{release}
623
624 %description utils-static
625 Static rpm utilities for repairing system in case something with
626 shared libraries used by rpm become broken. Currently it contains rpmi
627 binary, which can be used to install/upgrade/remove packages without
628 using shared libraries (well, in fact with exception of NSS modules).
629
630 %description utils-static -l pl.UTF-8
631 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
632 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
633 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
634 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
635 (z wyjątkiem modułów NSS).
636
637 %package build
638 Summary:        Scripts for building binary RPM packages
639 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
640 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
641 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
642 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
643 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
644 Group:          Applications/File
645 Requires(pretrans):     coreutils
646 Requires(pretrans):     findutils
647 Requires:       %{name}-build-macros >= 1.656
648 Requires:       %{name}-utils = %{version}-%{release}
649 Requires:       /bin/id
650 Requires:       awk
651 Requires:       bzip2
652 Requires:       chrpath >= 0.10-4
653 Requires:       cpio
654 Requires:       diffutils
655 Requires:       elfutils
656 Requires:       file >= 4.17
657 Requires:       fileutils
658 Requires:       findutils
659 %ifarch athlon
660 Requires:       gcc >= 3.0.3
661 %else
662 Requires:       gcc
663 %endif
664 Requires:       glibc-devel
665 Requires:       grep
666 Requires:       gzip
667 Requires:       make
668 Requires:       patch
669 Requires:       sed >= 4.0
670 Requires:       sh-utils
671 Requires:       tar >= 1:1.22
672 Requires:       textutils
673 Requires:       which
674 Requires:       xz
675 Provides:       rpmbuild(monoautodeps)
676 Provides:       rpmbuild(noauto) = 3
677 %ifarch %{x8664}
678 Conflicts:      automake < 1:1.7.9-2
679 Conflicts:      libtool < 2:1.5-13
680 %endif
681
682 %description build
683 Scripts for building binary RPM packages.
684
685 %description build -l de.UTF-8
686 Scripts fürs Bauen binärer RPM-Pakete.
687
688 %description build -l pl.UTF-8
689 Skrypty pomocnicze do budowania binarnych RPM-ów.
690
691 %description build -l pt_BR.UTF-8
692 Este pacote contém scripts e programas executáveis que são usados para
693 construir pacotes usando o RPM.
694
695 %description build -l ru.UTF-8
696 Различные вспомогательные скрипты и исполняемые программы, которые
697 используются для сборки RPM'ов.
698
699 %description build -l uk.UTF-8
700 Різноманітні допоміжні скрипти та утиліти, які використовуються для
701 побудови RPM'ів.
702
703 %package javaprov
704 Summary:        Additional utilities for checking Java provides/requires in RPM packages
705 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
706 Group:          Applications/File
707 Requires:       %{name} = %{version}-%{release}
708 Requires:       file
709 Requires:       findutils >= 1:4.2.26
710 Requires:       mktemp
711 Requires:       unzip
712
713 %description javaprov
714 Additional utilities for checking Java provides/requires in RPM
715 packages.
716
717 %description javaprov -l pl.UTF-8
718 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
719 RPM.
720
721 %package perlprov
722 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
723 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
724 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
725 Group:          Applications/File
726 Requires:       %{name} = %{version}-%{release}
727 Requires:       perl-Encode
728 Requires:       perl-devel
729 Requires:       perl-modules
730
731 %description perlprov
732 Additional utilities for checking Perl provides/requires in RPM
733 packages.
734
735 %description perlprov -l de.UTF-8
736 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
737
738 %description perlprov -l pl.UTF-8
739 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
740 pakietach RPM.
741
742 %package pythonprov
743 Summary:        Python macros, which simplifies creation of RPM packages with Python software
744 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
745 Group:          Applications/File
746 Requires:       %{name} = %{version}-%{release}
747 Requires:       python
748 Requires:       python-distribute
749 Requires:       python-modules
750
751 %description pythonprov
752 Python macros, which simplifies creation of RPM packages with Python
753 software.
754
755 %description pythonprov -l pl.UTF-8
756 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
757 Pythonie.
758
759 %package php-pearprov
760 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
761 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
762 Group:          Applications/File
763 Requires:       %{name} = %{version}-%{release}
764 Requires:       sed >= 4.0
765 Suggests:       php-pear-PHP_CompatInfo
766
767 %description php-pearprov
768 Additional utilities for checking PHP PEAR provides/requires in RPM
769 packages.
770
771 %description php-pearprov -l pl.UTF-8
772 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
773 pakietach RPM.
774
775 %package rubyprov
776 Summary:        Ruby tools, which simplify creation of RPM packages with Ruby software
777 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
778 Group:          Applications/File
779 Requires:       %{name} = %{version}-%{release}
780 Requires:       ruby
781 Requires:       ruby-modules
782 Requires:       ruby-rubygems
783
784 %description rubyprov
785 Ruby tools, which simplifies creation of RPM packages with Ruby
786 software.
787
788 %description rubyprov -l pl.UTF-8
789 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
790 Ruby.
791
792 %package -n python-rpm
793 Summary:        Python interface to RPM library
794 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
795 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
796 Group:          Development/Languages/Python
797 Requires:       %{name} = %{version}-%{release}
798 Requires:       python
799 Obsoletes:      rpm-python
800
801 %description -n python-rpm
802 The rpm-python package contains a module which permits applications
803 written in the Python programming language to use the interface
804 supplied by RPM (RPM Package Manager) libraries.
805
806 This package should be installed if you want to develop Python
807 programs that will manipulate RPM packages and databases.
808
809 %description -n python-rpm -l pl.UTF-8
810 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
811 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
812
813 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
814 Pythonie programy manipulujące pakietami i bazami danych rpm.
815
816 %description -n python-rpm -l pt_BR.UTF-8
817 O pacote rpm-python contém um módulo que permite que aplicações
818 escritas em Python utilizem a interface fornecida pelas bibliotecas
819 RPM (RPM Package Manager).
820
821 Esse pacote deve ser instalado se você quiser desenvolver programas em
822 Python para manipular pacotes e bancos de dados RPM.
823
824 %package apidocs
825 Summary:        RPM API documentation and guides
826 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
827 Group:          Documentation
828 %if "%{_rpmversion}" >= "5"
829 BuildArch:      noarch
830 %endif
831
832 %description apidocs
833 Documentation for RPM API and guides in HTML format generated from rpm
834 sources by doxygen.
835
836 %description apidocs -l pl.UTF-8
837 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
838 źrodeł RPM-a przez doxygen.
839
840 %prep
841 %setup -q -n %{name}-%{version}%{?subver} -a100
842 #patch0 -p1
843 %patch1 -p1
844 %patch2 -p1
845 %patch3 -p1
846 %patch4 -p1
847 %patch5 -p1
848 %patch6 -p1
849 %patch7 -p1
850 %patch8 -p1
851 %{?with_system_lua:%patch9 -p1}
852 %patch10 -p1
853 %ifnarch i386 i486
854 # enable TSC for capable archs
855 %patch11 -p1
856 %endif
857 %patch12 -p1
858 %patch13 -p1
859 %patch14 -p0
860 %patch15 -p1
861 %patch16 -p1
862 %patch17 -p1
863 %patch18 -p1
864 %patch19 -p1
865 %patch20 -p1
866 %patch21 -p1
867 %ifarch sparc64
868 %patch22 -p1
869 %endif
870 %patch23 -p1
871 %patch24 -p1
872 %patch25 -p1
873 %patch27 -p1
874 %patch28 -p1
875 %patch29 -p1
876 %patch30 -p1
877 %patch31 -p1
878 %patch32 -p1
879 %patch33 -p1
880 %patch34 -p1
881 %patch35 -p1
882 %patch36 -p1
883 %patch37 -p1
884 %patch38 -p1
885 %patch39 -p1
886 %patch40 -p1
887 %{?with_db61:%patch41 -p1}
888 %patch42 -p1
889 %patch43 -p1
890 %patch44 -p1
891 %patch45 -p1
892 %patch46 -p1
893 %patch47 -p1
894 %patch48 -p1
895 %patch49 -p1
896 %patch50 -p1
897 %patch51 -p1
898 %patch52 -p0
899 %patch53 -p1
900 %patch54 -p1
901 %patch55 -p1
902 %patch56 -p1
903 %{!?with_db61:%patch57 -p1}
904 %patch58 -p1
905 %patch60 -p1
906 %patch61 -p1
907 %patch62 -p1
908 %patch63 -p1
909 %patch64 -p1
910 %patch65 -p1
911 %patch66 -p1
912 %patch67 -p1
913 %patch70 -p1
914 %patch71 -p1
915 %patch72 -p1
916 %patch73 -p1
917 %patch74 -p1
918 %patch75 -p1
919 %patch77 -p0
920 %patch78 -p1
921 %patch79 -p1
922 %patch80 -p1
923 %patch81 -p0
924
925 %patch1000 -p1
926 %patch1001 -p1
927 %patch1002 -p1
928 %patch1003 -p1
929 %patch1004 -p1
930 %patch1005 -p1
931 %patch1006 -p1
932 %patch1007 -p1
933 %patch1008 -p1
934 %patch1009 -p1
935 %patch1010 -p1
936 %patch1011 -p1
937 %patch1012 -p1
938 %patch1013 -p1
939 %patch1014 -p1
940 %patch1015 -p1
941 %patch1016 -p1
942 %patch1017 -p1
943 %patch1019 -p1
944 %patch1020 -p1
945 %patch1021 -p1
946 %patch1022 -p1
947 %patch1024 -p1
948 %patch1026 -p1
949 %patch1027 -p1
950 %patch1028 -p1
951 %patch1029 -p1
952 %patch1030 -p1
953 %patch1031 -p1
954 %patch1032 -p1
955 %patch1033 -p1
956 %patch1034 -p1
957 %patch1035 -p1
958 %patch1037 -p1
959 %patch1038 -p1
960 %patch1039 -p1
961 %patch1040 -p1
962 # don't delete, may be usefull if jbj descides to enable this again
963 #%patch1041 -p1
964 %patch1042 -p1
965 %patch1043 -p1
966 %patch1044 -p1
967 %patch1045 -p1
968 %patch1046 -p1
969 %patch1047 -p1
970
971 install %{SOURCE2} macros/pld.in
972 install %{SOURCE8} scripts/php.prov.in
973 install %{SOURCE9} scripts/php.req.in
974 install %{SOURCE11} scripts/perl.prov.in
975 cp -p %{SOURCE30} scripts/rubygems.rb
976
977 %{__mv} -f scripts/perl.req{,.in}
978
979 # generate Group translations to *.po
980 awk -f %{SOURCE6} %{SOURCE1}
981
982 install %{SOURCE26} tools/rpmdb_checkversion.c
983 install %{SOURCE28} tools/rpmdb_reset.c
984
985 for extlib in beecrypt neon pcre popt; do
986         [ -d $extlib ] && %{__rm} -r $extlib
987 done
988
989 %build
990 %{__libtoolize}
991 #%{__autopoint}
992 %{__aclocal}
993 %{__autoheader}
994 %{__autoconf}
995 %{__automake}
996
997 # rpm checks for CPU type at runtime, but it looks better
998 sed -i \
999         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
1000         -e 's|@host_cpu@|%{_target_cpu}|' \
1001         -e 's|@host_os@|%{_target_os}|' \
1002         macros/macros.in
1003
1004 %{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
1005 # pass CC and CXX too in case of building with some older configure macro
1006 %configure \
1007         CC="%{__newcc}" \
1008         CXX="%{__newcxx}" \
1009         CPP="%{__newcpp}" \
1010         WITH_PERL_VERSION=no \
1011         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
1012         --disable-silent-rules \
1013         --enable-shared \
1014         --enable-static \
1015         %{!?with_apidocs:--without-apidocs} \
1016         --with-beecrypt=external \
1017         --with-bugreport="http://bugs.pld-linux.org/" \
1018         --with-bzip2=external \
1019         --with-db=external \
1020         --with-dbapi=db \
1021         --with-file=external \
1022         --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
1023         --with-libelf \
1024         --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
1025         --with-lzma=external \
1026         --with-neon=%{?with_neon:external}%{!?with_neon:no} \
1027         --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/%%{_target}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
1028         --without-path-versioned \
1029         --with-pcre=external \
1030         --with-popt=external \
1031         %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
1032         %{!?with_python:--without-python} \
1033         --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
1034         --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
1035         --with-sepol=%{!?with_selinux:no}%{?with_selinux:external} \
1036         --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
1037         --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
1038         --with-vendor=pld \
1039         --with-xz=external \
1040         --with-zlib=external
1041
1042 %{__make} -j1 \
1043         CC="%{__cc}" \
1044         CXX="%{__cxx}" \
1045         CPP="%{__cpp}"
1046
1047 %{?with_apidocs:%{__make} apidocs}
1048
1049 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
1050         -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
1051 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
1052         -o tools/rpmdb_reset -ldb-%{reqdb_ver}
1053
1054 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
1055         echo "Error linking rpmdb tools!"
1056         exit 1
1057 fi
1058 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
1059         echo "Error linking rpmdb tools!"
1060         exit 1
1061 fi
1062
1063 %install
1064 rm -rf $RPM_BUILD_ROOT
1065 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
1066         $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
1067
1068 install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1069
1070 %{__make} -j1 install \
1071         pkgconfigdir=%{_pkgconfigdir} \
1072         DESTDIR=$RPM_BUILD_ROOT
1073
1074 # install ARCH macros
1075 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux
1076 install cpu-os-macros/noarch-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
1077
1078 %ifarch %{ix86}
1079 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{i386,i486,i586,i686,athlon,pentium3,pentium4}-linux
1080 install cpu-os-macros/athlon-linux/macros   $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
1081 install cpu-os-macros/i386-linux/macros     $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
1082 install cpu-os-macros/i486-linux/macros     $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
1083 install cpu-os-macros/i586-linux/macros     $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
1084 install cpu-os-macros/i686-linux/macros     $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
1085 install cpu-os-macros/pentium3-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
1086 install cpu-os-macros/pentium4-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
1087 %endif
1088
1089 %ifarch %{x8664}
1090 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{x86_64,ia32e,amd64}-linux
1091 install cpu-os-macros/x86_64-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
1092 install cpu-os-macros/ia32e-linux/macros  $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
1093 install cpu-os-macros/amd64-linux/macros  $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
1094 %endif
1095
1096 %ifarch %{ppc}
1097 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux
1098 install cpu-os-macros/ppc-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
1099 %endif
1100
1101 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
1102 # first platform file entry can't contain regexps
1103 %{_target_cpu}-%{_target_vendor}-linux
1104
1105 %ifarch x86_64
1106 x86_64-[^-]*-[Ll]inux(-gnu)?
1107 amd64-[^-]*-[Ll]inux(-gnu)?
1108 %endif
1109 %ifarch amd64
1110 amd64-[^-]*-[Ll]inux(-gnu)?
1111 x86_64-[^-]*-[Ll]inux(-gnu)?
1112 %endif
1113 %ifarch ia32e
1114 ia32e-[^-]*-[Ll]inux(-gnu)?
1115 x86_64-[^-]*-[Ll]inux(-gnu)?
1116 %endif
1117
1118 %ifarch athlon %{x8664}
1119 athlon-[^-]*-[Ll]inux(-gnu)?
1120 %endif
1121 %ifarch pentium4 athlon %{x8664}
1122 pentium4-[^-]*-[Ll]inux(-gnu)?
1123 %endif
1124 %ifarch pentium3 pentium4 athlon %{x8664}
1125 pentium3-[^-]*-[Ll]inux(-gnu)?
1126 %endif
1127 %ifarch i686 pentium3 pentium4 athlon %{x8664}
1128 i686-[^-]*-[Ll]inux(-gnu)?
1129 %endif
1130 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
1131 i586-[^-]*-[Ll]inux(-gnu)?
1132 %endif
1133 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
1134 i486-[^-]*-[Ll]inux(-gnu)?
1135 %endif
1136 %ifarch %{ix86} %{x8664}
1137 i386-[^-]*-[Ll]inux(-gnu)?
1138 %endif
1139
1140 %ifarch alpha
1141 alpha-[^-]*-[Ll]inux(-gnu)?
1142 %endif
1143
1144 %ifarch ia64
1145 ia64-[^-]*-[Ll]inux(-gnu)?
1146 %endif
1147
1148 %ifarch ppc64
1149 powerpc64-[^-]*-[Ll]inux(-gnu)?
1150 ppc64-[^-]*-[Ll]inux(-gnu)?
1151 %endif
1152 %ifarch %{ppc} ppc64
1153 powerpc-[^-]*-[Ll]inux(-gnu)?
1154 ppc-[^-]*-[Ll]inux(-gnu)?
1155 %endif
1156
1157 %ifarch s390x
1158 s390x-[^-]*-[Ll]inux(-gnu)?
1159 %endif
1160 %ifarch s390 s390x
1161 s390-[^-]*-[Ll]inux(-gnu)?
1162 %endif
1163
1164 %ifarch sparc64
1165 sparc64-[^-]*-[Ll]inux(-gnu)?
1166 sparcv8-[^-]*-[Ll]inux(-gnu)?
1167 sparcv9-[^-]*-[Ll]inux(-gnu)?
1168 %endif
1169 %ifarch sparcv9
1170 sparcv8-[^-]*-[Ll]inux(-gnu)?
1171 sparcv9-[^-]*-[Ll]inux(-gnu)?
1172 %endif
1173 %ifarch sparc sparcv9 sparc64
1174 sparc-[^-]*-[Ll]inux(-gnu)?
1175 %endif
1176
1177 noarch-[^-]*-.*
1178 EOF
1179
1180 # Squash Extra Blank Lines
1181 %{__sed} -i -e '/./,/^$/!d' $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
1182
1183 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1184 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1185 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
1186 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
1187 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.a
1188 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.la
1189 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-provides
1190 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-requires
1191
1192 # not installed since 4.4.8 (-tools-perl subpackage)
1193 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1194
1195 install %{SOURCE1} doc/manual/groups
1196 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
1197 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1198 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
1199 install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1200 install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
1201 install scripts/find-php*       $RPM_BUILD_ROOT%{_rpmlibdir}
1202 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
1203 cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
1204 install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
1205 install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
1206 install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
1207
1208 install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
1209
1210 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1211
1212 install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
1213 install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
1214 install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1215 install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1216 install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1217 install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
1218 install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
1219
1220 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1221 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
1222 install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
1223 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1224 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1225 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
1226
1227 install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1228 install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1229 install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
1230
1231 # create macro loading wrappers for backward compatibility
1232 for m in gstreamer java mono perl php python; do
1233         echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
1234 done
1235
1236 # for rpm -e|-U --repackage
1237 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1238 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
1239
1240 # move rpm to /bin
1241 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1242 # move essential libs to /lib (libs that /bin/rpm links to)
1243 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
1244         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1245         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
1246 done
1247
1248 # Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1249 mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1250
1251 %if %{with python}
1252 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1253 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
1254
1255 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
1256 %endif
1257
1258 # wrong location, not used anyway
1259 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
1260 # utils dropped in 5.4 -- their manuals
1261 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
1262 # script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1263 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
1264
1265 %find_lang %{name}
1266
1267 %{__rm} -rf manual
1268 cp -a doc/manual manual
1269 %{__rm} -f manual/Makefile*
1270
1271 %clean
1272 rm -rf $RPM_BUILD_ROOT
1273
1274 %pretrans
1275 # this needs to be a dir
1276 if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
1277         umask 022
1278         mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1279         mkdir %{_sysconfdir}/rpm/sysinfo
1280 fi
1281
1282 %posttrans
1283 if [ -e /var/lib/rpm/Packages ] && \
1284                 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
1285         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
1286                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
1287                 echo
1288                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
1289                 echo
1290         fi
1291         echo
1292         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
1293         echo 'you should ignore it and restart poldek'
1294         echo
1295         %{_rpmlibdir}/bin/dbupgrade.sh
1296 fi
1297
1298 %triggerpostun -- %{name} < 4.4.9-44
1299 %{_rpmlibdir}/hrmib-cache
1300
1301 %post   lib -p /sbin/ldconfig
1302 %postun lib -p /sbin/ldconfig
1303
1304 %pretrans build
1305 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
1306
1307 %files -f %{name}.lang
1308 %defattr(644,root,root,755)
1309 %doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
1310
1311 %dir /etc/pki/rpm-gpg
1312 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1313
1314 %attr(755,root,root) /bin/rpm
1315
1316 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
1317 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
1318 %dir %{_sysconfdir}/rpm/sysinfo
1319 # these are ok to be replaced
1320 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
1321 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1322
1323 %{_mandir}/man8/rpm.8*
1324 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1325 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1326 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1327 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1328 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1329
1330 %dir /var/lib/rpm
1331 %dir /var/lib/rpm/log
1332 %dir /var/lib/rpm/tmp
1333 %config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
1334 %dir %attr(700,root,root) /var/spool/repackage
1335 %dir /var/lock/rpm
1336 /var/lock/rpm/transaction
1337
1338 # exported package NVRA (stamped with install tid)
1339 # net-snmp hrSWInstalledName queries, bash-completions
1340 %dir /var/cache/hrmib
1341
1342 %{_rpmlibdir}/qf
1343 %{_rpmlibdir}/rpmpopt*
1344 %{_rpmlibdir}/macros
1345 %dir %{_rpmlibdir}/macros.d
1346 %{_rpmlibdir}/macros.d/pld
1347 %{_rpmlibdir}/cpuinfo.yaml
1348 %{_rpmlibdir}/noarch-*
1349 %ifarch %{ix86}
1350 %{_rpmlibdir}/i?86*
1351 %{_rpmlibdir}/pentium*
1352 %{_rpmlibdir}/athlon*
1353 %endif
1354 %ifarch alpha
1355 %{_rpmlibdir}/alpha*
1356 %endif
1357 %ifarch ia64
1358 %{_rpmlibdir}/ia64*
1359 %endif
1360 %ifarch mips mipsel mips64 mips64el
1361 %{_rpmlibdir}/mips*
1362 %endif
1363 %ifarch %{ppc}
1364 %{_rpmlibdir}/ppc*
1365 %endif
1366 %ifarch sparc sparc64
1367 %{_rpmlibdir}/sparc*
1368 %endif
1369 %ifarch %{x8664}
1370 %{_rpmlibdir}/amd64*
1371 %{_rpmlibdir}/ia32e*
1372 %{_rpmlibdir}/x86_64*
1373 %endif
1374
1375 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1376
1377 %dir %{_rpmlibdir}/bin
1378 %attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
1379 %attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
1380 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
1381 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
1382
1383 %files base
1384 %defattr(644,root,root,755)
1385 %dir %{_sysconfdir}/rpm
1386 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1387 %dir %{_rpmlibdir}
1388 %attr(755,root,root) %{_bindir}/banner.sh
1389 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1390 %dir /var/lib/banner
1391
1392 %files lib
1393 %defattr(644,root,root,755)
1394 %attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1395 %attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1396 %attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1397 %attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
1398 %attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
1399 %attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
1400
1401 %files devel
1402 %defattr(644,root,root,755)
1403 %attr(755,root,root) %{_libdir}/librpm.so
1404 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1405 %attr(755,root,root) %{_libdir}/librpmbuild.so
1406 %attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
1407 %attr(755,root,root) %{_libdir}/librpmconstant.so
1408 %attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
1409 %attr(755,root,root) %{_libdir}/librpmdb.so
1410 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1411 %attr(755,root,root) %{_libdir}/librpmio.so
1412 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1413 %attr(755,root,root) %{_libdir}/librpmmisc.so
1414 %attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
1415 %{_libdir}/librpm*.la
1416 %{_includedir}/rpm
1417 %{_pkgconfigdir}/*.pc
1418
1419 %files static
1420 %defattr(644,root,root,755)
1421 %{_libdir}/librpm*.a
1422
1423 %files utils
1424 %defattr(644,root,root,755)
1425 %attr(755,root,root) %{_bindir}/rpm2cpio
1426 %attr(755,root,root) %{_bindir}/rpmconstant
1427 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1428 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1429 %attr(755,root,root) %{_rpmlibdir}/tgpg
1430 %attr(755,root,root) %{_rpmlibdir}/bin/chroot
1431 %attr(755,root,root) %{_rpmlibdir}/bin/cp
1432 %attr(755,root,root) %{_rpmlibdir}/bin/debugedit
1433 %attr(755,root,root) %{_rpmlibdir}/bin/find
1434 %attr(755,root,root) %{_rpmlibdir}/bin/mgo
1435 %attr(755,root,root) %{_rpmlibdir}/bin/mtree
1436 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1437 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1438 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1439 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
1440 %if %{with selinux}
1441 %attr(755,root,root) %{_rpmlibdir}/bin/semodule
1442 %attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1443 %endif
1444 %if %{without system_lua}
1445 %attr(755,root,root) %{_rpmlibdir}/bin/lua
1446 %attr(755,root,root) %{_rpmlibdir}/bin/luac
1447 %attr(755,root,root) %{_rpmlibdir}/bin/rpmlua
1448 %attr(755,root,root) %{_rpmlibdir}/bin/rpmluac
1449 %endif
1450 %{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
1451 %attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
1452 %{_mandir}/man8/rpm2cpio.8*
1453 %{_mandir}/man8/rpmconstant.8*
1454 %{_mandir}/man8/rpmdeps.8*
1455 %{_mandir}/man8/rpmmtree.8*
1456 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1457 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1458 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1459 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1460
1461 %files utils-perl
1462 %defattr(644,root,root,755)
1463 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1464
1465 %if %{with static}
1466 %files utils-static
1467 %defattr(644,root,root,755)
1468 %attr(755,root,root) %{_bindir}/rpm[ieu]
1469 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1470 %endif
1471
1472 %files build
1473 %defattr(644,root,root,755)
1474 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1475 %attr(755,root,root) %{_rpmlibdir}/brp-*
1476 %attr(755,root,root) %{_rpmlibdir}/check-files
1477 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1478 %attr(755,root,root) %{_rpmlibdir}/cross-build
1479 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1480 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1481 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1482 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1483 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1484 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1485 %attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
1486 # needs hacked pkg-config to return anything
1487 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1488 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1489 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
1490 %{!?with_sqlite:%attr(755,root,root) %{_rpmlibdir}/bin/dbsql}
1491 %attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1492 %attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
1493 %attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1494 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspec
1495 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1496 %attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1497 %attr(755,root,root) %{_rpmlibdir}/bin/wget
1498 %attr(755,root,root) %{_rpmlibdir}/vcheck
1499 # not used yet ... these six depend on perl
1500 %attr(755,root,root) %{_rpmlibdir}/http.req
1501 # we always used scripts provided by mono-devel, maybe move them here
1502 #%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1503 #%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
1504
1505 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
1506 # must be here for "Requires: rpm-*prov" to work
1507 %{_rpmlibdir}/macros.d/cmake
1508 %{_rpmlibdir}/macros.d/gstreamer
1509 %{_rpmlibdir}/macros.d/java
1510 %{_rpmlibdir}/macros.d/kernel
1511 %{_rpmlibdir}/macros.d/libtool
1512 %{_rpmlibdir}/macros.d/mono
1513 %{_rpmlibdir}/macros.d/perl
1514 %{_rpmlibdir}/macros.d/php
1515 %{_rpmlibdir}/macros.d/pkgconfig
1516 %{_rpmlibdir}/macros.d/python
1517 %{_rpmlibdir}/macros.d/ruby
1518 %{_rpmlibdir}/macros.d/selinux
1519 %{_rpmlibdir}/macros.d/tcl
1520 %{_rpmlibdir}/macros.rpmbuild
1521 # compat wrappers
1522 %{_rpmlibdir}/macros.gstreamer
1523 %{_rpmlibdir}/macros.java
1524 %{_rpmlibdir}/macros.mono
1525 %{_rpmlibdir}/macros.perl
1526 %{_rpmlibdir}/macros.php
1527 %{_rpmlibdir}/macros.python
1528
1529 %attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1530 %attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1531
1532 %attr(755,root,root) %{_bindir}/gendiff
1533 %attr(755,root,root) %{_bindir}/rpmbuild
1534
1535 %dir %{_rpmlibdir}/helpers
1536 %attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
1537
1538 %{_mandir}/man1/gendiff.1*
1539 %{_mandir}/man8/rpmbuild.8*
1540 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1541 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1542 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1543
1544 %files javaprov
1545 %defattr(644,root,root,755)
1546 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1547 # needs jar (any jdk), jcf-dump (gcc-java) to work
1548 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1549
1550 %files rubyprov
1551 %defattr(644,root,root,755)
1552 %attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1553 %attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1554
1555 %files perlprov
1556 %defattr(644,root,root,755)
1557 %attr(755,root,root) %{_rpmlibdir}/perl.*
1558 %attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1559 %attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1560
1561 %files pythonprov
1562 %defattr(644,root,root,755)
1563 %attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
1564 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1565
1566 %files php-pearprov
1567 %defattr(644,root,root,755)
1568 %attr(755,root,root) %{_rpmlibdir}/php*
1569 %attr(755,root,root) %{_rpmlibdir}/find-php*
1570
1571 %if %{with python}
1572 %files -n python-rpm
1573 %defattr(644,root,root,755)
1574 %dir %{py_sitedir}/rpm
1575 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1576 %{py_sitedir}/rpm/*.py[co]
1577 %endif
1578
1579 %if %{with apidocs}
1580 %files apidocs
1581 %defattr(644,root,root,755)
1582 %doc apidocs
1583 %endif
This page took 0.325091 seconds and 3 git commands to generate.