]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
ee72442a19832772984b97b736da62b0b60960ae
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - manuals are not compressed
4 # - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
5 #   matches ELF first
6 # - repackaging when lzma is not installed (todo: fix digest signature of header)
7 #   rpmbuild computes digest when writing package to temporary file, then adds a few
8 #   tags (incl. digest) and writes whole package to destination file;
9 #   repackaging uses unchanged "immutable header" image from original rpm, also
10 #   preserving payload format and compressor from original rpm, _not_ current settings
11 # - TODO: add macros for some ppc, mipsel, alpha and sparc
12 # - uppackaged list:
13 #   /usr/lib/rpm/http.req
14 #   /usr/lib/rpm/install-sh
15 #   /usr/lib/rpm/mono-find-provides
16 #   /usr/lib/rpm/mono-find-requires
17 #   /usr/lib/rpm/osgideps.pl
18 #   /usr/lib/rpm/perldeps.pl
19 #   /usr/lib/rpm/rpm2cpio
20 #   /usr/lib/rpm/symclash.py
21 #   /usr/lib/rpm/symclash.sh
22 #   /usr/lib/rpm/vcheck
23 #   /usr/share/man/ja/man8/rpmcache.8
24 #   /usr/share/man/ja/man8/rpmgraph.8
25 #   /usr/share/man/man8/rpmcache.8
26 #   /usr/share/man/man8/rpmconstant.8
27 #   /usr/share/man/man8/rpmgraph.8
28 #   /usr/share/man/pl/man8/rpmcache.8
29 #   /usr/share/man/pl/man8/rpmgraph.8
30 #
31 # Conditional build:
32 %bcond_with     static          # build static rpm+rpmi
33 %bcond_with     autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
34 %bcond_without  python          # don't build python bindings
35 %bcond_without  selinux         # build without selinux support
36 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
37 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
38 %bcond_without  db              # BerkeleyDB
39 %bcond_with     sqlite          # build with SQLite support
40 %bcond_with     sqlite_dbapi    # default database backend is sqlite
41 # force_cc              - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
42 # force_cxx             - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
43 # force_cpp             - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
44 #
45 %if %{with sqlite_dbapi}
46 %define with_sqlite     1
47 %endif
48
49 %if %{without db} && %{without sqlite}
50 %{error:Need db or sqlite}
51 ERROR
52 %endif
53
54 #
55 # versions of required libraries
56 %define reqdb_ver       4.6.18
57 %define reqpopt_ver     1.10.8
58 %define beecrypt_ver    2:4.1.2-4
59 %define find_lang_rev   1.27
60 %define sover   5.0
61 Summary:        RPM Package Manager
62 Summary(de.UTF-8):      RPM Packet-Manager
63 Summary(es.UTF-8):      Gestor de paquetes RPM
64 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
65 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
66 Summary(ru.UTF-8):      Менеджер пакетов от RPM
67 Summary(uk.UTF-8):      Менеджер пакетів від RPM
68 Name:           rpm
69 Version:        5.0.2
70 Release:        0.1
71 License:        LGPL
72 Group:          Base
73 Source0:        http://rpm5.org/files/rpm/rpm-5.0/%{name}-%{version}.tar.gz
74 # Source0-md5:  596aaf5cd9dea7195f625530bc89e684
75 Source1:        %{name}.groups
76 Source2:        %{name}.platform
77 Source3:        %{name}-install-tree
78 Source4:        %{name}-find-spec-bcond
79 Source5:        %{name}-find-lang
80 Source6:        %{name}-groups-po.awk
81 Source7:        %{name}-compress-doc
82 Source8:        %{name}-check-files
83 Source9:        %{name}-php-provides
84 Source10:       %{name}-php-requires
85 Source11:       %{name}.sysinfo
86 Source12:       perl.prov
87 Source13:       %{name}-user_group.sh
88 Source14:       %{name}.sysconfig
89 Source15:       %{name}-macros.java
90 Source16:       %{name}-java-requires
91 # http://svn.pld-linux.org/banner.sh/
92 Source17:       banner.sh
93 Source18:       %{name}-pld.macros
94
95 Source100:      %{name}-macros-athlon
96 Source101:      %{name}-macros-i386
97 Source102:      %{name}-macros-i486
98 Source103:      %{name}-macros-i586
99 Source104:      %{name}-macros-i686
100 Source105:      %{name}-macros-noarch
101 Source106:      %{name}-macros-pentium3
102 Source107:      %{name}-macros-pentium4
103 Source108:      %{name}-macros-ppc
104 Source109:      %{name}-macros-x86_64
105 Source110:      %{name}-macros-ia32e
106 Source111:      %{name}-macros-amd64
107
108 #Patch0:                %{name}-pl.po.patch
109 Patch1:         %{name}-man_pl.patch
110 Patch3:         %{name}-rpmpopt.patch
111 Patch4:         %{name}-perl-macros.patch
112 Patch5:         %{name}-perl-req-perlfile.patch
113 Patch6:         %{name}-noexpand.patch
114 Patch7:         %{name}-scripts-closefds.patch
115 Patch8:         %{name}-php-macros.patch
116 Patch9:         %{name}-gettext-in-header.patch
117 Patch10:        %{name}-compress-doc.patch
118
119 Patch14:        %{name}-etc_dir.patch
120 Patch16:        %{name}-php-deps.patch
121
122 Patch18:        %{name}-perl_req.patch
123
124 Patch23:        %{name}-pkgconfigdeps.patch
125
126 Patch26:        %{name}-notsc.patch
127 Patch27:        %{name}-hack-norpmlibdep.patch
128
129 Patch32:        %{name}-pld-autodep.patch
130 Patch35:        %{name}-perl_req-INC_dirs.patch
131 Patch36:        %{name}-debuginfo.patch
132 Patch37:        %{name}-doxygen_hack.patch
133
134 Patch42:        %{name}-old-fileconflicts-behaviour.patch
135
136 Patch46:        %{name}-mono.patch
137 Patch47:        %{name}-javadeps.patch
138
139 Patch52:        %{name}-morearchs.patch
140
141 Patch55:        %{name}-truncate-cvslog.patch
142
143 Patch58:        %{name}-repackage-wo-lzma.patch
144 Patch59:        %{name}-libtool-deps.patch
145
146 Patch61:        %{name}-sparc64.patch
147 URL:            http://rpm5.org/
148 BuildRequires:  autoconf >= 2.57
149 BuildRequires:  automake >= 1.4
150 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
151 BuildRequires:  bzip2-devel >= 1.0.2-17
152 %{?with_db:BuildRequires:       db-devel >= %{reqdb_ver}}
153 BuildRequires:  elfutils-devel >= 0.108
154 %ifnarch sparc64
155 # -fPIE/-pie
156 BuildRequires:  gcc >= 5:3.4
157 %endif
158 BuildRequires:  gettext-devel >= 0.11.4-2
159 BuildRequires:  libmagic-devel
160 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.18}
161 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
162 BuildRequires:  libstdc++-devel
163 BuildRequires:  libtool >= 1:1.4.2-9
164 %if %{with neon}
165 BuildRequires:  libxml2-devel
166 BuildRequires:  neon-devel >= 0.25.5
167 %endif
168 BuildRequires:  patch >= 2.2
169 BuildRequires:  popt-devel >= %{reqpopt_ver}
170 %{?with_python:BuildRequires:   python-devel >= 1:2.5}
171 BuildRequires:  python-modules >= 1:2.5
172 BuildRequires:  rpm-perlprov
173 %{?with_python:BuildRequires:   rpm-pythonprov}
174 %{?with_sqlite:BuildRequires:   sqlite3-devel}
175 BuildRequires:  zlib-devel
176 %if %{with static}
177 # Require static library only for static build
178 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
179 BuildRequires:  bzip2-static >= 1.0.2-17
180 %{?with_db:BuildRequires:       db-static >= %{reqdb_ver}}
181 BuildRequires:  elfutils-static
182 BuildRequires:  glibc-static >= 2.2.94
183 BuildRequires:  libmagic-static
184 %{?with_selinux:BuildRequires:  libselinux-static >= 1.18}
185 BuildRequires:  popt-static >= %{reqpopt_ver}
186 BuildRequires:  zlib-static
187 %endif
188 Requires:       %{name}-base = %{version}-%{release}
189 Requires:       %{name}-lib = %{version}-%{release}
190 Requires:       beecrypt >= %{beecrypt_ver}
191 Requires:       popt >= %{reqpopt_ver}
192 %{!?with_static:Obsoletes:      rpm-utils-static}
193 Conflicts:      glibc < 2.2.92
194 # db4.6 poldek needed
195 Conflicts:      poldek < 0.21-0.20070703.00.3
196 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
197
198 %define         _binary_payload         w9.gzdio
199 %define         _noPayloadPrefix        1
200
201 # don't require very fresh rpm.macros to build
202 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
203 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
204 %define         ppc     ppc ppc7400 ppc7450
205 %define         x8664   amd64 ia32e x86_64
206
207 # stabilize new build environment
208 %define         __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
209 %define         __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
210 %define         __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
211
212 %define         _rpmlibdir /usr/lib/rpm
213
214 %define         specflags       -fno-strict-aliasing
215
216 %description
217 RPM is a powerful package manager, which can be used to build,
218 install, query, verify, update, and uninstall individual software
219 packages. A package consists of an archive of files, and package
220 information, including name, version, and description.
221
222 %description -l de.UTF-8
223 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
224 Installation, Anfrage, Verifizierung, Aktualisierung und
225 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
226 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
227 Beschreibung.
228
229 %description -l es.UTF-8
230 RPM es un poderoso administrador de paquetes, que puede ser usado para
231 construir, instalar, pesquisar, verificar, actualizar y desinstalar
232 paquetes individuales de software. Un paquete consiste en un
233 almacenaje de archivos, y información sobre el paquete, incluyendo
234 nombre, versión y descripción.
235
236 %description -l pl.UTF-8
237 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
238 przebudowanie, instalację czy weryfikację dowolnego pakietu.
239 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
240 plików wchodzących w skład pakietu, zależności od innych pakietów, są
241 przechowywane w bazie danych i można je uzyskać za pomocą opcji
242 odpytywania programu rpm.
243
244 %description -l pt_BR.UTF-8
245 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
246 construir, instalar, pesquisar, verificar, atualizar e desinstalar
247 pacotes individuais de software. Um pacote consiste de um conjunto de
248 arquivos e informações adicionais, incluindo nome, versão e descrição
249 do pacote, permissões dos arquivos, etc.
250
251 %description -l ru.UTF-8
252 RPM - это мощный менеджер пакетов, который может быть использован для
253 создания, инсталляции, запросов (query), проверки, обновления и
254 удаления программных пакетов. Пакет состоит из файлового архива и
255 служебной информации, включающей название, версию, описание и другие
256 данные о пакете.
257
258 %description -l uk.UTF-8
259 RPM - це потужний менеджер пакетів, що може бути використаний для
260 створення, інсталяції, запитів (query), перевірки, поновлення та
261 видалення програмних пакетів. Пакет складається з файлового архіву та
262 службової інформації, що містить назву, версію, опис та іншу
263 інформацію про пакет.
264
265 %package base
266 Summary:        RPM base package - scripts used by rpm packages themselves
267 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
268 Group:          Base
269 Requires:       filesystem
270 Obsoletes:      vserver-rpm
271
272 %description base
273 The RPM base package contains scripts used by rpm packages themselves.
274 These include:
275 - scripts for adding/removing groups and users needed for rpm
276   packages,
277 - banner.sh to display %%banner messages from rpm scriptlets.
278
279 %description base -l pl.UTF-8
280 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
281 Zawiera on:
282 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
283 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
284
285 %package lib
286 Summary:        RPMs library
287 Summary(pl.UTF-8):      Biblioteki RPM-a
288 Group:          Libraries
289 Requires:       beecrypt >= %{beecrypt_ver}
290 %{?with_db:Requires:    db >= %{reqdb_ver}}
291 %{?with_selinux:Requires:       libselinux >= 1.18}
292 Requires:       libmagic >= 1.15-2
293 Requires:       popt >= %{reqpopt_ver}
294 Obsoletes:      rpm-libs
295 Obsoletes:      rpm-apidocs
296 # avoid SEGV caused by mixed db versions
297 Conflicts:      poldek < 0.18.1-16
298 %{?with_suggest_tags:Suggests:  lzma}
299
300 %description lib
301 RPMs library.
302
303 %description lib -l pl.UTF-8
304 Biblioteki RPM-a.
305
306 %package devel
307 Summary:        Header files for rpm libraries
308 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
309 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
310 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
311 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
312 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
313 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
314 Group:          Development/Libraries
315 Requires:       %{name}-lib = %{version}-%{release}
316 Requires:       beecrypt-devel >= %{beecrypt_ver}
317 Requires:       bzip2-devel
318 %{?with_db:Requires:    db-devel >= %{reqdb_ver}}
319 Requires:       elfutils-devel
320 Requires:       libmagic-devel
321 %{?with_selinux:Requires:       libselinux-devel}
322 Requires:       popt-devel >= %{reqpopt_ver}
323 Requires:       zlib-devel
324
325 %description devel
326 The RPM packaging system includes C libraries that make it easy to
327 manipulate RPM packages and databases. They are intended to ease the
328 creation of graphical package managers and other tools that need
329 intimate knowledge of RPM packages. This package contains header files
330 for these libraries.
331
332 %description devel -l de.UTF-8
333 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
334 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
335 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
336 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
337
338 %description devel -l es.UTF-8
339 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
340 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
341 facilitar la creación de administradores gráficos de paquetes y otras
342 herramientas que necesiten un conocimiento profundo de paquetes RPM.
343
344 %description devel -l pl.UTF-8
345 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
346 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
347 graficznych programów zarządzających pakietami oraz innych narzędzi,
348 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
349 zawiera pliki nagłówkowe wspomnianych bibliotek.
350
351 %description devel -l pt_BR.UTF-8
352 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
353 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
354 facilitar a criação de gerenciadores gráficos de pacotes e outras
355 ferramentas que precisem de conhecimento profundo de pacotes RPM.
356
357 %description devel -l ru.UTF-8
358 Система управления пакетами RPM содержит библиотеку C, которая
359 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
360 Эта библиотека предназначена для облегчения создания графических
361 пакетных менеджеров и других утилит, которым необходимо работать с
362 пакетами RPM.
363
364 %description devel -l uk.UTF-8
365 Система керування пакетами RPM містить бібліотеку C, котра спрощує
366 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
367 призначена для полегшення створення графічних пакетних менеджерів та
368 інших утиліт, що працюють з пакетами RPM.
369
370 %package static
371 Summary:        RPM static libraries
372 Summary(de.UTF-8):      RPMs statische Libraries
373 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
374 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
375 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
376 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
377 Group:          Development/Libraries
378 Requires:       %{name}-devel = %{version}-%{release}
379 Requires:       beecrypt-static >= %{beecrypt_ver}
380 Requires:       bzip2-static
381 %{?with_db:Requires:    db-static >= %{reqdb_ver}}
382 Requires:       elfutils-static
383 Requires:       libmagic-static
384 Requires:       popt-static >= %{reqpopt_ver}
385 Requires:       zlib-static
386
387 %description static
388 RPM static libraries.
389
390 %description static -l de.UTF-8
391 RPMs statische Libraries.
392
393 %description static -l pl.UTF-8
394 Biblioteki statyczne RPM-a.
395
396 %description static -l pt_BR.UTF-8
397 Bibliotecas estáticas para desenvolvimento.
398
399 %description static -l ru.UTF-8
400 Система управления пакетами RPM содержит библиотеку C, которая
401 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
402 Это статическая библиотека RPM.
403
404 %description static -l uk.UTF-8
405 Система керування пакетами RPM містить бібліотеку C, котра спрощує
406 роботу з пакетами RPM та відповідними базами даних. Це статична
407 бібліотека RPM.
408
409 %package utils
410 Summary:        Additional utilities for managing RPM packages and database
411 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
412 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
413 Group:          Applications/File
414 Requires:       %{name} = %{version}-%{release}
415 Requires:       popt >= %{reqpopt_ver}
416
417 %description utils
418 Additional utilities for managing RPM packages and database.
419
420 %description utils -l de.UTF-8
421 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
422
423 %description utils -l pl.UTF-8
424 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
425
426 %package utils-perl
427 Summary:        Additional utilities for managing RPM packages and database
428 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
429 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
430 Group:          Applications/File
431 Requires:       %{name}-utils = %{version}-%{release}
432 Requires:       popt >= %{reqpopt_ver}
433
434 %description utils-perl
435 Additional utilities for managing RPM packages and database.
436
437 %description utils-perl -l de.UTF-8
438 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
439
440 %description utils-perl -l pl.UTF-8
441 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
442
443 %package utils-static
444 Summary:        Static rpm utilities
445 Summary(pl.UTF-8):      Statyczne narzędzia rpm
446 Group:          Applications/System
447 Requires:       %{name} = %{version}-%{release}
448
449 %description utils-static
450 Static rpm utilities for repairing system in case something with
451 shared libraries used by rpm become broken. Currently it contains rpmi
452 binary, which can be used to install/upgrade/remove packages without
453 using shared libraries (well, in fact with exception of NSS modules).
454
455 %description utils-static -l pl.UTF-8
456 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
457 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
458 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
459 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
460 (z wyjątkiem modułów NSS).
461
462 %package build
463 Summary:        Scripts for building binary RPM packages
464 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
465 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
466 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
467 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
468 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
469 Group:          Applications/File
470 Requires(pre):  findutils
471 Requires:       %{name}-build-macros >= 1.314
472 Requires:       %{name}-utils = %{version}-%{release}
473 Requires:       /bin/id
474 Requires:       awk
475 # we need fixed binutils for -feliminate-dwarf2-dups
476 Requires:       binutils >= 3:2.17.50.0.3-2
477 Requires:       bzip2
478 Requires:       chrpath >= 0.10-4
479 Requires:       cpio
480 Requires:       diffutils
481 Requires:       elfutils
482 Requires:       file >= 4.17
483 Requires:       fileutils
484 Requires:       findutils
485 Requires:       gcc >= 5:3.4
486 Requires:       glibc-devel
487 Requires:       grep
488 Requires:       gzip
489 Requires:       lzma
490 Requires:       make
491 Requires:       patch
492 Requires:       sed
493 Requires:       sh-utils
494 Requires:       tar
495 Requires:       textutils
496 Provides:       rpmbuild(find_lang) = %{find_lang_rev}
497 Provides:       rpmbuild(monoautodeps)
498 Provides:       rpmbuild(noauto) = 3
499 %ifarch %{x8664}
500 Conflicts:      automake < 1:1.7.9-2
501 Conflicts:      libtool < 2:1.5-13
502 %endif
503
504 %description build
505 Scripts for building binary RPM packages.
506
507 %description build -l de.UTF-8
508 Scripts fürs Bauen binärer RPM-Pakete.
509
510 %description build -l pl.UTF-8
511 Skrypty pomocnicze do budowania binarnych RPM-ów.
512
513 %description build -l pt_BR.UTF-8
514 Este pacote contém scripts e programas executáveis que são usados para
515 construir pacotes usando o RPM.
516
517 %description build -l ru.UTF-8
518 Различные вспомогательные скрипты и исполняемые программы, которые
519 используются для сборки RPM'ов.
520
521 %description build -l uk.UTF-8
522 Різноманітні допоміжні скрипти та утиліти, які використовуються для
523 побудови RPM'ів.
524
525 %package javaprov
526 Summary:        Additional utilities for checking Java provides/requires in RPM packages
527 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
528 Group:          Applications/File
529 Requires:       %{name} = %{version}-%{release}
530 Requires:       file
531 Requires:       findutils >= 1:4.2.26
532 Requires:       mktemp
533 Requires:       unzip
534
535 %description javaprov
536 Additional utilities for checking Java provides/requires in RPM
537 packages.
538
539 %description javaprov -l pl.UTF-8
540 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
541 RPM.
542
543 %package perlprov
544 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
545 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
546 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
547 Group:          Applications/File
548 Requires:       %{name} = %{version}-%{release}
549 Requires:       perl-devel
550 Requires:       perl-modules
551
552 %description perlprov
553 Additional utilities for checking Perl provides/requires in RPM
554 packages.
555
556 %description perlprov -l de.UTF-8
557 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
558
559 %description perlprov -l pl.UTF-8
560 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
561 pakietach RPM.
562
563 %package pythonprov
564 Summary:        Python macros, which simplifies creation of RPM packages with Python software
565 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
566 Group:          Applications/File
567 Requires:       %{name} = %{version}-%{release}
568 Requires:       python
569 Requires:       python-modules
570
571 %description pythonprov
572 Python macros, which simplifies creation of RPM packages with Python
573 software.
574
575 %description pythonprov -l pl.UTF-8
576 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
577 Pythonie.
578
579 %package php-pearprov
580 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
581 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
582 Group:          Applications/File
583 Requires:       %{name} = %{version}-%{release}
584 Requires:       sed >= 4.0
585
586 %description php-pearprov
587 Additional utilities for checking PHP PEAR provides/requires in RPM
588 packages.
589
590 %description php-pearprov -l pl.UTF-8
591 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
592 pakietach RPM.
593
594 %package -n python-rpm
595 Summary:        Python interface to RPM library
596 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
597 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
598 Group:          Development/Languages/Python
599 Requires:       %{name} = %{version}-%{release}
600 %pyrequires_eq  python
601 Obsoletes:      rpm-python
602
603 %description -n python-rpm
604 The rpm-python package contains a module which permits applications
605 written in the Python programming language to use the interface
606 supplied by RPM (RPM Package Manager) libraries.
607
608 This package should be installed if you want to develop Python
609 programs that will manipulate RPM packages and databases.
610
611 %description -n python-rpm -l pl.UTF-8
612 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
613 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
614
615 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
616 Pythonie programy manipulujące pakietami i bazami danych rpm.
617
618 %description -n python-rpm -l pt_BR.UTF-8
619 O pacote rpm-python contém um módulo que permite que aplicações
620 escritas em Python utilizem a interface fornecida pelas bibliotecas
621 RPM (RPM Package Manager).
622
623 Esse pacote deve ser instalado se você quiser desenvolver programas em
624 Python para manipular pacotes e bancos de dados RPM.
625
626 %prep
627 %setup -q
628
629 # APPLIED ALREADY? translationproject.org is used now
630 #%%patch0 -p1
631 %patch1 -p1
632 %patch3 -p1
633 %patch4 -p1
634 %patch5 -p1
635 %patch6 -p1
636 %patch7 -p1
637 %patch8 -p1
638 %patch9 -p1
639 %patch10 -p1
640 # CHECK ME - macrofiles: ~/etc could be used
641 #%%patch14 -p1
642 %patch16 -p1
643 %patch18 -p1
644 echo '%%define  __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
645 echo '%%define  __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
646 echo '# obsoleted file' > macros.python
647 echo '%%define  __php_provides  /usr/lib/rpm/php.prov' > macros.php
648 echo '%%define  __php_requires  /usr/lib/rpm/php.req' >> macros.php
649 echo '%%define  __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
650 echo '%%define  __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
651 install %{SOURCE5} scripts/find-lang.sh
652 install %{SOURCE9} scripts/php.prov.in
653 install %{SOURCE10} scripts/php.req.in
654 install %{SOURCE12} scripts/perl.prov
655 %patch23 -p1
656
657 %ifarch i386 i486
658 # disable TSC
659 %patch26 -p1
660 %endif
661 %patch27 -p1
662 %patch32 -p1
663 %patch35 -p0
664 %patch36 -p1
665 %patch37 -p1
666 %patch42 -p1
667 %patch46 -p1
668 %patch47 -p1
669 # OLD COMMENTED OUT
670 #%%patch52 -p1
671 %patch55 -p1
672 %patch58 -p1
673 %patch59 -p1
674 %ifarch sparc64
675 %patch61 -p1
676 %endif
677
678 cd scripts
679 mv -f perl.req perl.req.in
680 mv -f perl.prov perl.prov.in
681 cd ..
682
683 # generate Group translations to *.po
684 awk -f %{SOURCE6} %{SOURCE1}
685
686 # update macros paths
687 #for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
688 #       sed -e 's@lib/rpm/redhat@lib/rpm/pld@g' $f > ${f}.tmp
689 #       mv -f ${f}.tmp $f
690 #done
691
692 %build
693 rev=$(awk '/^#.*Id:.*/{print $4}' scripts/find-lang.sh)
694 if [ "$rev" != "%find_lang_rev" ]; then
695         : Update find_lang_rev define to $rev, and retry
696         exit 1
697 fi
698
699 %{__libtoolize}
700 %{__autopoint}
701 %{__aclocal}
702 %{__autoheader}
703 %{__autoconf}
704 %{__automake}
705
706 # config.guess doesn't handle athlon, so we have to change it by hand.
707 # rpm checks for CPU type at runtime, but it looks better
708 #sed -i -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' -e 's|@host_cpu@|%{_target_cpu}|' macros.in
709
710 # pass CC and CXX too in case of building with some older configure macro
711 # disable perl-RPM2 build, we have it in separate spec
712 %configure \
713         CC="%{__newcc}" \
714         CXX="%{__newcxx}" \
715         CPP="%{__newcpp}" \
716         WITH_PERL_VERSION=no \
717         %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
718         --enable-shared \
719         --enable-static \
720         %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
721         %{!?with_python:--without-python} \
722         --with%{!?with_selinux:out}-selinux \
723         --with-libelf \
724         --with-zlib=external \
725         --with-bzip2=external \
726         --with-beecrypt=external \
727         --with-neon=%{?with_neon:external}%{!?with_neon:no} \
728         --with-file=external \
729         --with-popt=external \
730         --with-db=%{?with_db:external}%{!?with_db:no} \
731         --with-sqlite=%{?with_sqlite:external}%{!?with_sqlite:no} \
732         --with-dbapi=%{!?sqlite_dbapi:db}%{?sqlite_dbapi:sqlite} \
733         --with-lua=internal \
734         --with-pcre=no \
735         --with-keyutils=none \
736         --without-path-versioned \
737         --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.pld:%{_rpmlibdir}/macros.build:%{_rpmlibdir}/%%{_target}/macros:%{_sysconfdir}/macros.*:%{_sysconfdir}/macros:%{_sysconfdir}/%%{_target}/macros:~/etc/rpmmacros:~/etc/.rpmmacros:~/.rpmmacros' \
738         --with-bugreport="http://bugs.pld-linux.org/"
739
740 %{__make} \
741         CC="%{__cc}" \
742         CXX="%{__cxx}" \
743         CPP="%{__cpp}"
744
745 %install
746 rm -rf $RPM_BUILD_ROOT
747 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/banner}
748
749 %{__make} install \
750         pkgconfigdir=%{_pkgconfigdir} \
751         DESTDIR=$RPM_BUILD_ROOT
752
753 # install ARCH macros
754 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux
755 install %{SOURCE105} $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
756
757 %ifarch %{ix86}
758 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{i386,i486,i586,i686,athlon,pentium3,pentium4}-linux
759 install %{SOURCE100} $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
760 install %{SOURCE101} $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
761 install %{SOURCE102} $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
762 install %{SOURCE103} $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
763 install %{SOURCE104} $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
764 install %{SOURCE106} $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
765 install %{SOURCE107} $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
766 %endif
767
768 %ifarch %{x8664}
769 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{x86_64,ia32e,amd64}-linux
770 install %{SOURCE109} $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
771 install %{SOURCE110} $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
772 install %{SOURCE111} $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
773 %endif
774
775 %ifarch %{ppc}
776 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux
777 install %{SOURCE108} $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
778 %endif
779
780 # first platform file entry can't contain regexps
781 echo "%{_target_cpu}-%{_target_vendor}-linux" > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
782
783 # x86_64 things
784 %ifarch x86_64
785 echo "amd64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
786 echo "x86_64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
787 %endif
788
789 %ifarch amd64
790 echo "amd64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
791 echo "x86_64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
792 %endif
793
794 %ifarch ia32e
795 echo "ia32e-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
796 echo "x86_64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
797 %endif
798
799 # x86 things
800 %ifarch athlon %{x8664}
801 echo "athlon-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
802 %endif
803 %ifarch pentium4 athlon %{x8664}
804 echo "pentium4-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
805 %endif
806 %ifarch pentium3 pentium4 athlon %{x8664}
807 echo "pentium3-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
808 %endif
809 %ifarch i686 pentium3 pentium4 athlon %{x8664}
810 echo "i686-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
811 %endif
812 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
813 echo "i586-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
814 %endif
815 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
816 echo "i486-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
817 %endif
818 %ifarch %{ix86} %{x8664}
819 echo "i386-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
820 %endif
821
822 # ppc
823 %ifarch ppc
824 echo "ppc-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
825 echo "powerpc-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
826 %endif
827
828 # noarch
829 echo "noarch-[^-]*-.*" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
830
831 %ifarch %{ppc}
832 #sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
833 #       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
834 %endif
835
836 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
837 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
838 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
839
840 # not installed since 4.4.8 (-tools-perl subpackage)
841 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
842
843 install macros.perl     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.perl
844 install macros.python   $RPM_BUILD_ROOT%{_rpmlibdir}/macros.python
845 install macros.php      $RPM_BUILD_ROOT%{_rpmlibdir}/macros.php
846 install macros.mono     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.mono
847 install %{SOURCE15}     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.java
848 install %{SOURCE18}     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.pld
849
850 install %{SOURCE1} doc/manual/groups
851 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
852 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
853 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
854 install %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/check-files
855 install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
856 install %{SOURCE16} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
857 install scripts/find-php*       $RPM_BUILD_ROOT%{_rpmlibdir}
858 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
859 install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
860
861 install %{SOURCE17} $RPM_BUILD_ROOT%{_bindir}/banner.sh
862
863 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
864
865 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
866 # customized rpm macros - global for host
867 #
868 #%%_install_langs pl_PL:en_US
869 %%distribution PLD
870 #
871 # remove or replace with file_contexts path if you want to use custom
872 # SELinux file contexts policy instead of one stored in packages payload
873 %%_install_file_context_path    %%{nil}
874 %%_verify_file_context_path     %%{nil}
875
876 # If non-zero, all erasures will be automagically repackaged.
877 #%%_repackage_all_erasures    1
878 EOF
879
880 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles <<EOF
881 # global list of files (regexps) which don't generate Provides
882 EOF
883 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov <<EOF
884 # global list of script capabilities (regexps) not to be used in Provides
885 EOF
886 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles <<EOF
887 # global list of files (regexps) which don't generate Requires
888 ^%{_examplesdir}/
889 ^%{_docdir}/
890 EOF
891 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq <<EOF
892 # global list of script capabilities (regexps) not to be used in Requires
893 EOF
894 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
895 # global list of capabilities (SONAME, perl(module), php(module) regexps)
896 # which don't generate dependencies on package NAMES
897 # -- OpenGL implementation
898 ^libGL.so.1
899 ^libGLU.so.1
900 ^libOSMesa.so
901 # -- Glide
902 ^libglide3.so.3
903 # -- mozilla
904 ^libgtkmozembed.so
905 ^libgtksuperwin.so
906 ^libxpcom.so
907 # -- X11 implementation
908 ^libFS.so
909 ^libI810XvMC.so
910 ^libICE.so
911 ^libSM.so
912 ^libX11.so
913 ^libXRes.so
914 ^libXTrap.so
915 ^libXaw.so
916 ^libXcomposite.so
917 ^libXcursor.so
918 ^libXdamage.so
919 ^libXdmcp.so
920 ^libXevie.so
921 ^libXext.so
922 ^libXfixes.so
923 ^libXfont.so
924 ^libXfontcache.so
925 ^libXft.so
926 ^libXi.so
927 ^libXinerama.so
928 ^libXmu.so
929 ^libXmuu.so
930 ^libXp.so
931 ^libXpm.so
932 ^libXrandr.so
933 ^libXrender.so
934 ^libXss.so
935 ^libXt.so
936 ^libXtst.so
937 ^libXv.so
938 ^libXvMC.so
939 ^libXxf86dga.so
940 ^libXxf86misc.so
941 ^libXxf86rush.so
942 ^libXxf86vm.so
943 ^libdps.so
944 ^libdpstk.so
945 ^libfontenc.so
946 ^libpsres.so
947 ^libxkbfile.so
948 ^libxkbui.so
949 # -- fam / gamin
950 ^libfam.so.0
951 EOF
952 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
953 # global list of file masks not to be compressed in DOCDIR
954 EOF
955
956 # for rpm -e|-U --repackage
957 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
958 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
959
960 # mov rpm to /bin
961 mv -f $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
962 # move libs to /lib
963 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so; do
964         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
965         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
966 done
967
968 # remove arch dependant macros which have no use on noarch
969 #%{__sed} -i -e '
970 #/{__spec_install_post_strip}/d
971 #/{__spec_install_post_chrpath}/d
972 #/{__spec_install_post_compress_modules}/d
973 #' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
974
975 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
976 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
977
978 rm $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
979
980 # wrong location, not used anyway
981 rm $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
982 # manuals for utils dropped in 4.4.8 (?)
983 #rm $RPM_BUILD_ROOT%{_mandir}/{,*/}/man8/{rpmcache,rpmgraph}.8
984
985 %find_lang %{name}
986
987 rm -rf manual
988 cp -a doc/manual manual
989 rm -f manual/Makefile*
990
991 %clean
992 rm -rf $RPM_BUILD_ROOT
993
994 %post   lib -p /sbin/ldconfig
995 %postun lib -p /sbin/ldconfig
996
997 %pre build
998 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
999
1000 %files -f %{name}.lang
1001 %defattr(644,root,root,755)
1002 %doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
1003
1004 %attr(755,root,root) /bin/rpm
1005 #%attr(755,root,root) %{_bindir}/rpmdb
1006 #%attr(755,root,root) %{_bindir}/rpmquery
1007 #%attr(755,root,root) %{_bindir}/rpmsign
1008 #%attr(755,root,root) %{_bindir}/rpmverify
1009
1010 %dir %{_sysconfdir}/rpm
1011 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
1012 # these are ok to be replaced
1013 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo
1014 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1015
1016
1017 %{_mandir}/man8/rpm.8*
1018 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1019 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1020 %lang(ko) %{_mandir}/ko/man8/rpm.8*
1021 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1022 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1023 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1024
1025 %dir /var/lib/rpm
1026 %dir %attr(700,root,root) /var/spool/repackage
1027 %dir /var/lock/rpm
1028 /var/lock/rpm/transaction
1029
1030 #%attr(755,root,root) %{_rpmlibdir}/rpmd
1031 #%{!?with_static:%attr(755,root,root) %{_rpmlibdir}/rpm[eiu]}
1032 #%attr(755,root,root) %{_rpmlibdir}/rpmk
1033 #%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
1034
1035 %{_rpmlibdir}/rpmpopt*
1036 %{_rpmlibdir}/macros
1037 %{_rpmlibdir}/macros.pld
1038
1039 %files base
1040 %defattr(644,root,root,755)
1041 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1042 %dir %{_rpmlibdir}
1043 %attr(755,root,root) %{_bindir}/banner.sh
1044 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1045 %dir /var/lib/banner
1046
1047 %files lib
1048 %defattr(644,root,root,755)
1049 %attr(755,root,root) /%{_lib}/librpm*-*.so
1050 %attr(755,root,root) %{_libdir}/librpm*-*.so
1051
1052 %files devel
1053 %defattr(644,root,root,755)
1054 %{_includedir}/rpm
1055 %{_libdir}/librpm*.la
1056 %{_pkgconfigdir}/*.pc
1057 %attr(755,root,root) %{_libdir}/librpm.so
1058 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1059 %attr(755,root,root) %{_libdir}/librpmconstant.so
1060 %attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
1061 %attr(755,root,root) %{_libdir}/librpmio.so
1062 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1063 %attr(755,root,root) %{_libdir}/librpmmisc.so
1064 %attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
1065 %attr(755,root,root) %{_libdir}/librpmdb.so
1066 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1067 %attr(755,root,root) %{_libdir}/librpmbuild.so
1068
1069 %files static
1070 %defattr(644,root,root,755)
1071 %{_libdir}/librpm*.a
1072
1073 %files utils
1074 %defattr(644,root,root,755)
1075 %attr(755,root,root) %{_bindir}/rpmconstant
1076 %attr(755,root,root) %{_bindir}/rpm2cpio
1077 %attr(755,root,root) %{_rpmlibdir}/rpmcache
1078 %attr(755,root,root) %{_rpmlibdir}/rpmcmp
1079 %attr(755,root,root) %{_rpmlibdir}/rpmdeps
1080 %attr(755,root,root) %{_rpmlibdir}/debugedit
1081 %attr(755,root,root) %{_rpmlibdir}/rpmdigest
1082 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1083 %attr(755,root,root) %{_rpmlibdir}/tgpg
1084 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1085 %{_mandir}/man8/rpm2cpio.8*
1086 %{_mandir}/man8/rpmdeps.8*
1087 #%{_mandir}/man8/rpmcache.8*
1088 #%{_mandir}/man8/rpmgraph.8*
1089 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1090 #%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
1091 #%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
1092 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1093 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1094 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1095 #%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
1096 #%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
1097 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1098
1099 %files utils-perl
1100 %defattr(644,root,root,755)
1101 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1102
1103 %if %{with static}
1104 %files utils-static
1105 %defattr(644,root,root,755)
1106 %attr(755,root,root) %{_bindir}/rpm[ieu]
1107 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1108 %endif
1109
1110 %files build
1111 %defattr(644,root,root,755)
1112 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1113 %attr(755,root,root) %{_rpmlibdir}/brp-*
1114 %attr(755,root,root) %{_rpmlibdir}/check-files
1115 # %attr(755,root,root) %{_rpmlibdir}/check-prereqs
1116 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1117 #%attr(755,root,root) %{_rpmlibdir}/config.*
1118 %attr(755,root,root) %{_rpmlibdir}/cross-build
1119 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1120 %attr(755,root,root) %{_rpmlibdir}/find-lang.sh
1121 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1122 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1123 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
1124 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1125 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1126 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1127 # needs hacked pkg-config to return anything
1128 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1129 #%attr(755,root,root) %{_rpmlibdir}/rpmb
1130 #%attr(755,root,root) %{_rpmlibdir}/rpmt
1131 %{_rpmlibdir}/noarch-*
1132 %ifarch %{ix86}
1133 %{_rpmlibdir}/i?86*
1134 %{_rpmlibdir}/pentium*
1135 %{_rpmlibdir}/athlon*
1136 %endif
1137 %ifarch alpha
1138 %{_rpmlibdir}/alpha*
1139 %endif
1140 %ifarch ia64
1141 %{_rpmlibdir}/ia64*
1142 %endif
1143 %ifarch mips mipsel mips64 mips64el
1144 %{_rpmlibdir}/mips*
1145 %endif
1146 %ifarch %{ppc}
1147 %{_rpmlibdir}/ppc*
1148 %endif
1149 %ifarch sparc sparc64
1150 %{_rpmlibdir}/sparc*
1151 %endif
1152 %ifarch %{x8664}
1153 %{_rpmlibdir}/amd64*
1154 %{_rpmlibdir}/ia32e*
1155 %{_rpmlibdir}/x86_64*
1156 %endif
1157 # must be here for "Requires: rpm-*prov" to work
1158 %{_rpmlibdir}/macros.java
1159 %{_rpmlibdir}/macros.mono
1160 %{_rpmlibdir}/macros.perl
1161 %{_rpmlibdir}/macros.php
1162 # not used yet ... these six depend on perl
1163 #%attr(755,root,root) %{_rpmlibdir}/http.req
1164 #%attr(755,root,root) %{_rpmlibdir}/magic.prov
1165 #%attr(755,root,root) %{_rpmlibdir}/magic.req
1166 #%{_rpmlibdir}/sql.prov
1167 #%{_rpmlibdir}/sql.req
1168 #%{_rpmlibdir}/tcl.req
1169
1170 %attr(755,root,root) %{_bindir}/gendiff
1171 %attr(755,root,root) %{_bindir}/rpmbuild
1172
1173 %{_mandir}/man1/gendiff.1*
1174 %{_mandir}/man8/rpmbuild.8*
1175 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1176 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1177 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1178
1179 %files javaprov
1180 %defattr(644,root,root,755)
1181 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1182 # needs jar (any jdk), jcf-dump (gcc-java) to work
1183 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1184
1185 %files perlprov
1186 %defattr(644,root,root,755)
1187 %attr(755,root,root) %{_rpmlibdir}/perl.*
1188 #%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1189 #%attr(755,root,root) %{_rpmlibdir}/find-perl-*
1190 #%attr(755,root,root) %{_rpmlibdir}/find-*.perl
1191 #%attr(755,root,root) %{_rpmlibdir}/find-prov.pl
1192 #%attr(755,root,root) %{_rpmlibdir}/find-req.pl
1193 #%attr(755,root,root) %{_rpmlibdir}/get_magic.pl
1194
1195 %files pythonprov
1196 %defattr(644,root,root,755)
1197 %{_rpmlibdir}/macros.python
1198 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1199
1200 %files php-pearprov
1201 %defattr(644,root,root,755)
1202 %attr(755,root,root) %{_rpmlibdir}/php*
1203 %attr(755,root,root) %{_rpmlibdir}/find-php*
1204
1205 %if %{with python}
1206 %files -n python-rpm
1207 %defattr(644,root,root,755)
1208 %dir %{py_sitedir}/rpm
1209 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1210 %{py_sitedir}/rpm/*.py[co]
1211 %endif
This page took 0.269792 seconds and 2 git commands to generate.