]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
ee2a2aae24bc45669524e3a2c4876cf713a9c4df
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - rebuild database after upgrading from rpm5
4 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
5 #
6 # Conditional build:
7 %bcond_without  apidocs         # don't generate documentation with doxygen
8 %bcond_without  python2         # don't build python bindings
9 %bcond_without  python3         # don't build python bindings
10 %bcond_without  plugins         # build plugins
11 %bcond_without  recommends_tags # build without Recommends tag (bootstrapping)
12
13 %define         db_ver          5.3.28.0
14 %define         popt_ver        1.15
15 %define         openssl_ver     1.1.1d
16 %define         sover           9.0.1
17
18 Summary:        RPM Package Manager
19 Summary(de.UTF-8):      RPM Packet-Manager
20 Summary(es.UTF-8):      Gestor de paquetes RPM
21 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
22 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
23 Summary(ru.UTF-8):      Менеджер пакетов от RPM
24 Summary(uk.UTF-8):      Менеджер пакетів від RPM
25 Name:           rpm
26 Version:        4.15.1
27 Release:        0.1
28 Epoch:          1
29 License:        GPL v2 / LGPL v2.1
30 Group:          Base
31 Source0:        http://ftp.rpm.org/releases/rpm-4.15.x/%{name}-%{version}.tar.bz2
32 # Source0-md5:  ed72147451a5ed93b2a48e2f8f5413c3
33 Source1:        ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
34 # Source1-md5:  23914bb49fafe7153cee87126d966461
35 Source2:        macros.local
36 Source3:        macros.lang
37 Source4:        %{name}.sysconfig
38 Source5:        %{name}.groups
39 Source6:        %{name}-groups-po.awk
40 Source7:        %{name}-install-tree
41 Source8:        %{name}-hrmib-cache
42 Source9:        %{name}-user_group.sh
43 # http://svn.pld-linux.org/banner.sh/
44 Source10:       banner.sh
45 Source11:       %{name}.noautocompressdoc
46 Source12:       %{name}.noautoprov
47 Source13:       %{name}.noautoprovfiles
48 Source14:       %{name}.noautoreq
49 Source15:       %{name}.noautoreqfiles
50 Source16:       perl.prov
51 Source17:       %{name}db_checkversion.c
52 Source18:       %{name}db_reset.c
53 Source19:       dbupgrade.sh
54 Patch0:         %{name}-man_pl.patch
55 Patch1:         %{name}-popt-aliases.patch
56 Patch2:         %{name}-perl-macros.patch
57 Patch3:         %{name}-perl-req-perlfile.patch
58 Patch4:         %{name}-scripts-closefds.patch
59 Patch5:         %{name}-lua.patch
60 Patch6:         %{name}-perl_req-INC_dirs.patch
61 Patch7:         %{name}-debuginfo.patch
62 Patch8:         %{name}-libtool-deps.patch
63 Patch9:         %{name}-builddir-readlink.patch
64 Patch10:        %{name}-changelog_order_check_nonfatal.patch
65 Patch11:        %{name}-postun-nofail.patch
66 Patch12:        %{name}-clean-docdir.patch
67 Patch13:        %{name}-perl-magic.patch
68 Patch14:        %{name}-ignore-missing-macro-files.patch
69 Patch15:        x32.patch
70 Patch16:        %{name}-add-compress-doc.patch
71 Patch17:        rpm5-db-compat.patch
72 Patch18:        python-internal-build.patch
73 Patch19:        create-build-tree-after-parse.patch
74 URL:            https://rpm.org/
75 BuildRequires:  db-devel >= %{db_ver}
76 BuildRequires:  autoconf >= 2.63
77 BuildRequires:  automake >= 1.4
78 BuildRequires:  bzip2-devel >= 1.0.2-17
79 BuildRequires:  elfutils-devel >= 0.108
80 BuildRequires:  gettext-tools >= 0.19.2
81 BuildRequires:  libarchive-devel
82 BuildRequires:  libmagic-devel
83 BuildRequires:  openssl-devel >= %{openssl_ver}
84 %if %{with plugins}
85 BuildRequires:  audit-libs-devel
86 BuildRequires:  dbus-devel
87 BuildRequires:  libselinux-devel >= 2.1.0
88 %endif
89 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
90 BuildRequires:  libstdc++-devel
91 BuildRequires:  libtool >= 1:1.4.2-9
92 BuildRequires:  lua53-devel >= 5.3.5
93 BuildRequires:  ossp-uuid-devel
94 BuildRequires:  patch >= 2.2
95 BuildRequires:  popt-devel >= %{popt_ver}
96 %{?with_python2:BuildRequires:  python-devel >= 1:2.3}
97 %{?with_python3:BuildRequires:  python3-devel}
98 BuildRequires:  python-modules >= 1:2.3
99 %if %{with python2} || %{with python3}
100 BuildRequires:  rpm-pythonprov
101 %endif
102 BuildRequires:  tcl
103 BuildRequires:  xz-devel
104 BuildRequires:  zlib-devel
105 BuildRequires:  zstd-devel
106 %if %{with apidocs}
107 BuildRequires:  doxygen
108 BuildRequires:  ghostscript
109 BuildRequires:  graphviz
110 BuildRequires:  tetex-pdftex
111 %endif
112 Requires(posttrans):    coreutils
113 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
114 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
115 Requires:       rpm-pld-macros >= 1.744
116 Requires:       FHS >= 3.0-2
117 Requires:       openssl >= %{openssl_ver}
118 Requires:       popt >= %{popt_ver}
119 %if %{with recommends_tags}
120 Recommends:     rpm-plugin-audit
121 Recommends:     rpm-plugin-prioreset
122 Recommends:     rpm-plugin-syslog
123 Recommends:     rpm-plugin-systemd-inhibit
124 %endif
125 Obsoletes:      rpm-getdeps
126 Obsoletes:      rpm-utils-perl
127 Obsoletes:      rpm-utils-static
128 Conflicts:      glibc < 2.2.92
129 # db4.6 poldek needed
130 Conflicts:      poldek < 0.21-0.20070703.00.3
131 # segfaults with lzma 0.42.2
132 Conflicts:      lzma-libs < 4.999.3
133 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
134 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
135
136 %define         _binary_payload         w9.gzdio
137
138 # don't require very fresh rpm.macros to build
139 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
140 %define         ix86    i386 i486 i586 i686 athlon geode pentium3 pentium4
141 %define         ppc     ppc ppc7400 ppc7450
142 %define         x8664   amd64 ia32e x86_64
143
144 %define         _rpmlibdir /usr/lib/rpm
145 %define         _noautocompressdoc      RPM-GPG-KEY
146
147 %description
148 RPM is a powerful package manager, which can be used to build,
149 install, query, verify, update, and uninstall individual software
150 packages. A package consists of an archive of files, and package
151 information, including name, version, and description.
152
153 %description -l de.UTF-8
154 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
155 Installation, Anfrage, Verifizierung, Aktualisierung und
156 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
157 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
158 Beschreibung.
159
160 %description -l es.UTF-8
161 RPM es un poderoso administrador de paquetes, que puede ser usado para
162 construir, instalar, pesquisar, verificar, actualizar y desinstalar
163 paquetes individuales de software. Un paquete consiste en un
164 almacenaje de archivos, y información sobre el paquete, incluyendo
165 nombre, versión y descripción.
166
167 %description -l pl.UTF-8
168 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
169 przebudowanie, instalację czy weryfikację dowolnego pakietu.
170 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
171 plików wchodzących w skład pakietu, zależności od innych pakietów, są
172 przechowywane w bazie danych i można je uzyskać za pomocą opcji
173 odpytywania programu rpm.
174
175 %description -l pt_BR.UTF-8
176 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
177 construir, instalar, pesquisar, verificar, atualizar e desinstalar
178 pacotes individuais de software. Um pacote consiste de um conjunto de
179 arquivos e informações adicionais, incluindo nome, versão e descrição
180 do pacote, permissões dos arquivos, etc.
181
182 %description -l ru.UTF-8
183 RPM - это мощный менеджер пакетов, который может быть использован для
184 создания, инсталляции, запросов (query), проверки, обновления и
185 удаления программных пакетов. Пакет состоит из файлового архива и
186 служебной информации, включающей название, версию, описание и другие
187 данные о пакете.
188
189 %description -l uk.UTF-8
190 RPM - це потужний менеджер пакетів, що може бути використаний для
191 створення, інсталяції, запитів (query), перевірки, поновлення та
192 видалення програмних пакетів. Пакет складається з файлового архіву та
193 службової інформації, що містить назву, версію, опис та іншу
194 інформацію про пакет.
195
196 %package base
197 Summary:        RPM base package - scripts used by rpm packages themselves
198 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
199 Group:          Base
200 Requires:       filesystem
201 Obsoletes:      rpm-scripts
202 Obsoletes:      vserver-rpm
203
204 %description base
205 The RPM base package contains scripts used by rpm packages themselves.
206 These include:
207 - scripts for adding/removing groups and users needed for rpm
208   packages,
209 - banner.sh to display %%banner messages from rpm scriptlets.
210
211 %description base -l pl.UTF-8
212 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
213 Zawiera on:
214 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
215 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
216
217 %package lib
218 Summary:        RPMs library
219 Summary(pl.UTF-8):      Biblioteki RPM-a
220 Group:          Libraries
221 Requires:       db >= %{db_ver}
222 Requires:       libmagic >= 1.15-2
223 Requires:       openssl >= %{openssl_ver}
224 Requires:       popt >= %{popt_ver}
225 Obsoletes:      rpm-libs
226 # avoid SEGV caused by mixed db versions
227 Conflicts:      poldek < 0.18.1-16
228
229 %description lib
230 RPMs library.
231
232 %description lib -l pl.UTF-8
233 Biblioteki RPM-a.
234
235 %package devel
236 Summary:        Header files for rpm libraries
237 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
238 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
239 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
240 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
241 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
242 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
243 Group:          Development/Libraries
244 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
245 Requires:       db-devel >= %{db_ver}
246 Requires:       bzip2-devel
247 Requires:       elfutils-devel
248 Requires:       libmagic-devel
249 Requires:       openssl-devel >= %{openssl_ver}
250 %if %{with selinux}
251 Requires:       libselinux-devel
252 Requires:       libsemanage-devel
253 Requires:       libsepol-devel
254 %endif
255 Requires:       popt-devel >= %{popt_ver}
256 Requires:       zlib-devel
257
258 %description devel
259 The RPM packaging system includes C libraries that make it easy to
260 manipulate RPM packages and databases. They are intended to ease the
261 creation of graphical package managers and other tools that need
262 intimate knowledge of RPM packages. This package contains header files
263 for these libraries.
264
265 %description devel -l de.UTF-8
266 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
267 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
268 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
269 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
270
271 %description devel -l es.UTF-8
272 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
273 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
274 facilitar la creación de administradores gráficos de paquetes y otras
275 herramientas que necesiten un conocimiento profundo de paquetes RPM.
276
277 %description devel -l pl.UTF-8
278 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
279 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
280 graficznych programów zarządzających pakietami oraz innych narzędzi,
281 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
282 zawiera pliki nagłówkowe wspomnianych bibliotek.
283
284 %description devel -l pt_BR.UTF-8
285 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
286 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
287 facilitar a criação de gerenciadores gráficos de pacotes e outras
288 ferramentas que precisem de conhecimento profundo de pacotes RPM.
289
290 %description devel -l ru.UTF-8
291 Система управления пакетами RPM содержит библиотеку C, которая
292 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
293 Эта библиотека предназначена для облегчения создания графических
294 пакетных менеджеров и других утилит, которым необходимо работать с
295 пакетами RPM.
296
297 %description devel -l uk.UTF-8
298 Система керування пакетами RPM містить бібліотеку C, котра спрощує
299 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
300 призначена для полегшення створення графічних пакетних менеджерів та
301 інших утиліт, що працюють з пакетами RPM.
302
303 %package utils
304 Summary:        Additional utilities for managing RPM packages and database
305 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
306 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
307 Group:          Applications/File
308 Requires:       %{name} = %{epoch}:%{version}-%{release}
309 Requires:       popt >= %{popt_ver}
310 %if %{with recommends_tags}
311 Recommends:     bzip2
312 Recommends:     gzip
313 %endif
314 Conflicts:      filesystem-debuginfo < 3.0-16
315
316 %description utils
317 Additional utilities for managing RPM packages and database.
318
319 %description utils -l de.UTF-8
320 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
321
322 %description utils -l pl.UTF-8
323 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
324
325 %package build
326 Summary:        Scripts for building binary RPM packages
327 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
328 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
329 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
330 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
331 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
332 Group:          Applications/File
333 Requires(pretrans):     coreutils
334 Requires(pretrans):     findutils
335 Requires:       %{name}-utils = %{epoch}:%{version}-%{release}
336 Requires:       rpm-pld-macros-build >= 1.744
337 Requires:       /bin/id
338 Requires:       awk
339 Requires:       bzip2
340 Requires:       chrpath >= 0.10-4
341 Requires:       cpio
342 Requires:       diffutils
343 Requires:       elfutils
344 Requires:       file >= 4.17
345 Requires:       fileutils
346 Requires:       findutils
347 %ifarch athlon
348 Requires:       gcc >= 3.0.3
349 %else
350 Requires:       gcc
351 %endif
352 Requires:       glibc-devel
353 Requires:       grep
354 Requires:       gzip
355 Requires:       make
356 Requires:       patch
357 Requires:       sed >= 4.0
358 Requires:       sh-utils
359 Requires:       tar >= 1:1.22
360 Requires:       textutils
361 Requires:       which
362 Requires:       xz
363 Provides:       rpmbuild(noauto) = 3
364 %ifarch %{x8664}
365 Conflicts:      automake < 1:1.7.9-2
366 Conflicts:      libtool < 2:1.5-13
367 %endif
368
369 %description build
370 Scripts for building binary RPM packages.
371
372 %description build -l de.UTF-8
373 Scripts fürs Bauen binärer RPM-Pakete.
374
375 %description build -l pl.UTF-8
376 Skrypty pomocnicze do budowania binarnych RPM-ów.
377
378 %description build -l pt_BR.UTF-8
379 Este pacote contém scripts e programas executáveis que são usados para
380 construir pacotes usando o RPM.
381
382 %description build -l ru.UTF-8
383 Различные вспомогательные скрипты и исполняемые программы, которые
384 используются для сборки RPM'ов.
385
386 %description build -l uk.UTF-8
387 Різноманітні допоміжні скрипти та утиліти, які використовуються для
388 побудови RPM'ів.
389
390 %package perlprov
391 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
392 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
393 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
394 Group:          Applications/File
395 Requires:       %{name} = %{epoch}:%{version}-%{release}
396 Requires:       perl-Encode
397 Requires:       perl-devel
398 Requires:       perl-modules
399
400 %description perlprov
401 Additional utilities for checking Perl provides/requires in RPM
402 packages.
403
404 %description perlprov -l de.UTF-8
405 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
406
407 %description perlprov -l pl.UTF-8
408 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
409 pakietach RPM.
410
411 %package pythonprov
412 Summary:        Python macros, which simplifies creation of RPM packages with Python software
413 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
414 Group:          Applications/File
415 Requires:       %{name} = %{epoch}:%{version}-%{release}
416 Requires:       python
417 Requires:       python-modules
418 Requires:       python-setuptools
419
420 %description pythonprov
421 Python macros, which simplifies creation of RPM packages with Python
422 software.
423
424 %description pythonprov -l pl.UTF-8
425 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
426 Pythonie.
427
428 %package -n python-rpm
429 Summary:        Python interface to RPM library
430 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
431 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
432 Group:          Development/Languages/Python
433 Requires:       %{name} = %{epoch}:%{version}-%{release}
434 Requires:       python
435 Obsoletes:      rpm-python
436
437 %description -n python-rpm
438 The python-rpm package contains a module which permits applications
439 written in the Python programming language to use the interface
440 supplied by RPM (RPM Package Manager) libraries.
441
442 This package should be installed if you want to develop Python
443 programs that will manipulate RPM packages and databases.
444
445 %description -n python-rpm -l pl.UTF-8
446 Pakiet python-rpm zawiera moduł, który pozwala aplikacjom napisanym w
447 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
448
449 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
450 Pythonie programy manipulujące pakietami i bazami danych rpm.
451
452 %description -n python-rpm -l pt_BR.UTF-8
453 O pacote python-rpm contém um módulo que permite que aplicações
454 escritas em Python utilizem a interface fornecida pelas bibliotecas
455 RPM (RPM Package Manager).
456
457 Esse pacote deve ser instalado se você quiser desenvolver programas em
458 Python para manipular pacotes e bancos de dados RPM.
459
460 %package -n python3-rpm
461 Summary:        Python 3 interface to RPM library
462 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki RPM-a
463 Summary(pt_BR.UTF-8):   Módulo Python 3 para aplicativos que manipulam pacotes RPM
464 Group:          Development/Languages/Python
465 Requires:       %{name} = %{epoch}:%{version}-%{release}
466 Requires:       python3
467
468 %description -n python3-rpm
469 The python3-rpm package contains a module which permits applications
470 written in the Python 3 programming language to use the interface
471 supplied by RPM (RPM Package Manager) libraries.
472
473 This package should be installed if you want to develop Python 3
474 programs that will manipulate RPM packages and databases.
475
476 %description -n python3-rpm -l pl.UTF-8
477 Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
478 Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki RPM-a.
479
480 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
481 Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
482
483 %description -n python3-rpm -l pt_BR.UTF-8
484 O pacote python3-rpm contém um módulo que permite que aplicações
485 escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
486 RPM (RPM Package Manager).
487
488 Esse pacote deve ser instalado se você quiser desenvolver programas em
489 Python 3 para manipular pacotes e bancos de dados RPM.
490
491 %package plugin-audit
492 Summary:        Plugin for logging audit events on package operations
493 Group:          System/Base
494 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
495
496 %description plugin-audit
497 Plugin for libaudit support
498
499 %package plugin-syslog
500 Summary:        Plugin for syslog functionality
501 Group:          System/Base
502 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
503
504 %description plugin-syslog
505 This plugin exports RPM actions to the system log.
506
507 %package plugin-systemd-inhibit
508 Summary:        Plugin for systemd inhibit functionality
509 Group:          System/Base
510 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
511
512 %description plugin-systemd-inhibit
513 This plugin blocks systemd from entering idle, sleep or shutdown while
514 an rpm transaction is running using the systemd-inhibit mechanism.
515
516 %package plugin-ima
517 Summary:        Plugin for IMA file signatures
518 Group:          Base
519 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
520
521 %description plugin-ima
522 This plugin adds support for enforcing and verifying IMA file
523 signatures in an rpm.
524
525 %package plugin-prioreset
526 Summary:        Plugin for resetting scriptlet priorities for SysV init
527 Group:          Base
528 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
529
530 %description plugin-prioreset
531 This plugin is useful on legacy SysV init systems if you run rpm
532 transactions with nice/ionice priorities. Should not be used on
533 systemd systems.
534
535 %package plugin-selinux
536 Summary:        Plugin for SELinux functionality
537 Group:          Base
538 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
539 Requires:       libselinux >= 2.1.0
540
541 %description plugin-selinux
542 Plugin for SELinux functionality.
543
544 %package sign
545 Summary:        Package signing support
546 Group:          Base
547 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
548
549 %description sign
550 This package contains support for digitally signing RPM packages.
551
552 %package apidocs
553 Summary:        RPM API documentation and guides
554 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
555 Group:          Documentation
556 BuildArch:      noarch
557
558 %description apidocs
559 Documentation for RPM API and guides in HTML format generated from rpm
560 sources by doxygen.
561
562 %description apidocs -l pl.UTF-8
563 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
564 źrodeł RPM-a przez doxygen.
565
566 %prep
567 %setup -q -n %{name}-%{version}%{?subver}
568 %patch0 -p1
569 %patch1 -p1
570 %patch2 -p1
571 %patch3 -p1
572 %patch4 -p1
573 %patch5 -p1
574 %patch6 -p0
575 %patch7 -p1
576 %patch8 -p1
577 %patch9 -p1
578 %patch10 -p1
579 %patch11 -p1
580 %patch12 -p1
581 %patch13 -p1
582 %patch14 -p1
583 %patch15 -p1
584 %patch16 -p1
585 %patch17 -p1
586 %patch18 -p1
587 %patch19 -p1
588
589 install %{SOURCE16} scripts/perl.prov.in
590
591 %{__mv} -f scripts/perl.req{,.in}
592
593 # generate Group translations to *.po
594 awk -f %{SOURCE6} %{SOURCE5}
595
596 install %{SOURCE17} tools/rpmdb_checkversion.c
597 install %{SOURCE18} tools/rpmdb_reset.c
598
599 %{__sed} -i -e '1s,/usr/bin/python,%{__python},' scripts/pythondistdeps.py
600
601 %build
602 %{__libtoolize}
603 %{__aclocal}
604 %{__autoheader}
605 %{__autoconf}
606 %{__automake}
607
608 # rpm checks for CPU type at runtime, but it looks better
609 sed -i \
610         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
611         -e 's|@host_cpu@|%{_target_cpu}|' \
612         -e 's|@host_os@|%{_target_os}|' \
613         macros.in
614
615 CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
616 %configure \
617         WITH_PERL_VERSION=no \
618         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
619         __GPG=%{_bindir}/gpg \
620         %{?with_python3:PYTHON=python3} \
621         %{!?with_python3:%{?with_python2:PYTHON=python2}} \
622         --disable-silent-rules \
623         --enable-shared \
624         --enable-bdb \
625         --enable-zstd \
626         --with-crypto=openssl \
627         --with-lua \
628         --with-cap \
629         --with-acl \
630         --with-audit \
631         --with-archive \
632 %if %{with python2} || %{with python3}
633         --enable-python \
634 %endif
635         --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
636         %{!?with_plugins:--disable-plugins} \
637         --with-vendor=pld
638
639 #  --enable-ndb (EXPERIMENTAL) enable the new rpm database format
640 #  --enable-lmdb=[yes/no/auto] (EXPERIMENTAL) build with LMDB rpm database format support (default=auto)
641 #  --with-imaevm           build with imaevm support
642
643 %{__make}
644
645 %{__cc} %{rpmcflags} tools/rpmdb_checkversion.c -o tools/rpmdb_checkversion -ldb
646 %{__cc} %{rpmcflags} tools/rpmdb_reset.c -o tools/rpmdb_reset -ldb
647
648 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
649         echo "Error linking rpmdb tools!"
650         exit 1
651 fi
652 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
653         echo "Error linking rpmdb tools!"
654         exit 1
655 fi
656
657 %if %{with python2}
658 cd python
659 %py_build
660 cd ..
661 %endif
662
663 %if %{with python3}
664 cd python
665 %py3_build
666 %endif
667
668 %install
669 rm -rf $RPM_BUILD_ROOT
670 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
671         $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/var/cache/hrmib}
672
673 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
674
675 %{__make} install \
676         pkgconfigdir=%{_pkgconfigdir} \
677         DESTDIR=$RPM_BUILD_ROOT
678
679 # cleanup
680 %ifnarch %{ix86} %{x8664} x32
681 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
682 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
683 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
684 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
685 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
686 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
687 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
688 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
689 %endif
690
691 %ifnarch %{x8664} x32
692 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
693 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
694 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
695 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
696 %endif
697
698 %ifnarch %{ppc}
699 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
700 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
701 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
702 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
703 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
704 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
705 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
706 %endif
707
708 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
709 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
710 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
711 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
712 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
713 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
714 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
715 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
716 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
717
718 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
719
720 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
721
722 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
723 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
724 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
725 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rpm
726
727 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/banner.sh
728
729 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
730 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
731 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
732 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
733 cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
734 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
735 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
736
737 cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
738 cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
739 cp -p %{SOURCE19} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
740
741 # move rpm to /bin
742 %{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
743 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
744 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
745
746 # move essential libs to /lib (libs that /bin/rpm links to)
747 for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
748         mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
749         ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
750 done
751
752 #./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
753
754 %if %{with python2}
755 # Remove anything that rpm make install might put there
756 %{__rm} -rf $RPM_BUILD_ROOT%{py_sitedir}
757 cd python
758 %py_install
759 %py_postclean
760 cd ..
761 %endif
762
763 %if %{with python3}
764 # Remove anything that rpm make install might put there
765 %{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
766 cd python
767 %py3_install
768 cd ..
769 %endif
770
771 %{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
772
773 # wrong location, not used anyway
774 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
775
776 %find_lang %{name}
777
778 %clean
779 rm -rf $RPM_BUILD_ROOT
780
781 %posttrans
782 if [ -e /var/lib/rpm/Packages ] && \
783                 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
784         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
785                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
786                 echo
787                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
788                 echo
789         fi
790         echo
791         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
792         echo 'you should ignore it and restart poldek'
793         echo
794         %{_rpmlibdir}/dbupgrade.sh
795 fi
796
797 %triggerpostun -- %{name} < 4.4.9-44
798 %{_rpmlibdir}/hrmib-cache
799
800 %post   lib -p /sbin/ldconfig
801 %postun lib -p /sbin/ldconfig
802
803 %pretrans build
804 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
805
806 %files -f %{name}.lang
807 %defattr(644,root,root,755)
808 %doc ChangeLog CREDITS README
809
810 %dir /etc/pki/rpm-gpg
811 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
812
813 %attr(755,root,root) /bin/rpm
814 %attr(755,root,root) %{_bindir}/rpmdb
815 %attr(755,root,root) %{_bindir}/rpmkeys
816 %attr(755,root,root) %{_bindir}/rpmquery
817 %attr(755,root,root) %{_bindir}/rpmverify
818
819 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
820 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
821
822 %{_mandir}/man8/rpm.8*
823 %{_mandir}/man8/rpmdb.8*
824 %{_mandir}/man8/rpmkeys.8*
825 %{_mandir}/man8/rpm-misc.8*
826 %lang(fr) %{_mandir}/fr/man8/rpm.8*
827 %lang(ja) %{_mandir}/ja/man8/rpm.8*
828 %lang(ko) %{_mandir}/ko/man8/rpm.8*
829 %lang(pl) %{_mandir}/pl/man8/rpm.8*
830 %lang(ru) %{_mandir}/ru/man8/rpm.8*
831 %lang(sk) %{_mandir}/sk/man8/rpm.8*
832
833 %dir /var/lib/rpm
834
835 # exported package NVRA (stamped with install tid)
836 # net-snmp hrSWInstalledName queries, bash-completions
837 %dir /var/cache/hrmib
838
839 %{_rpmlibdir}/rpmpopt*
840 %{_rpmlibdir}/rpmrc
841 %{_rpmlibdir}/macros
842 %dir %{_rpmlibdir}/macros.d
843 %dir %{_rpmlibdir}/platform
844 %{_rpmlibdir}/platform/noarch-*
845 %ifarch %{ix86} %{x8664} x32
846 %{_rpmlibdir}/platform/athlon*
847 %{_rpmlibdir}/platform/geode*
848 %{_rpmlibdir}/platform/i?86*
849 %{_rpmlibdir}/platform/pentium*
850 %endif
851 %ifarch %{x8664} x32
852 %{_rpmlibdir}/platform/amd64*
853 %{_rpmlibdir}/platform/ia32e*
854 %{_rpmlibdir}/platform/x86_64*
855 %{_rpmlibdir}/platform/x32*
856 %endif
857 %ifarch alpha
858 %{_rpmlibdir}/platform/alpha*
859 %endif
860 %ifarch ia64
861 %{_rpmlibdir}/platform/ia64*
862 %endif
863 %ifarch mips mipsel mips64 mips64el
864 %{_rpmlibdir}/platform/mips*
865 %endif
866 %ifarch %{ppc}
867 %{_rpmlibdir}/platform/ppc*
868 %endif
869 %ifarch sparc sparc64
870 %{_rpmlibdir}/platform/sparc*
871 %endif
872
873 %dir %{_rpmlibdir}/pld
874
875 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
876
877 %attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
878 %attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
879 %attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
880
881 # valgrind suppression file for rpm
882 %{_rpmlibdir}/rpm.supp
883
884 %files base
885 %defattr(644,root,root,755)
886 %dir %{_sysconfdir}/rpm
887 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
888 %dir %{_rpmlibdir}
889 %attr(755,root,root) %{_bindir}/banner.sh
890 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
891 %dir /var/lib/banner
892
893 %files lib
894 %defattr(644,root,root,755)
895 %attr(755,root,root) /%{_lib}/librpm.so.9
896 %attr(755,root,root) /%{_lib}/librpm.so.%{sover}
897 %attr(755,root,root) /%{_lib}/librpmbuild.so.9
898 %attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
899 %attr(755,root,root) /%{_lib}/librpmio.so.9
900 %attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
901 %attr(755,root,root) /%{_lib}/librpmsign.so.9
902 %attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
903 %{?with_plugins:%dir %{_libdir}/rpm-plugins}
904
905 %files devel
906 %defattr(644,root,root,755)
907 %attr(755,root,root) %{_libdir}/librpm.so
908 %attr(755,root,root) %{_libdir}/librpmbuild.so
909 %attr(755,root,root) %{_libdir}/librpmio.so
910 %attr(755,root,root) %{_libdir}/librpmsign.so
911 %{_libdir}/librpm*.la
912 %{_includedir}/rpm
913 %{_pkgconfigdir}/*.pc
914
915 %files utils
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_bindir}/rpm2archive
918 %attr(755,root,root) %{_bindir}/rpm2cpio
919 %attr(755,root,root) %{_bindir}/rpmgraph
920 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
921 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
922 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
923 %attr(755,root,root) %{_rpmlibdir}/tgpg
924 %attr(755,root,root) %{_rpmlibdir}/debugedit
925 %attr(755,root,root) %{_rpmlibdir}/rpmdeps
926 %{_mandir}/man8/rpm2cpio.8*
927 %{_mandir}/man8/rpmdeps.8*
928 %{_mandir}/man8/rpmgraph.8*
929 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
930 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
931 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
932 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
933 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
934 %lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
935 %lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
936
937 %files build
938 %defattr(644,root,root,755)
939 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
940 %attr(755,root,root) %{_rpmlibdir}/brp-*
941 %attr(755,root,root) %{_rpmlibdir}/check-files
942 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
943 %attr(755,root,root) %{_rpmlibdir}/elfdeps
944 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
945 # needs hacked pkg-config to return anything
946 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
947 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
948
949 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
950 # must be here for "Requires: rpm-*prov" to work
951 #%{_rpmlibdir}/macros.d/cmake
952 #%{_rpmlibdir}/macros.d/gstreamer
953 #%{_rpmlibdir}/macros.d/libtool
954 #%{_rpmlibdir}/macros.d/perl
955 #%{_rpmlibdir}/macros.d/pkgconfig
956 #%{_rpmlibdir}/macros.d/python
957 #%{_rpmlibdir}/macros.d/selinux
958 #%{_rpmlibdir}/macros.d/tcl
959 #%{_rpmlibdir}/macros.rpmbuild
960
961 %attr(755,root,root) %{_rpmlibdir}/check-buildroot
962 %attr(755,root,root) %{_rpmlibdir}/check-prereqs
963 %attr(755,root,root) %{_rpmlibdir}/check-rpaths
964 %attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
965 %attr(755,root,root) %{_rpmlibdir}/debuginfo.prov
966 %attr(755,root,root) %{_rpmlibdir}/desktop-file.prov
967 %attr(755,root,root) %{_rpmlibdir}/find-provides
968 %attr(755,root,root) %{_rpmlibdir}/find-requires
969 %attr(755,root,root) %{_rpmlibdir}/metainfo.prov
970 %attr(755,root,root) %{_rpmlibdir}/ocaml-find-provides.sh
971 %attr(755,root,root) %{_rpmlibdir}/ocaml-find-requires.sh
972 %attr(755,root,root) %{_rpmlibdir}/script.req
973 %attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
974 # Fedora has this in -build, but shouldn't this be in -devel?
975 %attr(755,root,root) %{_rpmlibdir}/config.guess
976 %attr(755,root,root) %{_rpmlibdir}/config.sub
977
978 %dir %{_rpmlibdir}/fileattrs
979 %{_rpmlibdir}/fileattrs/debuginfo.attr
980 %{_rpmlibdir}/fileattrs/desktop.attr
981 %{_rpmlibdir}/fileattrs/elf.attr
982 %{_rpmlibdir}/fileattrs/font.attr
983 %{_rpmlibdir}/fileattrs/libtool.attr
984 %{_rpmlibdir}/fileattrs/metainfo.attr
985 %{_rpmlibdir}/fileattrs/ocaml.attr
986 %{_rpmlibdir}/fileattrs/perl.attr
987 %{_rpmlibdir}/fileattrs/perllib.attr
988 %{_rpmlibdir}/fileattrs/pkgconfig.attr
989 %{_rpmlibdir}/fileattrs/python.attr
990 %{_rpmlibdir}/fileattrs/pythondist.attr
991 %{_rpmlibdir}/fileattrs/script.attr
992
993 %attr(755,root,root) %{_bindir}/gendiff
994 %attr(755,root,root) %{_bindir}/rpmbuild
995 %attr(755,root,root) %{_bindir}/rpmspec
996
997 %{_mandir}/man1/gendiff.1*
998 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
999 %{_mandir}/man8/rpmbuild.8*
1000 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1001 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1002 %{_mandir}/man8/rpmspec.8*
1003
1004 %files perlprov
1005 %defattr(644,root,root,755)
1006 %attr(755,root,root) %{_rpmlibdir}/perl.*
1007
1008 %files pythonprov
1009 %defattr(644,root,root,755)
1010 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1011 %attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
1012
1013 %if %{with python2}
1014 %files -n python-rpm
1015 %defattr(644,root,root,755)
1016 %dir %{py_sitedir}/rpm
1017 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1018 %{py_sitedir}/rpm/*.py[co]
1019 %{py_sitedir}/rpm-%{version}-py*.egg-info
1020 %endif
1021
1022 %if %{with python3}
1023 %files -n python3-rpm
1024 %defattr(644,root,root,755)
1025 %dir %{py3_sitedir}/rpm
1026 %attr(755,root,root) %{py3_sitedir}/rpm/*.so
1027 %{py3_sitedir}/rpm/*.py
1028 %{py3_sitedir}/rpm-%{version}-py*.egg-info
1029 %{py3_sitedir}/rpm/__pycache__
1030 %endif
1031
1032 %if %{with plugins}
1033 %files plugin-audit
1034 %defattr(644,root,root,755)
1035 %attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
1036
1037 %files plugin-syslog
1038 %defattr(644,root,root,755)
1039 %attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
1040
1041 %files plugin-systemd-inhibit
1042 %defattr(644,root,root,755)
1043 %attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
1044 %{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
1045
1046 %files plugin-ima
1047 %defattr(644,root,root,755)
1048 %attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
1049
1050 %files plugin-prioreset
1051 %defattr(644,root,root,755)
1052 %attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
1053
1054 %files plugin-selinux
1055 %defattr(644,root,root,755)
1056 %attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
1057 %endif
1058
1059 %files sign
1060 %defattr(644,root,root,755)
1061 %attr(755,root,root) %{_bindir}/rpmsign
1062 %{_mandir}/man8/rpmsign.8*
1063
1064 %if %{with apidocs}
1065 %files apidocs
1066 %defattr(644,root,root,755)
1067 %doc doc/librpm/html/*
1068 %endif
This page took 0.104732 seconds and 2 git commands to generate.