c51bd4ef47845bf04ceb69241f25e17b6e9fab2c
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4 #   returns -ENOSYS
5 # - add macros for some ppc, mipsel, alpha and sparc
6 #
7 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
8 #
9 # Conditional build:
10 %bcond_with     static          # build static rpm+rpmi
11 %bcond_without  apidocs         # don't generate documentation with doxygen
12 %bcond_without  python          # don't build python bindings
13 %bcond_without  selinux         # build without selinux support
14 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
15 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
16 %bcond_with     sqlite          # build with SQLite support
17 %bcond_with     system_lua      # use system lua
18 %bcond_with     keyutils        # build with keyutils support
19 # force_cc              - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
20 # force_cxx             - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
21 # force_cpp             - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
22 #
23
24 %if %{with sqlite}
25 # Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
26 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
27 %endif
28
29 # versions of required libraries
30 %define         reqdb_pkg       db5.2
31 %define         reqdb_ver       5.2
32 %define         reqdb_pkgver    5.2.36.0-4
33 %define         reqpopt_ver     1.15
34 %define         beecrypt_ver    2:4.2.0
35 %define         sover           5.4
36
37 Summary:        RPM Package Manager
38 Summary(de.UTF-8):      RPM Packet-Manager
39 Summary(es.UTF-8):      Gestor de paquetes RPM
40 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
41 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
42 Summary(ru.UTF-8):      Менеджер пакетов от RPM
43 Summary(uk.UTF-8):      Менеджер пакетів від RPM
44 Name:           rpm
45 Version:        5.4.13
46 Release:        2
47 License:        LGPL v2.1
48 Group:          Base
49 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.13-0.20130819.src.rpm
50 Source0:        %{name}-%{version}.tar.gz
51 # Source0-md5:  4ce4ab33a4d5f1fcb13afcc494c92c07
52 Source100:      cpu-os-macros.tar.gz
53 # Source100-md5:        928034a5bdceb398881bc14b5f29973b
54 Source1:        %{name}.groups
55 Source2:        macros.pld.in
56 Source3:        %{name}-install-tree
57 Source4:        %{name}-find-spec-bcond
58 Source5:        %{name}-hrmib-cache
59 Source6:        %{name}-groups-po.awk
60 Source7:        %{name}-compress-doc
61 Source8:        %{name}-php-provides
62 Source9:        %{name}-php-requires
63 Source10:       %{name}.sysinfo
64 Source11:       perl.prov
65 Source12:       %{name}-user_group.sh
66 Source13:       %{name}.sysconfig
67 Source14:       %{name}-java-requires
68 # http://svn.pld-linux.org/banner.sh/
69 Source15:       banner.sh
70 Source16:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
71 # Source16-md5: 08b29584dd349aac9caa7610131a0a88
72 Source17:       %{name}-mimetypedeps
73 Source18:       macros.local
74 Source19:       %{name}.noautocompressdoc
75 Source20:       %{name}.noautoprov
76 Source21:       %{name}.noautoprovfiles
77 Source22:       %{name}.noautoreq
78 Source24:       %{name}.noautoreqfiles
79 Source25:       %{name}-php-requires.php
80 Source26:       %{name}db_checkversion.c
81 Source27:       macros.lang
82 Source28:       %{name}db_reset.c
83 Source29:       dbupgrade.sh
84 Patch0:         %{name}-branch.patch
85 Patch1:         %{name}-man_pl.patch
86 Patch2:         %{name}-popt-aliases.patch
87 Patch3:         %{name}-nosetproctitle.patch
88 Patch4:         %{name}-perl-macros.patch
89 Patch5:         %{name}-perl-req-perlfile.patch
90 Patch6:         %{name}-scripts-closefds.patch
91 Patch7:         %{name}-php-macros.patch
92 Patch8:         %{name}-gettext-in-header.patch
93 Patch9:         %{name}-lua.patch
94 Patch10:        %{name}-php-deps.patch
95 Patch11:        %{name}-notsc.patch
96 Patch12:        %{name}-hack-norpmlibdep.patch
97 Patch13:        %{name}-dont-copy-descriptive-tags.patch
98 Patch14:        %{name}-perl_req-INC_dirs.patch
99 Patch15:        %{name}-debuginfo.patch
100 Patch16:        vendor-pld.patch
101 Patch17:        %{name}-old-fileconflicts-behaviour.patch
102 Patch18:        %{name}-javadeps.patch
103 Patch19:        %{name}-truncate-cvslog.patch
104 Patch20:        %{name}-libtool-deps.patch
105 Patch21:        %{name}-mimetype.patch
106 Patch22:        %{name}-sparc64.patch
107 Patch23:        %{name}-gendiff.patch
108 Patch24:        openmp.patch
109 Patch25:        %{name}-URPM-build-fix.patch
110 Patch26:        %{name}-db5.3.patch
111 Patch27:        %{name}-helperEVR-noassert.patch
112 Patch28:        %{name}-unglobal.patch
113 Patch29:        %{name}-builddir-readlink.patch
114 Patch30:        %{name}-changelog_order_check_nonfatal.patch
115 Patch31:        %{name}-cleanbody.patch
116 Patch32:        %{name}-dirdeps-macro.patch
117 Patch33:        %{name}-installbeforeerase.patch
118 Patch34:        %{name}-libmagic-locale.patch
119 Patch35:        %{name}-namespace-compare.patch
120 Patch36:        %{name}-popt-coreutils.patch
121 Patch37:        %{name}-postun-nofail.patch
122 Patch38:        %{name}-silence-RPM_CHAR_TYPE.patch
123 Patch39:        %{name}-fix-missing-types-in-headers.patch
124 Patch40:        %{name}-fix--p-interpreter-and-empty-script.patch
125 Patch41:        %{name}-db_buffer_small.patch
126 Patch42:        %{name}-pattern_Release.patch
127 Patch43:        %{name}-fix-___build_pre-macro.patch
128 Patch44:        %{name}-missing-patch-file-fails-build.patch
129 Patch45:        %{name}-remove-misleading-missing-patch-message.patch
130 Patch46:        %{name}-file-magic-can-be-mixed-case.patch
131 Patch47:        %{name}-query-always-noisy.patch
132 Patch48:        %{name}-verify-ghosts-broken-logic.patch
133 Patch49:        %{name}-python-enable-compat-RPMSENSE.patch
134 Patch50:        %{name}-dont-treat-gstreamer-modules-as-font.patch
135 Patch51:        %{name}-gst-inspect-typo.patch
136 Patch52:        %{name}-null-term-ascii-digest.patch
137 Patch53:        %{name}-lua-enable-extra-libs.patch
138 Patch54:        %{name}-fix-filedigests-verify.patch
139 Patch55:        %{name}-disable-hmac-verify.patch
140 Patch56:        %{name}-macros.patch
141 Patch57:        %{name}-db5.2.patch
142 Patch58:        %{name}-preserve-iterator.patch
143 Patch60:        %{name}-python-sitescriptdir.patch
144 Patch61:        %{name}-clean-docdir.patch
145 Patch62:        %{name}-DB_CONFIG.patch
146 Patch63:        %{name}-pythoneggs.patch
147 Patch64:        %{name}-fix-compress-doc.patch
148 Patch65:        %{name}-parseSpec-skip-empty-tags.patch
149 Patch66:        %{name}-payload-use-hashed-inode.patch
150 Patch67:        %{name}-repackage-dont-force-max-compression.patch
151 Patch68:        rubyprov-archdirs.patch
152 Patch69:        rubyprov-abi-versioned.patch
153 Patch70:        python-%{name}sense-missingok.patch
154 Patch71:        %{name}-changelog-encoding.patch
155 Patch72:        %{name}-preserve-tag-type.patch
156 Patch73:        gem_helper-spec-arg.patch
157 Patch74:        %{name}-fix-internal-lua-build.patch
158 Patch75:        %{name}-double_check_file_deps.patch
159 Patch76:        %{name}-revert-debugedit-breakage.patch
160 Patch77:        %{name}-lua-expat.patch
161
162 # Patches imported from Mandriva
163
164 # status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
165 # would basically just mean backporting it..
166 Patch1000:      %{name}-5.4.4-add-_specfile-macro.patch
167 # status: needs to be cleaned up and properly reviewed together with rest
168 # of the patches related to dependency generation
169 Patch1001:      %{name}-5.4.9-avoid-dependencies-on-self.patch
170 # status: probably ready to merge
171 Patch1002:      %{name}-5.4.4-pkgconfigdeps-check-path.patch
172 # status: probably okay to merge, but discuss on rpm-devel first
173 Patch1003:      %{name}-5.4.4-glob-wildcards-for-loading-macro-files.patch
174 # status: needs to be discussed
175 Patch1004:      %{name}-5.4.4-allow-installation-of-repackaged-rpms.patch
176 # status: ready to merge
177 Patch1005:      %{name}-5.4.8-dont-show-suggests-with-requires.patch
178 # status: ready for merge
179 Patch1006:      %{name}-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
180 # status: probably okay to merge, but discuss on rpm-devel first
181 Patch1007:      %{name}-5.4.10-duplicate_files_terminate_build.patch
182 # status: same as above
183 Patch1008:      %{name}-5.4.10-unpackaged_subdirs_terminate_build.patch
184 # mdvbz#64898
185 # status: uncertain, might be okay to merge, discuss on rpm-devel first
186 Patch1009:      %{name}-5.4.4-rpmbuild-withoutclean.patch
187 # no sense in having an additional dependency on 'pkgconfig' on all packages that
188 # have a pkgconfig file, it's not needed for them to be made useful and anything
189 # actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
190 # status: might be okay to merge, but discuss on rpm-devel first
191 Patch1010:      %{name}-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
192 # status: ready for merge
193 Patch1011:      %{name}-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
194 # $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
195 # %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
196 # status: needs to be discussed and investigated a bit better..
197 Patch1012:      %{name}-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
198 # status: probably okay to merge, but discuss on rpm-devel first
199 Patch1013:      %{name}-5.4.10-files-listed-twice-terminates-build.patch
200 # status: probably okay to merge
201 Patch1014:      %{name}-5.4.9-ruby1.9-fixes.patch
202 # status: keep locally
203 Patch1015:      %{name}-5.4.9-keep-loading-script-macros.patch
204 # status: same as for other dep gen patches
205 Patch1016:      %{name}-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
206 # status: idem
207 Patch1017:      %{name}-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
208 # status: ready for merge
209 Patch1018:      %{name}-5.4.5-rubygems-add-missing-newline.patch
210 # status: probably okay to merge
211 Patch1019:      %{name}-5.4.5-python-export-spec-macros.patch
212 # status: idem
213 Patch1020:      %{name}-5.4.9-font-provides.patch
214 # stauus: idem
215 Patch1021:      %{name}-5.4.7-kmod-dependencies.patch
216 # status: probably okay to merge, discuss on rpm-devel first
217 Patch1022:      %{name}-5.4.5-skip-dependencies-for-character-devices.patch
218 # status: ready to merge
219 Patch1023:      %{name}-5.4.5-rpmfc-use-strlen-not-sizeof.patch
220 # status: probably okay to merge
221 Patch1024:      %{name}-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
222 # status: probably okay to merge
223 Patch1026:      %{name}-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
224 # status: ready
225 Patch1027:      %{name}-5.4.7-fix-generation-of-ruby-abi-provides.patch
226 # crash reproducable with 'rpm -qa --triggers'
227 # status: ready
228 Patch1028:      %{name}-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
229 # status: same as for other dep gen patches
230 Patch1029:      %{name}-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
231 # status: ready
232 Patch1030:      %{name}-5.4.7-fix-minor-memleaks.patch
233 # status: ready
234 Patch1031:      %{name}-5.4.9-mire-fix-strings-lacking-null-terminator.patch
235 # status: ready
236 Patch1032:      %{name}-5.4.9-rpmpython-fix-input.patch
237 # status: ready
238 Patch1033:      %{name}-5.4.7-no-seqid_init-on-rdonly-database.patch
239 # status: probably ready for merging
240 Patch1034:      %{name}-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
241 # status: probably ready to merge, discuss on rpm-devel first
242 Patch1035:      %{name}-5.4.9-fix-verify-segfault.patch
243 # status: ready and should be merged
244 Patch1036:      %{name}-5.4.9-fix-typo-in-rpmtag-header.patch
245 # Due to rpmdav/neon being written in a different fashion than other rpmio clients,
246 # the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
247 # with the result being that when unable to download files, neon will save error
248 # page as the target file.
249 # status: should go upstream, but uncertain about "correct" fix, ie. this is
250 # more of a workaround, while rewriting rpmdav code to behave consistently
251 # would be "the right thing to do". Yet I'm not fully able to grasp all of the
252 # code and don't want to spend more time just to get the API..
253 Patch1037:      %{name}-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
254 # As the transaction flags for ignoring arch & os are no longer used, there's
255 # currently no way to ignore arch & os of packages anymore. This patch adds
256 # support for doing this again by defining rpm variables and overriding
257 # --ignorearch & --ignoreos to set these.
258 # status: needs to be discussed upstream before thinking about merging
259 Patch1038:      %{name}-5.4.10-support-ignore-arch-and-os-again.patch
260 # status: ready for merge
261 Patch1039:      %{name}-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
262 # we want that patch too, a bit of builder infrastructure relies on NOSIGNATURES
263 Patch1040:      %{name}-5.4.9-support-signatures-and-digest-disablers.patch
264 # lack insight on actual functionality, which anyways seems broken, so let's
265 # disable it to avoid errors from berkeley db..
266 # status: keep locally
267 Patch1041:      %{name}-5.4.9-disable-l10ndir.patch
268 # status: ready for merge
269 Patch1042:      %{name}-5.4.9-fix-rpm_qa-pattern.patch
270 # warning: introduces memory leak
271 Patch1043:      %{name}-5.4.12-copy-Value-string.patch
272 Patch1044:      %{name}-5.4.12-fix-rpmlua-print.patch
273 Patch1045:      %{name}-5.4.12-fix-rpmpython-module-import-init.patch
274 Patch1046:      %{name}-5.4.12-truncate-output-buffer-after-use.patch
275 Patch1047:      %{name}-5.4.13-perl-bindings-do-not-use-xmalloc.patch
276 Patch1048:      %{name}-5.4.13-dont-override-existing-variables-with-etc-os-release.patch
277
278 URL:            http://rpm5.org/
279 BuildRequires:  %{reqdb_pkg}-devel >= %{reqdb_pkgver}
280 %if %{with sqlite}
281 BuildRequires:  sqlite3-devel
282 %else
283 BuildRequires:  %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
284 %endif
285 BuildRequires:  autoconf >= 2.60
286 BuildRequires:  automake >= 1.4
287 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
288 BuildRequires:  bzip2-devel >= 1.0.2-17
289 BuildRequires:  elfutils-devel >= 0.108
290 #BuildRequires: gettext-autopoint >= 0.11.4-2
291 BuildRequires:  gettext-devel >= 0.11.4-2
292 %{?with_keyutils:BuildRequires: keyutils-devel}
293 BuildRequires:  libmagic-devel
294 %if %{with selinux}
295 BuildRequires:  libselinux-devel >= 2.1.0
296 BuildRequires:  libsemanage-devel >= 2.1.0
297 BuildRequires:  libsepol-devel >= 2.1.0
298 %endif
299 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
300 BuildRequires:  libstdc++-devel
301 BuildRequires:  libtool >= 1:1.4.2-9
302 %if %{with neon}
303 BuildRequires:  libxml2-devel
304 BuildRequires:  neon-devel >= 0.25.5
305 %endif
306 %{?with_system_lua:BuildRequires:       lua52-devel >= 5.2.2}
307 BuildRequires:  ossp-uuid-devel
308 BuildRequires:  patch >= 2.2
309 BuildRequires:  popt-devel >= %{reqpopt_ver}
310 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
311 BuildRequires:  python-modules >= 1:2.3
312 %{?with_python:BuildRequires:   rpm-pythonprov}
313 BuildRequires:  tcl
314 BuildRequires:  xz-devel
315 BuildRequires:  zlib-devel
316 %if %{with apidocs}
317 BuildRequires:  doxygen
318 BuildRequires:  ghostscript
319 BuildRequires:  graphviz
320 BuildRequires:  tetex-pdftex
321 %endif
322 %if %{with static}
323 # Require static library only for static build
324 BuildRequires:  %{reqdb_pkg}-static >= %{reqdb_pkgver}
325 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
326 BuildRequires:  bzip2-static >= 1.0.2-17
327 BuildRequires:  elfutils-static
328 BuildRequires:  glibc-static >= 2.2.94
329 BuildRequires:  libmagic-static
330 %if %{with selinux}
331 BuildRequires:  libselinux-static >= 2.1.0
332 BuildRequires:  libsemanage-static >= 2.1.0
333 BuildRequires:  libsepol-static >= 2.1.0
334 %endif
335 BuildRequires:  popt-static >= %{reqpopt_ver}
336 BuildRequires:  zlib-static
337 %endif
338 Requires(posttrans):    coreutils
339 Requires:       %{name}-base = %{version}-%{release}
340 Requires:       %{name}-lib = %{version}-%{release}
341 Requires:       beecrypt >= %{beecrypt_ver}
342 Requires:       popt >= %{reqpopt_ver}
343 Provides:       rpm-db-ver = %{reqdb_ver}
344 Obsoletes:      rpm-getdeps
345 %{!?with_static:Obsoletes:      rpm-utils-static}
346 Conflicts:      glibc < 2.2.92
347 # db4.6 poldek needed
348 Conflicts:      poldek < 0.21-0.20070703.00.3
349 # segfaults with lzma 0.42.2
350 Conflicts:      lzma-libs < 4.999.3
351 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
352 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
353
354 %define         _binary_payload         w9.gzdio
355
356 # don't require very fresh rpm.macros to build
357 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
358 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
359 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
360 %define         ppc     ppc ppc7400 ppc7450
361 %define         x8664   amd64 ia32e x86_64
362
363 # stabilize new build environment
364 %define         __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
365 %define         __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
366 %define         __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
367
368 %define         _rpmlibdir /usr/lib/rpm
369 %define         _noautocompressdoc      RPM-GPG-KEY
370
371 %description
372 RPM is a powerful package manager, which can be used to build,
373 install, query, verify, update, and uninstall individual software
374 packages. A package consists of an archive of files, and package
375 information, including name, version, and description.
376
377 %description -l de.UTF-8
378 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
379 Installation, Anfrage, Verifizierung, Aktualisierung und
380 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
381 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
382 Beschreibung.
383
384 %description -l es.UTF-8
385 RPM es un poderoso administrador de paquetes, que puede ser usado para
386 construir, instalar, pesquisar, verificar, actualizar y desinstalar
387 paquetes individuales de software. Un paquete consiste en un
388 almacenaje de archivos, y información sobre el paquete, incluyendo
389 nombre, versión y descripción.
390
391 %description -l pl.UTF-8
392 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
393 przebudowanie, instalację czy weryfikację dowolnego pakietu.
394 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
395 plików wchodzących w skład pakietu, zależności od innych pakietów, są
396 przechowywane w bazie danych i można je uzyskać za pomocą opcji
397 odpytywania programu rpm.
398
399 %description -l pt_BR.UTF-8
400 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
401 construir, instalar, pesquisar, verificar, atualizar e desinstalar
402 pacotes individuais de software. Um pacote consiste de um conjunto de
403 arquivos e informações adicionais, incluindo nome, versão e descrição
404 do pacote, permissões dos arquivos, etc.
405
406 %description -l ru.UTF-8
407 RPM - это мощный менеджер пакетов, который может быть использован для
408 создания, инсталляции, запросов (query), проверки, обновления и
409 удаления программных пакетов. Пакет состоит из файлового архива и
410 служебной информации, включающей название, версию, описание и другие
411 данные о пакете.
412
413 %description -l uk.UTF-8
414 RPM - це потужний менеджер пакетів, що може бути використаний для
415 створення, інсталяції, запитів (query), перевірки, поновлення та
416 видалення програмних пакетів. Пакет складається з файлового архіву та
417 службової інформації, що містить назву, версію, опис та іншу
418 інформацію про пакет.
419
420 %package base
421 Summary:        RPM base package - scripts used by rpm packages themselves
422 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
423 Group:          Base
424 Requires:       filesystem
425 Obsoletes:      rpm-scripts
426 Obsoletes:      vserver-rpm
427
428 %description base
429 The RPM base package contains scripts used by rpm packages themselves.
430 These include:
431 - scripts for adding/removing groups and users needed for rpm
432   packages,
433 - banner.sh to display %%banner messages from rpm scriptlets.
434
435 %description base -l pl.UTF-8
436 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
437 Zawiera on:
438 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
439 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
440
441 %package lib
442 Summary:        RPMs library
443 Summary(pl.UTF-8):      Biblioteki RPM-a
444 Group:          Libraries
445 Requires:       %{reqdb_pkg} >= %{reqdb_pkgver}
446 %if %{with sqlite}
447 Requires:       sqlite3 >= %{sqlite_build_version}
448 %else
449 Requires:       %{reqdb_pkg}-sql >= %{reqdb_pkgver}
450 %endif
451 Requires:       beecrypt >= %{beecrypt_ver}
452 Requires:       libmagic >= 1.15-2
453 %{?with_selinux:Requires:       libselinux >= 2.1.0}
454 Requires:       popt >= %{reqpopt_ver}
455 Obsoletes:      rpm-libs
456 # avoid SEGV caused by mixed db versions
457 Conflicts:      poldek < 0.18.1-16
458
459 %description lib
460 RPMs library.
461
462 %description lib -l pl.UTF-8
463 Biblioteki RPM-a.
464
465 %package devel
466 Summary:        Header files for rpm libraries
467 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
468 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
469 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
470 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
471 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
472 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
473 Group:          Development/Libraries
474 Requires:       %{name}-lib = %{version}-%{release}
475 Requires:       %{reqdb_pkg}-devel >= %{reqdb_pkgver}
476 Requires:       beecrypt-devel >= %{beecrypt_ver}
477 Requires:       bzip2-devel
478 Requires:       elfutils-devel
479 %{?with_keyutils:Requires:      keyutils-devel}
480 Requires:       libmagic-devel
481 %{?with_selinux:Requires:       libselinux-devel}
482 Requires:       popt-devel >= %{reqpopt_ver}
483 Requires:       zlib-devel
484
485 %description devel
486 The RPM packaging system includes C libraries that make it easy to
487 manipulate RPM packages and databases. They are intended to ease the
488 creation of graphical package managers and other tools that need
489 intimate knowledge of RPM packages. This package contains header files
490 for these libraries.
491
492 %description devel -l de.UTF-8
493 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
494 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
495 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
496 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
497
498 %description devel -l es.UTF-8
499 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
500 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
501 facilitar la creación de administradores gráficos de paquetes y otras
502 herramientas que necesiten un conocimiento profundo de paquetes RPM.
503
504 %description devel -l pl.UTF-8
505 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
506 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
507 graficznych programów zarządzających pakietami oraz innych narzędzi,
508 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
509 zawiera pliki nagłówkowe wspomnianych bibliotek.
510
511 %description devel -l pt_BR.UTF-8
512 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
513 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
514 facilitar a criação de gerenciadores gráficos de pacotes e outras
515 ferramentas que precisem de conhecimento profundo de pacotes RPM.
516
517 %description devel -l ru.UTF-8
518 Система управления пакетами RPM содержит библиотеку C, которая
519 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
520 Эта библиотека предназначена для облегчения создания графических
521 пакетных менеджеров и других утилит, которым необходимо работать с
522 пакетами RPM.
523
524 %description devel -l uk.UTF-8
525 Система керування пакетами RPM містить бібліотеку C, котра спрощує
526 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
527 призначена для полегшення створення графічних пакетних менеджерів та
528 інших утиліт, що працюють з пакетами RPM.
529
530 %package static
531 Summary:        RPM static libraries
532 Summary(de.UTF-8):      RPMs statische Libraries
533 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
534 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
535 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
536 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
537 Group:          Development/Libraries
538 Requires:       %{name}-devel = %{version}-%{release}
539 Requires:       %{reqdb_pkg}-static >= %{reqdb_pkgver}
540 Requires:       beecrypt-static >= %{beecrypt_ver}
541 Requires:       bzip2-static
542 Requires:       elfutils-static
543 %{?with_keyutils:Requires:      keyutils-static}
544 Requires:       libmagic-static
545 Requires:       popt-static >= %{reqpopt_ver}
546 Requires:       zlib-static
547
548 %description static
549 RPM static libraries.
550
551 %description static -l de.UTF-8
552 RPMs statische Libraries.
553
554 %description static -l pl.UTF-8
555 Biblioteki statyczne RPM-a.
556
557 %description static -l pt_BR.UTF-8
558 Bibliotecas estáticas para desenvolvimento.
559
560 %description static -l ru.UTF-8
561 Система управления пакетами RPM содержит библиотеку C, которая
562 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
563 Это статическая библиотека RPM.
564
565 %description static -l uk.UTF-8
566 Система керування пакетами RPM містить бібліотеку C, котра спрощує
567 роботу з пакетами RPM та відповідними базами даних. Це статична
568 бібліотека RPM.
569
570 %package utils
571 Summary:        Additional utilities for managing RPM packages and database
572 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
573 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
574 Group:          Applications/File
575 Requires:       %{name} = %{version}-%{release}
576 Requires:       popt >= %{reqpopt_ver}
577 %if %{with suggest_tags}
578 Suggests:       bzip2
579 Suggests:       gzip
580 %endif
581 Conflicts:      filesystem-debuginfo < 3.0-16
582
583 %description utils
584 Additional utilities for managing RPM packages and database.
585
586 %description utils -l de.UTF-8
587 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
588
589 %description utils -l pl.UTF-8
590 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
591
592 %package utils-perl
593 Summary:        Additional utilities for managing RPM packages and database
594 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
595 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
596 Group:          Applications/File
597 Requires:       %{name}-utils = %{version}-%{release}
598 Requires:       popt >= %{reqpopt_ver}
599
600 %description utils-perl
601 Additional utilities for managing RPM packages and database.
602
603 %description utils-perl -l de.UTF-8
604 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
605
606 %description utils-perl -l pl.UTF-8
607 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
608
609 %package utils-static
610 Summary:        Static rpm utilities
611 Summary(pl.UTF-8):      Statyczne narzędzia rpm
612 Group:          Applications/System
613 Requires:       %{name} = %{version}-%{release}
614
615 %description utils-static
616 Static rpm utilities for repairing system in case something with
617 shared libraries used by rpm become broken. Currently it contains rpmi
618 binary, which can be used to install/upgrade/remove packages without
619 using shared libraries (well, in fact with exception of NSS modules).
620
621 %description utils-static -l pl.UTF-8
622 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
623 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
624 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
625 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
626 (z wyjątkiem modułów NSS).
627
628 %package build
629 Summary:        Scripts for building binary RPM packages
630 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
631 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
632 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
633 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
634 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
635 Group:          Applications/File
636 Requires(pre):  findutils
637 Requires:       %{name}-build-macros >= 1.656
638 Requires:       %{name}-utils = %{version}-%{release}
639 Requires:       /bin/id
640 Requires:       awk
641 Requires:       bzip2
642 Requires:       chrpath >= 0.10-4
643 Requires:       cpio
644 Requires:       diffutils
645 Requires:       elfutils
646 Requires:       file >= 4.17
647 Requires:       fileutils
648 Requires:       findutils
649 %ifarch athlon
650 Requires:       gcc >= 3.0.3
651 %else
652 Requires:       gcc
653 %endif
654 Requires:       glibc-devel
655 Requires:       grep
656 Requires:       gzip
657 Requires:       make
658 Requires:       patch
659 Requires:       sed >= 4.0
660 Requires:       sh-utils
661 Requires:       tar >= 1:1.22
662 Requires:       textutils
663 Requires:       which
664 Requires:       xz
665 Provides:       rpmbuild(monoautodeps)
666 Provides:       rpmbuild(noauto) = 3
667 %ifarch %{x8664}
668 Conflicts:      automake < 1:1.7.9-2
669 Conflicts:      libtool < 2:1.5-13
670 %endif
671
672 %description build
673 Scripts for building binary RPM packages.
674
675 %description build -l de.UTF-8
676 Scripts fürs Bauen binärer RPM-Pakete.
677
678 %description build -l pl.UTF-8
679 Skrypty pomocnicze do budowania binarnych RPM-ów.
680
681 %description build -l pt_BR.UTF-8
682 Este pacote contém scripts e programas executáveis que são usados para
683 construir pacotes usando o RPM.
684
685 %description build -l ru.UTF-8
686 Различные вспомогательные скрипты и исполняемые программы, которые
687 используются для сборки RPM'ов.
688
689 %description build -l uk.UTF-8
690 Різноманітні допоміжні скрипти та утиліти, які використовуються для
691 побудови RPM'ів.
692
693 %package javaprov
694 Summary:        Additional utilities for checking Java provides/requires in RPM packages
695 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
696 Group:          Applications/File
697 Requires:       %{name} = %{version}-%{release}
698 Requires:       file
699 Requires:       findutils >= 1:4.2.26
700 Requires:       mktemp
701 Requires:       unzip
702
703 %description javaprov
704 Additional utilities for checking Java provides/requires in RPM
705 packages.
706
707 %description javaprov -l pl.UTF-8
708 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
709 RPM.
710
711 %package perlprov
712 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
713 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
714 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
715 Group:          Applications/File
716 Requires:       %{name} = %{version}-%{release}
717 Requires:       perl-devel
718 Requires:       perl-modules
719
720 %description perlprov
721 Additional utilities for checking Perl provides/requires in RPM
722 packages.
723
724 %description perlprov -l de.UTF-8
725 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
726
727 %description perlprov -l pl.UTF-8
728 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
729 pakietach RPM.
730
731 %package pythonprov
732 Summary:        Python macros, which simplifies creation of RPM packages with Python software
733 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
734 Group:          Applications/File
735 Requires:       %{name} = %{version}-%{release}
736 Requires:       python
737 Requires:       python-distribute
738 Requires:       python-modules
739
740 %description pythonprov
741 Python macros, which simplifies creation of RPM packages with Python
742 software.
743
744 %description pythonprov -l pl.UTF-8
745 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
746 Pythonie.
747
748 %package php-pearprov
749 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
750 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
751 Group:          Applications/File
752 Requires:       %{name} = %{version}-%{release}
753 Requires:       sed >= 4.0
754 Suggests:       php-pear-PHP_CompatInfo
755
756 %description php-pearprov
757 Additional utilities for checking PHP PEAR provides/requires in RPM
758 packages.
759
760 %description php-pearprov -l pl.UTF-8
761 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
762 pakietach RPM.
763
764 %package rubyprov
765 Summary:        Ruby tools, which simplify creation of RPM packages with Ruby software
766 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
767 Group:          Applications/File
768 Requires:       %{name} = %{version}-%{release}
769 Requires:       ruby
770 Requires:       ruby-modules
771 Requires:       ruby-rubygems
772
773 %description rubyprov
774 Ruby tools, which simplifies creation of RPM packages with Ruby
775 software.
776
777 %description rubyprov -l pl.UTF-8
778 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
779 Ruby.
780
781 %package -n python-rpm
782 Summary:        Python interface to RPM library
783 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
784 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
785 Group:          Development/Languages/Python
786 Requires:       %{name} = %{version}-%{release}
787 Requires:       python
788 Obsoletes:      rpm-python
789
790 %description -n python-rpm
791 The rpm-python package contains a module which permits applications
792 written in the Python programming language to use the interface
793 supplied by RPM (RPM Package Manager) libraries.
794
795 This package should be installed if you want to develop Python
796 programs that will manipulate RPM packages and databases.
797
798 %description -n python-rpm -l pl.UTF-8
799 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
800 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
801
802 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
803 Pythonie programy manipulujące pakietami i bazami danych rpm.
804
805 %description -n python-rpm -l pt_BR.UTF-8
806 O pacote rpm-python contém um módulo que permite que aplicações
807 escritas em Python utilizem a interface fornecida pelas bibliotecas
808 RPM (RPM Package Manager).
809
810 Esse pacote deve ser instalado se você quiser desenvolver programas em
811 Python para manipular pacotes e bancos de dados RPM.
812
813 %package apidocs
814 Summary:        RPM API documentation and guides
815 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
816 Group:          Documentation
817
818 %description apidocs
819 Documentation for RPM API and guides in HTML format generated from rpm
820 sources by doxygen.
821
822 %description apidocs -l pl.UTF-8
823 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
824 źrodeł RPM-a przez doxygen.
825
826 %prep
827 %setup -q -n %{name}-%{version}%{?subver} -a100
828 #patch0 -p1
829 %patch1 -p1
830 %patch2 -p1
831 %patch3 -p1
832 %patch4 -p1
833 %patch5 -p1
834 %patch6 -p1
835 %patch7 -p1
836 %patch8 -p1
837 %{?with_system_lua:%patch9 -p1}
838 %patch10 -p1
839 %ifnarch i386 i486
840 # enable TSC for capable archs
841 %patch11 -p1
842 %endif
843 %patch12 -p1
844 %patch13 -p1
845 %patch14 -p0
846 %patch15 -p1
847 %patch16 -p1
848 %patch17 -p1
849 %patch18 -p1
850 %patch19 -p1
851 %patch20 -p1
852 %patch21 -p1
853 %ifarch sparc64
854 %patch22 -p1
855 %endif
856 %patch23 -p1
857 %patch24 -p1
858 %patch25 -p1
859 ####%patch26 -p1
860 %patch27 -p1
861 %patch28 -p1
862 %patch29 -p1
863 %patch30 -p1
864 %patch31 -p1
865 %patch32 -p1
866 %patch33 -p1
867 %patch34 -p1
868 %patch35 -p1
869 %patch36 -p1
870 %patch37 -p1
871 %patch38 -p1
872 %patch39 -p1
873 %patch40 -p1
874 ####%patch41 -p1
875 %patch42 -p1
876 %patch43 -p1
877 %patch44 -p1
878 %patch45 -p1
879 %patch46 -p1
880 %patch47 -p1
881 %patch48 -p1
882 %patch49 -p1
883 %patch50 -p1
884 %patch51 -p1
885 %patch52 -p0
886 %patch53 -p1
887 %patch54 -p1
888 %patch55 -p1
889 %patch56 -p1
890 %patch57 -p1
891 %patch58 -p1
892 %patch60 -p1
893 %patch61 -p1
894 %patch62 -p1
895 %patch63 -p1
896 %patch64 -p1
897 %patch65 -p1
898 %patch66 -p1
899 %patch67 -p1
900 %patch70 -p1
901 %patch71 -p1
902 %patch72 -p1
903 %patch73 -p1
904 %patch74 -p1
905 %patch75 -p1
906 %patch76 -p0
907 %patch77 -p0
908
909 %patch1000 -p1
910 %patch1001 -p1
911 %patch1002 -p1
912 %patch1003 -p1
913 %patch1004 -p1
914 %patch1005 -p1
915 %patch1006 -p1
916 %patch1007 -p1
917 %patch1008 -p1
918 %patch1009 -p1
919 %patch1010 -p1
920 %patch1011 -p1
921 %patch1012 -p1
922 %patch1013 -p1
923 %patch1014 -p1
924 %patch1015 -p1
925 %patch1016 -p1
926 %patch1017 -p1
927 %patch1018 -p1
928 %patch1019 -p1
929 %patch1020 -p1
930 %patch1021 -p1
931 %patch1022 -p1
932 %patch1023 -p1
933 %patch1024 -p1
934 %patch1026 -p1
935 %patch1027 -p1
936 %patch1028 -p1
937 %patch1029 -p1
938 %patch1030 -p1
939 %patch1031 -p1
940 %patch1032 -p1
941 %patch1033 -p1
942 %patch1034 -p1
943 %patch1035 -p1
944 %patch1036 -p1
945 %patch1037 -p1
946 %patch1038 -p1
947 %patch1039 -p1
948 %patch1040 -p1
949 %patch1041 -p1
950 %patch1042 -p1
951 %patch1043 -p1
952 %patch1044 -p1
953 %patch1045 -p1
954 %patch1046 -p1
955 %patch1047 -p1
956 %patch1048 -p1
957 %patch68 -p1
958 %patch69 -p1
959
960 install %{SOURCE2} macros/pld.in
961 install %{SOURCE8} scripts/php.prov.in
962 install %{SOURCE9} scripts/php.req.in
963 install %{SOURCE11} scripts/perl.prov.in
964
965 %{__mv} -f scripts/perl.req{,.in}
966
967 # generate Group translations to *.po
968 awk -f %{SOURCE6} %{SOURCE1}
969
970 install %{SOURCE26} tools/rpmdb_checkversion.c
971 install %{SOURCE28} tools/rpmdb_reset.c
972
973 for extlib in beecrypt neon pcre popt; do
974         [ -d $extlib ] && %{__rm} -r $extlib
975 done
976
977 %build
978 %{__libtoolize}
979 #%{__autopoint}
980 %{__aclocal}
981 %{__autoheader}
982 %{__autoconf}
983 %{__automake}
984
985 # rpm checks for CPU type at runtime, but it looks better
986 sed -i \
987         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
988         -e 's|@host_cpu@|%{_target_cpu}|' \
989         -e 's|@host_os@|%{_target_os}|' \
990         macros/macros.in
991
992 %{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
993 # pass CC and CXX too in case of building with some older configure macro
994 %configure \
995         CC="%{__newcc}" \
996         CXX="%{__newcxx}" \
997         CPP="%{__newcpp}" \
998         WITH_PERL_VERSION=no \
999         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
1000         --enable-shared \
1001         --enable-static \
1002         %{!?with_apidocs:--without-apidocs} \
1003         %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
1004         %{!?with_python:--without-python} \
1005         --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
1006         --with-sepol=%{!?with_selinux:no}%{?with_selinux:external} \
1007         --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
1008         --with-libelf \
1009         --with-zlib=external \
1010         --with-bzip2=external \
1011         --with-beecrypt=external \
1012         --with-lzma=external \
1013         --with-xz=external \
1014         --with-neon=%{?with_neon:external}%{!?with_neon:no} \
1015         --with-file=external \
1016         --with-popt=external \
1017         --with-db=external \
1018         --with-dbapi=db \
1019         --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
1020         --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
1021         --with-pcre=external \
1022         --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
1023         --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
1024         --without-path-versioned \
1025         --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/%{_target}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
1026         --with-bugreport="http://bugs.pld-linux.org/" \
1027         --with-vendor=pld
1028
1029 %{__make} -j1 \
1030         CC="%{__cc}" \
1031         CXX="%{__cxx}" \
1032         CPP="%{__cpp}"
1033
1034 %{?with_apidocs:%{__make} apidocs}
1035
1036 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
1037         -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
1038 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
1039         -o tools/rpmdb_reset -ldb-%{reqdb_ver}
1040
1041 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
1042         echo "Error linking rpmdb tools!"
1043         exit 1
1044 fi
1045 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
1046         echo "Error linking rpmdb tools!"
1047         exit 1
1048 fi
1049
1050 %install
1051 rm -rf $RPM_BUILD_ROOT
1052 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
1053         $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
1054
1055 install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1056
1057 %{__make} -j1 install \
1058         pkgconfigdir=%{_pkgconfigdir} \
1059         DESTDIR=$RPM_BUILD_ROOT
1060
1061 # install ARCH macros
1062 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux
1063 install cpu-os-macros/noarch-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
1064
1065 %ifarch %{ix86}
1066 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{i386,i486,i586,i686,athlon,pentium3,pentium4}-linux
1067 install cpu-os-macros/athlon-linux/macros   $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
1068 install cpu-os-macros/i386-linux/macros     $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
1069 install cpu-os-macros/i486-linux/macros     $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
1070 install cpu-os-macros/i586-linux/macros     $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
1071 install cpu-os-macros/i686-linux/macros     $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
1072 install cpu-os-macros/pentium3-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
1073 install cpu-os-macros/pentium4-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
1074 %endif
1075
1076 %ifarch %{x8664}
1077 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{x86_64,ia32e,amd64}-linux
1078 install cpu-os-macros/x86_64-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
1079 install cpu-os-macros/ia32e-linux/macros  $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
1080 install cpu-os-macros/amd64-linux/macros  $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
1081 %endif
1082
1083 %ifarch %{ppc}
1084 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux
1085 install cpu-os-macros/ppc-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
1086 %endif
1087
1088 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
1089 # first platform file entry can't contain regexps
1090 %{_target_cpu}-%{_target_vendor}-linux
1091
1092 # x86_64 things
1093 %ifarch x86_64
1094 x86_64-[^-]*-[Ll]inux(-gnu)?
1095 amd64-[^-]*-[Ll]inux(-gnu)?
1096 %endif
1097 %ifarch amd64
1098 amd64-[^-]*-[Ll]inux(-gnu)?
1099 x86_64-[^-]*-[Ll]inux(-gnu)?
1100 %endif
1101 %ifarch ia32e
1102 ia32e-[^-]*-[Ll]inux(-gnu)?
1103 x86_64-[^-]*-[Ll]inux(-gnu)?
1104 %endif
1105
1106 # x86 things
1107 %ifarch athlon %{x8664}
1108 athlon-[^-]*-[Ll]inux(-gnu)?
1109 %endif
1110 %ifarch pentium4 athlon %{x8664}
1111 pentium4-[^-]*-[Ll]inux(-gnu)?
1112 %endif
1113 %ifarch pentium3 pentium4 athlon %{x8664}
1114 pentium3-[^-]*-[Ll]inux(-gnu)?
1115 %endif
1116 %ifarch i686 pentium3 pentium4 athlon %{x8664}
1117 i686-[^-]*-[Ll]inux(-gnu)?
1118 %endif
1119 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
1120 i586-[^-]*-[Ll]inux(-gnu)?
1121 %endif
1122 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
1123 i486-[^-]*-[Ll]inux(-gnu)?
1124 %endif
1125 %ifarch %{ix86} %{x8664}
1126 i386-[^-]*-[Ll]inux(-gnu)?
1127 %endif
1128
1129 %ifarch alpha
1130 alpha-[^-]*-[Ll]inux(-gnu)?
1131 %endif
1132
1133 %ifarch ia64
1134 ia64-[^-]*-[Ll]inux(-gnu)?
1135 %endif
1136
1137 %ifarch ppc64
1138 powerpc64-[^-]*-[Ll]inux(-gnu)?
1139 ppc64-[^-]*-[Ll]inux(-gnu)?
1140 %endif
1141 %ifarch %{ppc} ppc64
1142 powerpc-[^-]*-[Ll]inux(-gnu)?
1143 ppc-[^-]*-[Ll]inux(-gnu)?
1144 %endif
1145
1146 %ifarch s390x
1147 s390x-[^-]*-[Ll]inux(-gnu)?
1148 %endif
1149 %ifarch s390 s390x
1150 s390-[^-]*-[Ll]inux(-gnu)?
1151 %endif
1152
1153 %ifarch sparc64
1154 sparc64-[^-]*-[Ll]inux(-gnu)?
1155 sparcv8-[^-]*-[Ll]inux(-gnu)?
1156 sparcv9-[^-]*-[Ll]inux(-gnu)?
1157 %endif
1158 %ifarch sparcv9
1159 sparcv8-[^-]*-[Ll]inux(-gnu)?
1160 sparcv9-[^-]*-[Ll]inux(-gnu)?
1161 %endif
1162 %ifarch sparc sparcv9 sparc64
1163 sparc-[^-]*-[Ll]inux(-gnu)?
1164 %endif
1165
1166 # noarch
1167 noarch-[^-]*-.*
1168 EOF
1169
1170 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1171 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1172 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
1173 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
1174 rm $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.a
1175 rm $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.la
1176 rm $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-provides
1177 rm $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-requires
1178
1179 # not installed since 4.4.8 (-tools-perl subpackage)
1180 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1181
1182 install %{SOURCE1} doc/manual/groups
1183 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
1184 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1185 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
1186 install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1187 install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
1188 install scripts/find-php*       $RPM_BUILD_ROOT%{_rpmlibdir}
1189 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
1190 cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
1191 install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
1192 install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
1193 install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
1194
1195 install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
1196
1197 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1198
1199 install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
1200 install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
1201 install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1202 install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1203 install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1204 install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
1205 install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
1206
1207 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1208 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
1209 install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
1210 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1211 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1212 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
1213
1214 install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1215 install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1216 install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
1217
1218 # create macro loading wrappers for backward compatibility
1219 for m in gstreamer java mono perl php python; do
1220         echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
1221 done
1222
1223 # for rpm -e|-U --repackage
1224 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1225 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
1226
1227 # move rpm to /bin
1228 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1229 # move essential libs to /lib (libs that /bin/rpm links to)
1230 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
1231         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1232         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
1233 done
1234
1235 # Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1236 mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1237
1238 %if %{with python}
1239 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1240 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
1241
1242 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
1243 %endif
1244
1245 # wrong location, not used anyway
1246 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
1247 # utils dropped in 4.4.8 -- their manuals
1248 %{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man8/rpmgraph.8
1249 # utils dropped in 5.4 -- their manuals
1250 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
1251 # script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1252 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
1253
1254 %find_lang %{name}
1255
1256 %{__rm} -rf manual
1257 cp -a doc/manual manual
1258 %{__rm} -f manual/Makefile*
1259
1260 %clean
1261 rm -rf $RPM_BUILD_ROOT
1262
1263 %pretrans
1264 # this needs to be a dir
1265 if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
1266         umask 022
1267         mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1268         mkdir %{_sysconfdir}/rpm/sysinfo
1269 fi
1270
1271 %posttrans
1272 if [ -e /var/lib/rpm/Packages ] && \
1273                 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
1274         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
1275                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
1276                 echo
1277                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
1278                 echo
1279         fi
1280         echo
1281         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
1282         echo 'you should ignore it and restart poldek'
1283         echo
1284         %{_rpmlibdir}/bin/dbupgrade.sh
1285 fi
1286
1287 %triggerpostun -- %{name} < 4.4.9-44
1288 %{_rpmlibdir}/hrmib-cache
1289
1290 %post   lib -p /sbin/ldconfig
1291 %postun lib -p /sbin/ldconfig
1292
1293 %pretrans build
1294 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
1295
1296 %files -f %{name}.lang
1297 %defattr(644,root,root,755)
1298 %doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
1299
1300 %dir /etc/pki/rpm-gpg
1301 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1302
1303 %attr(755,root,root) /bin/rpm
1304
1305 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
1306 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
1307 %dir %{_sysconfdir}/rpm/sysinfo
1308 # these are ok to be replaced
1309 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
1310 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1311
1312 %{_mandir}/man8/rpm.8*
1313 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1314 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1315 %lang(ko) %{_mandir}/ko/man8/rpm.8*
1316 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1317 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1318 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1319
1320 %dir /var/lib/rpm
1321 %dir /var/lib/rpm/log
1322 %dir /var/lib/rpm/tmp
1323 %config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
1324 %dir %attr(700,root,root) /var/spool/repackage
1325 %dir /var/lock/rpm
1326 /var/lock/rpm/transaction
1327
1328 # exported package NVRA (stamped with install tid)
1329 # net-snmp hrSWInstalledName queries, bash-completions
1330 %dir /var/cache/hrmib
1331
1332 %{_rpmlibdir}/qf
1333 %{_rpmlibdir}/rpmpopt*
1334 %{_rpmlibdir}/macros
1335 %dir %{_rpmlibdir}/macros.d
1336 %{_rpmlibdir}/macros.d/pld
1337 %{_rpmlibdir}/cpuinfo.yaml
1338 %{_rpmlibdir}/noarch-*
1339 %ifarch %{ix86}
1340 %{_rpmlibdir}/i?86*
1341 %{_rpmlibdir}/pentium*
1342 %{_rpmlibdir}/athlon*
1343 %endif
1344 %ifarch alpha
1345 %{_rpmlibdir}/alpha*
1346 %endif
1347 %ifarch ia64
1348 %{_rpmlibdir}/ia64*
1349 %endif
1350 %ifarch mips mipsel mips64 mips64el
1351 %{_rpmlibdir}/mips*
1352 %endif
1353 %ifarch %{ppc}
1354 %{_rpmlibdir}/ppc*
1355 %endif
1356 %ifarch sparc sparc64
1357 %{_rpmlibdir}/sparc*
1358 %endif
1359 %ifarch %{x8664}
1360 %{_rpmlibdir}/amd64*
1361 %{_rpmlibdir}/ia32e*
1362 %{_rpmlibdir}/x86_64*
1363 %endif
1364
1365 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1366
1367 %dir %{_rpmlibdir}/bin
1368 %attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
1369 %attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
1370 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
1371 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
1372
1373 %files base
1374 %defattr(644,root,root,755)
1375 %dir %{_sysconfdir}/rpm
1376 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1377 %dir %{_rpmlibdir}
1378 %attr(755,root,root) %{_bindir}/banner.sh
1379 %attr(755,root,root) %{_bindir}/multiarch-dispatch
1380 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1381 %dir /var/lib/banner
1382
1383 %files lib
1384 %defattr(644,root,root,755)
1385 %attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1386 %attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1387 %attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1388 %attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
1389 %attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
1390 %attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
1391
1392 %files devel
1393 %defattr(644,root,root,755)
1394 %attr(755,root,root) %{_libdir}/librpm.so
1395 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1396 %attr(755,root,root) %{_libdir}/librpmbuild.so
1397 %attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
1398 %attr(755,root,root) %{_libdir}/librpmconstant.so
1399 %attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
1400 %attr(755,root,root) %{_libdir}/librpmdb.so
1401 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1402 %attr(755,root,root) %{_libdir}/librpmio.so
1403 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1404 %attr(755,root,root) %{_libdir}/librpmmisc.so
1405 %attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
1406 %{_libdir}/librpm*.la
1407 %{_includedir}/rpm
1408 %{_includedir}/multiarch-dispatch.h
1409 %{_pkgconfigdir}/*.pc
1410
1411 %files static
1412 %defattr(644,root,root,755)
1413 %{_libdir}/librpm*.a
1414
1415 %files utils
1416 %defattr(644,root,root,755)
1417 %attr(755,root,root) %{_bindir}/rpm2cpio
1418 %attr(755,root,root) %{_bindir}/rpmconstant
1419 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1420 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1421 %attr(755,root,root) %{_rpmlibdir}/tgpg
1422 %attr(755,root,root) %{_rpmlibdir}/bin/chroot
1423 %attr(755,root,root) %{_rpmlibdir}/bin/cp
1424 %attr(755,root,root) %{_rpmlibdir}/bin/debugedit
1425 %attr(755,root,root) %{_rpmlibdir}/bin/find
1426 %attr(755,root,root) %{_rpmlibdir}/bin/mgo
1427 %attr(755,root,root) %{_rpmlibdir}/bin/mtree
1428 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1429 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1430 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1431 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
1432 %if %{with selinux}
1433 %attr(755,root,root) %{_rpmlibdir}/bin/semodule
1434 %attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1435 %endif
1436 %if %{without system_lua}
1437 %attr(755,root,root) %{_rpmlibdir}/bin/lua
1438 %attr(755,root,root) %{_rpmlibdir}/bin/luac
1439 %attr(755,root,root) %{_rpmlibdir}/bin/rpmlua
1440 %attr(755,root,root) %{_rpmlibdir}/bin/rpmluac
1441 %endif
1442 %{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
1443 %attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
1444 %{_mandir}/man8/rpm2cpio.8*
1445 %{_mandir}/man8/rpmcache.8*
1446 %{_mandir}/man8/rpmconstant.8*
1447 %{_mandir}/man8/rpmdeps.8*
1448 %{_mandir}/man8/rpmmtree.8*
1449 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1450 %lang(ja) %{_mandir}/ja/man8/rpmcache.8*
1451 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1452 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1453 %lang(pl) %{_mandir}/pl/man8/rpmcache.8*
1454 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1455 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1456
1457 %files utils-perl
1458 %defattr(644,root,root,755)
1459 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1460
1461 %if %{with static}
1462 %files utils-static
1463 %defattr(644,root,root,755)
1464 %attr(755,root,root) %{_bindir}/rpm[ieu]
1465 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1466 %endif
1467
1468 %files build
1469 %defattr(644,root,root,755)
1470 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1471 %attr(755,root,root) %{_rpmlibdir}/brp-*
1472 %attr(755,root,root) %{_rpmlibdir}/check-files
1473 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1474 %attr(755,root,root) %{_rpmlibdir}/cross-build
1475 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1476 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1477 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1478 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1479 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1480 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1481 %attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
1482 # needs hacked pkg-config to return anything
1483 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1484 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1485 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
1486 %{!?with_sqlite:%attr(755,root,root) %{_rpmlibdir}/bin/dbsql}
1487 %attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1488 %attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
1489 %attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1490 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1491 %attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1492 %attr(755,root,root) %{_rpmlibdir}/bin/wget
1493 %attr(755,root,root) %{_rpmlibdir}/vcheck
1494 # not used yet ... these six depend on perl
1495 %attr(755,root,root) %{_rpmlibdir}/http.req
1496 # we always used scripts provided by mono-devel, maybe move them here
1497 #%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1498 #%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
1499
1500 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
1501 # must be here for "Requires: rpm-*prov" to work
1502 %{_rpmlibdir}/macros.d/cmake
1503 %{_rpmlibdir}/macros.d/gstreamer
1504 %{_rpmlibdir}/macros.d/java
1505 %{_rpmlibdir}/macros.d/kernel
1506 %{_rpmlibdir}/macros.d/libtool
1507 %{_rpmlibdir}/macros.d/mono
1508 %{_rpmlibdir}/macros.d/perl
1509 %{_rpmlibdir}/macros.d/php
1510 %{_rpmlibdir}/macros.d/pkgconfig
1511 %{_rpmlibdir}/macros.d/python
1512 %{_rpmlibdir}/macros.d/ruby
1513 %{_rpmlibdir}/macros.d/selinux
1514 %{_rpmlibdir}/macros.d/tcl
1515 %{_rpmlibdir}/macros.rpmbuild
1516 # compat wrappers
1517 %{_rpmlibdir}/macros.gstreamer
1518 %{_rpmlibdir}/macros.java
1519 %{_rpmlibdir}/macros.mono
1520 %{_rpmlibdir}/macros.perl
1521 %{_rpmlibdir}/macros.php
1522 %{_rpmlibdir}/macros.python
1523
1524 %attr(755,root,root) %{_rpmlibdir}/check-multiarch-files
1525 %attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1526 %attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1527 %attr(755,root,root) %{_rpmlibdir}/mkmultiarch
1528
1529 %attr(755,root,root) %{_bindir}/gendiff
1530 %attr(755,root,root) %{_bindir}/multiarch-platform
1531 %attr(755,root,root) %{_bindir}/rpmbuild
1532
1533 %dir %{_rpmlibdir}/helpers
1534 %attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
1535
1536 %{_mandir}/man1/gendiff.1*
1537 %{_mandir}/man8/rpmbuild.8*
1538 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1539 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1540 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1541
1542 %files javaprov
1543 %defattr(644,root,root,755)
1544 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1545 # needs jar (any jdk), jcf-dump (gcc-java) to work
1546 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1547
1548 %files rubyprov
1549 %defattr(644,root,root,755)
1550 %attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1551 %attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1552
1553 %files perlprov
1554 %defattr(644,root,root,755)
1555 %attr(755,root,root) %{_rpmlibdir}/perl.*
1556 %attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1557 %attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1558
1559 %files pythonprov
1560 %defattr(644,root,root,755)
1561 %attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
1562 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1563
1564 %files php-pearprov
1565 %defattr(644,root,root,755)
1566 %attr(755,root,root) %{_rpmlibdir}/php*
1567 %attr(755,root,root) %{_rpmlibdir}/find-php*
1568
1569 %if %{with python}
1570 %files -n python-rpm
1571 %defattr(644,root,root,755)
1572 %dir %{py_sitedir}/rpm
1573 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1574 %{py_sitedir}/rpm/*.py[co]
1575 %endif
1576
1577 %if %{with apidocs}
1578 %files apidocs
1579 %defattr(644,root,root,755)
1580 %doc apidocs
1581 %endif
This page took 0.351416 seconds and 2 git commands to generate.