]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
b920a1e56dbf61be018a4a0000b0728c9c416760
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4 #   returns -ENOSYS
5 # - add macros for some ppc, mipsel, alpha and sparc
6 #
7 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
8 #
9 # Conditional build:
10 %bcond_with     static          # build static rpm+rpmi
11 %bcond_without  apidocs         # don't generate documentation with doxygen
12 %bcond_without  python          # don't build python bindings
13 %bcond_without  selinux         # build without selinux support
14 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
15 %bcond_with     db61            # use DB 6.1 instead of 5.3
16 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
17 %bcond_with     keyutils        # build with keyutils support
18
19 # versions of required libraries
20 %if %{with db61}
21 %define         reqdb_pkg       db6.1
22 %define         reqdb_ver       6.1
23 %define         reqdb_pkgver    6.1.19
24 %else
25 %define         reqdb_pkg       db5.3
26 %define         reqdb_ver       5.3
27 %define         reqdb_pkgver    5.3.28.0
28 %endif
29 %define         reqpopt_ver     1.15
30 %define         openssl_ver     1.1.1d
31 %define         sover           9.0.1
32
33 Summary:        RPM Package Manager
34 Summary(de.UTF-8):      RPM Packet-Manager
35 Summary(es.UTF-8):      Gestor de paquetes RPM
36 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
37 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
38 Summary(ru.UTF-8):      Менеджер пакетов от RPM
39 Summary(uk.UTF-8):      Менеджер пакетів від RPM
40 Name:           rpm
41 Version:        4.15.1
42 Release:        0.1
43 License:        GPL v2 / LGPL v2.1
44 Group:          Base
45 Source0:        http://ftp.rpm.org/releases/rpm-4.15.x/%{name}-%{version}.tar.bz2
46 # Source0-md5:  ed72147451a5ed93b2a48e2f8f5413c3
47 Source1:        %{name}.groups
48 Source2:        macros.pld.in
49 Source3:        %{name}-install-tree
50 Source4:        %{name}-find-spec-bcond
51 Source5:        %{name}-hrmib-cache
52 Source6:        %{name}-groups-po.awk
53 Source7:        %{name}-compress-doc
54 Source8:        %{name}-php-provides
55 Source9:        %{name}-php-requires
56 Source10:       %{name}.sysinfo
57 Source11:       perl.prov
58 Source12:       %{name}-user_group.sh
59 Source13:       %{name}.sysconfig
60 Source14:       %{name}-java-requires
61 # http://svn.pld-linux.org/banner.sh/
62 Source15:       banner.sh
63 Source16:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
64 # Source16-md5: 23914bb49fafe7153cee87126d966461
65 Source17:       %{name}-mimetypedeps
66 Source18:       macros.local
67 Source19:       %{name}.noautocompressdoc
68 Source20:       %{name}.noautoprov
69 Source21:       %{name}.noautoprovfiles
70 Source22:       %{name}.noautoreq
71 Source24:       %{name}.noautoreqfiles
72 Source25:       %{name}-php-requires.php
73 Source26:       %{name}db_checkversion.c
74 Source27:       macros.lang
75 Source28:       %{name}db_reset.c
76 Source29:       dbupgrade.sh
77 Source30:       rubygems.rb
78 Source31:       gem_helper.rb
79 Patch1:         %{name}-man_pl.patch
80 Patch2:         %{name}-popt-aliases.patch
81 Patch4:         %{name}-perl-macros.patch
82 Patch5:         %{name}-perl-req-perlfile.patch
83 Patch6:         %{name}-scripts-closefds.patch
84 Patch7:         %{name}-php-macros.patch
85 Patch9:         %{name}-lua.patch
86 Patch14:        %{name}-perl_req-INC_dirs.patch
87 Patch15:        %{name}-debuginfo.patch
88 Patch16:        vendor-pld.patch
89 Patch18:        %{name}-javadeps.patch
90 Patch20:        %{name}-libtool-deps.patch
91 Patch29:        %{name}-builddir-readlink.patch
92 Patch30:        %{name}-changelog_order_check_nonfatal.patch
93 Patch37:        %{name}-postun-nofail.patch
94 Patch61:        %{name}-clean-docdir.patch
95 Patch64:        %{name}-fix-compress-doc.patch
96 Patch81:        %{name}-perl-magic.patch
97 Patch83:        %{name}-ignore-missing-macro-files.patch
98 Patch84:        x32.patch
99
100 URL:            http://rpm5.org/
101 BuildRequires:  %{reqdb_pkg}-devel >= %{reqdb_pkgver}
102 BuildRequires:  %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
103 BuildRequires:  autoconf >= 2.63
104 BuildRequires:  automake >= 1.4
105 BuildRequires:  openssl-devel >= %{openssl_ver}
106 BuildRequires:  bzip2-devel >= 1.0.2-17
107 BuildRequires:  elfutils-devel >= 0.108
108 BuildRequires:  gettext-tools >= 0.19.2
109 %{?with_keyutils:BuildRequires: keyutils-devel}
110 BuildRequires:  libmagic-devel
111 %if %{with selinux}
112 BuildRequires:  libselinux-devel >= 2.1.0
113 BuildRequires:  libsemanage-devel >= 2.1.0
114 BuildRequires:  libsepol-devel >= 2.1.0
115 %endif
116 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
117 BuildRequires:  libstdc++-devel
118 BuildRequires:  libtool >= 1:1.4.2-9
119 %if %{with neon}
120 BuildRequires:  libxml2-devel
121 BuildRequires:  neon-devel >= 0.25.5
122 %endif
123 BuildRequires:  lua53-devel >= 5.3.5
124 BuildRequires:  ossp-uuid-devel
125 BuildRequires:  patch >= 2.2
126 BuildRequires:  popt-devel >= %{reqpopt_ver}
127 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
128 BuildRequires:  python-modules >= 1:2.3
129 %{?with_python:BuildRequires:   rpm-pythonprov}
130 BuildRequires:  tcl
131 BuildRequires:  xz-devel
132 BuildRequires:  zlib-devel
133 BuildRequires:  zstd-devel
134 %if %{with apidocs}
135 BuildRequires:  doxygen
136 BuildRequires:  ghostscript
137 BuildRequires:  graphviz
138 BuildRequires:  tetex-pdftex
139 %endif
140 %if %{with static}
141 # Require static library only for static build
142 BuildRequires:  %{reqdb_pkg}-static >= %{reqdb_pkgver}
143 BuildRequires:  openssl-static >= %{openssl_ver}
144 BuildRequires:  bzip2-static >= 1.0.2-17
145 BuildRequires:  elfutils-static
146 BuildRequires:  glibc-static >= 2.2.94
147 BuildRequires:  libmagic-static
148 %if %{with selinux}
149 BuildRequires:  libselinux-static >= 2.1.0
150 BuildRequires:  libsemanage-static >= 2.1.0
151 BuildRequires:  libsepol-static >= 2.1.0
152 %endif
153 BuildRequires:  popt-static >= %{reqpopt_ver}
154 BuildRequires:  zlib-static
155 BuildRequires:  zstd-static
156 %endif
157 Requires(posttrans):    coreutils
158 Requires:       FHS >= 3.0-2
159 Requires:       %{name}-base = %{version}-%{release}
160 Requires:       %{name}-lib = %{version}-%{release}
161 Requires:       openssl >= %{openssl_ver}
162 Requires:       popt >= %{reqpopt_ver}
163 Provides:       rpm-db-ver = %{reqdb_ver}
164 Obsoletes:      rpm-getdeps
165 %{!?with_static:Obsoletes:      rpm-utils-static}
166 Conflicts:      glibc < 2.2.92
167 # db4.6 poldek needed
168 Conflicts:      poldek < 0.21-0.20070703.00.3
169 # segfaults with lzma 0.42.2
170 Conflicts:      lzma-libs < 4.999.3
171 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
172 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
173
174 %define         _binary_payload         w9.gzdio
175
176 # don't require very fresh rpm.macros to build
177 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
178 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
179 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
180 %define         ppc     ppc ppc7400 ppc7450
181 %define         x8664   amd64 ia32e x86_64
182
183 %define         _rpmlibdir /usr/lib/rpm
184 %define         _noautocompressdoc      RPM-GPG-KEY
185
186 %description
187 RPM is a powerful package manager, which can be used to build,
188 install, query, verify, update, and uninstall individual software
189 packages. A package consists of an archive of files, and package
190 information, including name, version, and description.
191
192 %description -l de.UTF-8
193 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
194 Installation, Anfrage, Verifizierung, Aktualisierung und
195 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
196 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
197 Beschreibung.
198
199 %description -l es.UTF-8
200 RPM es un poderoso administrador de paquetes, que puede ser usado para
201 construir, instalar, pesquisar, verificar, actualizar y desinstalar
202 paquetes individuales de software. Un paquete consiste en un
203 almacenaje de archivos, y información sobre el paquete, incluyendo
204 nombre, versión y descripción.
205
206 %description -l pl.UTF-8
207 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
208 przebudowanie, instalację czy weryfikację dowolnego pakietu.
209 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
210 plików wchodzących w skład pakietu, zależności od innych pakietów, są
211 przechowywane w bazie danych i można je uzyskać za pomocą opcji
212 odpytywania programu rpm.
213
214 %description -l pt_BR.UTF-8
215 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
216 construir, instalar, pesquisar, verificar, atualizar e desinstalar
217 pacotes individuais de software. Um pacote consiste de um conjunto de
218 arquivos e informações adicionais, incluindo nome, versão e descrição
219 do pacote, permissões dos arquivos, etc.
220
221 %description -l ru.UTF-8
222 RPM - это мощный менеджер пакетов, который может быть использован для
223 создания, инсталляции, запросов (query), проверки, обновления и
224 удаления программных пакетов. Пакет состоит из файлового архива и
225 служебной информации, включающей название, версию, описание и другие
226 данные о пакете.
227
228 %description -l uk.UTF-8
229 RPM - це потужний менеджер пакетів, що може бути використаний для
230 створення, інсталяції, запитів (query), перевірки, поновлення та
231 видалення програмних пакетів. Пакет складається з файлового архіву та
232 службової інформації, що містить назву, версію, опис та іншу
233 інформацію про пакет.
234
235 %package base
236 Summary:        RPM base package - scripts used by rpm packages themselves
237 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
238 Group:          Base
239 Requires:       filesystem
240 Obsoletes:      rpm-scripts
241 Obsoletes:      vserver-rpm
242
243 %description base
244 The RPM base package contains scripts used by rpm packages themselves.
245 These include:
246 - scripts for adding/removing groups and users needed for rpm
247   packages,
248 - banner.sh to display %%banner messages from rpm scriptlets.
249
250 %description base -l pl.UTF-8
251 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
252 Zawiera on:
253 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
254 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
255
256 %package lib
257 Summary:        RPMs library
258 Summary(pl.UTF-8):      Biblioteki RPM-a
259 Group:          Libraries
260 Requires:       %{reqdb_pkg} >= %{reqdb_pkgver}
261 Requires:       %{reqdb_pkg}-sql >= %{reqdb_pkgver}
262 Requires:       openssl >= %{openssl_ver}
263 Requires:       libmagic >= 1.15-2
264 %{?with_selinux:Requires:       libselinux >= 2.1.0}
265 Requires:       popt >= %{reqpopt_ver}
266 Obsoletes:      rpm-libs
267 # avoid SEGV caused by mixed db versions
268 Conflicts:      poldek < 0.18.1-16
269
270 %description lib
271 RPMs library.
272
273 %description lib -l pl.UTF-8
274 Biblioteki RPM-a.
275
276 %package devel
277 Summary:        Header files for rpm libraries
278 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
279 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
280 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
281 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
282 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
283 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
284 Group:          Development/Libraries
285 Requires:       %{name}-lib = %{version}-%{release}
286 Requires:       %{reqdb_pkg}-devel >= %{reqdb_pkgver}
287 Requires:       openssl-devel >= %{openssl_ver}
288 Requires:       bzip2-devel
289 Requires:       elfutils-devel
290 %{?with_keyutils:Requires:      keyutils-devel}
291 Requires:       libmagic-devel
292 %if %{with selinux}
293 Requires:       libselinux-devel
294 Requires:       libsemanage-devel
295 Requires:       libsepol-devel
296 %endif
297 Requires:       popt-devel >= %{reqpopt_ver}
298 Requires:       zlib-devel
299
300 %description devel
301 The RPM packaging system includes C libraries that make it easy to
302 manipulate RPM packages and databases. They are intended to ease the
303 creation of graphical package managers and other tools that need
304 intimate knowledge of RPM packages. This package contains header files
305 for these libraries.
306
307 %description devel -l de.UTF-8
308 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
309 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
310 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
311 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
312
313 %description devel -l es.UTF-8
314 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
315 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
316 facilitar la creación de administradores gráficos de paquetes y otras
317 herramientas que necesiten un conocimiento profundo de paquetes RPM.
318
319 %description devel -l pl.UTF-8
320 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
321 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
322 graficznych programów zarządzających pakietami oraz innych narzędzi,
323 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
324 zawiera pliki nagłówkowe wspomnianych bibliotek.
325
326 %description devel -l pt_BR.UTF-8
327 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
328 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
329 facilitar a criação de gerenciadores gráficos de pacotes e outras
330 ferramentas que precisem de conhecimento profundo de pacotes RPM.
331
332 %description devel -l ru.UTF-8
333 Система управления пакетами RPM содержит библиотеку C, которая
334 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
335 Эта библиотека предназначена для облегчения создания графических
336 пакетных менеджеров и других утилит, которым необходимо работать с
337 пакетами RPM.
338
339 %description devel -l uk.UTF-8
340 Система керування пакетами RPM містить бібліотеку C, котра спрощує
341 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
342 призначена для полегшення створення графічних пакетних менеджерів та
343 інших утиліт, що працюють з пакетами RPM.
344
345 %package static
346 Summary:        RPM static libraries
347 Summary(de.UTF-8):      RPMs statische Libraries
348 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
349 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
350 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
351 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
352 Group:          Development/Libraries
353 Requires:       %{name}-devel = %{version}-%{release}
354 Requires:       %{reqdb_pkg}-static >= %{reqdb_pkgver}
355 Requires:       openssl-static >= %{openssl_ver}
356 Requires:       bzip2-static
357 Requires:       elfutils-static
358 %{?with_keyutils:Requires:      keyutils-static}
359 Requires:       libmagic-static
360 %if %{with selinux}
361 Requires:       libselinux-static
362 Requires:       libsemanage-static
363 Requires:       libsepol-static
364 %endif
365 Requires:       popt-static >= %{reqpopt_ver}
366 Requires:       zlib-static
367
368 %description static
369 RPM static libraries.
370
371 %description static -l de.UTF-8
372 RPMs statische Libraries.
373
374 %description static -l pl.UTF-8
375 Biblioteki statyczne RPM-a.
376
377 %description static -l pt_BR.UTF-8
378 Bibliotecas estáticas para desenvolvimento.
379
380 %description static -l ru.UTF-8
381 Система управления пакетами RPM содержит библиотеку C, которая
382 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
383 Это статическая библиотека RPM.
384
385 %description static -l uk.UTF-8
386 Система керування пакетами RPM містить бібліотеку C, котра спрощує
387 роботу з пакетами RPM та відповідними базами даних. Це статична
388 бібліотека RPM.
389
390 %package utils
391 Summary:        Additional utilities for managing RPM packages and database
392 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
393 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
394 Group:          Applications/File
395 Requires:       %{name} = %{version}-%{release}
396 Requires:       popt >= %{reqpopt_ver}
397 %if %{with suggest_tags}
398 Suggests:       bzip2
399 Suggests:       gzip
400 %endif
401 Conflicts:      filesystem-debuginfo < 3.0-16
402
403 %description utils
404 Additional utilities for managing RPM packages and database.
405
406 %description utils -l de.UTF-8
407 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
408
409 %description utils -l pl.UTF-8
410 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
411
412 %package utils-perl
413 Summary:        Additional utilities for managing RPM packages and database
414 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
415 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
416 Group:          Applications/File
417 Requires:       %{name}-utils = %{version}-%{release}
418 Requires:       popt >= %{reqpopt_ver}
419
420 %description utils-perl
421 Additional utilities for managing RPM packages and database.
422
423 %description utils-perl -l de.UTF-8
424 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
425
426 %description utils-perl -l pl.UTF-8
427 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
428
429 %package utils-static
430 Summary:        Static rpm utilities
431 Summary(pl.UTF-8):      Statyczne narzędzia rpm
432 Group:          Applications/System
433 Requires:       %{name} = %{version}-%{release}
434
435 %description utils-static
436 Static rpm utilities for repairing system in case something with
437 shared libraries used by rpm become broken. Currently it contains rpmi
438 binary, which can be used to install/upgrade/remove packages without
439 using shared libraries (well, in fact with exception of NSS modules).
440
441 %description utils-static -l pl.UTF-8
442 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
443 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
444 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
445 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
446 (z wyjątkiem modułów NSS).
447
448 %package build
449 Summary:        Scripts for building binary RPM packages
450 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
451 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
452 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
453 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
454 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
455 Group:          Applications/File
456 Requires(pretrans):     coreutils
457 Requires(pretrans):     findutils
458 Requires:       %{name}-build-macros >= 1.712
459 Requires:       %{name}-utils = %{version}-%{release}
460 Requires:       /bin/id
461 Requires:       awk
462 Requires:       bzip2
463 Requires:       chrpath >= 0.10-4
464 Requires:       cpio
465 Requires:       diffutils
466 Requires:       elfutils
467 Requires:       file >= 4.17
468 Requires:       fileutils
469 Requires:       findutils
470 %ifarch athlon
471 Requires:       gcc >= 3.0.3
472 %else
473 Requires:       gcc
474 %endif
475 Requires:       glibc-devel
476 Requires:       grep
477 Requires:       gzip
478 Requires:       make
479 Requires:       patch
480 Requires:       sed >= 4.0
481 Requires:       sh-utils
482 Requires:       tar >= 1:1.22
483 Requires:       textutils
484 Requires:       which
485 Requires:       xz
486 Provides:       rpmbuild(monoautodeps)
487 Provides:       rpmbuild(noauto) = 3
488 %ifarch %{x8664}
489 Conflicts:      automake < 1:1.7.9-2
490 Conflicts:      libtool < 2:1.5-13
491 %endif
492
493 %description build
494 Scripts for building binary RPM packages.
495
496 %description build -l de.UTF-8
497 Scripts fürs Bauen binärer RPM-Pakete.
498
499 %description build -l pl.UTF-8
500 Skrypty pomocnicze do budowania binarnych RPM-ów.
501
502 %description build -l pt_BR.UTF-8
503 Este pacote contém scripts e programas executáveis que são usados para
504 construir pacotes usando o RPM.
505
506 %description build -l ru.UTF-8
507 Различные вспомогательные скрипты и исполняемые программы, которые
508 используются для сборки RPM'ов.
509
510 %description build -l uk.UTF-8
511 Різноманітні допоміжні скрипти та утиліти, які використовуються для
512 побудови RPM'ів.
513
514 %package javaprov
515 Summary:        Additional utilities for checking Java provides/requires in RPM packages
516 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
517 Group:          Applications/File
518 Requires:       %{name} = %{version}-%{release}
519 Requires:       file
520 Requires:       findutils >= 1:4.2.26
521 Requires:       mktemp
522 Requires:       unzip
523
524 %description javaprov
525 Additional utilities for checking Java provides/requires in RPM
526 packages.
527
528 %description javaprov -l pl.UTF-8
529 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
530 RPM.
531
532 %package perlprov
533 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
534 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
535 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
536 Group:          Applications/File
537 Requires:       %{name} = %{version}-%{release}
538 Requires:       perl-Encode
539 Requires:       perl-devel
540 Requires:       perl-modules
541
542 %description perlprov
543 Additional utilities for checking Perl provides/requires in RPM
544 packages.
545
546 %description perlprov -l de.UTF-8
547 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
548
549 %description perlprov -l pl.UTF-8
550 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
551 pakietach RPM.
552
553 %package pythonprov
554 Summary:        Python macros, which simplifies creation of RPM packages with Python software
555 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
556 Group:          Applications/File
557 Requires:       %{name} = %{version}-%{release}
558 Requires:       python
559 Requires:       python-setuptools
560 Requires:       python-modules
561
562 %description pythonprov
563 Python macros, which simplifies creation of RPM packages with Python
564 software.
565
566 %description pythonprov -l pl.UTF-8
567 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
568 Pythonie.
569
570 %package php-pearprov
571 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
572 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
573 Group:          Applications/File
574 Requires:       %{name} = %{version}-%{release}
575 Requires:       sed >= 4.0
576 Suggests:       php-pear-PHP_CompatInfo
577
578 %description php-pearprov
579 Additional utilities for checking PHP PEAR provides/requires in RPM
580 packages.
581
582 %description php-pearprov -l pl.UTF-8
583 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
584 pakietach RPM.
585
586 %package rubyprov
587 Summary:        Ruby tools, which simplify creation of RPM packages with Ruby software
588 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
589 Group:          Applications/File
590 Requires:       %{name} = %{version}-%{release}
591 Requires:       ruby
592 Requires:       ruby-modules
593 Requires:       ruby-rubygems
594
595 %description rubyprov
596 Ruby tools, which simplifies creation of RPM packages with Ruby
597 software.
598
599 %description rubyprov -l pl.UTF-8
600 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
601 Ruby.
602
603 %package -n python-rpm
604 Summary:        Python interface to RPM library
605 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
606 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
607 Group:          Development/Languages/Python
608 Requires:       %{name} = %{version}-%{release}
609 Requires:       python
610 Obsoletes:      rpm-python
611
612 %description -n python-rpm
613 The rpm-python package contains a module which permits applications
614 written in the Python programming language to use the interface
615 supplied by RPM (RPM Package Manager) libraries.
616
617 This package should be installed if you want to develop Python
618 programs that will manipulate RPM packages and databases.
619
620 %description -n python-rpm -l pl.UTF-8
621 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
622 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
623
624 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
625 Pythonie programy manipulujące pakietami i bazami danych rpm.
626
627 %description -n python-rpm -l pt_BR.UTF-8
628 O pacote rpm-python contém um módulo que permite que aplicações
629 escritas em Python utilizem a interface fornecida pelas bibliotecas
630 RPM (RPM Package Manager).
631
632 Esse pacote deve ser instalado se você quiser desenvolver programas em
633 Python para manipular pacotes e bancos de dados RPM.
634
635 %package apidocs
636 Summary:        RPM API documentation and guides
637 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
638 Group:          Documentation
639 %if "%{_rpmversion}" >= "5"
640 BuildArch:      noarch
641 %endif
642
643 %description apidocs
644 Documentation for RPM API and guides in HTML format generated from rpm
645 sources by doxygen.
646
647 %description apidocs -l pl.UTF-8
648 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
649 źrodeł RPM-a przez doxygen.
650
651 %prep
652 %setup -q -n %{name}-%{version}%{?subver}
653
654 %patch1 -p1
655 %patch2 -p1
656 %patch4 -p1
657 %patch5 -p1
658 %patch6 -p1
659 %patch7 -p1
660 %patch9 -p1
661 %patch14 -p0
662 %patch15 -p1
663 #%patch16 -p1
664 %patch18 -p1
665 %patch20 -p1
666 %patch29 -p1
667 %patch30 -p1
668 %patch37 -p1
669 %patch61 -p1
670 #%patch64 -p1
671 %patch81 -p1
672 %patch83 -p1
673 %patch84 -p1
674
675 install %{SOURCE2} pld.in
676 install %{SOURCE8} scripts/php.prov.in
677 install %{SOURCE9} scripts/php.req.in
678 install %{SOURCE11} scripts/perl.prov.in
679 cp -p %{SOURCE30} scripts/rubygems.rb
680 cp -p %{SOURCE31} scripts/gem_helper.rb
681
682 %{__mv} -f scripts/perl.req{,.in}
683
684 # generate Group translations to *.po
685 awk -f %{SOURCE6} %{SOURCE1}
686
687 install %{SOURCE26} tools/rpmdb_checkversion.c
688 install %{SOURCE28} tools/rpmdb_reset.c
689
690 %{__sed} -i -e '1s,/usr/bin/python,%{__python},' scripts/pythondistdeps.py
691
692 %build
693 %{__libtoolize}
694 #%{__autopoint}
695 %{__aclocal}
696 %{__autoheader}
697 %{__autoconf}
698 %{__automake}
699
700 # rpm checks for CPU type at runtime, but it looks better
701 sed -i \
702         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
703         -e 's|@host_cpu@|%{_target_cpu}|' \
704         -e 's|@host_os@|%{_target_os}|' \
705         macros.in
706
707 CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
708 %configure \
709         WITH_PERL_VERSION=no \
710         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
711         __GPG=%{_bindir}/gpg \
712         %{?with_python:PYTHON=python%{py_ver}} \
713         --disable-silent-rules \
714         --enable-shared \
715         --enable-static \
716         --with-hackingdocs=%{!?with_apidocs:no}%{?with_apidocs:yes} \
717         --enable-bdb \
718         --with-crypto=openssl \
719         --with-lua \
720         --with-cap \
721         --with-acl \
722         --with-audit \
723         %{?with_python:--enable-python} \
724         --with-selinux=%{!?with_selinux:no}%{?with_selinux:yes} \
725         --with-vendor=pld
726
727 #  --enable-zstd=[yes/no/auto] build without zstd support (default=auto)
728 #  --enable-ndb (EXPERIMENTAL) enable the new rpm database format
729 #  --enable-lmdb=[yes/no/auto] (EXPERIMENTAL) build with LMDB rpm database format support (default=auto)
730 #  --with-archive          build rpm2archive - requires libarchive
731 #  --with-imaevm           build with imaevm support
732
733 %{__make}
734
735 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
736         -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
737 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
738         -o tools/rpmdb_reset -ldb-%{reqdb_ver}
739
740 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
741         echo "Error linking rpmdb tools!"
742         exit 1
743 fi
744 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
745         echo "Error linking rpmdb tools!"
746         exit 1
747 fi
748
749 %install
750 rm -rf $RPM_BUILD_ROOT
751 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
752         $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
753
754 install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
755
756 %{__make} -j1 install \
757         pkgconfigdir=%{_pkgconfigdir} \
758         DESTDIR=$RPM_BUILD_ROOT
759
760 # cleanup
761 %ifnarch %{ix86} %{x8664} x32
762 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
763 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
764 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
765 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
766 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
767 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
768 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
769 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
770 %endif
771
772 %ifnarch %{x8664} x32
773 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
774 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
775 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
776 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
777 %endif
778
779 %ifnarch %{ppc}
780 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
781 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
782 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
783 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
784 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
785 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
786 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
787 %endif
788
789 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
790 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
791 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
792 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
793 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
794 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
795 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
796 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
797 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
798
799 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
800
801 install %{SOURCE1} doc/manual/groups
802 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
803 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
804 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
805 install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
806 install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
807 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
808 cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
809 install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
810 install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
811 install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
812
813 install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
814
815 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
816
817 install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
818 install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
819 install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
820 install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
821 install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
822 install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
823 install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
824
825 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
826 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
827 install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
828 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
829 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
830 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
831
832 install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
833 install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
834 #install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
835
836 # create macro loading wrappers for backward compatibility
837 for m in gstreamer java mono perl php python; do
838         echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
839 done
840
841 # move rpm to /bin
842 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
843 # move essential libs to /lib (libs that /bin/rpm links to)
844 for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
845         mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
846         ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
847 done
848
849 %if %{with python}
850 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
851 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
852
853 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,py}
854 %endif
855
856 # wrong location, not used anyway
857 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
858
859 %find_lang %{name}
860
861 %{__rm} -rf manual
862 cp -a doc/manual manual
863 %{__rm} -f manual/Makefile*
864
865 %clean
866 rm -rf $RPM_BUILD_ROOT
867
868 %pretrans
869 # this needs to be a dir
870 if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
871         umask 022
872         mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
873         mkdir %{_sysconfdir}/rpm/sysinfo
874 fi
875
876 %posttrans
877 if [ -e /var/lib/rpm/Packages ] && \
878                 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
879         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
880                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
881                 echo
882                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
883                 echo
884         fi
885         echo
886         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
887         echo 'you should ignore it and restart poldek'
888         echo
889         %{_rpmlibdir}/bin/dbupgrade.sh
890 fi
891
892 %triggerpostun -- %{name} < 4.4.9-44
893 %{_rpmlibdir}/hrmib-cache
894
895 %post   lib -p /sbin/ldconfig
896 %postun lib -p /sbin/ldconfig
897
898 %pretrans build
899 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
900
901 %files -f %{name}.lang
902 %defattr(644,root,root,755)
903 %doc ChangeLog CREDITS README manual/*
904
905 %dir /etc/pki/rpm-gpg
906 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
907
908 %attr(755,root,root) /bin/rpm
909
910 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
911 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
912 %dir %{_sysconfdir}/rpm/sysinfo
913 # these are ok to be replaced
914 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
915
916 %{_mandir}/man8/rpm.8*
917 %lang(fr) %{_mandir}/fr/man8/rpm.8*
918 %lang(ja) %{_mandir}/ja/man8/rpm.8*
919 %lang(pl) %{_mandir}/pl/man8/rpm.8*
920 %lang(ru) %{_mandir}/ru/man8/rpm.8*
921 %lang(sk) %{_mandir}/sk/man8/rpm.8*
922
923 #%dir /var/lib/rpm
924 #%dir /var/lib/rpm/log
925 #%dir /var/lib/rpm/tmp
926 #%config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
927
928 # exported package NVRA (stamped with install tid)
929 # net-snmp hrSWInstalledName queries, bash-completions
930 %dir /var/cache/hrmib
931
932 %{_rpmlibdir}/rpmpopt*
933 %{_rpmlibdir}/macros
934 %dir %{_rpmlibdir}/macros.d
935 #%{_rpmlibdir}/macros.d/pld
936 %{_rpmlibdir}/platform/noarch-*
937 %ifarch %{ix86} %{x8664} x32
938 %{_rpmlibdir}/platform/athlon*
939 %{_rpmlibdir}/platform/geode*
940 %{_rpmlibdir}/platform/i?86*
941 %{_rpmlibdir}/platform/pentium*
942 %endif
943 %ifarch %{x8664} x32
944 %{_rpmlibdir}/platform/amd64*
945 %{_rpmlibdir}/platform/ia32e*
946 %{_rpmlibdir}/platform/x86_64*
947 %{_rpmlibdir}/platform/x32*
948 %endif
949 %ifarch alpha
950 %{_rpmlibdir}/platform/alpha*
951 %endif
952 %ifarch ia64
953 %{_rpmlibdir}/platform/ia64*
954 %endif
955 %ifarch mips mipsel mips64 mips64el
956 %{_rpmlibdir}/platform/mips*
957 %endif
958 %ifarch %{ppc}
959 %{_rpmlibdir}/platform/ppc*
960 %endif
961 %ifarch sparc sparc64
962 %{_rpmlibdir}/platform/sparc*
963 %endif
964
965 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
966
967 %dir %{_rpmlibdir}/bin
968 #%attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
969 #%attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
970 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
971 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
972 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmdbchk
973
974 %files base
975 %defattr(644,root,root,755)
976 %dir %{_sysconfdir}/rpm
977 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
978 %dir %{_rpmlibdir}
979 %attr(755,root,root) %{_bindir}/banner.sh
980 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
981 %dir /var/lib/banner
982
983 %files lib
984 %defattr(644,root,root,755)
985 %attr(755,root,root) /%{_lib}/librpm.so.9
986 %attr(755,root,root) /%{_lib}/librpm.so.%{sover}
987 %attr(755,root,root) /%{_lib}/librpmbuild.so.9
988 %attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
989 %attr(755,root,root) /%{_lib}/librpmio.so.9
990 %attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
991 %attr(755,root,root) /%{_lib}/librpmsign.so.9
992 %attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
993
994 %files devel
995 %defattr(644,root,root,755)
996 %attr(755,root,root) %{_libdir}/librpm.so
997 %attr(755,root,root) %{_libdir}/librpmbuild.so
998 %attr(755,root,root) %{_libdir}/librpmio.so
999 %attr(755,root,root) %{_libdir}/librpmsign.so
1000 %{_libdir}/librpm*.la
1001 %{_includedir}/rpm
1002 %{_pkgconfigdir}/*.pc
1003
1004 %files static
1005 %defattr(644,root,root,755)
1006 %{_libdir}/librpm*.a
1007
1008 %files utils
1009 %defattr(644,root,root,755)
1010 %attr(755,root,root) %{_bindir}/rpm2cpio
1011 #%attr(755,root,root) %{_bindir}/rpmconstant
1012 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1013 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1014 %attr(755,root,root) %{_rpmlibdir}/tgpg
1015 #%attr(755,root,root) %{_rpmlibdir}/bin/chroot
1016 #%attr(755,root,root) %{_rpmlibdir}/bin/cp
1017 #%attr(755,root,root) %{_rpmlibdir}/bin/debugedit
1018 #%attr(755,root,root) %{_rpmlibdir}/bin/find
1019 #%attr(755,root,root) %{_rpmlibdir}/bin/mgo
1020 #%attr(755,root,root) %{_rpmlibdir}/bin/mtree
1021 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1022 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1023 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1024 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
1025 %if %{with selinux}
1026 #%attr(755,root,root) %{_rpmlibdir}/bin/semodule
1027 #%attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1028 %endif
1029 %{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
1030 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
1031 %{_mandir}/man8/rpm2cpio.8*
1032 #%{_mandir}/man8/rpmconstant.8*
1033 %{_mandir}/man8/rpmdeps.8*
1034 #%{_mandir}/man8/rpmmtree.8*
1035 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1036 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1037 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1038 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1039
1040 %files utils-perl
1041 %defattr(644,root,root,755)
1042 #%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1043
1044 %if %{with static}
1045 %files utils-static
1046 %defattr(644,root,root,755)
1047 %attr(755,root,root) %{_bindir}/rpm[ieu]
1048 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1049 %endif
1050
1051 %files build
1052 %defattr(644,root,root,755)
1053 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1054 %attr(755,root,root) %{_rpmlibdir}/brp-*
1055 %attr(755,root,root) %{_rpmlibdir}/check-files
1056 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1057 #%attr(755,root,root) %{_rpmlibdir}/cross-build
1058 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1059 #%attr(755,root,root) %{_rpmlibdir}/getpo.sh
1060 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1061 #%attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1062 #%attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1063 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1064 %attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
1065 # needs hacked pkg-config to return anything
1066 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1067 #%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1068 #%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
1069 #%attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1070 #%attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
1071 #%attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1072 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmspec
1073 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1074 #%attr(755,root,root) %{_rpmlibdir}/bin/wget
1075 #%attr(755,root,root) %{_rpmlibdir}/vcheck
1076 # not used yet ... these six depend on perl
1077 #%attr(755,root,root) %{_rpmlibdir}/http.req
1078 # we always used scripts provided by mono-devel, maybe move them here
1079 #%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1080 #%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
1081
1082 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
1083 # must be here for "Requires: rpm-*prov" to work
1084 #%{_rpmlibdir}/macros.d/cmake
1085 #%{_rpmlibdir}/macros.d/gstreamer
1086 #%{_rpmlibdir}/macros.d/java
1087 #%{_rpmlibdir}/macros.d/libtool
1088 #%{_rpmlibdir}/macros.d/mono
1089 #%{_rpmlibdir}/macros.d/perl
1090 #%{_rpmlibdir}/macros.d/php
1091 #%{_rpmlibdir}/macros.d/pkgconfig
1092 #%{_rpmlibdir}/macros.d/python
1093 #%{_rpmlibdir}/macros.d/ruby
1094 #%{_rpmlibdir}/macros.d/selinux
1095 #%{_rpmlibdir}/macros.d/tcl
1096 #%{_rpmlibdir}/macros.rpmbuild
1097 # compat wrappers
1098 #%{_rpmlibdir}/macros.gstreamer
1099 %{_rpmlibdir}/macros.java
1100 %{_rpmlibdir}/macros.mono
1101 %{_rpmlibdir}/macros.perl
1102 %{_rpmlibdir}/macros.php
1103 %{_rpmlibdir}/macros.python
1104
1105 #%attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1106 #%attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1107
1108 %attr(755,root,root) %{_bindir}/gendiff
1109 %attr(755,root,root) %{_bindir}/rpmbuild
1110
1111 #%dir %{_rpmlibdir}/helpers
1112 #%attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
1113
1114 %{_mandir}/man1/gendiff.1*
1115 %{_mandir}/man8/rpmbuild.8*
1116 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1117 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1118 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1119
1120 %files javaprov
1121 %defattr(644,root,root,755)
1122 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1123 # needs jar (any jdk), jcf-dump (gcc-java) to work
1124 #%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1125
1126 %files rubyprov
1127 %defattr(644,root,root,755)
1128 #%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1129 #%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1130
1131 %files perlprov
1132 %defattr(644,root,root,755)
1133 %attr(755,root,root) %{_rpmlibdir}/perl.*
1134 #%attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1135 #%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1136
1137 %files pythonprov
1138 %defattr(644,root,root,755)
1139 #%attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
1140 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1141
1142 %files php-pearprov
1143 %defattr(644,root,root,755)
1144 %attr(755,root,root) %{_rpmlibdir}/php.prov
1145 %attr(755,root,root) %{_rpmlibdir}/php.req
1146 %attr(755,root,root) %{_rpmlibdir}/php.req.php
1147
1148 %if %{with python}
1149 %files -n python-rpm
1150 %defattr(644,root,root,755)
1151 %dir %{py_sitedir}/rpm
1152 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1153 %{py_sitedir}/rpm/*.py[co]
1154 %endif
1155
1156 %if %{with apidocs}
1157 %files apidocs
1158 %defattr(644,root,root,755)
1159 #%doc apidocs
1160 %endif
This page took 0.246621 seconds and 2 git commands to generate.