]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- clean up configure options
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4 #   returns -ENOSYS
5 # - add macros for some ppc, mipsel, alpha and sparc
6 #
7 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
8 #
9 # Conditional build:
10 %bcond_with     static          # build static rpm+rpmi
11 %bcond_without  apidocs         # don't generate documentation with doxygen
12 %bcond_without  python          # don't build python bindings
13 %bcond_without  selinux         # build without selinux support
14 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
15 %bcond_with     db61            # use DB 6.1 instead of 5.3
16 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
17 %bcond_with     keyutils        # build with keyutils support
18
19 # versions of required libraries
20 %if %{with db61}
21 %define         reqdb_pkg       db6.1
22 %define         reqdb_ver       6.1
23 %define         reqdb_pkgver    6.1.19
24 %else
25 %define         reqdb_pkg       db5.3
26 %define         reqdb_ver       5.3
27 %define         reqdb_pkgver    5.3.28.0
28 %endif
29 %define         reqpopt_ver     1.15
30 %define         openssl_ver     1.1.1d
31 %define         sover           9.0.1
32
33 Summary:        RPM Package Manager
34 Summary(de.UTF-8):      RPM Packet-Manager
35 Summary(es.UTF-8):      Gestor de paquetes RPM
36 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
37 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
38 Summary(ru.UTF-8):      Менеджер пакетов от RPM
39 Summary(uk.UTF-8):      Менеджер пакетів від RPM
40 Name:           rpm
41 Version:        4.15.1
42 Release:        0.1
43 License:        GPL v2 / LGPL v2.1
44 Group:          Base
45 Source0:        http://ftp.rpm.org/releases/rpm-4.15.x/%{name}-%{version}.tar.bz2
46 # Source0-md5:  ed72147451a5ed93b2a48e2f8f5413c3
47 Source1:        %{name}.groups
48 Source2:        macros.pld.in
49 Source3:        %{name}-install-tree
50 Source4:        %{name}-find-spec-bcond
51 Source5:        %{name}-hrmib-cache
52 Source6:        %{name}-groups-po.awk
53 Source7:        %{name}-compress-doc
54 Source8:        %{name}-php-provides
55 Source9:        %{name}-php-requires
56 Source10:       %{name}.sysinfo
57 Source11:       perl.prov
58 Source12:       %{name}-user_group.sh
59 Source13:       %{name}.sysconfig
60 Source14:       %{name}-java-requires
61 # http://svn.pld-linux.org/banner.sh/
62 Source15:       banner.sh
63 Source16:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
64 # Source16-md5: 23914bb49fafe7153cee87126d966461
65 Source17:       %{name}-mimetypedeps
66 Source18:       macros.local
67 Source19:       %{name}.noautocompressdoc
68 Source20:       %{name}.noautoprov
69 Source21:       %{name}.noautoprovfiles
70 Source22:       %{name}.noautoreq
71 Source24:       %{name}.noautoreqfiles
72 Source25:       %{name}-php-requires.php
73 Source26:       %{name}db_checkversion.c
74 Source27:       macros.lang
75 Source28:       %{name}db_reset.c
76 Source29:       dbupgrade.sh
77 Source30:       rubygems.rb
78 Source31:       gem_helper.rb
79 Patch1:         %{name}-man_pl.patch
80 Patch2:         %{name}-popt-aliases.patch
81 Patch4:         %{name}-perl-macros.patch
82 Patch5:         %{name}-perl-req-perlfile.patch
83 Patch6:         %{name}-scripts-closefds.patch
84 Patch7:         %{name}-php-macros.patch
85 Patch9:         %{name}-lua.patch
86 Patch14:        %{name}-perl_req-INC_dirs.patch
87 Patch15:        %{name}-debuginfo.patch
88 Patch16:        vendor-pld.patch
89 Patch18:        %{name}-javadeps.patch
90 Patch20:        %{name}-libtool-deps.patch
91 Patch29:        %{name}-builddir-readlink.patch
92 Patch30:        %{name}-changelog_order_check_nonfatal.patch
93 Patch35:        %{name}-namespace-compare.patch
94 Patch37:        %{name}-postun-nofail.patch
95 Patch61:        %{name}-clean-docdir.patch
96 Patch64:        %{name}-fix-compress-doc.patch
97 Patch81:        %{name}-perl-magic.patch
98 Patch83:        %{name}-ignore-missing-macro-files.patch
99 Patch84:        x32.patch
100
101 URL:            http://rpm5.org/
102 BuildRequires:  %{reqdb_pkg}-devel >= %{reqdb_pkgver}
103 BuildRequires:  %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
104 BuildRequires:  autoconf >= 2.63
105 BuildRequires:  automake >= 1.4
106 BuildRequires:  openssl-devel >= %{openssl_ver}
107 BuildRequires:  bzip2-devel >= 1.0.2-17
108 BuildRequires:  elfutils-devel >= 0.108
109 BuildRequires:  gettext-tools >= 0.19.2
110 %{?with_keyutils:BuildRequires: keyutils-devel}
111 BuildRequires:  libmagic-devel
112 %if %{with selinux}
113 BuildRequires:  libselinux-devel >= 2.1.0
114 BuildRequires:  libsemanage-devel >= 2.1.0
115 BuildRequires:  libsepol-devel >= 2.1.0
116 %endif
117 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
118 BuildRequires:  libstdc++-devel
119 BuildRequires:  libtool >= 1:1.4.2-9
120 %if %{with neon}
121 BuildRequires:  libxml2-devel
122 BuildRequires:  neon-devel >= 0.25.5
123 %endif
124 BuildRequires:  lua53-devel >= 5.3.5
125 BuildRequires:  ossp-uuid-devel
126 BuildRequires:  patch >= 2.2
127 BuildRequires:  popt-devel >= %{reqpopt_ver}
128 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
129 BuildRequires:  python-modules >= 1:2.3
130 %{?with_python:BuildRequires:   rpm-pythonprov}
131 BuildRequires:  tcl
132 BuildRequires:  xz-devel
133 BuildRequires:  zlib-devel
134 BuildRequires:  zstd-devel
135 %if %{with apidocs}
136 BuildRequires:  doxygen
137 BuildRequires:  ghostscript
138 BuildRequires:  graphviz
139 BuildRequires:  tetex-pdftex
140 %endif
141 %if %{with static}
142 # Require static library only for static build
143 BuildRequires:  %{reqdb_pkg}-static >= %{reqdb_pkgver}
144 BuildRequires:  openssl-static >= %{openssl_ver}
145 BuildRequires:  bzip2-static >= 1.0.2-17
146 BuildRequires:  elfutils-static
147 BuildRequires:  glibc-static >= 2.2.94
148 BuildRequires:  libmagic-static
149 %if %{with selinux}
150 BuildRequires:  libselinux-static >= 2.1.0
151 BuildRequires:  libsemanage-static >= 2.1.0
152 BuildRequires:  libsepol-static >= 2.1.0
153 %endif
154 BuildRequires:  popt-static >= %{reqpopt_ver}
155 BuildRequires:  zlib-static
156 BuildRequires:  zstd-static
157 %endif
158 Requires(posttrans):    coreutils
159 Requires:       FHS >= 3.0-2
160 Requires:       %{name}-base = %{version}-%{release}
161 Requires:       %{name}-lib = %{version}-%{release}
162 Requires:       openssl >= %{openssl_ver}
163 Requires:       popt >= %{reqpopt_ver}
164 Provides:       rpm-db-ver = %{reqdb_ver}
165 Obsoletes:      rpm-getdeps
166 %{!?with_static:Obsoletes:      rpm-utils-static}
167 Conflicts:      glibc < 2.2.92
168 # db4.6 poldek needed
169 Conflicts:      poldek < 0.21-0.20070703.00.3
170 # segfaults with lzma 0.42.2
171 Conflicts:      lzma-libs < 4.999.3
172 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
173 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
174
175 %define         _binary_payload         w9.gzdio
176
177 # don't require very fresh rpm.macros to build
178 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
179 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
180 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
181 %define         ppc     ppc ppc7400 ppc7450
182 %define         x8664   amd64 ia32e x86_64
183
184 %define         _rpmlibdir /usr/lib/rpm
185 %define         _noautocompressdoc      RPM-GPG-KEY
186
187 %description
188 RPM is a powerful package manager, which can be used to build,
189 install, query, verify, update, and uninstall individual software
190 packages. A package consists of an archive of files, and package
191 information, including name, version, and description.
192
193 %description -l de.UTF-8
194 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
195 Installation, Anfrage, Verifizierung, Aktualisierung und
196 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
197 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
198 Beschreibung.
199
200 %description -l es.UTF-8
201 RPM es un poderoso administrador de paquetes, que puede ser usado para
202 construir, instalar, pesquisar, verificar, actualizar y desinstalar
203 paquetes individuales de software. Un paquete consiste en un
204 almacenaje de archivos, y información sobre el paquete, incluyendo
205 nombre, versión y descripción.
206
207 %description -l pl.UTF-8
208 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
209 przebudowanie, instalację czy weryfikację dowolnego pakietu.
210 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
211 plików wchodzących w skład pakietu, zależności od innych pakietów, są
212 przechowywane w bazie danych i można je uzyskać za pomocą opcji
213 odpytywania programu rpm.
214
215 %description -l pt_BR.UTF-8
216 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
217 construir, instalar, pesquisar, verificar, atualizar e desinstalar
218 pacotes individuais de software. Um pacote consiste de um conjunto de
219 arquivos e informações adicionais, incluindo nome, versão e descrição
220 do pacote, permissões dos arquivos, etc.
221
222 %description -l ru.UTF-8
223 RPM - это мощный менеджер пакетов, который может быть использован для
224 создания, инсталляции, запросов (query), проверки, обновления и
225 удаления программных пакетов. Пакет состоит из файлового архива и
226 служебной информации, включающей название, версию, описание и другие
227 данные о пакете.
228
229 %description -l uk.UTF-8
230 RPM - це потужний менеджер пакетів, що може бути використаний для
231 створення, інсталяції, запитів (query), перевірки, поновлення та
232 видалення програмних пакетів. Пакет складається з файлового архіву та
233 службової інформації, що містить назву, версію, опис та іншу
234 інформацію про пакет.
235
236 %package base
237 Summary:        RPM base package - scripts used by rpm packages themselves
238 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
239 Group:          Base
240 Requires:       filesystem
241 Obsoletes:      rpm-scripts
242 Obsoletes:      vserver-rpm
243
244 %description base
245 The RPM base package contains scripts used by rpm packages themselves.
246 These include:
247 - scripts for adding/removing groups and users needed for rpm
248   packages,
249 - banner.sh to display %%banner messages from rpm scriptlets.
250
251 %description base -l pl.UTF-8
252 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
253 Zawiera on:
254 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
255 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
256
257 %package lib
258 Summary:        RPMs library
259 Summary(pl.UTF-8):      Biblioteki RPM-a
260 Group:          Libraries
261 Requires:       %{reqdb_pkg} >= %{reqdb_pkgver}
262 Requires:       %{reqdb_pkg}-sql >= %{reqdb_pkgver}
263 Requires:       openssl >= %{openssl_ver}
264 Requires:       libmagic >= 1.15-2
265 %{?with_selinux:Requires:       libselinux >= 2.1.0}
266 Requires:       popt >= %{reqpopt_ver}
267 Obsoletes:      rpm-libs
268 # avoid SEGV caused by mixed db versions
269 Conflicts:      poldek < 0.18.1-16
270
271 %description lib
272 RPMs library.
273
274 %description lib -l pl.UTF-8
275 Biblioteki RPM-a.
276
277 %package devel
278 Summary:        Header files for rpm libraries
279 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
280 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
281 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
282 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
283 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
284 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
285 Group:          Development/Libraries
286 Requires:       %{name}-lib = %{version}-%{release}
287 Requires:       %{reqdb_pkg}-devel >= %{reqdb_pkgver}
288 Requires:       openssl-devel >= %{openssl_ver}
289 Requires:       bzip2-devel
290 Requires:       elfutils-devel
291 %{?with_keyutils:Requires:      keyutils-devel}
292 Requires:       libmagic-devel
293 %if %{with selinux}
294 Requires:       libselinux-devel
295 Requires:       libsemanage-devel
296 Requires:       libsepol-devel
297 %endif
298 Requires:       popt-devel >= %{reqpopt_ver}
299 Requires:       zlib-devel
300
301 %description devel
302 The RPM packaging system includes C libraries that make it easy to
303 manipulate RPM packages and databases. They are intended to ease the
304 creation of graphical package managers and other tools that need
305 intimate knowledge of RPM packages. This package contains header files
306 for these libraries.
307
308 %description devel -l de.UTF-8
309 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
310 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
311 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
312 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
313
314 %description devel -l es.UTF-8
315 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
316 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
317 facilitar la creación de administradores gráficos de paquetes y otras
318 herramientas que necesiten un conocimiento profundo de paquetes RPM.
319
320 %description devel -l pl.UTF-8
321 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
322 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
323 graficznych programów zarządzających pakietami oraz innych narzędzi,
324 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
325 zawiera pliki nagłówkowe wspomnianych bibliotek.
326
327 %description devel -l pt_BR.UTF-8
328 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
329 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
330 facilitar a criação de gerenciadores gráficos de pacotes e outras
331 ferramentas que precisem de conhecimento profundo de pacotes RPM.
332
333 %description devel -l ru.UTF-8
334 Система управления пакетами RPM содержит библиотеку C, которая
335 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
336 Эта библиотека предназначена для облегчения создания графических
337 пакетных менеджеров и других утилит, которым необходимо работать с
338 пакетами RPM.
339
340 %description devel -l uk.UTF-8
341 Система керування пакетами RPM містить бібліотеку C, котра спрощує
342 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
343 призначена для полегшення створення графічних пакетних менеджерів та
344 інших утиліт, що працюють з пакетами RPM.
345
346 %package static
347 Summary:        RPM static libraries
348 Summary(de.UTF-8):      RPMs statische Libraries
349 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
350 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
351 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
352 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
353 Group:          Development/Libraries
354 Requires:       %{name}-devel = %{version}-%{release}
355 Requires:       %{reqdb_pkg}-static >= %{reqdb_pkgver}
356 Requires:       openssl-static >= %{openssl_ver}
357 Requires:       bzip2-static
358 Requires:       elfutils-static
359 %{?with_keyutils:Requires:      keyutils-static}
360 Requires:       libmagic-static
361 %if %{with selinux}
362 Requires:       libselinux-static
363 Requires:       libsemanage-static
364 Requires:       libsepol-static
365 %endif
366 Requires:       popt-static >= %{reqpopt_ver}
367 Requires:       zlib-static
368
369 %description static
370 RPM static libraries.
371
372 %description static -l de.UTF-8
373 RPMs statische Libraries.
374
375 %description static -l pl.UTF-8
376 Biblioteki statyczne RPM-a.
377
378 %description static -l pt_BR.UTF-8
379 Bibliotecas estáticas para desenvolvimento.
380
381 %description static -l ru.UTF-8
382 Система управления пакетами RPM содержит библиотеку C, которая
383 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
384 Это статическая библиотека RPM.
385
386 %description static -l uk.UTF-8
387 Система керування пакетами RPM містить бібліотеку C, котра спрощує
388 роботу з пакетами RPM та відповідними базами даних. Це статична
389 бібліотека RPM.
390
391 %package utils
392 Summary:        Additional utilities for managing RPM packages and database
393 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
394 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
395 Group:          Applications/File
396 Requires:       %{name} = %{version}-%{release}
397 Requires:       popt >= %{reqpopt_ver}
398 %if %{with suggest_tags}
399 Suggests:       bzip2
400 Suggests:       gzip
401 %endif
402 Conflicts:      filesystem-debuginfo < 3.0-16
403
404 %description utils
405 Additional utilities for managing RPM packages and database.
406
407 %description utils -l de.UTF-8
408 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
409
410 %description utils -l pl.UTF-8
411 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
412
413 %package utils-perl
414 Summary:        Additional utilities for managing RPM packages and database
415 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
416 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
417 Group:          Applications/File
418 Requires:       %{name}-utils = %{version}-%{release}
419 Requires:       popt >= %{reqpopt_ver}
420
421 %description utils-perl
422 Additional utilities for managing RPM packages and database.
423
424 %description utils-perl -l de.UTF-8
425 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
426
427 %description utils-perl -l pl.UTF-8
428 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
429
430 %package utils-static
431 Summary:        Static rpm utilities
432 Summary(pl.UTF-8):      Statyczne narzędzia rpm
433 Group:          Applications/System
434 Requires:       %{name} = %{version}-%{release}
435
436 %description utils-static
437 Static rpm utilities for repairing system in case something with
438 shared libraries used by rpm become broken. Currently it contains rpmi
439 binary, which can be used to install/upgrade/remove packages without
440 using shared libraries (well, in fact with exception of NSS modules).
441
442 %description utils-static -l pl.UTF-8
443 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
444 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
445 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
446 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
447 (z wyjątkiem modułów NSS).
448
449 %package build
450 Summary:        Scripts for building binary RPM packages
451 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
452 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
453 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
454 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
455 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
456 Group:          Applications/File
457 Requires(pretrans):     coreutils
458 Requires(pretrans):     findutils
459 Requires:       %{name}-build-macros >= 1.712
460 Requires:       %{name}-utils = %{version}-%{release}
461 Requires:       /bin/id
462 Requires:       awk
463 Requires:       bzip2
464 Requires:       chrpath >= 0.10-4
465 Requires:       cpio
466 Requires:       diffutils
467 Requires:       elfutils
468 Requires:       file >= 4.17
469 Requires:       fileutils
470 Requires:       findutils
471 %ifarch athlon
472 Requires:       gcc >= 3.0.3
473 %else
474 Requires:       gcc
475 %endif
476 Requires:       glibc-devel
477 Requires:       grep
478 Requires:       gzip
479 Requires:       make
480 Requires:       patch
481 Requires:       sed >= 4.0
482 Requires:       sh-utils
483 Requires:       tar >= 1:1.22
484 Requires:       textutils
485 Requires:       which
486 Requires:       xz
487 Provides:       rpmbuild(monoautodeps)
488 Provides:       rpmbuild(noauto) = 3
489 %ifarch %{x8664}
490 Conflicts:      automake < 1:1.7.9-2
491 Conflicts:      libtool < 2:1.5-13
492 %endif
493
494 %description build
495 Scripts for building binary RPM packages.
496
497 %description build -l de.UTF-8
498 Scripts fürs Bauen binärer RPM-Pakete.
499
500 %description build -l pl.UTF-8
501 Skrypty pomocnicze do budowania binarnych RPM-ów.
502
503 %description build -l pt_BR.UTF-8
504 Este pacote contém scripts e programas executáveis que são usados para
505 construir pacotes usando o RPM.
506
507 %description build -l ru.UTF-8
508 Различные вспомогательные скрипты и исполняемые программы, которые
509 используются для сборки RPM'ов.
510
511 %description build -l uk.UTF-8
512 Різноманітні допоміжні скрипти та утиліти, які використовуються для
513 побудови RPM'ів.
514
515 %package javaprov
516 Summary:        Additional utilities for checking Java provides/requires in RPM packages
517 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
518 Group:          Applications/File
519 Requires:       %{name} = %{version}-%{release}
520 Requires:       file
521 Requires:       findutils >= 1:4.2.26
522 Requires:       mktemp
523 Requires:       unzip
524
525 %description javaprov
526 Additional utilities for checking Java provides/requires in RPM
527 packages.
528
529 %description javaprov -l pl.UTF-8
530 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
531 RPM.
532
533 %package perlprov
534 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
535 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
536 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
537 Group:          Applications/File
538 Requires:       %{name} = %{version}-%{release}
539 Requires:       perl-Encode
540 Requires:       perl-devel
541 Requires:       perl-modules
542
543 %description perlprov
544 Additional utilities for checking Perl provides/requires in RPM
545 packages.
546
547 %description perlprov -l de.UTF-8
548 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
549
550 %description perlprov -l pl.UTF-8
551 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
552 pakietach RPM.
553
554 %package pythonprov
555 Summary:        Python macros, which simplifies creation of RPM packages with Python software
556 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
557 Group:          Applications/File
558 Requires:       %{name} = %{version}-%{release}
559 Requires:       python
560 Requires:       python-setuptools
561 Requires:       python-modules
562
563 %description pythonprov
564 Python macros, which simplifies creation of RPM packages with Python
565 software.
566
567 %description pythonprov -l pl.UTF-8
568 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
569 Pythonie.
570
571 %package php-pearprov
572 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
573 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
574 Group:          Applications/File
575 Requires:       %{name} = %{version}-%{release}
576 Requires:       sed >= 4.0
577 Suggests:       php-pear-PHP_CompatInfo
578
579 %description php-pearprov
580 Additional utilities for checking PHP PEAR provides/requires in RPM
581 packages.
582
583 %description php-pearprov -l pl.UTF-8
584 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
585 pakietach RPM.
586
587 %package rubyprov
588 Summary:        Ruby tools, which simplify creation of RPM packages with Ruby software
589 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
590 Group:          Applications/File
591 Requires:       %{name} = %{version}-%{release}
592 Requires:       ruby
593 Requires:       ruby-modules
594 Requires:       ruby-rubygems
595
596 %description rubyprov
597 Ruby tools, which simplifies creation of RPM packages with Ruby
598 software.
599
600 %description rubyprov -l pl.UTF-8
601 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
602 Ruby.
603
604 %package -n python-rpm
605 Summary:        Python interface to RPM library
606 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
607 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
608 Group:          Development/Languages/Python
609 Requires:       %{name} = %{version}-%{release}
610 Requires:       python
611 Obsoletes:      rpm-python
612
613 %description -n python-rpm
614 The rpm-python package contains a module which permits applications
615 written in the Python programming language to use the interface
616 supplied by RPM (RPM Package Manager) libraries.
617
618 This package should be installed if you want to develop Python
619 programs that will manipulate RPM packages and databases.
620
621 %description -n python-rpm -l pl.UTF-8
622 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
623 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
624
625 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
626 Pythonie programy manipulujące pakietami i bazami danych rpm.
627
628 %description -n python-rpm -l pt_BR.UTF-8
629 O pacote rpm-python contém um módulo que permite que aplicações
630 escritas em Python utilizem a interface fornecida pelas bibliotecas
631 RPM (RPM Package Manager).
632
633 Esse pacote deve ser instalado se você quiser desenvolver programas em
634 Python para manipular pacotes e bancos de dados RPM.
635
636 %package apidocs
637 Summary:        RPM API documentation and guides
638 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
639 Group:          Documentation
640 %if "%{_rpmversion}" >= "5"
641 BuildArch:      noarch
642 %endif
643
644 %description apidocs
645 Documentation for RPM API and guides in HTML format generated from rpm
646 sources by doxygen.
647
648 %description apidocs -l pl.UTF-8
649 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
650 źrodeł RPM-a przez doxygen.
651
652 %prep
653 %setup -q -n %{name}-%{version}%{?subver}
654
655 %patch1 -p1
656 %patch2 -p1
657 %patch4 -p1
658 %patch5 -p1
659 %patch6 -p1
660 %patch7 -p1
661 %patch9 -p1
662 %patch14 -p0
663 %patch15 -p1
664 #%patch16 -p1
665 #%patch18 -p1
666 %patch20 -p1
667 %patch29 -p1
668 %patch30 -p1
669 #%patch35 -p1
670 %patch37 -p1
671 %patch61 -p1
672 #%patch64 -p1
673 %patch81 -p1
674 %patch83 -p1
675 #%patch84 -p1
676
677 install %{SOURCE2} pld.in
678 install %{SOURCE8} scripts/php.prov.in
679 install %{SOURCE9} scripts/php.req.in
680 install %{SOURCE11} scripts/perl.prov.in
681 cp -p %{SOURCE30} scripts/rubygems.rb
682 cp -p %{SOURCE31} scripts/gem_helper.rb
683
684 %{__mv} -f scripts/perl.req{,.in}
685
686 # generate Group translations to *.po
687 awk -f %{SOURCE6} %{SOURCE1}
688
689 install %{SOURCE26} tools/rpmdb_checkversion.c
690 install %{SOURCE28} tools/rpmdb_reset.c
691
692 %{__sed} -i -e '1s,/usr/bin/python,%{__python},' scripts/pythondistdeps.py
693
694 %build
695 %{__libtoolize}
696 #%{__autopoint}
697 %{__aclocal}
698 %{__autoheader}
699 %{__autoconf}
700 %{__automake}
701
702 # rpm checks for CPU type at runtime, but it looks better
703 sed -i \
704         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
705         -e 's|@host_cpu@|%{_target_cpu}|' \
706         -e 's|@host_os@|%{_target_os}|' \
707         macros.in
708
709 CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
710 %configure \
711         WITH_PERL_VERSION=no \
712         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
713         __GPG=%{_bindir}/gpg \
714         %{?with_python:PYTHON=python%{py_ver}} \
715         --disable-silent-rules \
716         --enable-shared \
717         --enable-static \
718         --with-hackingdocs=%{!?with_apidocs:no}%{?with_apidocs:yes} \
719         --enable-bdb \
720         --with-crypto=openssl \
721         --with-lua \
722         --with-cap \
723         --with-acl \
724         --with-audit \
725         %{?with_python:--enable-python} \
726         --with-selinux=%{!?with_selinux:no}%{?with_selinux:yes} \
727         --with-vendor=pld
728
729 #  --enable-zstd=[yes/no/auto] build without zstd support (default=auto)
730 #  --enable-ndb (EXPERIMENTAL) enable the new rpm database format
731 #  --enable-lmdb=[yes/no/auto] (EXPERIMENTAL) build with LMDB rpm database format support (default=auto)
732 #  --with-archive          build rpm2archive - requires libarchive
733 #  --with-imaevm           build with imaevm support
734
735 %{__make}
736
737 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
738         -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
739 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
740         -o tools/rpmdb_reset -ldb-%{reqdb_ver}
741
742 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
743         echo "Error linking rpmdb tools!"
744         exit 1
745 fi
746 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
747         echo "Error linking rpmdb tools!"
748         exit 1
749 fi
750
751 %install
752 rm -rf $RPM_BUILD_ROOT
753 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
754         $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
755
756 install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
757
758 %{__make} -j1 install \
759         pkgconfigdir=%{_pkgconfigdir} \
760         DESTDIR=$RPM_BUILD_ROOT
761
762 # cleanup
763 %ifnarch %{ix86} %{x8664} x32
764 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
765 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
766 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
767 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
768 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
769 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
770 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
771 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
772 %endif
773
774 %ifnarch %{x8664} x32
775 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
776 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
777 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
778 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
779 %endif
780
781 %ifnarch %{ppc}
782 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
783 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
784 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
785 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
786 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
787 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
788 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
789 %endif
790
791 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
792 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
793 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
794 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
795 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
796 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
797 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
798 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
799 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
800
801 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
802 # first platform file entry can't contain regexps
803 %ifarch x32
804 %{_target_cpu}-%{_target_vendor}-linux-gnux32
805 %else
806 %{_target_cpu}-%{_target_vendor}-linux
807 %endif
808
809 %ifarch x86_64
810 x86_64-[^-]*-[Ll]inux(-gnu)?
811 amd64-[^-]*-[Ll]inux(-gnu)?
812 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
813 %endif
814 %ifarch amd64
815 amd64-[^-]*-[Ll]inux(-gnu)?
816 x86_64-[^-]*-[Ll]inux(-gnu)?
817 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
818 %endif
819 %ifarch ia32e
820 ia32e-[^-]*-[Ll]inux(-gnu)?
821 x86_64-[^-]*-[Ll]inux(-gnu)?
822 %endif
823 %ifarch x32
824 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
825 x86_64-[^-]*-[Ll]inux(-gnu)?
826 amd64-[^-]*-[Ll]inux(-gnu)?
827 %endif
828
829 %ifarch athlon %{x8664} x32
830 athlon-[^-]*-[Ll]inux(-gnu)?
831 %endif
832 %ifarch pentium4 athlon %{x8664} x32
833 pentium4-[^-]*-[Ll]inux(-gnu)?
834 %endif
835 %ifarch pentium3 pentium4 athlon %{x8664} x32
836 pentium3-[^-]*-[Ll]inux(-gnu)?
837 %endif
838 %ifarch i686 pentium3 pentium4 athlon %{x8664} x32
839 i686-[^-]*-[Ll]inux(-gnu)?
840 %endif
841 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664} x32
842 i586-[^-]*-[Ll]inux(-gnu)?
843 %endif
844 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664} x32
845 i486-[^-]*-[Ll]inux(-gnu)?
846 %endif
847 %ifarch %{ix86} %{x8664} x32
848 i386-[^-]*-[Ll]inux(-gnu)?
849 %endif
850
851 %ifarch alpha
852 alpha-[^-]*-[Ll]inux(-gnu)?
853 %endif
854
855 %ifarch ia64
856 ia64-[^-]*-[Ll]inux(-gnu)?
857 %endif
858
859 %ifarch ppc64
860 powerpc64-[^-]*-[Ll]inux(-gnu)?
861 ppc64-[^-]*-[Ll]inux(-gnu)?
862 %endif
863 %ifarch %{ppc} ppc64
864 powerpc-[^-]*-[Ll]inux(-gnu)?
865 ppc-[^-]*-[Ll]inux(-gnu)?
866 %endif
867
868 %ifarch s390x
869 s390x-[^-]*-[Ll]inux(-gnu)?
870 %endif
871 %ifarch s390 s390x
872 s390-[^-]*-[Ll]inux(-gnu)?
873 %endif
874
875 %ifarch sparc64
876 sparc64-[^-]*-[Ll]inux(-gnu)?
877 sparcv8-[^-]*-[Ll]inux(-gnu)?
878 sparcv9-[^-]*-[Ll]inux(-gnu)?
879 %endif
880 %ifarch sparcv9
881 sparcv8-[^-]*-[Ll]inux(-gnu)?
882 sparcv9-[^-]*-[Ll]inux(-gnu)?
883 %endif
884 %ifarch sparc sparcv9 sparc64
885 sparc-[^-]*-[Ll]inux(-gnu)?
886 %endif
887
888 noarch-[^-]*-.*
889 EOF
890
891 # Squash Extra Blank Lines
892 %{__sed} -i -e '/./,/^$/!d' $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
893
894 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
895
896 install %{SOURCE1} doc/manual/groups
897 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
898 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
899 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
900 install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
901 install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
902 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
903 cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
904 install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
905 install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
906 install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
907
908 install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
909
910 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
911
912 install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
913 install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
914 install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
915 install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
916 install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
917 install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
918 install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
919
920 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
921 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
922 install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
923 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
924 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
925 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
926
927 install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
928 install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
929 #install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
930
931 # create macro loading wrappers for backward compatibility
932 for m in gstreamer java mono perl php python; do
933         echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
934 done
935
936 # move rpm to /bin
937 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
938 # move essential libs to /lib (libs that /bin/rpm links to)
939 for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
940         mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
941         ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
942 done
943
944 %if %{with python}
945 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
946 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
947
948 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,py}
949 %endif
950
951 # wrong location, not used anyway
952 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
953
954 %find_lang %{name}
955
956 %{__rm} -rf manual
957 cp -a doc/manual manual
958 %{__rm} -f manual/Makefile*
959
960 %clean
961 rm -rf $RPM_BUILD_ROOT
962
963 %pretrans
964 # this needs to be a dir
965 if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
966         umask 022
967         mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
968         mkdir %{_sysconfdir}/rpm/sysinfo
969 fi
970
971 %posttrans
972 if [ -e /var/lib/rpm/Packages ] && \
973                 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
974         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
975                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
976                 echo
977                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
978                 echo
979         fi
980         echo
981         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
982         echo 'you should ignore it and restart poldek'
983         echo
984         %{_rpmlibdir}/bin/dbupgrade.sh
985 fi
986
987 %triggerpostun -- %{name} < 4.4.9-44
988 %{_rpmlibdir}/hrmib-cache
989
990 %post   lib -p /sbin/ldconfig
991 %postun lib -p /sbin/ldconfig
992
993 %pretrans build
994 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
995
996 %files -f %{name}.lang
997 %defattr(644,root,root,755)
998 %doc ChangeLog CREDITS README manual/*
999
1000 %dir /etc/pki/rpm-gpg
1001 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1002
1003 %attr(755,root,root) /bin/rpm
1004
1005 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
1006 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
1007 %dir %{_sysconfdir}/rpm/sysinfo
1008 # these are ok to be replaced
1009 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
1010 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1011
1012 %{_mandir}/man8/rpm.8*
1013 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1014 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1015 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1016 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1017 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1018
1019 #%dir /var/lib/rpm
1020 #%dir /var/lib/rpm/log
1021 #%dir /var/lib/rpm/tmp
1022 #%config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
1023
1024 # exported package NVRA (stamped with install tid)
1025 # net-snmp hrSWInstalledName queries, bash-completions
1026 %dir /var/cache/hrmib
1027
1028 %{_rpmlibdir}/rpmpopt*
1029 %{_rpmlibdir}/macros
1030 %dir %{_rpmlibdir}/macros.d
1031 #%{_rpmlibdir}/macros.d/pld
1032 %{_rpmlibdir}/platform/noarch-*
1033 %ifarch %{ix86} %{x8664} x32
1034 %{_rpmlibdir}/platform/athlon*
1035 %{_rpmlibdir}/platform/geode*
1036 %{_rpmlibdir}/platform/i?86*
1037 %{_rpmlibdir}/platform/pentium*
1038 %endif
1039 %ifarch %{x8664} x32
1040 %{_rpmlibdir}/platform/amd64*
1041 %{_rpmlibdir}/platform/ia32e*
1042 %{_rpmlibdir}/platform/x86_64*
1043 #%{_rpmlibdir}/platform/x32*
1044 %endif
1045 %ifarch alpha
1046 %{_rpmlibdir}/platform/alpha*
1047 %endif
1048 %ifarch ia64
1049 %{_rpmlibdir}/platform/ia64*
1050 %endif
1051 %ifarch mips mipsel mips64 mips64el
1052 %{_rpmlibdir}/platform/mips*
1053 %endif
1054 %ifarch %{ppc}
1055 %{_rpmlibdir}/platform/ppc*
1056 %endif
1057 %ifarch sparc sparc64
1058 %{_rpmlibdir}/platform/sparc*
1059 %endif
1060
1061 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1062
1063 %dir %{_rpmlibdir}/bin
1064 #%attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
1065 #%attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
1066 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
1067 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
1068 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmdbchk
1069
1070 %files base
1071 %defattr(644,root,root,755)
1072 %dir %{_sysconfdir}/rpm
1073 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1074 %dir %{_rpmlibdir}
1075 %attr(755,root,root) %{_bindir}/banner.sh
1076 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1077 %dir /var/lib/banner
1078
1079 %files lib
1080 %defattr(644,root,root,755)
1081 %attr(755,root,root) /%{_lib}/librpm.so.9
1082 %attr(755,root,root) /%{_lib}/librpm.so.%{sover}
1083 %attr(755,root,root) /%{_lib}/librpmbuild.so.9
1084 %attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
1085 %attr(755,root,root) /%{_lib}/librpmio.so.9
1086 %attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
1087 %attr(755,root,root) /%{_lib}/librpmsign.so.9
1088 %attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
1089
1090 %files devel
1091 %defattr(644,root,root,755)
1092 %attr(755,root,root) %{_libdir}/librpm.so
1093 %attr(755,root,root) %{_libdir}/librpmbuild.so
1094 %attr(755,root,root) %{_libdir}/librpmio.so
1095 %attr(755,root,root) %{_libdir}/librpmsign.so
1096 %{_libdir}/librpm*.la
1097 %{_includedir}/rpm
1098 %{_pkgconfigdir}/*.pc
1099
1100 %files static
1101 %defattr(644,root,root,755)
1102 %{_libdir}/librpm*.a
1103
1104 %files utils
1105 %defattr(644,root,root,755)
1106 %attr(755,root,root) %{_bindir}/rpm2cpio
1107 #%attr(755,root,root) %{_bindir}/rpmconstant
1108 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1109 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1110 %attr(755,root,root) %{_rpmlibdir}/tgpg
1111 #%attr(755,root,root) %{_rpmlibdir}/bin/chroot
1112 #%attr(755,root,root) %{_rpmlibdir}/bin/cp
1113 #%attr(755,root,root) %{_rpmlibdir}/bin/debugedit
1114 #%attr(755,root,root) %{_rpmlibdir}/bin/find
1115 #%attr(755,root,root) %{_rpmlibdir}/bin/mgo
1116 #%attr(755,root,root) %{_rpmlibdir}/bin/mtree
1117 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1118 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1119 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1120 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
1121 %if %{with selinux}
1122 #%attr(755,root,root) %{_rpmlibdir}/bin/semodule
1123 #%attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1124 %endif
1125 %{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
1126 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
1127 %{_mandir}/man8/rpm2cpio.8*
1128 #%{_mandir}/man8/rpmconstant.8*
1129 %{_mandir}/man8/rpmdeps.8*
1130 #%{_mandir}/man8/rpmmtree.8*
1131 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1132 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1133 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1134 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1135
1136 %files utils-perl
1137 %defattr(644,root,root,755)
1138 #%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1139
1140 %if %{with static}
1141 %files utils-static
1142 %defattr(644,root,root,755)
1143 %attr(755,root,root) %{_bindir}/rpm[ieu]
1144 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1145 %endif
1146
1147 %files build
1148 %defattr(644,root,root,755)
1149 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1150 %attr(755,root,root) %{_rpmlibdir}/brp-*
1151 %attr(755,root,root) %{_rpmlibdir}/check-files
1152 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1153 #%attr(755,root,root) %{_rpmlibdir}/cross-build
1154 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1155 #%attr(755,root,root) %{_rpmlibdir}/getpo.sh
1156 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1157 #%attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1158 #%attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1159 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1160 %attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
1161 # needs hacked pkg-config to return anything
1162 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1163 #%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1164 #%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
1165 #%attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1166 #%attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
1167 #%attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1168 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmspec
1169 #%attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1170 #%attr(755,root,root) %{_rpmlibdir}/bin/wget
1171 #%attr(755,root,root) %{_rpmlibdir}/vcheck
1172 # not used yet ... these six depend on perl
1173 #%attr(755,root,root) %{_rpmlibdir}/http.req
1174 # we always used scripts provided by mono-devel, maybe move them here
1175 #%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1176 #%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
1177
1178 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
1179 # must be here for "Requires: rpm-*prov" to work
1180 #%{_rpmlibdir}/macros.d/cmake
1181 #%{_rpmlibdir}/macros.d/gstreamer
1182 #%{_rpmlibdir}/macros.d/java
1183 #%{_rpmlibdir}/macros.d/libtool
1184 #%{_rpmlibdir}/macros.d/mono
1185 #%{_rpmlibdir}/macros.d/perl
1186 #%{_rpmlibdir}/macros.d/php
1187 #%{_rpmlibdir}/macros.d/pkgconfig
1188 #%{_rpmlibdir}/macros.d/python
1189 #%{_rpmlibdir}/macros.d/ruby
1190 #%{_rpmlibdir}/macros.d/selinux
1191 #%{_rpmlibdir}/macros.d/tcl
1192 #%{_rpmlibdir}/macros.rpmbuild
1193 # compat wrappers
1194 #%{_rpmlibdir}/macros.gstreamer
1195 %{_rpmlibdir}/macros.java
1196 %{_rpmlibdir}/macros.mono
1197 %{_rpmlibdir}/macros.perl
1198 %{_rpmlibdir}/macros.php
1199 %{_rpmlibdir}/macros.python
1200
1201 #%attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1202 #%attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1203
1204 %attr(755,root,root) %{_bindir}/gendiff
1205 %attr(755,root,root) %{_bindir}/rpmbuild
1206
1207 #%dir %{_rpmlibdir}/helpers
1208 #%attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
1209
1210 %{_mandir}/man1/gendiff.1*
1211 %{_mandir}/man8/rpmbuild.8*
1212 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1213 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1214 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1215
1216 %files javaprov
1217 %defattr(644,root,root,755)
1218 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1219 # needs jar (any jdk), jcf-dump (gcc-java) to work
1220 #%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1221
1222 %files rubyprov
1223 %defattr(644,root,root,755)
1224 #%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1225 #%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1226
1227 %files perlprov
1228 %defattr(644,root,root,755)
1229 %attr(755,root,root) %{_rpmlibdir}/perl.*
1230 #%attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1231 #%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1232
1233 %files pythonprov
1234 %defattr(644,root,root,755)
1235 #%attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
1236 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1237
1238 %files php-pearprov
1239 %defattr(644,root,root,755)
1240 %attr(755,root,root) %{_rpmlibdir}/php.prov
1241 %attr(755,root,root) %{_rpmlibdir}/php.req
1242 %attr(755,root,root) %{_rpmlibdir}/php.req.php
1243
1244 %if %{with python}
1245 %files -n python-rpm
1246 %defattr(644,root,root,755)
1247 %dir %{py_sitedir}/rpm
1248 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1249 %{py_sitedir}/rpm/*.py[co]
1250 %endif
1251
1252 %if %{with apidocs}
1253 %files apidocs
1254 %defattr(644,root,root,755)
1255 #%doc apidocs
1256 %endif
This page took 0.166539 seconds and 3 git commands to generate.