]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
742bd08f5d0763d530d02607dae532799e584421
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - rebuild database after upgrading from rpm5
4 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
5 #
6 # Conditional build:
7 %bcond_without  apidocs         # don't generate documentation with doxygen
8 %bcond_without  python2         # don't build python bindings
9 %bcond_without  python3         # don't build python bindings
10 %bcond_without  plugins         # build plugins
11 %bcond_without  recommends_tags # build without Recommends tag (bootstrapping)
12 %bcond_with     db61            # use DB 6.1 instead of 5.3
13
14 # versions of required libraries
15 %if %{with db61}
16 %define         reqdb_pkg       db6.1
17 %define         reqdb_ver       6.1
18 %define         reqdb_pkgver    6.1.19
19 %else
20 %define         reqdb_pkg       db5.3
21 %define         reqdb_ver       5.3
22 %define         reqdb_pkgver    5.3.28.0
23 %endif
24 %define         reqpopt_ver     1.15
25 %define         openssl_ver     1.1.1d
26 %define         sover           9.0.1
27
28 Summary:        RPM Package Manager
29 Summary(de.UTF-8):      RPM Packet-Manager
30 Summary(es.UTF-8):      Gestor de paquetes RPM
31 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
32 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
33 Summary(ru.UTF-8):      Менеджер пакетов от RPM
34 Summary(uk.UTF-8):      Менеджер пакетів від RPM
35 Name:           rpm
36 Version:        4.15.1
37 Release:        0.1
38 Epoch:          1
39 License:        GPL v2 / LGPL v2.1
40 Group:          Base
41 Source0:        http://ftp.rpm.org/releases/rpm-4.15.x/%{name}-%{version}.tar.bz2
42 # Source0-md5:  ed72147451a5ed93b2a48e2f8f5413c3
43 Source1:        %{name}.groups
44 Source2:        macros.pld
45 Source3:        %{name}-install-tree
46 Source5:        %{name}-hrmib-cache
47 Source6:        %{name}-groups-po.awk
48 Source11:       perl.prov
49 Source12:       %{name}-user_group.sh
50 Source13:       %{name}.sysconfig
51 # http://svn.pld-linux.org/banner.sh/
52 Source15:       banner.sh
53 Source16:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
54 # Source16-md5: 23914bb49fafe7153cee87126d966461
55 Source18:       macros.local
56 Source19:       %{name}.noautocompressdoc
57 Source20:       %{name}.noautoprov
58 Source21:       %{name}.noautoprovfiles
59 Source22:       %{name}.noautoreq
60 Source24:       %{name}.noautoreqfiles
61 Source26:       %{name}db_checkversion.c
62 Source27:       macros.lang
63 Source28:       %{name}db_reset.c
64 Source29:       dbupgrade.sh
65 Source32:       rpmrc.pld
66 Patch0:         %{name}-man_pl.patch
67 Patch1:         %{name}-popt-aliases.patch
68 Patch2:         %{name}-perl-macros.patch
69 Patch3:         %{name}-perl-req-perlfile.patch
70 Patch4:         %{name}-scripts-closefds.patch
71 Patch6:         %{name}-lua.patch
72 Patch7:         %{name}-perl_req-INC_dirs.patch
73 Patch8:         %{name}-debuginfo.patch
74 Patch10:        %{name}-libtool-deps.patch
75 Patch11:        %{name}-builddir-readlink.patch
76 Patch12:        %{name}-changelog_order_check_nonfatal.patch
77 Patch13:        %{name}-postun-nofail.patch
78 Patch14:        %{name}-clean-docdir.patch
79 Patch15:        %{name}-perl-magic.patch
80 Patch16:        %{name}-ignore-missing-macro-files.patch
81 Patch17:        x32.patch
82 Patch18:        %{name}-add-compress-doc.patch
83 Patch20:        rpm5-db-compat.patch
84 Patch21:        python-internal-build.patch
85 URL:            https://rpm.org/
86 BuildRequires:  %{reqdb_pkg}-devel >= %{reqdb_pkgver}
87 BuildRequires:  %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
88 BuildRequires:  autoconf >= 2.63
89 BuildRequires:  automake >= 1.4
90 BuildRequires:  bzip2-devel >= 1.0.2-17
91 BuildRequires:  elfutils-devel >= 0.108
92 BuildRequires:  gettext-tools >= 0.19.2
93 BuildRequires:  libarchive-devel
94 BuildRequires:  libmagic-devel
95 BuildRequires:  openssl-devel >= %{openssl_ver}
96 %if %{with plugins}
97 BuildRequires:  audit-libs-devel
98 BuildRequires:  dbus-devel
99 BuildRequires:  libselinux-devel >= 2.1.0
100 %endif
101 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
102 BuildRequires:  libstdc++-devel
103 BuildRequires:  libtool >= 1:1.4.2-9
104 BuildRequires:  lua53-devel >= 5.3.5
105 BuildRequires:  ossp-uuid-devel
106 BuildRequires:  patch >= 2.2
107 BuildRequires:  popt-devel >= %{reqpopt_ver}
108 %{?with_python2:BuildRequires:  python-devel >= 1:2.3}
109 %{?with_python3:BuildRequires:  python3-devel}
110 BuildRequires:  python-modules >= 1:2.3
111 %if %{with python2} || %{with python3}
112 BuildRequires:  rpm-pythonprov
113 %endif
114 BuildRequires:  tcl
115 BuildRequires:  xz-devel
116 BuildRequires:  zlib-devel
117 BuildRequires:  zstd-devel
118 %if %{with apidocs}
119 BuildRequires:  doxygen
120 BuildRequires:  ghostscript
121 BuildRequires:  graphviz
122 BuildRequires:  tetex-pdftex
123 %endif
124 Requires(posttrans):    coreutils
125 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
126 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
127 Requires:       FHS >= 3.0-2
128 Requires:       openssl >= %{openssl_ver}
129 Requires:       popt >= %{reqpopt_ver}
130 %if %{with recommends_tags}
131 Recommends:     rpm-plugin-audit
132 Recommends:     rpm-plugin-prioreset
133 Recommends:     rpm-plugin-syslog
134 Recommends:     rpm-plugin-systemd-inhibit
135 %endif
136 Provides:       rpm-db-ver = %{reqdb_ver}
137 Obsoletes:      rpm-getdeps
138 Obsoletes:      rpm-utils-perl
139 Obsoletes:      rpm-utils-static
140 Conflicts:      glibc < 2.2.92
141 # db4.6 poldek needed
142 Conflicts:      poldek < 0.21-0.20070703.00.3
143 # segfaults with lzma 0.42.2
144 Conflicts:      lzma-libs < 4.999.3
145 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
146 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
147
148 %define         _binary_payload         w9.gzdio
149
150 # don't require very fresh rpm.macros to build
151 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
152 %define         ix86    i386 i486 i586 i686 athlon geode pentium3 pentium4
153 %define         ppc     ppc ppc7400 ppc7450
154 %define         x8664   amd64 ia32e x86_64
155
156 %define         _rpmlibdir /usr/lib/rpm
157 %define         _noautocompressdoc      RPM-GPG-KEY
158
159 %description
160 RPM is a powerful package manager, which can be used to build,
161 install, query, verify, update, and uninstall individual software
162 packages. A package consists of an archive of files, and package
163 information, including name, version, and description.
164
165 %description -l de.UTF-8
166 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
167 Installation, Anfrage, Verifizierung, Aktualisierung und
168 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
169 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
170 Beschreibung.
171
172 %description -l es.UTF-8
173 RPM es un poderoso administrador de paquetes, que puede ser usado para
174 construir, instalar, pesquisar, verificar, actualizar y desinstalar
175 paquetes individuales de software. Un paquete consiste en un
176 almacenaje de archivos, y información sobre el paquete, incluyendo
177 nombre, versión y descripción.
178
179 %description -l pl.UTF-8
180 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
181 przebudowanie, instalację czy weryfikację dowolnego pakietu.
182 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
183 plików wchodzących w skład pakietu, zależności od innych pakietów, są
184 przechowywane w bazie danych i można je uzyskać za pomocą opcji
185 odpytywania programu rpm.
186
187 %description -l pt_BR.UTF-8
188 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
189 construir, instalar, pesquisar, verificar, atualizar e desinstalar
190 pacotes individuais de software. Um pacote consiste de um conjunto de
191 arquivos e informações adicionais, incluindo nome, versão e descrição
192 do pacote, permissões dos arquivos, etc.
193
194 %description -l ru.UTF-8
195 RPM - это мощный менеджер пакетов, который может быть использован для
196 создания, инсталляции, запросов (query), проверки, обновления и
197 удаления программных пакетов. Пакет состоит из файлового архива и
198 служебной информации, включающей название, версию, описание и другие
199 данные о пакете.
200
201 %description -l uk.UTF-8
202 RPM - це потужний менеджер пакетів, що може бути використаний для
203 створення, інсталяції, запитів (query), перевірки, поновлення та
204 видалення програмних пакетів. Пакет складається з файлового архіву та
205 службової інформації, що містить назву, версію, опис та іншу
206 інформацію про пакет.
207
208 %package base
209 Summary:        RPM base package - scripts used by rpm packages themselves
210 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
211 Group:          Base
212 Requires:       filesystem
213 Obsoletes:      rpm-scripts
214 Obsoletes:      vserver-rpm
215
216 %description base
217 The RPM base package contains scripts used by rpm packages themselves.
218 These include:
219 - scripts for adding/removing groups and users needed for rpm
220   packages,
221 - banner.sh to display %%banner messages from rpm scriptlets.
222
223 %description base -l pl.UTF-8
224 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
225 Zawiera on:
226 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
227 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
228
229 %package lib
230 Summary:        RPMs library
231 Summary(pl.UTF-8):      Biblioteki RPM-a
232 Group:          Libraries
233 Requires:       %{reqdb_pkg} >= %{reqdb_pkgver}
234 Requires:       %{reqdb_pkg}-sql >= %{reqdb_pkgver}
235 Requires:       libmagic >= 1.15-2
236 Requires:       openssl >= %{openssl_ver}
237 Requires:       popt >= %{reqpopt_ver}
238 Obsoletes:      rpm-libs
239 # avoid SEGV caused by mixed db versions
240 Conflicts:      poldek < 0.18.1-16
241
242 %description lib
243 RPMs library.
244
245 %description lib -l pl.UTF-8
246 Biblioteki RPM-a.
247
248 %package devel
249 Summary:        Header files for rpm libraries
250 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
251 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
252 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
253 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
254 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
255 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
256 Group:          Development/Libraries
257 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
258 Requires:       %{reqdb_pkg}-devel >= %{reqdb_pkgver}
259 Requires:       bzip2-devel
260 Requires:       elfutils-devel
261 Requires:       libmagic-devel
262 Requires:       openssl-devel >= %{openssl_ver}
263 %if %{with selinux}
264 Requires:       libselinux-devel
265 Requires:       libsemanage-devel
266 Requires:       libsepol-devel
267 %endif
268 Requires:       popt-devel >= %{reqpopt_ver}
269 Requires:       zlib-devel
270
271 %description devel
272 The RPM packaging system includes C libraries that make it easy to
273 manipulate RPM packages and databases. They are intended to ease the
274 creation of graphical package managers and other tools that need
275 intimate knowledge of RPM packages. This package contains header files
276 for these libraries.
277
278 %description devel -l de.UTF-8
279 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
280 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
281 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
282 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
283
284 %description devel -l es.UTF-8
285 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
286 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
287 facilitar la creación de administradores gráficos de paquetes y otras
288 herramientas que necesiten un conocimiento profundo de paquetes RPM.
289
290 %description devel -l pl.UTF-8
291 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
292 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
293 graficznych programów zarządzających pakietami oraz innych narzędzi,
294 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
295 zawiera pliki nagłówkowe wspomnianych bibliotek.
296
297 %description devel -l pt_BR.UTF-8
298 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
299 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
300 facilitar a criação de gerenciadores gráficos de pacotes e outras
301 ferramentas que precisem de conhecimento profundo de pacotes RPM.
302
303 %description devel -l ru.UTF-8
304 Система управления пакетами RPM содержит библиотеку C, которая
305 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
306 Эта библиотека предназначена для облегчения создания графических
307 пакетных менеджеров и других утилит, которым необходимо работать с
308 пакетами RPM.
309
310 %description devel -l uk.UTF-8
311 Система керування пакетами RPM містить бібліотеку C, котра спрощує
312 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
313 призначена для полегшення створення графічних пакетних менеджерів та
314 інших утиліт, що працюють з пакетами RPM.
315
316 %package utils
317 Summary:        Additional utilities for managing RPM packages and database
318 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
319 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
320 Group:          Applications/File
321 Requires:       %{name} = %{epoch}:%{version}-%{release}
322 Requires:       popt >= %{reqpopt_ver}
323 %if %{with recommends_tags}
324 Recommends:     bzip2
325 Recommends:     gzip
326 %endif
327 Conflicts:      filesystem-debuginfo < 3.0-16
328
329 %description utils
330 Additional utilities for managing RPM packages and database.
331
332 %description utils -l de.UTF-8
333 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
334
335 %description utils -l pl.UTF-8
336 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
337
338 %package build
339 Summary:        Scripts for building binary RPM packages
340 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
341 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
342 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
343 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
344 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
345 Group:          Applications/File
346 Requires(pretrans):     coreutils
347 Requires(pretrans):     findutils
348 Requires:       %{name}-build-macros >= 1.712
349 Requires:       %{name}-utils = %{epoch}:%{version}-%{release}
350 Requires:       /bin/id
351 Requires:       awk
352 Requires:       bzip2
353 Requires:       chrpath >= 0.10-4
354 Requires:       cpio
355 Requires:       diffutils
356 Requires:       elfutils
357 Requires:       file >= 4.17
358 Requires:       fileutils
359 Requires:       findutils
360 %ifarch athlon
361 Requires:       gcc >= 3.0.3
362 %else
363 Requires:       gcc
364 %endif
365 Requires:       glibc-devel
366 Requires:       grep
367 Requires:       gzip
368 Requires:       make
369 Requires:       patch
370 Requires:       sed >= 4.0
371 Requires:       sh-utils
372 Requires:       tar >= 1:1.22
373 Requires:       textutils
374 Requires:       which
375 Requires:       xz
376 Provides:       rpmbuild(noauto) = 3
377 %ifarch %{x8664}
378 Conflicts:      automake < 1:1.7.9-2
379 Conflicts:      libtool < 2:1.5-13
380 %endif
381
382 %description build
383 Scripts for building binary RPM packages.
384
385 %description build -l de.UTF-8
386 Scripts fürs Bauen binärer RPM-Pakete.
387
388 %description build -l pl.UTF-8
389 Skrypty pomocnicze do budowania binarnych RPM-ów.
390
391 %description build -l pt_BR.UTF-8
392 Este pacote contém scripts e programas executáveis que são usados para
393 construir pacotes usando o RPM.
394
395 %description build -l ru.UTF-8
396 Различные вспомогательные скрипты и исполняемые программы, которые
397 используются для сборки RPM'ов.
398
399 %description build -l uk.UTF-8
400 Різноманітні допоміжні скрипти та утиліти, які використовуються для
401 побудови RPM'ів.
402
403 %package perlprov
404 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
405 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
406 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
407 Group:          Applications/File
408 Requires:       %{name} = %{epoch}:%{version}-%{release}
409 Requires:       perl-Encode
410 Requires:       perl-devel
411 Requires:       perl-modules
412
413 %description perlprov
414 Additional utilities for checking Perl provides/requires in RPM
415 packages.
416
417 %description perlprov -l de.UTF-8
418 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
419
420 %description perlprov -l pl.UTF-8
421 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
422 pakietach RPM.
423
424 %package pythonprov
425 Summary:        Python macros, which simplifies creation of RPM packages with Python software
426 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
427 Group:          Applications/File
428 Requires:       %{name} = %{epoch}:%{version}-%{release}
429 Requires:       python
430 Requires:       python-modules
431 Requires:       python-setuptools
432
433 %description pythonprov
434 Python macros, which simplifies creation of RPM packages with Python
435 software.
436
437 %description pythonprov -l pl.UTF-8
438 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
439 Pythonie.
440
441 %package -n python-rpm
442 Summary:        Python interface to RPM library
443 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
444 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
445 Group:          Development/Languages/Python
446 Requires:       %{name} = %{epoch}:%{version}-%{release}
447 Requires:       python
448 Obsoletes:      rpm-python
449
450 %description -n python-rpm
451 The python-rpm package contains a module which permits applications
452 written in the Python programming language to use the interface
453 supplied by RPM (RPM Package Manager) libraries.
454
455 This package should be installed if you want to develop Python
456 programs that will manipulate RPM packages and databases.
457
458 %description -n python-rpm -l pl.UTF-8
459 Pakiet python-rpm zawiera moduł, który pozwala aplikacjom napisanym w
460 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
461
462 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
463 Pythonie programy manipulujące pakietami i bazami danych rpm.
464
465 %description -n python-rpm -l pt_BR.UTF-8
466 O pacote python-rpm contém um módulo que permite que aplicações
467 escritas em Python utilizem a interface fornecida pelas bibliotecas
468 RPM (RPM Package Manager).
469
470 Esse pacote deve ser instalado se você quiser desenvolver programas em
471 Python para manipular pacotes e bancos de dados RPM.
472
473 %package -n python3-rpm
474 Summary:        Python 3 interface to RPM library
475 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki RPM-a
476 Summary(pt_BR.UTF-8):   Módulo Python 3 para aplicativos que manipulam pacotes RPM
477 Group:          Development/Languages/Python
478 Requires:       %{name} = %{epoch}:%{version}-%{release}
479 Requires:       python3
480
481 %description -n python3-rpm
482 The python3-rpm package contains a module which permits applications
483 written in the Python 3 programming language to use the interface
484 supplied by RPM (RPM Package Manager) libraries.
485
486 This package should be installed if you want to develop Python 3
487 programs that will manipulate RPM packages and databases.
488
489 %description -n python3-rpm -l pl.UTF-8
490 Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
491 Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki RPM-a.
492
493 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
494 Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
495
496 %description -n python3-rpm -l pt_BR.UTF-8
497 O pacote python3-rpm contém um módulo que permite que aplicações
498 escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
499 RPM (RPM Package Manager).
500
501 Esse pacote deve ser instalado se você quiser desenvolver programas em
502 Python 3 para manipular pacotes e bancos de dados RPM.
503
504 %package plugin-audit
505 Summary:        Plugin for logging audit events on package operations
506 Group:          System/Base
507 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
508
509 %description plugin-audit
510 Plugin for libaudit support
511
512 %package plugin-syslog
513 Summary:        Plugin for syslog functionality
514 Group:          System/Base
515 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
516
517 %description plugin-syslog
518 This plugin exports RPM actions to the system log.
519
520 %package plugin-systemd-inhibit
521 Summary:        Plugin for systemd inhibit functionality
522 Group:          System/Base
523 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
524
525 %description plugin-systemd-inhibit
526 This plugin blocks systemd from entering idle, sleep or shutdown while
527 an rpm transaction is running using the systemd-inhibit mechanism.
528
529 %package plugin-ima
530 Summary:        Plugin for IMA file signatures
531 Group:          Base
532 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
533
534 %description plugin-ima
535 This plugin adds support for enforcing and verifying IMA file
536 signatures in an rpm.
537
538 %package plugin-prioreset
539 Summary:        Plugin for resetting scriptlet priorities for SysV init
540 Group:          Base
541 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
542
543 %description plugin-prioreset
544 This plugin is useful on legacy SysV init systems if you run rpm
545 transactions with nice/ionice priorities. Should not be used on
546 systemd systems.
547
548 %package plugin-selinux
549 Summary:        Plugin for SELinux functionality
550 Group:          Base
551 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
552 Requires:       libselinux >= 2.1.0
553
554 %description plugin-selinux
555 Plugin for SELinux functionality.
556
557 %package sign
558 Summary:        Package signing support
559 Group:          Base
560 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
561
562 %description sign
563 This package contains support for digitally signing RPM packages.
564
565 %package apidocs
566 Summary:        RPM API documentation and guides
567 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
568 Group:          Documentation
569 BuildArch:      noarch
570
571 %description apidocs
572 Documentation for RPM API and guides in HTML format generated from rpm
573 sources by doxygen.
574
575 %description apidocs -l pl.UTF-8
576 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
577 źrodeł RPM-a przez doxygen.
578
579 %prep
580 %setup -q -n %{name}-%{version}%{?subver}
581 %patch0 -p1
582 %patch1 -p1
583 %patch2 -p1
584 %patch3 -p1
585 %patch4 -p1
586 %patch6 -p1
587 %patch7 -p0
588 %patch8 -p1
589 %patch10 -p1
590 %patch11 -p1
591 %patch12 -p1
592 %patch13 -p1
593 %patch14 -p1
594 %patch15 -p1
595 %patch16 -p1
596 %patch17 -p1
597 %patch18 -p1
598 %patch20 -p1
599 %patch21 -p1
600
601 install %{SOURCE11} scripts/perl.prov.in
602
603 %{__mv} -f scripts/perl.req{,.in}
604
605 # generate Group translations to *.po
606 awk -f %{SOURCE6} %{SOURCE1}
607
608 install %{SOURCE26} tools/rpmdb_checkversion.c
609 install %{SOURCE28} tools/rpmdb_reset.c
610
611 %{__sed} -i -e '1s,/usr/bin/python,%{__python},' scripts/pythondistdeps.py
612
613 %build
614 %{__libtoolize}
615 %{__aclocal}
616 %{__autoheader}
617 %{__autoconf}
618 %{__automake}
619
620 # rpm checks for CPU type at runtime, but it looks better
621 sed -i \
622         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
623         -e 's|@host_cpu@|%{_target_cpu}|' \
624         -e 's|@host_os@|%{_target_os}|' \
625         macros.in
626
627 CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
628 %configure \
629         WITH_PERL_VERSION=no \
630         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
631         __GPG=%{_bindir}/gpg \
632         %{?with_python3:PYTHON=python3} \
633         %{!?with_python3:%{?with_python2:PYTHON=python2}} \
634         --disable-silent-rules \
635         --enable-shared \
636         --enable-bdb \
637         --enable-zstd \
638         --with-crypto=openssl \
639         --with-lua \
640         --with-cap \
641         --with-acl \
642         --with-audit \
643         --with-archive \
644 %if %{with python2} || %{with python3}
645         --enable-python \
646 %endif
647         --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
648         %{!?with_plugins:--disable-plugins} \
649         --with-vendor=pld
650
651 #  --enable-ndb (EXPERIMENTAL) enable the new rpm database format
652 #  --enable-lmdb=[yes/no/auto] (EXPERIMENTAL) build with LMDB rpm database format support (default=auto)
653 #  --with-imaevm           build with imaevm support
654
655 %{__make}
656
657 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
658         -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
659 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
660         -o tools/rpmdb_reset -ldb-%{reqdb_ver}
661
662 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
663         echo "Error linking rpmdb tools!"
664         exit 1
665 fi
666 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
667         echo "Error linking rpmdb tools!"
668         exit 1
669 fi
670
671 %if %{with python2}
672 cd python
673 %py_build
674 cd ..
675 %endif
676
677 %if %{with python3}
678 cd python
679 %py3_build
680 %endif
681
682 %install
683 rm -rf $RPM_BUILD_ROOT
684 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
685         $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/var/cache/hrmib}
686
687 cp -p %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
688
689 %{__make} install \
690         pkgconfigdir=%{_pkgconfigdir} \
691         DESTDIR=$RPM_BUILD_ROOT
692
693 # cleanup
694 %ifnarch %{ix86} %{x8664} x32
695 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
696 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
697 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
698 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
699 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
700 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
701 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
702 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
703 %endif
704
705 %ifnarch %{x8664} x32
706 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
707 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
708 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
709 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
710 %endif
711
712 %ifnarch %{ppc}
713 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
714 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
715 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
716 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
717 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
718 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
719 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
720 %endif
721
722 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
723 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
724 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
725 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
726 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
727 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
728 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
729 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
730 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
731
732 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
733
734 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
735 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_rpmlibdir}/pld/macros
736 cp -p %{SOURCE32} $RPM_BUILD_ROOT%{_rpmlibdir}/pld/rpmrc
737
738 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
739 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
740 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
741 cp -p %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
742
743 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
744
745 cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
746 cp -p %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
747 cp -p %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
748 cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
749 cp -p %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
750 cp -p %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
751 cp -p %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
752
753 cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
754 cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
755 cp -p %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
756
757 # move rpm to /bin
758 %{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
759 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
760 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
761
762 # move essential libs to /lib (libs that /bin/rpm links to)
763 for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
764         mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
765         ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
766 done
767
768 #./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
769
770 %if %{with python2}
771 # Remove anything that rpm make install might put there
772 %{__rm} -rf $RPM_BUILD_ROOT%{py_sitedir}
773 cd python
774 %py_install
775 %py_postclean
776 cd ..
777 %endif
778
779 %if %{with python3}
780 # Remove anything that rpm make install might put there
781 %{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
782 cd python
783 %py3_install
784 cd ..
785 %endif
786
787 %{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
788
789 # wrong location, not used anyway
790 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
791
792 %find_lang %{name}
793
794 %clean
795 rm -rf $RPM_BUILD_ROOT
796
797 %posttrans
798 if [ -e /var/lib/rpm/Packages ] && \
799                 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
800         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
801                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
802                 echo
803                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
804                 echo
805         fi
806         echo
807         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
808         echo 'you should ignore it and restart poldek'
809         echo
810         %{_rpmlibdir}/dbupgrade.sh
811 fi
812
813 %triggerpostun -- %{name} < 4.4.9-44
814 %{_rpmlibdir}/hrmib-cache
815
816 %post   lib -p /sbin/ldconfig
817 %postun lib -p /sbin/ldconfig
818
819 %pretrans build
820 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
821
822 %files -f %{name}.lang
823 %defattr(644,root,root,755)
824 %doc ChangeLog CREDITS README
825
826 %dir /etc/pki/rpm-gpg
827 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
828
829 %attr(755,root,root) /bin/rpm
830 %attr(755,root,root) %{_bindir}/rpmdb
831 %attr(755,root,root) %{_bindir}/rpmkeys
832 %attr(755,root,root) %{_bindir}/rpmquery
833 %attr(755,root,root) %{_bindir}/rpmverify
834
835 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
836 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
837
838 %{_mandir}/man8/rpm.8*
839 %{_mandir}/man8/rpmdb.8*
840 %{_mandir}/man8/rpmkeys.8*
841 %{_mandir}/man8/rpm-misc.8*
842 %lang(fr) %{_mandir}/fr/man8/rpm.8*
843 %lang(ja) %{_mandir}/ja/man8/rpm.8*
844 %lang(ko) %{_mandir}/ko/man8/rpm.8*
845 %lang(pl) %{_mandir}/pl/man8/rpm.8*
846 %lang(ru) %{_mandir}/ru/man8/rpm.8*
847 %lang(sk) %{_mandir}/sk/man8/rpm.8*
848
849 %dir /var/lib/rpm
850
851 # exported package NVRA (stamped with install tid)
852 # net-snmp hrSWInstalledName queries, bash-completions
853 %dir /var/cache/hrmib
854
855 %{_rpmlibdir}/rpmpopt*
856 %{_rpmlibdir}/rpmrc
857 %{_rpmlibdir}/macros
858 %dir %{_rpmlibdir}/macros.d
859 %dir %{_rpmlibdir}/platform
860 %{_rpmlibdir}/platform/noarch-*
861 %ifarch %{ix86} %{x8664} x32
862 %{_rpmlibdir}/platform/athlon*
863 %{_rpmlibdir}/platform/geode*
864 %{_rpmlibdir}/platform/i?86*
865 %{_rpmlibdir}/platform/pentium*
866 %endif
867 %ifarch %{x8664} x32
868 %{_rpmlibdir}/platform/amd64*
869 %{_rpmlibdir}/platform/ia32e*
870 %{_rpmlibdir}/platform/x86_64*
871 %{_rpmlibdir}/platform/x32*
872 %endif
873 %ifarch alpha
874 %{_rpmlibdir}/platform/alpha*
875 %endif
876 %ifarch ia64
877 %{_rpmlibdir}/platform/ia64*
878 %endif
879 %ifarch mips mipsel mips64 mips64el
880 %{_rpmlibdir}/platform/mips*
881 %endif
882 %ifarch %{ppc}
883 %{_rpmlibdir}/platform/ppc*
884 %endif
885 %ifarch sparc sparc64
886 %{_rpmlibdir}/platform/sparc*
887 %endif
888
889 %{_rpmlibdir}/pld/macros
890 %{_rpmlibdir}/pld/rpmrc
891
892 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
893
894 %attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
895 %attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
896 %attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
897
898 # valgrind suppression file for rpm
899 %{_rpmlibdir}/rpm.supp
900
901 %files base
902 %defattr(644,root,root,755)
903 %dir %{_sysconfdir}/rpm
904 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
905 %dir %{_rpmlibdir}
906 %attr(755,root,root) %{_bindir}/banner.sh
907 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
908 %dir /var/lib/banner
909
910 %files lib
911 %defattr(644,root,root,755)
912 %attr(755,root,root) /%{_lib}/librpm.so.9
913 %attr(755,root,root) /%{_lib}/librpm.so.%{sover}
914 %attr(755,root,root) /%{_lib}/librpmbuild.so.9
915 %attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
916 %attr(755,root,root) /%{_lib}/librpmio.so.9
917 %attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
918 %attr(755,root,root) /%{_lib}/librpmsign.so.9
919 %attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
920 %{?with_plugins:%dir %{_libdir}/rpm-plugins}
921
922 %files devel
923 %defattr(644,root,root,755)
924 %attr(755,root,root) %{_libdir}/librpm.so
925 %attr(755,root,root) %{_libdir}/librpmbuild.so
926 %attr(755,root,root) %{_libdir}/librpmio.so
927 %attr(755,root,root) %{_libdir}/librpmsign.so
928 %{_libdir}/librpm*.la
929 %{_includedir}/rpm
930 %{_pkgconfigdir}/*.pc
931
932 %files utils
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_bindir}/rpm2archive
935 %attr(755,root,root) %{_bindir}/rpm2cpio
936 %attr(755,root,root) %{_bindir}/rpmgraph
937 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
938 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
939 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
940 %attr(755,root,root) %{_rpmlibdir}/tgpg
941 %attr(755,root,root) %{_rpmlibdir}/debugedit
942 %attr(755,root,root) %{_rpmlibdir}/rpmdeps
943 %{_mandir}/man8/rpm2cpio.8*
944 %{_mandir}/man8/rpmdeps.8*
945 %{_mandir}/man8/rpmgraph.8*
946 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
947 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
948 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
949 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
950 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
951 %lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
952 %lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
953
954 %files build
955 %defattr(644,root,root,755)
956 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
957 %attr(755,root,root) %{_rpmlibdir}/brp-*
958 %attr(755,root,root) %{_rpmlibdir}/check-files
959 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
960 %attr(755,root,root) %{_rpmlibdir}/elfdeps
961 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
962 # needs hacked pkg-config to return anything
963 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
964 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
965
966 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
967 # must be here for "Requires: rpm-*prov" to work
968 #%{_rpmlibdir}/macros.d/cmake
969 #%{_rpmlibdir}/macros.d/gstreamer
970 #%{_rpmlibdir}/macros.d/libtool
971 #%{_rpmlibdir}/macros.d/perl
972 #%{_rpmlibdir}/macros.d/pkgconfig
973 #%{_rpmlibdir}/macros.d/python
974 #%{_rpmlibdir}/macros.d/selinux
975 #%{_rpmlibdir}/macros.d/tcl
976 #%{_rpmlibdir}/macros.rpmbuild
977
978 %attr(755,root,root) %{_rpmlibdir}/check-buildroot
979 %attr(755,root,root) %{_rpmlibdir}/check-prereqs
980 %attr(755,root,root) %{_rpmlibdir}/check-rpaths
981 %attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
982 %attr(755,root,root) %{_rpmlibdir}/debuginfo.prov
983 %attr(755,root,root) %{_rpmlibdir}/desktop-file.prov
984 %attr(755,root,root) %{_rpmlibdir}/find-provides
985 %attr(755,root,root) %{_rpmlibdir}/find-requires
986 %attr(755,root,root) %{_rpmlibdir}/metainfo.prov
987 %attr(755,root,root) %{_rpmlibdir}/ocaml-find-provides.sh
988 %attr(755,root,root) %{_rpmlibdir}/ocaml-find-requires.sh
989 %attr(755,root,root) %{_rpmlibdir}/script.req
990 %attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
991 # Fedora has this in -build, but shouldn't this be in -devel?
992 %attr(755,root,root) %{_rpmlibdir}/config.guess
993 %attr(755,root,root) %{_rpmlibdir}/config.sub
994
995 %dir %{_rpmlibdir}/fileattrs
996 %{_rpmlibdir}/fileattrs/debuginfo.attr
997 %{_rpmlibdir}/fileattrs/desktop.attr
998 %{_rpmlibdir}/fileattrs/elf.attr
999 %{_rpmlibdir}/fileattrs/font.attr
1000 %{_rpmlibdir}/fileattrs/libtool.attr
1001 %{_rpmlibdir}/fileattrs/metainfo.attr
1002 %{_rpmlibdir}/fileattrs/ocaml.attr
1003 %{_rpmlibdir}/fileattrs/perl.attr
1004 %{_rpmlibdir}/fileattrs/perllib.attr
1005 %{_rpmlibdir}/fileattrs/pkgconfig.attr
1006 %{_rpmlibdir}/fileattrs/python.attr
1007 %{_rpmlibdir}/fileattrs/pythondist.attr
1008 %{_rpmlibdir}/fileattrs/script.attr
1009
1010 %attr(755,root,root) %{_bindir}/gendiff
1011 %attr(755,root,root) %{_bindir}/rpmbuild
1012 %attr(755,root,root) %{_bindir}/rpmspec
1013
1014 %{_mandir}/man1/gendiff.1*
1015 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1016 %{_mandir}/man8/rpmbuild.8*
1017 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1018 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1019 %{_mandir}/man8/rpmspec.8*
1020
1021 %files perlprov
1022 %defattr(644,root,root,755)
1023 %attr(755,root,root) %{_rpmlibdir}/perl.*
1024
1025 %files pythonprov
1026 %defattr(644,root,root,755)
1027 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1028 %attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
1029
1030 %if %{with python2}
1031 %files -n python-rpm
1032 %defattr(644,root,root,755)
1033 %dir %{py_sitedir}/rpm
1034 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1035 %{py_sitedir}/rpm/*.py[co]
1036 %{py_sitedir}/rpm-%{version}-py*.egg-info
1037 %endif
1038
1039 %if %{with python3}
1040 %files -n python3-rpm
1041 %defattr(644,root,root,755)
1042 %dir %{py3_sitedir}/rpm
1043 %attr(755,root,root) %{py3_sitedir}/rpm/*.so
1044 %{py3_sitedir}/rpm/*.py
1045 %{py3_sitedir}/rpm-%{version}-py*.egg-info
1046 %{py3_sitedir}/rpm/__pycache__
1047 %endif
1048
1049 %if %{with plugins}
1050 %files plugin-audit
1051 %defattr(644,root,root,755)
1052 %attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
1053
1054 %files plugin-syslog
1055 %defattr(644,root,root,755)
1056 %attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
1057
1058 %files plugin-systemd-inhibit
1059 %defattr(644,root,root,755)
1060 %attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
1061 %{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
1062
1063 %files plugin-ima
1064 %defattr(644,root,root,755)
1065 %attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
1066
1067 %files plugin-prioreset
1068 %defattr(644,root,root,755)
1069 %attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
1070
1071 %files plugin-selinux
1072 %defattr(644,root,root,755)
1073 %attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
1074 %endif
1075
1076 %files sign
1077 %defattr(644,root,root,755)
1078 %attr(755,root,root) %{_bindir}/rpmsign
1079 %{_mandir}/man8/rpmsign.8*
1080
1081 %if %{with apidocs}
1082 %files apidocs
1083 %defattr(644,root,root,755)
1084 %doc doc/librpm/html/*
1085 %endif
This page took 0.117267 seconds and 2 git commands to generate.