]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
73a7eda7004cd959aba1687088406ee5658df791
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - check if we want shell autodeps: Requires: executable(ln) executable(mv)
4 # - %{_arch} = i686 not as used to be i386:
5 #   5.0.2: rpm -E '%_target_base_arch %_arch'
6 #          i386 i686
7 #   4.4.9: rpm -E '%_target_base_arch %_arch'
8 #          i386 i386
9 # - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
10 #   matches ELF first
11 # - rpmbuild computes digest when writing package to temporary file, then adds a few
12 #   tags (incl. digest) and writes whole package to destination file;
13 #   repackaging uses unchanged "immutable header" image from original rpm, also
14 #   preserving payload format and compressor from original rpm, _not_ current settings
15 # - TODO: add macros for some ppc, mipsel, alpha and sparc
16 # - uppackaged list:
17 #   /usr/lib/rpm/http.req
18 #   /usr/lib/rpm/install-sh
19 #   /usr/lib/rpm/mono-find-provides
20 #   /usr/lib/rpm/mono-find-requires
21 #   /usr/lib/rpm/osgideps.pl
22 #   /usr/lib/rpm/perldeps.pl
23 #   /usr/lib/rpm/vcheck
24 #   /usr/share/man/man8/rpmconstant.8
25 #
26 # Conditional build:
27 %bcond_with     static          # build static rpm+rpmi
28 %bcond_without  apidocs         # don't generate documentation with doxygen
29 %bcond_with     autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
30 %bcond_without  python          # don't build python bindings
31 %bcond_without  selinux         # build without selinux support
32 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
33 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
34 %bcond_without  db              # BerkeleyDB
35 %bcond_with     sqlite          # build with SQLite support
36 %bcond_with     sqlite_dbapi    # default database backend is sqlite
37 %bcond_without  system_lua              # use system lua
38 # force_cc              - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
39 # force_cxx             - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
40 # force_cpp             - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
41 #
42 %if %{with sqlite_dbapi}
43 %define with_sqlite     1
44 %endif
45
46 %if %{without db} && %{without sqlite}
47 %{error:Need db or sqlite}
48 ERROR
49 %endif
50
51 # versions of required libraries
52 %define         reqdb_ver       4.7.25
53 %define         reqpopt_ver     1.10.8
54 %define         beecrypt_ver    2:4.1.2-4
55 %define         sover   5.0
56
57 Summary:        RPM Package Manager
58 Summary(de.UTF-8):      RPM Packet-Manager
59 Summary(es.UTF-8):      Gestor de paquetes RPM
60 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
61 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
62 Summary(ru.UTF-8):      Менеджер пакетов от RPM
63 Summary(uk.UTF-8):      Менеджер пакетів від RPM
64 Name:           rpm
65 Version:        5.1.4
66 Release:        0.5
67 License:        LGPL
68 Group:          Base
69 Source0:        http://rpm5.org/files/rpm/rpm-5.1/%{name}-%{version}.tar.gz
70 # Source0-md5:  9a04c22ce1dffc81a7e43d39b002aaa1
71 Source1:        %{name}.groups
72 Source2:        %{name}.platform
73 Source3:        %{name}-install-tree
74 Source4:        %{name}-find-spec-bcond
75 Source5:        %{name}-hrmib-cache
76 Source6:        %{name}-groups-po.awk
77 Source7:        %{name}-compress-doc
78 Source8:        %{name}-check-files
79 Source9:        %{name}-php-provides
80 Source10:       %{name}-php-requires
81 Source11:       %{name}.sysinfo
82 Source12:       perl.prov
83 Source13:       %{name}-user_group.sh
84 Source14:       %{name}.sysconfig
85 Source15:       %{name}-macros.java
86 Source16:       %{name}-java-requires
87 # http://svn.pld-linux.org/banner.sh/
88 Source17:       banner.sh
89 Source18:       %{name}-pld.macros
90 Source19:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
91 # Source19-md5:  08b29584dd349aac9caa7610131a0a88
92 Source20:       %{name}-mimetypedeps
93 Source100:      %{name}-macros-athlon
94 Source101:      %{name}-macros-i386
95 Source102:      %{name}-macros-i486
96 Source103:      %{name}-macros-i586
97 Source104:      %{name}-macros-i686
98 Source105:      %{name}-macros-noarch
99 Source106:      %{name}-macros-pentium3
100 Source107:      %{name}-macros-pentium4
101 Source108:      %{name}-macros-ppc
102 Source109:      %{name}-macros-x86_64
103 Source110:      %{name}-macros-ia32e
104 Source111:      %{name}-macros-amd64
105
106 Patch0:         %{name}-branch.patch
107 Patch1:         %{name}-man_pl.patch
108 Patch2:         %{name}-popt-aliases.patch
109 Patch3:         %{name}-rpmpopt.patch
110 Patch4:         %{name}-perl-macros.patch
111 Patch5:         %{name}-perl-req-perlfile.patch
112 Patch6:         %{name}-noexpand.patch
113 Patch7:         %{name}-scripts-closefds.patch
114 Patch8:         %{name}-php-macros.patch
115 Patch9:         %{name}-gettext-in-header.patch
116 Patch10:        %{name}-compress-doc.patch
117 Patch11:        %{name}-lua.patch
118
119 Patch14:        %{name}-etc_dir.patch
120 Patch16:        %{name}-php-deps.patch
121 Patch17:        %{name}-macros.patch
122 Patch18:        %{name}-macros-th.patch
123
124 Patch23:        %{name}-pkgconfigdeps.patch
125
126 Patch26:        %{name}-notsc.patch
127 Patch27:        %{name}-hack-norpmlibdep.patch
128
129 Patch32:        %{name}-pld-autodep.patch
130 Patch34:        %{name}-epoch0.patch
131 Patch35:        %{name}-perl_req-INC_dirs.patch
132 Patch36:        %{name}-debuginfo.patch
133 Patch37:        %{name}-doxygen_hack.patch
134
135 Patch42:        %{name}-old-fileconflicts-behaviour.patch
136
137 Patch46:        %{name}-mono.patch
138 Patch47:        %{name}-javadeps.patch
139
140 Patch52:        %{name}-morearchs.patch
141
142 Patch55:        %{name}-truncate-cvslog.patch
143
144 Patch59:        %{name}-libtool-deps.patch
145 Patch60:        %{name}-mimetype.patch
146 Patch61:        %{name}-sparc64.patch
147 URL:            http://rpm5.org/
148 BuildRequires:  autoconf >= 2.60
149 BuildRequires:  automake >= 1.4
150 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
151 BuildRequires:  bzip2-devel >= 1.0.2-17
152 %{?with_db:BuildRequires:       db-devel >= %{reqdb_ver}}
153 BuildRequires:  elfutils-devel >= 0.108
154 BuildRequires:  gettext-autopoint >= 0.11.4-2
155 BuildRequires:  gettext-devel >= 0.11.4-2
156 BuildRequires:  lzma-devel >= 4.999.3
157 BuildRequires:  libmagic-devel
158 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.18}
159 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
160 BuildRequires:  libstdc++-devel
161 BuildRequires:  libtool >= 1:1.4.2-9
162 %if %{with neon}
163 BuildRequires:  libxml2-devel
164 BuildRequires:  neon-devel >= 0.25.5
165 %endif
166 BuildRequires:  patch >= 2.2
167 BuildRequires:  popt-devel >= %{reqpopt_ver}
168 %{?with_system_lua:BuildRequires:       lua51-devel >= 5.1.2}
169 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
170 BuildRequires:  python-modules >= 1:2.3
171 BuildRequires:  rpm-perlprov
172 %{?with_python:BuildRequires:   rpm-pythonprov}
173 %{?with_sqlite:BuildRequires:   sqlite3-devel}
174 BuildRequires:  zlib-devel
175 %if %{with apidocs}
176 BuildRequires:  doxygen
177 BuildRequires:  ghostscript
178 BuildRequires:  graphviz
179 BuildRequires:  tetex-pdftex
180 %endif
181 %if %{with static}
182 # Require static library only for static build
183 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
184 BuildRequires:  bzip2-static >= 1.0.2-17
185 %{?with_db:BuildRequires:       db-static >= %{reqdb_ver}}
186 BuildRequires:  elfutils-static
187 BuildRequires:  glibc-static >= 2.2.94
188 BuildRequires:  libmagic-static
189 %{?with_selinux:BuildRequires:  libselinux-static >= 1.18}
190 BuildRequires:  popt-static >= %{reqpopt_ver}
191 BuildRequires:  zlib-static
192 %endif
193 Requires:       %{name}-base = %{version}-%{release}
194 Requires:       %{name}-lib = %{version}-%{release}
195 Requires:       beecrypt >= %{beecrypt_ver}
196 Requires:       popt >= %{reqpopt_ver}
197 Provides:       rpm-db-ver = %{reqdb_ver}
198 Obsoletes:      rpm-getdeps
199 %{!?with_static:Obsoletes:      rpm-utils-static}
200 Conflicts:      glibc < 2.2.92
201 # db4.6 poldek needed
202 Conflicts:      poldek < 0.21-0.20070703.00.3
203 # segfaults with lzma 0.42.2
204 Conflicts:      lzma-libs < 4.999.3
205 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
206
207 %define         _binary_payload         w9.gzdio
208 %define         _noPayloadPrefix        1
209
210 # don't require very fresh rpm.macros to build
211 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
212 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
213 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
214 %define         ppc     ppc ppc7400 ppc7450
215 %define         x8664   amd64 ia32e x86_64
216
217 # stabilize new build environment
218 %define         __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
219 %define         __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
220 %define         __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
221
222 %define         _rpmlibdir /usr/lib/rpm
223 %define         _noautocompressdoc      RPM-GPG-KEY
224
225 %define         specflags       -fno-strict-aliasing
226
227 %description
228 RPM is a powerful package manager, which can be used to build,
229 install, query, verify, update, and uninstall individual software
230 packages. A package consists of an archive of files, and package
231 information, including name, version, and description.
232
233 %description -l de.UTF-8
234 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
235 Installation, Anfrage, Verifizierung, Aktualisierung und
236 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
237 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
238 Beschreibung.
239
240 %description -l es.UTF-8
241 RPM es un poderoso administrador de paquetes, que puede ser usado para
242 construir, instalar, pesquisar, verificar, actualizar y desinstalar
243 paquetes individuales de software. Un paquete consiste en un
244 almacenaje de archivos, y información sobre el paquete, incluyendo
245 nombre, versión y descripción.
246
247 %description -l pl.UTF-8
248 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
249 przebudowanie, instalację czy weryfikację dowolnego pakietu.
250 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
251 plików wchodzących w skład pakietu, zależności od innych pakietów, są
252 przechowywane w bazie danych i można je uzyskać za pomocą opcji
253 odpytywania programu rpm.
254
255 %description -l pt_BR.UTF-8
256 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
257 construir, instalar, pesquisar, verificar, atualizar e desinstalar
258 pacotes individuais de software. Um pacote consiste de um conjunto de
259 arquivos e informações adicionais, incluindo nome, versão e descrição
260 do pacote, permissões dos arquivos, etc.
261
262 %description -l ru.UTF-8
263 RPM - это мощный менеджер пакетов, который может быть использован для
264 создания, инсталляции, запросов (query), проверки, обновления и
265 удаления программных пакетов. Пакет состоит из файлового архива и
266 служебной информации, включающей название, версию, описание и другие
267 данные о пакете.
268
269 %description -l uk.UTF-8
270 RPM - це потужний менеджер пакетів, що може бути використаний для
271 створення, інсталяції, запитів (query), перевірки, поновлення та
272 видалення програмних пакетів. Пакет складається з файлового архіву та
273 службової інформації, що містить назву, версію, опис та іншу
274 інформацію про пакет.
275
276 %package base
277 Summary:        RPM base package - scripts used by rpm packages themselves
278 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
279 Group:          Base
280 Requires:       filesystem
281 Obsoletes:      rpm-scripts
282 Obsoletes:      vserver-rpm
283
284 %description base
285 The RPM base package contains scripts used by rpm packages themselves.
286 These include:
287 - scripts for adding/removing groups and users needed for rpm
288   packages,
289 - banner.sh to display %%banner messages from rpm scriptlets.
290
291 %description base -l pl.UTF-8
292 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
293 Zawiera on:
294 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
295 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
296
297 %package lib
298 Summary:        RPMs library
299 Summary(pl.UTF-8):      Biblioteki RPM-a
300 Group:          Libraries
301 Requires:       beecrypt >= %{beecrypt_ver}
302 %{?with_db:Requires:    db >= %{reqdb_ver}}
303 Requires:       libmagic >= 1.15-2
304 %{?with_selinux:Requires:       libselinux >= 1.18}
305 Requires:       popt >= %{reqpopt_ver}
306 Obsoletes:      rpm-libs
307 # avoid SEGV caused by mixed db versions
308 Conflicts:      poldek < 0.18.1-16
309
310 %description lib
311 RPMs library.
312
313 %description lib -l pl.UTF-8
314 Biblioteki RPM-a.
315
316 %package devel
317 Summary:        Header files for rpm libraries
318 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
319 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
320 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
321 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
322 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
323 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
324 Group:          Development/Libraries
325 Requires:       %{name}-lib = %{version}-%{release}
326 Requires:       beecrypt-devel >= %{beecrypt_ver}
327 Requires:       bzip2-devel
328 %{?with_db:Requires:    db-devel >= %{reqdb_ver}}
329 Requires:       elfutils-devel
330 Requires:       libmagic-devel
331 %{?with_selinux:Requires:       libselinux-devel}
332 Requires:       popt-devel >= %{reqpopt_ver}
333 Requires:       zlib-devel
334
335 %description devel
336 The RPM packaging system includes C libraries that make it easy to
337 manipulate RPM packages and databases. They are intended to ease the
338 creation of graphical package managers and other tools that need
339 intimate knowledge of RPM packages. This package contains header files
340 for these libraries.
341
342 %description devel -l de.UTF-8
343 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
344 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
345 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
346 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
347
348 %description devel -l es.UTF-8
349 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
350 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
351 facilitar la creación de administradores gráficos de paquetes y otras
352 herramientas que necesiten un conocimiento profundo de paquetes RPM.
353
354 %description devel -l pl.UTF-8
355 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
356 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
357 graficznych programów zarządzających pakietami oraz innych narzędzi,
358 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
359 zawiera pliki nagłówkowe wspomnianych bibliotek.
360
361 %description devel -l pt_BR.UTF-8
362 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
363 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
364 facilitar a criação de gerenciadores gráficos de pacotes e outras
365 ferramentas que precisem de conhecimento profundo de pacotes RPM.
366
367 %description devel -l ru.UTF-8
368 Система управления пакетами RPM содержит библиотеку C, которая
369 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
370 Эта библиотека предназначена для облегчения создания графических
371 пакетных менеджеров и других утилит, которым необходимо работать с
372 пакетами RPM.
373
374 %description devel -l uk.UTF-8
375 Система керування пакетами RPM містить бібліотеку C, котра спрощує
376 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
377 призначена для полегшення створення графічних пакетних менеджерів та
378 інших утиліт, що працюють з пакетами RPM.
379
380 %package static
381 Summary:        RPM static libraries
382 Summary(de.UTF-8):      RPMs statische Libraries
383 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
384 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
385 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
386 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
387 Group:          Development/Libraries
388 Requires:       %{name}-devel = %{version}-%{release}
389 Requires:       beecrypt-static >= %{beecrypt_ver}
390 Requires:       bzip2-static
391 %{?with_db:Requires:    db-static >= %{reqdb_ver}}
392 Requires:       elfutils-static
393 Requires:       libmagic-static
394 Requires:       popt-static >= %{reqpopt_ver}
395 Requires:       zlib-static
396
397 %description static
398 RPM static libraries.
399
400 %description static -l de.UTF-8
401 RPMs statische Libraries.
402
403 %description static -l pl.UTF-8
404 Biblioteki statyczne RPM-a.
405
406 %description static -l pt_BR.UTF-8
407 Bibliotecas estáticas para desenvolvimento.
408
409 %description static -l ru.UTF-8
410 Система управления пакетами RPM содержит библиотеку C, которая
411 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
412 Это статическая библиотека RPM.
413
414 %description static -l uk.UTF-8
415 Система керування пакетами RPM містить бібліотеку C, котра спрощує
416 роботу з пакетами RPM та відповідними базами даних. Це статична
417 бібліотека RPM.
418
419 %package utils
420 Summary:        Additional utilities for managing RPM packages and database
421 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
422 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
423 Group:          Applications/File
424 Requires:       %{name} = %{version}-%{release}
425 Requires:       popt >= %{reqpopt_ver}
426 %if %{with suggest_tags}
427 Suggests:       bzip2
428 Suggests:       gzip
429 %endif
430 Conflicts:      filesystem-debuginfo < 3.0-16
431
432 %description utils
433 Additional utilities for managing RPM packages and database.
434
435 %description utils -l de.UTF-8
436 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
437
438 %description utils -l pl.UTF-8
439 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
440
441 %package utils-perl
442 Summary:        Additional utilities for managing RPM packages and database
443 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
444 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
445 Group:          Applications/File
446 Requires:       %{name}-utils = %{version}-%{release}
447 Requires:       popt >= %{reqpopt_ver}
448
449 %description utils-perl
450 Additional utilities for managing RPM packages and database.
451
452 %description utils-perl -l de.UTF-8
453 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
454
455 %description utils-perl -l pl.UTF-8
456 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
457
458 %package utils-static
459 Summary:        Static rpm utilities
460 Summary(pl.UTF-8):      Statyczne narzędzia rpm
461 Group:          Applications/System
462 Requires:       %{name} = %{version}-%{release}
463
464 %description utils-static
465 Static rpm utilities for repairing system in case something with
466 shared libraries used by rpm become broken. Currently it contains rpmi
467 binary, which can be used to install/upgrade/remove packages without
468 using shared libraries (well, in fact with exception of NSS modules).
469
470 %description utils-static -l pl.UTF-8
471 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
472 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
473 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
474 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
475 (z wyjątkiem modułów NSS).
476
477 %package build
478 Summary:        Scripts for building binary RPM packages
479 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
480 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
481 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
482 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
483 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
484 Group:          Applications/File
485 Requires(pre):  findutils
486 Requires:       %{name}-build-macros >= 1.433-2
487 Requires:       %{name}-utils = %{version}-%{release}
488 Requires:       /bin/id
489 Requires:       awk
490 Requires:       bzip2
491 Requires:       chrpath >= 0.10-4
492 Requires:       cpio
493 Requires:       diffutils
494 Requires:       elfutils
495 Requires:       file >= 4.17
496 Requires:       fileutils
497 Requires:       findutils
498 %ifarch athlon
499 Requires:       gcc >= 3.0.3
500 %else
501 Requires:       gcc
502 %endif
503 Requires:       glibc-devel
504 Requires:       grep
505 Requires:       gzip
506 Requires:       make
507 Requires:       patch
508 Requires:       sed
509 Requires:       sh-utils
510 Requires:       tar
511 Requires:       textutils
512 Provides:       rpmbuild(monoautodeps)
513 Provides:       rpmbuild(noauto) = 3
514 %ifarch %{x8664}
515 Conflicts:      automake < 1:1.7.9-2
516 Conflicts:      libtool < 2:1.5-13
517 %endif
518
519 %description build
520 Scripts for building binary RPM packages.
521
522 %description build -l de.UTF-8
523 Scripts fürs Bauen binärer RPM-Pakete.
524
525 %description build -l pl.UTF-8
526 Skrypty pomocnicze do budowania binarnych RPM-ów.
527
528 %description build -l pt_BR.UTF-8
529 Este pacote contém scripts e programas executáveis que são usados para
530 construir pacotes usando o RPM.
531
532 %description build -l ru.UTF-8
533 Различные вспомогательные скрипты и исполняемые программы, которые
534 используются для сборки RPM'ов.
535
536 %description build -l uk.UTF-8
537 Різноманітні допоміжні скрипти та утиліти, які використовуються для
538 побудови RPM'ів.
539
540 %package javaprov
541 Summary:        Additional utilities for checking Java provides/requires in RPM packages
542 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
543 Group:          Applications/File
544 Requires:       %{name} = %{version}-%{release}
545 Requires:       file
546 Requires:       findutils >= 1:4.2.26
547 Requires:       mktemp
548 Requires:       unzip
549
550 %description javaprov
551 Additional utilities for checking Java provides/requires in RPM
552 packages.
553
554 %description javaprov -l pl.UTF-8
555 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
556 RPM.
557
558 %package perlprov
559 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
560 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
561 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
562 Group:          Applications/File
563 Requires:       %{name} = %{version}-%{release}
564 Requires:       perl-devel
565 Requires:       perl-modules
566
567 %description perlprov
568 Additional utilities for checking Perl provides/requires in RPM
569 packages.
570
571 %description perlprov -l de.UTF-8
572 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
573
574 %description perlprov -l pl.UTF-8
575 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
576 pakietach RPM.
577
578 %package pythonprov
579 Summary:        Python macros, which simplifies creation of RPM packages with Python software
580 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
581 Group:          Applications/File
582 Requires:       %{name} = %{version}-%{release}
583 Requires:       python
584 Requires:       python-modules
585
586 %description pythonprov
587 Python macros, which simplifies creation of RPM packages with Python
588 software.
589
590 %description pythonprov -l pl.UTF-8
591 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
592 Pythonie.
593
594 %package php-pearprov
595 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
596 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
597 Group:          Applications/File
598 Requires:       %{name} = %{version}-%{release}
599 Requires:       sed >= 4.0
600
601 %description php-pearprov
602 Additional utilities for checking PHP PEAR provides/requires in RPM
603 packages.
604
605 %description php-pearprov -l pl.UTF-8
606 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
607 pakietach RPM.
608
609 %package -n python-rpm
610 Summary:        Python interface to RPM library
611 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
612 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
613 Group:          Development/Languages/Python
614 Requires:       %{name} = %{version}-%{release}
615 %pyrequires_eq  python
616 Obsoletes:      rpm-python
617
618 %description -n python-rpm
619 The rpm-python package contains a module which permits applications
620 written in the Python programming language to use the interface
621 supplied by RPM (RPM Package Manager) libraries.
622
623 This package should be installed if you want to develop Python
624 programs that will manipulate RPM packages and databases.
625
626 %description -n python-rpm -l pl.UTF-8
627 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
628 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
629
630 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
631 Pythonie programy manipulujące pakietami i bazami danych rpm.
632
633 %description -n python-rpm -l pt_BR.UTF-8
634 O pacote rpm-python contém um módulo que permite que aplicações
635 escritas em Python utilizem a interface fornecida pelas bibliotecas
636 RPM (RPM Package Manager).
637
638 Esse pacote deve ser instalado se você quiser desenvolver programas em
639 Python para manipular pacotes e bancos de dados RPM.
640
641 %package apidocs
642 Summary:        RPM API documentation and guides
643 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
644 Group:          Documentation
645
646 %description apidocs
647 Documentation for RPM API and guides in HTML format generated from rpm
648 sources by doxygen.
649
650 %description apidocs -l pl.UTF-8
651 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
652 źrodeł RPM-a przez doxygen.
653
654 %prep
655 %setup -q -n %{name}-%{version}%{?subver}
656 %patch0 -p1
657 %patch1 -p1
658 %patch2 -p1
659 %patch3 -p1
660 %patch4 -p1
661 %patch5 -p1
662 %patch6 -p1
663 %patch7 -p1
664 %patch8 -p1
665 %patch9 -p1
666 %patch10 -p1
667 %{?with_system_lua:%patch11 -p1}
668 # CHECK ME - macrofiles: ~/etc could be used
669 #%%patch14 -p1
670 %patch16 -p1
671 echo '%%define  __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
672 echo '%%define  __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
673 echo '# obsoleted file' > macros.python
674 echo '%%define  __php_provides  /usr/lib/rpm/php.prov' > macros.php
675 echo '%%define  __php_requires  /usr/lib/rpm/php.req' >> macros.php
676 echo '%%define  __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
677 echo '%%define  __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
678 install %{SOURCE9} scripts/php.prov.in
679 install %{SOURCE10} scripts/php.req.in
680 install %{SOURCE12} scripts/perl.prov
681 %patch23 -p1
682
683 %ifarch i386 i486
684 # disable TSC
685 %patch26 -p1
686 %endif
687 %patch27 -p1
688 %patch32 -p1
689 %patch34 -p1
690 %patch35 -p0
691 %patch36 -p1
692 %patch37 -p1
693 %patch42 -p1
694 %patch46 -p1
695 %patch47 -p1
696 # OLD COMMENTED OUT
697 #%%patch52 -p1 -- morearchs (rpmrc patch) adds ppc7400, ppc7400
698 %patch55 -p1
699 %patch59 -p1
700 %patch17 -p1
701 %patch18 -p1
702 %patch60 -p1
703 %ifarch sparc64
704 %patch61 -p1
705 %endif
706
707 cd scripts
708 mv -f perl.req perl.req.in
709 mv -f perl.prov perl.prov.in
710 cd ..
711
712 # generate Group translations to *.po
713 awk -f %{SOURCE6} %{SOURCE1}
714
715 # update macros paths
716 #for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
717 #       sed -e 's@lib/rpm/redhat@lib/rpm/pld@g' $f > ${f}.tmp
718 #       mv -f ${f}.tmp $f
719 #done
720
721 %build
722 %{__libtoolize}
723 #%{__autopoint}
724 %{__aclocal}
725 %{__autoheader}
726 %{__autoconf}
727 %{__automake}
728
729 # config.guess doesn't handle athlon, so we have to change it by hand.
730 # rpm checks for CPU type at runtime, but it looks better
731 #sed -i -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' -e 's|@host_cpu@|%{_target_cpu}|' macros.in
732
733 %{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
734 # pass CC and CXX too in case of building with some older configure macro
735 %configure \
736         CC="%{__newcc}" \
737         CXX="%{__newcxx}" \
738         CPP="%{__newcpp}" \
739         WITH_PERL_VERSION=no \
740         %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
741         --enable-shared \
742         --enable-static \
743         %{!?with_apidocs:--without-apidocs} \
744         %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
745         %{!?with_python:--without-python} \
746         --with%{!?with_selinux:out}-selinux \
747         --with-libelf \
748         --with-zlib=external \
749         --with-bzip2=external \
750         --with-beecrypt=external \
751         --with-lzma=external \
752         --with-neon=%{?with_neon:external}%{!?with_neon:no} \
753         --with-file=external \
754         --with-popt=external \
755         --with-db=%{?with_db:external}%{!?with_db:no} \
756         --with-sqlite=%{?with_sqlite:external}%{!?with_sqlite:no} \
757         --with-dbapi=%{!?with_sqlite_dbapi:db}%{?with_sqlite_dbapi:sqlite} \
758         --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
759         --with-pcre=no \
760         --with-keyutils=none \
761         --without-path-versioned \
762         --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.pld:%{_rpmlibdir}/macros.build:%{_rpmlibdir}/%%{_target}/macros:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:~/etc/rpmmacros:~/etc/.rpmmacros:~/.rpmmacros' \
763         --with-bugreport="http://bugs.pld-linux.org/"
764
765 %{__make} -j1 \
766         CC="%{__cc}" \
767         CXX="%{__cxx}" \
768         CPP="%{__cpp}"
769
770 %{?with_apidocs:%{__make} apidocs}
771
772 %install
773 rm -rf $RPM_BUILD_ROOT
774 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
775
776 install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
777
778 %{__make} install \
779         pkgconfigdir=%{_pkgconfigdir} \
780         DESTDIR=$RPM_BUILD_ROOT
781
782 # install ARCH macros
783 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux
784 install %{SOURCE105} $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
785
786 %ifarch %{ix86}
787 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{i386,i486,i586,i686,athlon,pentium3,pentium4}-linux
788 install %{SOURCE100} $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
789 install %{SOURCE101} $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
790 install %{SOURCE102} $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
791 install %{SOURCE103} $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
792 install %{SOURCE104} $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
793 install %{SOURCE106} $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
794 install %{SOURCE107} $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
795 %endif
796
797 %ifarch %{x8664}
798 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{x86_64,ia32e,amd64}-linux
799 install %{SOURCE109} $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
800 install %{SOURCE110} $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
801 install %{SOURCE111} $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
802 %endif
803
804 %ifarch %{ppc}
805 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux
806 install %{SOURCE108} $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
807 %endif
808
809 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
810 # first platform file entry can't contain regexps
811 %{_target_cpu}-%{_target_vendor}-linux
812
813 # x86_64 things
814 %ifarch x86_64
815 x86_64-[^-]*-[Ll]inux(-gnu)?
816 amd64-[^-]*-[Ll]inux(-gnu)?
817 %endif
818 %ifarch amd64
819 amd64-[^-]*-[Ll]inux(-gnu)?
820 x86_64-[^-]*-[Ll]inux(-gnu)?
821 %endif
822 %ifarch ia32e
823 ia32e-[^-]*-[Ll]inux(-gnu)?
824 x86_64-[^-]*-[Ll]inux(-gnu)?
825 %endif
826
827 # x86 things
828 %ifarch athlon %{x8664}
829 athlon-[^-]*-[Ll]inux(-gnu)?
830 %endif
831 %ifarch pentium4 athlon %{x8664}
832 pentium4-[^-]*-[Ll]inux(-gnu)?
833 %endif
834 %ifarch pentium3 pentium4 athlon %{x8664}
835 pentium3-[^-]*-[Ll]inux(-gnu)?
836 %endif
837 %ifarch i686 pentium3 pentium4 athlon %{x8664}
838 i686-[^-]*-[Ll]inux(-gnu)?
839 %endif
840 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
841 i586-[^-]*-[Ll]inux(-gnu)?
842 %endif
843 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
844 i486-[^-]*-[Ll]inux(-gnu)?
845 %endif
846 %ifarch %{ix86} %{x8664}
847 i386-[^-]*-[Ll]inux(-gnu)?
848 %endif
849
850 %ifarch alpha
851 alpha-[^-]*-[Ll]inux(-gnu)?
852 %endif
853
854 %ifarch ia64
855 ia64-[^-]*-[Ll]inux(-gnu)?
856 %endif
857
858 %ifarch ppc64
859 powerpc64-[^-]*-[Ll]inux(-gnu)?
860 ppc64-[^-]*-[Ll]inux(-gnu)?
861 %endif
862 %ifarch %{ppc} ppc64
863 powerpc-[^-]*-[Ll]inux(-gnu)?
864 ppc-[^-]*-[Ll]inux(-gnu)?
865 %endif
866
867 %ifarch s390x
868 s390x-[^-]*-[Ll]inux(-gnu)?
869 %endif
870 %ifarch s390 s390x
871 s390-[^-]*-[Ll]inux(-gnu)?
872 %endif
873
874 %ifarch sparc64
875 sparc64-[^-]*-[Ll]inux(-gnu)?
876 sparcv8-[^-]*-[Ll]inux(-gnu)?
877 sparcv9-[^-]*-[Ll]inux(-gnu)?
878 %endif
879 %ifarch sparcv9
880 sparcv8-[^-]*-[Ll]inux(-gnu)?
881 sparcv9-[^-]*-[Ll]inux(-gnu)?
882 %endif
883 %ifarch sparc sparcv9 sparc64
884 sparc-[^-]*-[Ll]inux(-gnu)?
885 %endif
886
887 # noarch
888 noarch-[^-]*-.*
889 EOF
890
891 %ifarch %{ppc}
892 #sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
893 #       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
894 %endif
895
896 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
897 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
898 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
899 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
900
901 # not installed since 4.4.8 (-tools-perl subpackage)
902 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
903
904 install macros.perl     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.perl
905 install macros.python   $RPM_BUILD_ROOT%{_rpmlibdir}/macros.python
906 install macros.php      $RPM_BUILD_ROOT%{_rpmlibdir}/macros.php
907 install macros.mono     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.mono
908 install %{SOURCE15}     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.java
909 install %{SOURCE18}     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.pld
910
911 install %{SOURCE1} doc/manual/groups
912 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
913 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
914 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
915 install %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/check-files
916 install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
917 install %{SOURCE16} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
918 install scripts/find-php*       $RPM_BUILD_ROOT%{_rpmlibdir}
919 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
920 install %{SOURCE20} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
921 install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
922 install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
923
924 install %{SOURCE17} $RPM_BUILD_ROOT%{_bindir}/banner.sh
925
926 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
927
928 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
929 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
930 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
931 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
932 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
933 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
934
935 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
936 # customized rpm macros - global for host
937 #
938 #%%_install_langs pl_PL:en_US
939 %%distribution PLD
940 #
941 # remove or replace with file_contexts path if you want to use custom
942 # SELinux file contexts policy instead of one stored in packages payload
943 %%_install_file_context_path    %%{nil}
944 %%_verify_file_context_path     %%{nil}
945
946 # If non-zero, all erasures will be automagically repackaged.
947 #%%_repackage_all_erasures    1
948 EOF
949
950 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles <<EOF
951 # global list of files (regexps) which don't generate Provides
952 EOF
953 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov <<EOF
954 # global list of script capabilities (regexps) not to be used in Provides
955 EOF
956 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles <<EOF
957 # global list of files (regexps) which don't generate Requires
958 ^%{_examplesdir}/
959 ^%{_docdir}/
960 EOF
961 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq <<EOF
962 # global list of script capabilities (regexps) not to be used in Requires
963 EOF
964 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
965 # global list of capabilities (SONAME, perl(module), php(module) regexps)
966 # which don't generate dependencies on package NAMES
967 # -- OpenGL implementation
968 ^libGL.so.1
969 ^libGLU.so.1
970 ^libOSMesa.so
971 # -- Glide
972 ^libglide3.so.3
973 # -- mozilla
974 ^libgtkmozembed.so
975 ^libgtksuperwin.so
976 ^libxpcom.so
977 # -- X11 implementation
978 ^libFS.so
979 ^libI810XvMC.so
980 ^libICE.so
981 ^libSM.so
982 ^libX11.so
983 ^libXRes.so
984 ^libXTrap.so
985 ^libXaw.so
986 ^libXcomposite.so
987 ^libXcursor.so
988 ^libXdamage.so
989 ^libXdmcp.so
990 ^libXevie.so
991 ^libXext.so
992 ^libXfixes.so
993 ^libXfont.so
994 ^libXfontcache.so
995 ^libXft.so
996 ^libXi.so
997 ^libXinerama.so
998 ^libXmu.so
999 ^libXmuu.so
1000 ^libXp.so
1001 ^libXpm.so
1002 ^libXrandr.so
1003 ^libXrender.so
1004 ^libXss.so
1005 ^libXt.so
1006 ^libXtst.so
1007 ^libXv.so
1008 ^libXvMC.so
1009 ^libXxf86dga.so
1010 ^libXxf86misc.so
1011 ^libXxf86rush.so
1012 ^libXxf86vm.so
1013 ^libdps.so
1014 ^libdpstk.so
1015 ^libfontenc.so
1016 ^libpsres.so
1017 ^libxkbfile.so
1018 ^libxkbui.so
1019 # -- fam / gamin
1020 ^libfam.so.0
1021 # -- mdns-bonjour: mDNSResponder-libs / avahi-compat-libdns_sd
1022 ^libdns_sd.so.1
1023 EOF
1024 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
1025 # global list of file masks not to be compressed in DOCDIR
1026 EOF
1027
1028 # for rpm -e|-U --repackage
1029 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1030 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
1031
1032 # move rpm to /bin
1033 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1034 # move essential libs to /lib (libs that /bin/rpm links to)
1035 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so; do
1036         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1037         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
1038 done
1039
1040 # Append rpm.platform contents to /usr/lib/rpm/${arch}-linux/macros
1041 for m in $RPM_BUILD_ROOT%{_rpmlibdir}/*/macros ; do
1042         cat %{SOURCE2} | %{__sed} 's#@LIB@#%{_lib}#' >> $m
1043 done
1044 # remove arch dependant macros which have no use on noarch
1045 %{__sed} -i -e '
1046 /{__spec_install_post_strip}/d
1047 /{__spec_install_post_chrpath}/d
1048 /{__spec_install_post_compress_modules}/d
1049 ' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
1050
1051 # Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1052 mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1053
1054 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1055 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
1056
1057 rm $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
1058
1059 # wrong location, not used anyway
1060 rm $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
1061 # utils dropped in 4.4.8 -- their manuals
1062 rm $RPM_BUILD_ROOT%{_mandir}/{,*/}/man8/rpmgraph.8
1063 # unpackaged in 4.4.9, reasons unknown
1064 rm $RPM_BUILD_ROOT%{_rpmlibdir}/symclash.{sh,py}
1065
1066 %find_lang %{name}
1067
1068 rm -rf manual
1069 cp -a doc/manual manual
1070 rm -f manual/Makefile*
1071
1072 %clean
1073 rm -rf $RPM_BUILD_ROOT
1074
1075 %triggerpostun lib -- %{name}-lib < %{version}
1076 rm -f /var/lib/rpm/__db*
1077
1078 %pretrans
1079 # this needs to be a dir
1080 if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
1081         umask 022
1082         mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1083         mkdir %{_sysconfdir}/rpm/sysinfo
1084 fi
1085
1086 %triggerpostun -- %{name} < 4.4.9-44
1087 %{_rpmlibdir}/hrmib-cache
1088
1089 %post   lib -p /sbin/ldconfig
1090 %postun lib -p /sbin/ldconfig
1091
1092 %pretrans build
1093 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
1094
1095 %files -f %{name}.lang
1096 %defattr(644,root,root,755)
1097 %doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
1098
1099 %dir %{_sysconfdir}/pki/rpm-gpg
1100 %{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1101
1102 %attr(755,root,root) /bin/rpm
1103 #%attr(755,root,root) %{_bindir}/rpmdb
1104 #%attr(755,root,root) %{_bindir}/rpmquery
1105 #%attr(755,root,root) %{_bindir}/rpmsign
1106 #%attr(755,root,root) %{_bindir}/rpmverify
1107
1108 %dir %{_sysconfdir}/rpm
1109 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
1110 %dir %{_sysconfdir}/rpm/sysinfo
1111 # these are ok to be replaced
1112 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
1113 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1114
1115
1116 %{_mandir}/man8/rpm.8*
1117 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1118 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1119 %lang(ko) %{_mandir}/ko/man8/rpm.8*
1120 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1121 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1122 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1123
1124 %dir /var/lib/rpm
1125 %dir %attr(700,root,root) /var/spool/repackage
1126 %dir /var/lock/rpm
1127 /var/lock/rpm/transaction
1128
1129 # exported package NVRA (stamped with install tid)
1130 # net-snmp hrSWInstalledName queries, bash-completions
1131 %dir /var/cache/hrmib
1132
1133 #%attr(755,root,root) %{_rpmlibdir}/rpmd
1134 #%{!?with_static:%attr(755,root,root) %{_rpmlibdir}/rpm[eiu]}
1135 #%attr(755,root,root) %{_rpmlibdir}/rpmk
1136 #%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
1137
1138 %{_rpmlibdir}/rpmpopt*
1139 %{_rpmlibdir}/macros
1140 %{_rpmlibdir}/macros.pld
1141
1142 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1143
1144 %files base
1145 %defattr(644,root,root,755)
1146 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1147 %dir %{_rpmlibdir}
1148 %attr(755,root,root) %{_bindir}/banner.sh
1149 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1150 %dir /var/lib/banner
1151
1152 %files lib
1153 %defattr(644,root,root,755)
1154 %attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1155 %attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1156 %attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1157 %attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
1158
1159 %files devel
1160 %defattr(644,root,root,755)
1161 %attr(755,root,root) %{_libdir}/librpm.so
1162 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1163 %attr(755,root,root) %{_libdir}/librpmbuild.so
1164 %attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
1165 %attr(755,root,root) %{_libdir}/librpmconstant.so
1166 %attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
1167 %attr(755,root,root) %{_libdir}/librpmdb.so
1168 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1169 %attr(755,root,root) %{_libdir}/librpmio.so
1170 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1171 %attr(755,root,root) %{_libdir}/librpmmisc.so
1172 %attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
1173 %{_libdir}/librpm*.la
1174 %{_includedir}/rpm
1175 %{_pkgconfigdir}/*.pc
1176
1177 %files static
1178 %defattr(644,root,root,755)
1179 %{_libdir}/librpm*.a
1180
1181 %files utils
1182 %defattr(644,root,root,755)
1183 %attr(755,root,root) %{_bindir}/rpm2cpio
1184 %attr(755,root,root) %{_bindir}/rpmcache
1185 %attr(755,root,root) %{_bindir}/rpmconstant
1186 %attr(755,root,root) %{_bindir}/rpmdigest
1187 %attr(755,root,root) %{_bindir}/rpmgrep
1188 %attr(755,root,root) %{_bindir}/rpmrepo
1189 %attr(755,root,root) %{_bindir}/rpmmtree
1190 %attr(755,root,root) %{_rpmlibdir}/debugedit
1191 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1192 %attr(755,root,root) %{_rpmlibdir}/rpmcmp
1193 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1194 %attr(755,root,root) %{_rpmlibdir}/rpmdeps
1195 %attr(755,root,root) %{_rpmlibdir}/tgpg
1196 %{_mandir}/man1/rpmgrep.1*
1197 %{_mandir}/man8/rpm2cpio.8*
1198 %{_mandir}/man8/rpmcache.8*
1199 %{_mandir}/man8/rpmdeps.8*
1200 %{_mandir}/man8/rpmmtree.8*
1201 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1202 %lang(ja) %{_mandir}/ja/man8/rpmcache.8*
1203 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1204 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1205 %lang(pl) %{_mandir}/pl/man8/rpmcache.8*
1206 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1207 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1208
1209 %files utils-perl
1210 %defattr(644,root,root,755)
1211 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1212
1213 %if %{with static}
1214 %files utils-static
1215 %defattr(644,root,root,755)
1216 %attr(755,root,root) %{_bindir}/rpm[ieu]
1217 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1218 %endif
1219
1220 %files build
1221 %defattr(644,root,root,755)
1222 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1223 %attr(755,root,root) %{_rpmlibdir}/brp-*
1224 %attr(755,root,root) %{_rpmlibdir}/check-files
1225 # %attr(755,root,root) %{_rpmlibdir}/check-prereqs
1226 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1227 #%attr(755,root,root) %{_rpmlibdir}/config.*
1228 %attr(755,root,root) %{_rpmlibdir}/cross-build
1229 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1230 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1231 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1232 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
1233 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1234 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1235 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1236 %attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
1237 # needs hacked pkg-config to return anything
1238 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1239 #%attr(755,root,root) %{_rpmlibdir}/rpmb
1240 #%attr(755,root,root) %{_rpmlibdir}/rpmt
1241 %{_rpmlibdir}/noarch-*
1242 %ifarch %{ix86}
1243 %{_rpmlibdir}/i?86*
1244 %{_rpmlibdir}/pentium*
1245 %{_rpmlibdir}/athlon*
1246 %endif
1247 %ifarch alpha
1248 %{_rpmlibdir}/alpha*
1249 %endif
1250 %ifarch ia64
1251 %{_rpmlibdir}/ia64*
1252 %endif
1253 %ifarch mips mipsel mips64 mips64el
1254 %{_rpmlibdir}/mips*
1255 %endif
1256 %ifarch %{ppc}
1257 %{_rpmlibdir}/ppc*
1258 %endif
1259 %ifarch sparc sparc64
1260 %{_rpmlibdir}/sparc*
1261 %endif
1262 %ifarch %{x8664}
1263 %{_rpmlibdir}/amd64*
1264 %{_rpmlibdir}/ia32e*
1265 %{_rpmlibdir}/x86_64*
1266 %endif
1267 # must be here for "Requires: rpm-*prov" to work
1268 %{_rpmlibdir}/macros.java
1269 %{_rpmlibdir}/macros.mono
1270 %{_rpmlibdir}/macros.perl
1271 %{_rpmlibdir}/macros.php
1272 # not used yet ... these six depend on perl
1273 #%attr(755,root,root) %{_rpmlibdir}/http.req
1274 #%attr(755,root,root) %{_rpmlibdir}/magic.prov
1275 #%attr(755,root,root) %{_rpmlibdir}/magic.req
1276 #%{_rpmlibdir}/sql.prov
1277 #%{_rpmlibdir}/sql.req
1278 #%{_rpmlibdir}/tcl.req
1279
1280 %attr(755,root,root) %{_bindir}/gendiff
1281 %attr(755,root,root) %{_bindir}/rpmbuild
1282
1283 %{_mandir}/man1/gendiff.1*
1284 %{_mandir}/man8/rpmbuild.8*
1285 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1286 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1287 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1288
1289 %files javaprov
1290 %defattr(644,root,root,755)
1291 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1292 # needs jar (any jdk), jcf-dump (gcc-java) to work
1293 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1294
1295 %files perlprov
1296 %defattr(644,root,root,755)
1297 %attr(755,root,root) %{_rpmlibdir}/perl.*
1298 #%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1299 #%attr(755,root,root) %{_rpmlibdir}/find-perl-*
1300 #%attr(755,root,root) %{_rpmlibdir}/find-*.perl
1301 #%attr(755,root,root) %{_rpmlibdir}/find-prov.pl
1302 #%attr(755,root,root) %{_rpmlibdir}/find-req.pl
1303 #%attr(755,root,root) %{_rpmlibdir}/get_magic.pl
1304
1305 %files pythonprov
1306 %defattr(644,root,root,755)
1307 %{_rpmlibdir}/macros.python
1308 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1309
1310 %files php-pearprov
1311 %defattr(644,root,root,755)
1312 %attr(755,root,root) %{_rpmlibdir}/php*
1313 %attr(755,root,root) %{_rpmlibdir}/find-php*
1314
1315 %if %{with python}
1316 %files -n python-rpm
1317 %defattr(644,root,root,755)
1318 %dir %{py_sitedir}/rpm
1319 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1320 %{py_sitedir}/rpm/*.py[co]
1321 %endif
1322
1323 %if %{with apidocs}
1324 %files apidocs
1325 %defattr(644,root,root,755)
1326 %doc apidocs
1327 %endif
This page took 0.297746 seconds and 2 git commands to generate.