]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- added %ifarch for PPC port of PLD :)
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat (and now also PLD) Package Manager
2 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
3 Summary(pl):    Aplikacja do zarz±dzania pakietami
4 Name:           rpm
5 Version:        4.0.2
6 Release:        45
7 License:        GPL
8 Group:          Base
9 Group(de):      Gründsätzlich
10 Group(es):      Base
11 Group(pl):      Podstawowe
12 Group(pt_BR):   Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Patch0:         %{name}-rpmrc.patch
28 Patch1:         %{name}-macros.patch
29 Patch2:         %{name}-arch.patch
30 Patch3:         %{name}-rpmpopt.patch
31 Patch4:         %{name}-perl-macros.patch
32 Patch5:         %{name}-db3.patch
33 Patch6:         %{name}-segv.patch
34 Patch7:         %{name}-am_fix.patch
35 Patch8:         %{name}-perl-req-perlfile.patch
36 Patch9:         %{name}-installplatform.patch
37 Patch10:        %{name}-cache.patch
38 Patch11:        %{name}-suggestions.patch
39 Patch12:        %{name}-rh-lame.patch
40 Patch13:        %{name}-glob.patch
41 Patch14:        %{name}-header_h.patch
42 Patch15:        %{name}-fast-alAddPackage.patch
43 Patch16:        %{name}-byKey.patch
44 Patch17:        %{name}-perlprov.patch
45 Patch18:        %{name}-noperldir.patch
46 Patch19:        popt-cvs20010530.patch
47 Patch20:        %{name}-noexpand.patch
48 Patch21:        %{name}-scripts-closefds.patch
49 Patch22:        %{name}-python-amfix.patch
50 Patch23:        %{name}-non-english-man-pages.patch
51 Patch24:        %{name}-progress-nontty.patch
52 Patch25:        %{name}-am_ac.patch
53 Patch26:        %{name}-python-macros.patch
54 Patch37:        %{name}-short_circuit.patch
55 Patch38:        %{name}-section_test.patch
56 BuildRequires:  gettext-devel >= 0.10.38-3
57 BuildRequires:  automake
58 BuildRequires:  db3-devel >= 3.1.17-9
59 BuildRequires:  bzip2-devel >= 1.0.1
60 BuildRequires:  zlib-devel
61 BuildRequires:  gettext-devel >= 0.10.38-3
62 BuildRequires:  libtool
63 BuildRequires:  automake
64 BuildRequires:  autoconf >= 2.50
65 BuildRequires:  python-devel
66 BuildRequires:  python-modules >= 2.2.1
67 BuildRequires:  zlib-devel >= 1.1.4
68 # Require static library only for static build
69 BuildRequires:  db3-static >= 3.1.17-9
70 BuildRequires:  bzip2-static >= 1.0.1
71 BuildRequires:  zlib-static
72 BuildRequires:  glibc-static >= 2.2.0
73 %endif
74 BuildRequires:  zlib-static >= 1.1.4
75 Obsoletes:      rpm-libs
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77 Obsoletes:      rpm-libs
78 %define __find_provides %{SOURCE4}
79 %define _binary_payload w9.gzdio
80 %define         __find_provides %{SOURCE4}
81 %define py_ver         %(echo `python -c "import sys; print sys.version[:3]"`)
82 %define py_prefix      %(echo `python -c "import sys; print sys.prefix"`)
83 %define py_libdir      %{py_prefix}/lib/python%{py_ver}
84 %define py_sitedir     %{py_libdir}/site-packages
85 %define py_dyndir      %{py_libdir}/lib-dynload
86 %define         py_dyndir       %{py_libdir}/lib-dynload
87 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
88
89 %description
90 RPM is a powerful package manager, which can be used to build,
91 install, query, verify, update, and uninstall individual software
92 packages. A package consists of an archive of files, and package
93 information, including name, version, and description.
94
95 %description -l de
96 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
97 Installation, Anfrage, Verifizierung, Aktualisierung und
98 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
99 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
100 nombre, versión y descripción.
101
102 %description -l pl
103 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
104 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
105 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
106 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
107 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
108 do pacote, permissões dos arquivos, etc.
109
110 %package devel
111 Summary(de):    Header-Dateien uns Libraries
112 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
113 Group(de):      Entwicklung/Libraries
114 Group(es):      Desarrollo/Bibliotecas
115 Group(fr):      Development/Librairies
116 Group(pl):      Programowanie/Biblioteki
117 Group(pt_BR):   Desenvolvimento/Bibliotecas
118 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
119 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
120 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
121 Group:          Development/Libraries
122 Requires:       %{name} = %{version}
123 Requires:       popt-devel
124
125 %description devel
126 The RPM packaging system includes a C library that makes it easy to
127 manipulate RPM packages and databases. It is intended to ease the
128 creation of graphical package managers and other tools that need
129 intimate knowledge of RPM packages.
130
131 %description devel -l de
132 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
133 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
134 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
135 herramientas que necesiten un conocimiento profundo de paquetes RPM.
136 Pliki nag³ówkowe i biblioteki statyczne.
137 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
138 ferramentas que precisem de conhecimento profundo de pacotes RPM.
139
140 %package static
141 Summary(pl):    Biblioteki statyczne rpm-a
142 Summary(pl):    Biblioteki statyczne RPM-a
143 Group(de):      Entwicklung/Libraries
144 Group(es):      Desarrollo/Bibliotecas
145 Group(fr):      Development/Librairies
146 Group(pl):      Programowanie/Biblioteki
147 Group(pt_BR):   Desenvolvimento/Bibliotecas
148 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
149 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
150 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
151 Group:          Development/Libraries
152 Requires:       %{name}-devel = %{version}
153
154 %description static
155 RPM static libraries.
156
157 %description static -l de
158 RPMs statische Libraries.
159 Biblioteki statyczne rpm-a.
160 %description static -l pl
161 Bibliotecas estáticas para desenvolvimento.
162
163 %package utils
164 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami
165 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
166 Group(de):      Applikationen/Datei
167 Group(pl):      Aplikacje/Pliki
168 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
169 Group:          Applications/File
170 Requires:       %{name} = %{version}
171
172 %description utils
173 Additional utilities for managing rpm packages and database.
174
175 %description utils -l de
176 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
177 Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami.
178 %description utils -l pl
179 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
180
181 %package perlprov
182 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w pakietach rpm
183 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
184 Group(de):      Applikationen/Datei
185 Group(pl):      Aplikacje/Pliki
186 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
187 Group:          Applications/File
188 Requires:       perl-modules
189 Requires:       findutils
190
191 %description perlprov
192 Additional utilities for checking perl provides/requires in rpm
193 packages.
194
195 %description perlprov -l de
196 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
197 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w
198 %description perlprov -l pl
199 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
200 pakietach rpm.
201
202 %package pythonprov
203 Summary:        Python macros, which simplifies creation of rpm packages with Python software
204 Group(de):      Applikationen/Datei
205 Group(pl):      Aplikacje/Pliki
206 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
207 Requires:       python
208 Requires:       %{name} = %{version}
209 Requires:       python-modules
210
211 %description pythonprov
212 Python macros, which simplifies creation of rpm packages with Python
213 software.
214 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi
215 w Pythonie.
216 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
217 %package python
218
219 Group:          Development/Languages/Python
220 Group(de):      Entwicklung/Sprachen/Python
221 Group(pl):      Programowanie/Jêzyki/Python
222 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
223 %pyrequires_eq  python
224 %description python
225
226 %description -n python-rpm
227 The rpm-python package contains a module which permits applications
228 written in the Python programming language to use the interface
229 supplied by RPM (RPM Package Manager) libraries.
230
231 This package should be installed if you want to develop Python
232 %description python -l pl
233 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym
234 w Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki rpma.
235 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
236 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ
237 w Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
238 Esse pacote deve ser instalado se você quiser desenvolver programas em
239 Python para manipular pacotes e bancos de dados RPM.
240
241 %package build
242 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPMów
243 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
244 Group(de):      Applikationen/Datei
245 Group(pl):      Aplikacje/Pliki
246 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
247 Group:          Applications/File
248 Requires:       sh-utils
249 Requires:       binutils
250 Requires:       patch
251 Requires:       file >= 3.31
252 Requires:       binutils
253 Requires:       make
254 Requires:       gcc >= 3.0.3
255 Requires:       gcc
256 Requires:       diffutils
257 Requires:       glibc-devel
258 Requires:       sed
259 Requires:       sed
260 Requires:       popt >= 1.6.2-2
261 Requires:       tar
262 Requires:       textutils
263
264 %description build
265 Scripts for building binary RPM packages.
266
267 %description build -l de
268 Scripts fürs Bauen binärer RPM-Pakete.
269 Skrypty pomocnicze do budowania binarnych RPMów.
270 %description build -l pl
271 construir pacotes usando o RPM.
272
273 %prep
274 %setup -q -a12
275 %patch0 -p1
276 %patch1 -p1
277 %patch2 -p1
278 %patch3 -p1
279 %patch4 -p1
280 %patch5 -p1
281 %patch6 -p1
282 %patch7 -p1
283 %patch8 -p1
284 %patch11 -p0
285 %patch12 -p0
286 %patch11 -p0
287 %patch12 -p0
288 %patch15 -p0
289 %patch16 -p0
290 %patch15 -p0
291 %patch16 -p0
292 %patch17 -p1
293 %patch18 -p1
294 %patch19 -p1
295 %patch22 -p1
296 %patch23 -p1
297 %patch24 -p1
298 %patch25 -p1
299 %patch26 -p0
300 %patch31 -p1
301 %patch36 -p1
302 %patch37 -p1
303 %patch38 -p1
304
305 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
306 cp -f platform.in macros.pld.in
307 install %{SOURCE9} scripts/find-lang.sh
308 install %{SOURCE13} macros.python.in
309 install %{SOURCE6} scripts/find-perl-provides
310 install %{SOURCE7} scripts/find-perl-requires
311 install %{SOURCE9} scripts/find-lang.sh
312
313 (cd scripts;
314 mv -f perl.req perl.req.in
315 mv -f perl.prov perl.prov.in)
316 %build
317 awk -f %{SOURCE14} %{SOURCE1}
318
319 cd popt
320 autoconf
321 automake -a -c
322 aclocal
323 autoheader
324 %{__automake}
325 cd ..
326
327 rm -f missing
328 libtoolize --force --copy
329 autoconf
330 # ugly workaround for automake
331 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
332         lib/Makefile.am > lib/Makefile.am.new
333 mv -f lib/Makefile.am.new lib/Makefile.am
334 automake -a -c
335 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
336         lib/Makefile.in > lib/Makefile.in.new
337 mv -f lib/Makefile.in.new lib/Makefile.in
338
339 sed -e 's#python1.5#python%{py_ver}#g' \
340         python/Makefile.in > python/Makefile.in.new
341 mv -f python/Makefile.in.new python/Makefile.in
342
343 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
344         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
345         --enable-v1-packages \
346         --with-python
347 %configure \
348         --enable-v1-packages \
349         --with-python
350
351
352 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
353
354         DESTDIR="$RPM_BUILD_ROOT" \
355 rm -rf $RPM_BUILD_ROOT
356
357 %{__make} install \
358         DESTDIR=$RPM_BUILD_ROOT \
359         pkgbindir="%{_bindir}"
360
361 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
362 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
363
364 install %{SOURCE1} doc/manual/groups
365 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
366 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
367 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
368 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
369 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
370
371 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
372
373 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
374 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
375 # customized rpm macros - global for host
376 #
377 #%%_install_langs pl_PL:en_US
378 %%distribution PLD
379 EOF
380
381 %find_lang %{name}
382
383 # DON'T BREAK BUILD TREE!!!
384 # rm -f doc/manual/Makefile*
385
386 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
387
388 %clean
389 rm -rf $RPM_BUILD_ROOT
390
391 %post   -p /sbin/ldconfig
392 %postun -p /sbin/ldconfig
393
394 %attr(755,root,root) %{_libdir}/rpm/rpmdb
395 %attr(755,root,root) %{_libdir}/rpm/rpmq
396 %attr(755,root,root) %{_libdir}/rpm/rpmk
397 %attr(755,root,root) %{_libdir}/rpm/rpmv
398 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
399 %attr(755,root,root) %{_libdir}/rpm/rpmdb
400 %attr(755,root,root) %{_libdir}/rpm/rpmq
401 %attr(755,root,root) %{_libdir}/rpm/rpmk
402 %attr(755,root,root) %{_libdir}/rpm/rpmv
403 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
404
405 %dir %{_sysconfdir}/rpm
406 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
407
408 %{_mandir}/man8/rpm.8*
409 %lang(fr) %{_mandir}/fr/man8/rpm.8*
410 %lang(ja) %{_mandir}/ja/man8/rpm.8*
411 %lang(ko) %{_mandir}/ko/man8/rpm.8*
412 %lang(pl) %{_mandir}/pl/man8/rpm.8*
413 %lang(ru) %{_mandir}/ru/man8/rpm.8*
414 %lang(sk) %{_mandir}/sk/man8/rpm.8*
415
416 %dir /var/lib/rpm
417 %dir %{_libdir}/rpm
418
419 %{_libdir}/rpm/macros.python
420 %{_libdir}/rpm/noarch-linux
421 %{_libdir}/rpm/noarch-pld-linux
422 %ifarch i386 i486 i586 i686
423 %{_libdir}/rpm/rpmpopt*
424 %{_libdir}/rpm/noarch-linux
425 %{_libdir}/rpm/noarch-pld-linux
426 %ifarch i386 i486 i586 i686 athlon
427 %{_libdir}/rpm/i?86*
428 %{_libdir}/rpm/athlon*
429 %endif
430 %ifarch sparc sparc64
431 %{_libdir}/rpm/sparc*
432 %endif
433 %ifarch alpha
434 %{_libdir}/rpm/alpha*
435 %endif
436 %ifarch ppc
437 %{_libdir}/rpm/ppc*
438 %defattr(644,root,root,755)
439 %attr(755,root,root) %{_bindir}/rpmbuild
440 %attr(755,root,root) %{_bindir}/rpme
441 %attr(755,root,root) %{_bindir}/rpmi
442 %attr(755,root,root) %{_bindir}/rpmu
443 %attr(755,root,root) %{_libdir}/rpm/find-requires
444 %attr(755,root,root) %{_libdir}/rpm/find-provides
445 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
446 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
447 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
448 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
449 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
450 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
451 %attr(755,root,root) %{_libdir}/rpm/brp-*
452 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
453 %attr(755,root,root) %{_libdir}/rpm/compress-doc
454 %attr(755,root,root) %{_libdir}/rpm/cpanflute
455 %attr(755,root,root) %{_libdir}/rpm/http.req
456 %attr(755,root,root) %{_libdir}/rpm/magic.*
457 %attr(755,root,root) %{_libdir}/rpm/rpmi
458 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
459 %attr(755,root,root) %{_libdir}/rpm/rpme
460 %attr(755,root,root) %{_libdir}/rpm/rpmu
461 %attr(755,root,root) %{_libdir}/rpm/rpmb
462 %attr(755,root,root) %{_libdir}/rpm/rpmi
463 %attr(755,root,root) %{_libdir}/rpm/rpmt
464 %attr(755,root,root) %{_libdir}/rpm/rpme
465 %attr(755,root,root) %{_libdir}/librpm*.la
466 %attr(755,root,root) %{_libdir}/librpm*.so
467 %files devel
468 %defattr(644,root,root,755)
469 %{_includedir}/rpm
470 %attr(755,root,root) %{_libdir}/librpm*.la
471 %attr(755,root,root) %{_libdir}/librpm*.so
472
473 %files static
474 %attr(755,root,root) %{_bindir}/*
475 %files utils
476 %defattr(644,root,root,755)
477 %{_mandir}/man1/*
478 %attr(755,root,root) %{_bindir}/javadeps
479 %attr(755,root,root) %{_bindir}/rpm2cpio
480
481 %{_mandir}/man8/rpm2cpio.8*
482 %{_mandir}/man1/*
483 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
484 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
485 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
486 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
487
488 %files perlprov
489 %defattr(644,root,root,755)
490 %attr(755,root,root) %{_libdir}/rpm/perl*
491 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
492 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
493 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
494 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
495 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
496
497 %{_libdir}/rpm/macros.perl
498 %files python
499 %defattr(644,root,root,755)
500 %{py_sitedir}/*.so
501 %{_libdir}/rpm/macros.python
502
503 %files -n python-rpm
504 * %{date} PLD Team <pld-list@pld.org.pl>
505 %{py_sitedir}/*.so
This page took 0.060097 seconds and 3 git commands to generate.