]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
drop cc/cxx/cpp hack
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4 #   returns -ENOSYS
5 # - add macros for some ppc, mipsel, alpha and sparc
6 #
7 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
8 #
9 # Conditional build:
10 %bcond_with     static          # build static rpm+rpmi
11 %bcond_without  apidocs         # don't generate documentation with doxygen
12 %bcond_without  python          # don't build python bindings
13 %bcond_without  selinux         # build without selinux support
14 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
15 %bcond_with     db61            # use DB 6.1 instead of 5.2
16 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
17 %bcond_with     sqlite          # build with SQLite support
18 %bcond_with     system_lua      # use system lua
19 %bcond_without  system_pcre     # use system pcre
20 %bcond_with     keyutils        # build with keyutils support
21
22 %if %{with sqlite}
23 # Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
24 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
25 %endif
26
27 # versions of required libraries
28 %if %{with db61}
29 %define         reqdb_pkg       db6.1
30 %define         reqdb_ver       6.1
31 %define         reqdb_pkgver    6.1.19
32 %else
33 %define         reqdb_pkg       db5.2
34 %define         reqdb_ver       5.2
35 %define         reqdb_pkgver    5.2.36.0-4
36 %endif
37 %define         reqpopt_ver     1.15
38 %define         beecrypt_ver    2:4.2.0
39 %define         sover           5.4
40
41 Summary:        RPM Package Manager
42 Summary(de.UTF-8):      RPM Packet-Manager
43 Summary(es.UTF-8):      Gestor de paquetes RPM
44 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
45 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
46 Summary(ru.UTF-8):      Менеджер пакетов от RPM
47 Summary(uk.UTF-8):      Менеджер пакетів від RPM
48 Name:           rpm
49 Version:        5.4.15
50 Release:        39
51 License:        LGPL v2.1
52 Group:          Base
53 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
54 Source0:        %{name}-%{version}.tar.gz
55 # Source0-md5:  4067f83ca8b5bf1a21e443c0cff3efa0
56 # See README.cpu-os-macros how to update cpu-os-macros.a
57 Source100:      cpu-os-macros.a
58 Source101:      README.cpu-os-macros
59 Source1:        %{name}.groups
60 Source2:        macros.pld.in
61 Source3:        %{name}-install-tree
62 Source4:        %{name}-find-spec-bcond
63 Source5:        %{name}-hrmib-cache
64 Source6:        %{name}-groups-po.awk
65 Source7:        %{name}-compress-doc
66 Source8:        %{name}-php-provides
67 Source9:        %{name}-php-requires
68 Source10:       %{name}.sysinfo
69 Source11:       perl.prov
70 Source12:       %{name}-user_group.sh
71 Source13:       %{name}.sysconfig
72 Source14:       %{name}-java-requires
73 # http://svn.pld-linux.org/banner.sh/
74 Source15:       banner.sh
75 Source16:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
76 # Source16-md5: 23914bb49fafe7153cee87126d966461
77 Source17:       %{name}-mimetypedeps
78 Source18:       macros.local
79 Source19:       %{name}.noautocompressdoc
80 Source20:       %{name}.noautoprov
81 Source21:       %{name}.noautoprovfiles
82 Source22:       %{name}.noautoreq
83 Source24:       %{name}.noautoreqfiles
84 Source25:       %{name}-php-requires.php
85 Source26:       %{name}db_checkversion.c
86 Source27:       macros.lang
87 Source28:       %{name}db_reset.c
88 Source29:       dbupgrade.sh
89 Source30:       rubygems.rb
90 Source31:       gem_helper.rb
91 Patch0:         %{name}-branch.patch
92 Patch1:         %{name}-man_pl.patch
93 Patch2:         %{name}-popt-aliases.patch
94 Patch3:         %{name}-nosetproctitle.patch
95 Patch4:         %{name}-perl-macros.patch
96 Patch5:         %{name}-perl-req-perlfile.patch
97 Patch6:         %{name}-scripts-closefds.patch
98 Patch7:         %{name}-php-macros.patch
99 Patch8:         %{name}-gettext-in-header.patch
100 Patch9:         %{name}-lua.patch
101 Patch10:        %{name}-php-deps.patch
102 Patch11:        %{name}-notsc.patch
103 Patch12:        %{name}-hack-norpmlibdep.patch
104 Patch13:        %{name}-dont-copy-descriptive-tags.patch
105 Patch14:        %{name}-perl_req-INC_dirs.patch
106 Patch15:        %{name}-debuginfo.patch
107 Patch16:        vendor-pld.patch
108 Patch17:        %{name}-old-fileconflicts-behaviour.patch
109 Patch18:        %{name}-javadeps.patch
110 Patch19:        %{name}-truncate-cvslog.patch
111 Patch20:        %{name}-libtool-deps.patch
112 Patch21:        %{name}-mimetype.patch
113 Patch22:        %{name}-sparc64.patch
114 Patch23:        %{name}-gendiff.patch
115 Patch24:        openmp.patch
116 Patch25:        %{name}-URPM-build-fix.patch
117 Patch26:        %{name}-semanage.patch
118 Patch27:        %{name}-helperEVR-noassert.patch
119 Patch28:        %{name}-unglobal.patch
120 Patch29:        %{name}-builddir-readlink.patch
121 Patch30:        %{name}-changelog_order_check_nonfatal.patch
122 Patch31:        %{name}-cleanbody.patch
123 Patch32:        %{name}-dirdeps-macro.patch
124 Patch33:        %{name}-installbeforeerase.patch
125 Patch34:        %{name}-libmagic-locale.patch
126 Patch35:        %{name}-namespace-compare.patch
127 Patch36:        %{name}-popt-coreutils.patch
128 Patch37:        %{name}-postun-nofail.patch
129 Patch38:        %{name}-silence-RPM_CHAR_TYPE.patch
130 Patch39:        %{name}-fix-missing-types-in-headers.patch
131 Patch40:        %{name}-fix--p-interpreter-and-empty-script.patch
132 Patch41:        %{name}-db_buffer_small.patch
133 Patch42:        %{name}-pattern_Release.patch
134 Patch43:        %{name}-fix-___build_pre-macro.patch
135 Patch44:        %{name}-missing-patch-file-fails-build.patch
136 Patch45:        %{name}-remove-misleading-missing-patch-message.patch
137 Patch46:        %{name}-file-magic-can-be-mixed-case.patch
138 Patch47:        %{name}-query-always-noisy.patch
139 Patch48:        %{name}-verify-ghosts-broken-logic.patch
140 Patch49:        %{name}-python-enable-compat-RPMSENSE.patch
141 Patch50:        %{name}-dont-treat-gstreamer-modules-as-font.patch
142 Patch51:        %{name}-gst-inspect-typo.patch
143 Patch52:        %{name}-null-term-ascii-digest.patch
144 Patch53:        %{name}-lua-enable-extra-libs.patch
145 Patch54:        %{name}-fix-filedigests-verify.patch
146 Patch55:        %{name}-disable-hmac-verify.patch
147 Patch56:        %{name}-macros.patch
148 Patch57:        %{name}-db5.2.patch
149 Patch58:        %{name}-preserve-iterator.patch
150 Patch59:        gcc6-stdlib.patch
151 Patch60:        %{name}-python-sitescriptdir.patch
152 Patch61:        %{name}-clean-docdir.patch
153 Patch62:        %{name}-DB_CONFIG.patch
154 Patch63:        %{name}-pythoneggs.patch
155 Patch64:        %{name}-fix-compress-doc.patch
156 Patch65:        %{name}-parseSpec-skip-empty-tags.patch
157 Patch66:        %{name}-payload-use-hashed-inode.patch
158 Patch67:        %{name}-repackage-dont-force-max-compression.patch
159 Patch70:        python-%{name}sense-missingok.patch
160 Patch71:        %{name}-changelog-encoding.patch
161 Patch72:        %{name}-preserve-tag-type.patch
162 Patch74:        %{name}-fix-internal-lua-build.patch
163 Patch75:        %{name}-double_check_file_deps.patch
164 Patch77:        %{name}-lua-expat.patch
165 Patch78:        %{name}-double_check_unpackaged_subdirs.patch
166 Patch79:        %{name}-rpmspec.patch
167 Patch80:        %{name}-revert-gpg-argv-parsing.patch
168 Patch81:        %{name}-perl-magic.patch
169 Patch82:        %{name}-5.4.15-use-DSA-sig.patch
170 Patch83:        %{name}-ignore-missing-macro-files.patch
171 Patch84:        x32.patch
172 Patch85:        rpm-CVE-2013-6435.patch
173 Patch86:        rpm-CVE-2014-8118.patch
174 Patch87:        %{name}-file-output-for-ELF.patch
175 Patch88:        %{name}-rpmtdnext.patch
176 Patch89:        disable-header-verification.patch
177 Patch90:        %{name}-cppcompat.patch
178 Patch91:        py-disable-fetch.patch
179 Patch92:        fast_python_deps.patch
180 Patch93:        python2_explicit.patch
181 Patch94:        do_not_write_before_macro_buffer.patch
182 Patch95:        rpm-python-spec-header.patch
183 Patch96:        skip-ldconfig-optimization.patch
184
185 # Patches imported from Mandriva
186
187 # status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
188 # would basically just mean backporting it..
189 Patch1000:      %{name}-5.4.4-add-_specfile-macro.patch
190 # status: needs to be cleaned up and properly reviewed together with rest
191 # of the patches related to dependency generation
192 Patch1001:      %{name}-5.4.9-avoid-dependencies-on-self.patch
193 # status: probably ready to merge
194 Patch1002:      %{name}-5.4.4-pkgconfigdeps-check-path.patch
195 # status: probably okay to merge, but discuss on rpm-devel first
196 Patch1003:      %{name}-5.4.4-glob-wildcards-for-loading-macro-files.patch
197 # status: needs to be discussed
198 Patch1004:      %{name}-5.4.4-allow-installation-of-repackaged-rpms.patch
199 # status: ready to merge
200 Patch1005:      %{name}-5.4.8-dont-show-suggests-with-requires.patch
201 # status: ready for merge
202 Patch1006:      %{name}-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
203 # status: probably okay to merge, but discuss on rpm-devel first
204 Patch1007:      %{name}-5.4.10-duplicate_files_terminate_build.patch
205 # status: same as above
206 Patch1008:      %{name}-5.4.10-unpackaged_subdirs_terminate_build.patch
207 # mdvbz#64898
208 # status: uncertain, might be okay to merge, discuss on rpm-devel first
209 Patch1009:      %{name}-5.4.4-rpmbuild-withoutclean.patch
210 # no sense in having an additional dependency on 'pkgconfig' on all packages that
211 # have a pkgconfig file, it's not needed for them to be made useful and anything
212 # actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
213 # status: might be okay to merge, but discuss on rpm-devel first
214 Patch1010:      %{name}-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
215 # status: ready for merge
216 Patch1011:      %{name}-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
217 # $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
218 # %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
219 # status: needs to be discussed and investigated a bit better..
220 Patch1012:      %{name}-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
221 # status: probably okay to merge, but discuss on rpm-devel first
222 Patch1013:      %{name}-5.4.10-files-listed-twice-terminates-build.patch
223 # status: probably okay to merge
224 Patch1014:      %{name}-5.4.9-ruby1.9-fixes.patch
225 # status: keep locally
226 Patch1015:      %{name}-5.4.9-keep-loading-script-macros.patch
227 # status: same as for other dep gen patches
228 Patch1016:      %{name}-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
229 # status: idem
230 Patch1017:      %{name}-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
231 # status: probably okay to merge
232 Patch1019:      %{name}-5.4.5-python-export-spec-macros.patch
233 # status: idem
234 Patch1020:      %{name}-5.4.9-font-provides.patch
235 # stauus: idem
236 Patch1021:      %{name}-5.4.7-kmod-dependencies.patch
237 # status: probably okay to merge, discuss on rpm-devel first
238 Patch1022:      %{name}-5.4.5-skip-dependencies-for-character-devices.patch
239 # status: probably okay to merge
240 Patch1024:      %{name}-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
241 # status: probably okay to merge
242 Patch1026:      %{name}-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
243 # status: ready
244 Patch1027:      %{name}-5.4.7-fix-generation-of-ruby-abi-provides.patch
245 # crash reproducable with 'rpm -qa --triggers'
246 # status: ready
247 Patch1028:      %{name}-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
248 # status: same as for other dep gen patches
249 Patch1029:      %{name}-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
250 # status: ready
251 Patch1030:      %{name}-5.4.7-fix-minor-memleaks.patch
252 # status: ready
253 Patch1031:      %{name}-5.4.9-mire-fix-strings-lacking-null-terminator.patch
254 # status: ready
255 Patch1032:      %{name}-5.4.9-rpmpython-fix-input.patch
256 # status: ready
257 Patch1033:      %{name}-5.4.7-no-seqid_init-on-rdonly-database.patch
258 # status: probably ready for merging
259 Patch1034:      %{name}-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
260 # status: probably ready to merge, discuss on rpm-devel first
261 Patch1035:      %{name}-5.4.9-fix-verify-segfault.patch
262 # Due to rpmdav/neon being written in a different fashion than other rpmio clients,
263 # the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
264 # with the result being that when unable to download files, neon will save error
265 # page as the target file.
266 # status: should go upstream, but uncertain about "correct" fix, ie. this is
267 # more of a workaround, while rewriting rpmdav code to behave consistently
268 # would be "the right thing to do". Yet I'm not fully able to grasp all of the
269 # code and don't want to spend more time just to get the API..
270 Patch1037:      %{name}-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
271 # As the transaction flags for ignoring arch & os are no longer used, there's
272 # currently no way to ignore arch & os of packages anymore. This patch adds
273 # support for doing this again by defining rpm variables and overriding
274 # --ignorearch & --ignoreos to set these.
275 # status: needs to be discussed upstream before thinking about merging
276 Patch1038:      %{name}-5.4.10-support-ignore-arch-and-os-again.patch
277 # status: ready for merge
278 Patch1039:      %{name}-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
279 # we want that patch too, a bit of builder infrastructure relies on NOSIGNATURES
280 Patch1040:      %{name}-5.4.9-support-signatures-and-digest-disablers.patch
281 # lack insight on actual functionality, which anyways seems broken, so let's
282 # disable it to avoid errors from berkeley db..
283 # status: keep locally
284 Patch1041:      %{name}-5.4.9-disable-l10ndir.patch
285 # status: ready for merge
286 Patch1042:      %{name}-5.4.9-fix-rpm_qa-pattern.patch
287 # warning: introduces memory leak
288 Patch1043:      %{name}-5.4.12-copy-Value-string.patch
289 Patch1044:      %{name}-5.4.12-fix-rpmlua-print.patch
290 Patch1045:      %{name}-5.4.12-fix-rpmpython-module-import-init.patch
291 Patch1046:      %{name}-5.4.12-truncate-output-buffer-after-use.patch
292 Patch1047:      %{name}-5.4.13-perl-bindings-do-not-use-xmalloc.patch
293 # proyvind:
294 # there's a rpmdbchk tool I wrote a while back, which might help you. although
295 # the incidents it's able to deal with is rather limited ATM... it might help
296 # you out, if not and you'll be able to solve yer problem, you could take a
297 # stab at adding support for fixing your specific problem to the util ;)
298 # https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-rpmdbchk.patch
299 Patch1048:      %{name}-5.4.14-rpmdbchk.patch
300 # https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-no-assert-abort-with-broken-headers.patch
301 Patch1049:      %{name}-5.4.14-no-assert-abort-with-broken-headers.patch
302
303 Patch1050:      python-libx32.patch
304
305 URL:            http://rpm5.org/
306 BuildRequires:  %{reqdb_pkg}-devel >= %{reqdb_pkgver}
307 %if %{with sqlite}
308 BuildRequires:  sqlite3-devel
309 %else
310 BuildRequires:  %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
311 %endif
312 BuildRequires:  autoconf >= 2.63
313 BuildRequires:  automake >= 1.4
314 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
315 BuildRequires:  bzip2-devel >= 1.0.2-17
316 BuildRequires:  elfutils-devel >= 0.108
317 BuildRequires:  gettext-tools >= 0.19.2
318 %{?with_keyutils:BuildRequires: keyutils-devel}
319 BuildRequires:  libmagic-devel
320 %if %{with selinux}
321 BuildRequires:  libselinux-devel >= 2.1.0
322 BuildRequires:  libsemanage-devel >= 2.1.0
323 BuildRequires:  libsepol-devel >= 2.1.0
324 %endif
325 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
326 BuildRequires:  libstdc++-devel
327 BuildRequires:  libtool >= 1:1.4.2-9
328 %if %{with neon}
329 BuildRequires:  libxml2-devel
330 BuildRequires:  neon-devel >= 0.25.5
331 %endif
332 %{?with_system_lua:BuildRequires:       lua52-devel >= 5.2.2}
333 BuildRequires:  ossp-uuid-devel
334 BuildRequires:  patch >= 2.2
335 BuildRequires:  popt-devel >= %{reqpopt_ver}
336 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
337 BuildRequires:  python-modules >= 1:2.3
338 %{?with_python:BuildRequires:   rpm-pythonprov}
339 BuildRequires:  tcl
340 BuildRequires:  xz-devel
341 BuildRequires:  zlib-devel
342 %if %{with apidocs}
343 BuildRequires:  doxygen
344 BuildRequires:  ghostscript
345 BuildRequires:  graphviz
346 BuildRequires:  tetex-pdftex
347 %endif
348 %if %{with static}
349 # Require static library only for static build
350 BuildRequires:  %{reqdb_pkg}-static >= %{reqdb_pkgver}
351 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
352 BuildRequires:  bzip2-static >= 1.0.2-17
353 BuildRequires:  elfutils-static
354 BuildRequires:  glibc-static >= 2.2.94
355 BuildRequires:  libmagic-static
356 %if %{with selinux}
357 BuildRequires:  libselinux-static >= 2.1.0
358 BuildRequires:  libsemanage-static >= 2.1.0
359 BuildRequires:  libsepol-static >= 2.1.0
360 %endif
361 BuildRequires:  popt-static >= %{reqpopt_ver}
362 BuildRequires:  zlib-static
363 %endif
364 Requires(posttrans):    coreutils
365 Requires:       %{name}-base = %{version}-%{release}
366 Requires:       %{name}-lib = %{version}-%{release}
367 Requires:       beecrypt >= %{beecrypt_ver}
368 Requires:       popt >= %{reqpopt_ver}
369 Provides:       rpm-db-ver = %{reqdb_ver}
370 Obsoletes:      rpm-getdeps
371 %{!?with_static:Obsoletes:      rpm-utils-static}
372 Conflicts:      glibc < 2.2.92
373 # db4.6 poldek needed
374 Conflicts:      poldek < 0.21-0.20070703.00.3
375 # segfaults with lzma 0.42.2
376 Conflicts:      lzma-libs < 4.999.3
377 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
378 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
379
380 %define         _binary_payload         w9.gzdio
381
382 # don't require very fresh rpm.macros to build
383 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
384 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
385 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
386 %define         ppc     ppc ppc7400 ppc7450
387 %define         x8664   amd64 ia32e x86_64
388
389 %define         _rpmlibdir /usr/lib/rpm
390 %define         _noautocompressdoc      RPM-GPG-KEY
391
392 %description
393 RPM is a powerful package manager, which can be used to build,
394 install, query, verify, update, and uninstall individual software
395 packages. A package consists of an archive of files, and package
396 information, including name, version, and description.
397
398 %description -l de.UTF-8
399 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
400 Installation, Anfrage, Verifizierung, Aktualisierung und
401 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
402 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
403 Beschreibung.
404
405 %description -l es.UTF-8
406 RPM es un poderoso administrador de paquetes, que puede ser usado para
407 construir, instalar, pesquisar, verificar, actualizar y desinstalar
408 paquetes individuales de software. Un paquete consiste en un
409 almacenaje de archivos, y información sobre el paquete, incluyendo
410 nombre, versión y descripción.
411
412 %description -l pl.UTF-8
413 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
414 przebudowanie, instalację czy weryfikację dowolnego pakietu.
415 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
416 plików wchodzących w skład pakietu, zależności od innych pakietów, są
417 przechowywane w bazie danych i można je uzyskać za pomocą opcji
418 odpytywania programu rpm.
419
420 %description -l pt_BR.UTF-8
421 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
422 construir, instalar, pesquisar, verificar, atualizar e desinstalar
423 pacotes individuais de software. Um pacote consiste de um conjunto de
424 arquivos e informações adicionais, incluindo nome, versão e descrição
425 do pacote, permissões dos arquivos, etc.
426
427 %description -l ru.UTF-8
428 RPM - это мощный менеджер пакетов, который может быть использован для
429 создания, инсталляции, запросов (query), проверки, обновления и
430 удаления программных пакетов. Пакет состоит из файлового архива и
431 служебной информации, включающей название, версию, описание и другие
432 данные о пакете.
433
434 %description -l uk.UTF-8
435 RPM - це потужний менеджер пакетів, що може бути використаний для
436 створення, інсталяції, запитів (query), перевірки, поновлення та
437 видалення програмних пакетів. Пакет складається з файлового архіву та
438 службової інформації, що містить назву, версію, опис та іншу
439 інформацію про пакет.
440
441 %package base
442 Summary:        RPM base package - scripts used by rpm packages themselves
443 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
444 Group:          Base
445 Requires:       filesystem
446 Obsoletes:      rpm-scripts
447 Obsoletes:      vserver-rpm
448
449 %description base
450 The RPM base package contains scripts used by rpm packages themselves.
451 These include:
452 - scripts for adding/removing groups and users needed for rpm
453   packages,
454 - banner.sh to display %%banner messages from rpm scriptlets.
455
456 %description base -l pl.UTF-8
457 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
458 Zawiera on:
459 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
460 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
461
462 %package lib
463 Summary:        RPMs library
464 Summary(pl.UTF-8):      Biblioteki RPM-a
465 Group:          Libraries
466 Requires:       %{reqdb_pkg} >= %{reqdb_pkgver}
467 %if %{with sqlite}
468 Requires:       sqlite3 >= %{sqlite_build_version}
469 %else
470 Requires:       %{reqdb_pkg}-sql >= %{reqdb_pkgver}
471 %endif
472 Requires:       beecrypt >= %{beecrypt_ver}
473 Requires:       libmagic >= 1.15-2
474 %{?with_selinux:Requires:       libselinux >= 2.1.0}
475 Requires:       popt >= %{reqpopt_ver}
476 Obsoletes:      rpm-libs
477 # avoid SEGV caused by mixed db versions
478 Conflicts:      poldek < 0.18.1-16
479
480 %description lib
481 RPMs library.
482
483 %description lib -l pl.UTF-8
484 Biblioteki RPM-a.
485
486 %package devel
487 Summary:        Header files for rpm libraries
488 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
489 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
490 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
491 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
492 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
493 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
494 Group:          Development/Libraries
495 Requires:       %{name}-lib = %{version}-%{release}
496 Requires:       %{reqdb_pkg}-devel >= %{reqdb_pkgver}
497 Requires:       beecrypt-devel >= %{beecrypt_ver}
498 Requires:       bzip2-devel
499 Requires:       elfutils-devel
500 %{?with_keyutils:Requires:      keyutils-devel}
501 Requires:       libmagic-devel
502 %if %{with selinux}
503 Requires:       libselinux-devel
504 Requires:       libsemanage-devel
505 Requires:       libsepol-devel
506 %endif
507 Requires:       popt-devel >= %{reqpopt_ver}
508 Requires:       zlib-devel
509
510 %description devel
511 The RPM packaging system includes C libraries that make it easy to
512 manipulate RPM packages and databases. They are intended to ease the
513 creation of graphical package managers and other tools that need
514 intimate knowledge of RPM packages. This package contains header files
515 for these libraries.
516
517 %description devel -l de.UTF-8
518 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
519 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
520 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
521 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
522
523 %description devel -l es.UTF-8
524 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
525 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
526 facilitar la creación de administradores gráficos de paquetes y otras
527 herramientas que necesiten un conocimiento profundo de paquetes RPM.
528
529 %description devel -l pl.UTF-8
530 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
531 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
532 graficznych programów zarządzających pakietami oraz innych narzędzi,
533 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
534 zawiera pliki nagłówkowe wspomnianych bibliotek.
535
536 %description devel -l pt_BR.UTF-8
537 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
538 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
539 facilitar a criação de gerenciadores gráficos de pacotes e outras
540 ferramentas que precisem de conhecimento profundo de pacotes RPM.
541
542 %description devel -l ru.UTF-8
543 Система управления пакетами RPM содержит библиотеку C, которая
544 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
545 Эта библиотека предназначена для облегчения создания графических
546 пакетных менеджеров и других утилит, которым необходимо работать с
547 пакетами RPM.
548
549 %description devel -l uk.UTF-8
550 Система керування пакетами RPM містить бібліотеку C, котра спрощує
551 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
552 призначена для полегшення створення графічних пакетних менеджерів та
553 інших утиліт, що працюють з пакетами RPM.
554
555 %package static
556 Summary:        RPM static libraries
557 Summary(de.UTF-8):      RPMs statische Libraries
558 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
559 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
560 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
561 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
562 Group:          Development/Libraries
563 Requires:       %{name}-devel = %{version}-%{release}
564 Requires:       %{reqdb_pkg}-static >= %{reqdb_pkgver}
565 Requires:       beecrypt-static >= %{beecrypt_ver}
566 Requires:       bzip2-static
567 Requires:       elfutils-static
568 %{?with_keyutils:Requires:      keyutils-static}
569 Requires:       libmagic-static
570 %if %{with selinux}
571 Requires:       libselinux-static
572 Requires:       libsemanage-static
573 Requires:       libsepol-static
574 %endif
575 Requires:       popt-static >= %{reqpopt_ver}
576 Requires:       zlib-static
577
578 %description static
579 RPM static libraries.
580
581 %description static -l de.UTF-8
582 RPMs statische Libraries.
583
584 %description static -l pl.UTF-8
585 Biblioteki statyczne RPM-a.
586
587 %description static -l pt_BR.UTF-8
588 Bibliotecas estáticas para desenvolvimento.
589
590 %description static -l ru.UTF-8
591 Система управления пакетами RPM содержит библиотеку C, которая
592 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
593 Это статическая библиотека RPM.
594
595 %description static -l uk.UTF-8
596 Система керування пакетами RPM містить бібліотеку C, котра спрощує
597 роботу з пакетами RPM та відповідними базами даних. Це статична
598 бібліотека RPM.
599
600 %package utils
601 Summary:        Additional utilities for managing RPM packages and database
602 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
603 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
604 Group:          Applications/File
605 Requires:       %{name} = %{version}-%{release}
606 Requires:       popt >= %{reqpopt_ver}
607 %if %{with suggest_tags}
608 Suggests:       bzip2
609 Suggests:       gzip
610 %endif
611 Conflicts:      filesystem-debuginfo < 3.0-16
612
613 %description utils
614 Additional utilities for managing RPM packages and database.
615
616 %description utils -l de.UTF-8
617 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
618
619 %description utils -l pl.UTF-8
620 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
621
622 %package utils-perl
623 Summary:        Additional utilities for managing RPM packages and database
624 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
625 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
626 Group:          Applications/File
627 Requires:       %{name}-utils = %{version}-%{release}
628 Requires:       popt >= %{reqpopt_ver}
629
630 %description utils-perl
631 Additional utilities for managing RPM packages and database.
632
633 %description utils-perl -l de.UTF-8
634 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
635
636 %description utils-perl -l pl.UTF-8
637 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
638
639 %package utils-static
640 Summary:        Static rpm utilities
641 Summary(pl.UTF-8):      Statyczne narzędzia rpm
642 Group:          Applications/System
643 Requires:       %{name} = %{version}-%{release}
644
645 %description utils-static
646 Static rpm utilities for repairing system in case something with
647 shared libraries used by rpm become broken. Currently it contains rpmi
648 binary, which can be used to install/upgrade/remove packages without
649 using shared libraries (well, in fact with exception of NSS modules).
650
651 %description utils-static -l pl.UTF-8
652 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
653 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
654 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
655 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
656 (z wyjątkiem modułów NSS).
657
658 %package build
659 Summary:        Scripts for building binary RPM packages
660 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
661 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
662 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
663 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
664 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
665 Group:          Applications/File
666 Requires(pretrans):     coreutils
667 Requires(pretrans):     findutils
668 Requires:       %{name}-build-macros >= 1.712
669 Requires:       %{name}-utils = %{version}-%{release}
670 Requires:       /bin/id
671 Requires:       awk
672 Requires:       bzip2
673 Requires:       chrpath >= 0.10-4
674 Requires:       cpio
675 Requires:       diffutils
676 Requires:       elfutils
677 Requires:       file >= 4.17
678 Requires:       fileutils
679 Requires:       findutils
680 %ifarch athlon
681 Requires:       gcc >= 3.0.3
682 %else
683 Requires:       gcc
684 %endif
685 Requires:       glibc-devel
686 Requires:       grep
687 Requires:       gzip
688 Requires:       make
689 Requires:       patch
690 Requires:       sed >= 4.0
691 Requires:       sh-utils
692 Requires:       tar >= 1:1.22
693 Requires:       textutils
694 Requires:       which
695 Requires:       xz
696 Provides:       rpmbuild(monoautodeps)
697 Provides:       rpmbuild(noauto) = 3
698 %ifarch %{x8664}
699 Conflicts:      automake < 1:1.7.9-2
700 Conflicts:      libtool < 2:1.5-13
701 %endif
702
703 %description build
704 Scripts for building binary RPM packages.
705
706 %description build -l de.UTF-8
707 Scripts fürs Bauen binärer RPM-Pakete.
708
709 %description build -l pl.UTF-8
710 Skrypty pomocnicze do budowania binarnych RPM-ów.
711
712 %description build -l pt_BR.UTF-8
713 Este pacote contém scripts e programas executáveis que são usados para
714 construir pacotes usando o RPM.
715
716 %description build -l ru.UTF-8
717 Различные вспомогательные скрипты и исполняемые программы, которые
718 используются для сборки RPM'ов.
719
720 %description build -l uk.UTF-8
721 Різноманітні допоміжні скрипти та утиліти, які використовуються для
722 побудови RPM'ів.
723
724 %package javaprov
725 Summary:        Additional utilities for checking Java provides/requires in RPM packages
726 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
727 Group:          Applications/File
728 Requires:       %{name} = %{version}-%{release}
729 Requires:       file
730 Requires:       findutils >= 1:4.2.26
731 Requires:       mktemp
732 Requires:       unzip
733
734 %description javaprov
735 Additional utilities for checking Java provides/requires in RPM
736 packages.
737
738 %description javaprov -l pl.UTF-8
739 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
740 RPM.
741
742 %package perlprov
743 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
744 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
745 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
746 Group:          Applications/File
747 Requires:       %{name} = %{version}-%{release}
748 Requires:       perl-Encode
749 Requires:       perl-devel
750 Requires:       perl-modules
751
752 %description perlprov
753 Additional utilities for checking Perl provides/requires in RPM
754 packages.
755
756 %description perlprov -l de.UTF-8
757 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
758
759 %description perlprov -l pl.UTF-8
760 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
761 pakietach RPM.
762
763 %package pythonprov
764 Summary:        Python macros, which simplifies creation of RPM packages with Python software
765 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
766 Group:          Applications/File
767 Requires:       %{name} = %{version}-%{release}
768 Requires:       python
769 Requires:       python-setuptools
770 Requires:       python-modules
771
772 %description pythonprov
773 Python macros, which simplifies creation of RPM packages with Python
774 software.
775
776 %description pythonprov -l pl.UTF-8
777 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
778 Pythonie.
779
780 %package php-pearprov
781 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
782 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
783 Group:          Applications/File
784 Requires:       %{name} = %{version}-%{release}
785 Requires:       sed >= 4.0
786 Suggests:       php-pear-PHP_CompatInfo
787
788 %description php-pearprov
789 Additional utilities for checking PHP PEAR provides/requires in RPM
790 packages.
791
792 %description php-pearprov -l pl.UTF-8
793 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
794 pakietach RPM.
795
796 %package rubyprov
797 Summary:        Ruby tools, which simplify creation of RPM packages with Ruby software
798 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
799 Group:          Applications/File
800 Requires:       %{name} = %{version}-%{release}
801 Requires:       ruby
802 Requires:       ruby-modules
803 Requires:       ruby-rubygems
804
805 %description rubyprov
806 Ruby tools, which simplifies creation of RPM packages with Ruby
807 software.
808
809 %description rubyprov -l pl.UTF-8
810 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
811 Ruby.
812
813 %package -n python-rpm
814 Summary:        Python interface to RPM library
815 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
816 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
817 Group:          Development/Languages/Python
818 Requires:       %{name} = %{version}-%{release}
819 Requires:       python
820 Obsoletes:      rpm-python
821
822 %description -n python-rpm
823 The rpm-python package contains a module which permits applications
824 written in the Python programming language to use the interface
825 supplied by RPM (RPM Package Manager) libraries.
826
827 This package should be installed if you want to develop Python
828 programs that will manipulate RPM packages and databases.
829
830 %description -n python-rpm -l pl.UTF-8
831 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
832 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
833
834 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
835 Pythonie programy manipulujące pakietami i bazami danych rpm.
836
837 %description -n python-rpm -l pt_BR.UTF-8
838 O pacote rpm-python contém um módulo que permite que aplicações
839 escritas em Python utilizem a interface fornecida pelas bibliotecas
840 RPM (RPM Package Manager).
841
842 Esse pacote deve ser instalado se você quiser desenvolver programas em
843 Python para manipular pacotes e bancos de dados RPM.
844
845 %package apidocs
846 Summary:        RPM API documentation and guides
847 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
848 Group:          Documentation
849 %if "%{_rpmversion}" >= "5"
850 BuildArch:      noarch
851 %endif
852
853 %description apidocs
854 Documentation for RPM API and guides in HTML format generated from rpm
855 sources by doxygen.
856
857 %description apidocs -l pl.UTF-8
858 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
859 źrodeł RPM-a przez doxygen.
860
861 %prep
862 %setup -q -n %{name}-%{version}%{?subver}
863 install -d platform
864 cd platform
865 ar x %{SOURCE100}
866 cd -
867
868 #patch0 -p1
869 %patch1 -p1
870 %patch2 -p1
871 %patch3 -p1
872 %patch4 -p1
873 %patch5 -p1
874 %patch6 -p1
875 %patch7 -p1
876 %patch8 -p1
877 %{?with_system_lua:%patch9 -p1}
878 %patch10 -p1
879 %ifnarch i386 i486
880 # enable TSC for capable archs
881 %patch11 -p1
882 %endif
883 %patch12 -p1
884 %patch13 -p1
885 %patch14 -p0
886 %patch15 -p1
887 %patch16 -p1
888 %patch17 -p1
889 %patch18 -p1
890 %patch19 -p1
891 %patch20 -p1
892 %patch21 -p1
893 %ifarch sparc64
894 %patch22 -p1
895 %endif
896 %patch23 -p1
897 %patch24 -p1
898 %patch25 -p1
899 %patch26 -p1
900 %patch27 -p1
901 %patch28 -p1
902 %patch29 -p1
903 %patch30 -p1
904 %patch31 -p1
905 %patch32 -p1
906 %patch33 -p1
907 %patch34 -p1
908 %patch35 -p1
909 %patch36 -p1
910 %patch37 -p1
911 %patch38 -p1
912 %patch39 -p1
913 %patch40 -p1
914 %{?with_db61:%patch41 -p1}
915 %patch42 -p1
916 %patch43 -p1
917 %patch44 -p1
918 %patch45 -p1
919 %patch46 -p1
920 %patch47 -p1
921 %patch48 -p1
922 %patch49 -p1
923 %patch50 -p1
924 %patch51 -p1
925 %patch52 -p0
926 %patch53 -p1
927 %patch54 -p1
928 %patch55 -p1
929 %patch56 -p1
930 %{!?with_db61:%patch57 -p1}
931 %patch58 -p1
932 %patch59 -p1
933 %patch60 -p1
934 %patch61 -p1
935 %patch62 -p1
936 %patch63 -p1
937 %patch64 -p1
938 %patch65 -p1
939 %patch66 -p1
940 %patch67 -p1
941 %patch70 -p1
942 %patch71 -p1
943 %patch72 -p1
944 %patch74 -p1
945 %patch75 -p1
946 %patch77 -p0
947 %patch78 -p1
948 %patch79 -p1
949 %patch80 -p1
950 %patch81 -p0
951 %patch82 -p1
952 %patch84 -p1
953 %patch85 -p1
954 %patch86 -p1
955 %patch87 -p1
956 %patch88 -p1
957 %patch89 -p1
958 %patch90 -p1
959 %patch91 -p1
960
961 %patch1000 -p1
962 %patch1001 -p1
963 %patch1002 -p1
964 %patch1003 -p1
965 %patch1004 -p1
966 %patch1005 -p1
967 %patch1006 -p1
968 %patch1007 -p1
969 %patch1008 -p1
970 %patch1009 -p1
971 %patch1010 -p1
972 %patch1011 -p1
973 %patch1012 -p1
974 %patch1013 -p1
975 %patch1014 -p1
976 %patch1015 -p1
977 %patch1016 -p1
978 %patch1017 -p1
979 %patch1019 -p1
980 %patch1020 -p1
981 %patch1021 -p1
982 %patch1022 -p1
983 %patch1024 -p1
984 %patch1026 -p1
985 %patch1027 -p1
986 %patch1028 -p1
987 %patch1029 -p1
988 %patch1030 -p1
989 %patch1031 -p1
990 %patch1032 -p1
991 %patch1033 -p1
992 %patch1034 -p1
993 %patch1035 -p1
994 %patch1037 -p1
995 %patch1038 -p1
996 %patch1039 -p1
997 %patch1040 -p1
998 # don't delete, may be usefull if jbj descides to enable this again
999 #%patch1041 -p1
1000 %patch1042 -p1
1001 %patch1043 -p1
1002 %patch1044 -p1
1003 %patch1045 -p1
1004 %patch1046 -p1
1005 %patch1047 -p1
1006 %patch1048 -p1
1007 %patch1049 -p1
1008
1009 %patch83 -p1
1010 %patch92 -p1
1011 %patch93 -p1
1012 %patch94 -p1
1013 %patch95 -p1
1014 %patch96 -p1
1015
1016 %patch1050 -p1
1017
1018 install %{SOURCE2} macros/pld.in
1019 install %{SOURCE8} scripts/php.prov.in
1020 install %{SOURCE9} scripts/php.req.in
1021 install %{SOURCE11} scripts/perl.prov.in
1022 cp -p %{SOURCE30} scripts/rubygems.rb
1023 cp -p %{SOURCE31} scripts/gem_helper.rb
1024
1025 rm scripts/find-php*
1026
1027 %{__mv} -f scripts/perl.req{,.in}
1028
1029 # generate Group translations to *.po
1030 awk -f %{SOURCE6} %{SOURCE1}
1031
1032 install %{SOURCE26} tools/rpmdb_checkversion.c
1033 install %{SOURCE28} tools/rpmdb_reset.c
1034
1035 for extlib in beecrypt neon %{?with_system_pcre:pcre} popt; do
1036         [ -d $extlib ] && %{__rm} -r $extlib
1037 done
1038
1039 %build
1040 %{__libtoolize}
1041 #%{__autopoint}
1042 %{__aclocal}
1043 %{__autoheader}
1044 %{__autoconf}
1045 %{__automake}
1046
1047 # rpm checks for CPU type at runtime, but it looks better
1048 sed -i \
1049         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
1050         -e 's|@host_cpu@|%{_target_cpu}|' \
1051         -e 's|@host_os@|%{_target_os}|' \
1052         macros/macros.in
1053
1054 %{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
1055 %configure \
1056         WITH_PERL_VERSION=no \
1057         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
1058         --disable-silent-rules \
1059         --enable-shared \
1060         --enable-static \
1061         %{!?with_apidocs:--without-apidocs} \
1062         --with-beecrypt=external \
1063         --with-bugreport="http://bugs.pld-linux.org/" \
1064         --with-bzip2=external \
1065         --with-db=external \
1066         --with-dbapi=db \
1067         --with-file=external \
1068         --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
1069         --with-libelf \
1070         --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
1071         --with-lzma=external \
1072         --with-neon=%{?with_neon:external}%{!?with_neon:no} \
1073         --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/%%{_target}/macros:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
1074         --without-path-versioned \
1075         --with-pcre=%{!?with_system_pcre:internal}%{?with_system_pcre:external} \
1076         --with-popt=external \
1077         %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
1078         %{!?with_python:--without-python} \
1079         --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
1080         --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
1081         --with-sepol=%{!?with_selinux:no}%{?with_selinux:external} \
1082         --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
1083         --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
1084         --with-vendor=pld \
1085         --with-xz=external \
1086         --with-zlib=external
1087
1088 %{__make} -j1
1089
1090 %{?with_apidocs:%{__make} apidocs}
1091
1092 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
1093         -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
1094 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
1095         -o tools/rpmdb_reset -ldb-%{reqdb_ver}
1096
1097 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
1098         echo "Error linking rpmdb tools!"
1099         exit 1
1100 fi
1101 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
1102         echo "Error linking rpmdb tools!"
1103         exit 1
1104 fi
1105
1106 %install
1107 rm -rf $RPM_BUILD_ROOT
1108 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
1109         $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
1110
1111 install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1112
1113 %{__make} -j1 install \
1114         pkgconfigdir=%{_pkgconfigdir} \
1115         DESTDIR=$RPM_BUILD_ROOT
1116
1117 # install platform macros
1118 for f in platform/*macros; do
1119         bn=${f#*/}
1120         fn=${bn%.macros}/macros
1121         install -m644 $f -D %{buildroot}%{_rpmlibdir}/$fn
1122 done
1123
1124 # cleanup
1125 %ifnarch %{ix86} %{x8664} x32
1126 rm $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
1127 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
1128 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
1129 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
1130 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
1131 rm $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
1132 rm $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
1133 %endif
1134
1135 %ifnarch %{x8664} x32
1136 rm $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
1137 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
1138 rm $RPM_BUILD_ROOT%{_rpmlibdir}/x32-linux/macros
1139 rm $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
1140 %endif
1141
1142 %ifnarch %{ppc}
1143 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
1144 %endif
1145
1146 rm $RPM_BUILD_ROOT%{_rpmlibdir}/alpha*-linux/macros
1147 rm $RPM_BUILD_ROOT%{_rpmlibdir}/arm*-linux/macros
1148 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ia64-linux/macros
1149 rm $RPM_BUILD_ROOT%{_rpmlibdir}/k6-linux/macros
1150 rm $RPM_BUILD_ROOT%{_rpmlibdir}/mips*-linux/macros
1151 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc*series-linux/macros
1152 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc64*-linux/macros
1153 rm $RPM_BUILD_ROOT%{_rpmlibdir}/s390*-linux/macros
1154 rm $RPM_BUILD_ROOT%{_rpmlibdir}/sparc*-linux/macros
1155
1156 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
1157 # first platform file entry can't contain regexps
1158 %ifarch x32
1159 %{_target_cpu}-%{_target_vendor}-linux-gnux32
1160 %else
1161 %{_target_cpu}-%{_target_vendor}-linux
1162 %endif
1163
1164 %ifarch x86_64
1165 x86_64-[^-]*-[Ll]inux(-gnu)?
1166 amd64-[^-]*-[Ll]inux(-gnu)?
1167 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
1168 %endif
1169 %ifarch amd64
1170 amd64-[^-]*-[Ll]inux(-gnu)?
1171 x86_64-[^-]*-[Ll]inux(-gnu)?
1172 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
1173 %endif
1174 %ifarch ia32e
1175 ia32e-[^-]*-[Ll]inux(-gnu)?
1176 x86_64-[^-]*-[Ll]inux(-gnu)?
1177 %endif
1178 %ifarch x32
1179 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
1180 x86_64-[^-]*-[Ll]inux(-gnu)?
1181 amd64-[^-]*-[Ll]inux(-gnu)?
1182 %endif
1183
1184 %ifarch athlon %{x8664} x32
1185 athlon-[^-]*-[Ll]inux(-gnu)?
1186 %endif
1187 %ifarch pentium4 athlon %{x8664} x32
1188 pentium4-[^-]*-[Ll]inux(-gnu)?
1189 %endif
1190 %ifarch pentium3 pentium4 athlon %{x8664} x32
1191 pentium3-[^-]*-[Ll]inux(-gnu)?
1192 %endif
1193 %ifarch i686 pentium3 pentium4 athlon %{x8664} x32
1194 i686-[^-]*-[Ll]inux(-gnu)?
1195 %endif
1196 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664} x32
1197 i586-[^-]*-[Ll]inux(-gnu)?
1198 %endif
1199 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664} x32
1200 i486-[^-]*-[Ll]inux(-gnu)?
1201 %endif
1202 %ifarch %{ix86} %{x8664} x32
1203 i386-[^-]*-[Ll]inux(-gnu)?
1204 %endif
1205
1206 %ifarch alpha
1207 alpha-[^-]*-[Ll]inux(-gnu)?
1208 %endif
1209
1210 %ifarch ia64
1211 ia64-[^-]*-[Ll]inux(-gnu)?
1212 %endif
1213
1214 %ifarch ppc64
1215 powerpc64-[^-]*-[Ll]inux(-gnu)?
1216 ppc64-[^-]*-[Ll]inux(-gnu)?
1217 %endif
1218 %ifarch %{ppc} ppc64
1219 powerpc-[^-]*-[Ll]inux(-gnu)?
1220 ppc-[^-]*-[Ll]inux(-gnu)?
1221 %endif
1222
1223 %ifarch s390x
1224 s390x-[^-]*-[Ll]inux(-gnu)?
1225 %endif
1226 %ifarch s390 s390x
1227 s390-[^-]*-[Ll]inux(-gnu)?
1228 %endif
1229
1230 %ifarch sparc64
1231 sparc64-[^-]*-[Ll]inux(-gnu)?
1232 sparcv8-[^-]*-[Ll]inux(-gnu)?
1233 sparcv9-[^-]*-[Ll]inux(-gnu)?
1234 %endif
1235 %ifarch sparcv9
1236 sparcv8-[^-]*-[Ll]inux(-gnu)?
1237 sparcv9-[^-]*-[Ll]inux(-gnu)?
1238 %endif
1239 %ifarch sparc sparcv9 sparc64
1240 sparc-[^-]*-[Ll]inux(-gnu)?
1241 %endif
1242
1243 noarch-[^-]*-.*
1244 EOF
1245
1246 # Squash Extra Blank Lines
1247 %{__sed} -i -e '/./,/^$/!d' $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
1248
1249 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1250 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1251 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
1252 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
1253 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.a
1254 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.la
1255 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-provides
1256 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-requires
1257
1258 # not installed since 4.4.8 (-tools-perl subpackage)
1259 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1260
1261 install %{SOURCE1} doc/manual/groups
1262 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
1263 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1264 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
1265 install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1266 install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
1267 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
1268 cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
1269 install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
1270 install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
1271 install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
1272
1273 install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
1274
1275 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1276
1277 install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
1278 install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
1279 install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1280 install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1281 install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1282 install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
1283 install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
1284
1285 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1286 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
1287 install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
1288 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1289 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1290 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
1291
1292 install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1293 install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1294 install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
1295
1296 # create macro loading wrappers for backward compatibility
1297 for m in gstreamer java mono perl php python; do
1298         echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
1299 done
1300
1301 # moved to rpm-build-macros 1.699
1302 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/macros.d/kernel
1303
1304 # for rpm -e|-U --repackage
1305 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1306 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
1307
1308 # move rpm to /bin
1309 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1310 # move essential libs to /lib (libs that /bin/rpm links to)
1311 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
1312         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1313         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
1314 done
1315
1316 # Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1317 mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1318
1319 %if %{with python}
1320 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1321 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
1322
1323 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
1324 %endif
1325
1326 # wrong location, not used anyway
1327 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
1328 # utils dropped in 5.4 -- their manuals
1329 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
1330 # script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1331 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
1332
1333 %find_lang %{name}
1334
1335 %{__rm} -rf manual
1336 cp -a doc/manual manual
1337 %{__rm} -f manual/Makefile*
1338
1339 %clean
1340 rm -rf $RPM_BUILD_ROOT
1341
1342 %pretrans
1343 # this needs to be a dir
1344 if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
1345         umask 022
1346         mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1347         mkdir %{_sysconfdir}/rpm/sysinfo
1348 fi
1349
1350 %posttrans
1351 if [ -e /var/lib/rpm/Packages ] && \
1352                 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
1353         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
1354                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
1355                 echo
1356                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
1357                 echo
1358         fi
1359         echo
1360         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
1361         echo 'you should ignore it and restart poldek'
1362         echo
1363         %{_rpmlibdir}/bin/dbupgrade.sh
1364 fi
1365
1366 %triggerpostun -- %{name} < 4.4.9-44
1367 %{_rpmlibdir}/hrmib-cache
1368
1369 %post   lib -p /sbin/ldconfig
1370 %postun lib -p /sbin/ldconfig
1371
1372 %pretrans build
1373 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
1374
1375 %files -f %{name}.lang
1376 %defattr(644,root,root,755)
1377 %doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
1378
1379 %dir /etc/pki/rpm-gpg
1380 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1381
1382 %attr(755,root,root) /bin/rpm
1383
1384 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
1385 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
1386 %dir %{_sysconfdir}/rpm/sysinfo
1387 # these are ok to be replaced
1388 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
1389 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1390
1391 %{_mandir}/man8/rpm.8*
1392 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1393 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1394 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1395 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1396 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1397
1398 %dir /var/lib/rpm
1399 %dir /var/lib/rpm/log
1400 %dir /var/lib/rpm/tmp
1401 %config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
1402 %dir %attr(700,root,root) /var/spool/repackage
1403 %dir /var/lock/rpm
1404 /var/lock/rpm/transaction
1405
1406 # exported package NVRA (stamped with install tid)
1407 # net-snmp hrSWInstalledName queries, bash-completions
1408 %dir /var/cache/hrmib
1409
1410 %{_rpmlibdir}/qf
1411 %{_rpmlibdir}/rpmpopt*
1412 %{_rpmlibdir}/macros
1413 %dir %{_rpmlibdir}/macros.d
1414 %{_rpmlibdir}/macros.d/pld
1415 %{_rpmlibdir}/cpuinfo.yaml
1416 %{_rpmlibdir}/noarch-*
1417 %ifarch %{ix86} %{x8664} x32
1418 %{_rpmlibdir}/i?86*
1419 %{_rpmlibdir}/pentium*
1420 %{_rpmlibdir}/athlon*
1421 %endif
1422 %ifarch alpha
1423 %{_rpmlibdir}/alpha*
1424 %endif
1425 %ifarch ia64
1426 %{_rpmlibdir}/ia64*
1427 %endif
1428 %ifarch mips mipsel mips64 mips64el
1429 %{_rpmlibdir}/mips*
1430 %endif
1431 %ifarch %{ppc}
1432 %{_rpmlibdir}/ppc*
1433 %endif
1434 %ifarch sparc sparc64
1435 %{_rpmlibdir}/sparc*
1436 %endif
1437 %ifarch %{x8664} x32
1438 %{_rpmlibdir}/amd64*
1439 %{_rpmlibdir}/ia32e*
1440 %{_rpmlibdir}/x86_64*
1441 %{_rpmlibdir}/x32*
1442 %endif
1443
1444 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1445
1446 %dir %{_rpmlibdir}/bin
1447 %attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
1448 %attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
1449 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
1450 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
1451 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdbchk
1452
1453 %files base
1454 %defattr(644,root,root,755)
1455 %dir %{_sysconfdir}/rpm
1456 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1457 %dir %{_rpmlibdir}
1458 %attr(755,root,root) %{_bindir}/banner.sh
1459 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1460 %dir /var/lib/banner
1461
1462 %files lib
1463 %defattr(644,root,root,755)
1464 %attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1465 %attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1466 %attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1467 %attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
1468 %attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
1469 %attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
1470
1471 %files devel
1472 %defattr(644,root,root,755)
1473 %attr(755,root,root) %{_libdir}/librpm.so
1474 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1475 %attr(755,root,root) %{_libdir}/librpmbuild.so
1476 %attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
1477 %attr(755,root,root) %{_libdir}/librpmconstant.so
1478 %attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
1479 %attr(755,root,root) %{_libdir}/librpmdb.so
1480 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1481 %attr(755,root,root) %{_libdir}/librpmio.so
1482 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1483 %attr(755,root,root) %{_libdir}/librpmmisc.so
1484 %attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
1485 %{_libdir}/librpm*.la
1486 %{_includedir}/rpm
1487 %{_pkgconfigdir}/*.pc
1488
1489 %files static
1490 %defattr(644,root,root,755)
1491 %{_libdir}/librpm*.a
1492
1493 %files utils
1494 %defattr(644,root,root,755)
1495 %attr(755,root,root) %{_bindir}/rpm2cpio
1496 %attr(755,root,root) %{_bindir}/rpmconstant
1497 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1498 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1499 %attr(755,root,root) %{_rpmlibdir}/tgpg
1500 %attr(755,root,root) %{_rpmlibdir}/bin/chroot
1501 %attr(755,root,root) %{_rpmlibdir}/bin/cp
1502 %attr(755,root,root) %{_rpmlibdir}/bin/debugedit
1503 %attr(755,root,root) %{_rpmlibdir}/bin/find
1504 %attr(755,root,root) %{_rpmlibdir}/bin/mgo
1505 %attr(755,root,root) %{_rpmlibdir}/bin/mtree
1506 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1507 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1508 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1509 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
1510 %if %{with selinux}
1511 %attr(755,root,root) %{_rpmlibdir}/bin/semodule
1512 %attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1513 %endif
1514 %if %{without system_lua}
1515 %attr(755,root,root) %{_rpmlibdir}/bin/lua
1516 %attr(755,root,root) %{_rpmlibdir}/bin/luac
1517 %attr(755,root,root) %{_rpmlibdir}/bin/rpmlua
1518 %attr(755,root,root) %{_rpmlibdir}/bin/rpmluac
1519 %endif
1520 %{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
1521 %attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
1522 %{_mandir}/man8/rpm2cpio.8*
1523 %{_mandir}/man8/rpmconstant.8*
1524 %{_mandir}/man8/rpmdeps.8*
1525 %{_mandir}/man8/rpmmtree.8*
1526 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1527 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1528 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1529 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1530
1531 %files utils-perl
1532 %defattr(644,root,root,755)
1533 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1534
1535 %if %{with static}
1536 %files utils-static
1537 %defattr(644,root,root,755)
1538 %attr(755,root,root) %{_bindir}/rpm[ieu]
1539 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1540 %endif
1541
1542 %files build
1543 %defattr(644,root,root,755)
1544 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1545 %attr(755,root,root) %{_rpmlibdir}/brp-*
1546 %attr(755,root,root) %{_rpmlibdir}/check-files
1547 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1548 %attr(755,root,root) %{_rpmlibdir}/cross-build
1549 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1550 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1551 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1552 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1553 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1554 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1555 %attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
1556 # needs hacked pkg-config to return anything
1557 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1558 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1559 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
1560 %{!?with_sqlite:%attr(755,root,root) %{_rpmlibdir}/bin/dbsql}
1561 %attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1562 %attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
1563 %attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1564 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspec
1565 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1566 %attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1567 %attr(755,root,root) %{_rpmlibdir}/bin/wget
1568 %attr(755,root,root) %{_rpmlibdir}/vcheck
1569 # not used yet ... these six depend on perl
1570 %attr(755,root,root) %{_rpmlibdir}/http.req
1571 # we always used scripts provided by mono-devel, maybe move them here
1572 #%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1573 #%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
1574
1575 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
1576 # must be here for "Requires: rpm-*prov" to work
1577 %{_rpmlibdir}/macros.d/cmake
1578 %{_rpmlibdir}/macros.d/gstreamer
1579 %{_rpmlibdir}/macros.d/java
1580 %{_rpmlibdir}/macros.d/libtool
1581 %{_rpmlibdir}/macros.d/mono
1582 %{_rpmlibdir}/macros.d/perl
1583 %{_rpmlibdir}/macros.d/php
1584 %{_rpmlibdir}/macros.d/pkgconfig
1585 %{_rpmlibdir}/macros.d/python
1586 %{_rpmlibdir}/macros.d/ruby
1587 %{_rpmlibdir}/macros.d/selinux
1588 %{_rpmlibdir}/macros.d/tcl
1589 %{_rpmlibdir}/macros.rpmbuild
1590 # compat wrappers
1591 %{_rpmlibdir}/macros.gstreamer
1592 %{_rpmlibdir}/macros.java
1593 %{_rpmlibdir}/macros.mono
1594 %{_rpmlibdir}/macros.perl
1595 %{_rpmlibdir}/macros.php
1596 %{_rpmlibdir}/macros.python
1597
1598 %attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1599 %attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1600
1601 %attr(755,root,root) %{_bindir}/gendiff
1602 %attr(755,root,root) %{_bindir}/rpmbuild
1603
1604 %dir %{_rpmlibdir}/helpers
1605 %attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
1606
1607 %{_mandir}/man1/gendiff.1*
1608 %{_mandir}/man8/rpmbuild.8*
1609 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1610 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1611 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1612
1613 %files javaprov
1614 %defattr(644,root,root,755)
1615 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1616 # needs jar (any jdk), jcf-dump (gcc-java) to work
1617 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1618
1619 %files rubyprov
1620 %defattr(644,root,root,755)
1621 %attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1622 %attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1623
1624 %files perlprov
1625 %defattr(644,root,root,755)
1626 %attr(755,root,root) %{_rpmlibdir}/perl.*
1627 %attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1628 %attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1629
1630 %files pythonprov
1631 %defattr(644,root,root,755)
1632 %attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
1633 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1634
1635 %files php-pearprov
1636 %defattr(644,root,root,755)
1637 %attr(755,root,root) %{_rpmlibdir}/php.prov
1638 %attr(755,root,root) %{_rpmlibdir}/php.req
1639 %attr(755,root,root) %{_rpmlibdir}/php.req.php
1640
1641 %if %{with python}
1642 %files -n python-rpm
1643 %defattr(644,root,root,755)
1644 %dir %{py_sitedir}/rpm
1645 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1646 %{py_sitedir}/rpm/*.py[co]
1647 %endif
1648
1649 %if %{with apidocs}
1650 %files apidocs
1651 %defattr(644,root,root,755)
1652 %doc apidocs
1653 %endif
This page took 0.282052 seconds and 3 git commands to generate.