fix pythondist provides for noarch packages
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
4 #
5 # Conditional build:
6 %bcond_without  apidocs         # don't generate documentation with doxygen
7 %bcond_without  python3         # don't build python bindings
8 %bcond_without  plugins         # build plugins
9 %bcond_without  recommends_tags # build without Recommends tag (bootstrapping)
10 %bcond_with     imaevm          # build with IMA/EVM support (requires libimaevm from ima-evm-utils)
11
12 %define         db_ver          5.3.28.0
13 %define         popt_ver        1.15
14 %define         sover           9.1.0
15
16 %if "%{_rpmversion}" >= "4.12" && "%{_rpmversion}" < "5"
17 %define with_recommends_tags    1
18 %endif
19
20 Summary:        RPM Package Manager
21 Summary(de.UTF-8):      RPM Packet-Manager
22 Summary(es.UTF-8):      Gestor de paquetes RPM
23 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
24 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
25 Summary(ru.UTF-8):      Менеджер пакетов от RPM
26 Summary(uk.UTF-8):      Менеджер пакетів від RPM
27 Name:           rpm
28 Version:        4.16.0
29 Release:        0.10
30 Epoch:          1
31 License:        GPL v2 / LGPL v2.1
32 Group:          Base
33 Source0:        http://ftp.rpm.org/releases/rpm-4.16.x/%{name}-%{version}.tar.bz2
34 # Source0-md5:  434e166a812e35ef181f6dd176326920
35 Source1:        ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
36 # Source1-md5:  23914bb49fafe7153cee87126d966461
37 Source2:        macros.local
38 Source3:        macros.lang
39 Source4:        %{name}.sysconfig
40 Source5:        %{name}.groups
41 Source6:        %{name}-groups-po.awk
42 Source7:        %{name}-install-tree
43 Source9:        %{name}-user_group.sh
44 # http://svn.pld-linux.org/banner.sh/
45 Source10:       banner.sh
46 Source11:       %{name}.noautoprov
47 Source12:       %{name}.noautoprovfiles
48 Source13:       %{name}.noautoreq
49 Source14:       %{name}.noautoreqfiles
50 Source15:       perl.prov
51 Source16:       %{name}db_checkversion.c
52 Source17:       %{name}db_reset.c
53 Source18:       dbupgrade.sh
54 Patch0:         %{name}-man_pl.patch
55 Patch1:         %{name}-popt-aliases.patch
56 Patch2:         %{name}-perl-macros.patch
57 Patch3:         %{name}-perl-req-perlfile.patch
58 Patch4:         %{name}-scripts-closefds.patch
59 Patch6:         %{name}-perl_req-INC_dirs.patch
60 Patch7:         %{name}-debuginfo.patch
61 Patch8:         %{name}-libtool-deps.patch
62 Patch9:         %{name}-builddir-readlink.patch
63 Patch10:        %{name}-changelog_order_check_nonfatal.patch
64 Patch11:        %{name}-postun-nofail.patch
65 Patch12:        %{name}-clean-docdir.patch
66 Patch13:        %{name}-perl-magic.patch
67 Patch14:        %{name}-ignore-missing-macro-files.patch
68 Patch15:        x32.patch
69 Patch16:        rpm5-db-compat.patch
70 Patch17:        python-internal-build.patch
71 Patch18:        missing-macros.patch
72 Patch19:        pkgconfig.patch
73 Patch20:        uname-deps.patch
74 Patch21:        aarch64.patch
75 Patch22:        ix86-platforms.patch
76 Patch23:        shortcircuited-deps.patch
77 Patch24:        cpuinfo-deps.patch
78 Patch25:        rpmio-read-proc-files.patch
79 Patch26:        allow-at-in-ver-rel.patch
80 Patch27:        no-exeonly-for-elf-reqprov.patch
81 Patch28:        default-patch-flags.patch
82 Patch29:        %{name}-noarch_py_prov.patch
83 URL:            https://rpm.org/
84 BuildRequires:  acl-devel
85 BuildRequires:  db-devel >= %{db_ver}
86 BuildRequires:  autoconf >= 2.63
87 BuildRequires:  automake >= 1.4
88 BuildRequires:  bzip2-devel >= 1.0.2-17
89 BuildRequires:  elfutils-devel >= 0.108
90 BuildRequires:  gettext-tools >= 0.19.2
91 BuildRequires:  libarchive-devel
92 BuildRequires:  libcap-devel
93 BuildRequires:  libmagic-devel
94 BuildRequires:  libgcrypt-devel
95 %if %{with plugins}
96 BuildRequires:  audit-libs-devel
97 BuildRequires:  dbus-devel
98 %{?with_imaevm:BuildRequires:   libimaevm-devel >= 1.0}
99 BuildRequires:  libselinux-devel >= 2.1.0
100 %endif
101 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
102 BuildRequires:  libstdc++-devel
103 BuildRequires:  libtool >= 1:1.4.2-9
104 BuildRequires:  ossp-uuid-devel
105 BuildRequires:  patch >= 2.2
106 BuildRequires:  pkgconfig(lua) >= 5.1
107 BuildRequires:  popt-devel >= %{popt_ver}
108 BuildRequires:  python3-modules
109 %if %{with python3}
110 BuildRequires:  python3-devel
111 BuildRequires:  rpm-pythonprov
112 BuildRequires:  rpmbuild(macros) >= 1.750
113 %endif
114 BuildRequires:  sqlite3-devel >= 3.22.0
115 BuildRequires:  tcl
116 BuildRequires:  xz-devel
117 BuildRequires:  zlib-devel
118 BuildRequires:  zstd-devel
119 %if %{with apidocs}
120 BuildRequires:  doxygen
121 BuildRequires:  ghostscript
122 BuildRequires:  graphviz
123 BuildRequires:  tetex-pdftex
124 %endif
125 Requires(posttrans):    coreutils
126 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
127 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
128 Requires:       rpm-pld-macros >= 1.744
129 Requires:       FHS >= 3.0-2
130 Requires:       libgcrypt
131 Requires:       popt >= %{popt_ver}
132 %if %{with recommends_tags}
133 Recommends:     rpm-plugin-audit
134 Recommends:     rpm-plugin-prioreset
135 Recommends:     rpm-plugin-syslog
136 Recommends:     rpm-plugin-systemd-inhibit
137 %endif
138 Obsoletes:      rpm-utils-perl
139 Obsoletes:      rpm-utils-static
140 Conflicts:      glibc < 2.2.92
141 # db4.6 poldek needed
142 Conflicts:      poldek < 0.21-0.20070703.00.3
143 # segfaults with lzma 0.42.2
144 Conflicts:      lzma-libs < 4.999.3
145 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
146 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
147
148 %define         _binary_payload         w9.gzdio
149
150 # don't require very fresh rpm.macros to build
151 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
152 %define         ix86    i386 i486 i586 i686 athlon geode pentium3 pentium4
153 %define         ppc     ppc ppc7400 ppc7450
154 %define         x8664   amd64 ia32e x86_64
155
156 %define         _rpmlibdir /usr/lib/rpm
157
158 %description
159 RPM is a powerful package manager, which can be used to build,
160 install, query, verify, update, and uninstall individual software
161 packages. A package consists of an archive of files, and package
162 information, including name, version, and description.
163
164 %description -l de.UTF-8
165 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
166 Installation, Anfrage, Verifizierung, Aktualisierung und
167 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
168 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
169 Beschreibung.
170
171 %description -l es.UTF-8
172 RPM es un poderoso administrador de paquetes, que puede ser usado para
173 construir, instalar, pesquisar, verificar, actualizar y desinstalar
174 paquetes individuales de software. Un paquete consiste en un
175 almacenaje de archivos, y información sobre el paquete, incluyendo
176 nombre, versión y descripción.
177
178 %description -l pl.UTF-8
179 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
180 przebudowanie, instalację czy weryfikację dowolnego pakietu.
181 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
182 plików wchodzących w skład pakietu, zależności od innych pakietów, są
183 przechowywane w bazie danych i można je uzyskać za pomocą opcji
184 odpytywania programu rpm.
185
186 %description -l pt_BR.UTF-8
187 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
188 construir, instalar, pesquisar, verificar, atualizar e desinstalar
189 pacotes individuais de software. Um pacote consiste de um conjunto de
190 arquivos e informações adicionais, incluindo nome, versão e descrição
191 do pacote, permissões dos arquivos, etc.
192
193 %description -l ru.UTF-8
194 RPM - это мощный менеджер пакетов, который может быть использован для
195 создания, инсталляции, запросов (query), проверки, обновления и
196 удаления программных пакетов. Пакет состоит из файлового архива и
197 служебной информации, включающей название, версию, описание и другие
198 данные о пакете.
199
200 %description -l uk.UTF-8
201 RPM - це потужний менеджер пакетів, що може бути використаний для
202 створення, інсталяції, запитів (query), перевірки, поновлення та
203 видалення програмних пакетів. Пакет складається з файлового архіву та
204 службової інформації, що містить назву, версію, опис та іншу
205 інформацію про пакет.
206
207 %package base
208 Summary:        RPM base package - scripts used by rpm packages themselves
209 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
210 Group:          Base
211 Requires:       filesystem
212 Obsoletes:      rpm-scripts
213 Obsoletes:      vserver-rpm
214
215 %description base
216 The RPM base package contains scripts used by rpm packages themselves.
217 These include:
218 - scripts for adding/removing groups and users needed for rpm
219   packages,
220 - banner.sh to display %%banner messages from rpm scriptlets.
221
222 %description base -l pl.UTF-8
223 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
224 Zawiera on:
225 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
226 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
227
228 %package lib
229 Summary:        RPMs library
230 Summary(pl.UTF-8):      Biblioteki RPM-a
231 Group:          Libraries
232 Requires:       db >= %{db_ver}
233 Requires:       libmagic >= 1.15-2
234 Requires:       popt >= %{popt_ver}
235 Obsoletes:      rpm-libs
236 # avoid SEGV caused by mixed db versions
237 Conflicts:      poldek < 0.18.1-16
238
239 %description lib
240 RPMs library.
241
242 %description lib -l pl.UTF-8
243 Biblioteki RPM-a.
244
245 %package devel
246 Summary:        Header files for rpm libraries
247 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
248 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
249 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
250 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
251 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
252 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
253 Group:          Development/Libraries
254 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
255 Requires:       bzip2-devel
256 Requires:       db-devel >= %{db_ver}
257 Requires:       elfutils-devel
258 Requires:       libmagic-devel
259 Requires:       libgcrypt-devel
260 %if %{with selinux}
261 Requires:       libselinux-devel
262 Requires:       libsemanage-devel
263 Requires:       libsepol-devel
264 %endif
265 Requires:       popt-devel >= %{popt_ver}
266 Requires:       zlib-devel
267
268 %description devel
269 The RPM packaging system includes C libraries that make it easy to
270 manipulate RPM packages and databases. They are intended to ease the
271 creation of graphical package managers and other tools that need
272 intimate knowledge of RPM packages. This package contains header files
273 for these libraries.
274
275 %description devel -l de.UTF-8
276 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
277 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
278 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
279 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
280
281 %description devel -l es.UTF-8
282 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
283 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
284 facilitar la creación de administradores gráficos de paquetes y otras
285 herramientas que necesiten un conocimiento profundo de paquetes RPM.
286
287 %description devel -l pl.UTF-8
288 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
289 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
290 graficznych programów zarządzających pakietami oraz innych narzędzi,
291 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
292 zawiera pliki nagłówkowe wspomnianych bibliotek.
293
294 %description devel -l pt_BR.UTF-8
295 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
296 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
297 facilitar a criação de gerenciadores gráficos de pacotes e outras
298 ferramentas que precisem de conhecimento profundo de pacotes RPM.
299
300 %description devel -l ru.UTF-8
301 Система управления пакетами RPM содержит библиотеку C, которая
302 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
303 Эта библиотека предназначена для облегчения создания графических
304 пакетных менеджеров и других утилит, которым необходимо работать с
305 пакетами RPM.
306
307 %description devel -l uk.UTF-8
308 Система керування пакетами RPM містить бібліотеку C, котра спрощує
309 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
310 призначена для полегшення створення графічних пакетних менеджерів та
311 інших утиліт, що працюють з пакетами RPM.
312
313 %package utils
314 Summary:        Additional utilities for managing RPM packages and database
315 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
316 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
317 Group:          Applications/File
318 Requires:       %{name} = %{epoch}:%{version}-%{release}
319 Requires:       popt >= %{popt_ver}
320 %if %{with recommends_tags}
321 Recommends:     bzip2
322 Recommends:     gzip
323 %endif
324 Conflicts:      filesystem-debuginfo < 3.0-16
325
326 %description utils
327 Additional utilities for managing RPM packages and database.
328
329 %description utils -l de.UTF-8
330 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
331
332 %description utils -l pl.UTF-8
333 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
334
335 %package build
336 Summary:        Scripts for building binary RPM packages
337 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
338 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
339 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
340 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
341 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
342 Group:          Applications/File
343 Requires(pretrans):     coreutils
344 Requires(pretrans):     findutils
345 Requires:       %{name}-utils = %{epoch}:%{version}-%{release}
346 Requires:       rpm-pld-macros-build >= 1.744
347 Requires:       /bin/id
348 Requires:       awk
349 Requires:       bzip2
350 Requires:       chrpath >= 0.10-4
351 Requires:       cpio
352 Requires:       diffutils
353 Requires:       elfutils
354 Requires:       file >= 4.17
355 Requires:       fileutils
356 Requires:       findutils
357 %ifarch athlon
358 Requires:       gcc >= 3.0.3
359 %else
360 Requires:       gcc
361 %endif
362 Requires:       glibc-devel
363 Requires:       grep
364 Requires:       gzip
365 Requires:       make
366 Requires:       patch
367 Requires:       sed >= 4.0
368 Requires:       sh-utils
369 Requires:       tar >= 1:1.22
370 Requires:       textutils
371 Requires:       which
372 Requires:       xz
373 Provides:       rpmbuild(noauto) = 3
374 %ifarch %{x8664}
375 Conflicts:      automake < 1:1.7.9-2
376 Conflicts:      libtool < 2:1.5-13
377 %endif
378
379 %description build
380 Scripts for building binary RPM packages.
381
382 %description build -l de.UTF-8
383 Scripts fürs Bauen binärer RPM-Pakete.
384
385 %description build -l pl.UTF-8
386 Skrypty pomocnicze do budowania binarnych RPM-ów.
387
388 %description build -l pt_BR.UTF-8
389 Este pacote contém scripts e programas executáveis que são usados para
390 construir pacotes usando o RPM.
391
392 %description build -l ru.UTF-8
393 Различные вспомогательные скрипты и исполняемые программы, которые
394 используются для сборки RPM'ов.
395
396 %description build -l uk.UTF-8
397 Різноманітні допоміжні скрипти та утиліти, які використовуються для
398 побудови RPM'ів.
399
400 %package perlprov
401 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
402 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
403 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
404 Group:          Applications/File
405 Requires:       %{name} = %{epoch}:%{version}-%{release}
406 Requires:       perl-Encode
407 Requires:       perl-devel
408 Requires:       perl-modules
409
410 %description perlprov
411 Additional utilities for checking Perl provides/requires in RPM
412 packages.
413
414 %description perlprov -l de.UTF-8
415 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
416
417 %description perlprov -l pl.UTF-8
418 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
419 pakietach RPM.
420
421 %package pythonprov
422 Summary:        Python macros, which simplifies creation of RPM packages with Python software
423 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
424 Group:          Applications/File
425 Requires:       %{name} = %{epoch}:%{version}-%{release}
426 Requires:       python3
427 Requires:       python3-modules
428 Requires:       python3-setuptools
429
430 %description pythonprov
431 Python macros, which simplifies creation of RPM packages with Python
432 software.
433
434 %description pythonprov -l pl.UTF-8
435 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
436 Pythonie.
437
438 %package -n python3-rpm
439 Summary:        Python 3 interface to RPM library
440 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki RPM-a
441 Summary(pt_BR.UTF-8):   Módulo Python 3 para aplicativos que manipulam pacotes RPM
442 Group:          Development/Languages/Python
443 Requires:       %{name} = %{epoch}:%{version}-%{release}
444 Requires:       python3
445 Obsoletes:      python-rpm < 1:4.16.0
446 Obsoletes:      rpm-python
447
448 %description -n python3-rpm
449 The python3-rpm package contains a module which permits applications
450 written in the Python 3 programming language to use the interface
451 supplied by RPM (RPM Package Manager) libraries.
452
453 This package should be installed if you want to develop Python 3
454 programs that will manipulate RPM packages and databases.
455
456 %description -n python3-rpm -l pl.UTF-8
457 Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
458 Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki
459 RPM-a.
460
461 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
462 Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
463
464 %description -n python3-rpm -l pt_BR.UTF-8
465 O pacote python3-rpm contém um módulo que permite que aplicações
466 escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
467 RPM (RPM Package Manager).
468
469 Esse pacote deve ser instalado se você quiser desenvolver programas em
470 Python 3 para manipular pacotes e bancos de dados RPM.
471
472 %package plugin-audit
473 Summary:        Plugin for logging audit events on package operations
474 Group:          Base
475 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
476
477 %description plugin-audit
478 Plugin for libaudit support
479
480 %package plugin-syslog
481 Summary:        Plugin for syslog functionality
482 Group:          Base
483 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
484
485 %description plugin-syslog
486 This plugin exports RPM actions to the system log.
487
488 %package plugin-systemd-inhibit
489 Summary:        Plugin for systemd inhibit functionality
490 Group:          Base
491 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
492
493 %description plugin-systemd-inhibit
494 This plugin blocks systemd from entering idle, sleep or shutdown while
495 an rpm transaction is running using the systemd-inhibit mechanism.
496
497 %package plugin-ima
498 Summary:        Plugin for IMA file signatures
499 Group:          Base
500 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
501
502 %description plugin-ima
503 This plugin adds support for enforcing and verifying IMA file
504 signatures in an rpm.
505
506 %package plugin-prioreset
507 Summary:        Plugin for resetting scriptlet priorities for SysV init
508 Group:          Base
509 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
510
511 %description plugin-prioreset
512 This plugin is useful on legacy SysV init systems if you run rpm
513 transactions with nice/ionice priorities. Should not be used on
514 systemd systems.
515
516 %package plugin-selinux
517 Summary:        Plugin for SELinux functionality
518 Group:          Base
519 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
520 Requires:       libselinux >= 2.1.0
521
522 %description plugin-selinux
523 Plugin for SELinux functionality.
524
525 %package sign
526 Summary:        Package signing support
527 Group:          Base
528 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
529
530 %description sign
531 This package contains support for digitally signing RPM packages.
532
533 %package apidocs
534 Summary:        RPM API documentation and guides
535 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
536 Group:          Documentation
537 BuildArch:      noarch
538
539 %description apidocs
540 Documentation for RPM API and guides in HTML format generated from rpm
541 sources by doxygen.
542
543 %description apidocs -l pl.UTF-8
544 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
545 źrodeł RPM-a przez doxygen.
546
547 %prep
548 %setup -q -n %{name}-%{version}%{?subver}
549 %patch0 -p1
550 %patch1 -p1
551 %patch2 -p1
552 %patch3 -p1
553 %patch4 -p1
554 %patch6 -p0
555 %patch7 -p1
556 %patch8 -p1
557 %patch9 -p1
558 %patch10 -p1
559 %patch11 -p1
560 %patch12 -p1
561 %patch13 -p1
562 %patch14 -p1
563 %patch15 -p1
564 %patch16 -p1
565 %patch17 -p1
566 %patch18 -p1
567 %patch19 -p1
568 %patch20 -p1
569 %patch21 -p1
570 %patch22 -p1
571 %patch23 -p1
572 %patch24 -p1
573 %patch25 -p1
574 %patch26 -p1
575 %patch27 -p1
576 %patch28 -p1
577 %patch29 -p1
578
579 install %{SOURCE15} scripts/perl.prov.in
580
581 %{__mv} -f scripts/perl.req{,.in}
582
583 # generate Group translations to *.po
584 awk -f %{SOURCE6} %{SOURCE5}
585
586 install %{SOURCE16} tools/rpmdb_checkversion.c
587 install %{SOURCE17} tools/rpmdb_reset.c
588
589 %{__sed} -i -e '1s,/usr/bin/python,%{__python3},' scripts/pythondistdeps.py
590
591 %build
592 %{__libtoolize}
593 %{__aclocal}
594 %{__autoheader}
595 %{__autoconf}
596 %{__automake}
597
598 # rpm checks for CPU type at runtime, but it looks better
599 sed -i \
600         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
601         -e 's|@host_cpu@|%{_target_cpu}|' \
602         -e 's|@host_os@|%{_target_os}|' \
603         macros.in
604
605 %configure \
606         WITH_PERL_VERSION=no \
607         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
608         __GPG=%{_bindir}/gpg \
609 %if %{with python3}
610         PYTHON=python3 \
611         --enable-python \
612 %endif
613         --disable-silent-rules \
614         --enable-shared \
615         --enable-bdb \
616         --enable-bdb-ro \
617         --enable-ndb \
618         --enable-sqlite \
619         --enable-zstd \
620         --with-lua \
621         %{?with_imaevm:--with-imaevm} \
622         --with-cap \
623         --with-acl \
624         --with-audit \
625         --with-archive \
626         --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
627         %{!?with_plugins:--disable-plugins} \
628         --with-vendor=pld
629
630 %{__make}
631
632 %{__cc} %{rpmcflags} tools/rpmdb_checkversion.c -o tools/rpmdb_checkversion -ldb
633 %{__cc} %{rpmcflags} tools/rpmdb_reset.c -o tools/rpmdb_reset -ldb
634
635 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
636         echo "Error linking rpmdb tools!"
637         exit 1
638 fi
639 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
640         echo "Error linking rpmdb tools!"
641         exit 1
642 fi
643
644 %if %{with python3}
645 cd python
646 %py3_build
647 %endif
648
649 %install
650 rm -rf $RPM_BUILD_ROOT
651 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
652         $RPM_BUILD_ROOT/var/lib/{banner,rpm}
653
654 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
655
656 %{__make} install \
657         pkgconfigdir=%{_pkgconfigdir} \
658         DESTDIR=$RPM_BUILD_ROOT
659
660 # cleanup
661 %ifnarch %{ix86} %{x8664} x32
662 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
663 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
664 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
665 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
666 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
667 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
668 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
669 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
670 %endif
671
672 %ifnarch %{x8664} x32
673 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
674 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
675 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
676 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
677 %endif
678
679 %ifnarch %{ppc}
680 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
681 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
682 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
683 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
684 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
685 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
686 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
687 %endif
688
689 %ifnarch aarch64
690 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
691 %endif
692
693 %ifnarch %{arm}
694 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
695 %endif
696
697 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
698 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
699 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
700 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
701 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
702 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
703 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
704
705 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
706 %ifarch x32
707 %{_target_cpu}-%{_target_vendor}-linux-gnux32
708 %else
709 %{_target_cpu}-%{_target_vendor}-linux
710 %endif
711 EOF
712
713 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
714
715 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
716
717 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
718 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
719 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rpm
720
721 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/banner.sh
722
723 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
724 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
725 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
726 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
727 cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
728 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
729
730 cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
731 cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
732 cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
733
734 # move rpm to /bin
735 %{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
736 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
737 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
738
739 # move essential libs to /lib (libs that /bin/rpm links to)
740 for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
741         mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
742         ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
743 done
744
745 #./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
746
747 # Make sure we have bdb set a default backend
748 grep -qE "db_backend[[:blank:]]+bdb" $RPM_BUILD_ROOT%{_rpmlibdir}/macros
749
750 %if %{with python3}
751 # Remove anything that rpm make install might put there
752 %{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
753 cd python
754 %py3_install
755 cd ..
756 %endif
757
758 %{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
759
760 # wrong location, not used anyway
761 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
762
763 %find_lang %{name}
764
765 %clean
766 rm -rf $RPM_BUILD_ROOT
767
768 %posttrans
769 if [ -e /var/lib/rpm/Packages ] && \
770                 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
771         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
772                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
773                 echo
774                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
775                 echo
776         fi
777         echo
778         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
779         echo 'you should ignore it and restart poldek'
780         echo
781         %{_rpmlibdir}/dbupgrade.sh
782 fi
783
784 %post   lib -p /sbin/ldconfig
785 %postun lib -p /sbin/ldconfig
786
787 %pretrans build
788 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
789
790 %files -f %{name}.lang
791 %defattr(644,root,root,755)
792 %doc ChangeLog CREDITS README
793
794 %dir /etc/pki/rpm-gpg
795 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
796
797 %attr(755,root,root) /bin/rpm
798 %attr(755,root,root) %{_bindir}/rpmdb
799 %attr(755,root,root) %{_bindir}/rpmkeys
800 %attr(755,root,root) %{_bindir}/rpmquery
801 %attr(755,root,root) %{_bindir}/rpmverify
802
803 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
804 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
805 # this is ok to be replaced
806 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
807
808 %{_mandir}/man8/rpm.8*
809 %{_mandir}/man8/rpmdb.8*
810 %{_mandir}/man8/rpmkeys.8*
811 %{_mandir}/man8/rpm-misc.8*
812 %{?with_plugins:%{_mandir}/man8/rpm-plugins.8*}
813 %lang(fr) %{_mandir}/fr/man8/rpm.8*
814 %lang(ja) %{_mandir}/ja/man8/rpm.8*
815 %lang(ko) %{_mandir}/ko/man8/rpm.8*
816 %lang(pl) %{_mandir}/pl/man8/rpm.8*
817 %lang(ru) %{_mandir}/ru/man8/rpm.8*
818 %lang(sk) %{_mandir}/sk/man8/rpm.8*
819
820 %dir /var/lib/rpm
821
822 %{_rpmlibdir}/rpmpopt*
823 %{_rpmlibdir}/rpmrc
824 %{_rpmlibdir}/macros
825 %dir %{_rpmlibdir}/macros.d
826 %dir %{_rpmlibdir}/platform
827 %{_rpmlibdir}/platform/noarch-*
828 %ifarch %{ix86} %{x8664} x32
829 %{_rpmlibdir}/platform/athlon*
830 %{_rpmlibdir}/platform/geode*
831 %{_rpmlibdir}/platform/i?86*
832 %{_rpmlibdir}/platform/pentium*
833 %endif
834 %ifarch %{x8664} x32
835 %{_rpmlibdir}/platform/amd64*
836 %{_rpmlibdir}/platform/ia32e*
837 %{_rpmlibdir}/platform/x86_64*
838 %{_rpmlibdir}/platform/x32*
839 %endif
840 %ifarch alpha
841 %{_rpmlibdir}/platform/alpha*
842 %endif
843 %ifarch aarch64
844 %{_rpmlibdir}/platform/aarch64*
845 %endif
846 %ifarch %{arm}
847 %{_rpmlibdir}/platform/arm*
848 %endif
849 %ifarch ia64
850 %{_rpmlibdir}/platform/ia64*
851 %endif
852 %ifarch mips mipsel mips64 mips64el
853 %{_rpmlibdir}/platform/mips*
854 %endif
855 %ifarch %{ppc}
856 %{_rpmlibdir}/platform/ppc*
857 %endif
858 %ifarch sparc sparc64
859 %{_rpmlibdir}/platform/sparc*
860 %endif
861
862 %dir %{_rpmlibdir}/pld
863
864 %attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
865 %attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
866 %attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
867 %attr(755,root,root) %{_rpmlibdir}/rpmdb_dump
868 %attr(755,root,root) %{_rpmlibdir}/rpmdb_load
869
870 # valgrind suppression file for rpm
871 %{_rpmlibdir}/rpm.supp
872
873 %files base
874 %defattr(644,root,root,755)
875 %dir %{_sysconfdir}/rpm
876 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
877 %dir %{_rpmlibdir}
878 %attr(755,root,root) %{_bindir}/banner.sh
879 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
880 %dir /var/lib/banner
881
882 %files lib
883 %defattr(644,root,root,755)
884 %attr(755,root,root) /%{_lib}/librpm.so.9
885 %attr(755,root,root) /%{_lib}/librpm.so.%{sover}
886 %attr(755,root,root) /%{_lib}/librpmbuild.so.9
887 %attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
888 %attr(755,root,root) /%{_lib}/librpmio.so.9
889 %attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
890 %attr(755,root,root) /%{_lib}/librpmsign.so.9
891 %attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
892 %{?with_plugins:%dir %{_libdir}/rpm-plugins}
893
894 %files devel
895 %defattr(644,root,root,755)
896 %attr(755,root,root) %{_libdir}/librpm.so
897 %attr(755,root,root) %{_libdir}/librpmbuild.so
898 %attr(755,root,root) %{_libdir}/librpmio.so
899 %attr(755,root,root) %{_libdir}/librpmsign.so
900 %{_libdir}/librpm*.la
901 %{_includedir}/rpm
902 %{_pkgconfigdir}/*.pc
903
904 %files utils
905 %defattr(644,root,root,755)
906 %attr(755,root,root) %{_bindir}/rpm2archive
907 %attr(755,root,root) %{_bindir}/rpm2cpio
908 %attr(755,root,root) %{_bindir}/rpmgraph
909 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
910 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
911 %attr(755,root,root) %{_rpmlibdir}/tgpg
912 %attr(755,root,root) %{_rpmlibdir}/debugedit
913 %attr(755,root,root) %{_rpmlibdir}/rpmdeps
914 %{_mandir}/man8/rpm2archive.8*
915 %{_mandir}/man8/rpm2cpio.8*
916 %{_mandir}/man8/rpmdeps.8*
917 %{_mandir}/man8/rpmgraph.8*
918 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
919 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
920 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
921 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
922 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
923 %lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
924 %lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
925
926 %files build
927 %defattr(644,root,root,755)
928 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
929 %attr(755,root,root) %{_rpmlibdir}/brp-*
930 %attr(755,root,root) %{_rpmlibdir}/check-files
931 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
932 %attr(755,root,root) %{_rpmlibdir}/elfdeps
933 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
934 # needs hacked pkg-config to return anything
935 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
936 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
937
938 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
939 # must be here for "Requires: rpm-*prov" to work
940 #%{_rpmlibdir}/macros.d/cmake
941 #%{_rpmlibdir}/macros.d/gstreamer
942 #%{_rpmlibdir}/macros.d/libtool
943 #%{_rpmlibdir}/macros.d/perl
944 #%{_rpmlibdir}/macros.d/pkgconfig
945 #%{_rpmlibdir}/macros.d/python
946 #%{_rpmlibdir}/macros.d/selinux
947 #%{_rpmlibdir}/macros.d/tcl
948 #%{_rpmlibdir}/macros.rpmbuild
949
950 %attr(755,root,root) %{_rpmlibdir}/check-buildroot
951 %attr(755,root,root) %{_rpmlibdir}/check-prereqs
952 %attr(755,root,root) %{_rpmlibdir}/check-rpaths
953 %attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
954 %attr(755,root,root) %{_rpmlibdir}/find-provides
955 %attr(755,root,root) %{_rpmlibdir}/find-requires
956 %attr(755,root,root) %{_rpmlibdir}/ocamldeps.sh
957 %attr(755,root,root) %{_rpmlibdir}/script.req
958 %attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
959
960 %dir %{_rpmlibdir}/fileattrs
961 %{_rpmlibdir}/fileattrs/debuginfo.attr
962 %{_rpmlibdir}/fileattrs/desktop.attr
963 %{_rpmlibdir}/fileattrs/elf.attr
964 %{_rpmlibdir}/fileattrs/font.attr
965 %{_rpmlibdir}/fileattrs/libtool.attr
966 %{_rpmlibdir}/fileattrs/metainfo.attr
967 %{_rpmlibdir}/fileattrs/ocaml.attr
968 %{_rpmlibdir}/fileattrs/perl.attr
969 %{_rpmlibdir}/fileattrs/perllib.attr
970 %{_rpmlibdir}/fileattrs/pkgconfig.attr
971 %{_rpmlibdir}/fileattrs/python.attr
972 %{_rpmlibdir}/fileattrs/pythondist.attr
973 %{_rpmlibdir}/fileattrs/script.attr
974
975 %attr(755,root,root) %{_bindir}/gendiff
976 %attr(755,root,root) %{_bindir}/rpmbuild
977 %attr(755,root,root) %{_bindir}/rpmspec
978
979 %{_mandir}/man1/gendiff.1*
980 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
981 %{_mandir}/man8/rpmbuild.8*
982 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
983 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
984 %{_mandir}/man8/rpmspec.8*
985
986 %files perlprov
987 %defattr(644,root,root,755)
988 %attr(755,root,root) %{_rpmlibdir}/perl.*
989
990 %files pythonprov
991 %defattr(644,root,root,755)
992 %attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
993
994 %if %{with python3}
995 %files -n python3-rpm
996 %defattr(644,root,root,755)
997 %dir %{py3_sitedir}/rpm
998 %attr(755,root,root) %{py3_sitedir}/rpm/*.so
999 %{py3_sitedir}/rpm/*.py
1000 %{py3_sitedir}/rpm-%{version}-py*.egg-info
1001 %{py3_sitedir}/rpm/__pycache__
1002 %endif
1003
1004 %if %{with plugins}
1005 %files plugin-audit
1006 %defattr(644,root,root,755)
1007 %attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
1008 %{_mandir}/man8/rpm-plugin-audit.8*
1009
1010 %files plugin-syslog
1011 %defattr(644,root,root,755)
1012 %attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
1013 %{_mandir}/man8/rpm-plugin-syslog.8*
1014
1015 %files plugin-systemd-inhibit
1016 %defattr(644,root,root,755)
1017 %attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
1018 %{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
1019
1020 %files plugin-ima
1021 %defattr(644,root,root,755)
1022 %attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
1023 %{_mandir}/man8/rpm-plugin-ima.8*
1024
1025 %files plugin-prioreset
1026 %defattr(644,root,root,755)
1027 %attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
1028 %{_mandir}/man8/rpm-plugin-prioreset.8*
1029
1030 %files plugin-selinux
1031 %defattr(644,root,root,755)
1032 %attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
1033 %{_mandir}/man8/rpm-plugin-selinux.8*
1034 %endif
1035
1036 %files sign
1037 %defattr(644,root,root,755)
1038 %attr(755,root,root) %{_bindir}/rpmsign
1039 %{_mandir}/man8/rpmsign.8*
1040
1041 %if %{with apidocs}
1042 %files apidocs
1043 %defattr(644,root,root,755)
1044 %doc doc/librpm/html/*
1045 %endif
This page took 0.22226 seconds and 3 git commands to generate.