]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- dropped obsolete comment
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - check if we want shell autodeps: Requires: executable(ln) executable(mv)
4 # - %{_arch} = i686 not as used to be i386:
5 #   5.0.2: rpm -E '%_target_base_arch %_arch'
6 #          i386 i686
7 #   4.4.9: rpm -E '%_target_base_arch %_arch'
8 #          i386 i386
9 # - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
10 #   matches ELF first
11 # - TODO: add macros for some ppc, mipsel, alpha and sparc
12 # - uppackaged list:
13 #   /usr/lib/rpm/http.req
14 #   /usr/lib/rpm/install-sh
15 #   /usr/lib/rpm/mono-find-provides
16 #   /usr/lib/rpm/mono-find-requires
17 #   /usr/lib/rpm/osgideps.pl
18 #   /usr/lib/rpm/perldeps.pl
19 #   /usr/lib/rpm/vcheck
20 #   /usr/share/man/man8/rpmconstant.8
21 #
22 # Conditional build:
23 %bcond_with     static          # build static rpm+rpmi
24 %bcond_without  apidocs         # don't generate documentation with doxygen
25 %bcond_with     autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
26 %bcond_without  python          # don't build python bindings
27 %bcond_without  selinux         # build without selinux support
28 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
29 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
30 %bcond_without  db              # BerkeleyDB
31 %bcond_with     sqlite          # build with SQLite support
32 %bcond_with     sqlite_dbapi    # default database backend is sqlite
33 %bcond_without  system_lua              # use system lua
34 # force_cc              - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
35 # force_cxx             - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
36 # force_cpp             - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
37 #
38 %if %{with sqlite_dbapi}
39 %define with_sqlite     1
40 %endif
41
42 %if %{without db} && %{without sqlite}
43 %{error:Need db or sqlite}
44 ERROR
45 %endif
46
47 # versions of required libraries
48 %define         reqdb_ver       4.7.25
49 %define         reqpopt_ver     1.10.8
50 %define         beecrypt_ver    2:4.1.2-4
51 %define         sover   5.0
52
53 Summary:        RPM Package Manager
54 Summary(de.UTF-8):      RPM Packet-Manager
55 Summary(es.UTF-8):      Gestor de paquetes RPM
56 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
57 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
58 Summary(ru.UTF-8):      Менеджер пакетов от RPM
59 Summary(uk.UTF-8):      Менеджер пакетів від RPM
60 Name:           rpm
61 Version:        5.1.4
62 Release:        0.5
63 License:        LGPL
64 Group:          Base
65 Source0:        http://rpm5.org/files/rpm/rpm-5.1/%{name}-%{version}.tar.gz
66 # Source0-md5:  9a04c22ce1dffc81a7e43d39b002aaa1
67 Source1:        %{name}.groups
68 Source2:        %{name}.platform
69 Source3:        %{name}-install-tree
70 Source4:        %{name}-find-spec-bcond
71 Source5:        %{name}-hrmib-cache
72 Source6:        %{name}-groups-po.awk
73 Source7:        %{name}-compress-doc
74 Source8:        %{name}-check-files
75 Source9:        %{name}-php-provides
76 Source10:       %{name}-php-requires
77 Source11:       %{name}.sysinfo
78 Source12:       perl.prov
79 Source13:       %{name}-user_group.sh
80 Source14:       %{name}.sysconfig
81 Source15:       %{name}-macros.java
82 Source16:       %{name}-java-requires
83 # http://svn.pld-linux.org/banner.sh/
84 Source17:       banner.sh
85 Source18:       %{name}-pld.macros
86 Source19:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
87 # Source19-md5:  08b29584dd349aac9caa7610131a0a88
88 Source20:       %{name}-mimetypedeps
89 Source100:      %{name}-macros-athlon
90 Source101:      %{name}-macros-i386
91 Source102:      %{name}-macros-i486
92 Source103:      %{name}-macros-i586
93 Source104:      %{name}-macros-i686
94 Source105:      %{name}-macros-noarch
95 Source106:      %{name}-macros-pentium3
96 Source107:      %{name}-macros-pentium4
97 Source108:      %{name}-macros-ppc
98 Source109:      %{name}-macros-x86_64
99 Source110:      %{name}-macros-ia32e
100 Source111:      %{name}-macros-amd64
101
102 Patch0:         %{name}-branch.patch
103 Patch1:         %{name}-man_pl.patch
104 Patch2:         %{name}-popt-aliases.patch
105 Patch3:         %{name}-rpmpopt.patch
106 Patch4:         %{name}-perl-macros.patch
107 Patch5:         %{name}-perl-req-perlfile.patch
108 Patch6:         %{name}-noexpand.patch
109 Patch7:         %{name}-scripts-closefds.patch
110 Patch8:         %{name}-php-macros.patch
111 Patch9:         %{name}-gettext-in-header.patch
112 Patch10:        %{name}-compress-doc.patch
113 Patch11:        %{name}-lua.patch
114
115 Patch14:        %{name}-etc_dir.patch
116 Patch16:        %{name}-php-deps.patch
117 Patch17:        %{name}-macros.patch
118 Patch18:        %{name}-macros-th.patch
119
120 Patch23:        %{name}-pkgconfigdeps.patch
121
122 Patch26:        %{name}-notsc.patch
123 Patch27:        %{name}-hack-norpmlibdep.patch
124
125 Patch32:        %{name}-pld-autodep.patch
126 Patch34:        %{name}-epoch0.patch
127 Patch35:        %{name}-perl_req-INC_dirs.patch
128 Patch36:        %{name}-debuginfo.patch
129 Patch37:        %{name}-doxygen_hack.patch
130
131 Patch42:        %{name}-old-fileconflicts-behaviour.patch
132
133 Patch46:        %{name}-mono.patch
134 Patch47:        %{name}-javadeps.patch
135
136 Patch52:        %{name}-morearchs.patch
137
138 Patch55:        %{name}-truncate-cvslog.patch
139
140 Patch59:        %{name}-libtool-deps.patch
141 Patch60:        %{name}-mimetype.patch
142 Patch61:        %{name}-sparc64.patch
143 URL:            http://rpm5.org/
144 BuildRequires:  autoconf >= 2.60
145 BuildRequires:  automake >= 1.4
146 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
147 BuildRequires:  bzip2-devel >= 1.0.2-17
148 %{?with_db:BuildRequires:       db-devel >= %{reqdb_ver}}
149 BuildRequires:  elfutils-devel >= 0.108
150 BuildRequires:  gettext-autopoint >= 0.11.4-2
151 BuildRequires:  gettext-devel >= 0.11.4-2
152 BuildRequires:  lzma-devel >= 4.999.3
153 BuildRequires:  libmagic-devel
154 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.18}
155 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
156 BuildRequires:  libstdc++-devel
157 BuildRequires:  libtool >= 1:1.4.2-9
158 %if %{with neon}
159 BuildRequires:  libxml2-devel
160 BuildRequires:  neon-devel >= 0.25.5
161 %endif
162 BuildRequires:  patch >= 2.2
163 BuildRequires:  popt-devel >= %{reqpopt_ver}
164 %{?with_system_lua:BuildRequires:       lua51-devel >= 5.1.2}
165 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
166 BuildRequires:  python-modules >= 1:2.3
167 BuildRequires:  rpm-perlprov
168 %{?with_python:BuildRequires:   rpm-pythonprov}
169 %{?with_sqlite:BuildRequires:   sqlite3-devel}
170 BuildRequires:  zlib-devel
171 %if %{with apidocs}
172 BuildRequires:  doxygen
173 BuildRequires:  ghostscript
174 BuildRequires:  graphviz
175 BuildRequires:  tetex-pdftex
176 %endif
177 %if %{with static}
178 # Require static library only for static build
179 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
180 BuildRequires:  bzip2-static >= 1.0.2-17
181 %{?with_db:BuildRequires:       db-static >= %{reqdb_ver}}
182 BuildRequires:  elfutils-static
183 BuildRequires:  glibc-static >= 2.2.94
184 BuildRequires:  libmagic-static
185 %{?with_selinux:BuildRequires:  libselinux-static >= 1.18}
186 BuildRequires:  popt-static >= %{reqpopt_ver}
187 BuildRequires:  zlib-static
188 %endif
189 Requires:       %{name}-base = %{version}-%{release}
190 Requires:       %{name}-lib = %{version}-%{release}
191 Requires:       beecrypt >= %{beecrypt_ver}
192 Requires:       popt >= %{reqpopt_ver}
193 Provides:       rpm-db-ver = %{reqdb_ver}
194 Obsoletes:      rpm-getdeps
195 %{!?with_static:Obsoletes:      rpm-utils-static}
196 Conflicts:      glibc < 2.2.92
197 # db4.6 poldek needed
198 Conflicts:      poldek < 0.21-0.20070703.00.3
199 # segfaults with lzma 0.42.2
200 Conflicts:      lzma-libs < 4.999.3
201 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
202
203 %define         _binary_payload         w9.gzdio
204 %define         _noPayloadPrefix        1
205
206 # don't require very fresh rpm.macros to build
207 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
208 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
209 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
210 %define         ppc     ppc ppc7400 ppc7450
211 %define         x8664   amd64 ia32e x86_64
212
213 # stabilize new build environment
214 %define         __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
215 %define         __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
216 %define         __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
217
218 %define         _rpmlibdir /usr/lib/rpm
219 %define         _noautocompressdoc      RPM-GPG-KEY
220
221 %define         specflags       -fno-strict-aliasing
222
223 %description
224 RPM is a powerful package manager, which can be used to build,
225 install, query, verify, update, and uninstall individual software
226 packages. A package consists of an archive of files, and package
227 information, including name, version, and description.
228
229 %description -l de.UTF-8
230 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
231 Installation, Anfrage, Verifizierung, Aktualisierung und
232 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
233 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
234 Beschreibung.
235
236 %description -l es.UTF-8
237 RPM es un poderoso administrador de paquetes, que puede ser usado para
238 construir, instalar, pesquisar, verificar, actualizar y desinstalar
239 paquetes individuales de software. Un paquete consiste en un
240 almacenaje de archivos, y información sobre el paquete, incluyendo
241 nombre, versión y descripción.
242
243 %description -l pl.UTF-8
244 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
245 przebudowanie, instalację czy weryfikację dowolnego pakietu.
246 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
247 plików wchodzących w skład pakietu, zależności od innych pakietów, są
248 przechowywane w bazie danych i można je uzyskać za pomocą opcji
249 odpytywania programu rpm.
250
251 %description -l pt_BR.UTF-8
252 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
253 construir, instalar, pesquisar, verificar, atualizar e desinstalar
254 pacotes individuais de software. Um pacote consiste de um conjunto de
255 arquivos e informações adicionais, incluindo nome, versão e descrição
256 do pacote, permissões dos arquivos, etc.
257
258 %description -l ru.UTF-8
259 RPM - это мощный менеджер пакетов, который может быть использован для
260 создания, инсталляции, запросов (query), проверки, обновления и
261 удаления программных пакетов. Пакет состоит из файлового архива и
262 служебной информации, включающей название, версию, описание и другие
263 данные о пакете.
264
265 %description -l uk.UTF-8
266 RPM - це потужний менеджер пакетів, що може бути використаний для
267 створення, інсталяції, запитів (query), перевірки, поновлення та
268 видалення програмних пакетів. Пакет складається з файлового архіву та
269 службової інформації, що містить назву, версію, опис та іншу
270 інформацію про пакет.
271
272 %package base
273 Summary:        RPM base package - scripts used by rpm packages themselves
274 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
275 Group:          Base
276 Requires:       filesystem
277 Obsoletes:      rpm-scripts
278 Obsoletes:      vserver-rpm
279
280 %description base
281 The RPM base package contains scripts used by rpm packages themselves.
282 These include:
283 - scripts for adding/removing groups and users needed for rpm
284   packages,
285 - banner.sh to display %%banner messages from rpm scriptlets.
286
287 %description base -l pl.UTF-8
288 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
289 Zawiera on:
290 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
291 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
292
293 %package lib
294 Summary:        RPMs library
295 Summary(pl.UTF-8):      Biblioteki RPM-a
296 Group:          Libraries
297 Requires:       beecrypt >= %{beecrypt_ver}
298 %{?with_db:Requires:    db >= %{reqdb_ver}}
299 Requires:       libmagic >= 1.15-2
300 %{?with_selinux:Requires:       libselinux >= 1.18}
301 Requires:       popt >= %{reqpopt_ver}
302 Obsoletes:      rpm-libs
303 # avoid SEGV caused by mixed db versions
304 Conflicts:      poldek < 0.18.1-16
305
306 %description lib
307 RPMs library.
308
309 %description lib -l pl.UTF-8
310 Biblioteki RPM-a.
311
312 %package devel
313 Summary:        Header files for rpm libraries
314 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
315 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
316 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
317 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
318 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
319 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
320 Group:          Development/Libraries
321 Requires:       %{name}-lib = %{version}-%{release}
322 Requires:       beecrypt-devel >= %{beecrypt_ver}
323 Requires:       bzip2-devel
324 %{?with_db:Requires:    db-devel >= %{reqdb_ver}}
325 Requires:       elfutils-devel
326 Requires:       libmagic-devel
327 %{?with_selinux:Requires:       libselinux-devel}
328 Requires:       popt-devel >= %{reqpopt_ver}
329 Requires:       zlib-devel
330
331 %description devel
332 The RPM packaging system includes C libraries that make it easy to
333 manipulate RPM packages and databases. They are intended to ease the
334 creation of graphical package managers and other tools that need
335 intimate knowledge of RPM packages. This package contains header files
336 for these libraries.
337
338 %description devel -l de.UTF-8
339 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
340 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
341 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
342 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
343
344 %description devel -l es.UTF-8
345 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
346 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
347 facilitar la creación de administradores gráficos de paquetes y otras
348 herramientas que necesiten un conocimiento profundo de paquetes RPM.
349
350 %description devel -l pl.UTF-8
351 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
352 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
353 graficznych programów zarządzających pakietami oraz innych narzędzi,
354 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
355 zawiera pliki nagłówkowe wspomnianych bibliotek.
356
357 %description devel -l pt_BR.UTF-8
358 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
359 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
360 facilitar a criação de gerenciadores gráficos de pacotes e outras
361 ferramentas que precisem de conhecimento profundo de pacotes RPM.
362
363 %description devel -l ru.UTF-8
364 Система управления пакетами RPM содержит библиотеку C, которая
365 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
366 Эта библиотека предназначена для облегчения создания графических
367 пакетных менеджеров и других утилит, которым необходимо работать с
368 пакетами RPM.
369
370 %description devel -l uk.UTF-8
371 Система керування пакетами RPM містить бібліотеку C, котра спрощує
372 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
373 призначена для полегшення створення графічних пакетних менеджерів та
374 інших утиліт, що працюють з пакетами RPM.
375
376 %package static
377 Summary:        RPM static libraries
378 Summary(de.UTF-8):      RPMs statische Libraries
379 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
380 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
381 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
382 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
383 Group:          Development/Libraries
384 Requires:       %{name}-devel = %{version}-%{release}
385 Requires:       beecrypt-static >= %{beecrypt_ver}
386 Requires:       bzip2-static
387 %{?with_db:Requires:    db-static >= %{reqdb_ver}}
388 Requires:       elfutils-static
389 Requires:       libmagic-static
390 Requires:       popt-static >= %{reqpopt_ver}
391 Requires:       zlib-static
392
393 %description static
394 RPM static libraries.
395
396 %description static -l de.UTF-8
397 RPMs statische Libraries.
398
399 %description static -l pl.UTF-8
400 Biblioteki statyczne RPM-a.
401
402 %description static -l pt_BR.UTF-8
403 Bibliotecas estáticas para desenvolvimento.
404
405 %description static -l ru.UTF-8
406 Система управления пакетами RPM содержит библиотеку C, которая
407 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
408 Это статическая библиотека RPM.
409
410 %description static -l uk.UTF-8
411 Система керування пакетами RPM містить бібліотеку C, котра спрощує
412 роботу з пакетами RPM та відповідними базами даних. Це статична
413 бібліотека RPM.
414
415 %package utils
416 Summary:        Additional utilities for managing RPM packages and database
417 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
418 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
419 Group:          Applications/File
420 Requires:       %{name} = %{version}-%{release}
421 Requires:       popt >= %{reqpopt_ver}
422 %if %{with suggest_tags}
423 Suggests:       bzip2
424 Suggests:       gzip
425 %endif
426 Conflicts:      filesystem-debuginfo < 3.0-16
427
428 %description utils
429 Additional utilities for managing RPM packages and database.
430
431 %description utils -l de.UTF-8
432 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
433
434 %description utils -l pl.UTF-8
435 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
436
437 %package utils-perl
438 Summary:        Additional utilities for managing RPM packages and database
439 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
440 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
441 Group:          Applications/File
442 Requires:       %{name}-utils = %{version}-%{release}
443 Requires:       popt >= %{reqpopt_ver}
444
445 %description utils-perl
446 Additional utilities for managing RPM packages and database.
447
448 %description utils-perl -l de.UTF-8
449 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
450
451 %description utils-perl -l pl.UTF-8
452 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
453
454 %package utils-static
455 Summary:        Static rpm utilities
456 Summary(pl.UTF-8):      Statyczne narzędzia rpm
457 Group:          Applications/System
458 Requires:       %{name} = %{version}-%{release}
459
460 %description utils-static
461 Static rpm utilities for repairing system in case something with
462 shared libraries used by rpm become broken. Currently it contains rpmi
463 binary, which can be used to install/upgrade/remove packages without
464 using shared libraries (well, in fact with exception of NSS modules).
465
466 %description utils-static -l pl.UTF-8
467 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
468 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
469 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
470 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
471 (z wyjątkiem modułów NSS).
472
473 %package build
474 Summary:        Scripts for building binary RPM packages
475 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
476 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
477 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
478 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
479 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
480 Group:          Applications/File
481 Requires(pre):  findutils
482 Requires:       %{name}-build-macros >= 1.433-2
483 Requires:       %{name}-utils = %{version}-%{release}
484 Requires:       /bin/id
485 Requires:       awk
486 Requires:       bzip2
487 Requires:       chrpath >= 0.10-4
488 Requires:       cpio
489 Requires:       diffutils
490 Requires:       elfutils
491 Requires:       file >= 4.17
492 Requires:       fileutils
493 Requires:       findutils
494 %ifarch athlon
495 Requires:       gcc >= 3.0.3
496 %else
497 Requires:       gcc
498 %endif
499 Requires:       glibc-devel
500 Requires:       grep
501 Requires:       gzip
502 Requires:       make
503 Requires:       patch
504 Requires:       sed
505 Requires:       sh-utils
506 Requires:       tar
507 Requires:       textutils
508 Provides:       rpmbuild(monoautodeps)
509 Provides:       rpmbuild(noauto) = 3
510 %ifarch %{x8664}
511 Conflicts:      automake < 1:1.7.9-2
512 Conflicts:      libtool < 2:1.5-13
513 %endif
514
515 %description build
516 Scripts for building binary RPM packages.
517
518 %description build -l de.UTF-8
519 Scripts fürs Bauen binärer RPM-Pakete.
520
521 %description build -l pl.UTF-8
522 Skrypty pomocnicze do budowania binarnych RPM-ów.
523
524 %description build -l pt_BR.UTF-8
525 Este pacote contém scripts e programas executáveis que são usados para
526 construir pacotes usando o RPM.
527
528 %description build -l ru.UTF-8
529 Различные вспомогательные скрипты и исполняемые программы, которые
530 используются для сборки RPM'ов.
531
532 %description build -l uk.UTF-8
533 Різноманітні допоміжні скрипти та утиліти, які використовуються для
534 побудови RPM'ів.
535
536 %package javaprov
537 Summary:        Additional utilities for checking Java provides/requires in RPM packages
538 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
539 Group:          Applications/File
540 Requires:       %{name} = %{version}-%{release}
541 Requires:       file
542 Requires:       findutils >= 1:4.2.26
543 Requires:       mktemp
544 Requires:       unzip
545
546 %description javaprov
547 Additional utilities for checking Java provides/requires in RPM
548 packages.
549
550 %description javaprov -l pl.UTF-8
551 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
552 RPM.
553
554 %package perlprov
555 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
556 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
557 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
558 Group:          Applications/File
559 Requires:       %{name} = %{version}-%{release}
560 Requires:       perl-devel
561 Requires:       perl-modules
562
563 %description perlprov
564 Additional utilities for checking Perl provides/requires in RPM
565 packages.
566
567 %description perlprov -l de.UTF-8
568 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
569
570 %description perlprov -l pl.UTF-8
571 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
572 pakietach RPM.
573
574 %package pythonprov
575 Summary:        Python macros, which simplifies creation of RPM packages with Python software
576 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
577 Group:          Applications/File
578 Requires:       %{name} = %{version}-%{release}
579 Requires:       python
580 Requires:       python-modules
581
582 %description pythonprov
583 Python macros, which simplifies creation of RPM packages with Python
584 software.
585
586 %description pythonprov -l pl.UTF-8
587 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
588 Pythonie.
589
590 %package php-pearprov
591 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
592 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
593 Group:          Applications/File
594 Requires:       %{name} = %{version}-%{release}
595 Requires:       sed >= 4.0
596
597 %description php-pearprov
598 Additional utilities for checking PHP PEAR provides/requires in RPM
599 packages.
600
601 %description php-pearprov -l pl.UTF-8
602 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
603 pakietach RPM.
604
605 %package -n python-rpm
606 Summary:        Python interface to RPM library
607 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
608 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
609 Group:          Development/Languages/Python
610 Requires:       %{name} = %{version}-%{release}
611 %pyrequires_eq  python
612 Obsoletes:      rpm-python
613
614 %description -n python-rpm
615 The rpm-python package contains a module which permits applications
616 written in the Python programming language to use the interface
617 supplied by RPM (RPM Package Manager) libraries.
618
619 This package should be installed if you want to develop Python
620 programs that will manipulate RPM packages and databases.
621
622 %description -n python-rpm -l pl.UTF-8
623 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
624 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
625
626 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
627 Pythonie programy manipulujące pakietami i bazami danych rpm.
628
629 %description -n python-rpm -l pt_BR.UTF-8
630 O pacote rpm-python contém um módulo que permite que aplicações
631 escritas em Python utilizem a interface fornecida pelas bibliotecas
632 RPM (RPM Package Manager).
633
634 Esse pacote deve ser instalado se você quiser desenvolver programas em
635 Python para manipular pacotes e bancos de dados RPM.
636
637 %package apidocs
638 Summary:        RPM API documentation and guides
639 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
640 Group:          Documentation
641
642 %description apidocs
643 Documentation for RPM API and guides in HTML format generated from rpm
644 sources by doxygen.
645
646 %description apidocs -l pl.UTF-8
647 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
648 źrodeł RPM-a przez doxygen.
649
650 %prep
651 %setup -q -n %{name}-%{version}%{?subver}
652 %patch0 -p1
653 %patch1 -p1
654 %patch2 -p1
655 %patch3 -p1
656 %patch4 -p1
657 %patch5 -p1
658 %patch6 -p1
659 %patch7 -p1
660 %patch8 -p1
661 %patch9 -p1
662 %patch10 -p1
663 %{?with_system_lua:%patch11 -p1}
664 # CHECK ME - macrofiles: ~/etc could be used
665 #%%patch14 -p1
666 %patch16 -p1
667 echo '%%define  __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
668 echo '%%define  __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
669 echo '# obsoleted file' > macros.python
670 echo '%%define  __php_provides  /usr/lib/rpm/php.prov' > macros.php
671 echo '%%define  __php_requires  /usr/lib/rpm/php.req' >> macros.php
672 echo '%%define  __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
673 echo '%%define  __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
674 install %{SOURCE9} scripts/php.prov.in
675 install %{SOURCE10} scripts/php.req.in
676 install %{SOURCE12} scripts/perl.prov
677 %patch23 -p1
678
679 %ifarch i386 i486
680 # disable TSC
681 %patch26 -p1
682 %endif
683 %patch27 -p1
684 %patch32 -p1
685 %patch34 -p1
686 %patch35 -p0
687 %patch36 -p1
688 %patch37 -p1
689 %patch42 -p1
690 %patch46 -p1
691 %patch47 -p1
692 # OLD COMMENTED OUT
693 #%%patch52 -p1 -- morearchs (rpmrc patch) adds ppc7400, ppc7400
694 %patch55 -p1
695 %patch59 -p1
696 %patch17 -p1
697 %patch18 -p1
698 %patch60 -p1
699 %ifarch sparc64
700 %patch61 -p1
701 %endif
702
703 cd scripts
704 mv -f perl.req perl.req.in
705 mv -f perl.prov perl.prov.in
706 cd ..
707
708 # generate Group translations to *.po
709 awk -f %{SOURCE6} %{SOURCE1}
710
711 # update macros paths
712 #for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
713 #       sed -e 's@lib/rpm/redhat@lib/rpm/pld@g' $f > ${f}.tmp
714 #       mv -f ${f}.tmp $f
715 #done
716
717 %build
718 %{__libtoolize}
719 #%{__autopoint}
720 %{__aclocal}
721 %{__autoheader}
722 %{__autoconf}
723 %{__automake}
724
725 # config.guess doesn't handle athlon, so we have to change it by hand.
726 # rpm checks for CPU type at runtime, but it looks better
727 #sed -i -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' -e 's|@host_cpu@|%{_target_cpu}|' macros.in
728
729 %{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
730 # pass CC and CXX too in case of building with some older configure macro
731 %configure \
732         CC="%{__newcc}" \
733         CXX="%{__newcxx}" \
734         CPP="%{__newcpp}" \
735         WITH_PERL_VERSION=no \
736         %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
737         --enable-shared \
738         --enable-static \
739         %{!?with_apidocs:--without-apidocs} \
740         %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
741         %{!?with_python:--without-python} \
742         --with%{!?with_selinux:out}-selinux \
743         --with-libelf \
744         --with-zlib=external \
745         --with-bzip2=external \
746         --with-beecrypt=external \
747         --with-lzma=external \
748         --with-neon=%{?with_neon:external}%{!?with_neon:no} \
749         --with-file=external \
750         --with-popt=external \
751         --with-db=%{?with_db:external}%{!?with_db:no} \
752         --with-sqlite=%{?with_sqlite:external}%{!?with_sqlite:no} \
753         --with-dbapi=%{!?with_sqlite_dbapi:db}%{?with_sqlite_dbapi:sqlite} \
754         --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
755         --with-pcre=no \
756         --with-keyutils=none \
757         --without-path-versioned \
758         --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.pld:%{_rpmlibdir}/macros.build:%{_rpmlibdir}/%%{_target}/macros:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:~/etc/rpmmacros:~/etc/.rpmmacros:~/.rpmmacros' \
759         --with-bugreport="http://bugs.pld-linux.org/"
760
761 %{__make} -j1 \
762         CC="%{__cc}" \
763         CXX="%{__cxx}" \
764         CPP="%{__cpp}"
765
766 %{?with_apidocs:%{__make} apidocs}
767
768 %install
769 rm -rf $RPM_BUILD_ROOT
770 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
771
772 install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
773
774 %{__make} install \
775         pkgconfigdir=%{_pkgconfigdir} \
776         DESTDIR=$RPM_BUILD_ROOT
777
778 # install ARCH macros
779 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux
780 install %{SOURCE105} $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
781
782 %ifarch %{ix86}
783 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{i386,i486,i586,i686,athlon,pentium3,pentium4}-linux
784 install %{SOURCE100} $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
785 install %{SOURCE101} $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
786 install %{SOURCE102} $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
787 install %{SOURCE103} $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
788 install %{SOURCE104} $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
789 install %{SOURCE106} $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
790 install %{SOURCE107} $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
791 %endif
792
793 %ifarch %{x8664}
794 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{x86_64,ia32e,amd64}-linux
795 install %{SOURCE109} $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
796 install %{SOURCE110} $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
797 install %{SOURCE111} $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
798 %endif
799
800 %ifarch %{ppc}
801 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux
802 install %{SOURCE108} $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
803 %endif
804
805 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
806 # first platform file entry can't contain regexps
807 %{_target_cpu}-%{_target_vendor}-linux
808
809 # x86_64 things
810 %ifarch x86_64
811 x86_64-[^-]*-[Ll]inux(-gnu)?
812 amd64-[^-]*-[Ll]inux(-gnu)?
813 %endif
814 %ifarch amd64
815 amd64-[^-]*-[Ll]inux(-gnu)?
816 x86_64-[^-]*-[Ll]inux(-gnu)?
817 %endif
818 %ifarch ia32e
819 ia32e-[^-]*-[Ll]inux(-gnu)?
820 x86_64-[^-]*-[Ll]inux(-gnu)?
821 %endif
822
823 # x86 things
824 %ifarch athlon %{x8664}
825 athlon-[^-]*-[Ll]inux(-gnu)?
826 %endif
827 %ifarch pentium4 athlon %{x8664}
828 pentium4-[^-]*-[Ll]inux(-gnu)?
829 %endif
830 %ifarch pentium3 pentium4 athlon %{x8664}
831 pentium3-[^-]*-[Ll]inux(-gnu)?
832 %endif
833 %ifarch i686 pentium3 pentium4 athlon %{x8664}
834 i686-[^-]*-[Ll]inux(-gnu)?
835 %endif
836 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
837 i586-[^-]*-[Ll]inux(-gnu)?
838 %endif
839 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
840 i486-[^-]*-[Ll]inux(-gnu)?
841 %endif
842 %ifarch %{ix86} %{x8664}
843 i386-[^-]*-[Ll]inux(-gnu)?
844 %endif
845
846 %ifarch alpha
847 alpha-[^-]*-[Ll]inux(-gnu)?
848 %endif
849
850 %ifarch ia64
851 ia64-[^-]*-[Ll]inux(-gnu)?
852 %endif
853
854 %ifarch ppc64
855 powerpc64-[^-]*-[Ll]inux(-gnu)?
856 ppc64-[^-]*-[Ll]inux(-gnu)?
857 %endif
858 %ifarch %{ppc} ppc64
859 powerpc-[^-]*-[Ll]inux(-gnu)?
860 ppc-[^-]*-[Ll]inux(-gnu)?
861 %endif
862
863 %ifarch s390x
864 s390x-[^-]*-[Ll]inux(-gnu)?
865 %endif
866 %ifarch s390 s390x
867 s390-[^-]*-[Ll]inux(-gnu)?
868 %endif
869
870 %ifarch sparc64
871 sparc64-[^-]*-[Ll]inux(-gnu)?
872 sparcv8-[^-]*-[Ll]inux(-gnu)?
873 sparcv9-[^-]*-[Ll]inux(-gnu)?
874 %endif
875 %ifarch sparcv9
876 sparcv8-[^-]*-[Ll]inux(-gnu)?
877 sparcv9-[^-]*-[Ll]inux(-gnu)?
878 %endif
879 %ifarch sparc sparcv9 sparc64
880 sparc-[^-]*-[Ll]inux(-gnu)?
881 %endif
882
883 # noarch
884 noarch-[^-]*-.*
885 EOF
886
887 %ifarch %{ppc}
888 #sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
889 #       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
890 %endif
891
892 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
893 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
894 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
895 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
896
897 # not installed since 4.4.8 (-tools-perl subpackage)
898 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
899
900 install macros.perl     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.perl
901 install macros.python   $RPM_BUILD_ROOT%{_rpmlibdir}/macros.python
902 install macros.php      $RPM_BUILD_ROOT%{_rpmlibdir}/macros.php
903 install macros.mono     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.mono
904 install %{SOURCE15}     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.java
905 install %{SOURCE18}     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.pld
906
907 install %{SOURCE1} doc/manual/groups
908 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
909 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
910 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
911 install %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/check-files
912 install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
913 install %{SOURCE16} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
914 install scripts/find-php*       $RPM_BUILD_ROOT%{_rpmlibdir}
915 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
916 install %{SOURCE20} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
917 install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
918 install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
919
920 install %{SOURCE17} $RPM_BUILD_ROOT%{_bindir}/banner.sh
921
922 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
923
924 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
925 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
926 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
927 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
928 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
929 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
930
931 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
932 # customized rpm macros - global for host
933 #
934 #%%_install_langs pl_PL:en_US
935 %%distribution PLD
936 #
937 # remove or replace with file_contexts path if you want to use custom
938 # SELinux file contexts policy instead of one stored in packages payload
939 %%_install_file_context_path    %%{nil}
940 %%_verify_file_context_path     %%{nil}
941
942 # If non-zero, all erasures will be automagically repackaged.
943 #%%_repackage_all_erasures    1
944 EOF
945
946 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles <<EOF
947 # global list of files (regexps) which don't generate Provides
948 EOF
949 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov <<EOF
950 # global list of script capabilities (regexps) not to be used in Provides
951 EOF
952 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles <<EOF
953 # global list of files (regexps) which don't generate Requires
954 ^%{_examplesdir}/
955 ^%{_docdir}/
956 EOF
957 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq <<EOF
958 # global list of script capabilities (regexps) not to be used in Requires
959 EOF
960 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
961 # global list of capabilities (SONAME, perl(module), php(module) regexps)
962 # which don't generate dependencies on package NAMES
963 # -- OpenGL implementation
964 ^libGL.so.1
965 ^libGLU.so.1
966 ^libOSMesa.so
967 # -- Glide
968 ^libglide3.so.3
969 # -- mozilla
970 ^libgtkmozembed.so
971 ^libgtksuperwin.so
972 ^libxpcom.so
973 # -- X11 implementation
974 ^libFS.so
975 ^libI810XvMC.so
976 ^libICE.so
977 ^libSM.so
978 ^libX11.so
979 ^libXRes.so
980 ^libXTrap.so
981 ^libXaw.so
982 ^libXcomposite.so
983 ^libXcursor.so
984 ^libXdamage.so
985 ^libXdmcp.so
986 ^libXevie.so
987 ^libXext.so
988 ^libXfixes.so
989 ^libXfont.so
990 ^libXfontcache.so
991 ^libXft.so
992 ^libXi.so
993 ^libXinerama.so
994 ^libXmu.so
995 ^libXmuu.so
996 ^libXp.so
997 ^libXpm.so
998 ^libXrandr.so
999 ^libXrender.so
1000 ^libXss.so
1001 ^libXt.so
1002 ^libXtst.so
1003 ^libXv.so
1004 ^libXvMC.so
1005 ^libXxf86dga.so
1006 ^libXxf86misc.so
1007 ^libXxf86rush.so
1008 ^libXxf86vm.so
1009 ^libdps.so
1010 ^libdpstk.so
1011 ^libfontenc.so
1012 ^libpsres.so
1013 ^libxkbfile.so
1014 ^libxkbui.so
1015 # -- fam / gamin
1016 ^libfam.so.0
1017 # -- mdns-bonjour: mDNSResponder-libs / avahi-compat-libdns_sd
1018 ^libdns_sd.so.1
1019 EOF
1020 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
1021 # global list of file masks not to be compressed in DOCDIR
1022 EOF
1023
1024 # for rpm -e|-U --repackage
1025 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1026 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
1027
1028 # move rpm to /bin
1029 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1030 # move essential libs to /lib (libs that /bin/rpm links to)
1031 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so; do
1032         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1033         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
1034 done
1035
1036 # Append rpm.platform contents to /usr/lib/rpm/${arch}-linux/macros
1037 for m in $RPM_BUILD_ROOT%{_rpmlibdir}/*/macros ; do
1038         cat %{SOURCE2} | %{__sed} 's#@LIB@#%{_lib}#' >> $m
1039 done
1040 # remove arch dependant macros which have no use on noarch
1041 %{__sed} -i -e '
1042 /{__spec_install_post_strip}/d
1043 /{__spec_install_post_chrpath}/d
1044 /{__spec_install_post_compress_modules}/d
1045 ' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
1046
1047 # Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1048 mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1049
1050 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1051 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
1052
1053 rm $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
1054
1055 # wrong location, not used anyway
1056 rm $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
1057 # utils dropped in 4.4.8 -- their manuals
1058 rm $RPM_BUILD_ROOT%{_mandir}/{,*/}/man8/rpmgraph.8
1059 # unpackaged in 4.4.9, reasons unknown
1060 rm $RPM_BUILD_ROOT%{_rpmlibdir}/symclash.{sh,py}
1061
1062 %find_lang %{name}
1063
1064 rm -rf manual
1065 cp -a doc/manual manual
1066 rm -f manual/Makefile*
1067
1068 %clean
1069 rm -rf $RPM_BUILD_ROOT
1070
1071 %triggerpostun lib -- %{name}-lib < %{version}
1072 rm -f /var/lib/rpm/__db*
1073
1074 %pretrans
1075 # this needs to be a dir
1076 if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
1077         umask 022
1078         mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1079         mkdir %{_sysconfdir}/rpm/sysinfo
1080 fi
1081
1082 %triggerpostun -- %{name} < 4.4.9-44
1083 %{_rpmlibdir}/hrmib-cache
1084
1085 %post   lib -p /sbin/ldconfig
1086 %postun lib -p /sbin/ldconfig
1087
1088 %pretrans build
1089 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
1090
1091 %files -f %{name}.lang
1092 %defattr(644,root,root,755)
1093 %doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
1094
1095 %dir %{_sysconfdir}/pki/rpm-gpg
1096 %{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1097
1098 %attr(755,root,root) /bin/rpm
1099 #%attr(755,root,root) %{_bindir}/rpmdb
1100 #%attr(755,root,root) %{_bindir}/rpmquery
1101 #%attr(755,root,root) %{_bindir}/rpmsign
1102 #%attr(755,root,root) %{_bindir}/rpmverify
1103
1104 %dir %{_sysconfdir}/rpm
1105 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
1106 %dir %{_sysconfdir}/rpm/sysinfo
1107 # these are ok to be replaced
1108 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
1109 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1110
1111
1112 %{_mandir}/man8/rpm.8*
1113 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1114 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1115 %lang(ko) %{_mandir}/ko/man8/rpm.8*
1116 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1117 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1118 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1119
1120 %dir /var/lib/rpm
1121 %dir %attr(700,root,root) /var/spool/repackage
1122 %dir /var/lock/rpm
1123 /var/lock/rpm/transaction
1124
1125 # exported package NVRA (stamped with install tid)
1126 # net-snmp hrSWInstalledName queries, bash-completions
1127 %dir /var/cache/hrmib
1128
1129 #%attr(755,root,root) %{_rpmlibdir}/rpmd
1130 #%{!?with_static:%attr(755,root,root) %{_rpmlibdir}/rpm[eiu]}
1131 #%attr(755,root,root) %{_rpmlibdir}/rpmk
1132 #%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
1133
1134 %{_rpmlibdir}/rpmpopt*
1135 %{_rpmlibdir}/macros
1136 %{_rpmlibdir}/macros.pld
1137
1138 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1139
1140 %files base
1141 %defattr(644,root,root,755)
1142 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1143 %dir %{_rpmlibdir}
1144 %attr(755,root,root) %{_bindir}/banner.sh
1145 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1146 %dir /var/lib/banner
1147
1148 %files lib
1149 %defattr(644,root,root,755)
1150 %attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1151 %attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1152 %attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1153 %attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
1154
1155 %files devel
1156 %defattr(644,root,root,755)
1157 %attr(755,root,root) %{_libdir}/librpm.so
1158 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1159 %attr(755,root,root) %{_libdir}/librpmbuild.so
1160 %attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
1161 %attr(755,root,root) %{_libdir}/librpmconstant.so
1162 %attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
1163 %attr(755,root,root) %{_libdir}/librpmdb.so
1164 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1165 %attr(755,root,root) %{_libdir}/librpmio.so
1166 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1167 %attr(755,root,root) %{_libdir}/librpmmisc.so
1168 %attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
1169 %{_libdir}/librpm*.la
1170 %{_includedir}/rpm
1171 %{_pkgconfigdir}/*.pc
1172
1173 %files static
1174 %defattr(644,root,root,755)
1175 %{_libdir}/librpm*.a
1176
1177 %files utils
1178 %defattr(644,root,root,755)
1179 %attr(755,root,root) %{_bindir}/rpm2cpio
1180 %attr(755,root,root) %{_bindir}/rpmcache
1181 %attr(755,root,root) %{_bindir}/rpmconstant
1182 %attr(755,root,root) %{_bindir}/rpmdigest
1183 %attr(755,root,root) %{_bindir}/rpmgrep
1184 %attr(755,root,root) %{_bindir}/rpmrepo
1185 %attr(755,root,root) %{_bindir}/rpmmtree
1186 %attr(755,root,root) %{_rpmlibdir}/debugedit
1187 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1188 %attr(755,root,root) %{_rpmlibdir}/rpmcmp
1189 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1190 %attr(755,root,root) %{_rpmlibdir}/rpmdeps
1191 %attr(755,root,root) %{_rpmlibdir}/tgpg
1192 %{_mandir}/man1/rpmgrep.1*
1193 %{_mandir}/man8/rpm2cpio.8*
1194 %{_mandir}/man8/rpmcache.8*
1195 %{_mandir}/man8/rpmdeps.8*
1196 %{_mandir}/man8/rpmmtree.8*
1197 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1198 %lang(ja) %{_mandir}/ja/man8/rpmcache.8*
1199 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1200 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1201 %lang(pl) %{_mandir}/pl/man8/rpmcache.8*
1202 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1203 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1204
1205 %files utils-perl
1206 %defattr(644,root,root,755)
1207 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1208
1209 %if %{with static}
1210 %files utils-static
1211 %defattr(644,root,root,755)
1212 %attr(755,root,root) %{_bindir}/rpm[ieu]
1213 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1214 %endif
1215
1216 %files build
1217 %defattr(644,root,root,755)
1218 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1219 %attr(755,root,root) %{_rpmlibdir}/brp-*
1220 %attr(755,root,root) %{_rpmlibdir}/check-files
1221 # %attr(755,root,root) %{_rpmlibdir}/check-prereqs
1222 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1223 #%attr(755,root,root) %{_rpmlibdir}/config.*
1224 %attr(755,root,root) %{_rpmlibdir}/cross-build
1225 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1226 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1227 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1228 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
1229 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1230 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1231 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1232 %attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
1233 # needs hacked pkg-config to return anything
1234 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1235 #%attr(755,root,root) %{_rpmlibdir}/rpmb
1236 #%attr(755,root,root) %{_rpmlibdir}/rpmt
1237 %{_rpmlibdir}/noarch-*
1238 %ifarch %{ix86}
1239 %{_rpmlibdir}/i?86*
1240 %{_rpmlibdir}/pentium*
1241 %{_rpmlibdir}/athlon*
1242 %endif
1243 %ifarch alpha
1244 %{_rpmlibdir}/alpha*
1245 %endif
1246 %ifarch ia64
1247 %{_rpmlibdir}/ia64*
1248 %endif
1249 %ifarch mips mipsel mips64 mips64el
1250 %{_rpmlibdir}/mips*
1251 %endif
1252 %ifarch %{ppc}
1253 %{_rpmlibdir}/ppc*
1254 %endif
1255 %ifarch sparc sparc64
1256 %{_rpmlibdir}/sparc*
1257 %endif
1258 %ifarch %{x8664}
1259 %{_rpmlibdir}/amd64*
1260 %{_rpmlibdir}/ia32e*
1261 %{_rpmlibdir}/x86_64*
1262 %endif
1263 # must be here for "Requires: rpm-*prov" to work
1264 %{_rpmlibdir}/macros.java
1265 %{_rpmlibdir}/macros.mono
1266 %{_rpmlibdir}/macros.perl
1267 %{_rpmlibdir}/macros.php
1268 # not used yet ... these six depend on perl
1269 #%attr(755,root,root) %{_rpmlibdir}/http.req
1270 #%attr(755,root,root) %{_rpmlibdir}/magic.prov
1271 #%attr(755,root,root) %{_rpmlibdir}/magic.req
1272 #%{_rpmlibdir}/sql.prov
1273 #%{_rpmlibdir}/sql.req
1274 #%{_rpmlibdir}/tcl.req
1275
1276 %attr(755,root,root) %{_bindir}/gendiff
1277 %attr(755,root,root) %{_bindir}/rpmbuild
1278
1279 %{_mandir}/man1/gendiff.1*
1280 %{_mandir}/man8/rpmbuild.8*
1281 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1282 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1283 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1284
1285 %files javaprov
1286 %defattr(644,root,root,755)
1287 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1288 # needs jar (any jdk), jcf-dump (gcc-java) to work
1289 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1290
1291 %files perlprov
1292 %defattr(644,root,root,755)
1293 %attr(755,root,root) %{_rpmlibdir}/perl.*
1294 #%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1295 #%attr(755,root,root) %{_rpmlibdir}/find-perl-*
1296 #%attr(755,root,root) %{_rpmlibdir}/find-*.perl
1297 #%attr(755,root,root) %{_rpmlibdir}/find-prov.pl
1298 #%attr(755,root,root) %{_rpmlibdir}/find-req.pl
1299 #%attr(755,root,root) %{_rpmlibdir}/get_magic.pl
1300
1301 %files pythonprov
1302 %defattr(644,root,root,755)
1303 %{_rpmlibdir}/macros.python
1304 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1305
1306 %files php-pearprov
1307 %defattr(644,root,root,755)
1308 %attr(755,root,root) %{_rpmlibdir}/php*
1309 %attr(755,root,root) %{_rpmlibdir}/find-php*
1310
1311 %if %{with python}
1312 %files -n python-rpm
1313 %defattr(644,root,root,755)
1314 %dir %{py_sitedir}/rpm
1315 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1316 %{py_sitedir}/rpm/*.py[co]
1317 %endif
1318
1319 %if %{with apidocs}
1320 %files apidocs
1321 %defattr(644,root,root,755)
1322 %doc apidocs
1323 %endif
This page took 0.143496 seconds and 3 git commands to generate.