]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
60ea476d8fff91f03537fa4e5ca94ad864ba380b
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
4 #   matches ELF first
5 # - repackaging when lzma is not installed (todo: fix digest signature of header)
6 #   rpmbuild computes digest when writing package to temporary file, then adds a few
7 #   tags (incl. digest) and writes whole package to destination file;
8 #   repackaging uses unchanged "immutable header" image from original rpm, also
9 #   preserving payload format and compressor from original rpm, _not_ current settings
10 #
11 # Conditional build:
12 %bcond_with     static          # build static rpm+rpmi
13 %bcond_without  apidocs         # don't generate documentation with doxygen
14 %bcond_with     autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
15 %bcond_without  python          # don't build python bindings
16 %bcond_without  selinux         # build without selinux support
17 %bcond_without  system_libmagic # don't use system libmagic
18 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
19 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
20 # force_cc              - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
21 # force_cxx             - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
22 # force_cpp             - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
23
24 # versions of required libraries
25 %define reqdb_ver       4.5.20
26 %define reqpopt_ver     1.10.8
27 %define beecrypt_ver    2:4.1.2-4
28 %define sover   4.4
29 Summary:        RPM Package Manager
30 Summary(de.UTF-8):      RPM Packet-Manager
31 Summary(es.UTF-8):      Gestor de paquetes RPM
32 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
33 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
34 Summary(ru.UTF-8):      Менеджер пакетов от RPM
35 Summary(uk.UTF-8):      Менеджер пакетів від RPM
36 Name:           rpm
37 Version:        4.4.9
38 Release:        0.1
39 License:        GPL
40 Group:          Base
41 Source0:        ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
42 # Source0-md5:  210b768006e7d88dd8a3bcd498ea27f6
43 Source1:        %{name}.groups
44 Source2:        %{name}.platform
45 Source3:        %{name}-install-tree
46 Source4:        %{name}-find-spec-bcond
47 Source5:        %{name}-find-lang
48 Source6:        %{name}-groups-po.awk
49 Source7:        %{name}-compress-doc
50 Source8:        %{name}-check-files
51 Source9:        %{name}-php-provides
52 Source10:       %{name}-php-requires
53 Source11:       %{name}.sysinfo
54 Source12:       perl.prov
55 Source13:       %{name}-user_group.sh
56 Source14:       %{name}.sysconfig
57 Source30:       builder
58 Source31:       adapter.awk
59 Source32:       pldnotify.awk
60 # http://svn.pld-linux.org/banner.sh/
61 Source33:       banner.sh
62 Patch0:         %{name}-pl.po.patch
63 Patch1:         %{name}-rpmrc.patch
64 Patch2:         %{name}-arch.patch
65 Patch3:         %{name}-rpmpopt.patch
66 Patch4:         %{name}-perl-macros.patch
67 Patch5:         %{name}-perl-req-perlfile.patch
68 Patch6:         %{name}-noexpand.patch
69 Patch7:         %{name}-scripts-closefds.patch
70 Patch8:         %{name}-python-macros.patch
71 Patch9:         %{name}-gettext-in-header.patch
72 Patch10:        %{name}-compress-doc.patch
73
74 Patch12:        %{name}-system_libs.patch
75 Patch13:        %{name}-bb-and-short-circuit.patch
76 Patch14:        %{name}-etc_dir.patch
77 Patch15:        %{name}-system_libs-more.patch
78 Patch16:        %{name}-php-deps.patch
79 Patch17:        %{name}-ldconfig-always.patch
80 Patch18:        %{name}-perl_req.patch
81 Patch19:        %{name}-link.patch
82 Patch20:        %{name}-magic-usesystem.patch
83 Patch21:        %{name}-dontneedutils.patch
84 Patch22:        %{name}-provides-dont-obsolete.patch
85 Patch23:        %{name}-pkgconfigdeps.patch
86 Patch24:        %{name}-po.patch
87 Patch25:        %{name}-glob.patch
88 Patch26:        %{name}-notsc.patch
89 Patch27:        %{name}-hack-norpmlibdep.patch
90 Patch28:        %{name}-makefile-no_myLDADD_deps.patch
91
92 Patch31:        %{name}-missing-prototypes.patch
93 Patch32:        %{name}-pld-autodep.patch
94 Patch33:        %{name}-arch-x86_64.patch
95 Patch34:        %{name}-epoch0.patch
96 Patch35:        %{name}-perl_req-INC_dirs.patch
97 Patch36:        %{name}-debuginfo.patch
98 Patch37:        %{name}-doxygen_hack.patch
99
100 Patch41:        %{name}-reduce-stack-usage.patch
101 Patch42:        %{name}-old-fileconflicts-behaviour.patch
102
103 Patch44:        %{name}-no-neon.patch
104 Patch45:        %{name}-no-sqlite.patch
105 Patch46:        %{name}-mono.patch
106
107 Patch49:        %{name}-p4.patch
108 Patch50:        %{name}-macros.patch
109 Patch51:        %{name}-cleanlibdirs.patch
110 Patch52:        %{name}-morearchs.patch
111
112 Patch55:        %{name}-truncate-cvslog.patch
113
114 Patch57:        %{name}-as_needed-fix.patch
115 Patch58:        %{name}-repackage-wo-lzma.patch
116 Patch59:        %{name}-libtool-deps.patch
117 URL:            http://wraptastic.org/
118 BuildRequires:  autoconf >= 2.57
119 BuildRequires:  automake >= 1.4
120 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
121 BuildRequires:  bzip2-devel >= 1.0.2-17
122 BuildRequires:  db-devel >= %{reqdb_ver}
123 BuildRequires:  elfutils-devel >= 0.108
124 BuildRequires:  gettext-devel >= 0.11.4-2
125 %{?with_system_libmagic:BuildRequires:  libmagic-devel}
126 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.18}
127 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
128 BuildRequires:  libstdc++-devel
129 BuildRequires:  libtool >= 1:1.4.2-9
130 %if %{with neon}
131 BuildRequires:  libxml2-devel
132 BuildRequires:  neon-devel >= 0.25.5
133 %endif
134 BuildRequires:  patch >= 2.2
135 BuildRequires:  popt-devel >= %{reqpopt_ver}
136 %{?with_python:BuildRequires:   python-devel >= 1:2.5}
137 BuildRequires:  python-modules >= 1:2.5
138 BuildRequires:  rpm-perlprov
139 %{?with_python:BuildRequires:   rpm-pythonprov}
140 BuildRequires:  zlib-devel
141 %if %{with apidocs}
142 BuildRequires:  doxygen
143 BuildRequires:  ghostscript
144 BuildRequires:  graphviz
145 BuildRequires:  tetex-pdftex
146 %endif
147 %if %{with static}
148 # Require static library only for static build
149 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
150 BuildRequires:  bzip2-static >= 1.0.2-17
151 BuildRequires:  db-static >= %{reqdb_ver}
152 BuildRequires:  elfutils-static
153 BuildRequires:  glibc-static >= 2.2.94
154 %{?with_system_libmagic:BuildRequires:  libmagic-static}
155 %{?with_selinux:BuildRequires:  libselinux-static >= 1.18}
156 BuildRequires:  popt-static >= %{reqpopt_ver}
157 BuildRequires:  zlib-static
158 %endif
159 Requires:       %{name}-base = %{version}-%{release}
160 Requires:       %{name}-lib = %{version}-%{release}
161 Requires:       beecrypt >= %{beecrypt_ver}
162 Requires:       popt >= %{reqpopt_ver}
163 %{!?with_static:Obsoletes:      rpm-utils-static}
164 Conflicts:      glibc < 2.2.92
165 # ABI changes in rpm, new poldek needed
166 Conflicts:      poldek < 0.20.1-0.20070105.0
167 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
168
169 %define         _binary_payload         w9.gzdio
170 %define         _noPayloadPrefix        1
171
172 # don't require very fresh rpm.macros to build
173 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
174 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
175 %define         ppc     ppc ppc7400 ppc7450
176 %define         x8664   amd64 ia32e x86_64
177
178 # stabilize new build environment
179 %define         __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
180 %define         __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
181 %define         __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
182
183 %define         _rpmlibdir /usr/lib/rpm
184
185 %define         specflags       -fno-strict-aliasing
186
187 %description
188 RPM is a powerful package manager, which can be used to build,
189 install, query, verify, update, and uninstall individual software
190 packages. A package consists of an archive of files, and package
191 information, including name, version, and description.
192
193 %description -l de.UTF-8
194 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
195 Installation, Anfrage, Verifizierung, Aktualisierung und
196 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
197 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
198 Beschreibung.
199
200 %description -l es.UTF-8
201 RPM es un poderoso administrador de paquetes, que puede ser usado para
202 construir, instalar, pesquisar, verificar, actualizar y desinstalar
203 paquetes individuales de software. Un paquete consiste en un
204 almacenaje de archivos, y información sobre el paquete, incluyendo
205 nombre, versión y descripción.
206
207 %description -l pl.UTF-8
208 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
209 przebudowanie, instalację czy weryfikację dowolnego pakietu.
210 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
211 plików wchodzących w skład pakietu, zależności od innych pakietów, są
212 przechowywane w bazie danych i można je uzyskać za pomocą opcji
213 odpytywania programu rpm.
214
215 %description -l pt_BR.UTF-8
216 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
217 construir, instalar, pesquisar, verificar, atualizar e desinstalar
218 pacotes individuais de software. Um pacote consiste de um conjunto de
219 arquivos e informações adicionais, incluindo nome, versão e descrição
220 do pacote, permissões dos arquivos, etc.
221
222 %description -l ru.UTF-8
223 RPM - это мощный менеджер пакетов, который может быть использован для
224 создания, инсталляции, запросов (query), проверки, обновления и
225 удаления программных пакетов. Пакет состоит из файлового архива и
226 служебной информации, включающей название, версию, описание и другие
227 данные о пакете.
228
229 %description -l uk.UTF-8
230 RPM - це потужний менеджер пакетів, що може бути використаний для
231 створення, інсталяції, запитів (query), перевірки, поновлення та
232 видалення програмних пакетів. Пакет складається з файлового архіву та
233 службової інформації, що містить назву, версію, опис та іншу
234 інформацію про пакет.
235
236 %package base
237 Summary:        RPM base package - scripts used by rpm packages themselves
238 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
239 Group:          Base
240 Requires:       filesystem
241 Obsoletes:      vserver-rpm
242
243 %description base
244 The RPM base package contains scripts used by rpm packages themselves.
245 These include:
246 - scripts for adding/removing groups and users needed for rpm
247   packages,
248 - banner.sh to display %%banner messages from rpm scriptlets.
249
250 %description base -l pl.UTF-8
251 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
252 Zawiera on:
253 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
254 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
255
256 %package lib
257 Summary:        RPMs library
258 Summary(pl.UTF-8):      Biblioteki RPM-a
259 Group:          Libraries
260 Requires:       beecrypt >= %{beecrypt_ver}
261 Requires:       db >= %{reqdb_ver}
262 %{?with_selinux:Requires:       libselinux >= 1.18}
263 %{?with_system_libmagic:Requires:       libmagic >= 1.15-2}
264 Requires:       popt >= %{reqpopt_ver}
265 Obsoletes:      rpm-libs
266 # avoid SEGV caused by mixed db versions
267 Conflicts:      poldek < 0.18.1-16
268 %{?with_suggest_tags:Suggests:  lzma}
269
270 %description lib
271 RPMs library.
272
273 %description lib -l pl.UTF-8
274 Biblioteki RPM-a.
275
276 %package devel
277 Summary:        Header files for rpm libraries
278 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
279 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
280 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
281 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
282 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
283 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
284 Group:          Development/Libraries
285 Requires:       %{name}-lib = %{version}-%{release}
286 Requires:       beecrypt-devel >= %{beecrypt_ver}
287 Requires:       bzip2-devel
288 Requires:       db-devel >= %{reqdb_ver}
289 Requires:       elfutils-devel
290 %{?with_system_libmagic:Requires:       libmagic-devel}
291 %{?with_selinux:Requires:       libselinux-devel}
292 Requires:       popt-devel >= %{reqpopt_ver}
293 Requires:       zlib-devel
294
295 %description devel
296 The RPM packaging system includes C libraries that make it easy to
297 manipulate RPM packages and databases. They are intended to ease the
298 creation of graphical package managers and other tools that need
299 intimate knowledge of RPM packages. This package contains header files
300 for these libraries.
301
302 %description devel -l de.UTF-8
303 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
304 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
305 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
306 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
307
308 %description devel -l es.UTF-8
309 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
310 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
311 facilitar la creación de administradores gráficos de paquetes y otras
312 herramientas que necesiten un conocimiento profundo de paquetes RPM.
313
314 %description devel -l pl.UTF-8
315 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
316 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
317 graficznych programów zarządzających pakietami oraz innych narzędzi,
318 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
319 zawiera pliki nagłówkowe wspomnianych bibliotek.
320
321 %description devel -l pt_BR.UTF-8
322 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
323 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
324 facilitar a criação de gerenciadores gráficos de pacotes e outras
325 ferramentas que precisem de conhecimento profundo de pacotes RPM.
326
327 %description devel -l ru.UTF-8
328 Система управления пакетами RPM содержит библиотеку C, которая
329 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
330 Эта библиотека предназначена для облегчения создания графических
331 пакетных менеджеров и других утилит, которым необходимо работать с
332 пакетами RPM.
333
334 %description devel -l uk.UTF-8
335 Система керування пакетами RPM містить бібліотеку C, котра спрощує
336 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
337 призначена для полегшення створення графічних пакетних менеджерів та
338 інших утиліт, що працюють з пакетами RPM.
339
340 %package static
341 Summary:        RPM static libraries
342 Summary(de.UTF-8):      RPMs statische Libraries
343 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
344 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
345 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
346 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
347 Group:          Development/Libraries
348 Requires:       %{name}-devel = %{version}-%{release}
349 Requires:       beecrypt-static >= %{beecrypt_ver}
350 Requires:       bzip2-static
351 Requires:       db-static >= %{reqdb_ver}
352 Requires:       elfutils-static
353 %{?with_system_libmagic:Requires:       libmagic-static}
354 Requires:       popt-static >= %{reqpopt_ver}
355 Requires:       zlib-static
356
357 %description static
358 RPM static libraries.
359
360 %description static -l de.UTF-8
361 RPMs statische Libraries.
362
363 %description static -l pl.UTF-8
364 Biblioteki statyczne RPM-a.
365
366 %description static -l pt_BR.UTF-8
367 Bibliotecas estáticas para desenvolvimento.
368
369 %description static -l ru.UTF-8
370 Система управления пакетами RPM содержит библиотеку C, которая
371 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
372 Это статическая библиотека RPM.
373
374 %description static -l uk.UTF-8
375 Система керування пакетами RPM містить бібліотеку C, котра спрощує
376 роботу з пакетами RPM та відповідними базами даних. Це статична
377 бібліотека RPM.
378
379 %package utils
380 Summary:        Additional utilities for managing rpm packages and database
381 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
382 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
383 Group:          Applications/File
384 Requires:       %{name} = %{version}-%{release}
385 Requires:       popt >= %{reqpopt_ver}
386
387 %description utils
388 Additional utilities for managing rpm packages and database.
389
390 %description utils -l de.UTF-8
391 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
392
393 %description utils -l pl.UTF-8
394 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
395
396 %package utils-perl
397 Summary:        Additional utilities for managing rpm packages and database
398 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
399 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
400 Group:          Applications/File
401 Requires:       %{name}-utils = %{version}-%{release}
402 Requires:       popt >= %{reqpopt_ver}
403
404 %description utils-perl
405 Additional utilities for managing rpm packages and database.
406
407 %description utils-perl -l de.UTF-8
408 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
409
410 %description utils-perl -l pl.UTF-8
411 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
412
413 %package utils-static
414 Summary:        Static rpm utilities
415 Summary(pl.UTF-8):      Statyczne narzędzia rpm
416 Group:          Applications/System
417 Requires:       %{name} = %{version}-%{release}
418
419 %description utils-static
420 Static rpm utilities for repairing system in case something with
421 shared libraries used by rpm become broken. Currently it contains rpmi
422 binary, which can be used to install/upgrade/remove packages without
423 using shared libraries (well, in fact with exception of NSS modules).
424
425 %description utils-static -l pl.UTF-8
426 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
427 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
428 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
429 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
430 (z wyjątkiem modułów NSS).
431
432 %package build
433 Summary:        Scripts for building binary RPM packages
434 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
435 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
436 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
437 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
438 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
439 Group:          Applications/File
440 Requires(pre):  findutils
441 Requires:       %{name}-build-macros >= 1.314
442 Requires:       %{name}-utils = %{version}-%{release}
443 Requires:       /bin/id
444 Requires:       awk
445 # we need fixed binutils for -feliminate-dwarf2-dups
446 Requires:       binutils >= 3:2.17.50.0.3-2
447 Requires:       bzip2
448 Requires:       chrpath >= 0.10-4
449 Requires:       cpio
450 Requires:       diffutils
451 Requires:       elfutils
452 Requires:       file >= 4.17
453 Requires:       fileutils
454 Requires:       findutils
455 Requires:       gcc >= 5:3.4
456 Requires:       glibc-devel
457 Requires:       grep
458 Requires:       gzip
459 Requires:       lzma
460 Requires:       make
461 Requires:       patch
462 Requires:       sed
463 Requires:       sh-utils
464 Requires:       tar
465 Requires:       textutils
466 Provides:       rpmbuild(monoautodeps)
467 Provides:       rpmbuild(noauto) = 3
468 %ifarch %{x8664}
469 Conflicts:      automake < 1:1.7.9-2
470 Conflicts:      libtool < 2:1.5-13
471 %endif
472
473 %description build
474 Scripts for building binary RPM packages.
475
476 %description build -l de.UTF-8
477 Scripts fürs Bauen binärer RPM-Pakete.
478
479 %description build -l pl.UTF-8
480 Skrypty pomocnicze do budowania binarnych RPM-ów.
481
482 %description build -l pt_BR.UTF-8
483 Este pacote contém scripts e programas executáveis que são usados para
484 construir pacotes usando o RPM.
485
486 %description build -l ru.UTF-8
487 Различные вспомогательные скрипты и исполняемые программы, которые
488 используются для сборки RPM'ов.
489
490 %description build -l uk.UTF-8
491 Різноманітні допоміжні скрипти та утиліти, які використовуються для
492 побудови RPM'ів.
493
494 %package build-tools
495 Summary:        Scripts for managing .spec files and building RPM packages
496 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
497 Summary(pl.UTF-8):      Skrypty pomocnicze do zarządznia plikami .spec i budowania RPM-ów
498 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
499 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
500 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
501 Group:          Applications/File
502 Requires:       %{name}-build = %{version}-%{release}
503 # these are optional
504 #Requires:      cvs
505 Requires:       wget
506
507 %description build-tools
508 Scripts for managing .spec files and building RPM packages.
509
510 %description build-tools -l de.UTF-8
511 Scripts fürs Bauen RPM-Pakete.
512
513 %description build-tools -l pl.UTF-8
514 Skrypty pomocnicze do zarządzania plikami .spec i do budowania RPM-ów.
515
516 %description build-tools -l pt_BR.UTF-8
517 Este pacote contém scripts e programas executáveis que são usados para
518 construir pacotes usando o RPM.
519
520 %description build-tools -l ru.UTF-8
521 Различные вспомогательные скрипты и исполняемые программы, которые
522 используются для сборки RPM'ов.
523
524 %description build-tools -l uk.UTF-8
525 Різноманітні допоміжні скрипти та утиліти, які використовуються для
526 побудови RPM'ів.
527
528 %package perlprov
529 Summary:        Additional utilities for checking perl provides/requires in rpm packages
530 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
531 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów perla w pakietach rpm
532 Group:          Applications/File
533 Requires:       %{name} = %{version}-%{release}
534 Requires:       perl-devel
535 Requires:       perl-modules
536
537 %description perlprov
538 Additional utilities for checking perl provides/requires in rpm
539 packages.
540
541 %description perlprov -l de.UTF-8
542 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
543
544 %description perlprov -l pl.UTF-8
545 Dodatkowe narzędzia do sprawdzenia zależności skryptów perla w
546 pakietach rpm.
547
548 %package pythonprov
549 Summary:        Python macros, which simplifies creation of rpm packages with Python software
550 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów rpm z programami napisanymi w Pythonie
551 Group:          Applications/File
552 Requires:       %{name} = %{version}-%{release}
553 Requires:       python
554 Requires:       python-modules
555
556 %description pythonprov
557 Python macros, which simplifies creation of rpm packages with Python
558 software.
559
560 %description pythonprov -l pl.UTF-8
561 Makra ułatwiające tworzenie pakietów rpm z programami napisanymi w
562 Pythonie.
563
564 %package php-pearprov
565 Summary:        Additional utilities for managing rpm packages and database
566 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w rpm
567 Group:          Applications/File
568 Requires:       %{name} = %{version}-%{release}
569 Requires:       sed >= 4.0
570
571 %description php-pearprov
572 Additional utilities for checking php pear provides/requires in rpm
573 packages.
574
575 %description php-pearprov -l pl.UTF-8
576 Dodatkowe narzędzia do sprawdzenia zależności skryptów php pear w
577 pakietach rpm.
578
579 %package -n python-rpm
580 Summary:        Python interface to RPM library
581 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
582 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
583 Group:          Development/Languages/Python
584 Requires:       %{name} = %{version}-%{release}
585 %pyrequires_eq  python
586 Obsoletes:      rpm-python
587
588 %description -n python-rpm
589 The rpm-python package contains a module which permits applications
590 written in the Python programming language to use the interface
591 supplied by RPM (RPM Package Manager) libraries.
592
593 This package should be installed if you want to develop Python
594 programs that will manipulate RPM packages and databases.
595
596 %description -n python-rpm -l pl.UTF-8
597 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
598 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
599
600 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
601 Pythonie programy manipulujące pakietami i bazami danych rpm.
602
603 %description -n python-rpm -l pt_BR.UTF-8
604 O pacote rpm-python contém um módulo que permite que aplicações
605 escritas em Python utilizem a interface fornecida pelas bibliotecas
606 RPM (RPM Package Manager).
607
608 Esse pacote deve ser instalado se você quiser desenvolver programas em
609 Python para manipular pacotes e bancos de dados RPM.
610
611 %package apidocs
612 Summary:        RPM API documentation and guides
613 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
614 Group:          Documentation
615
616 %description apidocs
617 Documentation for RPM API and guides in HTML format generated from rpm
618 sources by doxygen.
619
620 %description apidocs -l pl.UTF-8
621 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
622 źrodeł RPM-a przez doxygen.
623
624 %prep
625 %setup -q
626 %patch0 -p1
627 %patch1 -p1
628 %patch2 -p1
629 %patch3 -p1
630 %patch4 -p1
631 %patch5 -p1
632 %patch6 -p1
633 %patch7 -p1
634 %patch8 -p1
635 %patch9 -p1
636 %patch10 -p1
637 %patch12 -p1
638 %patch13 -p1
639 %patch14 -p1
640 %patch15 -p1
641 %patch16 -p1
642 %patch17 -p1
643 %patch18 -p1
644 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
645 #cp -f platform.in macros.pld.in # what for?
646 echo '%%define  __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
647 echo '%%define  __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
648 echo '# obsoleted file' > macros.python
649 echo '%%define  __php_provides  /usr/lib/rpm/php.prov' > macros.php
650 echo '%%define  __php_requires  /usr/lib/rpm/php.req' >> macros.php
651 echo '%%define  __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
652 echo '%%define  __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
653 install %{SOURCE5} scripts/find-lang.sh
654 install %{SOURCE9} scripts/php.prov.in
655 install %{SOURCE10} scripts/php.req.in
656 install %{SOURCE12} scripts/perl.prov
657 %patch19 -p1
658 %patch20 -p1
659 %patch21 -p1
660 %patch22 -p1
661 %patch23 -p1
662 %patch24 -p1
663 # obsolete?
664 #%patch25 -p1
665 %patch26 -p1
666 %patch27 -p1
667 %patch28 -p1
668 %patch31 -p1
669 # FIXME!
670 # %patch32 -p1
671 # needed? I doubt
672 # %patch33 -p1
673 %patch34 -p1
674 %patch35 -p0
675 %patch36 -p1
676 # FIXME
677 #%patch37 -p1
678 %patch41 -p1
679 %patch42 -p1
680 %{!?with_neon:%patch44 -p1}
681 # UPDATEME
682 #%patch45 -p1
683 %patch46 -p1
684 %patch49 -p1
685 %patch50 -p1
686 %patch51 -p1
687 #%patch52 -p1
688 %patch55 -p1
689 %patch57 -p1
690 %patch58 -p1
691 %patch59 -p1
692
693 cd scripts
694 mv -f perl.req perl.req.in
695 mv -f perl.prov perl.prov.in
696 cd ..
697
698 mv -f po/{no,nb}.po
699 mv -f po/{sr,sr@Latn}.po
700
701 rm -rf sqlite zlib db db3 popt rpmdb/db.h
702
703 # generate Group translations to *.po
704 awk -f %{SOURCE6} %{SOURCE1}
705
706 # update macros paths
707 for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
708         sed -e 's@lib/rpm/redhat@lib/rpm/pld@g' $f > ${f}.tmp
709         mv -f ${f}.tmp $f
710 done
711
712 %build
713 %if %{with system_libmagic}
714 rm -rf file
715 %else
716 cd file
717 %{__libtoolize}
718 %{__aclocal}
719 %{__autoheader}
720 %{__autoconf}
721 %{__automake}
722 cd ..
723 %endif
724
725 %{__libtoolize}
726 %{__gettextize}
727 %{__aclocal}
728 %{__autoheader}
729 %{__autoconf}
730 %{__automake}
731
732 # config.guess doesn't handle athlon, so we have to change it by hand.
733 # rpm checks for CPU type at runtime, but it looks better
734 sed -i -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' -e 's|@host_cpu@|%{_target_cpu}|' macros.in
735
736 # pass CC and CXX too in case of building with some older configure macro
737 # disable perl-RPM2 build, we have it in separate spec
738 %configure \
739         CC="%{__newcc}" \
740         CXX="%{__newcxx}" \
741         CPP="%{__newcpp}" \
742         WITH_PERL_VERSION=no \
743         %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
744         --enable-shared \
745         --enable-static \
746         %{!?with_apidocs:--without-apidocs} \
747         %{?with_python:--with-python=2.5} \
748         %{!?with_python:--without-python} \
749         %{!?with_selinux:--without-selinux} \
750         --without-db
751
752 # file_LDFLAGS, debugedit_LDADD - no need to link "file" and "debugedit" statically
753 %{__make} \
754         CC="%{__cc}" \
755         CXX="%{__cxx}" \
756         CPP="%{__cpp}" \
757         pylibdir=%{py_libdir} \
758         myLDFLAGS="%{rpmldflags}" \
759         file_LDFLAGS= \
760         debugedit_LDADD="\$(WITH_LIBELF_LIB) -lpopt" \
761         staticLDFLAGS=%{?with_static:-all-static}
762
763 %{?with_apidocs:%{__make} doxygen}
764
765 %install
766 rm -rf $RPM_BUILD_ROOT
767 install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/banner}
768
769 %{__make} install \
770         DESTDIR=$RPM_BUILD_ROOT \
771         staticLDFLAGS=%{?with_static:-all-static} \
772         pylibdir=%{py_libdir} \
773         pkgbindir="%{_bindir}"
774
775 echo "%{_target_cpu}-%{_target_vendor}-linux-gnu" > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
776
777 %ifarch %{ppc}
778 #sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
779 #       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
780 %endif
781
782 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
783 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
784 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
785
786 # not installed since 4.4.8 (-tools-perl subpackage)
787 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
788
789 install macros.perl     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.perl
790 install macros.python   $RPM_BUILD_ROOT%{_rpmlibdir}/macros.python
791 install macros.php      $RPM_BUILD_ROOT%{_rpmlibdir}/macros.php
792 install macros.mono     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.mono
793
794 install %{SOURCE1} doc/manual/groups
795 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
796 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
797 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
798 install %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/check-files
799 install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
800 install scripts/find-php*       $RPM_BUILD_ROOT%{_rpmlibdir}
801 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
802 install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
803
804 install %{SOURCE30} $RPM_BUILD_ROOT%{_bindir}/builder
805 install %{SOURCE31} $RPM_BUILD_ROOT%{_bindir}/adapter.awk
806 install %{SOURCE32} $RPM_BUILD_ROOT%{_bindir}/pldnotify.awk
807 install %{SOURCE33} $RPM_BUILD_ROOT%{_bindir}/banner.sh
808
809 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
810
811 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
812
813 # obsolete but still installed
814 rm $RPM_BUILD_ROOT%{_rpmlibdir}/rpmrc
815
816 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
817 # customized rpm macros - global for host
818 #
819 #%%_install_langs pl_PL:en_US
820 %%distribution PLD
821 #
822 # remove or replace with file_contexts path if you want to use custom
823 # SELinux file contexts policy instead of one stored in packages payload
824 %%_install_file_context_path    %%{nil}
825 %%_verify_file_context_path     %%{nil}
826
827 # If non-zero, all erasures will be automagically repackaged.
828 #%%_repackage_all_erasures    1
829 EOF
830
831 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles <<EOF
832 # global list of files (regexps) which don't generate Provides
833 EOF
834 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov <<EOF
835 # global list of script capabilities (regexps) not to be used in Provides
836 EOF
837 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles <<EOF
838 # global list of files (regexps) which don't generate Requires
839 ^%{_examplesdir}/
840 ^%{_docdir}/
841 EOF
842 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq <<EOF
843 # global list of script capabilities (regexps) not to be used in Requires
844 EOF
845 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
846 # global list of capabilities (SONAME, perl(module), php(module) regexps)
847 # which don't generate dependencies on package NAMES
848 # -- OpenGL implementation
849 ^libGL.so.1
850 ^libGLU.so.1
851 ^libOSMesa.so
852 # -- Glide
853 ^libglide3.so.3
854 # -- mozilla
855 ^libgtkmozembed.so
856 ^libgtksuperwin.so
857 ^libxpcom.so
858 # -- X11 implementation
859 ^libFS.so
860 ^libI810XvMC.so
861 ^libICE.so
862 ^libSM.so
863 ^libX11.so
864 ^libXRes.so
865 ^libXTrap.so
866 ^libXaw.so
867 ^libXcomposite.so
868 ^libXcursor.so
869 ^libXdamage.so
870 ^libXdmcp.so
871 ^libXevie.so
872 ^libXext.so
873 ^libXfixes.so
874 ^libXfont.so
875 ^libXfontcache.so
876 ^libXft.so
877 ^libXi.so
878 ^libXinerama.so
879 ^libXmu.so
880 ^libXmuu.so
881 ^libXp.so
882 ^libXpm.so
883 ^libXrandr.so
884 ^libXrender.so
885 ^libXss.so
886 ^libXt.so
887 ^libXtst.so
888 ^libXv.so
889 ^libXvMC.so
890 ^libXxf86dga.so
891 ^libXxf86misc.so
892 ^libXxf86rush.so
893 ^libXxf86vm.so
894 ^libdps.so
895 ^libdpstk.so
896 ^libfontenc.so
897 ^libpsres.so
898 ^libxkbfile.so
899 ^libxkbui.so
900 # -- fam / gamin
901 ^libfam.so.0
902 EOF
903 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
904 # global list of file masks not to be compressed in DOCDIR
905 EOF
906
907 # for rpm -e|-U --repackage
908 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
909 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
910
911 # move libs to /lib
912 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so ; do
913         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
914         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
915 done
916
917 # remove arch dependant macros which have no use on noarch
918 %{__sed} -i -e '
919 /{__spec_install_post_strip}/d
920 /{__spec_install_post_chrpath}/d
921 /{__spec_install_post_compress_modules}/d
922 ' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
923
924 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
925 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
926
927 rm -f $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
928
929 # (currently) not used or supported in PLD
930 rm -f $RPM_BUILD_ROOT%{_rpmlibdir}/{Specfile.pm,cpanflute,cpanflute2,find-provides,find-requires,freshen.sh,http.req,magic.prov,magic.req,perldeps.pl,sql.prov,sql.req,tcl.req}
931 # wrong location, not used anyway
932 rm -f $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
933 # manuals for utils dropped in 4.4.8 (?)
934 #rm -f $RPM_BUILD_ROOT%{_mandir}/{,*/}/man8/{rpmcache,rpmgraph}.8
935
936 %find_lang %{name}
937
938 rm -rf manual
939 cp -a doc/manual manual
940 rm -f manual/Makefile*
941
942 %clean
943 rm -rf $RPM_BUILD_ROOT
944
945 %post   lib -p /sbin/ldconfig
946 %postun lib -p /sbin/ldconfig
947
948 %pre build
949 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
950
951 %files -f %{name}.lang
952 %defattr(644,root,root,755)
953 %doc CHANGES CREDITS README wdj/JBJ-GPG-KEY manual/*
954
955 %attr(755,root,root) /bin/rpm
956 #%attr(755,root,root) %{_bindir}/rpmdb
957 #%attr(755,root,root) %{_bindir}/rpmquery
958 #%attr(755,root,root) %{_bindir}/rpmsign
959 #%attr(755,root,root) %{_bindir}/rpmverify
960
961 %dir %{_sysconfdir}/rpm
962 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
963 # these are ok to be replaced
964 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo
965 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
966
967
968 %{_mandir}/man8/rpm.8*
969 %lang(fr) %{_mandir}/fr/man8/rpm.8*
970 %lang(ja) %{_mandir}/ja/man8/rpm.8*
971 %lang(ko) %{_mandir}/ko/man8/rpm.8*
972 %lang(pl) %{_mandir}/pl/man8/rpm.8*
973 %lang(ru) %{_mandir}/ru/man8/rpm.8*
974 %lang(sk) %{_mandir}/sk/man8/rpm.8*
975
976 %dir /var/lib/rpm
977 %dir %attr(700,root,root) /var/spool/repackage
978 %dir /var/lock/rpm
979 /var/lock/rpm/transaction
980
981 #%attr(755,root,root) %{_rpmlibdir}/rpmd
982 #%{!?with_static:%attr(755,root,root) %{_rpmlibdir}/rpm[eiu]}
983 #%attr(755,root,root) %{_rpmlibdir}/rpmk
984 #%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
985
986 %{_rpmlibdir}/rpmpopt*
987 %{_rpmlibdir}/macros
988
989 %files base
990 %defattr(644,root,root,755)
991 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
992 %dir %{_rpmlibdir}
993 %attr(755,root,root) %{_bindir}/banner.sh
994 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
995 %dir /var/lib/banner
996
997 %files lib
998 %defattr(644,root,root,755)
999 %attr(755,root,root) /%{_lib}/librpm*-*.so
1000 %attr(755,root,root) %{_libdir}/librpm*-*.so
1001
1002 %files devel
1003 %defattr(644,root,root,755)
1004 %{_includedir}/rpm
1005 %{_libdir}/librpm*.la
1006 %attr(755,root,root) %{_libdir}/librpm.so
1007 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1008 %attr(755,root,root) %{_libdir}/librpmio.so
1009 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1010 %attr(755,root,root) %{_libdir}/librpmdb.so
1011 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1012 %attr(755,root,root) %{_libdir}/librpmbuild.so
1013
1014 %files static
1015 %defattr(644,root,root,755)
1016 %{_libdir}/librpm*.a
1017
1018 %files utils
1019 %defattr(644,root,root,755)
1020 %attr(755,root,root) %{_bindir}/debugedit
1021 %attr(755,root,root) %{_bindir}/rpm2cpio
1022 %attr(755,root,root) %{_bindir}/rpmdeps
1023 %{!?with_system_libmagic:%attr(755,root,root) %{_bindir}/rpmfile}
1024 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1025 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
1026 %attr(755,root,root) %{_rpmlibdir}/tgpg
1027 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1028 %{_mandir}/man8/rpm2cpio.8*
1029 %{_mandir}/man8/rpmdeps.8*
1030 #%{_mandir}/man8/rpmcache.8*
1031 #%{_mandir}/man8/rpmgraph.8*
1032 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1033 #%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
1034 #%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
1035 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1036 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1037 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1038 #%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
1039 #%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
1040 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1041
1042 %files utils-perl
1043 %defattr(644,root,root,755)
1044 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1045
1046 %if %{with static}
1047 %files utils-static
1048 %defattr(644,root,root,755)
1049 %attr(755,root,root) %{_bindir}/rpm[ieu]
1050 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1051 %endif
1052
1053 %files build
1054 %defattr(644,root,root,755)
1055 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1056 %attr(755,root,root) %{_rpmlibdir}/brp-*
1057 %attr(755,root,root) %{_rpmlibdir}/check-files
1058 # %attr(755,root,root) %{_rpmlibdir}/check-prereqs
1059 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1060 %attr(755,root,root) %{_rpmlibdir}/config.*
1061 %attr(755,root,root) %{_rpmlibdir}/cross-build
1062 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1063 %attr(755,root,root) %{_rpmlibdir}/find-lang.sh
1064 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1065 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1066 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
1067 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1068 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1069 # needs jar (any jdk), jcf-dump (gcc-java) to work
1070 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1071 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1072 # needs hacked pkg-config to return anything
1073 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1074 %attr(755,root,root) %{_rpmlibdir}/rpmb
1075 %attr(755,root,root) %{_rpmlibdir}/rpmt
1076 %{_rpmlibdir}/noarch-*
1077 %ifarch %{ix86}
1078 %{_rpmlibdir}/i?86*
1079 %{_rpmlibdir}/pentium*
1080 %{_rpmlibdir}/athlon*
1081 %endif
1082 %ifarch alpha
1083 %{_rpmlibdir}/alpha*
1084 %endif
1085 %ifarch ia64
1086 %{_rpmlibdir}/ia64*
1087 %endif
1088 %ifarch mips mipsel mips64 mips64el
1089 %{_rpmlibdir}/mips*
1090 %endif
1091 %ifarch %{ppc}
1092 %{_rpmlibdir}/ppc*
1093 %endif
1094 %ifarch sparc sparc64
1095 %{_rpmlibdir}/sparc*
1096 %endif
1097 %ifarch %{x8664}
1098 %{_rpmlibdir}/x86_64*
1099 %endif
1100 # must be here for "Requires: rpm-*prov" to work
1101 %{_rpmlibdir}/macros.mono
1102 %{_rpmlibdir}/macros.perl
1103 %{_rpmlibdir}/macros.php
1104 # not used yet ... these six depend on perl
1105 #%attr(755,root,root) %{_rpmlibdir}/http.req
1106 #%attr(755,root,root) %{_rpmlibdir}/magic.prov
1107 #%attr(755,root,root) %{_rpmlibdir}/magic.req
1108 #%{_rpmlibdir}/sql.prov
1109 #%{_rpmlibdir}/sql.req
1110 #%{_rpmlibdir}/tcl.req
1111
1112 %attr(755,root,root) %{_bindir}/gendiff
1113 %attr(755,root,root) %{_bindir}/rpmbuild
1114
1115 %{_mandir}/man1/gendiff.1*
1116 %{_mandir}/man8/rpmbuild.8*
1117 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1118 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1119 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1120
1121 %files build-tools
1122 %defattr(644,root,root,755)
1123 %attr(755,root,root) %{_bindir}/builder
1124 %attr(755,root,root) %{_bindir}/adapter.awk
1125 %attr(755,root,root) %{_bindir}/pldnotify.awk
1126
1127 %files perlprov
1128 %defattr(644,root,root,755)
1129 %attr(755,root,root) %{_rpmlibdir}/perl.*
1130 #%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1131 #%attr(755,root,root) %{_rpmlibdir}/find-perl-*
1132 #%attr(755,root,root) %{_rpmlibdir}/find-*.perl
1133 #%attr(755,root,root) %{_rpmlibdir}/find-prov.pl
1134 #%attr(755,root,root) %{_rpmlibdir}/find-req.pl
1135 #%attr(755,root,root) %{_rpmlibdir}/get_magic.pl
1136
1137 %files pythonprov
1138 %defattr(644,root,root,755)
1139 %{_rpmlibdir}/macros.python
1140 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1141
1142 %files php-pearprov
1143 %defattr(644,root,root,755)
1144 %attr(755,root,root) %{_rpmlibdir}/php*
1145 %attr(755,root,root) %{_rpmlibdir}/find-php*
1146
1147 %if %{with python}
1148 %files -n python-rpm
1149 %defattr(644,root,root,755)
1150 %dir %{py_sitedir}/rpm
1151 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1152 %{py_sitedir}/rpm/*.py[co]
1153 %endif
1154
1155 %if %{with apidocs}
1156 %files apidocs
1157 %defattr(644,root,root,755)
1158 %doc apidocs
1159 %endif
This page took 0.13834 seconds and 2 git commands to generate.