37fc0b20d9d4db06b7dec80e32f48ae85793c364
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
4 #
5 # Conditional build:
6 %bcond_without  apidocs         # don't generate documentation with doxygen
7 %bcond_without  python3         # don't build python bindings
8 %bcond_without  plugins         # build plugins
9 %bcond_without  recommends_tags # build without Recommends tag (bootstrapping)
10 %bcond_with     imaevm          # build with IMA/EVM support (requires libimaevm from ima-evm-utils)
11
12 %define         db_ver          5.3.28.0
13 %define         popt_ver        1.15
14 %define         sover           9.1.0
15
16  %if %{_ver_ge '%{_rpmversion}' '4.12'} && %{_ver_lt '%{_rpmversion}' '5.0'}
17  %define        with_recommends_tags
18  %endif
19
20 Summary:        RPM Package Manager
21 Summary(de.UTF-8):      RPM Packet-Manager
22 Summary(es.UTF-8):      Gestor de paquetes RPM
23 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
24 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
25 Summary(ru.UTF-8):      Менеджер пакетов от RPM
26 Summary(uk.UTF-8):      Менеджер пакетів від RPM
27 Name:           rpm
28 Version:        4.16.0
29 Release:        0.1
30 Epoch:          1
31 License:        GPL v2 / LGPL v2.1
32 Group:          Base
33 Source0:        http://ftp.rpm.org/releases/rpm-4.16.x/%{name}-%{version}.tar.bz2
34 # Source0-md5:  434e166a812e35ef181f6dd176326920
35 Source1:        ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
36 # Source1-md5:  23914bb49fafe7153cee87126d966461
37 Source2:        macros.local
38 Source3:        macros.lang
39 Source4:        %{name}.sysconfig
40 Source5:        %{name}.groups
41 Source6:        %{name}-groups-po.awk
42 Source7:        %{name}-install-tree
43 Source8:        %{name}-hrmib-cache
44 Source9:        %{name}-user_group.sh
45 # http://svn.pld-linux.org/banner.sh/
46 Source10:       banner.sh
47 Source11:       %{name}.noautoprov
48 Source12:       %{name}.noautoprovfiles
49 Source13:       %{name}.noautoreq
50 Source14:       %{name}.noautoreqfiles
51 Source15:       perl.prov
52 Source16:       %{name}db_checkversion.c
53 Source17:       %{name}db_reset.c
54 Source18:       dbupgrade.sh
55 Patch0:         %{name}-man_pl.patch
56 Patch1:         %{name}-popt-aliases.patch
57 Patch2:         %{name}-perl-macros.patch
58 Patch3:         %{name}-perl-req-perlfile.patch
59 Patch4:         %{name}-scripts-closefds.patch
60 Patch6:         %{name}-perl_req-INC_dirs.patch
61 Patch7:         %{name}-debuginfo.patch
62 Patch8:         %{name}-libtool-deps.patch
63 Patch9:         %{name}-builddir-readlink.patch
64 Patch10:        %{name}-changelog_order_check_nonfatal.patch
65 Patch11:        %{name}-postun-nofail.patch
66 Patch12:        %{name}-clean-docdir.patch
67 Patch13:        %{name}-perl-magic.patch
68 Patch14:        %{name}-ignore-missing-macro-files.patch
69 Patch15:        x32.patch
70 Patch16:        rpm5-db-compat.patch
71 Patch17:        python-internal-build.patch
72 Patch18:        rpmversion.patch
73 Patch19:        pkgconfig.patch
74 Patch20:        uname-deps.patch
75 Patch21:        aarch64.patch
76 URL:            https://rpm.org/
77 BuildRequires:  db-devel >= %{db_ver}
78 BuildRequires:  autoconf >= 2.63
79 BuildRequires:  automake >= 1.4
80 BuildRequires:  bzip2-devel >= 1.0.2-17
81 BuildRequires:  elfutils-devel >= 0.108
82 BuildRequires:  gettext-tools >= 0.19.2
83 BuildRequires:  libarchive-devel
84 BuildRequires:  libmagic-devel
85 BuildRequires:  libgcrypt-devel
86 %if %{with plugins}
87 BuildRequires:  audit-libs-devel
88 BuildRequires:  dbus-devel
89 %{?with_imaevm:BuildRequires:   libimaevm-devel >= 1.0}
90 BuildRequires:  libselinux-devel >= 2.1.0
91 %endif
92 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
93 BuildRequires:  libstdc++-devel
94 BuildRequires:  libtool >= 1:1.4.2-9
95 BuildRequires:  ossp-uuid-devel
96 BuildRequires:  patch >= 2.2
97 BuildRequires:  pkgconfig(lua) >= 5.1
98 BuildRequires:  popt-devel >= %{popt_ver}
99 BuildRequires:  python3-modules
100 %if %{with python3}
101 BuildRequires:  python3-devel
102 BuildRequires:  rpm-pythonprov
103 %endif
104 BuildRequires:  sqlite3-devel >= 3.22.0
105 BuildRequires:  tcl
106 BuildRequires:  xz-devel
107 BuildRequires:  zlib-devel
108 BuildRequires:  zstd-devel
109 %if %{with apidocs}
110 BuildRequires:  doxygen
111 BuildRequires:  ghostscript
112 BuildRequires:  graphviz
113 BuildRequires:  tetex-pdftex
114 %endif
115 Requires(posttrans):    coreutils
116 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
117 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
118 Requires:       rpm-pld-macros >= 1.744
119 Requires:       FHS >= 3.0-2
120 Requires:       libgcrypt
121 Requires:       popt >= %{popt_ver}
122 %if %{with recommends_tags}
123 Recommends:     rpm-plugin-audit
124 Recommends:     rpm-plugin-prioreset
125 Recommends:     rpm-plugin-syslog
126 Recommends:     rpm-plugin-systemd-inhibit
127 %endif
128 Obsoletes:      rpm-utils-perl
129 Obsoletes:      rpm-utils-static
130 Conflicts:      glibc < 2.2.92
131 # db4.6 poldek needed
132 Conflicts:      poldek < 0.21-0.20070703.00.3
133 # segfaults with lzma 0.42.2
134 Conflicts:      lzma-libs < 4.999.3
135 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
136 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
137
138 %define         _binary_payload         w9.gzdio
139
140 # don't require very fresh rpm.macros to build
141 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
142 %define         ix86    i386 i486 i586 i686 athlon geode pentium3 pentium4
143 %define         ppc     ppc ppc7400 ppc7450
144 %define         x8664   amd64 ia32e x86_64
145
146 %define         _rpmlibdir /usr/lib/rpm
147
148 %description
149 RPM is a powerful package manager, which can be used to build,
150 install, query, verify, update, and uninstall individual software
151 packages. A package consists of an archive of files, and package
152 information, including name, version, and description.
153
154 %description -l de.UTF-8
155 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
156 Installation, Anfrage, Verifizierung, Aktualisierung und
157 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
158 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
159 Beschreibung.
160
161 %description -l es.UTF-8
162 RPM es un poderoso administrador de paquetes, que puede ser usado para
163 construir, instalar, pesquisar, verificar, actualizar y desinstalar
164 paquetes individuales de software. Un paquete consiste en un
165 almacenaje de archivos, y información sobre el paquete, incluyendo
166 nombre, versión y descripción.
167
168 %description -l pl.UTF-8
169 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
170 przebudowanie, instalację czy weryfikację dowolnego pakietu.
171 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
172 plików wchodzących w skład pakietu, zależności od innych pakietów, są
173 przechowywane w bazie danych i można je uzyskać za pomocą opcji
174 odpytywania programu rpm.
175
176 %description -l pt_BR.UTF-8
177 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
178 construir, instalar, pesquisar, verificar, atualizar e desinstalar
179 pacotes individuais de software. Um pacote consiste de um conjunto de
180 arquivos e informações adicionais, incluindo nome, versão e descrição
181 do pacote, permissões dos arquivos, etc.
182
183 %description -l ru.UTF-8
184 RPM - это мощный менеджер пакетов, который может быть использован для
185 создания, инсталляции, запросов (query), проверки, обновления и
186 удаления программных пакетов. Пакет состоит из файлового архива и
187 служебной информации, включающей название, версию, описание и другие
188 данные о пакете.
189
190 %description -l uk.UTF-8
191 RPM - це потужний менеджер пакетів, що може бути використаний для
192 створення, інсталяції, запитів (query), перевірки, поновлення та
193 видалення програмних пакетів. Пакет складається з файлового архіву та
194 службової інформації, що містить назву, версію, опис та іншу
195 інформацію про пакет.
196
197 %package base
198 Summary:        RPM base package - scripts used by rpm packages themselves
199 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
200 Group:          Base
201 Requires:       filesystem
202 Obsoletes:      rpm-scripts
203 Obsoletes:      vserver-rpm
204
205 %description base
206 The RPM base package contains scripts used by rpm packages themselves.
207 These include:
208 - scripts for adding/removing groups and users needed for rpm
209   packages,
210 - banner.sh to display %%banner messages from rpm scriptlets.
211
212 %description base -l pl.UTF-8
213 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
214 Zawiera on:
215 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
216 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
217
218 %package lib
219 Summary:        RPMs library
220 Summary(pl.UTF-8):      Biblioteki RPM-a
221 Group:          Libraries
222 Requires:       db >= %{db_ver}
223 Requires:       libmagic >= 1.15-2
224 Requires:       popt >= %{popt_ver}
225 Obsoletes:      rpm-libs
226 # avoid SEGV caused by mixed db versions
227 Conflicts:      poldek < 0.18.1-16
228
229 %description lib
230 RPMs library.
231
232 %description lib -l pl.UTF-8
233 Biblioteki RPM-a.
234
235 %package devel
236 Summary:        Header files for rpm libraries
237 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
238 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
239 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
240 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
241 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
242 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
243 Group:          Development/Libraries
244 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
245 Requires:       bzip2-devel
246 Requires:       db-devel >= %{db_ver}
247 Requires:       elfutils-devel
248 Requires:       libmagic-devel
249 Requires:       libgcrypt-devel
250 %if %{with selinux}
251 Requires:       libselinux-devel
252 Requires:       libsemanage-devel
253 Requires:       libsepol-devel
254 %endif
255 Requires:       popt-devel >= %{popt_ver}
256 Requires:       zlib-devel
257
258 %description devel
259 The RPM packaging system includes C libraries that make it easy to
260 manipulate RPM packages and databases. They are intended to ease the
261 creation of graphical package managers and other tools that need
262 intimate knowledge of RPM packages. This package contains header files
263 for these libraries.
264
265 %description devel -l de.UTF-8
266 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
267 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
268 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
269 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
270
271 %description devel -l es.UTF-8
272 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
273 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
274 facilitar la creación de administradores gráficos de paquetes y otras
275 herramientas que necesiten un conocimiento profundo de paquetes RPM.
276
277 %description devel -l pl.UTF-8
278 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
279 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
280 graficznych programów zarządzających pakietami oraz innych narzędzi,
281 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
282 zawiera pliki nagłówkowe wspomnianych bibliotek.
283
284 %description devel -l pt_BR.UTF-8
285 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
286 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
287 facilitar a criação de gerenciadores gráficos de pacotes e outras
288 ferramentas que precisem de conhecimento profundo de pacotes RPM.
289
290 %description devel -l ru.UTF-8
291 Система управления пакетами RPM содержит библиотеку C, которая
292 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
293 Эта библиотека предназначена для облегчения создания графических
294 пакетных менеджеров и других утилит, которым необходимо работать с
295 пакетами RPM.
296
297 %description devel -l uk.UTF-8
298 Система керування пакетами RPM містить бібліотеку C, котра спрощує
299 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
300 призначена для полегшення створення графічних пакетних менеджерів та
301 інших утиліт, що працюють з пакетами RPM.
302
303 %package utils
304 Summary:        Additional utilities for managing RPM packages and database
305 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
306 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
307 Group:          Applications/File
308 Requires:       %{name} = %{epoch}:%{version}-%{release}
309 Requires:       popt >= %{popt_ver}
310 %if %{with recommends_tags}
311 Recommends:     bzip2
312 Recommends:     gzip
313 %endif
314 Conflicts:      filesystem-debuginfo < 3.0-16
315
316 %description utils
317 Additional utilities for managing RPM packages and database.
318
319 %description utils -l de.UTF-8
320 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
321
322 %description utils -l pl.UTF-8
323 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
324
325 %package build
326 Summary:        Scripts for building binary RPM packages
327 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
328 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
329 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
330 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
331 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
332 Group:          Applications/File
333 Requires(pretrans):     coreutils
334 Requires(pretrans):     findutils
335 Requires:       %{name}-utils = %{epoch}:%{version}-%{release}
336 Requires:       rpm-pld-macros-build >= 1.744
337 Requires:       /bin/id
338 Requires:       awk
339 Requires:       bzip2
340 Requires:       chrpath >= 0.10-4
341 Requires:       cpio
342 Requires:       diffutils
343 Requires:       elfutils
344 Requires:       file >= 4.17
345 Requires:       fileutils
346 Requires:       findutils
347 %ifarch athlon
348 Requires:       gcc >= 3.0.3
349 %else
350 Requires:       gcc
351 %endif
352 Requires:       glibc-devel
353 Requires:       grep
354 Requires:       gzip
355 Requires:       make
356 Requires:       patch
357 Requires:       sed >= 4.0
358 Requires:       sh-utils
359 Requires:       tar >= 1:1.22
360 Requires:       textutils
361 Requires:       which
362 Requires:       xz
363 Provides:       rpmbuild(noauto) = 3
364 %ifarch %{x8664}
365 Conflicts:      automake < 1:1.7.9-2
366 Conflicts:      libtool < 2:1.5-13
367 %endif
368
369 %description build
370 Scripts for building binary RPM packages.
371
372 %description build -l de.UTF-8
373 Scripts fürs Bauen binärer RPM-Pakete.
374
375 %description build -l pl.UTF-8
376 Skrypty pomocnicze do budowania binarnych RPM-ów.
377
378 %description build -l pt_BR.UTF-8
379 Este pacote contém scripts e programas executáveis que são usados para
380 construir pacotes usando o RPM.
381
382 %description build -l ru.UTF-8
383 Различные вспомогательные скрипты и исполняемые программы, которые
384 используются для сборки RPM'ов.
385
386 %description build -l uk.UTF-8
387 Різноманітні допоміжні скрипти та утиліти, які використовуються для
388 побудови RPM'ів.
389
390 %package perlprov
391 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
392 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
393 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
394 Group:          Applications/File
395 Requires:       %{name} = %{epoch}:%{version}-%{release}
396 Requires:       perl-Encode
397 Requires:       perl-devel
398 Requires:       perl-modules
399
400 %description perlprov
401 Additional utilities for checking Perl provides/requires in RPM
402 packages.
403
404 %description perlprov -l de.UTF-8
405 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
406
407 %description perlprov -l pl.UTF-8
408 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
409 pakietach RPM.
410
411 %package pythonprov
412 Summary:        Python macros, which simplifies creation of RPM packages with Python software
413 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
414 Group:          Applications/File
415 Requires:       %{name} = %{epoch}:%{version}-%{release}
416 Requires:       python3
417 Requires:       python3-modules
418 Requires:       python3-setuptools
419
420 %description pythonprov
421 Python macros, which simplifies creation of RPM packages with Python
422 software.
423
424 %description pythonprov -l pl.UTF-8
425 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
426 Pythonie.
427
428 %package -n python3-rpm
429 Summary:        Python 3 interface to RPM library
430 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki RPM-a
431 Summary(pt_BR.UTF-8):   Módulo Python 3 para aplicativos que manipulam pacotes RPM
432 Group:          Development/Languages/Python
433 Requires:       %{name} = %{epoch}:%{version}-%{release}
434 Requires:       python3
435 Obsoletes:      python-rpm < 1:4.16.0
436 Obsoletes:      rpm-python
437
438 %description -n python3-rpm
439 The python3-rpm package contains a module which permits applications
440 written in the Python 3 programming language to use the interface
441 supplied by RPM (RPM Package Manager) libraries.
442
443 This package should be installed if you want to develop Python 3
444 programs that will manipulate RPM packages and databases.
445
446 %description -n python3-rpm -l pl.UTF-8
447 Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
448 Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki
449 RPM-a.
450
451 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
452 Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
453
454 %description -n python3-rpm -l pt_BR.UTF-8
455 O pacote python3-rpm contém um módulo que permite que aplicações
456 escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
457 RPM (RPM Package Manager).
458
459 Esse pacote deve ser instalado se você quiser desenvolver programas em
460 Python 3 para manipular pacotes e bancos de dados RPM.
461
462 %package plugin-audit
463 Summary:        Plugin for logging audit events on package operations
464 Group:          Base
465 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
466
467 %description plugin-audit
468 Plugin for libaudit support
469
470 %package plugin-syslog
471 Summary:        Plugin for syslog functionality
472 Group:          Base
473 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
474
475 %description plugin-syslog
476 This plugin exports RPM actions to the system log.
477
478 %package plugin-systemd-inhibit
479 Summary:        Plugin for systemd inhibit functionality
480 Group:          Base
481 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
482
483 %description plugin-systemd-inhibit
484 This plugin blocks systemd from entering idle, sleep or shutdown while
485 an rpm transaction is running using the systemd-inhibit mechanism.
486
487 %package plugin-ima
488 Summary:        Plugin for IMA file signatures
489 Group:          Base
490 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
491
492 %description plugin-ima
493 This plugin adds support for enforcing and verifying IMA file
494 signatures in an rpm.
495
496 %package plugin-prioreset
497 Summary:        Plugin for resetting scriptlet priorities for SysV init
498 Group:          Base
499 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
500
501 %description plugin-prioreset
502 This plugin is useful on legacy SysV init systems if you run rpm
503 transactions with nice/ionice priorities. Should not be used on
504 systemd systems.
505
506 %package plugin-selinux
507 Summary:        Plugin for SELinux functionality
508 Group:          Base
509 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
510 Requires:       libselinux >= 2.1.0
511
512 %description plugin-selinux
513 Plugin for SELinux functionality.
514
515 %package sign
516 Summary:        Package signing support
517 Group:          Base
518 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
519
520 %description sign
521 This package contains support for digitally signing RPM packages.
522
523 %package apidocs
524 Summary:        RPM API documentation and guides
525 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
526 Group:          Documentation
527 BuildArch:      noarch
528
529 %description apidocs
530 Documentation for RPM API and guides in HTML format generated from rpm
531 sources by doxygen.
532
533 %description apidocs -l pl.UTF-8
534 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
535 źrodeł RPM-a przez doxygen.
536
537 %prep
538 %setup -q -n %{name}-%{version}%{?subver}
539 %patch0 -p1
540 %patch1 -p1
541 %patch2 -p1
542 %patch3 -p1
543 %patch4 -p1
544 %patch6 -p0
545 %patch7 -p1
546 %patch8 -p1
547 %patch9 -p1
548 %patch10 -p1
549 %patch11 -p1
550 %patch12 -p1
551 %patch13 -p1
552 %patch14 -p1
553 %patch15 -p1
554 %patch16 -p1
555 %patch17 -p1
556 %patch18 -p1
557 %patch19 -p1
558 %patch20 -p1
559 %ifarch aarch64
560 %patch21 -p1
561 %endif
562
563 install %{SOURCE15} scripts/perl.prov.in
564
565 %{__mv} -f scripts/perl.req{,.in}
566
567 # generate Group translations to *.po
568 awk -f %{SOURCE6} %{SOURCE5}
569
570 install %{SOURCE16} tools/rpmdb_checkversion.c
571 install %{SOURCE17} tools/rpmdb_reset.c
572
573 %{__sed} -i -e '1s,/usr/bin/python,%{__python3},' scripts/pythondistdeps.py
574
575 %build
576 %{__libtoolize}
577 %{__aclocal}
578 %{__autoheader}
579 %{__autoconf}
580 %{__automake}
581
582 # rpm checks for CPU type at runtime, but it looks better
583 sed -i \
584         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
585         -e 's|@host_cpu@|%{_target_cpu}|' \
586         -e 's|@host_os@|%{_target_os}|' \
587         macros.in
588
589 %configure \
590         WITH_PERL_VERSION=no \
591         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
592         __GPG=%{_bindir}/gpg \
593 %if %{with python3}
594         PYTHON=python3 \
595         --enable-python \
596 %endif
597         --disable-silent-rules \
598         --enable-shared \
599         --enable-bdb \
600         --enable-ndb \
601         --enable-sqlite \
602         --enable-zstd \
603         --with-lua \
604         %{?with_imaevm:--with-imaevm} \
605         --with-cap \
606         --with-acl \
607         --with-audit \
608         --with-archive \
609         --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
610         %{!?with_plugins:--disable-plugins} \
611         --with-vendor=pld
612
613 %{__make}
614
615 %{__cc} %{rpmcflags} tools/rpmdb_checkversion.c -o tools/rpmdb_checkversion -ldb
616 %{__cc} %{rpmcflags} tools/rpmdb_reset.c -o tools/rpmdb_reset -ldb
617
618 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
619         echo "Error linking rpmdb tools!"
620         exit 1
621 fi
622 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
623         echo "Error linking rpmdb tools!"
624         exit 1
625 fi
626
627 %if %{with python3}
628 cd python
629 %py3_build
630 %endif
631
632 %install
633 rm -rf $RPM_BUILD_ROOT
634 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
635         $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/var/cache/hrmib}
636
637 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
638
639 %{__make} install \
640         pkgconfigdir=%{_pkgconfigdir} \
641         DESTDIR=$RPM_BUILD_ROOT
642
643 # cleanup
644 %ifnarch %{ix86} %{x8664} x32
645 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
646 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
647 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
648 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
649 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
650 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
651 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
652 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
653 %endif
654
655 %ifnarch %{x8664} x32
656 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
657 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
658 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
659 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
660 %endif
661
662 %ifnarch %{ppc}
663 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
664 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
665 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
666 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
667 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
668 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
669 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
670 %endif
671
672 %ifnarch aarch64
673 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
674 %endif
675
676 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
677 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
678 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
679 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
680 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
681 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
682 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
683 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
684
685 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
686
687 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
688
689 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
690 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
691 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
692 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rpm
693
694 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/banner.sh
695
696 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
697 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
698 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
699 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
700 cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
701 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
702
703 cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
704 cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
705 cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
706
707 # move rpm to /bin
708 %{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
709 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
710 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
711
712 # move essential libs to /lib (libs that /bin/rpm links to)
713 for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
714         mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
715         ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
716 done
717
718 #./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
719
720 # Make sure we have bdb set a default backend
721 grep -qE "db_backend[[:blank:]]+bdb" $RPM_BUILD_ROOT%{_rpmlibdir}/macros
722
723 %if %{with python3}
724 # Remove anything that rpm make install might put there
725 %{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
726 cd python
727 %py3_install
728 cd ..
729 %endif
730
731 %{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
732
733 # wrong location, not used anyway
734 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
735
736 %find_lang %{name}
737
738 %clean
739 rm -rf $RPM_BUILD_ROOT
740
741 %posttrans
742 if [ -e /var/lib/rpm/Packages ] && \
743                 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
744         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
745                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
746                 echo
747                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
748                 echo
749         fi
750         echo
751         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
752         echo 'you should ignore it and restart poldek'
753         echo
754         %{_rpmlibdir}/dbupgrade.sh
755 fi
756
757 %triggerpostun -- %{name} < 4.4.9-44
758 %{_rpmlibdir}/hrmib-cache
759
760 %post   lib -p /sbin/ldconfig
761 %postun lib -p /sbin/ldconfig
762
763 %pretrans build
764 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
765
766 %files -f %{name}.lang
767 %defattr(644,root,root,755)
768 %doc ChangeLog CREDITS README
769
770 %dir /etc/pki/rpm-gpg
771 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
772
773 %attr(755,root,root) /bin/rpm
774 %attr(755,root,root) %{_bindir}/rpmdb
775 %attr(755,root,root) %{_bindir}/rpmkeys
776 %attr(755,root,root) %{_bindir}/rpmquery
777 %attr(755,root,root) %{_bindir}/rpmverify
778
779 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
780 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
781
782 %{_mandir}/man8/rpm.8*
783 %{_mandir}/man8/rpmdb.8*
784 %{_mandir}/man8/rpmkeys.8*
785 %{_mandir}/man8/rpm-misc.8*
786 %{?with_plugins:%{_mandir}/man8/rpm-plugins.8*}
787 %lang(fr) %{_mandir}/fr/man8/rpm.8*
788 %lang(ja) %{_mandir}/ja/man8/rpm.8*
789 %lang(ko) %{_mandir}/ko/man8/rpm.8*
790 %lang(pl) %{_mandir}/pl/man8/rpm.8*
791 %lang(ru) %{_mandir}/ru/man8/rpm.8*
792 %lang(sk) %{_mandir}/sk/man8/rpm.8*
793
794 %dir /var/lib/rpm
795
796 # exported package NVRA (stamped with install tid)
797 # net-snmp hrSWInstalledName queries, bash-completions
798 %dir /var/cache/hrmib
799
800 %{_rpmlibdir}/rpmpopt*
801 %{_rpmlibdir}/rpmrc
802 %{_rpmlibdir}/macros
803 %dir %{_rpmlibdir}/macros.d
804 %dir %{_rpmlibdir}/platform
805 %{_rpmlibdir}/platform/noarch-*
806 %ifarch %{ix86} %{x8664} x32
807 %{_rpmlibdir}/platform/athlon*
808 %{_rpmlibdir}/platform/geode*
809 %{_rpmlibdir}/platform/i?86*
810 %{_rpmlibdir}/platform/pentium*
811 %endif
812 %ifarch %{x8664} x32
813 %{_rpmlibdir}/platform/amd64*
814 %{_rpmlibdir}/platform/ia32e*
815 %{_rpmlibdir}/platform/x86_64*
816 %{_rpmlibdir}/platform/x32*
817 %endif
818 %ifarch alpha
819 %{_rpmlibdir}/platform/alpha*
820 %endif
821 %ifarch aarch64
822 %{_rpmlibdir}/platform/aarch64*
823 %endif
824 %ifarch ia64
825 %{_rpmlibdir}/platform/ia64*
826 %endif
827 %ifarch mips mipsel mips64 mips64el
828 %{_rpmlibdir}/platform/mips*
829 %endif
830 %ifarch %{ppc}
831 %{_rpmlibdir}/platform/ppc*
832 %endif
833 %ifarch sparc sparc64
834 %{_rpmlibdir}/platform/sparc*
835 %endif
836
837 %dir %{_rpmlibdir}/pld
838
839 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
840
841 %attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
842 %attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
843 %attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
844 %attr(755,root,root) %{_rpmlibdir}/rpmdb_dump
845 %attr(755,root,root) %{_rpmlibdir}/rpmdb_load
846
847 # valgrind suppression file for rpm
848 %{_rpmlibdir}/rpm.supp
849
850 %files base
851 %defattr(644,root,root,755)
852 %dir %{_sysconfdir}/rpm
853 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
854 %dir %{_rpmlibdir}
855 %attr(755,root,root) %{_bindir}/banner.sh
856 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
857 %dir /var/lib/banner
858
859 %files lib
860 %defattr(644,root,root,755)
861 %attr(755,root,root) /%{_lib}/librpm.so.9
862 %attr(755,root,root) /%{_lib}/librpm.so.%{sover}
863 %attr(755,root,root) /%{_lib}/librpmbuild.so.9
864 %attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
865 %attr(755,root,root) /%{_lib}/librpmio.so.9
866 %attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
867 %attr(755,root,root) /%{_lib}/librpmsign.so.9
868 %attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
869 %{?with_plugins:%dir %{_libdir}/rpm-plugins}
870
871 %files devel
872 %defattr(644,root,root,755)
873 %attr(755,root,root) %{_libdir}/librpm.so
874 %attr(755,root,root) %{_libdir}/librpmbuild.so
875 %attr(755,root,root) %{_libdir}/librpmio.so
876 %attr(755,root,root) %{_libdir}/librpmsign.so
877 %{_libdir}/librpm*.la
878 %{_includedir}/rpm
879 %{_pkgconfigdir}/*.pc
880
881 %files utils
882 %defattr(644,root,root,755)
883 %attr(755,root,root) %{_bindir}/rpm2archive
884 %attr(755,root,root) %{_bindir}/rpm2cpio
885 %attr(755,root,root) %{_bindir}/rpmgraph
886 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
887 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
888 %attr(755,root,root) %{_rpmlibdir}/tgpg
889 %attr(755,root,root) %{_rpmlibdir}/debugedit
890 %attr(755,root,root) %{_rpmlibdir}/rpmdeps
891 %{_mandir}/man8/rpm2archive.8*
892 %{_mandir}/man8/rpm2cpio.8*
893 %{_mandir}/man8/rpmdeps.8*
894 %{_mandir}/man8/rpmgraph.8*
895 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
896 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
897 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
898 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
899 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
900 %lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
901 %lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
902
903 %files build
904 %defattr(644,root,root,755)
905 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
906 %attr(755,root,root) %{_rpmlibdir}/brp-*
907 %attr(755,root,root) %{_rpmlibdir}/check-files
908 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
909 %attr(755,root,root) %{_rpmlibdir}/elfdeps
910 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
911 # needs hacked pkg-config to return anything
912 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
913 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
914
915 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
916 # must be here for "Requires: rpm-*prov" to work
917 #%{_rpmlibdir}/macros.d/cmake
918 #%{_rpmlibdir}/macros.d/gstreamer
919 #%{_rpmlibdir}/macros.d/libtool
920 #%{_rpmlibdir}/macros.d/perl
921 #%{_rpmlibdir}/macros.d/pkgconfig
922 #%{_rpmlibdir}/macros.d/python
923 #%{_rpmlibdir}/macros.d/selinux
924 #%{_rpmlibdir}/macros.d/tcl
925 #%{_rpmlibdir}/macros.rpmbuild
926
927 %attr(755,root,root) %{_rpmlibdir}/check-buildroot
928 %attr(755,root,root) %{_rpmlibdir}/check-prereqs
929 %attr(755,root,root) %{_rpmlibdir}/check-rpaths
930 %attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
931 %attr(755,root,root) %{_rpmlibdir}/find-provides
932 %attr(755,root,root) %{_rpmlibdir}/find-requires
933 %attr(755,root,root) %{_rpmlibdir}/ocamldeps.sh
934 %attr(755,root,root) %{_rpmlibdir}/script.req
935 %attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
936
937 %dir %{_rpmlibdir}/fileattrs
938 %{_rpmlibdir}/fileattrs/debuginfo.attr
939 %{_rpmlibdir}/fileattrs/desktop.attr
940 %{_rpmlibdir}/fileattrs/elf.attr
941 %{_rpmlibdir}/fileattrs/font.attr
942 %{_rpmlibdir}/fileattrs/libtool.attr
943 %{_rpmlibdir}/fileattrs/metainfo.attr
944 %{_rpmlibdir}/fileattrs/ocaml.attr
945 %{_rpmlibdir}/fileattrs/perl.attr
946 %{_rpmlibdir}/fileattrs/perllib.attr
947 %{_rpmlibdir}/fileattrs/pkgconfig.attr
948 %{_rpmlibdir}/fileattrs/python.attr
949 %{_rpmlibdir}/fileattrs/pythondist.attr
950 %{_rpmlibdir}/fileattrs/script.attr
951
952 %attr(755,root,root) %{_bindir}/gendiff
953 %attr(755,root,root) %{_bindir}/rpmbuild
954 %attr(755,root,root) %{_bindir}/rpmspec
955
956 %{_mandir}/man1/gendiff.1*
957 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
958 %{_mandir}/man8/rpmbuild.8*
959 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
960 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
961 %{_mandir}/man8/rpmspec.8*
962
963 %files perlprov
964 %defattr(644,root,root,755)
965 %attr(755,root,root) %{_rpmlibdir}/perl.*
966
967 %files pythonprov
968 %defattr(644,root,root,755)
969 %attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
970
971 %if %{with python3}
972 %files -n python3-rpm
973 %defattr(644,root,root,755)
974 %dir %{py3_sitedir}/rpm
975 %attr(755,root,root) %{py3_sitedir}/rpm/*.so
976 %{py3_sitedir}/rpm/*.py
977 %{py3_sitedir}/rpm-%{version}-py*.egg-info
978 %{py3_sitedir}/rpm/__pycache__
979 %endif
980
981 %if %{with plugins}
982 %files plugin-audit
983 %defattr(644,root,root,755)
984 %attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
985 %{_mandir}/man8/rpm-plugin-audit.8*
986
987 %files plugin-syslog
988 %defattr(644,root,root,755)
989 %attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
990 %{_mandir}/man8/rpm-plugin-syslog.8*
991
992 %files plugin-systemd-inhibit
993 %defattr(644,root,root,755)
994 %attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
995 %{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
996
997 %files plugin-ima
998 %defattr(644,root,root,755)
999 %attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
1000 %{_mandir}/man8/rpm-plugin-ima.8*
1001
1002 %files plugin-prioreset
1003 %defattr(644,root,root,755)
1004 %attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
1005 %{_mandir}/man8/rpm-plugin-prioreset.8*
1006
1007 %files plugin-selinux
1008 %defattr(644,root,root,755)
1009 %attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
1010 %{_mandir}/man8/rpm-plugin-selinux.8*
1011 %endif
1012
1013 %files sign
1014 %defattr(644,root,root,755)
1015 %attr(755,root,root) %{_bindir}/rpmsign
1016 %{_mandir}/man8/rpmsign.8*
1017
1018 %if %{with apidocs}
1019 %files apidocs
1020 %defattr(644,root,root,755)
1021 %doc doc/librpm/html/*
1022 %endif
This page took 0.56004 seconds and 2 git commands to generate.