]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
30910a59416394f75a207df1d94c5f1e03ffdac0
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - rebuild database after upgrading from rpm5
4 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
5 #
6 # Conditional build:
7 %bcond_without  apidocs         # don't generate documentation with doxygen
8 %bcond_without  python2         # don't build python bindings
9 %bcond_without  python3         # don't build python bindings
10 %bcond_without  plugins         # build plugins
11 %bcond_without  recommends_tags # build without Recommends tag (bootstrapping)
12 %bcond_with     db61            # use DB 6.1 instead of 5.3
13
14 # versions of required libraries
15 %if %{with db61}
16 %define         reqdb_pkg       db6.1
17 %define         reqdb_ver       6.1
18 %define         reqdb_pkgver    6.1.19
19 %else
20 %define         reqdb_pkg       db5.3
21 %define         reqdb_ver       5.3
22 %define         reqdb_pkgver    5.3.28.0
23 %endif
24 %define         reqpopt_ver     1.15
25 %define         openssl_ver     1.1.1d
26 %define         sover           9.0.1
27
28 Summary:        RPM Package Manager
29 Summary(de.UTF-8):      RPM Packet-Manager
30 Summary(es.UTF-8):      Gestor de paquetes RPM
31 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
32 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
33 Summary(ru.UTF-8):      Менеджер пакетов от RPM
34 Summary(uk.UTF-8):      Менеджер пакетів від RPM
35 Name:           rpm
36 Version:        4.15.1
37 Release:        0.1
38 Epoch:          1
39 License:        GPL v2 / LGPL v2.1
40 Group:          Base
41 Source0:        http://ftp.rpm.org/releases/rpm-4.15.x/%{name}-%{version}.tar.bz2
42 # Source0-md5:  ed72147451a5ed93b2a48e2f8f5413c3
43 Source1:        %{name}.groups
44 Source2:        macros.pld
45 Source3:        %{name}-install-tree
46 Source4:        %{name}-find-spec-bcond
47 Source5:        %{name}-hrmib-cache
48 Source6:        %{name}-groups-po.awk
49 Source7:        %{name}-compress-doc
50 Source8:        %{name}-php-provides
51 Source9:        %{name}-php-requires
52 Source10:       %{name}.sysinfo
53 Source11:       perl.prov
54 Source12:       %{name}-user_group.sh
55 Source13:       %{name}.sysconfig
56 Source14:       %{name}-java-requires
57 # http://svn.pld-linux.org/banner.sh/
58 Source15:       banner.sh
59 Source16:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
60 # Source16-md5: 23914bb49fafe7153cee87126d966461
61 Source17:       %{name}-mimetypedeps
62 Source18:       macros.local
63 Source19:       %{name}.noautocompressdoc
64 Source20:       %{name}.noautoprov
65 Source21:       %{name}.noautoprovfiles
66 Source22:       %{name}.noautoreq
67 Source24:       %{name}.noautoreqfiles
68 Source25:       %{name}-php-requires.php
69 Source26:       %{name}db_checkversion.c
70 Source27:       macros.lang
71 Source28:       %{name}db_reset.c
72 Source29:       dbupgrade.sh
73 Source30:       rubygems.rb
74 Source31:       gem_helper.rb
75 Patch0:         %{name}-man_pl.patch
76 Patch1:         %{name}-popt-aliases.patch
77 Patch2:         %{name}-perl-macros.patch
78 Patch3:         %{name}-perl-req-perlfile.patch
79 Patch4:         %{name}-scripts-closefds.patch
80 Patch5:         %{name}-php-macros.patch
81 Patch6:         %{name}-lua.patch
82 Patch7:         %{name}-perl_req-INC_dirs.patch
83 Patch8:         %{name}-debuginfo.patch
84 Patch9:         %{name}-javadeps.patch
85 Patch10:        %{name}-libtool-deps.patch
86 Patch11:        %{name}-builddir-readlink.patch
87 Patch12:        %{name}-changelog_order_check_nonfatal.patch
88 Patch13:        %{name}-postun-nofail.patch
89 Patch14:        %{name}-clean-docdir.patch
90 Patch15:        %{name}-perl-magic.patch
91 Patch16:        %{name}-ignore-missing-macro-files.patch
92 Patch17:        x32.patch
93 Patch18:        %{name}-fix-compress-doc.patch
94 Patch20:        rpm5-db-compat.patch
95 Patch21:        python-internal-build.patch
96 URL:            https://rpm.org/
97 BuildRequires:  %{reqdb_pkg}-devel >= %{reqdb_pkgver}
98 BuildRequires:  %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
99 BuildRequires:  autoconf >= 2.63
100 BuildRequires:  automake >= 1.4
101 BuildRequires:  bzip2-devel >= 1.0.2-17
102 BuildRequires:  elfutils-devel >= 0.108
103 BuildRequires:  gettext-tools >= 0.19.2
104 BuildRequires:  libarchive-devel
105 BuildRequires:  libmagic-devel
106 BuildRequires:  openssl-devel >= %{openssl_ver}
107 %if %{with plugins}
108 BuildRequires:  audit-libs-devel
109 BuildRequires:  dbus-devel
110 BuildRequires:  libselinux-devel >= 2.1.0
111 %endif
112 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
113 BuildRequires:  libstdc++-devel
114 BuildRequires:  libtool >= 1:1.4.2-9
115 BuildRequires:  lua53-devel >= 5.3.5
116 BuildRequires:  ossp-uuid-devel
117 BuildRequires:  patch >= 2.2
118 BuildRequires:  popt-devel >= %{reqpopt_ver}
119 %{?with_python2:BuildRequires:  python-devel >= 1:2.3}
120 %{?with_python3:BuildRequires:  python3-devel}
121 BuildRequires:  python-modules >= 1:2.3
122 %if %{with python2} || %{with python3}
123 BuildRequires:  rpm-pythonprov
124 %endif
125 BuildRequires:  tcl
126 BuildRequires:  xz-devel
127 BuildRequires:  zlib-devel
128 BuildRequires:  zstd-devel
129 %if %{with apidocs}
130 BuildRequires:  doxygen
131 BuildRequires:  ghostscript
132 BuildRequires:  graphviz
133 BuildRequires:  tetex-pdftex
134 %endif
135 Requires(posttrans):    coreutils
136 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
137 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
138 Requires:       FHS >= 3.0-2
139 Requires:       openssl >= %{openssl_ver}
140 Requires:       popt >= %{reqpopt_ver}
141 %if %{with recommends_tags}
142 Recommends:     rpm-plugin-audit
143 Recommends:     rpm-plugin-prioreset
144 Recommends:     rpm-plugin-syslog
145 Recommends:     rpm-plugin-systemd-inhibit
146 %endif
147 Provides:       rpm-db-ver = %{reqdb_ver}
148 Obsoletes:      rpm-getdeps
149 Obsoletes:      rpm-utils-perl
150 Obsoletes:      rpm-utils-static
151 Conflicts:      glibc < 2.2.92
152 # db4.6 poldek needed
153 Conflicts:      poldek < 0.21-0.20070703.00.3
154 # segfaults with lzma 0.42.2
155 Conflicts:      lzma-libs < 4.999.3
156 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
157 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
158
159 %define         _binary_payload         w9.gzdio
160
161 # don't require very fresh rpm.macros to build
162 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
163 %define         ix86    i386 i486 i586 i686 athlon geode pentium3 pentium4
164 %define         ppc     ppc ppc7400 ppc7450
165 %define         x8664   amd64 ia32e x86_64
166
167 %define         _rpmlibdir /usr/lib/rpm
168 %define         _noautocompressdoc      RPM-GPG-KEY
169
170 %description
171 RPM is a powerful package manager, which can be used to build,
172 install, query, verify, update, and uninstall individual software
173 packages. A package consists of an archive of files, and package
174 information, including name, version, and description.
175
176 %description -l de.UTF-8
177 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
178 Installation, Anfrage, Verifizierung, Aktualisierung und
179 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
180 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
181 Beschreibung.
182
183 %description -l es.UTF-8
184 RPM es un poderoso administrador de paquetes, que puede ser usado para
185 construir, instalar, pesquisar, verificar, actualizar y desinstalar
186 paquetes individuales de software. Un paquete consiste en un
187 almacenaje de archivos, y información sobre el paquete, incluyendo
188 nombre, versión y descripción.
189
190 %description -l pl.UTF-8
191 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
192 przebudowanie, instalację czy weryfikację dowolnego pakietu.
193 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
194 plików wchodzących w skład pakietu, zależności od innych pakietów, są
195 przechowywane w bazie danych i można je uzyskać za pomocą opcji
196 odpytywania programu rpm.
197
198 %description -l pt_BR.UTF-8
199 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
200 construir, instalar, pesquisar, verificar, atualizar e desinstalar
201 pacotes individuais de software. Um pacote consiste de um conjunto de
202 arquivos e informações adicionais, incluindo nome, versão e descrição
203 do pacote, permissões dos arquivos, etc.
204
205 %description -l ru.UTF-8
206 RPM - это мощный менеджер пакетов, который может быть использован для
207 создания, инсталляции, запросов (query), проверки, обновления и
208 удаления программных пакетов. Пакет состоит из файлового архива и
209 служебной информации, включающей название, версию, описание и другие
210 данные о пакете.
211
212 %description -l uk.UTF-8
213 RPM - це потужний менеджер пакетів, що може бути використаний для
214 створення, інсталяції, запитів (query), перевірки, поновлення та
215 видалення програмних пакетів. Пакет складається з файлового архіву та
216 службової інформації, що містить назву, версію, опис та іншу
217 інформацію про пакет.
218
219 %package base
220 Summary:        RPM base package - scripts used by rpm packages themselves
221 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
222 Group:          Base
223 Requires:       filesystem
224 Obsoletes:      rpm-scripts
225 Obsoletes:      vserver-rpm
226
227 %description base
228 The RPM base package contains scripts used by rpm packages themselves.
229 These include:
230 - scripts for adding/removing groups and users needed for rpm
231   packages,
232 - banner.sh to display %%banner messages from rpm scriptlets.
233
234 %description base -l pl.UTF-8
235 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
236 Zawiera on:
237 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
238 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
239
240 %package lib
241 Summary:        RPMs library
242 Summary(pl.UTF-8):      Biblioteki RPM-a
243 Group:          Libraries
244 Requires:       %{reqdb_pkg} >= %{reqdb_pkgver}
245 Requires:       %{reqdb_pkg}-sql >= %{reqdb_pkgver}
246 Requires:       libmagic >= 1.15-2
247 Requires:       openssl >= %{openssl_ver}
248 Requires:       popt >= %{reqpopt_ver}
249 Obsoletes:      rpm-libs
250 # avoid SEGV caused by mixed db versions
251 Conflicts:      poldek < 0.18.1-16
252
253 %description lib
254 RPMs library.
255
256 %description lib -l pl.UTF-8
257 Biblioteki RPM-a.
258
259 %package devel
260 Summary:        Header files for rpm libraries
261 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
262 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
263 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
264 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
265 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
266 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
267 Group:          Development/Libraries
268 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
269 Requires:       %{reqdb_pkg}-devel >= %{reqdb_pkgver}
270 Requires:       bzip2-devel
271 Requires:       elfutils-devel
272 Requires:       libmagic-devel
273 Requires:       openssl-devel >= %{openssl_ver}
274 %if %{with selinux}
275 Requires:       libselinux-devel
276 Requires:       libsemanage-devel
277 Requires:       libsepol-devel
278 %endif
279 Requires:       popt-devel >= %{reqpopt_ver}
280 Requires:       zlib-devel
281
282 %description devel
283 The RPM packaging system includes C libraries that make it easy to
284 manipulate RPM packages and databases. They are intended to ease the
285 creation of graphical package managers and other tools that need
286 intimate knowledge of RPM packages. This package contains header files
287 for these libraries.
288
289 %description devel -l de.UTF-8
290 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
291 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
292 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
293 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
294
295 %description devel -l es.UTF-8
296 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
297 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
298 facilitar la creación de administradores gráficos de paquetes y otras
299 herramientas que necesiten un conocimiento profundo de paquetes RPM.
300
301 %description devel -l pl.UTF-8
302 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
303 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
304 graficznych programów zarządzających pakietami oraz innych narzędzi,
305 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
306 zawiera pliki nagłówkowe wspomnianych bibliotek.
307
308 %description devel -l pt_BR.UTF-8
309 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
310 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
311 facilitar a criação de gerenciadores gráficos de pacotes e outras
312 ferramentas que precisem de conhecimento profundo de pacotes RPM.
313
314 %description devel -l ru.UTF-8
315 Система управления пакетами RPM содержит библиотеку C, которая
316 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
317 Эта библиотека предназначена для облегчения создания графических
318 пакетных менеджеров и других утилит, которым необходимо работать с
319 пакетами RPM.
320
321 %description devel -l uk.UTF-8
322 Система керування пакетами RPM містить бібліотеку C, котра спрощує
323 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
324 призначена для полегшення створення графічних пакетних менеджерів та
325 інших утиліт, що працюють з пакетами RPM.
326
327 %package utils
328 Summary:        Additional utilities for managing RPM packages and database
329 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
330 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
331 Group:          Applications/File
332 Requires:       %{name} = %{epoch}:%{version}-%{release}
333 Requires:       popt >= %{reqpopt_ver}
334 %if %{with recommends_tags}
335 Recommends:     bzip2
336 Recommends:     gzip
337 %endif
338 Conflicts:      filesystem-debuginfo < 3.0-16
339
340 %description utils
341 Additional utilities for managing RPM packages and database.
342
343 %description utils -l de.UTF-8
344 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
345
346 %description utils -l pl.UTF-8
347 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
348
349 %package build
350 Summary:        Scripts for building binary RPM packages
351 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
352 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
353 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
354 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
355 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
356 Group:          Applications/File
357 Requires(pretrans):     coreutils
358 Requires(pretrans):     findutils
359 Requires:       %{name}-build-macros >= 1.712
360 Requires:       %{name}-utils = %{epoch}:%{version}-%{release}
361 Requires:       /bin/id
362 Requires:       awk
363 Requires:       bzip2
364 Requires:       chrpath >= 0.10-4
365 Requires:       cpio
366 Requires:       diffutils
367 Requires:       elfutils
368 Requires:       file >= 4.17
369 Requires:       fileutils
370 Requires:       findutils
371 %ifarch athlon
372 Requires:       gcc >= 3.0.3
373 %else
374 Requires:       gcc
375 %endif
376 Requires:       glibc-devel
377 Requires:       grep
378 Requires:       gzip
379 Requires:       make
380 Requires:       patch
381 Requires:       sed >= 4.0
382 Requires:       sh-utils
383 Requires:       tar >= 1:1.22
384 Requires:       textutils
385 Requires:       which
386 Requires:       xz
387 Provides:       rpmbuild(monoautodeps)
388 Provides:       rpmbuild(noauto) = 3
389 %ifarch %{x8664}
390 Conflicts:      automake < 1:1.7.9-2
391 Conflicts:      libtool < 2:1.5-13
392 %endif
393
394 %description build
395 Scripts for building binary RPM packages.
396
397 %description build -l de.UTF-8
398 Scripts fürs Bauen binärer RPM-Pakete.
399
400 %description build -l pl.UTF-8
401 Skrypty pomocnicze do budowania binarnych RPM-ów.
402
403 %description build -l pt_BR.UTF-8
404 Este pacote contém scripts e programas executáveis que são usados para
405 construir pacotes usando o RPM.
406
407 %description build -l ru.UTF-8
408 Различные вспомогательные скрипты и исполняемые программы, которые
409 используются для сборки RPM'ов.
410
411 %description build -l uk.UTF-8
412 Різноманітні допоміжні скрипти та утиліти, які використовуються для
413 побудови RPM'ів.
414
415 %package javaprov
416 Summary:        Additional utilities for checking Java provides/requires in RPM packages
417 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
418 Group:          Applications/File
419 Requires:       %{name} = %{epoch}:%{version}-%{release}
420 Requires:       file
421 Requires:       findutils >= 1:4.2.26
422 Requires:       mktemp
423 Requires:       unzip
424
425 %description javaprov
426 Additional utilities for checking Java provides/requires in RPM
427 packages.
428
429 %description javaprov -l pl.UTF-8
430 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
431 RPM.
432
433 %package perlprov
434 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
435 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
436 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
437 Group:          Applications/File
438 Requires:       %{name} = %{epoch}:%{version}-%{release}
439 Requires:       perl-Encode
440 Requires:       perl-devel
441 Requires:       perl-modules
442
443 %description perlprov
444 Additional utilities for checking Perl provides/requires in RPM
445 packages.
446
447 %description perlprov -l de.UTF-8
448 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
449
450 %description perlprov -l pl.UTF-8
451 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
452 pakietach RPM.
453
454 %package pythonprov
455 Summary:        Python macros, which simplifies creation of RPM packages with Python software
456 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
457 Group:          Applications/File
458 Requires:       %{name} = %{epoch}:%{version}-%{release}
459 Requires:       python
460 Requires:       python-modules
461 Requires:       python-setuptools
462
463 %description pythonprov
464 Python macros, which simplifies creation of RPM packages with Python
465 software.
466
467 %description pythonprov -l pl.UTF-8
468 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
469 Pythonie.
470
471 %package php-pearprov
472 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
473 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
474 Group:          Applications/File
475 Requires:       %{name} = %{epoch}:%{version}-%{release}
476 Requires:       sed >= 4.0
477 Suggests:       php-pear-PHP_CompatInfo
478
479 %description php-pearprov
480 Additional utilities for checking PHP PEAR provides/requires in RPM
481 packages.
482
483 %description php-pearprov -l pl.UTF-8
484 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
485 pakietach RPM.
486
487 %package rubyprov
488 Summary:        Ruby tools, which simplify creation of RPM packages with Ruby software
489 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
490 Group:          Applications/File
491 Requires:       %{name} = %{epoch}:%{version}-%{release}
492 Requires:       ruby
493 Requires:       ruby-modules
494 Requires:       ruby-rubygems
495
496 %description rubyprov
497 Ruby tools, which simplifies creation of RPM packages with Ruby
498 software.
499
500 %description rubyprov -l pl.UTF-8
501 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
502 Ruby.
503
504 %package -n python-rpm
505 Summary:        Python interface to RPM library
506 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
507 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
508 Group:          Development/Languages/Python
509 Requires:       %{name} = %{epoch}:%{version}-%{release}
510 Requires:       python
511 Obsoletes:      rpm-python
512
513 %description -n python-rpm
514 The python-rpm package contains a module which permits applications
515 written in the Python programming language to use the interface
516 supplied by RPM (RPM Package Manager) libraries.
517
518 This package should be installed if you want to develop Python
519 programs that will manipulate RPM packages and databases.
520
521 %description -n python-rpm -l pl.UTF-8
522 Pakiet python-rpm zawiera moduł, który pozwala aplikacjom napisanym w
523 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
524
525 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
526 Pythonie programy manipulujące pakietami i bazami danych rpm.
527
528 %description -n python-rpm -l pt_BR.UTF-8
529 O pacote python-rpm contém um módulo que permite que aplicações
530 escritas em Python utilizem a interface fornecida pelas bibliotecas
531 RPM (RPM Package Manager).
532
533 Esse pacote deve ser instalado se você quiser desenvolver programas em
534 Python para manipular pacotes e bancos de dados RPM.
535
536 %package -n python3-rpm
537 Summary:        Python 3 interface to RPM library
538 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki RPM-a
539 Summary(pt_BR.UTF-8):   Módulo Python 3 para aplicativos que manipulam pacotes RPM
540 Group:          Development/Languages/Python
541 Requires:       %{name} = %{epoch}:%{version}-%{release}
542 Requires:       python3
543
544 %description -n python3-rpm
545 The python3-rpm package contains a module which permits applications
546 written in the Python 3 programming language to use the interface
547 supplied by RPM (RPM Package Manager) libraries.
548
549 This package should be installed if you want to develop Python 3
550 programs that will manipulate RPM packages and databases.
551
552 %description -n python3-rpm -l pl.UTF-8
553 Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
554 Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki RPM-a.
555
556 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
557 Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
558
559 %description -n python3-rpm -l pt_BR.UTF-8
560 O pacote python3-rpm contém um módulo que permite que aplicações
561 escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
562 RPM (RPM Package Manager).
563
564 Esse pacote deve ser instalado se você quiser desenvolver programas em
565 Python 3 para manipular pacotes e bancos de dados RPM.
566
567 %package plugin-audit
568 Summary:        Plugin for logging audit events on package operations
569 Group:          System/Base
570 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
571
572 %description plugin-audit
573 Plugin for libaudit support
574
575 %package plugin-syslog
576 Summary:        Plugin for syslog functionality
577 Group:          System/Base
578 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
579
580 %description plugin-syslog
581 This plugin exports RPM actions to the system log.
582
583 %package plugin-systemd-inhibit
584 Summary:        Plugin for systemd inhibit functionality
585 Group:          System/Base
586 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
587
588 %description plugin-systemd-inhibit
589 This plugin blocks systemd from entering idle, sleep or shutdown while
590 an rpm transaction is running using the systemd-inhibit mechanism.
591
592 %package plugin-ima
593 Summary:        Plugin for IMA file signatures
594 Group:          Base
595 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
596
597 %description plugin-ima
598 This plugin adds support for enforcing and verifying IMA file
599 signatures in an rpm.
600
601 %package plugin-prioreset
602 Summary:        Plugin for resetting scriptlet priorities for SysV init
603 Group:          Base
604 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
605
606 %description plugin-prioreset
607 This plugin is useful on legacy SysV init systems if you run rpm
608 transactions with nice/ionice priorities. Should not be used on
609 systemd systems.
610
611 %package plugin-selinux
612 Summary:        Plugin for SELinux functionality
613 Group:          Base
614 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
615 Requires:       libselinux >= 2.1.0
616
617 %description plugin-selinux
618 Plugin for SELinux functionality.
619
620 %package sign
621 Summary:        Package signing support
622 Group:          Base
623 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
624
625 %description sign
626 This package contains support for digitally signing RPM packages.
627
628 %package apidocs
629 Summary:        RPM API documentation and guides
630 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
631 Group:          Documentation
632 BuildArch:      noarch
633
634 %description apidocs
635 Documentation for RPM API and guides in HTML format generated from rpm
636 sources by doxygen.
637
638 %description apidocs -l pl.UTF-8
639 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
640 źrodeł RPM-a przez doxygen.
641
642 %prep
643 %setup -q -n %{name}-%{version}%{?subver}
644 %patch0 -p1
645 %patch1 -p1
646 %patch2 -p1
647 %patch3 -p1
648 %patch4 -p1
649 %patch5 -p1
650 %patch6 -p1
651 %patch7 -p0
652 %patch8 -p1
653 %patch9 -p1
654 %patch10 -p1
655 %patch11 -p1
656 %patch12 -p1
657 %patch13 -p1
658 %patch14 -p1
659 %patch15 -p1
660 %patch16 -p1
661 %patch17 -p1
662 #%patch18 -p1
663 %patch20 -p1
664 %patch21 -p1
665
666 install %{SOURCE8} scripts/php.prov.in
667 install %{SOURCE9} scripts/php.req.in
668 install %{SOURCE11} scripts/perl.prov.in
669 cp -p %{SOURCE30} scripts/rubygems.rb
670 cp -p %{SOURCE31} scripts/gem_helper.rb
671
672 %{__mv} -f scripts/perl.req{,.in}
673
674 # generate Group translations to *.po
675 awk -f %{SOURCE6} %{SOURCE1}
676
677 install %{SOURCE26} tools/rpmdb_checkversion.c
678 install %{SOURCE28} tools/rpmdb_reset.c
679
680 %{__sed} -i -e '1s,/usr/bin/python,%{__python},' scripts/pythondistdeps.py
681
682 %build
683 %{__libtoolize}
684 %{__aclocal}
685 %{__autoheader}
686 %{__autoconf}
687 %{__automake}
688
689 # rpm checks for CPU type at runtime, but it looks better
690 sed -i \
691         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
692         -e 's|@host_cpu@|%{_target_cpu}|' \
693         -e 's|@host_os@|%{_target_os}|' \
694         macros.in
695
696 CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
697 %configure \
698         WITH_PERL_VERSION=no \
699         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
700         __GPG=%{_bindir}/gpg \
701         %{?with_python3:PYTHON=python3} \
702         %{!?with_python3:%{?with_python2:PYTHON=python2}} \
703         --disable-silent-rules \
704         --enable-shared \
705         --enable-bdb \
706         --enable-zstd \
707         --with-crypto=openssl \
708         --with-lua \
709         --with-cap \
710         --with-acl \
711         --with-audit \
712         --with-archive \
713 %if %{with python2} || %{with python3}
714         --enable-python \
715 %endif
716         --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
717         %{!?with_plugins:--disable-plugins} \
718         --with-vendor=pld
719
720 #  --enable-ndb (EXPERIMENTAL) enable the new rpm database format
721 #  --enable-lmdb=[yes/no/auto] (EXPERIMENTAL) build with LMDB rpm database format support (default=auto)
722 #  --with-imaevm           build with imaevm support
723
724 %{__make}
725
726 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
727         -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
728 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
729         -o tools/rpmdb_reset -ldb-%{reqdb_ver}
730
731 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
732         echo "Error linking rpmdb tools!"
733         exit 1
734 fi
735 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
736         echo "Error linking rpmdb tools!"
737         exit 1
738 fi
739
740 %if %{with python2}
741 cd python
742 %py_build
743 cd ..
744 %endif
745
746 %if %{with python3}
747 cd python
748 %py3_build
749 %endif
750
751 %install
752 rm -rf $RPM_BUILD_ROOT
753 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
754         $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/var/cache/hrmib}
755
756 cp -p %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
757
758 %{__make} install \
759         pkgconfigdir=%{_pkgconfigdir} \
760         DESTDIR=$RPM_BUILD_ROOT
761
762 # cleanup
763 %ifnarch %{ix86} %{x8664} x32
764 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
765 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
766 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
767 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
768 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
769 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
770 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
771 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
772 %endif
773
774 %ifnarch %{x8664} x32
775 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
776 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
777 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
778 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
779 %endif
780
781 %ifnarch %{ppc}
782 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
783 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
784 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
785 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
786 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
787 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
788 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
789 %endif
790
791 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
792 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
793 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
794 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
795 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
796 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
797 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
798 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
799 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
800
801 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
802
803 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
804 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_rpmlibdir}/pld/macros
805
806 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
807 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
808 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
809 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
810 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
811 cp -p scripts/php.{prov,req}    $RPM_BUILD_ROOT%{_rpmlibdir}
812 cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
813 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
814 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
815 cp -p %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
816
817 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
818
819 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
820
821 cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
822 cp -p %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
823 cp -p %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
824 cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
825 cp -p %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
826 cp -p %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
827 cp -p %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
828
829 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
830 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
831 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
832 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
833 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
834 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
835
836 cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
837 cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
838 cp -p %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
839
840 # move rpm to /bin
841 %{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
842 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
843 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
844
845 # move essential libs to /lib (libs that /bin/rpm links to)
846 for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
847         mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
848         ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
849 done
850
851 #./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
852
853 %if %{with python2}
854 # Remove anything that rpm make install might put there
855 %{__rm} -rf $RPM_BUILD_ROOT%{py_sitedir}
856 cd python
857 %py_install
858 %py_postclean
859 cd ..
860 %endif
861
862 %if %{with python3}
863 # Remove anything that rpm make install might put there
864 %{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
865 cd python
866 %py3_install
867 cd ..
868 %endif
869
870 %{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
871
872 # wrong location, not used anyway
873 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
874
875 %find_lang %{name}
876
877 %clean
878 rm -rf $RPM_BUILD_ROOT
879
880 %pretrans
881 # this needs to be a dir
882 if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
883         umask 022
884         mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
885         mkdir %{_sysconfdir}/rpm/sysinfo
886 fi
887
888 %posttrans
889 if [ -e /var/lib/rpm/Packages ] && \
890                 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
891         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
892                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
893                 echo
894                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
895                 echo
896         fi
897         echo
898         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
899         echo 'you should ignore it and restart poldek'
900         echo
901         %{_rpmlibdir}/dbupgrade.sh
902 fi
903
904 %triggerpostun -- %{name} < 4.4.9-44
905 %{_rpmlibdir}/hrmib-cache
906
907 %post   lib -p /sbin/ldconfig
908 %postun lib -p /sbin/ldconfig
909
910 %pretrans build
911 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
912
913 %files -f %{name}.lang
914 %defattr(644,root,root,755)
915 %doc ChangeLog CREDITS README
916
917 %dir /etc/pki/rpm-gpg
918 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
919
920 %attr(755,root,root) /bin/rpm
921 %attr(755,root,root) %{_bindir}/rpmdb
922 %attr(755,root,root) %{_bindir}/rpmkeys
923 %attr(755,root,root) %{_bindir}/rpmquery
924 %attr(755,root,root) %{_bindir}/rpmverify
925
926 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
927 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
928 %dir %{_sysconfdir}/rpm/sysinfo
929 # these are ok to be replaced
930 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
931
932 %{_mandir}/man8/rpm.8*
933 %{_mandir}/man8/rpmdb.8*
934 %{_mandir}/man8/rpmkeys.8*
935 %{_mandir}/man8/rpm-misc.8*
936 %lang(fr) %{_mandir}/fr/man8/rpm.8*
937 %lang(ja) %{_mandir}/ja/man8/rpm.8*
938 %lang(ko) %{_mandir}/ko/man8/rpm.8*
939 %lang(pl) %{_mandir}/pl/man8/rpm.8*
940 %lang(ru) %{_mandir}/ru/man8/rpm.8*
941 %lang(sk) %{_mandir}/sk/man8/rpm.8*
942
943 %dir /var/lib/rpm
944
945 # exported package NVRA (stamped with install tid)
946 # net-snmp hrSWInstalledName queries, bash-completions
947 %dir /var/cache/hrmib
948
949 %{_rpmlibdir}/rpmpopt*
950 %{_rpmlibdir}/rpmrc
951 %{_rpmlibdir}/macros
952 %dir %{_rpmlibdir}/macros.d
953 %dir %{_rpmlibdir}/platform
954 %{_rpmlibdir}/platform/noarch-*
955 %ifarch %{ix86} %{x8664} x32
956 %{_rpmlibdir}/platform/athlon*
957 %{_rpmlibdir}/platform/geode*
958 %{_rpmlibdir}/platform/i?86*
959 %{_rpmlibdir}/platform/pentium*
960 %endif
961 %ifarch %{x8664} x32
962 %{_rpmlibdir}/platform/amd64*
963 %{_rpmlibdir}/platform/ia32e*
964 %{_rpmlibdir}/platform/x86_64*
965 %{_rpmlibdir}/platform/x32*
966 %endif
967 %ifarch alpha
968 %{_rpmlibdir}/platform/alpha*
969 %endif
970 %ifarch ia64
971 %{_rpmlibdir}/platform/ia64*
972 %endif
973 %ifarch mips mipsel mips64 mips64el
974 %{_rpmlibdir}/platform/mips*
975 %endif
976 %ifarch %{ppc}
977 %{_rpmlibdir}/platform/ppc*
978 %endif
979 %ifarch sparc sparc64
980 %{_rpmlibdir}/platform/sparc*
981 %endif
982
983 %{_rpmlibdir}/pld/macros
984
985 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
986
987 %attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
988 %attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
989 %attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
990
991 # valgrind suppression file for rpm
992 %{_rpmlibdir}/rpm.supp
993
994 %files base
995 %defattr(644,root,root,755)
996 %dir %{_sysconfdir}/rpm
997 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
998 %dir %{_rpmlibdir}
999 %attr(755,root,root) %{_bindir}/banner.sh
1000 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1001 %dir /var/lib/banner
1002
1003 %files lib
1004 %defattr(644,root,root,755)
1005 %attr(755,root,root) /%{_lib}/librpm.so.9
1006 %attr(755,root,root) /%{_lib}/librpm.so.%{sover}
1007 %attr(755,root,root) /%{_lib}/librpmbuild.so.9
1008 %attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
1009 %attr(755,root,root) /%{_lib}/librpmio.so.9
1010 %attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
1011 %attr(755,root,root) /%{_lib}/librpmsign.so.9
1012 %attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
1013 %{?with_plugins:%dir %{_libdir}/rpm-plugins}
1014
1015 %files devel
1016 %defattr(644,root,root,755)
1017 %attr(755,root,root) %{_libdir}/librpm.so
1018 %attr(755,root,root) %{_libdir}/librpmbuild.so
1019 %attr(755,root,root) %{_libdir}/librpmio.so
1020 %attr(755,root,root) %{_libdir}/librpmsign.so
1021 %{_libdir}/librpm*.la
1022 %{_includedir}/rpm
1023 %{_pkgconfigdir}/*.pc
1024
1025 %files utils
1026 %defattr(644,root,root,755)
1027 %attr(755,root,root) %{_bindir}/rpm2archive
1028 %attr(755,root,root) %{_bindir}/rpm2cpio
1029 %attr(755,root,root) %{_bindir}/rpmgraph
1030 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
1031 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1032 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1033 %attr(755,root,root) %{_rpmlibdir}/tgpg
1034 %attr(755,root,root) %{_rpmlibdir}/debugedit
1035 %attr(755,root,root) %{_rpmlibdir}/rpmdeps
1036 %{_mandir}/man8/rpm2cpio.8*
1037 %{_mandir}/man8/rpmdeps.8*
1038 %{_mandir}/man8/rpmgraph.8*
1039 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1040 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1041 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1042 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1043 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1044 %lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
1045 %lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
1046
1047 %files build
1048 %defattr(644,root,root,755)
1049 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1050 %attr(755,root,root) %{_rpmlibdir}/brp-*
1051 %attr(755,root,root) %{_rpmlibdir}/check-files
1052 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1053 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1054 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1055 %attr(755,root,root) %{_rpmlibdir}/elfdeps
1056 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1057 %attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
1058 # needs hacked pkg-config to return anything
1059 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1060 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
1061 # we always used scripts provided by mono-devel, maybe move them here
1062 #%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1063 #%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
1064
1065 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
1066 # must be here for "Requires: rpm-*prov" to work
1067 #%{_rpmlibdir}/macros.d/cmake
1068 #%{_rpmlibdir}/macros.d/gstreamer
1069 #%{_rpmlibdir}/macros.d/java
1070 #%{_rpmlibdir}/macros.d/libtool
1071 #%{_rpmlibdir}/macros.d/mono
1072 #%{_rpmlibdir}/macros.d/perl
1073 #%{_rpmlibdir}/macros.d/php
1074 #%{_rpmlibdir}/macros.d/pkgconfig
1075 #%{_rpmlibdir}/macros.d/python
1076 #%{_rpmlibdir}/macros.d/ruby
1077 #%{_rpmlibdir}/macros.d/selinux
1078 #%{_rpmlibdir}/macros.d/tcl
1079 #%{_rpmlibdir}/macros.rpmbuild
1080
1081 %attr(755,root,root) %{_rpmlibdir}/check-buildroot
1082 %attr(755,root,root) %{_rpmlibdir}/check-prereqs
1083 %attr(755,root,root) %{_rpmlibdir}/check-rpaths
1084 %attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
1085 %attr(755,root,root) %{_rpmlibdir}/debuginfo.prov
1086 %attr(755,root,root) %{_rpmlibdir}/desktop-file.prov
1087 %attr(755,root,root) %{_rpmlibdir}/find-provides
1088 %attr(755,root,root) %{_rpmlibdir}/find-requires
1089 %attr(755,root,root) %{_rpmlibdir}/metainfo.prov
1090 %attr(755,root,root) %{_rpmlibdir}/ocaml-find-provides.sh
1091 %attr(755,root,root) %{_rpmlibdir}/ocaml-find-requires.sh
1092 %attr(755,root,root) %{_rpmlibdir}/script.req
1093 %attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
1094 # Fedora has this in -build, but shouldn't this be in -devel?
1095 %attr(755,root,root) %{_rpmlibdir}/config.guess
1096 %attr(755,root,root) %{_rpmlibdir}/config.sub
1097
1098 %dir %{_rpmlibdir}/fileattrs
1099 %{_rpmlibdir}/fileattrs/debuginfo.attr
1100 %{_rpmlibdir}/fileattrs/desktop.attr
1101 %{_rpmlibdir}/fileattrs/elf.attr
1102 %{_rpmlibdir}/fileattrs/font.attr
1103 %{_rpmlibdir}/fileattrs/java.attr
1104 %{_rpmlibdir}/fileattrs/libtool.attr
1105 %{_rpmlibdir}/fileattrs/metainfo.attr
1106 %{_rpmlibdir}/fileattrs/ocaml.attr
1107 %{_rpmlibdir}/fileattrs/perl.attr
1108 %{_rpmlibdir}/fileattrs/perllib.attr
1109 %{_rpmlibdir}/fileattrs/php.attr
1110 %{_rpmlibdir}/fileattrs/pkgconfig.attr
1111 %{_rpmlibdir}/fileattrs/python.attr
1112 %{_rpmlibdir}/fileattrs/pythondist.attr
1113 %{_rpmlibdir}/fileattrs/script.attr
1114
1115 %attr(755,root,root) %{_bindir}/gendiff
1116 %attr(755,root,root) %{_bindir}/rpmbuild
1117 %attr(755,root,root) %{_bindir}/rpmspec
1118
1119 %{_mandir}/man1/gendiff.1*
1120 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1121 %{_mandir}/man8/rpmbuild.8*
1122 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1123 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1124 %{_mandir}/man8/rpmspec.8*
1125
1126 %files javaprov
1127 %defattr(644,root,root,755)
1128 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1129 # needs jar (any jdk), jcf-dump (gcc-java) to work
1130 #%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1131
1132 %files rubyprov
1133 %defattr(644,root,root,755)
1134 #%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1135 #%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1136
1137 %files perlprov
1138 %defattr(644,root,root,755)
1139 %attr(755,root,root) %{_rpmlibdir}/perl.*
1140
1141 %files pythonprov
1142 %defattr(644,root,root,755)
1143 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1144 %attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
1145
1146 %files php-pearprov
1147 %defattr(644,root,root,755)
1148 %attr(755,root,root) %{_rpmlibdir}/php.prov
1149 %attr(755,root,root) %{_rpmlibdir}/php.req
1150 %attr(755,root,root) %{_rpmlibdir}/php.req.php
1151
1152 %if %{with python2}
1153 %files -n python-rpm
1154 %defattr(644,root,root,755)
1155 %dir %{py_sitedir}/rpm
1156 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1157 %{py_sitedir}/rpm/*.py[co]
1158 %{py_sitedir}/rpm-%{version}-py*.egg-info
1159 %endif
1160
1161 %if %{with python3}
1162 %files -n python3-rpm
1163 %defattr(644,root,root,755)
1164 %dir %{py3_sitedir}/rpm
1165 %attr(755,root,root) %{py3_sitedir}/rpm/*.so
1166 %{py3_sitedir}/rpm/*.py
1167 %{py3_sitedir}/rpm-%{version}-py*.egg-info
1168 %{py3_sitedir}/rpm/__pycache__
1169 %endif
1170
1171 %if %{with plugins}
1172 %files plugin-audit
1173 %defattr(644,root,root,755)
1174 %attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
1175
1176 %files plugin-syslog
1177 %defattr(644,root,root,755)
1178 %attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
1179
1180 %files plugin-systemd-inhibit
1181 %defattr(644,root,root,755)
1182 %attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
1183 %{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
1184
1185 %files plugin-ima
1186 %defattr(644,root,root,755)
1187 %attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
1188
1189 %files plugin-prioreset
1190 %defattr(644,root,root,755)
1191 %attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
1192
1193 %files plugin-selinux
1194 %defattr(644,root,root,755)
1195 %attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
1196 %endif
1197
1198 %files sign
1199 %defattr(644,root,root,755)
1200 %attr(755,root,root) %{_bindir}/rpmsign
1201 %{_mandir}/man8/rpmsign.8*
1202
1203 %if %{with apidocs}
1204 %files apidocs
1205 %defattr(644,root,root,755)
1206 %doc doc/librpm/html/*
1207 %endif
This page took 0.129603 seconds and 2 git commands to generate.