- db_buffer_small patch is needed with db6.0 too (up to 3 retries needed:
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4 #   returns -ENOSYS
5 # - add macros for some ppc, mipsel, alpha and sparc
6 #
7 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
8 #
9 # Conditional build:
10 %bcond_with     static          # build static rpm+rpmi
11 %bcond_without  apidocs         # don't generate documentation with doxygen
12 %bcond_without  python          # don't build python bindings
13 %bcond_without  selinux         # build without selinux support
14 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
15 %bcond_with     db60            # use DB 6.0 instead of 5.2
16 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
17 %bcond_with     sqlite          # build with SQLite support
18 %bcond_with     system_lua      # use system lua
19 %bcond_with     keyutils        # build with keyutils support
20 # force_cc              - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
21 # force_cxx             - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
22 # force_cpp             - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
23 #
24
25 %if %{with sqlite}
26 # Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
27 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
28 %endif
29
30 # versions of required libraries
31 %if %{with db60}
32 %define         reqdb_pkg       db6.0
33 %define         reqdb_ver       6.0
34 %define         reqdb_pkgver    6.0.20
35 %else
36 %define         reqdb_pkg       db5.2
37 %define         reqdb_ver       5.2
38 %define         reqdb_pkgver    5.2.36.0-4
39 %endif
40 %define         reqpopt_ver     1.15
41 %define         beecrypt_ver    2:4.2.0
42 %define         sover           5.4
43
44 Summary:        RPM Package Manager
45 Summary(de.UTF-8):      RPM Packet-Manager
46 Summary(es.UTF-8):      Gestor de paquetes RPM
47 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
48 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
49 Summary(ru.UTF-8):      Менеджер пакетов от RPM
50 Summary(uk.UTF-8):      Менеджер пакетів від RPM
51 Name:           rpm
52 Version:        5.4.13
53 Release:        3
54 License:        LGPL v2.1
55 Group:          Base
56 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.13-0.20130819.src.rpm
57 Source0:        %{name}-%{version}.tar.gz
58 # Source0-md5:  4ce4ab33a4d5f1fcb13afcc494c92c07
59 Source100:      cpu-os-macros.tar.gz
60 # Source100-md5:        928034a5bdceb398881bc14b5f29973b
61 Source1:        %{name}.groups
62 Source2:        macros.pld.in
63 Source3:        %{name}-install-tree
64 Source4:        %{name}-find-spec-bcond
65 Source5:        %{name}-hrmib-cache
66 Source6:        %{name}-groups-po.awk
67 Source7:        %{name}-compress-doc
68 Source8:        %{name}-php-provides
69 Source9:        %{name}-php-requires
70 Source10:       %{name}.sysinfo
71 Source11:       perl.prov
72 Source12:       %{name}-user_group.sh
73 Source13:       %{name}.sysconfig
74 Source14:       %{name}-java-requires
75 # http://svn.pld-linux.org/banner.sh/
76 Source15:       banner.sh
77 Source16:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
78 # Source16-md5: 08b29584dd349aac9caa7610131a0a88
79 Source17:       %{name}-mimetypedeps
80 Source18:       macros.local
81 Source19:       %{name}.noautocompressdoc
82 Source20:       %{name}.noautoprov
83 Source21:       %{name}.noautoprovfiles
84 Source22:       %{name}.noautoreq
85 Source24:       %{name}.noautoreqfiles
86 Source25:       %{name}-php-requires.php
87 Source26:       %{name}db_checkversion.c
88 Source27:       macros.lang
89 Source28:       %{name}db_reset.c
90 Source29:       dbupgrade.sh
91 Patch0:         %{name}-branch.patch
92 Patch1:         %{name}-man_pl.patch
93 Patch2:         %{name}-popt-aliases.patch
94 Patch3:         %{name}-nosetproctitle.patch
95 Patch4:         %{name}-perl-macros.patch
96 Patch5:         %{name}-perl-req-perlfile.patch
97 Patch6:         %{name}-scripts-closefds.patch
98 Patch7:         %{name}-php-macros.patch
99 Patch8:         %{name}-gettext-in-header.patch
100 Patch9:         %{name}-lua.patch
101 Patch10:        %{name}-php-deps.patch
102 Patch11:        %{name}-notsc.patch
103 Patch12:        %{name}-hack-norpmlibdep.patch
104 Patch13:        %{name}-dont-copy-descriptive-tags.patch
105 Patch14:        %{name}-perl_req-INC_dirs.patch
106 Patch15:        %{name}-debuginfo.patch
107 Patch16:        vendor-pld.patch
108 Patch17:        %{name}-old-fileconflicts-behaviour.patch
109 Patch18:        %{name}-javadeps.patch
110 Patch19:        %{name}-truncate-cvslog.patch
111 Patch20:        %{name}-libtool-deps.patch
112 Patch21:        %{name}-mimetype.patch
113 Patch22:        %{name}-sparc64.patch
114 Patch23:        %{name}-gendiff.patch
115 Patch24:        openmp.patch
116 Patch25:        %{name}-URPM-build-fix.patch
117 Patch27:        %{name}-helperEVR-noassert.patch
118 Patch28:        %{name}-unglobal.patch
119 Patch29:        %{name}-builddir-readlink.patch
120 Patch30:        %{name}-changelog_order_check_nonfatal.patch
121 Patch31:        %{name}-cleanbody.patch
122 Patch32:        %{name}-dirdeps-macro.patch
123 Patch33:        %{name}-installbeforeerase.patch
124 Patch34:        %{name}-libmagic-locale.patch
125 Patch35:        %{name}-namespace-compare.patch
126 Patch36:        %{name}-popt-coreutils.patch
127 Patch37:        %{name}-postun-nofail.patch
128 Patch38:        %{name}-silence-RPM_CHAR_TYPE.patch
129 Patch39:        %{name}-fix-missing-types-in-headers.patch
130 Patch40:        %{name}-fix--p-interpreter-and-empty-script.patch
131 Patch41:        %{name}-db_buffer_small.patch
132 Patch42:        %{name}-pattern_Release.patch
133 Patch43:        %{name}-fix-___build_pre-macro.patch
134 Patch44:        %{name}-missing-patch-file-fails-build.patch
135 Patch45:        %{name}-remove-misleading-missing-patch-message.patch
136 Patch46:        %{name}-file-magic-can-be-mixed-case.patch
137 Patch47:        %{name}-query-always-noisy.patch
138 Patch48:        %{name}-verify-ghosts-broken-logic.patch
139 Patch49:        %{name}-python-enable-compat-RPMSENSE.patch
140 Patch50:        %{name}-dont-treat-gstreamer-modules-as-font.patch
141 Patch51:        %{name}-gst-inspect-typo.patch
142 Patch52:        %{name}-null-term-ascii-digest.patch
143 Patch53:        %{name}-lua-enable-extra-libs.patch
144 Patch54:        %{name}-fix-filedigests-verify.patch
145 Patch55:        %{name}-disable-hmac-verify.patch
146 Patch56:        %{name}-macros.patch
147 Patch57:        %{name}-db5.2.patch
148 Patch58:        %{name}-preserve-iterator.patch
149 Patch60:        %{name}-python-sitescriptdir.patch
150 Patch61:        %{name}-clean-docdir.patch
151 Patch62:        %{name}-DB_CONFIG.patch
152 Patch63:        %{name}-pythoneggs.patch
153 Patch64:        %{name}-fix-compress-doc.patch
154 Patch65:        %{name}-parseSpec-skip-empty-tags.patch
155 Patch66:        %{name}-payload-use-hashed-inode.patch
156 Patch67:        %{name}-repackage-dont-force-max-compression.patch
157 Patch68:        rubyprov-archdirs.patch
158 Patch69:        rubyprov-abi-versioned.patch
159 Patch70:        python-%{name}sense-missingok.patch
160 Patch71:        %{name}-changelog-encoding.patch
161 Patch72:        %{name}-preserve-tag-type.patch
162 Patch73:        gem_helper-spec-arg.patch
163 Patch74:        %{name}-fix-internal-lua-build.patch
164 Patch75:        %{name}-double_check_file_deps.patch
165 Patch76:        %{name}-revert-debugedit-breakage.patch
166 Patch77:        %{name}-lua-expat.patch
167 Patch78:        %{name}-double_check_unpackaged_subdirs.patch
168
169 # Patches imported from Mandriva
170
171 # status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
172 # would basically just mean backporting it..
173 Patch1000:      %{name}-5.4.4-add-_specfile-macro.patch
174 # status: needs to be cleaned up and properly reviewed together with rest
175 # of the patches related to dependency generation
176 Patch1001:      %{name}-5.4.9-avoid-dependencies-on-self.patch
177 # status: probably ready to merge
178 Patch1002:      %{name}-5.4.4-pkgconfigdeps-check-path.patch
179 # status: probably okay to merge, but discuss on rpm-devel first
180 Patch1003:      %{name}-5.4.4-glob-wildcards-for-loading-macro-files.patch
181 # status: needs to be discussed
182 Patch1004:      %{name}-5.4.4-allow-installation-of-repackaged-rpms.patch
183 # status: ready to merge
184 Patch1005:      %{name}-5.4.8-dont-show-suggests-with-requires.patch
185 # status: ready for merge
186 Patch1006:      %{name}-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
187 # status: probably okay to merge, but discuss on rpm-devel first
188 Patch1007:      %{name}-5.4.10-duplicate_files_terminate_build.patch
189 # status: same as above
190 Patch1008:      %{name}-5.4.10-unpackaged_subdirs_terminate_build.patch
191 # mdvbz#64898
192 # status: uncertain, might be okay to merge, discuss on rpm-devel first
193 Patch1009:      %{name}-5.4.4-rpmbuild-withoutclean.patch
194 # no sense in having an additional dependency on 'pkgconfig' on all packages that
195 # have a pkgconfig file, it's not needed for them to be made useful and anything
196 # actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
197 # status: might be okay to merge, but discuss on rpm-devel first
198 Patch1010:      %{name}-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
199 # status: ready for merge
200 Patch1011:      %{name}-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
201 # $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
202 # %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
203 # status: needs to be discussed and investigated a bit better..
204 Patch1012:      %{name}-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
205 # status: probably okay to merge, but discuss on rpm-devel first
206 Patch1013:      %{name}-5.4.10-files-listed-twice-terminates-build.patch
207 # status: probably okay to merge
208 Patch1014:      %{name}-5.4.9-ruby1.9-fixes.patch
209 # status: keep locally
210 Patch1015:      %{name}-5.4.9-keep-loading-script-macros.patch
211 # status: same as for other dep gen patches
212 Patch1016:      %{name}-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
213 # status: idem
214 Patch1017:      %{name}-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
215 # status: ready for merge
216 Patch1018:      %{name}-5.4.5-rubygems-add-missing-newline.patch
217 # status: probably okay to merge
218 Patch1019:      %{name}-5.4.5-python-export-spec-macros.patch
219 # status: idem
220 Patch1020:      %{name}-5.4.9-font-provides.patch
221 # stauus: idem
222 Patch1021:      %{name}-5.4.7-kmod-dependencies.patch
223 # status: probably okay to merge, discuss on rpm-devel first
224 Patch1022:      %{name}-5.4.5-skip-dependencies-for-character-devices.patch
225 # status: ready to merge
226 Patch1023:      %{name}-5.4.5-rpmfc-use-strlen-not-sizeof.patch
227 # status: probably okay to merge
228 Patch1024:      %{name}-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
229 # status: probably okay to merge
230 Patch1026:      %{name}-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
231 # status: ready
232 Patch1027:      %{name}-5.4.7-fix-generation-of-ruby-abi-provides.patch
233 # crash reproducable with 'rpm -qa --triggers'
234 # status: ready
235 Patch1028:      %{name}-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
236 # status: same as for other dep gen patches
237 Patch1029:      %{name}-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
238 # status: ready
239 Patch1030:      %{name}-5.4.7-fix-minor-memleaks.patch
240 # status: ready
241 Patch1031:      %{name}-5.4.9-mire-fix-strings-lacking-null-terminator.patch
242 # status: ready
243 Patch1032:      %{name}-5.4.9-rpmpython-fix-input.patch
244 # status: ready
245 Patch1033:      %{name}-5.4.7-no-seqid_init-on-rdonly-database.patch
246 # status: probably ready for merging
247 Patch1034:      %{name}-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
248 # status: probably ready to merge, discuss on rpm-devel first
249 Patch1035:      %{name}-5.4.9-fix-verify-segfault.patch
250 # status: ready and should be merged
251 Patch1036:      %{name}-5.4.9-fix-typo-in-rpmtag-header.patch
252 # Due to rpmdav/neon being written in a different fashion than other rpmio clients,
253 # the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
254 # with the result being that when unable to download files, neon will save error
255 # page as the target file.
256 # status: should go upstream, but uncertain about "correct" fix, ie. this is
257 # more of a workaround, while rewriting rpmdav code to behave consistently
258 # would be "the right thing to do". Yet I'm not fully able to grasp all of the
259 # code and don't want to spend more time just to get the API..
260 Patch1037:      %{name}-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
261 # As the transaction flags for ignoring arch & os are no longer used, there's
262 # currently no way to ignore arch & os of packages anymore. This patch adds
263 # support for doing this again by defining rpm variables and overriding
264 # --ignorearch & --ignoreos to set these.
265 # status: needs to be discussed upstream before thinking about merging
266 Patch1038:      %{name}-5.4.10-support-ignore-arch-and-os-again.patch
267 # status: ready for merge
268 Patch1039:      %{name}-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
269 # we want that patch too, a bit of builder infrastructure relies on NOSIGNATURES
270 Patch1040:      %{name}-5.4.9-support-signatures-and-digest-disablers.patch
271 # lack insight on actual functionality, which anyways seems broken, so let's
272 # disable it to avoid errors from berkeley db..
273 # status: keep locally
274 Patch1041:      %{name}-5.4.9-disable-l10ndir.patch
275 # status: ready for merge
276 Patch1042:      %{name}-5.4.9-fix-rpm_qa-pattern.patch
277 # warning: introduces memory leak
278 Patch1043:      %{name}-5.4.12-copy-Value-string.patch
279 Patch1044:      %{name}-5.4.12-fix-rpmlua-print.patch
280 Patch1045:      %{name}-5.4.12-fix-rpmpython-module-import-init.patch
281 Patch1046:      %{name}-5.4.12-truncate-output-buffer-after-use.patch
282 Patch1047:      %{name}-5.4.13-perl-bindings-do-not-use-xmalloc.patch
283 Patch1048:      %{name}-5.4.13-dont-override-existing-variables-with-etc-os-release.patch
284
285 URL:            http://rpm5.org/
286 BuildRequires:  %{reqdb_pkg}-devel >= %{reqdb_pkgver}
287 %if %{with sqlite}
288 BuildRequires:  sqlite3-devel
289 %else
290 BuildRequires:  %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
291 %endif
292 BuildRequires:  autoconf >= 2.60
293 BuildRequires:  automake >= 1.4
294 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
295 BuildRequires:  bzip2-devel >= 1.0.2-17
296 BuildRequires:  elfutils-devel >= 0.108
297 #BuildRequires: gettext-autopoint >= 0.11.4-2
298 BuildRequires:  gettext-devel >= 0.11.4-2
299 %{?with_keyutils:BuildRequires: keyutils-devel}
300 BuildRequires:  libmagic-devel
301 %if %{with selinux}
302 BuildRequires:  libselinux-devel >= 2.1.0
303 BuildRequires:  libsemanage-devel >= 2.1.0
304 BuildRequires:  libsepol-devel >= 2.1.0
305 %endif
306 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
307 BuildRequires:  libstdc++-devel
308 BuildRequires:  libtool >= 1:1.4.2-9
309 %if %{with neon}
310 BuildRequires:  libxml2-devel
311 BuildRequires:  neon-devel >= 0.25.5
312 %endif
313 %{?with_system_lua:BuildRequires:       lua52-devel >= 5.2.2}
314 BuildRequires:  ossp-uuid-devel
315 BuildRequires:  patch >= 2.2
316 BuildRequires:  popt-devel >= %{reqpopt_ver}
317 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
318 BuildRequires:  python-modules >= 1:2.3
319 %{?with_python:BuildRequires:   rpm-pythonprov}
320 BuildRequires:  tcl
321 BuildRequires:  xz-devel
322 BuildRequires:  zlib-devel
323 %if %{with apidocs}
324 BuildRequires:  doxygen
325 BuildRequires:  ghostscript
326 BuildRequires:  graphviz
327 BuildRequires:  tetex-pdftex
328 %endif
329 %if %{with static}
330 # Require static library only for static build
331 BuildRequires:  %{reqdb_pkg}-static >= %{reqdb_pkgver}
332 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
333 BuildRequires:  bzip2-static >= 1.0.2-17
334 BuildRequires:  elfutils-static
335 BuildRequires:  glibc-static >= 2.2.94
336 BuildRequires:  libmagic-static
337 %if %{with selinux}
338 BuildRequires:  libselinux-static >= 2.1.0
339 BuildRequires:  libsemanage-static >= 2.1.0
340 BuildRequires:  libsepol-static >= 2.1.0
341 %endif
342 BuildRequires:  popt-static >= %{reqpopt_ver}
343 BuildRequires:  zlib-static
344 %endif
345 Requires(posttrans):    coreutils
346 Requires:       %{name}-base = %{version}-%{release}
347 Requires:       %{name}-lib = %{version}-%{release}
348 Requires:       beecrypt >= %{beecrypt_ver}
349 Requires:       popt >= %{reqpopt_ver}
350 Provides:       rpm-db-ver = %{reqdb_ver}
351 Obsoletes:      rpm-getdeps
352 %{!?with_static:Obsoletes:      rpm-utils-static}
353 Conflicts:      glibc < 2.2.92
354 # db4.6 poldek needed
355 Conflicts:      poldek < 0.21-0.20070703.00.3
356 # segfaults with lzma 0.42.2
357 Conflicts:      lzma-libs < 4.999.3
358 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
359 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
360
361 %define         _binary_payload         w9.gzdio
362
363 # don't require very fresh rpm.macros to build
364 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
365 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
366 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
367 %define         ppc     ppc ppc7400 ppc7450
368 %define         x8664   amd64 ia32e x86_64
369
370 # stabilize new build environment
371 %define         __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
372 %define         __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
373 %define         __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
374
375 %define         _rpmlibdir /usr/lib/rpm
376 %define         _noautocompressdoc      RPM-GPG-KEY
377
378 %description
379 RPM is a powerful package manager, which can be used to build,
380 install, query, verify, update, and uninstall individual software
381 packages. A package consists of an archive of files, and package
382 information, including name, version, and description.
383
384 %description -l de.UTF-8
385 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
386 Installation, Anfrage, Verifizierung, Aktualisierung und
387 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
388 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
389 Beschreibung.
390
391 %description -l es.UTF-8
392 RPM es un poderoso administrador de paquetes, que puede ser usado para
393 construir, instalar, pesquisar, verificar, actualizar y desinstalar
394 paquetes individuales de software. Un paquete consiste en un
395 almacenaje de archivos, y información sobre el paquete, incluyendo
396 nombre, versión y descripción.
397
398 %description -l pl.UTF-8
399 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
400 przebudowanie, instalację czy weryfikację dowolnego pakietu.
401 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
402 plików wchodzących w skład pakietu, zależności od innych pakietów, są
403 przechowywane w bazie danych i można je uzyskać za pomocą opcji
404 odpytywania programu rpm.
405
406 %description -l pt_BR.UTF-8
407 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
408 construir, instalar, pesquisar, verificar, atualizar e desinstalar
409 pacotes individuais de software. Um pacote consiste de um conjunto de
410 arquivos e informações adicionais, incluindo nome, versão e descrição
411 do pacote, permissões dos arquivos, etc.
412
413 %description -l ru.UTF-8
414 RPM - это мощный менеджер пакетов, который может быть использован для
415 создания, инсталляции, запросов (query), проверки, обновления и
416 удаления программных пакетов. Пакет состоит из файлового архива и
417 служебной информации, включающей название, версию, описание и другие
418 данные о пакете.
419
420 %description -l uk.UTF-8
421 RPM - це потужний менеджер пакетів, що може бути використаний для
422 створення, інсталяції, запитів (query), перевірки, поновлення та
423 видалення програмних пакетів. Пакет складається з файлового архіву та
424 службової інформації, що містить назву, версію, опис та іншу
425 інформацію про пакет.
426
427 %package base
428 Summary:        RPM base package - scripts used by rpm packages themselves
429 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
430 Group:          Base
431 Requires:       filesystem
432 Obsoletes:      rpm-scripts
433 Obsoletes:      vserver-rpm
434
435 %description base
436 The RPM base package contains scripts used by rpm packages themselves.
437 These include:
438 - scripts for adding/removing groups and users needed for rpm
439   packages,
440 - banner.sh to display %%banner messages from rpm scriptlets.
441
442 %description base -l pl.UTF-8
443 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
444 Zawiera on:
445 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
446 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
447
448 %package lib
449 Summary:        RPMs library
450 Summary(pl.UTF-8):      Biblioteki RPM-a
451 Group:          Libraries
452 Requires:       %{reqdb_pkg} >= %{reqdb_pkgver}
453 %if %{with sqlite}
454 Requires:       sqlite3 >= %{sqlite_build_version}
455 %else
456 Requires:       %{reqdb_pkg}-sql >= %{reqdb_pkgver}
457 %endif
458 Requires:       beecrypt >= %{beecrypt_ver}
459 Requires:       libmagic >= 1.15-2
460 %{?with_selinux:Requires:       libselinux >= 2.1.0}
461 Requires:       popt >= %{reqpopt_ver}
462 Obsoletes:      rpm-libs
463 # avoid SEGV caused by mixed db versions
464 Conflicts:      poldek < 0.18.1-16
465
466 %description lib
467 RPMs library.
468
469 %description lib -l pl.UTF-8
470 Biblioteki RPM-a.
471
472 %package devel
473 Summary:        Header files for rpm libraries
474 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
475 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
476 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
477 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
478 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
479 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
480 Group:          Development/Libraries
481 Requires:       %{name}-lib = %{version}-%{release}
482 Requires:       %{reqdb_pkg}-devel >= %{reqdb_pkgver}
483 Requires:       beecrypt-devel >= %{beecrypt_ver}
484 Requires:       bzip2-devel
485 Requires:       elfutils-devel
486 %{?with_keyutils:Requires:      keyutils-devel}
487 Requires:       libmagic-devel
488 %{?with_selinux:Requires:       libselinux-devel}
489 Requires:       popt-devel >= %{reqpopt_ver}
490 Requires:       zlib-devel
491
492 %description devel
493 The RPM packaging system includes C libraries that make it easy to
494 manipulate RPM packages and databases. They are intended to ease the
495 creation of graphical package managers and other tools that need
496 intimate knowledge of RPM packages. This package contains header files
497 for these libraries.
498
499 %description devel -l de.UTF-8
500 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
501 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
502 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
503 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
504
505 %description devel -l es.UTF-8
506 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
507 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
508 facilitar la creación de administradores gráficos de paquetes y otras
509 herramientas que necesiten un conocimiento profundo de paquetes RPM.
510
511 %description devel -l pl.UTF-8
512 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
513 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
514 graficznych programów zarządzających pakietami oraz innych narzędzi,
515 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
516 zawiera pliki nagłówkowe wspomnianych bibliotek.
517
518 %description devel -l pt_BR.UTF-8
519 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
520 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
521 facilitar a criação de gerenciadores gráficos de pacotes e outras
522 ferramentas que precisem de conhecimento profundo de pacotes RPM.
523
524 %description devel -l ru.UTF-8
525 Система управления пакетами RPM содержит библиотеку C, которая
526 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
527 Эта библиотека предназначена для облегчения создания графических
528 пакетных менеджеров и других утилит, которым необходимо работать с
529 пакетами RPM.
530
531 %description devel -l uk.UTF-8
532 Система керування пакетами RPM містить бібліотеку C, котра спрощує
533 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
534 призначена для полегшення створення графічних пакетних менеджерів та
535 інших утиліт, що працюють з пакетами RPM.
536
537 %package static
538 Summary:        RPM static libraries
539 Summary(de.UTF-8):      RPMs statische Libraries
540 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
541 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
542 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
543 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
544 Group:          Development/Libraries
545 Requires:       %{name}-devel = %{version}-%{release}
546 Requires:       %{reqdb_pkg}-static >= %{reqdb_pkgver}
547 Requires:       beecrypt-static >= %{beecrypt_ver}
548 Requires:       bzip2-static
549 Requires:       elfutils-static
550 %{?with_keyutils:Requires:      keyutils-static}
551 Requires:       libmagic-static
552 Requires:       popt-static >= %{reqpopt_ver}
553 Requires:       zlib-static
554
555 %description static
556 RPM static libraries.
557
558 %description static -l de.UTF-8
559 RPMs statische Libraries.
560
561 %description static -l pl.UTF-8
562 Biblioteki statyczne RPM-a.
563
564 %description static -l pt_BR.UTF-8
565 Bibliotecas estáticas para desenvolvimento.
566
567 %description static -l ru.UTF-8
568 Система управления пакетами RPM содержит библиотеку C, которая
569 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
570 Это статическая библиотека RPM.
571
572 %description static -l uk.UTF-8
573 Система керування пакетами RPM містить бібліотеку C, котра спрощує
574 роботу з пакетами RPM та відповідними базами даних. Це статична
575 бібліотека RPM.
576
577 %package utils
578 Summary:        Additional utilities for managing RPM packages and database
579 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
580 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
581 Group:          Applications/File
582 Requires:       %{name} = %{version}-%{release}
583 Requires:       popt >= %{reqpopt_ver}
584 %if %{with suggest_tags}
585 Suggests:       bzip2
586 Suggests:       gzip
587 %endif
588 Conflicts:      filesystem-debuginfo < 3.0-16
589
590 %description utils
591 Additional utilities for managing RPM packages and database.
592
593 %description utils -l de.UTF-8
594 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
595
596 %description utils -l pl.UTF-8
597 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
598
599 %package utils-perl
600 Summary:        Additional utilities for managing RPM packages and database
601 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
602 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
603 Group:          Applications/File
604 Requires:       %{name}-utils = %{version}-%{release}
605 Requires:       popt >= %{reqpopt_ver}
606
607 %description utils-perl
608 Additional utilities for managing RPM packages and database.
609
610 %description utils-perl -l de.UTF-8
611 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
612
613 %description utils-perl -l pl.UTF-8
614 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
615
616 %package utils-static
617 Summary:        Static rpm utilities
618 Summary(pl.UTF-8):      Statyczne narzędzia rpm
619 Group:          Applications/System
620 Requires:       %{name} = %{version}-%{release}
621
622 %description utils-static
623 Static rpm utilities for repairing system in case something with
624 shared libraries used by rpm become broken. Currently it contains rpmi
625 binary, which can be used to install/upgrade/remove packages without
626 using shared libraries (well, in fact with exception of NSS modules).
627
628 %description utils-static -l pl.UTF-8
629 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
630 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
631 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
632 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
633 (z wyjątkiem modułów NSS).
634
635 %package build
636 Summary:        Scripts for building binary RPM packages
637 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
638 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
639 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
640 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
641 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
642 Group:          Applications/File
643 Requires(pre):  findutils
644 Requires:       %{name}-build-macros >= 1.656
645 Requires:       %{name}-utils = %{version}-%{release}
646 Requires:       /bin/id
647 Requires:       awk
648 Requires:       bzip2
649 Requires:       chrpath >= 0.10-4
650 Requires:       cpio
651 Requires:       diffutils
652 Requires:       elfutils
653 Requires:       file >= 4.17
654 Requires:       fileutils
655 Requires:       findutils
656 %ifarch athlon
657 Requires:       gcc >= 3.0.3
658 %else
659 Requires:       gcc
660 %endif
661 Requires:       glibc-devel
662 Requires:       grep
663 Requires:       gzip
664 Requires:       make
665 Requires:       patch
666 Requires:       sed >= 4.0
667 Requires:       sh-utils
668 Requires:       tar >= 1:1.22
669 Requires:       textutils
670 Requires:       which
671 Requires:       xz
672 Provides:       rpmbuild(monoautodeps)
673 Provides:       rpmbuild(noauto) = 3
674 %ifarch %{x8664}
675 Conflicts:      automake < 1:1.7.9-2
676 Conflicts:      libtool < 2:1.5-13
677 %endif
678
679 %description build
680 Scripts for building binary RPM packages.
681
682 %description build -l de.UTF-8
683 Scripts fürs Bauen binärer RPM-Pakete.
684
685 %description build -l pl.UTF-8
686 Skrypty pomocnicze do budowania binarnych RPM-ów.
687
688 %description build -l pt_BR.UTF-8
689 Este pacote contém scripts e programas executáveis que são usados para
690 construir pacotes usando o RPM.
691
692 %description build -l ru.UTF-8
693 Различные вспомогательные скрипты и исполняемые программы, которые
694 используются для сборки RPM'ов.
695
696 %description build -l uk.UTF-8
697 Різноманітні допоміжні скрипти та утиліти, які використовуються для
698 побудови RPM'ів.
699
700 %package javaprov
701 Summary:        Additional utilities for checking Java provides/requires in RPM packages
702 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
703 Group:          Applications/File
704 Requires:       %{name} = %{version}-%{release}
705 Requires:       file
706 Requires:       findutils >= 1:4.2.26
707 Requires:       mktemp
708 Requires:       unzip
709
710 %description javaprov
711 Additional utilities for checking Java provides/requires in RPM
712 packages.
713
714 %description javaprov -l pl.UTF-8
715 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
716 RPM.
717
718 %package perlprov
719 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
720 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
721 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
722 Group:          Applications/File
723 Requires:       %{name} = %{version}-%{release}
724 Requires:       perl-devel
725 Requires:       perl-modules
726
727 %description perlprov
728 Additional utilities for checking Perl provides/requires in RPM
729 packages.
730
731 %description perlprov -l de.UTF-8
732 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
733
734 %description perlprov -l pl.UTF-8
735 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
736 pakietach RPM.
737
738 %package pythonprov
739 Summary:        Python macros, which simplifies creation of RPM packages with Python software
740 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
741 Group:          Applications/File
742 Requires:       %{name} = %{version}-%{release}
743 Requires:       python
744 Requires:       python-distribute
745 Requires:       python-modules
746
747 %description pythonprov
748 Python macros, which simplifies creation of RPM packages with Python
749 software.
750
751 %description pythonprov -l pl.UTF-8
752 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
753 Pythonie.
754
755 %package php-pearprov
756 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
757 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
758 Group:          Applications/File
759 Requires:       %{name} = %{version}-%{release}
760 Requires:       sed >= 4.0
761 Suggests:       php-pear-PHP_CompatInfo
762
763 %description php-pearprov
764 Additional utilities for checking PHP PEAR provides/requires in RPM
765 packages.
766
767 %description php-pearprov -l pl.UTF-8
768 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
769 pakietach RPM.
770
771 %package rubyprov
772 Summary:        Ruby tools, which simplify creation of RPM packages with Ruby software
773 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
774 Group:          Applications/File
775 Requires:       %{name} = %{version}-%{release}
776 Requires:       ruby
777 Requires:       ruby-modules
778 Requires:       ruby-rubygems
779
780 %description rubyprov
781 Ruby tools, which simplifies creation of RPM packages with Ruby
782 software.
783
784 %description rubyprov -l pl.UTF-8
785 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
786 Ruby.
787
788 %package -n python-rpm
789 Summary:        Python interface to RPM library
790 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
791 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
792 Group:          Development/Languages/Python
793 Requires:       %{name} = %{version}-%{release}
794 Requires:       python
795 Obsoletes:      rpm-python
796
797 %description -n python-rpm
798 The rpm-python package contains a module which permits applications
799 written in the Python programming language to use the interface
800 supplied by RPM (RPM Package Manager) libraries.
801
802 This package should be installed if you want to develop Python
803 programs that will manipulate RPM packages and databases.
804
805 %description -n python-rpm -l pl.UTF-8
806 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
807 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
808
809 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
810 Pythonie programy manipulujące pakietami i bazami danych rpm.
811
812 %description -n python-rpm -l pt_BR.UTF-8
813 O pacote rpm-python contém um módulo que permite que aplicações
814 escritas em Python utilizem a interface fornecida pelas bibliotecas
815 RPM (RPM Package Manager).
816
817 Esse pacote deve ser instalado se você quiser desenvolver programas em
818 Python para manipular pacotes e bancos de dados RPM.
819
820 %package apidocs
821 Summary:        RPM API documentation and guides
822 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
823 Group:          Documentation
824
825 %description apidocs
826 Documentation for RPM API and guides in HTML format generated from rpm
827 sources by doxygen.
828
829 %description apidocs -l pl.UTF-8
830 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
831 źrodeł RPM-a przez doxygen.
832
833 %prep
834 %setup -q -n %{name}-%{version}%{?subver} -a100
835 #patch0 -p1
836 %patch1 -p1
837 %patch2 -p1
838 %patch3 -p1
839 %patch4 -p1
840 %patch5 -p1
841 %patch6 -p1
842 %patch7 -p1
843 %patch8 -p1
844 %{?with_system_lua:%patch9 -p1}
845 %patch10 -p1
846 %ifnarch i386 i486
847 # enable TSC for capable archs
848 %patch11 -p1
849 %endif
850 %patch12 -p1
851 %patch13 -p1
852 %patch14 -p0
853 %patch15 -p1
854 %patch16 -p1
855 %patch17 -p1
856 %patch18 -p1
857 %patch19 -p1
858 %patch20 -p1
859 %patch21 -p1
860 %ifarch sparc64
861 %patch22 -p1
862 %endif
863 %patch23 -p1
864 %patch24 -p1
865 %patch25 -p1
866 %patch27 -p1
867 %patch28 -p1
868 %patch29 -p1
869 %patch30 -p1
870 %patch31 -p1
871 %patch32 -p1
872 %patch33 -p1
873 %patch34 -p1
874 %patch35 -p1
875 %patch36 -p1
876 %patch37 -p1
877 %patch38 -p1
878 %patch39 -p1
879 %patch40 -p1
880 %{?with_db60:%patch41 -p1}
881 %patch42 -p1
882 %patch43 -p1
883 %patch44 -p1
884 %patch45 -p1
885 %patch46 -p1
886 %patch47 -p1
887 %patch48 -p1
888 %patch49 -p1
889 %patch50 -p1
890 %patch51 -p1
891 %patch52 -p0
892 %patch53 -p1
893 %patch54 -p1
894 %patch55 -p1
895 %patch56 -p1
896 %{!?with_db60:%patch57 -p1}
897 %patch58 -p1
898 %patch60 -p1
899 %patch61 -p1
900 %patch62 -p1
901 %patch63 -p1
902 %patch64 -p1
903 %patch65 -p1
904 %patch66 -p1
905 %patch67 -p1
906 %patch70 -p1
907 %patch71 -p1
908 %patch72 -p1
909 %patch73 -p1
910 %patch74 -p1
911 %patch75 -p1
912 %patch76 -p0
913 %patch77 -p0
914 %patch78 -p1
915
916 %patch1000 -p1
917 %patch1001 -p1
918 %patch1002 -p1
919 %patch1003 -p1
920 %patch1004 -p1
921 %patch1005 -p1
922 %patch1006 -p1
923 %patch1007 -p1
924 %patch1008 -p1
925 %patch1009 -p1
926 %patch1010 -p1
927 %patch1011 -p1
928 %patch1012 -p1
929 %patch1013 -p1
930 %patch1014 -p1
931 %patch1015 -p1
932 %patch1016 -p1
933 %patch1017 -p1
934 %patch1018 -p1
935 %patch1019 -p1
936 %patch1020 -p1
937 %patch1021 -p1
938 %patch1022 -p1
939 %patch1023 -p1
940 %patch1024 -p1
941 %patch1026 -p1
942 %patch1027 -p1
943 %patch1028 -p1
944 %patch1029 -p1
945 %patch1030 -p1
946 %patch1031 -p1
947 %patch1032 -p1
948 %patch1033 -p1
949 %patch1034 -p1
950 %patch1035 -p1
951 %patch1036 -p1
952 %patch1037 -p1
953 %patch1038 -p1
954 %patch1039 -p1
955 %patch1040 -p1
956 %patch1041 -p1
957 %patch1042 -p1
958 %patch1043 -p1
959 %patch1044 -p1
960 %patch1045 -p1
961 %patch1046 -p1
962 %patch1047 -p1
963 %patch1048 -p1
964 %patch68 -p1
965 %patch69 -p1
966
967 install %{SOURCE2} macros/pld.in
968 install %{SOURCE8} scripts/php.prov.in
969 install %{SOURCE9} scripts/php.req.in
970 install %{SOURCE11} scripts/perl.prov.in
971
972 %{__mv} -f scripts/perl.req{,.in}
973
974 # generate Group translations to *.po
975 awk -f %{SOURCE6} %{SOURCE1}
976
977 install %{SOURCE26} tools/rpmdb_checkversion.c
978 install %{SOURCE28} tools/rpmdb_reset.c
979
980 for extlib in beecrypt neon pcre popt; do
981         [ -d $extlib ] && %{__rm} -r $extlib
982 done
983
984 %build
985 %{__libtoolize}
986 #%{__autopoint}
987 %{__aclocal}
988 %{__autoheader}
989 %{__autoconf}
990 %{__automake}
991
992 # rpm checks for CPU type at runtime, but it looks better
993 sed -i \
994         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
995         -e 's|@host_cpu@|%{_target_cpu}|' \
996         -e 's|@host_os@|%{_target_os}|' \
997         macros/macros.in
998
999 %{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
1000 # pass CC and CXX too in case of building with some older configure macro
1001 %configure \
1002         CC="%{__newcc}" \
1003         CXX="%{__newcxx}" \
1004         CPP="%{__newcpp}" \
1005         WITH_PERL_VERSION=no \
1006         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
1007         --disable-silent-rules \
1008         --enable-shared \
1009         --enable-static \
1010         %{!?with_apidocs:--without-apidocs} \
1011         --with-beecrypt=external \
1012         --with-bugreport="http://bugs.pld-linux.org/" \
1013         --with-bzip2=external \
1014         --with-db=external \
1015         --with-dbapi=db \
1016         --with-file=external \
1017         --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
1018         --with-libelf \
1019         --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
1020         --with-lzma=external \
1021         --with-neon=%{?with_neon:external}%{!?with_neon:no} \
1022         --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/%{_target}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
1023         --without-path-versioned \
1024         --with-pcre=external \
1025         --with-popt=external \
1026         %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
1027         %{!?with_python:--without-python} \
1028         --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
1029         --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
1030         --with-sepol=%{!?with_selinux:no}%{?with_selinux:external} \
1031         --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
1032         --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
1033         --with-vendor=pld \
1034         --with-xz=external \
1035         --with-zlib=external
1036
1037 %{__make} -j1 \
1038         CC="%{__cc}" \
1039         CXX="%{__cxx}" \
1040         CPP="%{__cpp}"
1041
1042 %{?with_apidocs:%{__make} apidocs}
1043
1044 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
1045         -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
1046 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
1047         -o tools/rpmdb_reset -ldb-%{reqdb_ver}
1048
1049 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
1050         echo "Error linking rpmdb tools!"
1051         exit 1
1052 fi
1053 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
1054         echo "Error linking rpmdb tools!"
1055         exit 1
1056 fi
1057
1058 %install
1059 rm -rf $RPM_BUILD_ROOT
1060 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
1061         $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
1062
1063 install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1064
1065 %{__make} -j1 install \
1066         pkgconfigdir=%{_pkgconfigdir} \
1067         DESTDIR=$RPM_BUILD_ROOT
1068
1069 # install ARCH macros
1070 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux
1071 install cpu-os-macros/noarch-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
1072
1073 %ifarch %{ix86}
1074 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{i386,i486,i586,i686,athlon,pentium3,pentium4}-linux
1075 install cpu-os-macros/athlon-linux/macros   $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
1076 install cpu-os-macros/i386-linux/macros     $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
1077 install cpu-os-macros/i486-linux/macros     $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
1078 install cpu-os-macros/i586-linux/macros     $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
1079 install cpu-os-macros/i686-linux/macros     $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
1080 install cpu-os-macros/pentium3-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
1081 install cpu-os-macros/pentium4-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
1082 %endif
1083
1084 %ifarch %{x8664}
1085 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{x86_64,ia32e,amd64}-linux
1086 install cpu-os-macros/x86_64-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
1087 install cpu-os-macros/ia32e-linux/macros  $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
1088 install cpu-os-macros/amd64-linux/macros  $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
1089 %endif
1090
1091 %ifarch %{ppc}
1092 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux
1093 install cpu-os-macros/ppc-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
1094 %endif
1095
1096 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
1097 # first platform file entry can't contain regexps
1098 %{_target_cpu}-%{_target_vendor}-linux
1099
1100 # x86_64 things
1101 %ifarch x86_64
1102 x86_64-[^-]*-[Ll]inux(-gnu)?
1103 amd64-[^-]*-[Ll]inux(-gnu)?
1104 %endif
1105 %ifarch amd64
1106 amd64-[^-]*-[Ll]inux(-gnu)?
1107 x86_64-[^-]*-[Ll]inux(-gnu)?
1108 %endif
1109 %ifarch ia32e
1110 ia32e-[^-]*-[Ll]inux(-gnu)?
1111 x86_64-[^-]*-[Ll]inux(-gnu)?
1112 %endif
1113
1114 # x86 things
1115 %ifarch athlon %{x8664}
1116 athlon-[^-]*-[Ll]inux(-gnu)?
1117 %endif
1118 %ifarch pentium4 athlon %{x8664}
1119 pentium4-[^-]*-[Ll]inux(-gnu)?
1120 %endif
1121 %ifarch pentium3 pentium4 athlon %{x8664}
1122 pentium3-[^-]*-[Ll]inux(-gnu)?
1123 %endif
1124 %ifarch i686 pentium3 pentium4 athlon %{x8664}
1125 i686-[^-]*-[Ll]inux(-gnu)?
1126 %endif
1127 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
1128 i586-[^-]*-[Ll]inux(-gnu)?
1129 %endif
1130 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
1131 i486-[^-]*-[Ll]inux(-gnu)?
1132 %endif
1133 %ifarch %{ix86} %{x8664}
1134 i386-[^-]*-[Ll]inux(-gnu)?
1135 %endif
1136
1137 %ifarch alpha
1138 alpha-[^-]*-[Ll]inux(-gnu)?
1139 %endif
1140
1141 %ifarch ia64
1142 ia64-[^-]*-[Ll]inux(-gnu)?
1143 %endif
1144
1145 %ifarch ppc64
1146 powerpc64-[^-]*-[Ll]inux(-gnu)?
1147 ppc64-[^-]*-[Ll]inux(-gnu)?
1148 %endif
1149 %ifarch %{ppc} ppc64
1150 powerpc-[^-]*-[Ll]inux(-gnu)?
1151 ppc-[^-]*-[Ll]inux(-gnu)?
1152 %endif
1153
1154 %ifarch s390x
1155 s390x-[^-]*-[Ll]inux(-gnu)?
1156 %endif
1157 %ifarch s390 s390x
1158 s390-[^-]*-[Ll]inux(-gnu)?
1159 %endif
1160
1161 %ifarch sparc64
1162 sparc64-[^-]*-[Ll]inux(-gnu)?
1163 sparcv8-[^-]*-[Ll]inux(-gnu)?
1164 sparcv9-[^-]*-[Ll]inux(-gnu)?
1165 %endif
1166 %ifarch sparcv9
1167 sparcv8-[^-]*-[Ll]inux(-gnu)?
1168 sparcv9-[^-]*-[Ll]inux(-gnu)?
1169 %endif
1170 %ifarch sparc sparcv9 sparc64
1171 sparc-[^-]*-[Ll]inux(-gnu)?
1172 %endif
1173
1174 # noarch
1175 noarch-[^-]*-.*
1176 EOF
1177
1178 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1179 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1180 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
1181 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
1182 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.a
1183 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.la
1184 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-provides
1185 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-requires
1186
1187 # not installed since 4.4.8 (-tools-perl subpackage)
1188 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1189
1190 install %{SOURCE1} doc/manual/groups
1191 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
1192 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1193 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
1194 install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1195 install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
1196 install scripts/find-php*       $RPM_BUILD_ROOT%{_rpmlibdir}
1197 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
1198 cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
1199 install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
1200 install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
1201 install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
1202
1203 install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
1204
1205 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1206
1207 install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
1208 install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
1209 install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1210 install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1211 install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1212 install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
1213 install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
1214
1215 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1216 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
1217 install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
1218 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1219 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1220 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
1221
1222 install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1223 install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1224 install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
1225
1226 # create macro loading wrappers for backward compatibility
1227 for m in gstreamer java mono perl php python; do
1228         echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
1229 done
1230
1231 # for rpm -e|-U --repackage
1232 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1233 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
1234
1235 # move rpm to /bin
1236 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1237 # move essential libs to /lib (libs that /bin/rpm links to)
1238 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
1239         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1240         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
1241 done
1242
1243 # Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1244 mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1245
1246 %if %{with python}
1247 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1248 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
1249
1250 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
1251 %endif
1252
1253 # wrong location, not used anyway
1254 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
1255 # utils dropped in 4.4.8 -- their manuals
1256 %{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man8/rpmgraph.8
1257 # utils dropped in 5.4 -- their manuals
1258 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
1259 # script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1260 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
1261
1262 %find_lang %{name}
1263
1264 %{__rm} -rf manual
1265 cp -a doc/manual manual
1266 %{__rm} -f manual/Makefile*
1267
1268 %clean
1269 rm -rf $RPM_BUILD_ROOT
1270
1271 %pretrans
1272 # this needs to be a dir
1273 if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
1274         umask 022
1275         mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1276         mkdir %{_sysconfdir}/rpm/sysinfo
1277 fi
1278
1279 %posttrans
1280 if [ -e /var/lib/rpm/Packages ] && \
1281                 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
1282         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
1283                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
1284                 echo
1285                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
1286                 echo
1287         fi
1288         echo
1289         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
1290         echo 'you should ignore it and restart poldek'
1291         echo
1292         %{_rpmlibdir}/bin/dbupgrade.sh
1293 fi
1294
1295 %triggerpostun -- %{name} < 4.4.9-44
1296 %{_rpmlibdir}/hrmib-cache
1297
1298 %post   lib -p /sbin/ldconfig
1299 %postun lib -p /sbin/ldconfig
1300
1301 %pretrans build
1302 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
1303
1304 %files -f %{name}.lang
1305 %defattr(644,root,root,755)
1306 %doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
1307
1308 %dir /etc/pki/rpm-gpg
1309 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1310
1311 %attr(755,root,root) /bin/rpm
1312
1313 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
1314 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
1315 %dir %{_sysconfdir}/rpm/sysinfo
1316 # these are ok to be replaced
1317 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
1318 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1319
1320 %{_mandir}/man8/rpm.8*
1321 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1322 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1323 %lang(ko) %{_mandir}/ko/man8/rpm.8*
1324 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1325 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1326 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1327
1328 %dir /var/lib/rpm
1329 %dir /var/lib/rpm/log
1330 %dir /var/lib/rpm/tmp
1331 %config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
1332 %dir %attr(700,root,root) /var/spool/repackage
1333 %dir /var/lock/rpm
1334 /var/lock/rpm/transaction
1335
1336 # exported package NVRA (stamped with install tid)
1337 # net-snmp hrSWInstalledName queries, bash-completions
1338 %dir /var/cache/hrmib
1339
1340 %{_rpmlibdir}/qf
1341 %{_rpmlibdir}/rpmpopt*
1342 %{_rpmlibdir}/macros
1343 %dir %{_rpmlibdir}/macros.d
1344 %{_rpmlibdir}/macros.d/pld
1345 %{_rpmlibdir}/cpuinfo.yaml
1346 %{_rpmlibdir}/noarch-*
1347 %ifarch %{ix86}
1348 %{_rpmlibdir}/i?86*
1349 %{_rpmlibdir}/pentium*
1350 %{_rpmlibdir}/athlon*
1351 %endif
1352 %ifarch alpha
1353 %{_rpmlibdir}/alpha*
1354 %endif
1355 %ifarch ia64
1356 %{_rpmlibdir}/ia64*
1357 %endif
1358 %ifarch mips mipsel mips64 mips64el
1359 %{_rpmlibdir}/mips*
1360 %endif
1361 %ifarch %{ppc}
1362 %{_rpmlibdir}/ppc*
1363 %endif
1364 %ifarch sparc sparc64
1365 %{_rpmlibdir}/sparc*
1366 %endif
1367 %ifarch %{x8664}
1368 %{_rpmlibdir}/amd64*
1369 %{_rpmlibdir}/ia32e*
1370 %{_rpmlibdir}/x86_64*
1371 %endif
1372
1373 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1374
1375 %dir %{_rpmlibdir}/bin
1376 %attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
1377 %attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
1378 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
1379 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
1380
1381 %files base
1382 %defattr(644,root,root,755)
1383 %dir %{_sysconfdir}/rpm
1384 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1385 %dir %{_rpmlibdir}
1386 %attr(755,root,root) %{_bindir}/banner.sh
1387 %attr(755,root,root) %{_bindir}/multiarch-dispatch
1388 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1389 %dir /var/lib/banner
1390
1391 %files lib
1392 %defattr(644,root,root,755)
1393 %attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1394 %attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1395 %attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1396 %attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
1397 %attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
1398 %attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
1399
1400 %files devel
1401 %defattr(644,root,root,755)
1402 %attr(755,root,root) %{_libdir}/librpm.so
1403 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1404 %attr(755,root,root) %{_libdir}/librpmbuild.so
1405 %attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
1406 %attr(755,root,root) %{_libdir}/librpmconstant.so
1407 %attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
1408 %attr(755,root,root) %{_libdir}/librpmdb.so
1409 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1410 %attr(755,root,root) %{_libdir}/librpmio.so
1411 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1412 %attr(755,root,root) %{_libdir}/librpmmisc.so
1413 %attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
1414 %{_libdir}/librpm*.la
1415 %{_includedir}/rpm
1416 %{_includedir}/multiarch-dispatch.h
1417 %{_pkgconfigdir}/*.pc
1418
1419 %files static
1420 %defattr(644,root,root,755)
1421 %{_libdir}/librpm*.a
1422
1423 %files utils
1424 %defattr(644,root,root,755)
1425 %attr(755,root,root) %{_bindir}/rpm2cpio
1426 %attr(755,root,root) %{_bindir}/rpmconstant
1427 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1428 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1429 %attr(755,root,root) %{_rpmlibdir}/tgpg
1430 %attr(755,root,root) %{_rpmlibdir}/bin/chroot
1431 %attr(755,root,root) %{_rpmlibdir}/bin/cp
1432 %attr(755,root,root) %{_rpmlibdir}/bin/debugedit
1433 %attr(755,root,root) %{_rpmlibdir}/bin/find
1434 %attr(755,root,root) %{_rpmlibdir}/bin/mgo
1435 %attr(755,root,root) %{_rpmlibdir}/bin/mtree
1436 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1437 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1438 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1439 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
1440 %if %{with selinux}
1441 %attr(755,root,root) %{_rpmlibdir}/bin/semodule
1442 %attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1443 %endif
1444 %if %{without system_lua}
1445 %attr(755,root,root) %{_rpmlibdir}/bin/lua
1446 %attr(755,root,root) %{_rpmlibdir}/bin/luac
1447 %attr(755,root,root) %{_rpmlibdir}/bin/rpmlua
1448 %attr(755,root,root) %{_rpmlibdir}/bin/rpmluac
1449 %endif
1450 %{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
1451 %attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
1452 %{_mandir}/man8/rpm2cpio.8*
1453 %{_mandir}/man8/rpmcache.8*
1454 %{_mandir}/man8/rpmconstant.8*
1455 %{_mandir}/man8/rpmdeps.8*
1456 %{_mandir}/man8/rpmmtree.8*
1457 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1458 %lang(ja) %{_mandir}/ja/man8/rpmcache.8*
1459 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1460 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1461 %lang(pl) %{_mandir}/pl/man8/rpmcache.8*
1462 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1463 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1464
1465 %files utils-perl
1466 %defattr(644,root,root,755)
1467 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1468
1469 %if %{with static}
1470 %files utils-static
1471 %defattr(644,root,root,755)
1472 %attr(755,root,root) %{_bindir}/rpm[ieu]
1473 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1474 %endif
1475
1476 %files build
1477 %defattr(644,root,root,755)
1478 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1479 %attr(755,root,root) %{_rpmlibdir}/brp-*
1480 %attr(755,root,root) %{_rpmlibdir}/check-files
1481 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1482 %attr(755,root,root) %{_rpmlibdir}/cross-build
1483 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1484 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1485 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1486 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1487 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1488 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1489 %attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
1490 # needs hacked pkg-config to return anything
1491 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1492 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1493 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
1494 %{!?with_sqlite:%attr(755,root,root) %{_rpmlibdir}/bin/dbsql}
1495 %attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1496 %attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
1497 %attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1498 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1499 %attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1500 %attr(755,root,root) %{_rpmlibdir}/bin/wget
1501 %attr(755,root,root) %{_rpmlibdir}/vcheck
1502 # not used yet ... these six depend on perl
1503 %attr(755,root,root) %{_rpmlibdir}/http.req
1504 # we always used scripts provided by mono-devel, maybe move them here
1505 #%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1506 #%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
1507
1508 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
1509 # must be here for "Requires: rpm-*prov" to work
1510 %{_rpmlibdir}/macros.d/cmake
1511 %{_rpmlibdir}/macros.d/gstreamer
1512 %{_rpmlibdir}/macros.d/java
1513 %{_rpmlibdir}/macros.d/kernel
1514 %{_rpmlibdir}/macros.d/libtool
1515 %{_rpmlibdir}/macros.d/mono
1516 %{_rpmlibdir}/macros.d/perl
1517 %{_rpmlibdir}/macros.d/php
1518 %{_rpmlibdir}/macros.d/pkgconfig
1519 %{_rpmlibdir}/macros.d/python
1520 %{_rpmlibdir}/macros.d/ruby
1521 %{_rpmlibdir}/macros.d/selinux
1522 %{_rpmlibdir}/macros.d/tcl
1523 %{_rpmlibdir}/macros.rpmbuild
1524 # compat wrappers
1525 %{_rpmlibdir}/macros.gstreamer
1526 %{_rpmlibdir}/macros.java
1527 %{_rpmlibdir}/macros.mono
1528 %{_rpmlibdir}/macros.perl
1529 %{_rpmlibdir}/macros.php
1530 %{_rpmlibdir}/macros.python
1531
1532 %attr(755,root,root) %{_rpmlibdir}/check-multiarch-files
1533 %attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1534 %attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1535 %attr(755,root,root) %{_rpmlibdir}/mkmultiarch
1536
1537 %attr(755,root,root) %{_bindir}/gendiff
1538 %attr(755,root,root) %{_bindir}/multiarch-platform
1539 %attr(755,root,root) %{_bindir}/rpmbuild
1540
1541 %dir %{_rpmlibdir}/helpers
1542 %attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
1543
1544 %{_mandir}/man1/gendiff.1*
1545 %{_mandir}/man8/rpmbuild.8*
1546 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1547 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1548 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1549
1550 %files javaprov
1551 %defattr(644,root,root,755)
1552 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1553 # needs jar (any jdk), jcf-dump (gcc-java) to work
1554 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1555
1556 %files rubyprov
1557 %defattr(644,root,root,755)
1558 %attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1559 %attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1560
1561 %files perlprov
1562 %defattr(644,root,root,755)
1563 %attr(755,root,root) %{_rpmlibdir}/perl.*
1564 %attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1565 %attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1566
1567 %files pythonprov
1568 %defattr(644,root,root,755)
1569 %attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
1570 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1571
1572 %files php-pearprov
1573 %defattr(644,root,root,755)
1574 %attr(755,root,root) %{_rpmlibdir}/php*
1575 %attr(755,root,root) %{_rpmlibdir}/find-php*
1576
1577 %if %{with python}
1578 %files -n python-rpm
1579 %defattr(644,root,root,755)
1580 %dir %{py_sitedir}/rpm
1581 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1582 %{py_sitedir}/rpm/*.py[co]
1583 %endif
1584
1585 %if %{with apidocs}
1586 %files apidocs
1587 %defattr(644,root,root,755)
1588 %doc apidocs
1589 %endif
This page took 0.665432 seconds and 3 git commands to generate.