]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- started update to 4.4.8
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
4 #   matches ELF first
5 # - repackaging when lzma is not installed (todo: fix digest signature of header)
6 #   rpmbuild computes digest when writing package to temporary file, then adds a few
7 #   tags (incl. digest) and writes whole package to destination file;
8 #   repackaging uses unchanged "immutable header" image from original rpm, also
9 #   preserving payload format and compressor from original rpm, _not_ current settings
10 #
11 # Conditional build:
12 %bcond_with     static          # build static rpm+rpmi
13 %bcond_without  apidocs         # don't generate documentation with doxygen
14 %bcond_with     autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
15 %bcond_without  python          # don't build python bindings
16 %bcond_without  selinux         # build without selinux support
17 %bcond_without  system_libmagic # don't use system libmagic
18 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
19 # force_cc              - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
20 # force_cxx             - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
21 # force_cpp             - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
22
23 # versions of required libraries
24 %define reqdb_ver       4.5.20
25 %define reqpopt_ver     1.10.8
26 %define beecrypt_ver    2:4.1.2-4
27 %define sover   4.4
28 Summary:        RPM Package Manager
29 Summary(de.UTF-8):      RPM Packet-Manager
30 Summary(es.UTF-8):      Gestor de paquetes RPM
31 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
32 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
33 Summary(ru.UTF-8):      Менеджер пакетов от RPM
34 Summary(uk.UTF-8):      Менеджер пакетів від RPM
35 Name:           rpm
36 Version:        4.4.8
37 Release:        0.1
38 License:        GPL
39 Group:          Base
40 Source0:        ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
41 # Source0-md5:  dc73bcebf6b206058457c9a90f944c55
42 Source1:        %{name}.groups
43 Source2:        %{name}.platform
44 Source3:        %{name}-install-tree
45 Source4:        %{name}-find-spec-bcond
46 Source5:        %{name}-find-lang
47 Source6:        %{name}-groups-po.awk
48 Source7:        %{name}-compress-doc
49 Source8:        %{name}-check-files
50 Source9:        %{name}-php-provides
51 Source10:       %{name}-php-requires
52 Source11:       %{name}.sysinfo
53 Source12:       perl.prov
54 Source13:       %{name}-user_group.sh
55 Source14:       %{name}.sysconfig
56 Source30:       builder
57 Source31:       adapter.awk
58 Source32:       pldnotify.awk
59 # http://svn.pld-linux.org/banner.sh/
60 Source33:       banner.sh
61 Patch0:         %{name}-pl.po.patch
62 Patch1:         %{name}-rpmrc.patch
63 Patch2:         %{name}-arch.patch
64 Patch3:         %{name}-rpmpopt.patch
65 Patch4:         %{name}-perl-macros.patch
66 Patch5:         %{name}-perl-req-perlfile.patch
67 Patch6:         %{name}-noexpand.patch
68 Patch7:         %{name}-scripts-closefds.patch
69 Patch8:         %{name}-python-macros.patch
70 Patch9:         %{name}-gettext-in-header.patch
71 Patch10:        %{name}-compress-doc.patch
72 Patch11:        %{name}-rpmdeps-segv.patch
73 Patch12:        %{name}-system_libs.patch
74 Patch13:        %{name}-bb-and-short-circuit.patch
75 Patch14:        %{name}-etc_dir.patch
76 Patch15:        %{name}-system_libs-more.patch
77 Patch16:        %{name}-php-deps.patch
78 Patch17:        %{name}-ldconfig-always.patch
79 Patch18:        %{name}-perl_req.patch
80 Patch19:        %{name}-link.patch
81 Patch20:        %{name}-magic-usesystem.patch
82 Patch21:        %{name}-dontneedutils.patch
83 Patch22:        %{name}-provides-dont-obsolete.patch
84 Patch23:        %{name}-pkgconfigdeps.patch
85 Patch24:        %{name}-po.patch
86
87 Patch26:        %{name}-notsc.patch
88 Patch27:        %{name}-hack-norpmlibdep.patch
89 Patch28:        %{name}-makefile-no_myLDADD_deps.patch
90
91 Patch31:        %{name}-missing-prototypes.patch
92 Patch32:        %{name}-pld-autodep.patch
93 Patch33:        %{name}-arch-x86_64.patch
94 Patch34:        %{name}-epoch0.patch
95 Patch35:        %{name}-perl_req-INC_dirs.patch
96 Patch36:        %{name}-debuginfo.patch
97 Patch37:        %{name}-doxygen_hack.patch
98 Patch38:        %{name}-empty-rpmlock-path.patch
99
100 Patch41:        %{name}-reduce-stack-usage.patch
101 Patch42:        %{name}-old-fileconflicts-behaviour.patch
102
103 Patch44:        %{name}-no-neon.patch
104 Patch45:        %{name}-no-sqlite.patch
105 Patch46:        %{name}-mono.patch
106
107 Patch49:        %{name}-p4.patch
108 Patch50:        %{name}-macros.patch
109 Patch51:        %{name}-cleanlibdirs.patch
110 Patch52:        %{name}-morearchs.patch
111
112 Patch55:        %{name}-truncate-cvslog.patch
113
114 Patch57:        %{name}-as_needed-fix.patch
115 Patch58:        %{name}-repackage-wo-lzma.patch
116 Patch59:        %{name}-libtool-deps.patch
117
118 Patch64:        %{name}-iconv-translit.patch
119 URL:            http://wraptastic.org/
120 BuildRequires:  autoconf >= 2.57
121 BuildRequires:  automake >= 1.4
122 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
123 BuildRequires:  bzip2-devel >= 1.0.2-17
124 BuildRequires:  db-devel >= %{reqdb_ver}
125 BuildRequires:  elfutils-devel >= 0.108
126 BuildRequires:  gettext-devel >= 0.11.4-2
127 %{?with_system_libmagic:BuildRequires:  libmagic-devel}
128 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.18}
129 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
130 BuildRequires:  libstdc++-devel
131 BuildRequires:  libtool >= 1:1.4.2-9
132 %if %{with neon}
133 BuildRequires:  libxml2-devel
134 BuildRequires:  neon-devel >= 0.25.5
135 %endif
136 BuildRequires:  patch >= 2.2
137 BuildRequires:  popt-devel >= %{reqpopt_ver}
138 %{?with_python:BuildRequires:   python-devel >= 1:2.5}
139 BuildRequires:  python-modules >= 1:2.5
140 BuildRequires:  rpm-perlprov
141 %{?with_python:BuildRequires:   rpm-pythonprov}
142 BuildRequires:  zlib-devel
143 %if %{with apidocs}
144 BuildRequires:  doxygen
145 BuildRequires:  ghostscript
146 BuildRequires:  graphviz
147 BuildRequires:  tetex-pdftex
148 %endif
149 %if %{with static}
150 # Require static library only for static build
151 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
152 BuildRequires:  bzip2-static >= 1.0.2-17
153 BuildRequires:  db-static >= %{reqdb_ver}
154 BuildRequires:  elfutils-static
155 BuildRequires:  glibc-static >= 2.2.94
156 %{?with_system_libmagic:BuildRequires:  libmagic-static}
157 %{?with_selinux:BuildRequires:  libselinux-static >= 1.18}
158 BuildRequires:  popt-static >= %{reqpopt_ver}
159 BuildRequires:  zlib-static
160 %endif
161 Requires:       %{name}-base = %{version}-%{release}
162 Requires:       %{name}-lib = %{version}-%{release}
163 Requires:       beecrypt >= %{beecrypt_ver}
164 Requires:       popt >= %{reqpopt_ver}
165 %{!?with_static:Obsoletes:      rpm-utils-static}
166 Conflicts:      glibc < 2.2.92
167 # ABI changes in rpm, new poldek needed
168 Conflicts:      poldek < 0.20.1-0.20070105.0
169 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
170
171 %define         _binary_payload         w9.gzdio
172 %define         _noPayloadPrefix        1
173
174 # don't require very fresh rpm.macros to build
175 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
176 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
177 %define         ppc     ppc ppc7400 ppc7450
178 %define         x8664   amd64 ia32e x86_64
179
180 # stabilize new build environment
181 %define         __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
182 %define         __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
183 %define         __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
184
185 %define         _rpmlibdir /usr/lib/rpm
186
187 %define         specflags       -fno-strict-aliasing
188
189 %description
190 RPM is a powerful package manager, which can be used to build,
191 install, query, verify, update, and uninstall individual software
192 packages. A package consists of an archive of files, and package
193 information, including name, version, and description.
194
195 %description -l de.UTF-8
196 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
197 Installation, Anfrage, Verifizierung, Aktualisierung und
198 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
199 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
200 Beschreibung.
201
202 %description -l es.UTF-8
203 RPM es un poderoso administrador de paquetes, que puede ser usado para
204 construir, instalar, pesquisar, verificar, actualizar y desinstalar
205 paquetes individuales de software. Un paquete consiste en un
206 almacenaje de archivos, y información sobre el paquete, incluyendo
207 nombre, versión y descripción.
208
209 %description -l pl.UTF-8
210 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
211 przebudowanie, instalację czy weryfikację dowolnego pakietu.
212 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
213 plików wchodzących w skład pakietu, zależności od innych pakietów, są
214 przechowywane w bazie danych i można je uzyskać za pomocą opcji
215 odpytywania programu rpm.
216
217 %description -l pt_BR.UTF-8
218 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
219 construir, instalar, pesquisar, verificar, atualizar e desinstalar
220 pacotes individuais de software. Um pacote consiste de um conjunto de
221 arquivos e informações adicionais, incluindo nome, versão e descrição
222 do pacote, permissões dos arquivos, etc.
223
224 %description -l ru.UTF-8
225 RPM - это мощный менеджер пакетов, который может быть использован для
226 создания, инсталляции, запросов (query), проверки, обновления и
227 удаления программных пакетов. Пакет состоит из файлового архива и
228 служебной информации, включающей название, версию, описание и другие
229 данные о пакете.
230
231 %description -l uk.UTF-8
232 RPM - це потужний менеджер пакетів, що може бути використаний для
233 створення, інсталяції, запитів (query), перевірки, поновлення та
234 видалення програмних пакетів. Пакет складається з файлового архіву та
235 службової інформації, що містить назву, версію, опис та іншу
236 інформацію про пакет.
237
238 %package base
239 Summary:        RPM base package - scripts used by rpm packages themselves
240 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
241 Group:          Base
242 Requires:       filesystem
243 Obsoletes:      vserver-rpm
244
245 %description base
246 The RPM base package contains scripts used by rpm packages themselves.
247 These include:
248 - scripts for adding/removing groups and users needed for rpm
249   packages,
250 - banner.sh to display %%banner messages from rpm scriptlets.
251
252 %description base -l pl.UTF-8
253 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
254 Zawiera on:
255 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
256 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
257
258 %package lib
259 Summary:        RPMs library
260 Summary(pl.UTF-8):      Biblioteki RPM-a
261 Group:          Libraries
262 Requires:       beecrypt >= %{beecrypt_ver}
263 Requires:       db >= %{reqdb_ver}
264 %{?with_selinux:Requires:       libselinux >= 1.18}
265 %{?with_system_libmagic:Requires:       libmagic >= 1.15-2}
266 Requires:       popt >= %{reqpopt_ver}
267 Obsoletes:      rpm-libs
268 # avoid SEGV caused by mixed db versions
269 Conflicts:      poldek < 0.18.1-16
270 Suggests:       lzma
271
272 %description lib
273 RPMs library.
274
275 %description lib -l pl.UTF-8
276 Biblioteki RPM-a.
277
278 %package devel
279 Summary:        Header files for rpm libraries
280 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
281 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
282 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
283 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
284 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
285 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
286 Group:          Development/Libraries
287 Requires:       %{name}-lib = %{version}-%{release}
288 Requires:       beecrypt-devel >= %{beecrypt_ver}
289 Requires:       bzip2-devel
290 Requires:       db-devel >= %{reqdb_ver}
291 Requires:       elfutils-devel
292 %{?with_system_libmagic:Requires:       libmagic-devel}
293 %{?with_selinux:Requires:       libselinux-devel}
294 Requires:       popt-devel >= %{reqpopt_ver}
295 Requires:       zlib-devel
296
297 %description devel
298 The RPM packaging system includes C libraries that make it easy to
299 manipulate RPM packages and databases. They are intended to ease the
300 creation of graphical package managers and other tools that need
301 intimate knowledge of RPM packages. This package contains header files
302 for these libraries.
303
304 %description devel -l de.UTF-8
305 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
306 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
307 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
308 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
309
310 %description devel -l es.UTF-8
311 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
312 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
313 facilitar la creación de administradores gráficos de paquetes y otras
314 herramientas que necesiten un conocimiento profundo de paquetes RPM.
315
316 %description devel -l pl.UTF-8
317 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
318 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
319 graficznych programów zarządzających pakietami oraz innych narzędzi,
320 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
321 zawiera pliki nagłówkowe wspomnianych bibliotek.
322
323 %description devel -l pt_BR.UTF-8
324 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
325 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
326 facilitar a criação de gerenciadores gráficos de pacotes e outras
327 ferramentas que precisem de conhecimento profundo de pacotes RPM.
328
329 %description devel -l ru.UTF-8
330 Система управления пакетами RPM содержит библиотеку C, которая
331 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
332 Эта библиотека предназначена для облегчения создания графических
333 пакетных менеджеров и других утилит, которым необходимо работать с
334 пакетами RPM.
335
336 %description devel -l uk.UTF-8
337 Система керування пакетами RPM містить бібліотеку C, котра спрощує
338 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
339 призначена для полегшення створення графічних пакетних менеджерів та
340 інших утиліт, що працюють з пакетами RPM.
341
342 %package static
343 Summary:        RPM static libraries
344 Summary(de.UTF-8):      RPMs statische Libraries
345 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
346 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
347 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
348 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
349 Group:          Development/Libraries
350 Requires:       %{name}-devel = %{version}-%{release}
351 Requires:       beecrypt-static >= %{beecrypt_ver}
352 Requires:       bzip2-static
353 Requires:       db-static >= %{reqdb_ver}
354 Requires:       elfutils-static
355 %{?with_system_libmagic:Requires:       libmagic-static}
356 Requires:       popt-static >= %{reqpopt_ver}
357 Requires:       zlib-static
358
359 %description static
360 RPM static libraries.
361
362 %description static -l de.UTF-8
363 RPMs statische Libraries.
364
365 %description static -l pl.UTF-8
366 Biblioteki statyczne RPM-a.
367
368 %description static -l pt_BR.UTF-8
369 Bibliotecas estáticas para desenvolvimento.
370
371 %description static -l ru.UTF-8
372 Система управления пакетами RPM содержит библиотеку C, которая
373 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
374 Это статическая библиотека RPM.
375
376 %description static -l uk.UTF-8
377 Система керування пакетами RPM містить бібліотеку C, котра спрощує
378 роботу з пакетами RPM та відповідними базами даних. Це статична
379 бібліотека RPM.
380
381 %package utils
382 Summary:        Additional utilities for managing rpm packages and database
383 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
384 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
385 Group:          Applications/File
386 Requires:       %{name} = %{version}-%{release}
387 Requires:       popt >= %{reqpopt_ver}
388
389 %description utils
390 Additional utilities for managing rpm packages and database.
391
392 %description utils -l de.UTF-8
393 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
394
395 %description utils -l pl.UTF-8
396 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
397
398 %package utils-perl
399 Summary:        Additional utilities for managing rpm packages and database
400 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
401 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
402 Group:          Applications/File
403 Requires:       %{name}-utils = %{version}-%{release}
404 Requires:       popt >= %{reqpopt_ver}
405
406 %description utils-perl
407 Additional utilities for managing rpm packages and database.
408
409 %description utils-perl -l de.UTF-8
410 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
411
412 %description utils-perl -l pl.UTF-8
413 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
414
415 %package utils-static
416 Summary:        Static rpm utilities
417 Summary(pl.UTF-8):      Statyczne narzędzia rpm
418 Group:          Applications/System
419 Requires:       %{name} = %{version}-%{release}
420
421 %description utils-static
422 Static rpm utilities for repairing system in case something with
423 shared libraries used by rpm become broken. Currently it contains rpmi
424 binary, which can be used to install/upgrade/remove packages without
425 using shared libraries (well, in fact with exception of NSS modules).
426
427 %description utils-static -l pl.UTF-8
428 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
429 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
430 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
431 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
432 (z wyjątkiem modułów NSS).
433
434 %package build
435 Summary:        Scripts for building binary RPM packages
436 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
437 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
438 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
439 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
440 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
441 Group:          Applications/File
442 Requires(pre):  findutils
443 Requires:       %{name}-build-macros >= 1.314
444 Requires:       %{name}-utils = %{version}-%{release}
445 Requires:       /bin/id
446 Requires:       awk
447 # we need fixed binutils for -feliminate-dwarf2-dups
448 Requires:       binutils >= 3:2.17.50.0.3-2
449 Requires:       bzip2
450 Requires:       chrpath >= 0.10-4
451 Requires:       cpio
452 Requires:       diffutils
453 Requires:       elfutils
454 Requires:       file >= 4.17
455 Requires:       fileutils
456 Requires:       findutils
457 Requires:       gcc >= 5:3.4
458 Requires:       glibc-devel
459 Requires:       grep
460 Requires:       gzip
461 Requires:       lzma
462 Requires:       make
463 Requires:       patch
464 Requires:       sed
465 Requires:       sh-utils
466 Requires:       tar
467 Requires:       textutils
468 Provides:       rpmbuild(monoautodeps)
469 Provides:       rpmbuild(noauto) = 3
470 %ifarch %{x8664}
471 Conflicts:      automake < 1:1.7.9-2
472 Conflicts:      libtool < 2:1.5-13
473 %endif
474
475 %description build
476 Scripts for building binary RPM packages.
477
478 %description build -l de.UTF-8
479 Scripts fürs Bauen binärer RPM-Pakete.
480
481 %description build -l pl.UTF-8
482 Skrypty pomocnicze do budowania binarnych RPM-ów.
483
484 %description build -l pt_BR.UTF-8
485 Este pacote contém scripts e programas executáveis que são usados para
486 construir pacotes usando o RPM.
487
488 %description build -l ru.UTF-8
489 Различные вспомогательные скрипты и исполняемые программы, которые
490 используются для сборки RPM'ов.
491
492 %description build -l uk.UTF-8
493 Різноманітні допоміжні скрипти та утиліти, які використовуються для
494 побудови RPM'ів.
495
496 %package build-tools
497 Summary:        Scripts for managing .spec files and building RPM packages
498 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
499 Summary(pl.UTF-8):      Skrypty pomocnicze do zarządznia plikami .spec i budowania RPM-ów
500 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
501 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
502 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
503 Group:          Applications/File
504 Requires:       %{name}-build = %{version}-%{release}
505 # these are optional
506 #Requires:      cvs
507 Requires:       wget
508
509 %description build-tools
510 Scripts for managing .spec files and building RPM packages.
511
512 %description build-tools -l de.UTF-8
513 Scripts fürs Bauen RPM-Pakete.
514
515 %description build-tools -l pl.UTF-8
516 Skrypty pomocnicze do zarządzania plikami .spec i do budowania RPM-ów.
517
518 %description build-tools -l pt_BR.UTF-8
519 Este pacote contém scripts e programas executáveis que são usados para
520 construir pacotes usando o RPM.
521
522 %description build-tools -l ru.UTF-8
523 Различные вспомогательные скрипты и исполняемые программы, которые
524 используются для сборки RPM'ов.
525
526 %description build-tools -l uk.UTF-8
527 Різноманітні допоміжні скрипти та утиліти, які використовуються для
528 побудови RPM'ів.
529
530 %package perlprov
531 Summary:        Additional utilities for checking perl provides/requires in rpm packages
532 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
533 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów perla w pakietach rpm
534 Group:          Applications/File
535 Requires:       %{name} = %{version}-%{release}
536 Requires:       perl-devel
537 Requires:       perl-modules
538
539 %description perlprov
540 Additional utilities for checking perl provides/requires in rpm
541 packages.
542
543 %description perlprov -l de.UTF-8
544 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
545
546 %description perlprov -l pl.UTF-8
547 Dodatkowe narzędzia do sprawdzenia zależności skryptów perla w
548 pakietach rpm.
549
550 %package pythonprov
551 Summary:        Python macros, which simplifies creation of rpm packages with Python software
552 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów rpm z programami napisanymi w Pythonie
553 Group:          Applications/File
554 Requires:       %{name} = %{version}-%{release}
555 Requires:       python
556 Requires:       python-modules
557
558 %description pythonprov
559 Python macros, which simplifies creation of rpm packages with Python
560 software.
561
562 %description pythonprov -l pl.UTF-8
563 Makra ułatwiające tworzenie pakietów rpm z programami napisanymi w
564 Pythonie.
565
566 %package php-pearprov
567 Summary:        Additional utilities for managing rpm packages and database
568 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w rpm
569 Group:          Applications/File
570 Requires:       %{name} = %{version}-%{release}
571 Requires:       sed >= 4.0
572
573 %description php-pearprov
574 Additional utilities for checking php pear provides/requires in rpm
575 packages.
576
577 %description php-pearprov -l pl.UTF-8
578 Dodatkowe narzędzia do sprawdzenia zależności skryptów php pear w
579 pakietach rpm.
580
581 %package -n python-rpm
582 Summary:        Python interface to RPM library
583 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
584 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
585 Group:          Development/Languages/Python
586 Requires:       %{name} = %{version}-%{release}
587 %pyrequires_eq  python
588 Obsoletes:      rpm-python
589
590 %description -n python-rpm
591 The rpm-python package contains a module which permits applications
592 written in the Python programming language to use the interface
593 supplied by RPM (RPM Package Manager) libraries.
594
595 This package should be installed if you want to develop Python
596 programs that will manipulate RPM packages and databases.
597
598 %description -n python-rpm -l pl.UTF-8
599 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
600 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
601
602 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
603 Pythonie programy manipulujące pakietami i bazami danych rpm.
604
605 %description -n python-rpm -l pt_BR.UTF-8
606 O pacote rpm-python contém um módulo que permite que aplicações
607 escritas em Python utilizem a interface fornecida pelas bibliotecas
608 RPM (RPM Package Manager).
609
610 Esse pacote deve ser instalado se você quiser desenvolver programas em
611 Python para manipular pacotes e bancos de dados RPM.
612
613 %package apidocs
614 Summary:        RPM API documentation and guides
615 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
616 Group:          Documentation
617
618 %description apidocs
619 Documentation for RPM API and guides in HTML format generated from rpm
620 sources by doxygen.
621
622 %description apidocs -l pl.UTF-8
623 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
624 źrodeł RPM-a przez doxygen.
625
626 %prep
627 %setup -q
628 %patch0 -p1
629 %patch1 -p1
630 %patch2 -p1
631 %patch3 -p1
632 %patch4 -p1
633 %patch5 -p1
634 %patch6 -p1
635 %patch7 -p1
636 %patch8 -p1
637 %patch9 -p1
638 %patch10 -p1
639 %patch11 -p1
640 %patch12 -p1
641 %patch13 -p1
642 %patch14 -p1
643 %patch15 -p1
644 %patch16 -p1
645 %patch17 -p1
646 %patch18 -p1
647 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
648 #cp -f platform.in macros.pld.in # what for?
649 echo '%%define  __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
650 echo '%%define  __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
651 echo '# obsoleted file' > macros.python
652 echo '%%define  __php_provides  /usr/lib/rpm/php.prov' > macros.php
653 echo '%%define  __php_requires  /usr/lib/rpm/php.req' >> macros.php
654 echo '%%define  __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
655 echo '%%define  __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
656 install %{SOURCE5} scripts/find-lang.sh
657 install %{SOURCE9} scripts/php.prov.in
658 install %{SOURCE10} scripts/php.req.in
659 install %{SOURCE12} scripts/perl.prov
660 %patch19 -p1
661 %patch20 -p1
662 %patch21 -p1
663 %patch22 -p1
664 %patch23 -p1
665 %patch24 -p1
666 %patch26 -p1
667 %patch27 -p1
668 %patch28 -p1
669 %patch31 -p1
670 %patch32 -p1
671 %patch33 -p1
672 %patch34 -p1
673 %patch35 -p0
674 %patch36 -p1
675 %patch37 -p1
676 %patch38 -p1
677 %patch41 -p1
678 %patch42 -p1
679 %{!?with_neon:%patch44 -p1}
680 %patch45 -p1
681 %patch46 -p1
682 %patch49 -p1
683 %patch50 -p1
684 %patch51 -p1
685 #%patch52 -p1
686 %patch55 -p1
687 %patch57 -p1
688 %patch58 -p1
689 %patch59 -p1
690 %patch64 -p1
691
692 cd scripts
693 mv -f perl.req perl.req.in
694 mv -f perl.prov perl.prov.in
695 cd ..
696
697 mv -f po/{no,nb}.po
698 mv -f po/{sr,sr@Latn}.po
699
700 rm -rf sqlite zlib db db3 popt rpmdb/db.h
701
702 # generate Group translations to *.po
703 awk -f %{SOURCE6} %{SOURCE1}
704
705 # update macros paths
706 for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
707         sed -e 's@lib/rpm/redhat@lib/rpm/pld@g' $f > ${f}.tmp
708         mv -f ${f}.tmp $f
709 done
710
711 %build
712 %if %{with system_libmagic}
713 rm -rf file
714 %else
715 cd file
716 %{__libtoolize}
717 %{__aclocal}
718 %{__autoheader}
719 %{__autoconf}
720 %{__automake}
721 cd ..
722 %endif
723
724 %{__libtoolize}
725 %{__gettextize}
726 %{__aclocal}
727 %{__autoheader}
728 %{__autoconf}
729 %{__automake}
730
731 # config.guess doesn't handle athlon, so we have to change it by hand.
732 # rpm checks for CPU type at runtime, but it looks better
733 sed -i -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' -e 's|@host_cpu@|%{_target_cpu}|' macros.in
734
735 CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
736
737 # pass CC and CXX too in case of building with some older configure macro
738 # disable perl-RPM2 build, we have it in separate spec
739 %configure \
740         CC="%{__newcc}" \
741         CXX="%{__newcxx}" \
742         CPP="%{__newcpp}" \
743         WITH_PERL_VERSION=no \
744         %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
745         --enable-shared \
746         --enable-static \
747         %{!?with_apidocs:--without-apidocs} \
748         %{?with_python:--with-python=2.5} \
749         %{!?with_python:--without-python} \
750         %{!?with_selinux:--without-selinux} \
751         --without-db
752
753 # file_LDFLAGS, debugedit_LDADD - no need to link "file" and "debugedit" statically
754 %{__make} \
755         CC="%{__cc}" \
756         CXX="%{__cxx}" \
757         CPP="%{__cpp}" \
758         pylibdir=%{py_libdir} \
759         myLDFLAGS="%{rpmldflags}" \
760         file_LDFLAGS= \
761         debugedit_LDADD="\$(WITH_LIBELF_LIB) -lpopt" \
762         staticLDFLAGS=%{?with_static:-all-static}
763
764 %{?with_apidocs:%{__make} doxygen}
765
766 %install
767 rm -rf $RPM_BUILD_ROOT
768 install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/banner}
769
770 %{__make} install \
771         DESTDIR=$RPM_BUILD_ROOT \
772         staticLDFLAGS=%{?with_static:-all-static} \
773         pylibdir=%{py_libdir} \
774         pkgbindir="%{_bindir}"
775
776 echo "%{_target_cpu}-%{_target_vendor}-linux-gnu" > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
777
778 %ifarch %{ppc}
779 #sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
780 #       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
781 %endif
782
783 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
784 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
785 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
786
787 # not installed since 4.4.8 (-tools-perl subpackage)
788 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
789
790 install macros.perl     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.perl
791 install macros.python   $RPM_BUILD_ROOT%{_rpmlibdir}/macros.python
792 install macros.php      $RPM_BUILD_ROOT%{_rpmlibdir}/macros.php
793 install macros.mono     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.mono
794
795 install %{SOURCE1} doc/manual/groups
796 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
797 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
798 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
799 install %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/check-files
800 install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
801 install scripts/find-php*       $RPM_BUILD_ROOT%{_rpmlibdir}
802 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
803 install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
804
805 install %{SOURCE30} $RPM_BUILD_ROOT%{_bindir}/builder
806 install %{SOURCE31} $RPM_BUILD_ROOT%{_bindir}/adapter.awk
807 install %{SOURCE32} $RPM_BUILD_ROOT%{_bindir}/pldnotify.awk
808 install %{SOURCE33} $RPM_BUILD_ROOT%{_bindir}/banner.sh
809
810 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
811
812 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
813
814 # obsolete but still installed
815 rm $RPM_BUILD_ROOT%{_rpmlibdir}/rpmrc
816
817 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
818 # customized rpm macros - global for host
819 #
820 #%%_install_langs pl_PL:en_US
821 %%distribution PLD
822 #
823 # remove or replace with file_contexts path if you want to use custom
824 # SELinux file contexts policy instead of one stored in packages payload
825 %%_install_file_context_path    %%{nil}
826 %%_verify_file_context_path     %%{nil}
827
828 # If non-zero, all erasures will be automagically repackaged.
829 #%%_repackage_all_erasures    1
830 EOF
831
832 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles <<EOF
833 # global list of files (regexps) which don't generate Provides
834 EOF
835 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov <<EOF
836 # global list of script capabilities (regexps) not to be used in Provides
837 EOF
838 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles <<EOF
839 # global list of files (regexps) which don't generate Requires
840 ^%{_examplesdir}/
841 ^%{_docdir}/
842 EOF
843 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq <<EOF
844 # global list of script capabilities (regexps) not to be used in Requires
845 EOF
846 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
847 # global list of capabilities (SONAME, perl(module), php(module) regexps)
848 # which don't generate dependencies on package NAMES
849 # -- OpenGL implementation
850 ^libGL.so.1
851 ^libGLU.so.1
852 ^libOSMesa.so
853 # -- Glide
854 ^libglide3.so.3
855 # -- mozilla
856 ^libgtkmozembed.so
857 ^libgtksuperwin.so
858 ^libxpcom.so
859 # -- X11 implementation
860 ^libFS.so
861 ^libI810XvMC.so
862 ^libICE.so
863 ^libSM.so
864 ^libX11.so
865 ^libXRes.so
866 ^libXTrap.so
867 ^libXaw.so
868 ^libXcomposite.so
869 ^libXcursor.so
870 ^libXdamage.so
871 ^libXdmcp.so
872 ^libXevie.so
873 ^libXext.so
874 ^libXfixes.so
875 ^libXfont.so
876 ^libXfontcache.so
877 ^libXft.so
878 ^libXi.so
879 ^libXinerama.so
880 ^libXmu.so
881 ^libXmuu.so
882 ^libXp.so
883 ^libXpm.so
884 ^libXrandr.so
885 ^libXrender.so
886 ^libXss.so
887 ^libXt.so
888 ^libXtst.so
889 ^libXv.so
890 ^libXvMC.so
891 ^libXxf86dga.so
892 ^libXxf86misc.so
893 ^libXxf86rush.so
894 ^libXxf86vm.so
895 ^libdps.so
896 ^libdpstk.so
897 ^libfontenc.so
898 ^libpsres.so
899 ^libxkbfile.so
900 ^libxkbui.so
901 # -- fam / gamin
902 ^libfam.so.0
903 EOF
904 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
905 # global list of file masks not to be compressed in DOCDIR
906 EOF
907
908 # for rpm -e|-U --repackage
909 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
910 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
911
912 # move libs to /lib
913 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so ; do
914         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
915         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
916 done
917
918 # remove arch dependant macros which have no use on noarch
919 %{__sed} -i -e '
920 /{__spec_install_post_strip}/d
921 /{__spec_install_post_chrpath}/d
922 /{__spec_install_post_compress_modules}/d
923 ' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
924
925 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
926 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
927
928 rm -f $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
929
930 # (currently) not used or supported in PLD
931 rm -f $RPM_BUILD_ROOT%{_rpmlibdir}/{Specfile.pm,cpanflute,cpanflute2,find-provides,find-requires,freshen.sh,http.req,magic.prov,magic.req,perldeps.pl,sql.prov,sql.req,tcl.req}
932 # wrong location, not used anyway
933 rm -f $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
934 # manuals for utils dropped in 4.4.8 (?)
935 #rm -f $RPM_BUILD_ROOT%{_mandir}/{,*/}/man8/{rpmcache,rpmgraph}.8
936
937 %find_lang %{name}
938
939 rm -rf manual
940 cp -a doc/manual manual
941 rm -f manual/Makefile*
942
943 %clean
944 rm -rf $RPM_BUILD_ROOT
945
946 %post   lib -p /sbin/ldconfig
947 %postun lib -p /sbin/ldconfig
948
949 %pre build
950 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
951
952 %files -f %{name}.lang
953 %defattr(644,root,root,755)
954 %doc CHANGES CREDITS README wdj/JBJ-GPG-KEY manual/*
955
956 %attr(755,root,root) /bin/rpm
957 #%attr(755,root,root) %{_bindir}/rpmdb
958 #%attr(755,root,root) %{_bindir}/rpmquery
959 #%attr(755,root,root) %{_bindir}/rpmsign
960 #%attr(755,root,root) %{_bindir}/rpmverify
961
962 %dir %{_sysconfdir}/rpm
963 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
964 # these are ok to be replaced
965 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo
966 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
967
968
969 %{_mandir}/man8/rpm.8*
970 %lang(fr) %{_mandir}/fr/man8/rpm.8*
971 %lang(ja) %{_mandir}/ja/man8/rpm.8*
972 %lang(ko) %{_mandir}/ko/man8/rpm.8*
973 %lang(pl) %{_mandir}/pl/man8/rpm.8*
974 %lang(ru) %{_mandir}/ru/man8/rpm.8*
975 %lang(sk) %{_mandir}/sk/man8/rpm.8*
976
977 %dir /var/lib/rpm
978 %dir %attr(700,root,root) /var/spool/repackage
979 %dir /var/lock/rpm
980 /var/lock/rpm/transaction
981
982 #%attr(755,root,root) %{_rpmlibdir}/rpmd
983 #%{!?with_static:%attr(755,root,root) %{_rpmlibdir}/rpm[eiu]}
984 #%attr(755,root,root) %{_rpmlibdir}/rpmk
985 #%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
986
987 %{_rpmlibdir}/rpmpopt*
988 %{_rpmlibdir}/macros
989
990 %files base
991 %defattr(644,root,root,755)
992 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
993 %dir %{_rpmlibdir}
994 %attr(755,root,root) %{_bindir}/banner.sh
995 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
996 %dir /var/lib/banner
997
998 %files lib
999 %defattr(644,root,root,755)
1000 %attr(755,root,root) /%{_lib}/librpm*-*.so
1001 %attr(755,root,root) %{_libdir}/librpm*-*.so
1002
1003 %files devel
1004 %defattr(644,root,root,755)
1005 %{_includedir}/rpm
1006 %{_libdir}/librpm*.la
1007 %attr(755,root,root) %{_libdir}/librpm.so
1008 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1009 %attr(755,root,root) %{_libdir}/librpmio.so
1010 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1011 %attr(755,root,root) %{_libdir}/librpmdb.so
1012 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1013 %attr(755,root,root) %{_libdir}/librpmbuild.so
1014
1015 %files static
1016 %defattr(644,root,root,755)
1017 %{_libdir}/librpm*.a
1018
1019 %files utils
1020 %defattr(644,root,root,755)
1021 %attr(755,root,root) %{_bindir}/debugedit
1022 %attr(755,root,root) %{_bindir}/rpm2cpio
1023 %attr(755,root,root) %{_bindir}/rpmdeps
1024 %{!?with_system_libmagic:%attr(755,root,root) %{_bindir}/rpmfile}
1025 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1026 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
1027 %attr(755,root,root) %{_rpmlibdir}/tgpg
1028 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1029 %{_mandir}/man8/rpm2cpio.8*
1030 %{_mandir}/man8/rpmdeps.8*
1031 #%{_mandir}/man8/rpmcache.8*
1032 #%{_mandir}/man8/rpmgraph.8*
1033 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1034 #%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
1035 #%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
1036 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1037 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1038 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1039 #%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
1040 #%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
1041 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1042
1043 %files utils-perl
1044 %defattr(644,root,root,755)
1045 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1046
1047 %if %{with static}
1048 %files utils-static
1049 %defattr(644,root,root,755)
1050 %attr(755,root,root) %{_bindir}/rpm[ieu]
1051 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1052 %endif
1053
1054 %files build
1055 %defattr(644,root,root,755)
1056 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1057 %attr(755,root,root) %{_rpmlibdir}/brp-*
1058 %attr(755,root,root) %{_rpmlibdir}/check-files
1059 # %attr(755,root,root) %{_rpmlibdir}/check-prereqs
1060 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1061 %attr(755,root,root) %{_rpmlibdir}/config.*
1062 %attr(755,root,root) %{_rpmlibdir}/cross-build
1063 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1064 %attr(755,root,root) %{_rpmlibdir}/find-lang.sh
1065 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1066 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1067 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
1068 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1069 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1070 # needs jar (any jdk), jcf-dump (gcc-java) to work
1071 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1072 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1073 # needs hacked pkg-config to return anything
1074 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1075 %attr(755,root,root) %{_rpmlibdir}/rpmb
1076 %attr(755,root,root) %{_rpmlibdir}/rpmt
1077 %{_rpmlibdir}/noarch-*
1078 %ifarch %{ix86}
1079 %{_rpmlibdir}/i?86*
1080 %{_rpmlibdir}/pentium*
1081 %{_rpmlibdir}/athlon*
1082 %endif
1083 %ifarch alpha
1084 %{_rpmlibdir}/alpha*
1085 %endif
1086 %ifarch ia64
1087 %{_rpmlibdir}/ia64*
1088 %endif
1089 %ifarch mips mipsel mips64 mips64el
1090 %{_rpmlibdir}/mips*
1091 %endif
1092 %ifarch %{ppc}
1093 %{_rpmlibdir}/ppc*
1094 %endif
1095 %ifarch sparc sparc64
1096 %{_rpmlibdir}/sparc*
1097 %endif
1098 %ifarch %{x8664}
1099 %{_rpmlibdir}/x86_64*
1100 %endif
1101 # must be here for "Requires: rpm-*prov" to work
1102 %{_rpmlibdir}/macros.mono
1103 %{_rpmlibdir}/macros.perl
1104 %{_rpmlibdir}/macros.php
1105 # not used yet ... these six depend on perl
1106 #%attr(755,root,root) %{_rpmlibdir}/http.req
1107 #%attr(755,root,root) %{_rpmlibdir}/magic.prov
1108 #%attr(755,root,root) %{_rpmlibdir}/magic.req
1109 #%{_rpmlibdir}/sql.prov
1110 #%{_rpmlibdir}/sql.req
1111 #%{_rpmlibdir}/tcl.req
1112
1113 %attr(755,root,root) %{_bindir}/gendiff
1114 %attr(755,root,root) %{_bindir}/rpmbuild
1115
1116 %{_mandir}/man1/gendiff.1*
1117 %{_mandir}/man8/rpmbuild.8*
1118 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1119 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1120 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1121
1122 %files build-tools
1123 %defattr(644,root,root,755)
1124 %attr(755,root,root) %{_bindir}/builder
1125 %attr(755,root,root) %{_bindir}/adapter.awk
1126 %attr(755,root,root) %{_bindir}/pldnotify.awk
1127
1128 %files perlprov
1129 %defattr(644,root,root,755)
1130 %attr(755,root,root) %{_rpmlibdir}/perl.*
1131 #%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1132 #%attr(755,root,root) %{_rpmlibdir}/find-perl-*
1133 #%attr(755,root,root) %{_rpmlibdir}/find-*.perl
1134 #%attr(755,root,root) %{_rpmlibdir}/find-prov.pl
1135 #%attr(755,root,root) %{_rpmlibdir}/find-req.pl
1136 #%attr(755,root,root) %{_rpmlibdir}/get_magic.pl
1137
1138 %files pythonprov
1139 %defattr(644,root,root,755)
1140 %{_rpmlibdir}/macros.python
1141 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1142
1143 %files php-pearprov
1144 %defattr(644,root,root,755)
1145 %attr(755,root,root) %{_rpmlibdir}/php*
1146 %attr(755,root,root) %{_rpmlibdir}/find-php*
1147
1148 %if %{with python}
1149 %files -n python-rpm
1150 %defattr(644,root,root,755)
1151 %dir %{py_sitedir}/rpm
1152 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1153 %{py_sitedir}/rpm/*.py[co]
1154 %endif
1155
1156 %if %{with apidocs}
1157 %files apidocs
1158 %defattr(644,root,root,755)
1159 %doc apidocs
1160 %endif
This page took 0.142419 seconds and 3 git commands to generate.