]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- next batch of patch updates
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4 #   returns -ENOSYS
5 # - add macros for some ppc, mipsel, alpha and sparc
6 #
7 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
8 #
9 # Conditional build:
10 %bcond_with     static          # build static rpm+rpmi
11 %bcond_without  apidocs         # don't generate documentation with doxygen
12 %bcond_without  python          # don't build python bindings
13 %bcond_without  selinux         # build without selinux support
14 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
15 %bcond_with     db61            # use DB 6.1 instead of 5.2
16 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
17 %bcond_with     sqlite          # build with SQLite support
18 %bcond_without  system_pcre     # use system pcre
19 %bcond_with     keyutils        # build with keyutils support
20
21 %if %{with sqlite}
22 # Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
23 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
24 %endif
25
26 # versions of required libraries
27 %if %{with db61}
28 %define         reqdb_pkg       db6.1
29 %define         reqdb_ver       6.1
30 %define         reqdb_pkgver    6.1.19
31 %else
32 %define         reqdb_pkg       db5.2
33 %define         reqdb_ver       5.2
34 %define         reqdb_pkgver    5.2.36.0-4
35 %endif
36 %define         reqpopt_ver     1.15
37 %define         beecrypt_ver    2:4.2.0
38 %define         sover           5.4
39
40 Summary:        RPM Package Manager
41 Summary(de.UTF-8):      RPM Packet-Manager
42 Summary(es.UTF-8):      Gestor de paquetes RPM
43 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
44 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
45 Summary(ru.UTF-8):      Менеджер пакетов от RPM
46 Summary(uk.UTF-8):      Менеджер пакетів від RPM
47 Name:           rpm
48 Version:        4.15.1
49 Release:        0.1
50 License:        GPL v2 / LGPL v2.1
51 Group:          Base
52 Source0:        http://ftp.rpm.org/releases/rpm-4.15.x/%{name}-%{version}.tar.bz2
53 # Source0-md5:  ed72147451a5ed93b2a48e2f8f5413c3
54 # See README.cpu-os-macros how to update cpu-os-macros.a
55 Source100:      cpu-os-macros.a
56 Source101:      README.cpu-os-macros
57 Source1:        %{name}.groups
58 Source2:        macros.pld.in
59 Source3:        %{name}-install-tree
60 Source4:        %{name}-find-spec-bcond
61 Source5:        %{name}-hrmib-cache
62 Source6:        %{name}-groups-po.awk
63 Source7:        %{name}-compress-doc
64 Source8:        %{name}-php-provides
65 Source9:        %{name}-php-requires
66 Source10:       %{name}.sysinfo
67 Source11:       perl.prov
68 Source12:       %{name}-user_group.sh
69 Source13:       %{name}.sysconfig
70 Source14:       %{name}-java-requires
71 # http://svn.pld-linux.org/banner.sh/
72 Source15:       banner.sh
73 Source16:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
74 # Source16-md5: 23914bb49fafe7153cee87126d966461
75 Source17:       %{name}-mimetypedeps
76 Source18:       macros.local
77 Source19:       %{name}.noautocompressdoc
78 Source20:       %{name}.noautoprov
79 Source21:       %{name}.noautoprovfiles
80 Source22:       %{name}.noautoreq
81 Source24:       %{name}.noautoreqfiles
82 Source25:       %{name}-php-requires.php
83 Source26:       %{name}db_checkversion.c
84 Source27:       macros.lang
85 Source28:       %{name}db_reset.c
86 Source29:       dbupgrade.sh
87 Source30:       rubygems.rb
88 Source31:       gem_helper.rb
89 Patch0:         %{name}-branch.patch
90 Patch1:         %{name}-man_pl.patch
91 Patch2:         %{name}-popt-aliases.patch
92 Patch4:         %{name}-perl-macros.patch
93 Patch5:         %{name}-perl-req-perlfile.patch
94 Patch6:         %{name}-scripts-closefds.patch
95 Patch7:         %{name}-php-macros.patch
96 Patch9:         %{name}-lua.patch
97 Patch14:        %{name}-perl_req-INC_dirs.patch
98 Patch15:        %{name}-debuginfo.patch
99 Patch16:        vendor-pld.patch
100 Patch18:        %{name}-javadeps.patch
101 Patch20:        %{name}-libtool-deps.patch
102 Patch29:        %{name}-builddir-readlink.patch
103 Patch30:        %{name}-changelog_order_check_nonfatal.patch
104 Patch35:        %{name}-namespace-compare.patch
105 Patch37:        %{name}-postun-nofail.patch
106 Patch42:        %{name}-pattern_Release.patch
107 Patch43:        %{name}-fix-___build_pre-macro.patch
108 Patch44:        %{name}-missing-patch-file-fails-build.patch
109 Patch45:        %{name}-remove-misleading-missing-patch-message.patch
110 Patch46:        %{name}-file-magic-can-be-mixed-case.patch
111 Patch47:        %{name}-query-always-noisy.patch
112 Patch48:        %{name}-verify-ghosts-broken-logic.patch
113 Patch49:        %{name}-python-enable-compat-RPMSENSE.patch
114 Patch50:        %{name}-dont-treat-gstreamer-modules-as-font.patch
115 Patch51:        %{name}-gst-inspect-typo.patch
116 Patch52:        %{name}-null-term-ascii-digest.patch
117 Patch53:        %{name}-lua-enable-extra-libs.patch
118 Patch54:        %{name}-fix-filedigests-verify.patch
119 Patch55:        %{name}-disable-hmac-verify.patch
120 Patch56:        %{name}-macros.patch
121 Patch57:        %{name}-db5.2.patch
122 Patch58:        %{name}-preserve-iterator.patch
123 Patch59:        gcc6-stdlib.patch
124 Patch60:        %{name}-python-sitescriptdir.patch
125 Patch61:        %{name}-clean-docdir.patch
126 Patch62:        %{name}-DB_CONFIG.patch
127 Patch63:        %{name}-pythoneggs.patch
128 Patch64:        %{name}-fix-compress-doc.patch
129 Patch65:        %{name}-parseSpec-skip-empty-tags.patch
130 Patch66:        %{name}-payload-use-hashed-inode.patch
131 Patch67:        %{name}-repackage-dont-force-max-compression.patch
132 Patch68:        rpm-bug-420.patch
133 Patch70:        python-%{name}sense-missingok.patch
134 Patch71:        %{name}-changelog-encoding.patch
135 Patch72:        %{name}-preserve-tag-type.patch
136 Patch74:        %{name}-fix-internal-lua-build.patch
137 Patch75:        %{name}-double_check_file_deps.patch
138 Patch77:        %{name}-lua-expat.patch
139 Patch78:        %{name}-double_check_unpackaged_subdirs.patch
140 Patch79:        %{name}-rpmspec.patch
141 Patch80:        %{name}-revert-gpg-argv-parsing.patch
142 Patch81:        %{name}-perl-magic.patch
143 Patch82:        %{name}-5.4.15-use-DSA-sig.patch
144 Patch83:        %{name}-ignore-missing-macro-files.patch
145 Patch84:        x32.patch
146 Patch85:        rpm-CVE-2013-6435.patch
147 Patch86:        rpm-CVE-2014-8118.patch
148 Patch87:        %{name}-file-output-for-ELF.patch
149 Patch88:        %{name}-rpmtdnext.patch
150 Patch89:        disable-header-verification.patch
151 Patch90:        %{name}-cppcompat.patch
152 Patch91:        py-disable-fetch.patch
153 Patch92:        fast_python_deps.patch
154 Patch93:        python2_explicit.patch
155 Patch94:        do_not_write_before_macro_buffer.patch
156 Patch95:        rpm-python-spec-header.patch
157 Patch96:        skip-ldconfig-optimization.patch
158 Patch97:        glibc.patch
159 Patch98:        extension-based-compression-detection.patch
160 Patch99:        %{name}-gpg-pinentry.patch
161 Patch100:       python-libx32.patch
162
163 URL:            http://rpm5.org/
164 BuildRequires:  %{reqdb_pkg}-devel >= %{reqdb_pkgver}
165 %if %{with sqlite}
166 BuildRequires:  sqlite3-devel
167 %else
168 BuildRequires:  %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
169 %endif
170 BuildRequires:  autoconf >= 2.63
171 BuildRequires:  automake >= 1.4
172 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
173 BuildRequires:  bzip2-devel >= 1.0.2-17
174 BuildRequires:  elfutils-devel >= 0.108
175 BuildRequires:  gettext-tools >= 0.19.2
176 %{?with_keyutils:BuildRequires: keyutils-devel}
177 BuildRequires:  libmagic-devel
178 %if %{with selinux}
179 BuildRequires:  libselinux-devel >= 2.1.0
180 BuildRequires:  libsemanage-devel >= 2.1.0
181 BuildRequires:  libsepol-devel >= 2.1.0
182 %endif
183 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
184 BuildRequires:  libstdc++-devel
185 BuildRequires:  libtool >= 1:1.4.2-9
186 %if %{with neon}
187 BuildRequires:  libxml2-devel
188 BuildRequires:  neon-devel >= 0.25.5
189 %endif
190 BuildRequires:  lua52-devel >= 5.2.2
191 BuildRequires:  ossp-uuid-devel
192 BuildRequires:  patch >= 2.2
193 BuildRequires:  popt-devel >= %{reqpopt_ver}
194 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
195 BuildRequires:  python-modules >= 1:2.3
196 %{?with_python:BuildRequires:   rpm-pythonprov}
197 BuildRequires:  tcl
198 BuildRequires:  xz-devel
199 BuildRequires:  zlib-devel
200 %if %{with apidocs}
201 BuildRequires:  doxygen
202 BuildRequires:  ghostscript
203 BuildRequires:  graphviz
204 BuildRequires:  tetex-pdftex
205 %endif
206 %if %{with static}
207 # Require static library only for static build
208 BuildRequires:  %{reqdb_pkg}-static >= %{reqdb_pkgver}
209 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
210 BuildRequires:  bzip2-static >= 1.0.2-17
211 BuildRequires:  elfutils-static
212 BuildRequires:  glibc-static >= 2.2.94
213 BuildRequires:  libmagic-static
214 %if %{with selinux}
215 BuildRequires:  libselinux-static >= 2.1.0
216 BuildRequires:  libsemanage-static >= 2.1.0
217 BuildRequires:  libsepol-static >= 2.1.0
218 %endif
219 BuildRequires:  popt-static >= %{reqpopt_ver}
220 BuildRequires:  zlib-static
221 %endif
222 Requires(posttrans):    coreutils
223 Requires:       FHS >= 3.0-2
224 Requires:       %{name}-base = %{version}-%{release}
225 Requires:       %{name}-lib = %{version}-%{release}
226 Requires:       beecrypt >= %{beecrypt_ver}
227 Requires:       popt >= %{reqpopt_ver}
228 Provides:       rpm-db-ver = %{reqdb_ver}
229 Obsoletes:      rpm-getdeps
230 %{!?with_static:Obsoletes:      rpm-utils-static}
231 Conflicts:      glibc < 2.2.92
232 # db4.6 poldek needed
233 Conflicts:      poldek < 0.21-0.20070703.00.3
234 # segfaults with lzma 0.42.2
235 Conflicts:      lzma-libs < 4.999.3
236 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
237 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
238
239 %define         _binary_payload         w9.gzdio
240
241 # don't require very fresh rpm.macros to build
242 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
243 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
244 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
245 %define         ppc     ppc ppc7400 ppc7450
246 %define         x8664   amd64 ia32e x86_64
247
248 %define         _rpmlibdir /usr/lib/rpm
249 %define         _noautocompressdoc      RPM-GPG-KEY
250
251 %description
252 RPM is a powerful package manager, which can be used to build,
253 install, query, verify, update, and uninstall individual software
254 packages. A package consists of an archive of files, and package
255 information, including name, version, and description.
256
257 %description -l de.UTF-8
258 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
259 Installation, Anfrage, Verifizierung, Aktualisierung und
260 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
261 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
262 Beschreibung.
263
264 %description -l es.UTF-8
265 RPM es un poderoso administrador de paquetes, que puede ser usado para
266 construir, instalar, pesquisar, verificar, actualizar y desinstalar
267 paquetes individuales de software. Un paquete consiste en un
268 almacenaje de archivos, y información sobre el paquete, incluyendo
269 nombre, versión y descripción.
270
271 %description -l pl.UTF-8
272 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
273 przebudowanie, instalację czy weryfikację dowolnego pakietu.
274 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
275 plików wchodzących w skład pakietu, zależności od innych pakietów, są
276 przechowywane w bazie danych i można je uzyskać za pomocą opcji
277 odpytywania programu rpm.
278
279 %description -l pt_BR.UTF-8
280 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
281 construir, instalar, pesquisar, verificar, atualizar e desinstalar
282 pacotes individuais de software. Um pacote consiste de um conjunto de
283 arquivos e informações adicionais, incluindo nome, versão e descrição
284 do pacote, permissões dos arquivos, etc.
285
286 %description -l ru.UTF-8
287 RPM - это мощный менеджер пакетов, который может быть использован для
288 создания, инсталляции, запросов (query), проверки, обновления и
289 удаления программных пакетов. Пакет состоит из файлового архива и
290 служебной информации, включающей название, версию, описание и другие
291 данные о пакете.
292
293 %description -l uk.UTF-8
294 RPM - це потужний менеджер пакетів, що може бути використаний для
295 створення, інсталяції, запитів (query), перевірки, поновлення та
296 видалення програмних пакетів. Пакет складається з файлового архіву та
297 службової інформації, що містить назву, версію, опис та іншу
298 інформацію про пакет.
299
300 %package base
301 Summary:        RPM base package - scripts used by rpm packages themselves
302 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
303 Group:          Base
304 Requires:       filesystem
305 Obsoletes:      rpm-scripts
306 Obsoletes:      vserver-rpm
307
308 %description base
309 The RPM base package contains scripts used by rpm packages themselves.
310 These include:
311 - scripts for adding/removing groups and users needed for rpm
312   packages,
313 - banner.sh to display %%banner messages from rpm scriptlets.
314
315 %description base -l pl.UTF-8
316 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
317 Zawiera on:
318 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
319 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
320
321 %package lib
322 Summary:        RPMs library
323 Summary(pl.UTF-8):      Biblioteki RPM-a
324 Group:          Libraries
325 Requires:       %{reqdb_pkg} >= %{reqdb_pkgver}
326 %if %{with sqlite}
327 Requires:       sqlite3 >= %{sqlite_build_version}
328 %else
329 Requires:       %{reqdb_pkg}-sql >= %{reqdb_pkgver}
330 %endif
331 Requires:       beecrypt >= %{beecrypt_ver}
332 Requires:       libmagic >= 1.15-2
333 %{?with_selinux:Requires:       libselinux >= 2.1.0}
334 Requires:       popt >= %{reqpopt_ver}
335 Obsoletes:      rpm-libs
336 # avoid SEGV caused by mixed db versions
337 Conflicts:      poldek < 0.18.1-16
338
339 %description lib
340 RPMs library.
341
342 %description lib -l pl.UTF-8
343 Biblioteki RPM-a.
344
345 %package devel
346 Summary:        Header files for rpm libraries
347 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
348 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
349 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
350 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
351 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
352 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
353 Group:          Development/Libraries
354 Requires:       %{name}-lib = %{version}-%{release}
355 Requires:       %{reqdb_pkg}-devel >= %{reqdb_pkgver}
356 Requires:       beecrypt-devel >= %{beecrypt_ver}
357 Requires:       bzip2-devel
358 Requires:       elfutils-devel
359 %{?with_keyutils:Requires:      keyutils-devel}
360 Requires:       libmagic-devel
361 %if %{with selinux}
362 Requires:       libselinux-devel
363 Requires:       libsemanage-devel
364 Requires:       libsepol-devel
365 %endif
366 Requires:       popt-devel >= %{reqpopt_ver}
367 Requires:       zlib-devel
368
369 %description devel
370 The RPM packaging system includes C libraries that make it easy to
371 manipulate RPM packages and databases. They are intended to ease the
372 creation of graphical package managers and other tools that need
373 intimate knowledge of RPM packages. This package contains header files
374 for these libraries.
375
376 %description devel -l de.UTF-8
377 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
378 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
379 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
380 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
381
382 %description devel -l es.UTF-8
383 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
384 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
385 facilitar la creación de administradores gráficos de paquetes y otras
386 herramientas que necesiten un conocimiento profundo de paquetes RPM.
387
388 %description devel -l pl.UTF-8
389 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
390 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
391 graficznych programów zarządzających pakietami oraz innych narzędzi,
392 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
393 zawiera pliki nagłówkowe wspomnianych bibliotek.
394
395 %description devel -l pt_BR.UTF-8
396 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
397 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
398 facilitar a criação de gerenciadores gráficos de pacotes e outras
399 ferramentas que precisem de conhecimento profundo de pacotes RPM.
400
401 %description devel -l ru.UTF-8
402 Система управления пакетами RPM содержит библиотеку C, которая
403 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
404 Эта библиотека предназначена для облегчения создания графических
405 пакетных менеджеров и других утилит, которым необходимо работать с
406 пакетами RPM.
407
408 %description devel -l uk.UTF-8
409 Система керування пакетами RPM містить бібліотеку C, котра спрощує
410 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
411 призначена для полегшення створення графічних пакетних менеджерів та
412 інших утиліт, що працюють з пакетами RPM.
413
414 %package static
415 Summary:        RPM static libraries
416 Summary(de.UTF-8):      RPMs statische Libraries
417 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
418 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
419 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
420 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
421 Group:          Development/Libraries
422 Requires:       %{name}-devel = %{version}-%{release}
423 Requires:       %{reqdb_pkg}-static >= %{reqdb_pkgver}
424 Requires:       beecrypt-static >= %{beecrypt_ver}
425 Requires:       bzip2-static
426 Requires:       elfutils-static
427 %{?with_keyutils:Requires:      keyutils-static}
428 Requires:       libmagic-static
429 %if %{with selinux}
430 Requires:       libselinux-static
431 Requires:       libsemanage-static
432 Requires:       libsepol-static
433 %endif
434 Requires:       popt-static >= %{reqpopt_ver}
435 Requires:       zlib-static
436
437 %description static
438 RPM static libraries.
439
440 %description static -l de.UTF-8
441 RPMs statische Libraries.
442
443 %description static -l pl.UTF-8
444 Biblioteki statyczne RPM-a.
445
446 %description static -l pt_BR.UTF-8
447 Bibliotecas estáticas para desenvolvimento.
448
449 %description static -l ru.UTF-8
450 Система управления пакетами RPM содержит библиотеку C, которая
451 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
452 Это статическая библиотека RPM.
453
454 %description static -l uk.UTF-8
455 Система керування пакетами RPM містить бібліотеку C, котра спрощує
456 роботу з пакетами RPM та відповідними базами даних. Це статична
457 бібліотека RPM.
458
459 %package utils
460 Summary:        Additional utilities for managing RPM packages and database
461 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
462 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
463 Group:          Applications/File
464 Requires:       %{name} = %{version}-%{release}
465 Requires:       popt >= %{reqpopt_ver}
466 %if %{with suggest_tags}
467 Suggests:       bzip2
468 Suggests:       gzip
469 %endif
470 Conflicts:      filesystem-debuginfo < 3.0-16
471
472 %description utils
473 Additional utilities for managing RPM packages and database.
474
475 %description utils -l de.UTF-8
476 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
477
478 %description utils -l pl.UTF-8
479 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
480
481 %package utils-perl
482 Summary:        Additional utilities for managing RPM packages and database
483 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
484 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
485 Group:          Applications/File
486 Requires:       %{name}-utils = %{version}-%{release}
487 Requires:       popt >= %{reqpopt_ver}
488
489 %description utils-perl
490 Additional utilities for managing RPM packages and database.
491
492 %description utils-perl -l de.UTF-8
493 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
494
495 %description utils-perl -l pl.UTF-8
496 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
497
498 %package utils-static
499 Summary:        Static rpm utilities
500 Summary(pl.UTF-8):      Statyczne narzędzia rpm
501 Group:          Applications/System
502 Requires:       %{name} = %{version}-%{release}
503
504 %description utils-static
505 Static rpm utilities for repairing system in case something with
506 shared libraries used by rpm become broken. Currently it contains rpmi
507 binary, which can be used to install/upgrade/remove packages without
508 using shared libraries (well, in fact with exception of NSS modules).
509
510 %description utils-static -l pl.UTF-8
511 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
512 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
513 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
514 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
515 (z wyjątkiem modułów NSS).
516
517 %package build
518 Summary:        Scripts for building binary RPM packages
519 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
520 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
521 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
522 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
523 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
524 Group:          Applications/File
525 Requires(pretrans):     coreutils
526 Requires(pretrans):     findutils
527 Requires:       %{name}-build-macros >= 1.712
528 Requires:       %{name}-utils = %{version}-%{release}
529 Requires:       /bin/id
530 Requires:       awk
531 Requires:       bzip2
532 Requires:       chrpath >= 0.10-4
533 Requires:       cpio
534 Requires:       diffutils
535 Requires:       elfutils
536 Requires:       file >= 4.17
537 Requires:       fileutils
538 Requires:       findutils
539 %ifarch athlon
540 Requires:       gcc >= 3.0.3
541 %else
542 Requires:       gcc
543 %endif
544 Requires:       glibc-devel
545 Requires:       grep
546 Requires:       gzip
547 Requires:       make
548 Requires:       patch
549 Requires:       sed >= 4.0
550 Requires:       sh-utils
551 Requires:       tar >= 1:1.22
552 Requires:       textutils
553 Requires:       which
554 Requires:       xz
555 Provides:       rpmbuild(monoautodeps)
556 Provides:       rpmbuild(noauto) = 3
557 %ifarch %{x8664}
558 Conflicts:      automake < 1:1.7.9-2
559 Conflicts:      libtool < 2:1.5-13
560 %endif
561
562 %description build
563 Scripts for building binary RPM packages.
564
565 %description build -l de.UTF-8
566 Scripts fürs Bauen binärer RPM-Pakete.
567
568 %description build -l pl.UTF-8
569 Skrypty pomocnicze do budowania binarnych RPM-ów.
570
571 %description build -l pt_BR.UTF-8
572 Este pacote contém scripts e programas executáveis que são usados para
573 construir pacotes usando o RPM.
574
575 %description build -l ru.UTF-8
576 Различные вспомогательные скрипты и исполняемые программы, которые
577 используются для сборки RPM'ов.
578
579 %description build -l uk.UTF-8
580 Різноманітні допоміжні скрипти та утиліти, які використовуються для
581 побудови RPM'ів.
582
583 %package javaprov
584 Summary:        Additional utilities for checking Java provides/requires in RPM packages
585 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
586 Group:          Applications/File
587 Requires:       %{name} = %{version}-%{release}
588 Requires:       file
589 Requires:       findutils >= 1:4.2.26
590 Requires:       mktemp
591 Requires:       unzip
592
593 %description javaprov
594 Additional utilities for checking Java provides/requires in RPM
595 packages.
596
597 %description javaprov -l pl.UTF-8
598 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
599 RPM.
600
601 %package perlprov
602 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
603 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
604 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
605 Group:          Applications/File
606 Requires:       %{name} = %{version}-%{release}
607 Requires:       perl-Encode
608 Requires:       perl-devel
609 Requires:       perl-modules
610
611 %description perlprov
612 Additional utilities for checking Perl provides/requires in RPM
613 packages.
614
615 %description perlprov -l de.UTF-8
616 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
617
618 %description perlprov -l pl.UTF-8
619 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
620 pakietach RPM.
621
622 %package pythonprov
623 Summary:        Python macros, which simplifies creation of RPM packages with Python software
624 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
625 Group:          Applications/File
626 Requires:       %{name} = %{version}-%{release}
627 Requires:       python
628 Requires:       python-setuptools
629 Requires:       python-modules
630
631 %description pythonprov
632 Python macros, which simplifies creation of RPM packages with Python
633 software.
634
635 %description pythonprov -l pl.UTF-8
636 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
637 Pythonie.
638
639 %package php-pearprov
640 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
641 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
642 Group:          Applications/File
643 Requires:       %{name} = %{version}-%{release}
644 Requires:       sed >= 4.0
645 Suggests:       php-pear-PHP_CompatInfo
646
647 %description php-pearprov
648 Additional utilities for checking PHP PEAR provides/requires in RPM
649 packages.
650
651 %description php-pearprov -l pl.UTF-8
652 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
653 pakietach RPM.
654
655 %package rubyprov
656 Summary:        Ruby tools, which simplify creation of RPM packages with Ruby software
657 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
658 Group:          Applications/File
659 Requires:       %{name} = %{version}-%{release}
660 Requires:       ruby
661 Requires:       ruby-modules
662 Requires:       ruby-rubygems
663
664 %description rubyprov
665 Ruby tools, which simplifies creation of RPM packages with Ruby
666 software.
667
668 %description rubyprov -l pl.UTF-8
669 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
670 Ruby.
671
672 %package -n python-rpm
673 Summary:        Python interface to RPM library
674 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
675 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
676 Group:          Development/Languages/Python
677 Requires:       %{name} = %{version}-%{release}
678 Requires:       python
679 Obsoletes:      rpm-python
680
681 %description -n python-rpm
682 The rpm-python package contains a module which permits applications
683 written in the Python programming language to use the interface
684 supplied by RPM (RPM Package Manager) libraries.
685
686 This package should be installed if you want to develop Python
687 programs that will manipulate RPM packages and databases.
688
689 %description -n python-rpm -l pl.UTF-8
690 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
691 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
692
693 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
694 Pythonie programy manipulujące pakietami i bazami danych rpm.
695
696 %description -n python-rpm -l pt_BR.UTF-8
697 O pacote rpm-python contém um módulo que permite que aplicações
698 escritas em Python utilizem a interface fornecida pelas bibliotecas
699 RPM (RPM Package Manager).
700
701 Esse pacote deve ser instalado se você quiser desenvolver programas em
702 Python para manipular pacotes e bancos de dados RPM.
703
704 %package apidocs
705 Summary:        RPM API documentation and guides
706 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
707 Group:          Documentation
708 %if "%{_rpmversion}" >= "5"
709 BuildArch:      noarch
710 %endif
711
712 %description apidocs
713 Documentation for RPM API and guides in HTML format generated from rpm
714 sources by doxygen.
715
716 %description apidocs -l pl.UTF-8
717 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
718 źrodeł RPM-a przez doxygen.
719
720 %prep
721 %setup -q -n %{name}-%{version}%{?subver}
722 install -d platform
723 cd platform
724 ar x %{SOURCE100}
725 cd -
726
727 #patch0 -p1
728 %patch1 -p1
729 %patch2 -p1
730 %patch4 -p1
731 %patch5 -p1
732 %patch6 -p1
733 #%patch7 -p1
734 %patch9 -p1
735 %patch14 -p0
736 %patch15 -p1
737 #%patch16 -p1
738 #%patch18 -p1
739 %patch20 -p1
740 %patch29 -p1
741 %patch30 -p1
742 #%patch35 -p1
743 %patch37 -p1
744 %patch42 -p1
745 %patch43 -p1
746 %patch44 -p1
747 %patch45 -p1
748 %patch46 -p1
749 %patch47 -p1
750 %patch48 -p1
751 %patch49 -p1
752 %patch50 -p1
753 %patch51 -p1
754 %patch52 -p0
755 %patch53 -p1
756 %patch54 -p1
757 %patch55 -p1
758 %patch56 -p1
759 %{!?with_db61:%patch57 -p1}
760 %patch58 -p1
761 %patch59 -p1
762 %patch60 -p1
763 %patch61 -p1
764 %patch62 -p1
765 %patch63 -p1
766 %patch64 -p1
767 %patch65 -p1
768 %patch66 -p1
769 %patch67 -p1
770 %patch68 -p1
771 %patch70 -p1
772 %patch71 -p1
773 %patch72 -p1
774 %patch74 -p1
775 %patch75 -p1
776 %patch77 -p0
777 %patch78 -p1
778 %patch79 -p1
779 %patch80 -p1
780 %patch81 -p0
781 %patch82 -p1
782 %patch84 -p1
783 %patch85 -p1
784 %patch86 -p1
785 %patch87 -p1
786 %patch88 -p1
787 %patch89 -p1
788 %patch90 -p1
789 %patch91 -p1
790 %patch99 -p1
791
792 %patch83 -p1
793 %patch92 -p1
794 %patch93 -p1
795 %patch94 -p1
796 %patch95 -p1
797 %patch96 -p1
798 %patch97 -p1
799 %patch98 -p1
800
801 %patch100 -p1
802
803 install %{SOURCE2} macros/pld.in
804 #install %{SOURCE8} scripts/php.prov.in
805 #install %{SOURCE9} scripts/php.req.in
806 install %{SOURCE11} scripts/perl.prov.in
807 cp -p %{SOURCE30} scripts/rubygems.rb
808 cp -p %{SOURCE31} scripts/gem_helper.rb
809
810 rm scripts/find-php*
811
812 %{__mv} -f scripts/perl.req{,.in}
813
814 # generate Group translations to *.po
815 awk -f %{SOURCE6} %{SOURCE1}
816
817 install %{SOURCE26} tools/rpmdb_checkversion.c
818 install %{SOURCE28} tools/rpmdb_reset.c
819
820 for extlib in beecrypt neon %{?with_system_pcre:pcre} popt; do
821         [ -d $extlib ] && %{__rm} -r $extlib
822 done
823
824 %build
825 %{__libtoolize}
826 #%{__autopoint}
827 %{__aclocal}
828 %{__autoheader}
829 %{__autoconf}
830 %{__automake}
831
832 # rpm checks for CPU type at runtime, but it looks better
833 sed -i \
834         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
835         -e 's|@host_cpu@|%{_target_cpu}|' \
836         -e 's|@host_os@|%{_target_os}|' \
837         macros/macros.in
838
839 CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"
840 %configure \
841         WITH_PERL_VERSION=no \
842         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
843         __GPG=%{_bindir}/gpg \
844         --disable-silent-rules \
845         --enable-shared \
846         --enable-static \
847         %{!?with_apidocs:--without-apidocs} \
848         --with-beecrypt=external \
849         --with-bugreport="http://bugs.pld-linux.org/" \
850         --with-bzip2=external \
851         --with-db=external \
852         --with-dbapi=db \
853         --with-file=external \
854         --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
855         --with-libelf \
856         --with-lua \
857         --with-lzma=external \
858         --with-neon=%{?with_neon:external}%{!?with_neon:no} \
859         --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/%%{_target}/macros:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
860         --without-path-versioned \
861         --with-pcre=%{!?with_system_pcre:internal}%{?with_system_pcre:external} \
862         --with-popt=external \
863         %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
864         %{!?with_python:--without-python} \
865         --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
866         --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
867         --with-sepol=%{!?with_selinux:no}%{?with_selinux:external} \
868         --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
869         --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
870         --with-vendor=pld \
871         --with-xz=external \
872         --with-zlib=external
873
874 %{__make} -j1
875
876 %{?with_apidocs:%{__make} apidocs}
877
878 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
879         -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
880 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
881         -o tools/rpmdb_reset -ldb-%{reqdb_ver}
882
883 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
884         echo "Error linking rpmdb tools!"
885         exit 1
886 fi
887 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
888         echo "Error linking rpmdb tools!"
889         exit 1
890 fi
891
892 %install
893 rm -rf $RPM_BUILD_ROOT
894 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
895         $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
896
897 install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
898
899 %{__make} -j1 install \
900         pkgconfigdir=%{_pkgconfigdir} \
901         DESTDIR=$RPM_BUILD_ROOT
902
903 # install platform macros
904 for f in platform/*macros; do
905         bn=${f#*/}
906         fn=${bn%.macros}/macros
907         install -m644 $f -D %{buildroot}%{_rpmlibdir}/$fn
908 done
909
910 # cleanup
911 %ifnarch %{ix86} %{x8664} x32
912 rm $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
913 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
914 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
915 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
916 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
917 rm $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
918 rm $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
919 %endif
920
921 %ifnarch %{x8664} x32
922 rm $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
923 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
924 rm $RPM_BUILD_ROOT%{_rpmlibdir}/x32-linux/macros
925 rm $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
926 %endif
927
928 %ifnarch %{ppc}
929 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
930 %endif
931
932 rm $RPM_BUILD_ROOT%{_rpmlibdir}/alpha*-linux/macros
933 rm $RPM_BUILD_ROOT%{_rpmlibdir}/arm*-linux/macros
934 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ia64-linux/macros
935 rm $RPM_BUILD_ROOT%{_rpmlibdir}/k6-linux/macros
936 rm $RPM_BUILD_ROOT%{_rpmlibdir}/mips*-linux/macros
937 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc*series-linux/macros
938 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc64*-linux/macros
939 rm $RPM_BUILD_ROOT%{_rpmlibdir}/s390*-linux/macros
940 rm $RPM_BUILD_ROOT%{_rpmlibdir}/sparc*-linux/macros
941
942 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
943 # first platform file entry can't contain regexps
944 %ifarch x32
945 %{_target_cpu}-%{_target_vendor}-linux-gnux32
946 %else
947 %{_target_cpu}-%{_target_vendor}-linux
948 %endif
949
950 %ifarch x86_64
951 x86_64-[^-]*-[Ll]inux(-gnu)?
952 amd64-[^-]*-[Ll]inux(-gnu)?
953 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
954 %endif
955 %ifarch amd64
956 amd64-[^-]*-[Ll]inux(-gnu)?
957 x86_64-[^-]*-[Ll]inux(-gnu)?
958 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
959 %endif
960 %ifarch ia32e
961 ia32e-[^-]*-[Ll]inux(-gnu)?
962 x86_64-[^-]*-[Ll]inux(-gnu)?
963 %endif
964 %ifarch x32
965 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
966 x86_64-[^-]*-[Ll]inux(-gnu)?
967 amd64-[^-]*-[Ll]inux(-gnu)?
968 %endif
969
970 %ifarch athlon %{x8664} x32
971 athlon-[^-]*-[Ll]inux(-gnu)?
972 %endif
973 %ifarch pentium4 athlon %{x8664} x32
974 pentium4-[^-]*-[Ll]inux(-gnu)?
975 %endif
976 %ifarch pentium3 pentium4 athlon %{x8664} x32
977 pentium3-[^-]*-[Ll]inux(-gnu)?
978 %endif
979 %ifarch i686 pentium3 pentium4 athlon %{x8664} x32
980 i686-[^-]*-[Ll]inux(-gnu)?
981 %endif
982 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664} x32
983 i586-[^-]*-[Ll]inux(-gnu)?
984 %endif
985 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664} x32
986 i486-[^-]*-[Ll]inux(-gnu)?
987 %endif
988 %ifarch %{ix86} %{x8664} x32
989 i386-[^-]*-[Ll]inux(-gnu)?
990 %endif
991
992 %ifarch alpha
993 alpha-[^-]*-[Ll]inux(-gnu)?
994 %endif
995
996 %ifarch ia64
997 ia64-[^-]*-[Ll]inux(-gnu)?
998 %endif
999
1000 %ifarch ppc64
1001 powerpc64-[^-]*-[Ll]inux(-gnu)?
1002 ppc64-[^-]*-[Ll]inux(-gnu)?
1003 %endif
1004 %ifarch %{ppc} ppc64
1005 powerpc-[^-]*-[Ll]inux(-gnu)?
1006 ppc-[^-]*-[Ll]inux(-gnu)?
1007 %endif
1008
1009 %ifarch s390x
1010 s390x-[^-]*-[Ll]inux(-gnu)?
1011 %endif
1012 %ifarch s390 s390x
1013 s390-[^-]*-[Ll]inux(-gnu)?
1014 %endif
1015
1016 %ifarch sparc64
1017 sparc64-[^-]*-[Ll]inux(-gnu)?
1018 sparcv8-[^-]*-[Ll]inux(-gnu)?
1019 sparcv9-[^-]*-[Ll]inux(-gnu)?
1020 %endif
1021 %ifarch sparcv9
1022 sparcv8-[^-]*-[Ll]inux(-gnu)?
1023 sparcv9-[^-]*-[Ll]inux(-gnu)?
1024 %endif
1025 %ifarch sparc sparcv9 sparc64
1026 sparc-[^-]*-[Ll]inux(-gnu)?
1027 %endif
1028
1029 noarch-[^-]*-.*
1030 EOF
1031
1032 # Squash Extra Blank Lines
1033 %{__sed} -i -e '/./,/^$/!d' $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
1034
1035 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1036 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1037 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
1038 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
1039 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.a
1040 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.la
1041 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-provides
1042 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-requires
1043
1044 # not installed since 4.4.8 (-tools-perl subpackage)
1045 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1046
1047 install %{SOURCE1} doc/manual/groups
1048 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
1049 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1050 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
1051 install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1052 install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
1053 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
1054 cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
1055 install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
1056 install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
1057 install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
1058
1059 install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
1060
1061 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1062
1063 install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
1064 install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
1065 install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1066 install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1067 install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1068 install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
1069 install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
1070
1071 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1072 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
1073 install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
1074 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1075 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1076 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
1077
1078 install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1079 install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1080 install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
1081
1082 # create macro loading wrappers for backward compatibility
1083 for m in gstreamer java mono perl php python; do
1084         echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
1085 done
1086
1087 # moved to rpm-build-macros 1.699
1088 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/macros.d/kernel
1089
1090 # for rpm -e|-U --repackage
1091 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1092 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
1093
1094 # move rpm to /bin
1095 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1096 # move essential libs to /lib (libs that /bin/rpm links to)
1097 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
1098         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1099         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
1100 done
1101
1102 # Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1103 mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1104
1105 %if %{with python}
1106 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1107 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
1108
1109 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
1110 %endif
1111
1112 # wrong location, not used anyway
1113 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
1114 # utils dropped in 5.4 -- their manuals
1115 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
1116 # script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1117 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
1118
1119 %find_lang %{name}
1120
1121 %{__rm} -rf manual
1122 cp -a doc/manual manual
1123 %{__rm} -f manual/Makefile*
1124
1125 %clean
1126 rm -rf $RPM_BUILD_ROOT
1127
1128 %pretrans
1129 # this needs to be a dir
1130 if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
1131         umask 022
1132         mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1133         mkdir %{_sysconfdir}/rpm/sysinfo
1134 fi
1135
1136 %posttrans
1137 if [ -e /var/lib/rpm/Packages ] && \
1138                 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
1139         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
1140                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
1141                 echo
1142                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
1143                 echo
1144         fi
1145         echo
1146         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
1147         echo 'you should ignore it and restart poldek'
1148         echo
1149         %{_rpmlibdir}/bin/dbupgrade.sh
1150 fi
1151
1152 %triggerpostun -- %{name} < 4.4.9-44
1153 %{_rpmlibdir}/hrmib-cache
1154
1155 %post   lib -p /sbin/ldconfig
1156 %postun lib -p /sbin/ldconfig
1157
1158 %pretrans build
1159 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
1160
1161 %files -f %{name}.lang
1162 %defattr(644,root,root,755)
1163 %doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
1164
1165 %dir /etc/pki/rpm-gpg
1166 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1167
1168 %attr(755,root,root) /bin/rpm
1169
1170 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
1171 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
1172 %dir %{_sysconfdir}/rpm/sysinfo
1173 # these are ok to be replaced
1174 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
1175 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1176
1177 %{_mandir}/man8/rpm.8*
1178 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1179 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1180 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1181 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1182 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1183
1184 %dir /var/lib/rpm
1185 %dir /var/lib/rpm/log
1186 %dir /var/lib/rpm/tmp
1187 %config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
1188 %dir %attr(700,root,root) /var/spool/repackage
1189 %dir /var/lock/rpm
1190 /var/lock/rpm/transaction
1191
1192 # exported package NVRA (stamped with install tid)
1193 # net-snmp hrSWInstalledName queries, bash-completions
1194 %dir /var/cache/hrmib
1195
1196 %{_rpmlibdir}/qf
1197 %{_rpmlibdir}/rpmpopt*
1198 %{_rpmlibdir}/macros
1199 %dir %{_rpmlibdir}/macros.d
1200 %{_rpmlibdir}/macros.d/pld
1201 %{_rpmlibdir}/cpuinfo.yaml
1202 %{_rpmlibdir}/noarch-*
1203 %ifarch %{ix86} %{x8664} x32
1204 %{_rpmlibdir}/i?86*
1205 %{_rpmlibdir}/pentium*
1206 %{_rpmlibdir}/athlon*
1207 %endif
1208 %ifarch alpha
1209 %{_rpmlibdir}/alpha*
1210 %endif
1211 %ifarch ia64
1212 %{_rpmlibdir}/ia64*
1213 %endif
1214 %ifarch mips mipsel mips64 mips64el
1215 %{_rpmlibdir}/mips*
1216 %endif
1217 %ifarch %{ppc}
1218 %{_rpmlibdir}/ppc*
1219 %endif
1220 %ifarch sparc sparc64
1221 %{_rpmlibdir}/sparc*
1222 %endif
1223 %ifarch %{x8664} x32
1224 %{_rpmlibdir}/amd64*
1225 %{_rpmlibdir}/ia32e*
1226 %{_rpmlibdir}/x86_64*
1227 %{_rpmlibdir}/x32*
1228 %endif
1229
1230 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1231
1232 %dir %{_rpmlibdir}/bin
1233 %attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
1234 %attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
1235 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
1236 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
1237 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdbchk
1238
1239 %files base
1240 %defattr(644,root,root,755)
1241 %dir %{_sysconfdir}/rpm
1242 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1243 %dir %{_rpmlibdir}
1244 %attr(755,root,root) %{_bindir}/banner.sh
1245 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1246 %dir /var/lib/banner
1247
1248 %files lib
1249 %defattr(644,root,root,755)
1250 %attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1251 %attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1252 %attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1253 %attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
1254 %attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
1255 %attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
1256
1257 %files devel
1258 %defattr(644,root,root,755)
1259 %attr(755,root,root) %{_libdir}/librpm.so
1260 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1261 %attr(755,root,root) %{_libdir}/librpmbuild.so
1262 %attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
1263 %attr(755,root,root) %{_libdir}/librpmconstant.so
1264 %attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
1265 %attr(755,root,root) %{_libdir}/librpmdb.so
1266 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1267 %attr(755,root,root) %{_libdir}/librpmio.so
1268 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1269 %attr(755,root,root) %{_libdir}/librpmmisc.so
1270 %attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
1271 %{_libdir}/librpm*.la
1272 %{_includedir}/rpm
1273 %{_pkgconfigdir}/*.pc
1274
1275 %files static
1276 %defattr(644,root,root,755)
1277 %{_libdir}/librpm*.a
1278
1279 %files utils
1280 %defattr(644,root,root,755)
1281 %attr(755,root,root) %{_bindir}/rpm2cpio
1282 %attr(755,root,root) %{_bindir}/rpmconstant
1283 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1284 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1285 %attr(755,root,root) %{_rpmlibdir}/tgpg
1286 %attr(755,root,root) %{_rpmlibdir}/bin/chroot
1287 %attr(755,root,root) %{_rpmlibdir}/bin/cp
1288 %attr(755,root,root) %{_rpmlibdir}/bin/debugedit
1289 %attr(755,root,root) %{_rpmlibdir}/bin/find
1290 %attr(755,root,root) %{_rpmlibdir}/bin/mgo
1291 %attr(755,root,root) %{_rpmlibdir}/bin/mtree
1292 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1293 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1294 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1295 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
1296 %if %{with selinux}
1297 %attr(755,root,root) %{_rpmlibdir}/bin/semodule
1298 %attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1299 %endif
1300 %{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
1301 %attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
1302 %{_mandir}/man8/rpm2cpio.8*
1303 %{_mandir}/man8/rpmconstant.8*
1304 %{_mandir}/man8/rpmdeps.8*
1305 %{_mandir}/man8/rpmmtree.8*
1306 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1307 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1308 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1309 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1310
1311 %files utils-perl
1312 %defattr(644,root,root,755)
1313 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1314
1315 %if %{with static}
1316 %files utils-static
1317 %defattr(644,root,root,755)
1318 %attr(755,root,root) %{_bindir}/rpm[ieu]
1319 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1320 %endif
1321
1322 %files build
1323 %defattr(644,root,root,755)
1324 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1325 %attr(755,root,root) %{_rpmlibdir}/brp-*
1326 %attr(755,root,root) %{_rpmlibdir}/check-files
1327 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1328 %attr(755,root,root) %{_rpmlibdir}/cross-build
1329 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1330 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1331 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1332 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1333 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1334 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1335 %attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
1336 # needs hacked pkg-config to return anything
1337 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1338 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1339 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
1340 %{!?with_sqlite:%attr(755,root,root) %{_rpmlibdir}/bin/dbsql}
1341 %attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1342 %attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
1343 %attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1344 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspec
1345 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1346 %attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1347 %attr(755,root,root) %{_rpmlibdir}/bin/wget
1348 %attr(755,root,root) %{_rpmlibdir}/vcheck
1349 # not used yet ... these six depend on perl
1350 %attr(755,root,root) %{_rpmlibdir}/http.req
1351 # we always used scripts provided by mono-devel, maybe move them here
1352 #%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1353 #%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
1354
1355 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
1356 # must be here for "Requires: rpm-*prov" to work
1357 %{_rpmlibdir}/macros.d/cmake
1358 %{_rpmlibdir}/macros.d/gstreamer
1359 %{_rpmlibdir}/macros.d/java
1360 %{_rpmlibdir}/macros.d/libtool
1361 %{_rpmlibdir}/macros.d/mono
1362 %{_rpmlibdir}/macros.d/perl
1363 %{_rpmlibdir}/macros.d/php
1364 %{_rpmlibdir}/macros.d/pkgconfig
1365 %{_rpmlibdir}/macros.d/python
1366 %{_rpmlibdir}/macros.d/ruby
1367 %{_rpmlibdir}/macros.d/selinux
1368 %{_rpmlibdir}/macros.d/tcl
1369 %{_rpmlibdir}/macros.rpmbuild
1370 # compat wrappers
1371 %{_rpmlibdir}/macros.gstreamer
1372 %{_rpmlibdir}/macros.java
1373 %{_rpmlibdir}/macros.mono
1374 %{_rpmlibdir}/macros.perl
1375 %{_rpmlibdir}/macros.php
1376 %{_rpmlibdir}/macros.python
1377
1378 %attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1379 %attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1380
1381 %attr(755,root,root) %{_bindir}/gendiff
1382 %attr(755,root,root) %{_bindir}/rpmbuild
1383
1384 %dir %{_rpmlibdir}/helpers
1385 %attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
1386
1387 %{_mandir}/man1/gendiff.1*
1388 %{_mandir}/man8/rpmbuild.8*
1389 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1390 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1391 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1392
1393 %files javaprov
1394 %defattr(644,root,root,755)
1395 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1396 # needs jar (any jdk), jcf-dump (gcc-java) to work
1397 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1398
1399 %files rubyprov
1400 %defattr(644,root,root,755)
1401 %attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1402 %attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1403
1404 %files perlprov
1405 %defattr(644,root,root,755)
1406 %attr(755,root,root) %{_rpmlibdir}/perl.*
1407 %attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1408 %attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1409
1410 %files pythonprov
1411 %defattr(644,root,root,755)
1412 %attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
1413 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1414
1415 %files php-pearprov
1416 %defattr(644,root,root,755)
1417 %attr(755,root,root) %{_rpmlibdir}/php.prov
1418 %attr(755,root,root) %{_rpmlibdir}/php.req
1419 %attr(755,root,root) %{_rpmlibdir}/php.req.php
1420
1421 %if %{with python}
1422 %files -n python-rpm
1423 %defattr(644,root,root,755)
1424 %dir %{py_sitedir}/rpm
1425 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1426 %{py_sitedir}/rpm/*.py[co]
1427 %endif
1428
1429 %if %{with apidocs}
1430 %files apidocs
1431 %defattr(644,root,root,755)
1432 %doc apidocs
1433 %endif
This page took 0.375848 seconds and 3 git commands to generate.