]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
16bc4ec193268317037547391f51e61d8ec04239
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - rebuild database after upgrading from rpm5
4 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
5 #
6 # Conditional build:
7 %bcond_without  apidocs         # don't generate documentation with doxygen
8 %bcond_without  python2         # don't build python bindings
9 %bcond_without  python3         # don't build python bindings
10 %bcond_without  plugins         # build plugins
11 %bcond_without  recommends_tags # build without Recommends tag (bootstrapping)
12 %bcond_with     db61            # use DB 6.1 instead of 5.3
13
14 # versions of required libraries
15 %if %{with db61}
16 %define         reqdb_pkg       db6.1
17 %define         reqdb_ver       6.1
18 %define         reqdb_pkgver    6.1.19
19 %else
20 %define         reqdb_pkg       db5.3
21 %define         reqdb_ver       5.3
22 %define         reqdb_pkgver    5.3.28.0
23 %endif
24 %define         reqpopt_ver     1.15
25 %define         openssl_ver     1.1.1d
26 %define         sover           9.0.1
27
28 Summary:        RPM Package Manager
29 Summary(de.UTF-8):      RPM Packet-Manager
30 Summary(es.UTF-8):      Gestor de paquetes RPM
31 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
32 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
33 Summary(ru.UTF-8):      Менеджер пакетов от RPM
34 Summary(uk.UTF-8):      Менеджер пакетів від RPM
35 Name:           rpm
36 Version:        4.15.1
37 Release:        0.1
38 Epoch:          1
39 License:        GPL v2 / LGPL v2.1
40 Group:          Base
41 Source0:        http://ftp.rpm.org/releases/rpm-4.15.x/%{name}-%{version}.tar.bz2
42 # Source0-md5:  ed72147451a5ed93b2a48e2f8f5413c3
43 Source1:        ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
44 # Source1-md5:  23914bb49fafe7153cee87126d966461
45 Source2:        macros.local
46 Source3:        macros.lang
47 Source4:        %{name}.sysconfig
48 Source5:        %{name}.groups
49 Source6:        %{name}-groups-po.awk
50 Source7:        %{name}-install-tree
51 Source8:        %{name}-hrmib-cache
52 Source9:        %{name}-user_group.sh
53 # http://svn.pld-linux.org/banner.sh/
54 Source10:       banner.sh
55 Source11:       %{name}.noautocompressdoc
56 Source12:       %{name}.noautoprov
57 Source13:       %{name}.noautoprovfiles
58 Source14:       %{name}.noautoreq
59 Source15:       %{name}.noautoreqfiles
60 Source16:       perl.prov
61 Source17:       %{name}db_checkversion.c
62 Source18:       %{name}db_reset.c
63 Source19:       dbupgrade.sh
64 Patch0:         %{name}-man_pl.patch
65 Patch1:         %{name}-popt-aliases.patch
66 Patch2:         %{name}-perl-macros.patch
67 Patch3:         %{name}-perl-req-perlfile.patch
68 Patch4:         %{name}-scripts-closefds.patch
69 Patch5:         %{name}-lua.patch
70 Patch6:         %{name}-perl_req-INC_dirs.patch
71 Patch7:         %{name}-debuginfo.patch
72 Patch8:         %{name}-libtool-deps.patch
73 Patch9:         %{name}-builddir-readlink.patch
74 Patch10:        %{name}-changelog_order_check_nonfatal.patch
75 Patch11:        %{name}-postun-nofail.patch
76 Patch12:        %{name}-clean-docdir.patch
77 Patch13:        %{name}-perl-magic.patch
78 Patch14:        %{name}-ignore-missing-macro-files.patch
79 Patch15:        x32.patch
80 Patch16:        %{name}-add-compress-doc.patch
81 Patch17:        rpm5-db-compat.patch
82 Patch18:        python-internal-build.patch
83 URL:            https://rpm.org/
84 BuildRequires:  %{reqdb_pkg}-devel >= %{reqdb_pkgver}
85 BuildRequires:  %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
86 BuildRequires:  autoconf >= 2.63
87 BuildRequires:  automake >= 1.4
88 BuildRequires:  bzip2-devel >= 1.0.2-17
89 BuildRequires:  elfutils-devel >= 0.108
90 BuildRequires:  gettext-tools >= 0.19.2
91 BuildRequires:  libarchive-devel
92 BuildRequires:  libmagic-devel
93 BuildRequires:  openssl-devel >= %{openssl_ver}
94 %if %{with plugins}
95 BuildRequires:  audit-libs-devel
96 BuildRequires:  dbus-devel
97 BuildRequires:  libselinux-devel >= 2.1.0
98 %endif
99 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
100 BuildRequires:  libstdc++-devel
101 BuildRequires:  libtool >= 1:1.4.2-9
102 BuildRequires:  lua53-devel >= 5.3.5
103 BuildRequires:  ossp-uuid-devel
104 BuildRequires:  patch >= 2.2
105 BuildRequires:  popt-devel >= %{reqpopt_ver}
106 %{?with_python2:BuildRequires:  python-devel >= 1:2.3}
107 %{?with_python3:BuildRequires:  python3-devel}
108 BuildRequires:  python-modules >= 1:2.3
109 %if %{with python2} || %{with python3}
110 BuildRequires:  rpm-pythonprov
111 %endif
112 BuildRequires:  tcl
113 BuildRequires:  xz-devel
114 BuildRequires:  zlib-devel
115 BuildRequires:  zstd-devel
116 %if %{with apidocs}
117 BuildRequires:  doxygen
118 BuildRequires:  ghostscript
119 BuildRequires:  graphviz
120 BuildRequires:  tetex-pdftex
121 %endif
122 Requires(posttrans):    coreutils
123 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
124 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
125 Requires:       rpm-pld-macros >= 1.744
126 Requires:       FHS >= 3.0-2
127 Requires:       openssl >= %{openssl_ver}
128 Requires:       popt >= %{reqpopt_ver}
129 %if %{with recommends_tags}
130 Recommends:     rpm-plugin-audit
131 Recommends:     rpm-plugin-prioreset
132 Recommends:     rpm-plugin-syslog
133 Recommends:     rpm-plugin-systemd-inhibit
134 %endif
135 Provides:       rpm-db-ver = %{reqdb_ver}
136 Obsoletes:      rpm-getdeps
137 Obsoletes:      rpm-utils-perl
138 Obsoletes:      rpm-utils-static
139 Conflicts:      glibc < 2.2.92
140 # db4.6 poldek needed
141 Conflicts:      poldek < 0.21-0.20070703.00.3
142 # segfaults with lzma 0.42.2
143 Conflicts:      lzma-libs < 4.999.3
144 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
145 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
146
147 %define         _binary_payload         w9.gzdio
148
149 # don't require very fresh rpm.macros to build
150 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
151 %define         ix86    i386 i486 i586 i686 athlon geode pentium3 pentium4
152 %define         ppc     ppc ppc7400 ppc7450
153 %define         x8664   amd64 ia32e x86_64
154
155 %define         _rpmlibdir /usr/lib/rpm
156 %define         _noautocompressdoc      RPM-GPG-KEY
157
158 %description
159 RPM is a powerful package manager, which can be used to build,
160 install, query, verify, update, and uninstall individual software
161 packages. A package consists of an archive of files, and package
162 information, including name, version, and description.
163
164 %description -l de.UTF-8
165 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
166 Installation, Anfrage, Verifizierung, Aktualisierung und
167 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
168 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
169 Beschreibung.
170
171 %description -l es.UTF-8
172 RPM es un poderoso administrador de paquetes, que puede ser usado para
173 construir, instalar, pesquisar, verificar, actualizar y desinstalar
174 paquetes individuales de software. Un paquete consiste en un
175 almacenaje de archivos, y información sobre el paquete, incluyendo
176 nombre, versión y descripción.
177
178 %description -l pl.UTF-8
179 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
180 przebudowanie, instalację czy weryfikację dowolnego pakietu.
181 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
182 plików wchodzących w skład pakietu, zależności od innych pakietów, są
183 przechowywane w bazie danych i można je uzyskać za pomocą opcji
184 odpytywania programu rpm.
185
186 %description -l pt_BR.UTF-8
187 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
188 construir, instalar, pesquisar, verificar, atualizar e desinstalar
189 pacotes individuais de software. Um pacote consiste de um conjunto de
190 arquivos e informações adicionais, incluindo nome, versão e descrição
191 do pacote, permissões dos arquivos, etc.
192
193 %description -l ru.UTF-8
194 RPM - это мощный менеджер пакетов, который может быть использован для
195 создания, инсталляции, запросов (query), проверки, обновления и
196 удаления программных пакетов. Пакет состоит из файлового архива и
197 служебной информации, включающей название, версию, описание и другие
198 данные о пакете.
199
200 %description -l uk.UTF-8
201 RPM - це потужний менеджер пакетів, що може бути використаний для
202 створення, інсталяції, запитів (query), перевірки, поновлення та
203 видалення програмних пакетів. Пакет складається з файлового архіву та
204 службової інформації, що містить назву, версію, опис та іншу
205 інформацію про пакет.
206
207 %package base
208 Summary:        RPM base package - scripts used by rpm packages themselves
209 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
210 Group:          Base
211 Requires:       filesystem
212 Obsoletes:      rpm-scripts
213 Obsoletes:      vserver-rpm
214
215 %description base
216 The RPM base package contains scripts used by rpm packages themselves.
217 These include:
218 - scripts for adding/removing groups and users needed for rpm
219   packages,
220 - banner.sh to display %%banner messages from rpm scriptlets.
221
222 %description base -l pl.UTF-8
223 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
224 Zawiera on:
225 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
226 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
227
228 %package lib
229 Summary:        RPMs library
230 Summary(pl.UTF-8):      Biblioteki RPM-a
231 Group:          Libraries
232 Requires:       %{reqdb_pkg} >= %{reqdb_pkgver}
233 Requires:       %{reqdb_pkg}-sql >= %{reqdb_pkgver}
234 Requires:       libmagic >= 1.15-2
235 Requires:       openssl >= %{openssl_ver}
236 Requires:       popt >= %{reqpopt_ver}
237 Obsoletes:      rpm-libs
238 # avoid SEGV caused by mixed db versions
239 Conflicts:      poldek < 0.18.1-16
240
241 %description lib
242 RPMs library.
243
244 %description lib -l pl.UTF-8
245 Biblioteki RPM-a.
246
247 %package devel
248 Summary:        Header files for rpm libraries
249 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
250 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
251 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
252 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
253 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
254 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
255 Group:          Development/Libraries
256 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
257 Requires:       %{reqdb_pkg}-devel >= %{reqdb_pkgver}
258 Requires:       bzip2-devel
259 Requires:       elfutils-devel
260 Requires:       libmagic-devel
261 Requires:       openssl-devel >= %{openssl_ver}
262 %if %{with selinux}
263 Requires:       libselinux-devel
264 Requires:       libsemanage-devel
265 Requires:       libsepol-devel
266 %endif
267 Requires:       popt-devel >= %{reqpopt_ver}
268 Requires:       zlib-devel
269
270 %description devel
271 The RPM packaging system includes C libraries that make it easy to
272 manipulate RPM packages and databases. They are intended to ease the
273 creation of graphical package managers and other tools that need
274 intimate knowledge of RPM packages. This package contains header files
275 for these libraries.
276
277 %description devel -l de.UTF-8
278 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
279 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
280 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
281 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
282
283 %description devel -l es.UTF-8
284 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
285 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
286 facilitar la creación de administradores gráficos de paquetes y otras
287 herramientas que necesiten un conocimiento profundo de paquetes RPM.
288
289 %description devel -l pl.UTF-8
290 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
291 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
292 graficznych programów zarządzających pakietami oraz innych narzędzi,
293 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
294 zawiera pliki nagłówkowe wspomnianych bibliotek.
295
296 %description devel -l pt_BR.UTF-8
297 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
298 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
299 facilitar a criação de gerenciadores gráficos de pacotes e outras
300 ferramentas que precisem de conhecimento profundo de pacotes RPM.
301
302 %description devel -l ru.UTF-8
303 Система управления пакетами RPM содержит библиотеку C, которая
304 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
305 Эта библиотека предназначена для облегчения создания графических
306 пакетных менеджеров и других утилит, которым необходимо работать с
307 пакетами RPM.
308
309 %description devel -l uk.UTF-8
310 Система керування пакетами RPM містить бібліотеку C, котра спрощує
311 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
312 призначена для полегшення створення графічних пакетних менеджерів та
313 інших утиліт, що працюють з пакетами RPM.
314
315 %package utils
316 Summary:        Additional utilities for managing RPM packages and database
317 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
318 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
319 Group:          Applications/File
320 Requires:       %{name} = %{epoch}:%{version}-%{release}
321 Requires:       popt >= %{reqpopt_ver}
322 %if %{with recommends_tags}
323 Recommends:     bzip2
324 Recommends:     gzip
325 %endif
326 Conflicts:      filesystem-debuginfo < 3.0-16
327
328 %description utils
329 Additional utilities for managing RPM packages and database.
330
331 %description utils -l de.UTF-8
332 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
333
334 %description utils -l pl.UTF-8
335 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
336
337 %package build
338 Summary:        Scripts for building binary RPM packages
339 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
340 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
341 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
342 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
343 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
344 Group:          Applications/File
345 Requires(pretrans):     coreutils
346 Requires(pretrans):     findutils
347 Requires:       %{name}-utils = %{epoch}:%{version}-%{release}
348 Requires:       rpm-pld-macros-build >= 1.744
349 Requires:       /bin/id
350 Requires:       awk
351 Requires:       bzip2
352 Requires:       chrpath >= 0.10-4
353 Requires:       cpio
354 Requires:       diffutils
355 Requires:       elfutils
356 Requires:       file >= 4.17
357 Requires:       fileutils
358 Requires:       findutils
359 %ifarch athlon
360 Requires:       gcc >= 3.0.3
361 %else
362 Requires:       gcc
363 %endif
364 Requires:       glibc-devel
365 Requires:       grep
366 Requires:       gzip
367 Requires:       make
368 Requires:       patch
369 Requires:       sed >= 4.0
370 Requires:       sh-utils
371 Requires:       tar >= 1:1.22
372 Requires:       textutils
373 Requires:       which
374 Requires:       xz
375 Provides:       rpmbuild(noauto) = 3
376 %ifarch %{x8664}
377 Conflicts:      automake < 1:1.7.9-2
378 Conflicts:      libtool < 2:1.5-13
379 %endif
380
381 %description build
382 Scripts for building binary RPM packages.
383
384 %description build -l de.UTF-8
385 Scripts fürs Bauen binärer RPM-Pakete.
386
387 %description build -l pl.UTF-8
388 Skrypty pomocnicze do budowania binarnych RPM-ów.
389
390 %description build -l pt_BR.UTF-8
391 Este pacote contém scripts e programas executáveis que são usados para
392 construir pacotes usando o RPM.
393
394 %description build -l ru.UTF-8
395 Различные вспомогательные скрипты и исполняемые программы, которые
396 используются для сборки RPM'ов.
397
398 %description build -l uk.UTF-8
399 Різноманітні допоміжні скрипти та утиліти, які використовуються для
400 побудови RPM'ів.
401
402 %package perlprov
403 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
404 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
405 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
406 Group:          Applications/File
407 Requires:       %{name} = %{epoch}:%{version}-%{release}
408 Requires:       perl-Encode
409 Requires:       perl-devel
410 Requires:       perl-modules
411
412 %description perlprov
413 Additional utilities for checking Perl provides/requires in RPM
414 packages.
415
416 %description perlprov -l de.UTF-8
417 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
418
419 %description perlprov -l pl.UTF-8
420 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
421 pakietach RPM.
422
423 %package pythonprov
424 Summary:        Python macros, which simplifies creation of RPM packages with Python software
425 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
426 Group:          Applications/File
427 Requires:       %{name} = %{epoch}:%{version}-%{release}
428 Requires:       python
429 Requires:       python-modules
430 Requires:       python-setuptools
431
432 %description pythonprov
433 Python macros, which simplifies creation of RPM packages with Python
434 software.
435
436 %description pythonprov -l pl.UTF-8
437 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
438 Pythonie.
439
440 %package -n python-rpm
441 Summary:        Python interface to RPM library
442 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
443 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
444 Group:          Development/Languages/Python
445 Requires:       %{name} = %{epoch}:%{version}-%{release}
446 Requires:       python
447 Obsoletes:      rpm-python
448
449 %description -n python-rpm
450 The python-rpm package contains a module which permits applications
451 written in the Python programming language to use the interface
452 supplied by RPM (RPM Package Manager) libraries.
453
454 This package should be installed if you want to develop Python
455 programs that will manipulate RPM packages and databases.
456
457 %description -n python-rpm -l pl.UTF-8
458 Pakiet python-rpm zawiera moduł, który pozwala aplikacjom napisanym w
459 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
460
461 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
462 Pythonie programy manipulujące pakietami i bazami danych rpm.
463
464 %description -n python-rpm -l pt_BR.UTF-8
465 O pacote python-rpm contém um módulo que permite que aplicações
466 escritas em Python utilizem a interface fornecida pelas bibliotecas
467 RPM (RPM Package Manager).
468
469 Esse pacote deve ser instalado se você quiser desenvolver programas em
470 Python para manipular pacotes e bancos de dados RPM.
471
472 %package -n python3-rpm
473 Summary:        Python 3 interface to RPM library
474 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki RPM-a
475 Summary(pt_BR.UTF-8):   Módulo Python 3 para aplicativos que manipulam pacotes RPM
476 Group:          Development/Languages/Python
477 Requires:       %{name} = %{epoch}:%{version}-%{release}
478 Requires:       python3
479
480 %description -n python3-rpm
481 The python3-rpm package contains a module which permits applications
482 written in the Python 3 programming language to use the interface
483 supplied by RPM (RPM Package Manager) libraries.
484
485 This package should be installed if you want to develop Python 3
486 programs that will manipulate RPM packages and databases.
487
488 %description -n python3-rpm -l pl.UTF-8
489 Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
490 Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki RPM-a.
491
492 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
493 Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
494
495 %description -n python3-rpm -l pt_BR.UTF-8
496 O pacote python3-rpm contém um módulo que permite que aplicações
497 escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
498 RPM (RPM Package Manager).
499
500 Esse pacote deve ser instalado se você quiser desenvolver programas em
501 Python 3 para manipular pacotes e bancos de dados RPM.
502
503 %package plugin-audit
504 Summary:        Plugin for logging audit events on package operations
505 Group:          System/Base
506 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
507
508 %description plugin-audit
509 Plugin for libaudit support
510
511 %package plugin-syslog
512 Summary:        Plugin for syslog functionality
513 Group:          System/Base
514 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
515
516 %description plugin-syslog
517 This plugin exports RPM actions to the system log.
518
519 %package plugin-systemd-inhibit
520 Summary:        Plugin for systemd inhibit functionality
521 Group:          System/Base
522 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
523
524 %description plugin-systemd-inhibit
525 This plugin blocks systemd from entering idle, sleep or shutdown while
526 an rpm transaction is running using the systemd-inhibit mechanism.
527
528 %package plugin-ima
529 Summary:        Plugin for IMA file signatures
530 Group:          Base
531 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
532
533 %description plugin-ima
534 This plugin adds support for enforcing and verifying IMA file
535 signatures in an rpm.
536
537 %package plugin-prioreset
538 Summary:        Plugin for resetting scriptlet priorities for SysV init
539 Group:          Base
540 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
541
542 %description plugin-prioreset
543 This plugin is useful on legacy SysV init systems if you run rpm
544 transactions with nice/ionice priorities. Should not be used on
545 systemd systems.
546
547 %package plugin-selinux
548 Summary:        Plugin for SELinux functionality
549 Group:          Base
550 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
551 Requires:       libselinux >= 2.1.0
552
553 %description plugin-selinux
554 Plugin for SELinux functionality.
555
556 %package sign
557 Summary:        Package signing support
558 Group:          Base
559 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
560
561 %description sign
562 This package contains support for digitally signing RPM packages.
563
564 %package apidocs
565 Summary:        RPM API documentation and guides
566 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
567 Group:          Documentation
568 BuildArch:      noarch
569
570 %description apidocs
571 Documentation for RPM API and guides in HTML format generated from rpm
572 sources by doxygen.
573
574 %description apidocs -l pl.UTF-8
575 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
576 źrodeł RPM-a przez doxygen.
577
578 %prep
579 %setup -q -n %{name}-%{version}%{?subver}
580 %patch0 -p1
581 %patch1 -p1
582 %patch2 -p1
583 %patch3 -p1
584 %patch4 -p1
585 %patch5 -p1
586 %patch6 -p0
587 %patch7 -p1
588 %patch8 -p1
589 %patch9 -p1
590 %patch10 -p1
591 %patch11 -p1
592 %patch12 -p1
593 %patch13 -p1
594 %patch14 -p1
595 %patch15 -p1
596 %patch16 -p1
597 %patch17 -p1
598 %patch18 -p1
599
600 install %{SOURCE16} scripts/perl.prov.in
601
602 %{__mv} -f scripts/perl.req{,.in}
603
604 # generate Group translations to *.po
605 awk -f %{SOURCE6} %{SOURCE5}
606
607 install %{SOURCE17} tools/rpmdb_checkversion.c
608 install %{SOURCE18} tools/rpmdb_reset.c
609
610 %{__sed} -i -e '1s,/usr/bin/python,%{__python},' scripts/pythondistdeps.py
611
612 %build
613 %{__libtoolize}
614 %{__aclocal}
615 %{__autoheader}
616 %{__autoconf}
617 %{__automake}
618
619 # rpm checks for CPU type at runtime, but it looks better
620 sed -i \
621         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
622         -e 's|@host_cpu@|%{_target_cpu}|' \
623         -e 's|@host_os@|%{_target_os}|' \
624         macros.in
625
626 CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
627 %configure \
628         WITH_PERL_VERSION=no \
629         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
630         __GPG=%{_bindir}/gpg \
631         %{?with_python3:PYTHON=python3} \
632         %{!?with_python3:%{?with_python2:PYTHON=python2}} \
633         --disable-silent-rules \
634         --enable-shared \
635         --enable-bdb \
636         --enable-zstd \
637         --with-crypto=openssl \
638         --with-lua \
639         --with-cap \
640         --with-acl \
641         --with-audit \
642         --with-archive \
643 %if %{with python2} || %{with python3}
644         --enable-python \
645 %endif
646         --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
647         %{!?with_plugins:--disable-plugins} \
648         --with-vendor=pld
649
650 #  --enable-ndb (EXPERIMENTAL) enable the new rpm database format
651 #  --enable-lmdb=[yes/no/auto] (EXPERIMENTAL) build with LMDB rpm database format support (default=auto)
652 #  --with-imaevm           build with imaevm support
653
654 %{__make}
655
656 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
657         -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
658 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
659         -o tools/rpmdb_reset -ldb-%{reqdb_ver}
660
661 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
662         echo "Error linking rpmdb tools!"
663         exit 1
664 fi
665 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
666         echo "Error linking rpmdb tools!"
667         exit 1
668 fi
669
670 %if %{with python2}
671 cd python
672 %py_build
673 cd ..
674 %endif
675
676 %if %{with python3}
677 cd python
678 %py3_build
679 %endif
680
681 %install
682 rm -rf $RPM_BUILD_ROOT
683 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
684         $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/var/cache/hrmib}
685
686 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
687
688 %{__make} install \
689         pkgconfigdir=%{_pkgconfigdir} \
690         DESTDIR=$RPM_BUILD_ROOT
691
692 # cleanup
693 %ifnarch %{ix86} %{x8664} x32
694 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
695 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
696 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
697 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
698 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
699 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
700 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
701 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
702 %endif
703
704 %ifnarch %{x8664} x32
705 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
706 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
707 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
708 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
709 %endif
710
711 %ifnarch %{ppc}
712 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
713 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
714 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
715 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
716 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
717 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
718 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
719 %endif
720
721 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
722 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
723 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
724 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
725 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
726 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
727 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
728 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
729 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
730
731 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
732
733 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
734
735 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
736 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
737 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
738 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rpm
739
740 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/banner.sh
741
742 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
743 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
744 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
745 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
746 cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
747 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
748 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
749
750 cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
751 cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
752 cp -p %{SOURCE19} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
753
754 # move rpm to /bin
755 %{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
756 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
757 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
758
759 # move essential libs to /lib (libs that /bin/rpm links to)
760 for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
761         mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
762         ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
763 done
764
765 #./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
766
767 %if %{with python2}
768 # Remove anything that rpm make install might put there
769 %{__rm} -rf $RPM_BUILD_ROOT%{py_sitedir}
770 cd python
771 %py_install
772 %py_postclean
773 cd ..
774 %endif
775
776 %if %{with python3}
777 # Remove anything that rpm make install might put there
778 %{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
779 cd python
780 %py3_install
781 cd ..
782 %endif
783
784 %{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
785
786 # wrong location, not used anyway
787 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
788
789 %find_lang %{name}
790
791 %clean
792 rm -rf $RPM_BUILD_ROOT
793
794 %posttrans
795 if [ -e /var/lib/rpm/Packages ] && \
796                 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
797         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
798                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
799                 echo
800                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
801                 echo
802         fi
803         echo
804         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
805         echo 'you should ignore it and restart poldek'
806         echo
807         %{_rpmlibdir}/dbupgrade.sh
808 fi
809
810 %triggerpostun -- %{name} < 4.4.9-44
811 %{_rpmlibdir}/hrmib-cache
812
813 %post   lib -p /sbin/ldconfig
814 %postun lib -p /sbin/ldconfig
815
816 %pretrans build
817 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
818
819 %files -f %{name}.lang
820 %defattr(644,root,root,755)
821 %doc ChangeLog CREDITS README
822
823 %dir /etc/pki/rpm-gpg
824 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
825
826 %attr(755,root,root) /bin/rpm
827 %attr(755,root,root) %{_bindir}/rpmdb
828 %attr(755,root,root) %{_bindir}/rpmkeys
829 %attr(755,root,root) %{_bindir}/rpmquery
830 %attr(755,root,root) %{_bindir}/rpmverify
831
832 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
833 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
834
835 %{_mandir}/man8/rpm.8*
836 %{_mandir}/man8/rpmdb.8*
837 %{_mandir}/man8/rpmkeys.8*
838 %{_mandir}/man8/rpm-misc.8*
839 %lang(fr) %{_mandir}/fr/man8/rpm.8*
840 %lang(ja) %{_mandir}/ja/man8/rpm.8*
841 %lang(ko) %{_mandir}/ko/man8/rpm.8*
842 %lang(pl) %{_mandir}/pl/man8/rpm.8*
843 %lang(ru) %{_mandir}/ru/man8/rpm.8*
844 %lang(sk) %{_mandir}/sk/man8/rpm.8*
845
846 %dir /var/lib/rpm
847
848 # exported package NVRA (stamped with install tid)
849 # net-snmp hrSWInstalledName queries, bash-completions
850 %dir /var/cache/hrmib
851
852 %{_rpmlibdir}/rpmpopt*
853 %{_rpmlibdir}/rpmrc
854 %{_rpmlibdir}/macros
855 %dir %{_rpmlibdir}/macros.d
856 %dir %{_rpmlibdir}/platform
857 %{_rpmlibdir}/platform/noarch-*
858 %ifarch %{ix86} %{x8664} x32
859 %{_rpmlibdir}/platform/athlon*
860 %{_rpmlibdir}/platform/geode*
861 %{_rpmlibdir}/platform/i?86*
862 %{_rpmlibdir}/platform/pentium*
863 %endif
864 %ifarch %{x8664} x32
865 %{_rpmlibdir}/platform/amd64*
866 %{_rpmlibdir}/platform/ia32e*
867 %{_rpmlibdir}/platform/x86_64*
868 %{_rpmlibdir}/platform/x32*
869 %endif
870 %ifarch alpha
871 %{_rpmlibdir}/platform/alpha*
872 %endif
873 %ifarch ia64
874 %{_rpmlibdir}/platform/ia64*
875 %endif
876 %ifarch mips mipsel mips64 mips64el
877 %{_rpmlibdir}/platform/mips*
878 %endif
879 %ifarch %{ppc}
880 %{_rpmlibdir}/platform/ppc*
881 %endif
882 %ifarch sparc sparc64
883 %{_rpmlibdir}/platform/sparc*
884 %endif
885
886 %dir %{_rpmlibdir}/pld
887
888 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
889
890 %attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
891 %attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
892 %attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
893
894 # valgrind suppression file for rpm
895 %{_rpmlibdir}/rpm.supp
896
897 %files base
898 %defattr(644,root,root,755)
899 %dir %{_sysconfdir}/rpm
900 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
901 %dir %{_rpmlibdir}
902 %attr(755,root,root) %{_bindir}/banner.sh
903 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
904 %dir /var/lib/banner
905
906 %files lib
907 %defattr(644,root,root,755)
908 %attr(755,root,root) /%{_lib}/librpm.so.9
909 %attr(755,root,root) /%{_lib}/librpm.so.%{sover}
910 %attr(755,root,root) /%{_lib}/librpmbuild.so.9
911 %attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
912 %attr(755,root,root) /%{_lib}/librpmio.so.9
913 %attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
914 %attr(755,root,root) /%{_lib}/librpmsign.so.9
915 %attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
916 %{?with_plugins:%dir %{_libdir}/rpm-plugins}
917
918 %files devel
919 %defattr(644,root,root,755)
920 %attr(755,root,root) %{_libdir}/librpm.so
921 %attr(755,root,root) %{_libdir}/librpmbuild.so
922 %attr(755,root,root) %{_libdir}/librpmio.so
923 %attr(755,root,root) %{_libdir}/librpmsign.so
924 %{_libdir}/librpm*.la
925 %{_includedir}/rpm
926 %{_pkgconfigdir}/*.pc
927
928 %files utils
929 %defattr(644,root,root,755)
930 %attr(755,root,root) %{_bindir}/rpm2archive
931 %attr(755,root,root) %{_bindir}/rpm2cpio
932 %attr(755,root,root) %{_bindir}/rpmgraph
933 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
934 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
935 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
936 %attr(755,root,root) %{_rpmlibdir}/tgpg
937 %attr(755,root,root) %{_rpmlibdir}/debugedit
938 %attr(755,root,root) %{_rpmlibdir}/rpmdeps
939 %{_mandir}/man8/rpm2cpio.8*
940 %{_mandir}/man8/rpmdeps.8*
941 %{_mandir}/man8/rpmgraph.8*
942 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
943 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
944 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
945 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
946 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
947 %lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
948 %lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
949
950 %files build
951 %defattr(644,root,root,755)
952 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
953 %attr(755,root,root) %{_rpmlibdir}/brp-*
954 %attr(755,root,root) %{_rpmlibdir}/check-files
955 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
956 %attr(755,root,root) %{_rpmlibdir}/elfdeps
957 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
958 # needs hacked pkg-config to return anything
959 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
960 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
961
962 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
963 # must be here for "Requires: rpm-*prov" to work
964 #%{_rpmlibdir}/macros.d/cmake
965 #%{_rpmlibdir}/macros.d/gstreamer
966 #%{_rpmlibdir}/macros.d/libtool
967 #%{_rpmlibdir}/macros.d/perl
968 #%{_rpmlibdir}/macros.d/pkgconfig
969 #%{_rpmlibdir}/macros.d/python
970 #%{_rpmlibdir}/macros.d/selinux
971 #%{_rpmlibdir}/macros.d/tcl
972 #%{_rpmlibdir}/macros.rpmbuild
973
974 %attr(755,root,root) %{_rpmlibdir}/check-buildroot
975 %attr(755,root,root) %{_rpmlibdir}/check-prereqs
976 %attr(755,root,root) %{_rpmlibdir}/check-rpaths
977 %attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
978 %attr(755,root,root) %{_rpmlibdir}/debuginfo.prov
979 %attr(755,root,root) %{_rpmlibdir}/desktop-file.prov
980 %attr(755,root,root) %{_rpmlibdir}/find-provides
981 %attr(755,root,root) %{_rpmlibdir}/find-requires
982 %attr(755,root,root) %{_rpmlibdir}/metainfo.prov
983 %attr(755,root,root) %{_rpmlibdir}/ocaml-find-provides.sh
984 %attr(755,root,root) %{_rpmlibdir}/ocaml-find-requires.sh
985 %attr(755,root,root) %{_rpmlibdir}/script.req
986 %attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
987 # Fedora has this in -build, but shouldn't this be in -devel?
988 %attr(755,root,root) %{_rpmlibdir}/config.guess
989 %attr(755,root,root) %{_rpmlibdir}/config.sub
990
991 %dir %{_rpmlibdir}/fileattrs
992 %{_rpmlibdir}/fileattrs/debuginfo.attr
993 %{_rpmlibdir}/fileattrs/desktop.attr
994 %{_rpmlibdir}/fileattrs/elf.attr
995 %{_rpmlibdir}/fileattrs/font.attr
996 %{_rpmlibdir}/fileattrs/libtool.attr
997 %{_rpmlibdir}/fileattrs/metainfo.attr
998 %{_rpmlibdir}/fileattrs/ocaml.attr
999 %{_rpmlibdir}/fileattrs/perl.attr
1000 %{_rpmlibdir}/fileattrs/perllib.attr
1001 %{_rpmlibdir}/fileattrs/pkgconfig.attr
1002 %{_rpmlibdir}/fileattrs/python.attr
1003 %{_rpmlibdir}/fileattrs/pythondist.attr
1004 %{_rpmlibdir}/fileattrs/script.attr
1005
1006 %attr(755,root,root) %{_bindir}/gendiff
1007 %attr(755,root,root) %{_bindir}/rpmbuild
1008 %attr(755,root,root) %{_bindir}/rpmspec
1009
1010 %{_mandir}/man1/gendiff.1*
1011 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1012 %{_mandir}/man8/rpmbuild.8*
1013 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1014 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1015 %{_mandir}/man8/rpmspec.8*
1016
1017 %files perlprov
1018 %defattr(644,root,root,755)
1019 %attr(755,root,root) %{_rpmlibdir}/perl.*
1020
1021 %files pythonprov
1022 %defattr(644,root,root,755)
1023 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1024 %attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
1025
1026 %if %{with python2}
1027 %files -n python-rpm
1028 %defattr(644,root,root,755)
1029 %dir %{py_sitedir}/rpm
1030 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1031 %{py_sitedir}/rpm/*.py[co]
1032 %{py_sitedir}/rpm-%{version}-py*.egg-info
1033 %endif
1034
1035 %if %{with python3}
1036 %files -n python3-rpm
1037 %defattr(644,root,root,755)
1038 %dir %{py3_sitedir}/rpm
1039 %attr(755,root,root) %{py3_sitedir}/rpm/*.so
1040 %{py3_sitedir}/rpm/*.py
1041 %{py3_sitedir}/rpm-%{version}-py*.egg-info
1042 %{py3_sitedir}/rpm/__pycache__
1043 %endif
1044
1045 %if %{with plugins}
1046 %files plugin-audit
1047 %defattr(644,root,root,755)
1048 %attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
1049
1050 %files plugin-syslog
1051 %defattr(644,root,root,755)
1052 %attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
1053
1054 %files plugin-systemd-inhibit
1055 %defattr(644,root,root,755)
1056 %attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
1057 %{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
1058
1059 %files plugin-ima
1060 %defattr(644,root,root,755)
1061 %attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
1062
1063 %files plugin-prioreset
1064 %defattr(644,root,root,755)
1065 %attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
1066
1067 %files plugin-selinux
1068 %defattr(644,root,root,755)
1069 %attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
1070 %endif
1071
1072 %files sign
1073 %defattr(644,root,root,755)
1074 %attr(755,root,root) %{_bindir}/rpmsign
1075 %{_mandir}/man8/rpmsign.8*
1076
1077 %if %{with apidocs}
1078 %files apidocs
1079 %defattr(644,root,root,755)
1080 %doc doc/librpm/html/*
1081 %endif
This page took 0.12669 seconds and 2 git commands to generate.