]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- find_lang 1.25 (cleanup, consistency, symlinked catalogs support)
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
4 #   matches ELF first
5 # - repackaging when lzma is not installed (todo: fix digest signature of header)
6 #   rpmbuild computes digest when writing package to temporary file, then adds a few
7 #   tags (incl. digest) and writes whole package to destination file;
8 #   repackaging uses unchanged "immutable header" image from original rpm, also
9 #   preserving payload format and compressor from original rpm, _not_ current settings
10 # - TODO: add macros for some ppc, mipsel, alpha and sparc
11 #
12 # Conditional build:
13 %bcond_with     static          # build static rpm+rpmi
14 %bcond_with     autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
15 %bcond_without  python          # don't build python bindings
16 %bcond_without  selinux         # build without selinux support
17 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
18 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
19 %bcond_without  db              # BerkeleyDB
20 %bcond_with     sqlite          # build with SQLite support
21 %bcond_with     sqlite_dbapi    # default database backend is sqlite
22 # force_cc              - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
23 # force_cxx             - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
24 # force_cpp             - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
25 #
26 %if %{with sqlite_dbapi}
27 %define with_sqlite     1
28 %endif
29
30 %if %{without db} && %{without sqlite}
31 %{error:Need db or sqlite}
32 ERROR
33 %endif
34
35 #
36 # versions of required libraries
37 %define reqdb_ver       4.6.18
38 %define reqpopt_ver     1.10.8
39 %define beecrypt_ver    2:4.1.2-4
40 %define sover   5.0
41 Summary:        RPM Package Manager
42 Summary(de.UTF-8):      RPM Packet-Manager
43 Summary(es.UTF-8):      Gestor de paquetes RPM
44 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
45 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
46 Summary(ru.UTF-8):      Менеджер пакетов от RPM
47 Summary(uk.UTF-8):      Менеджер пакетів від RPM
48 Name:           rpm
49 Version:        5.0.0
50 Release:        0.1
51 License:        GPL
52 Group:          Base
53 Source0:        http://rpm5.org/files/rpm/rpm-5.0/%{name}-%{version}.tar.gz
54 # Source0-md5:  4866053828c7258213f5711f3ca1dcd5
55 Source1:        %{name}.groups
56 Source2:        %{name}.platform
57 Source3:        %{name}-install-tree
58 Source4:        %{name}-find-spec-bcond
59 Source5:        %{name}-find-lang
60 Source6:        %{name}-groups-po.awk
61 Source7:        %{name}-compress-doc
62 Source8:        %{name}-check-files
63 Source9:        %{name}-php-provides
64 Source10:       %{name}-php-requires
65 Source11:       %{name}.sysinfo
66 Source12:       perl.prov
67 Source13:       %{name}-user_group.sh
68 Source14:       %{name}.sysconfig
69 Source15:       %{name}-macros.java
70 Source16:       %{name}-java-requires
71 # http://svn.pld-linux.org/banner.sh/
72 Source17:       banner.sh
73 Source18:       %{name}-pld.macros
74
75 Source100:      %{name}-macros-athlon
76 Source101:      %{name}-macros-i386
77 Source102:      %{name}-macros-i486
78 Source103:      %{name}-macros-i586
79 Source104:      %{name}-macros-i686
80 Source105:      %{name}-macros-noarch
81 Source106:      %{name}-macros-pentium3
82 Source107:      %{name}-macros-pentium4
83 Source108:      %{name}-macros-ppc
84 Source109:      %{name}-macros-x86_64
85 Source110:      %{name}-macros-ia32e
86 Source111:      %{name}-macros-amd64
87
88 Patch0:         %{name}-pl.po.patch
89 Patch1:         %{name}-man_pl.patch
90 Patch3:         %{name}-rpmpopt.patch
91 Patch4:         %{name}-perl-macros.patch
92 Patch5:         %{name}-perl-req-perlfile.patch
93 Patch6:         %{name}-noexpand.patch
94 Patch7:         %{name}-scripts-closefds.patch
95 Patch8:         %{name}-php-macros.patch
96 Patch9:         %{name}-gettext-in-header.patch
97 Patch10:        %{name}-compress-doc.patch
98
99 Patch14:        %{name}-etc_dir.patch
100 Patch16:        %{name}-php-deps.patch
101
102 Patch18:        %{name}-perl_req.patch
103
104 Patch23:        %{name}-pkgconfigdeps.patch
105
106 Patch26:        %{name}-notsc.patch
107 Patch27:        %{name}-hack-norpmlibdep.patch
108
109 Patch31:        %{name}-missing-prototypes.patch
110 Patch32:        %{name}-pld-autodep.patch
111 Patch34:        %{name}-epoch0.patch
112 Patch35:        %{name}-perl_req-INC_dirs.patch
113 Patch36:        %{name}-debuginfo.patch
114 Patch37:        %{name}-doxygen_hack.patch
115
116 Patch41:        %{name}-reduce-stack-usage.patch
117 Patch42:        %{name}-old-fileconflicts-behaviour.patch
118
119 Patch46:        %{name}-mono.patch
120 Patch47:        %{name}-javadeps.patch
121
122 Patch52:        %{name}-morearchs.patch
123
124 Patch55:        %{name}-truncate-cvslog.patch
125
126 Patch58:        %{name}-repackage-wo-lzma.patch
127 Patch59:        %{name}-libtool-deps.patch
128
129 Patch61:        %{name}-sparc64.patch
130 URL:            http://rpm5.org/
131 BuildRequires:  autoconf >= 2.57
132 BuildRequires:  automake >= 1.4
133 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
134 BuildRequires:  bzip2-devel >= 1.0.2-17
135 %{?with_db:BuildRequires:       db-devel >= %{reqdb_ver}}
136 BuildRequires:  elfutils-devel >= 0.108
137 %ifnarch sparc64
138 # -fPIE/-pie
139 BuildRequires:  gcc >= 5:3.4
140 %endif
141 BuildRequires:  gettext-devel >= 0.11.4-2
142 BuildRequires:  libmagic-devel
143 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.18}
144 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
145 BuildRequires:  libstdc++-devel
146 BuildRequires:  libtool >= 1:1.4.2-9
147 %if %{with neon}
148 BuildRequires:  libxml2-devel
149 BuildRequires:  neon-devel >= 0.25.5
150 %endif
151 BuildRequires:  patch >= 2.2
152 BuildRequires:  popt-devel >= %{reqpopt_ver}
153 %{?with_python:BuildRequires:   python-devel >= 1:2.5}
154 BuildRequires:  python-modules >= 1:2.5
155 BuildRequires:  rpm-perlprov
156 %{?with_python:BuildRequires:   rpm-pythonprov}
157 %{?with_sqlite:BuildRequires:   sqlite3-devel}
158 BuildRequires:  zlib-devel
159 %if %{with static}
160 # Require static library only for static build
161 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
162 BuildRequires:  bzip2-static >= 1.0.2-17
163 %{?with_db:BuildRequires:       db-static >= %{reqdb_ver}}
164 BuildRequires:  elfutils-static
165 BuildRequires:  glibc-static >= 2.2.94
166 BuildRequires:  libmagic-static
167 %{?with_selinux:BuildRequires:  libselinux-static >= 1.18}
168 BuildRequires:  popt-static >= %{reqpopt_ver}
169 BuildRequires:  zlib-static
170 %endif
171 Requires:       %{name}-base = %{version}-%{release}
172 Requires:       %{name}-lib = %{version}-%{release}
173 Requires:       beecrypt >= %{beecrypt_ver}
174 Requires:       popt >= %{reqpopt_ver}
175 %{!?with_static:Obsoletes:      rpm-utils-static}
176 Conflicts:      glibc < 2.2.92
177 # db4.6 poldek needed
178 Conflicts:      poldek < 0.21-0.20070703.00.3
179 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
180
181 %define         _binary_payload         w9.gzdio
182 %define         _noPayloadPrefix        1
183
184 # don't require very fresh rpm.macros to build
185 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
186 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
187 %define         ppc     ppc ppc7400 ppc7450
188 %define         x8664   amd64 ia32e x86_64
189
190 # stabilize new build environment
191 %define         __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
192 %define         __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
193 %define         __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
194
195 %define         _rpmlibdir /usr/lib/rpm
196
197 %define         specflags       -fno-strict-aliasing
198
199 %description
200 RPM is a powerful package manager, which can be used to build,
201 install, query, verify, update, and uninstall individual software
202 packages. A package consists of an archive of files, and package
203 information, including name, version, and description.
204
205 %description -l de.UTF-8
206 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
207 Installation, Anfrage, Verifizierung, Aktualisierung und
208 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
209 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
210 Beschreibung.
211
212 %description -l es.UTF-8
213 RPM es un poderoso administrador de paquetes, que puede ser usado para
214 construir, instalar, pesquisar, verificar, actualizar y desinstalar
215 paquetes individuales de software. Un paquete consiste en un
216 almacenaje de archivos, y información sobre el paquete, incluyendo
217 nombre, versión y descripción.
218
219 %description -l pl.UTF-8
220 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
221 przebudowanie, instalację czy weryfikację dowolnego pakietu.
222 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
223 plików wchodzących w skład pakietu, zależności od innych pakietów, są
224 przechowywane w bazie danych i można je uzyskać za pomocą opcji
225 odpytywania programu rpm.
226
227 %description -l pt_BR.UTF-8
228 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
229 construir, instalar, pesquisar, verificar, atualizar e desinstalar
230 pacotes individuais de software. Um pacote consiste de um conjunto de
231 arquivos e informações adicionais, incluindo nome, versão e descrição
232 do pacote, permissões dos arquivos, etc.
233
234 %description -l ru.UTF-8
235 RPM - это мощный менеджер пакетов, который может быть использован для
236 создания, инсталляции, запросов (query), проверки, обновления и
237 удаления программных пакетов. Пакет состоит из файлового архива и
238 служебной информации, включающей название, версию, описание и другие
239 данные о пакете.
240
241 %description -l uk.UTF-8
242 RPM - це потужний менеджер пакетів, що може бути використаний для
243 створення, інсталяції, запитів (query), перевірки, поновлення та
244 видалення програмних пакетів. Пакет складається з файлового архіву та
245 службової інформації, що містить назву, версію, опис та іншу
246 інформацію про пакет.
247
248 %package base
249 Summary:        RPM base package - scripts used by rpm packages themselves
250 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
251 Group:          Base
252 Requires:       filesystem
253 Obsoletes:      vserver-rpm
254
255 %description base
256 The RPM base package contains scripts used by rpm packages themselves.
257 These include:
258 - scripts for adding/removing groups and users needed for rpm
259   packages,
260 - banner.sh to display %%banner messages from rpm scriptlets.
261
262 %description base -l pl.UTF-8
263 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
264 Zawiera on:
265 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
266 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
267
268 %package lib
269 Summary:        RPMs library
270 Summary(pl.UTF-8):      Biblioteki RPM-a
271 Group:          Libraries
272 Requires:       beecrypt >= %{beecrypt_ver}
273 %{?with_db:Requires:    db >= %{reqdb_ver}}
274 %{?with_selinux:Requires:       libselinux >= 1.18}
275 Requires:       libmagic >= 1.15-2
276 Requires:       popt >= %{reqpopt_ver}
277 Obsoletes:      rpm-libs
278 Obsoletes:      rpm-apidocs
279 # avoid SEGV caused by mixed db versions
280 Conflicts:      poldek < 0.18.1-16
281 %{?with_suggest_tags:Suggests:  lzma}
282
283 %description lib
284 RPMs library.
285
286 %description lib -l pl.UTF-8
287 Biblioteki RPM-a.
288
289 %package devel
290 Summary:        Header files for rpm libraries
291 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
292 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
293 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
294 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
295 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
296 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
297 Group:          Development/Libraries
298 Requires:       %{name}-lib = %{version}-%{release}
299 Requires:       beecrypt-devel >= %{beecrypt_ver}
300 Requires:       bzip2-devel
301 %{?with_db:Requires:    db-devel >= %{reqdb_ver}}
302 Requires:       elfutils-devel
303 Requires:       libmagic-devel
304 %{?with_selinux:Requires:       libselinux-devel}
305 Requires:       popt-devel >= %{reqpopt_ver}
306 Requires:       zlib-devel
307
308 %description devel
309 The RPM packaging system includes C libraries that make it easy to
310 manipulate RPM packages and databases. They are intended to ease the
311 creation of graphical package managers and other tools that need
312 intimate knowledge of RPM packages. This package contains header files
313 for these libraries.
314
315 %description devel -l de.UTF-8
316 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
317 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
318 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
319 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
320
321 %description devel -l es.UTF-8
322 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
323 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
324 facilitar la creación de administradores gráficos de paquetes y otras
325 herramientas que necesiten un conocimiento profundo de paquetes RPM.
326
327 %description devel -l pl.UTF-8
328 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
329 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
330 graficznych programów zarządzających pakietami oraz innych narzędzi,
331 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
332 zawiera pliki nagłówkowe wspomnianych bibliotek.
333
334 %description devel -l pt_BR.UTF-8
335 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
336 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
337 facilitar a criação de gerenciadores gráficos de pacotes e outras
338 ferramentas que precisem de conhecimento profundo de pacotes RPM.
339
340 %description devel -l ru.UTF-8
341 Система управления пакетами RPM содержит библиотеку C, которая
342 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
343 Эта библиотека предназначена для облегчения создания графических
344 пакетных менеджеров и других утилит, которым необходимо работать с
345 пакетами RPM.
346
347 %description devel -l uk.UTF-8
348 Система керування пакетами RPM містить бібліотеку C, котра спрощує
349 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
350 призначена для полегшення створення графічних пакетних менеджерів та
351 інших утиліт, що працюють з пакетами RPM.
352
353 %package static
354 Summary:        RPM static libraries
355 Summary(de.UTF-8):      RPMs statische Libraries
356 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
357 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
358 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
359 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
360 Group:          Development/Libraries
361 Requires:       %{name}-devel = %{version}-%{release}
362 Requires:       beecrypt-static >= %{beecrypt_ver}
363 Requires:       bzip2-static
364 %{?with_db:Requires:    db-static >= %{reqdb_ver}}
365 Requires:       elfutils-static
366 Requires:       libmagic-static
367 Requires:       popt-static >= %{reqpopt_ver}
368 Requires:       zlib-static
369
370 %description static
371 RPM static libraries.
372
373 %description static -l de.UTF-8
374 RPMs statische Libraries.
375
376 %description static -l pl.UTF-8
377 Biblioteki statyczne RPM-a.
378
379 %description static -l pt_BR.UTF-8
380 Bibliotecas estáticas para desenvolvimento.
381
382 %description static -l ru.UTF-8
383 Система управления пакетами RPM содержит библиотеку C, которая
384 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
385 Это статическая библиотека RPM.
386
387 %description static -l uk.UTF-8
388 Система керування пакетами RPM містить бібліотеку C, котра спрощує
389 роботу з пакетами RPM та відповідними базами даних. Це статична
390 бібліотека RPM.
391
392 %package utils
393 Summary:        Additional utilities for managing RPM packages and database
394 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
395 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
396 Group:          Applications/File
397 Requires:       %{name} = %{version}-%{release}
398 Requires:       popt >= %{reqpopt_ver}
399
400 %description utils
401 Additional utilities for managing RPM packages and database.
402
403 %description utils -l de.UTF-8
404 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
405
406 %description utils -l pl.UTF-8
407 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
408
409 %package utils-perl
410 Summary:        Additional utilities for managing RPM packages and database
411 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
412 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
413 Group:          Applications/File
414 Requires:       %{name}-utils = %{version}-%{release}
415 Requires:       popt >= %{reqpopt_ver}
416
417 %description utils-perl
418 Additional utilities for managing RPM packages and database.
419
420 %description utils-perl -l de.UTF-8
421 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
422
423 %description utils-perl -l pl.UTF-8
424 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
425
426 %package utils-static
427 Summary:        Static rpm utilities
428 Summary(pl.UTF-8):      Statyczne narzędzia rpm
429 Group:          Applications/System
430 Requires:       %{name} = %{version}-%{release}
431
432 %description utils-static
433 Static rpm utilities for repairing system in case something with
434 shared libraries used by rpm become broken. Currently it contains rpmi
435 binary, which can be used to install/upgrade/remove packages without
436 using shared libraries (well, in fact with exception of NSS modules).
437
438 %description utils-static -l pl.UTF-8
439 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
440 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
441 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
442 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
443 (z wyjątkiem modułów NSS).
444
445 %package build
446 Summary:        Scripts for building binary RPM packages
447 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
448 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
449 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
450 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
451 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
452 Group:          Applications/File
453 Requires(pre):  findutils
454 Requires:       %{name}-build-macros >= 1.314
455 Requires:       %{name}-utils = %{version}-%{release}
456 Requires:       /bin/id
457 Requires:       awk
458 # we need fixed binutils for -feliminate-dwarf2-dups
459 Requires:       binutils >= 3:2.17.50.0.3-2
460 Requires:       bzip2
461 Requires:       chrpath >= 0.10-4
462 Requires:       cpio
463 Requires:       diffutils
464 Requires:       elfutils
465 Requires:       file >= 4.17
466 Requires:       fileutils
467 Requires:       findutils
468 Requires:       gcc >= 5:3.4
469 Requires:       glibc-devel
470 Requires:       grep
471 Requires:       gzip
472 Requires:       lzma
473 Requires:       make
474 Requires:       patch
475 Requires:       sed
476 Requires:       sh-utils
477 Requires:       tar
478 Requires:       textutils
479 Provides:       rpmbuild(find_lang) = 1.25
480 Provides:       rpmbuild(monoautodeps)
481 Provides:       rpmbuild(noauto) = 3
482 %ifarch %{x8664}
483 Conflicts:      automake < 1:1.7.9-2
484 Conflicts:      libtool < 2:1.5-13
485 %endif
486
487 %description build
488 Scripts for building binary RPM packages.
489
490 %description build -l de.UTF-8
491 Scripts fürs Bauen binärer RPM-Pakete.
492
493 %description build -l pl.UTF-8
494 Skrypty pomocnicze do budowania binarnych RPM-ów.
495
496 %description build -l pt_BR.UTF-8
497 Este pacote contém scripts e programas executáveis que são usados para
498 construir pacotes usando o RPM.
499
500 %description build -l ru.UTF-8
501 Различные вспомогательные скрипты и исполняемые программы, которые
502 используются для сборки RPM'ов.
503
504 %description build -l uk.UTF-8
505 Різноманітні допоміжні скрипти та утиліти, які використовуються для
506 побудови RPM'ів.
507
508 %package javaprov
509 Summary:        Additional utilities for checking Java provides/requires in RPM packages
510 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
511 Group:          Applications/File
512 Requires:       %{name} = %{version}-%{release}
513 Requires:       file
514 Requires:       findutils >= 1:4.2.26
515 Requires:       mktemp
516 Requires:       unzip
517
518 %description javaprov
519 Additional utilities for checking Java provides/requires in RPM
520 packages.
521
522 %description javaprov -l pl.UTF-8
523 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
524 RPM.
525
526 %package perlprov
527 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
528 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
529 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
530 Group:          Applications/File
531 Requires:       %{name} = %{version}-%{release}
532 Requires:       perl-devel
533 Requires:       perl-modules
534
535 %description perlprov
536 Additional utilities for checking Perl provides/requires in RPM
537 packages.
538
539 %description perlprov -l de.UTF-8
540 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
541
542 %description perlprov -l pl.UTF-8
543 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
544 pakietach RPM.
545
546 %package pythonprov
547 Summary:        Python macros, which simplifies creation of RPM packages with Python software
548 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
549 Group:          Applications/File
550 Requires:       %{name} = %{version}-%{release}
551 Requires:       python
552 Requires:       python-modules
553
554 %description pythonprov
555 Python macros, which simplifies creation of RPM packages with Python
556 software.
557
558 %description pythonprov -l pl.UTF-8
559 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
560 Pythonie.
561
562 %package php-pearprov
563 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
564 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
565 Group:          Applications/File
566 Requires:       %{name} = %{version}-%{release}
567 Requires:       sed >= 4.0
568
569 %description php-pearprov
570 Additional utilities for checking PHP PEAR provides/requires in RPM
571 packages.
572
573 %description php-pearprov -l pl.UTF-8
574 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
575 pakietach RPM.
576
577 %package -n python-rpm
578 Summary:        Python interface to RPM library
579 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
580 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
581 Group:          Development/Languages/Python
582 Requires:       %{name} = %{version}-%{release}
583 %pyrequires_eq  python
584 Obsoletes:      rpm-python
585
586 %description -n python-rpm
587 The rpm-python package contains a module which permits applications
588 written in the Python programming language to use the interface
589 supplied by RPM (RPM Package Manager) libraries.
590
591 This package should be installed if you want to develop Python
592 programs that will manipulate RPM packages and databases.
593
594 %description -n python-rpm -l pl.UTF-8
595 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
596 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
597
598 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
599 Pythonie programy manipulujące pakietami i bazami danych rpm.
600
601 %description -n python-rpm -l pt_BR.UTF-8
602 O pacote rpm-python contém um módulo que permite que aplicações
603 escritas em Python utilizem a interface fornecida pelas bibliotecas
604 RPM (RPM Package Manager).
605
606 Esse pacote deve ser instalado se você quiser desenvolver programas em
607 Python para manipular pacotes e bancos de dados RPM.
608
609 %prep
610 %setup -q
611
612 # APPLIED ALREADY?
613 #%patch0 -p1
614 %patch1 -p1
615 %patch3 -p1
616 %patch4 -p1
617 %patch5 -p1
618 %patch6 -p1
619 %patch7 -p1
620 %patch8 -p1
621 %patch9 -p1
622 %patch10 -p1
623 # CHECK ME
624 #%patch14 -p1
625 %patch16 -p1
626 %patch18 -p1
627 echo '%%define  __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
628 echo '%%define  __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
629 echo '# obsoleted file' > macros.python
630 echo '%%define  __php_provides  /usr/lib/rpm/php.prov' > macros.php
631 echo '%%define  __php_requires  /usr/lib/rpm/php.req' >> macros.php
632 echo '%%define  __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
633 echo '%%define  __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
634 install %{SOURCE5} scripts/find-lang.sh
635 install %{SOURCE9} scripts/php.prov.in
636 install %{SOURCE10} scripts/php.req.in
637 install %{SOURCE12} scripts/perl.prov
638 %patch23 -p1
639
640 %ifarch i386 i486
641 # disable TSC
642 %patch26 -p1
643 %endif
644 %patch27 -p1
645 # CHECK ME
646 #%patch31 -p1
647 %patch32 -p1
648 %patch34 -p1
649 %patch35 -p0
650 %patch36 -p1
651 %patch37 -p1
652 # CHECK ME
653 #%patch41 -p1
654 %patch42 -p1
655 # CHECK ME, PROBABLY WILL NEED TO HANLE IN OTHER WAY since rpmfcSCRIPT already handles mono
656 #%patch46 -p1
657 %patch47 -p1
658 # OLD COMMENTED OUT
659 #%patch52 -p1
660 %patch55 -p1
661 %patch58 -p1
662 %patch59 -p1
663 %ifarch sparc64
664 %patch61 -p1
665 %endif
666
667 cd scripts
668 mv -f perl.req perl.req.in
669 mv -f perl.prov perl.prov.in
670 cd ..
671
672 # generate Group translations to *.po
673 awk -f %{SOURCE6} %{SOURCE1}
674
675 # update macros paths
676 #for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
677 #       sed -e 's@lib/rpm/redhat@lib/rpm/pld@g' $f > ${f}.tmp
678 #       mv -f ${f}.tmp $f
679 #done
680
681 %build
682 %{__libtoolize}
683 %{__autopoint}
684 %{__aclocal}
685 %{__autoheader}
686 %{__autoconf}
687 %{__automake}
688
689 # config.guess doesn't handle athlon, so we have to change it by hand.
690 # rpm checks for CPU type at runtime, but it looks better
691 #sed -i -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' -e 's|@host_cpu@|%{_target_cpu}|' macros.in
692
693 # pass CC and CXX too in case of building with some older configure macro
694 # disable perl-RPM2 build, we have it in separate spec
695 %configure \
696         CC="%{__newcc}" \
697         CXX="%{__newcxx}" \
698         CPP="%{__newcpp}" \
699         WITH_PERL_VERSION=no \
700         %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
701         --enable-shared \
702         --enable-static \
703         %{?with_python:--with-python=2.5 --with-python-lib-dir=%{py_libdir}} \
704         %{!?with_python:--without-python} \
705         --with%{!?with_selinux:out}-selinux \
706         --with-libelf \
707         --with-zlib=external \
708         --with-bzip2=external \
709         --with-beecrypt=external \
710         --with-neon=%{?with_neon:external}%{!?with_neon:no} \
711         --with-file=external \
712         --with-popt=external \
713         --with-db=%{?with_db:external}%{!?with_db:no} \
714         --with-sqlite=%{?with_sqlite:external}%{!?with_sqlite:no} \
715         --with-dbapi=%{!?sqlite_dbapi:db}%{?sqlite_dbapi:sqlite} \
716         --with-lua=internal \
717         --with-pcre=no \
718         --with-keyutils=none \
719         --without-path-versioned \
720         --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.pld:%{_rpmlibdir}/macros.build:%{_rpmlibdir}/%%{_target}/macros:%{_sysconfdir}/macros.*:%{_sysconfdir}/macros:%{_sysconfdir}/%%{_target}/macros:~/etc/rpmmacros:~/etc/.rpmmacros:~/.rpmmacros' \
721         --with-bugreport="http://bugs.pld-linux.org/"
722
723 %{__make} \
724         CC="%{__cc}" \
725         CXX="%{__cxx}" \
726         CPP="%{__cpp}"
727
728 %install
729 rm -rf $RPM_BUILD_ROOT
730 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/banner}
731
732 %{__make} install \
733         pkgconfigdir=%{_pkgconfigdir} \
734         DESTDIR=$RPM_BUILD_ROOT
735
736 # install ARCH macros
737 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux
738 install %{SOURCE105} $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
739
740 %ifarch %{ix86}
741 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{i386,i486,i586,i686,athlon,pentium3,pentium4}-linux
742 install %{SOURCE100} $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
743 install %{SOURCE101} $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
744 install %{SOURCE102} $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
745 install %{SOURCE103} $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
746 install %{SOURCE104} $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
747 install %{SOURCE106} $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
748 install %{SOURCE107} $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
749 %endif
750
751 %ifarch %{x8664}
752 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{x86_64,ia32e,amd64}-linux
753 install %{SOURCE109} $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
754 install %{SOURCE110} $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
755 install %{SOURCE111} $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
756 %endif
757
758 %ifarch %{ppc}
759 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux
760 install %{SOURCE108} $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
761 %endif
762
763 # first platform file entry can't contain regexps
764 echo "%{_target_cpu}-%{_target_vendor}-linux" > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
765
766 # x86_64 things
767 %ifarch x86_64
768 echo "amd64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
769 echo "x86_64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
770 %endif
771
772 %ifarch amd64
773 echo "amd64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
774 echo "x86_64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
775 %endif
776
777 %ifarch ia32e
778 echo "ia32e-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
779 echo "x86_64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
780 %endif
781
782 # x86 things
783 %ifarch athlon %{x8664}
784 echo "athlon-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
785 %endif
786 %ifarch pentium4 athlon %{x8664}
787 echo "pentium4-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
788 %endif
789 %ifarch pentium3 pentium4 athlon %{x8664}
790 echo "pentium3-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
791 %endif
792 %ifarch i686 pentium3 pentium4 athlon %{x8664}
793 echo "i686-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
794 %endif
795 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
796 echo "i586-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
797 %endif
798 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
799 echo "i486-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
800 %endif
801 %ifarch %{ix86} %{x8664}
802 echo "i386-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
803 %endif
804
805 # ppc
806 %ifarch ppc
807 echo "ppc-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
808 echo "powerpc-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
809 %endif
810
811 # noarch
812 echo "noarch-[^-]*-.*" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
813
814 %ifarch %{ppc}
815 #sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
816 #       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
817 %endif
818
819 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
820 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
821 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
822
823 # not installed since 4.4.8 (-tools-perl subpackage)
824 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
825
826 install macros.perl     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.perl
827 install macros.python   $RPM_BUILD_ROOT%{_rpmlibdir}/macros.python
828 install macros.php      $RPM_BUILD_ROOT%{_rpmlibdir}/macros.php
829 install macros.mono     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.mono
830 install %{SOURCE15}     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.java
831 install %{SOURCE18}     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.pld
832
833 install %{SOURCE1} doc/manual/groups
834 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
835 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
836 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
837 install %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/check-files
838 install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
839 install %{SOURCE16} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
840 install scripts/find-php*       $RPM_BUILD_ROOT%{_rpmlibdir}
841 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
842 install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
843
844 install %{SOURCE17} $RPM_BUILD_ROOT%{_bindir}/banner.sh
845
846 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
847
848 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
849 # customized rpm macros - global for host
850 #
851 #%%_install_langs pl_PL:en_US
852 %%distribution PLD
853 #
854 # remove or replace with file_contexts path if you want to use custom
855 # SELinux file contexts policy instead of one stored in packages payload
856 %%_install_file_context_path    %%{nil}
857 %%_verify_file_context_path     %%{nil}
858
859 # If non-zero, all erasures will be automagically repackaged.
860 #%%_repackage_all_erasures    1
861 EOF
862
863 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles <<EOF
864 # global list of files (regexps) which don't generate Provides
865 EOF
866 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov <<EOF
867 # global list of script capabilities (regexps) not to be used in Provides
868 EOF
869 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles <<EOF
870 # global list of files (regexps) which don't generate Requires
871 ^%{_examplesdir}/
872 ^%{_docdir}/
873 EOF
874 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq <<EOF
875 # global list of script capabilities (regexps) not to be used in Requires
876 EOF
877 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
878 # global list of capabilities (SONAME, perl(module), php(module) regexps)
879 # which don't generate dependencies on package NAMES
880 # -- OpenGL implementation
881 ^libGL.so.1
882 ^libGLU.so.1
883 ^libOSMesa.so
884 # -- Glide
885 ^libglide3.so.3
886 # -- mozilla
887 ^libgtkmozembed.so
888 ^libgtksuperwin.so
889 ^libxpcom.so
890 # -- X11 implementation
891 ^libFS.so
892 ^libI810XvMC.so
893 ^libICE.so
894 ^libSM.so
895 ^libX11.so
896 ^libXRes.so
897 ^libXTrap.so
898 ^libXaw.so
899 ^libXcomposite.so
900 ^libXcursor.so
901 ^libXdamage.so
902 ^libXdmcp.so
903 ^libXevie.so
904 ^libXext.so
905 ^libXfixes.so
906 ^libXfont.so
907 ^libXfontcache.so
908 ^libXft.so
909 ^libXi.so
910 ^libXinerama.so
911 ^libXmu.so
912 ^libXmuu.so
913 ^libXp.so
914 ^libXpm.so
915 ^libXrandr.so
916 ^libXrender.so
917 ^libXss.so
918 ^libXt.so
919 ^libXtst.so
920 ^libXv.so
921 ^libXvMC.so
922 ^libXxf86dga.so
923 ^libXxf86misc.so
924 ^libXxf86rush.so
925 ^libXxf86vm.so
926 ^libdps.so
927 ^libdpstk.so
928 ^libfontenc.so
929 ^libpsres.so
930 ^libxkbfile.so
931 ^libxkbui.so
932 # -- fam / gamin
933 ^libfam.so.0
934 EOF
935 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
936 # global list of file masks not to be compressed in DOCDIR
937 EOF
938
939 # for rpm -e|-U --repackage
940 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
941 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
942
943 # mov rpm to /bin
944 mv -f $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
945 # move libs to /lib
946 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so; do
947         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
948         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
949 done
950
951 # remove arch dependant macros which have no use on noarch
952 #%{__sed} -i -e '
953 #/{__spec_install_post_strip}/d
954 #/{__spec_install_post_chrpath}/d
955 #/{__spec_install_post_compress_modules}/d
956 #' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
957
958 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
959 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
960
961 rm $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
962
963 # wrong location, not used anyway
964 rm $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
965 # manuals for utils dropped in 4.4.8 (?)
966 #rm $RPM_BUILD_ROOT%{_mandir}/{,*/}/man8/{rpmcache,rpmgraph}.8
967
968 %find_lang %{name}
969
970 rm -rf manual
971 cp -a doc/manual manual
972 rm -f manual/Makefile*
973
974 %clean
975 rm -rf $RPM_BUILD_ROOT
976
977 %post   lib -p /sbin/ldconfig
978 %postun lib -p /sbin/ldconfig
979
980 %pre build
981 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
982
983 %files -f %{name}.lang
984 %defattr(644,root,root,755)
985 %doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
986
987 %attr(755,root,root) /bin/rpm
988 #%attr(755,root,root) %{_bindir}/rpmdb
989 #%attr(755,root,root) %{_bindir}/rpmquery
990 #%attr(755,root,root) %{_bindir}/rpmsign
991 #%attr(755,root,root) %{_bindir}/rpmverify
992
993 %dir %{_sysconfdir}/rpm
994 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
995 # these are ok to be replaced
996 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo
997 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
998
999
1000 %{_mandir}/man8/rpm.8*
1001 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1002 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1003 %lang(ko) %{_mandir}/ko/man8/rpm.8*
1004 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1005 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1006 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1007
1008 %dir /var/lib/rpm
1009 %dir %attr(700,root,root) /var/spool/repackage
1010 %dir /var/lock/rpm
1011 /var/lock/rpm/transaction
1012
1013 #%attr(755,root,root) %{_rpmlibdir}/rpmd
1014 #%{!?with_static:%attr(755,root,root) %{_rpmlibdir}/rpm[eiu]}
1015 #%attr(755,root,root) %{_rpmlibdir}/rpmk
1016 #%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
1017
1018 %{_rpmlibdir}/rpmpopt*
1019 %{_rpmlibdir}/macros
1020 %{_rpmlibdir}/macros.pld
1021
1022 %files base
1023 %defattr(644,root,root,755)
1024 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1025 %dir %{_rpmlibdir}
1026 %attr(755,root,root) %{_bindir}/banner.sh
1027 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1028 %dir /var/lib/banner
1029
1030 %files lib
1031 %defattr(644,root,root,755)
1032 %attr(755,root,root) /%{_lib}/librpm*-*.so
1033 %attr(755,root,root) %{_libdir}/librpm*-*.so
1034
1035 %files devel
1036 %defattr(644,root,root,755)
1037 %{_includedir}/rpm
1038 %{_libdir}/librpm*.la
1039 %{_pkgconfigdir}/*.pc
1040 %attr(755,root,root) %{_libdir}/librpm.so
1041 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1042 %attr(755,root,root) %{_libdir}/librpmconstant.so
1043 %attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
1044 %attr(755,root,root) %{_libdir}/librpmio.so
1045 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1046 %attr(755,root,root) %{_libdir}/librpmmisc.so
1047 %attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
1048 %attr(755,root,root) %{_libdir}/librpmdb.so
1049 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1050 %attr(755,root,root) %{_libdir}/librpmbuild.so
1051
1052 %files static
1053 %defattr(644,root,root,755)
1054 %{_libdir}/librpm*.a
1055
1056 %files utils
1057 %defattr(644,root,root,755)
1058 %attr(755,root,root) %{_bindir}/rpmconstant
1059 %attr(755,root,root) %{_bindir}/rpm2cpio
1060 %attr(755,root,root) %{_rpmlibdir}/rpmcache
1061 %attr(755,root,root) %{_rpmlibdir}/rpmcmp
1062 %attr(755,root,root) %{_rpmlibdir}/rpmdeps
1063 %attr(755,root,root) %{_rpmlibdir}/debugedit
1064 %attr(755,root,root) %{_rpmlibdir}/rpmdigest
1065 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1066 %attr(755,root,root) %{_rpmlibdir}/tgpg
1067 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1068 %{_mandir}/man8/rpm2cpio.8*
1069 %{_mandir}/man8/rpmdeps.8*
1070 #%{_mandir}/man8/rpmcache.8*
1071 #%{_mandir}/man8/rpmgraph.8*
1072 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1073 #%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
1074 #%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
1075 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1076 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1077 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1078 #%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
1079 #%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
1080 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1081
1082 %files utils-perl
1083 %defattr(644,root,root,755)
1084 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1085
1086 %if %{with static}
1087 %files utils-static
1088 %defattr(644,root,root,755)
1089 %attr(755,root,root) %{_bindir}/rpm[ieu]
1090 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1091 %endif
1092
1093 %files build
1094 %defattr(644,root,root,755)
1095 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1096 %attr(755,root,root) %{_rpmlibdir}/brp-*
1097 %attr(755,root,root) %{_rpmlibdir}/check-files
1098 # %attr(755,root,root) %{_rpmlibdir}/check-prereqs
1099 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1100 #%attr(755,root,root) %{_rpmlibdir}/config.*
1101 %attr(755,root,root) %{_rpmlibdir}/cross-build
1102 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1103 %attr(755,root,root) %{_rpmlibdir}/find-lang.sh
1104 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1105 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1106 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
1107 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1108 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1109 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1110 # needs hacked pkg-config to return anything
1111 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1112 #%attr(755,root,root) %{_rpmlibdir}/rpmb
1113 #%attr(755,root,root) %{_rpmlibdir}/rpmt
1114 %{_rpmlibdir}/noarch-*
1115 %ifarch %{ix86}
1116 %{_rpmlibdir}/i?86*
1117 %{_rpmlibdir}/pentium*
1118 %{_rpmlibdir}/athlon*
1119 %endif
1120 %ifarch alpha
1121 %{_rpmlibdir}/alpha*
1122 %endif
1123 %ifarch ia64
1124 %{_rpmlibdir}/ia64*
1125 %endif
1126 %ifarch mips mipsel mips64 mips64el
1127 %{_rpmlibdir}/mips*
1128 %endif
1129 %ifarch %{ppc}
1130 %{_rpmlibdir}/ppc*
1131 %endif
1132 %ifarch sparc sparc64
1133 %{_rpmlibdir}/sparc*
1134 %endif
1135 %ifarch %{x8664}
1136 %{_rpmlibdir}/amd64*
1137 %{_rpmlibdir}/ia32e*
1138 %{_rpmlibdir}/x86_64*
1139 %endif
1140 # must be here for "Requires: rpm-*prov" to work
1141 %{_rpmlibdir}/macros.java
1142 %{_rpmlibdir}/macros.mono
1143 %{_rpmlibdir}/macros.perl
1144 %{_rpmlibdir}/macros.php
1145 # not used yet ... these six depend on perl
1146 #%attr(755,root,root) %{_rpmlibdir}/http.req
1147 #%attr(755,root,root) %{_rpmlibdir}/magic.prov
1148 #%attr(755,root,root) %{_rpmlibdir}/magic.req
1149 #%{_rpmlibdir}/sql.prov
1150 #%{_rpmlibdir}/sql.req
1151 #%{_rpmlibdir}/tcl.req
1152
1153 %attr(755,root,root) %{_bindir}/gendiff
1154 %attr(755,root,root) %{_bindir}/rpmbuild
1155
1156 %{_mandir}/man1/gendiff.1*
1157 %{_mandir}/man8/rpmbuild.8*
1158 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1159 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1160 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1161
1162 %files javaprov
1163 %defattr(644,root,root,755)
1164 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1165 # needs jar (any jdk), jcf-dump (gcc-java) to work
1166 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1167
1168 %files perlprov
1169 %defattr(644,root,root,755)
1170 %attr(755,root,root) %{_rpmlibdir}/perl.*
1171 #%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1172 #%attr(755,root,root) %{_rpmlibdir}/find-perl-*
1173 #%attr(755,root,root) %{_rpmlibdir}/find-*.perl
1174 #%attr(755,root,root) %{_rpmlibdir}/find-prov.pl
1175 #%attr(755,root,root) %{_rpmlibdir}/find-req.pl
1176 #%attr(755,root,root) %{_rpmlibdir}/get_magic.pl
1177
1178 %files pythonprov
1179 %defattr(644,root,root,755)
1180 %{_rpmlibdir}/macros.python
1181 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1182
1183 %files php-pearprov
1184 %defattr(644,root,root,755)
1185 %attr(755,root,root) %{_rpmlibdir}/php*
1186 %attr(755,root,root) %{_rpmlibdir}/find-php*
1187
1188 %if %{with python}
1189 %files -n python-rpm
1190 %defattr(644,root,root,755)
1191 %dir %{py_sitedir}/rpm
1192 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1193 %{py_sitedir}/rpm/*.py[co]
1194 %endif
This page took 0.18802 seconds and 3 git commands to generate.