]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- up to 4.15.1
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4 #   returns -ENOSYS
5 # - add macros for some ppc, mipsel, alpha and sparc
6 #
7 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
8 #
9 # Conditional build:
10 %bcond_with     static          # build static rpm+rpmi
11 %bcond_without  apidocs         # don't generate documentation with doxygen
12 %bcond_without  python          # don't build python bindings
13 %bcond_without  selinux         # build without selinux support
14 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
15 %bcond_with     db61            # use DB 6.1 instead of 5.2
16 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
17 %bcond_with     sqlite          # build with SQLite support
18 %bcond_with     system_lua      # use system lua
19 %bcond_without  system_pcre     # use system pcre
20 %bcond_with     keyutils        # build with keyutils support
21
22 %if %{with sqlite}
23 # Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
24 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
25 %endif
26
27 # versions of required libraries
28 %if %{with db61}
29 %define         reqdb_pkg       db6.1
30 %define         reqdb_ver       6.1
31 %define         reqdb_pkgver    6.1.19
32 %else
33 %define         reqdb_pkg       db5.2
34 %define         reqdb_ver       5.2
35 %define         reqdb_pkgver    5.2.36.0-4
36 %endif
37 %define         reqpopt_ver     1.15
38 %define         beecrypt_ver    2:4.2.0
39 %define         sover           5.4
40
41 Summary:        RPM Package Manager
42 Summary(de.UTF-8):      RPM Packet-Manager
43 Summary(es.UTF-8):      Gestor de paquetes RPM
44 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
45 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
46 Summary(ru.UTF-8):      Менеджер пакетов от RPM
47 Summary(uk.UTF-8):      Менеджер пакетів від RPM
48 Name:           rpm
49 Version:        4.15.1
50 Release:        0.1
51 License:        GPL v2 / LGPL v2.1
52 Group:          Base
53 Source0:        http://ftp.rpm.org/releases/rpm-4.15.x/%{name}-%{version}.tar.bz2
54 # Source0-md5:  ed72147451a5ed93b2a48e2f8f5413c3
55 # See README.cpu-os-macros how to update cpu-os-macros.a
56 Source100:      cpu-os-macros.a
57 Source101:      README.cpu-os-macros
58 Source1:        %{name}.groups
59 Source2:        macros.pld.in
60 Source3:        %{name}-install-tree
61 Source4:        %{name}-find-spec-bcond
62 Source5:        %{name}-hrmib-cache
63 Source6:        %{name}-groups-po.awk
64 Source7:        %{name}-compress-doc
65 Source8:        %{name}-php-provides
66 Source9:        %{name}-php-requires
67 Source10:       %{name}.sysinfo
68 Source11:       perl.prov
69 Source12:       %{name}-user_group.sh
70 Source13:       %{name}.sysconfig
71 Source14:       %{name}-java-requires
72 # http://svn.pld-linux.org/banner.sh/
73 Source15:       banner.sh
74 Source16:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
75 # Source16-md5: 23914bb49fafe7153cee87126d966461
76 Source17:       %{name}-mimetypedeps
77 Source18:       macros.local
78 Source19:       %{name}.noautocompressdoc
79 Source20:       %{name}.noautoprov
80 Source21:       %{name}.noautoprovfiles
81 Source22:       %{name}.noautoreq
82 Source24:       %{name}.noautoreqfiles
83 Source25:       %{name}-php-requires.php
84 Source26:       %{name}db_checkversion.c
85 Source27:       macros.lang
86 Source28:       %{name}db_reset.c
87 Source29:       dbupgrade.sh
88 Source30:       rubygems.rb
89 Source31:       gem_helper.rb
90 Patch0:         %{name}-branch.patch
91 Patch1:         %{name}-man_pl.patch
92 Patch2:         %{name}-popt-aliases.patch
93 Patch4:         %{name}-perl-macros.patch
94 Patch5:         %{name}-perl-req-perlfile.patch
95 Patch6:         %{name}-scripts-closefds.patch
96 Patch7:         %{name}-php-macros.patch
97 Patch9:         %{name}-lua.patch
98 Patch14:        %{name}-perl_req-INC_dirs.patch
99 Patch15:        %{name}-debuginfo.patch
100 Patch16:        vendor-pld.patch
101 Patch17:        %{name}-old-fileconflicts-behaviour.patch
102 Patch18:        %{name}-javadeps.patch
103 Patch19:        %{name}-truncate-cvslog.patch
104 Patch20:        %{name}-libtool-deps.patch
105 Patch21:        %{name}-mimetype.patch
106 Patch22:        %{name}-sparc64.patch
107 Patch23:        %{name}-gendiff.patch
108 Patch24:        openmp.patch
109 Patch25:        %{name}-URPM-build-fix.patch
110 Patch26:        %{name}-semanage.patch
111 Patch27:        %{name}-helperEVR-noassert.patch
112 Patch28:        %{name}-unglobal.patch
113 Patch29:        %{name}-builddir-readlink.patch
114 Patch30:        %{name}-changelog_order_check_nonfatal.patch
115 Patch31:        %{name}-cleanbody.patch
116 Patch32:        %{name}-dirdeps-macro.patch
117 Patch33:        %{name}-installbeforeerase.patch
118 Patch34:        %{name}-libmagic-locale.patch
119 Patch35:        %{name}-namespace-compare.patch
120 Patch36:        %{name}-popt-coreutils.patch
121 Patch37:        %{name}-postun-nofail.patch
122 Patch38:        %{name}-silence-RPM_CHAR_TYPE.patch
123 Patch39:        %{name}-fix-missing-types-in-headers.patch
124 Patch40:        %{name}-fix--p-interpreter-and-empty-script.patch
125 Patch41:        %{name}-db_buffer_small.patch
126 Patch42:        %{name}-pattern_Release.patch
127 Patch43:        %{name}-fix-___build_pre-macro.patch
128 Patch44:        %{name}-missing-patch-file-fails-build.patch
129 Patch45:        %{name}-remove-misleading-missing-patch-message.patch
130 Patch46:        %{name}-file-magic-can-be-mixed-case.patch
131 Patch47:        %{name}-query-always-noisy.patch
132 Patch48:        %{name}-verify-ghosts-broken-logic.patch
133 Patch49:        %{name}-python-enable-compat-RPMSENSE.patch
134 Patch50:        %{name}-dont-treat-gstreamer-modules-as-font.patch
135 Patch51:        %{name}-gst-inspect-typo.patch
136 Patch52:        %{name}-null-term-ascii-digest.patch
137 Patch53:        %{name}-lua-enable-extra-libs.patch
138 Patch54:        %{name}-fix-filedigests-verify.patch
139 Patch55:        %{name}-disable-hmac-verify.patch
140 Patch56:        %{name}-macros.patch
141 Patch57:        %{name}-db5.2.patch
142 Patch58:        %{name}-preserve-iterator.patch
143 Patch59:        gcc6-stdlib.patch
144 Patch60:        %{name}-python-sitescriptdir.patch
145 Patch61:        %{name}-clean-docdir.patch
146 Patch62:        %{name}-DB_CONFIG.patch
147 Patch63:        %{name}-pythoneggs.patch
148 Patch64:        %{name}-fix-compress-doc.patch
149 Patch65:        %{name}-parseSpec-skip-empty-tags.patch
150 Patch66:        %{name}-payload-use-hashed-inode.patch
151 Patch67:        %{name}-repackage-dont-force-max-compression.patch
152 Patch68:        rpm-bug-420.patch
153 Patch70:        python-%{name}sense-missingok.patch
154 Patch71:        %{name}-changelog-encoding.patch
155 Patch72:        %{name}-preserve-tag-type.patch
156 Patch74:        %{name}-fix-internal-lua-build.patch
157 Patch75:        %{name}-double_check_file_deps.patch
158 Patch77:        %{name}-lua-expat.patch
159 Patch78:        %{name}-double_check_unpackaged_subdirs.patch
160 Patch79:        %{name}-rpmspec.patch
161 Patch80:        %{name}-revert-gpg-argv-parsing.patch
162 Patch81:        %{name}-perl-magic.patch
163 Patch82:        %{name}-5.4.15-use-DSA-sig.patch
164 Patch83:        %{name}-ignore-missing-macro-files.patch
165 Patch84:        x32.patch
166 Patch85:        rpm-CVE-2013-6435.patch
167 Patch86:        rpm-CVE-2014-8118.patch
168 Patch87:        %{name}-file-output-for-ELF.patch
169 Patch88:        %{name}-rpmtdnext.patch
170 Patch89:        disable-header-verification.patch
171 Patch90:        %{name}-cppcompat.patch
172 Patch91:        py-disable-fetch.patch
173 Patch92:        fast_python_deps.patch
174 Patch93:        python2_explicit.patch
175 Patch94:        do_not_write_before_macro_buffer.patch
176 Patch95:        rpm-python-spec-header.patch
177 Patch96:        skip-ldconfig-optimization.patch
178 Patch97:        glibc.patch
179 Patch98:        extension-based-compression-detection.patch
180 Patch99:        %{name}-gpg-pinentry.patch
181 Patch100:       python-libx32.patch
182
183 URL:            http://rpm5.org/
184 BuildRequires:  %{reqdb_pkg}-devel >= %{reqdb_pkgver}
185 %if %{with sqlite}
186 BuildRequires:  sqlite3-devel
187 %else
188 BuildRequires:  %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
189 %endif
190 BuildRequires:  autoconf >= 2.63
191 BuildRequires:  automake >= 1.4
192 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
193 BuildRequires:  bzip2-devel >= 1.0.2-17
194 BuildRequires:  elfutils-devel >= 0.108
195 BuildRequires:  gettext-tools >= 0.19.2
196 %{?with_keyutils:BuildRequires: keyutils-devel}
197 BuildRequires:  libmagic-devel
198 %if %{with selinux}
199 BuildRequires:  libselinux-devel >= 2.1.0
200 BuildRequires:  libsemanage-devel >= 2.1.0
201 BuildRequires:  libsepol-devel >= 2.1.0
202 %endif
203 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
204 BuildRequires:  libstdc++-devel
205 BuildRequires:  libtool >= 1:1.4.2-9
206 %if %{with neon}
207 BuildRequires:  libxml2-devel
208 BuildRequires:  neon-devel >= 0.25.5
209 %endif
210 %{?with_system_lua:BuildRequires:       lua52-devel >= 5.2.2}
211 BuildRequires:  ossp-uuid-devel
212 BuildRequires:  patch >= 2.2
213 BuildRequires:  popt-devel >= %{reqpopt_ver}
214 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
215 BuildRequires:  python-modules >= 1:2.3
216 %{?with_python:BuildRequires:   rpm-pythonprov}
217 BuildRequires:  tcl
218 BuildRequires:  xz-devel
219 BuildRequires:  zlib-devel
220 %if %{with apidocs}
221 BuildRequires:  doxygen
222 BuildRequires:  ghostscript
223 BuildRequires:  graphviz
224 BuildRequires:  tetex-pdftex
225 %endif
226 %if %{with static}
227 # Require static library only for static build
228 BuildRequires:  %{reqdb_pkg}-static >= %{reqdb_pkgver}
229 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
230 BuildRequires:  bzip2-static >= 1.0.2-17
231 BuildRequires:  elfutils-static
232 BuildRequires:  glibc-static >= 2.2.94
233 BuildRequires:  libmagic-static
234 %if %{with selinux}
235 BuildRequires:  libselinux-static >= 2.1.0
236 BuildRequires:  libsemanage-static >= 2.1.0
237 BuildRequires:  libsepol-static >= 2.1.0
238 %endif
239 BuildRequires:  popt-static >= %{reqpopt_ver}
240 BuildRequires:  zlib-static
241 %endif
242 Requires(posttrans):    coreutils
243 Requires:       FHS >= 3.0-2
244 Requires:       %{name}-base = %{version}-%{release}
245 Requires:       %{name}-lib = %{version}-%{release}
246 Requires:       beecrypt >= %{beecrypt_ver}
247 Requires:       popt >= %{reqpopt_ver}
248 Provides:       rpm-db-ver = %{reqdb_ver}
249 Obsoletes:      rpm-getdeps
250 %{!?with_static:Obsoletes:      rpm-utils-static}
251 Conflicts:      glibc < 2.2.92
252 # db4.6 poldek needed
253 Conflicts:      poldek < 0.21-0.20070703.00.3
254 # segfaults with lzma 0.42.2
255 Conflicts:      lzma-libs < 4.999.3
256 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
257 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
258
259 %define         _binary_payload         w9.gzdio
260
261 # don't require very fresh rpm.macros to build
262 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
263 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
264 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
265 %define         ppc     ppc ppc7400 ppc7450
266 %define         x8664   amd64 ia32e x86_64
267
268 %define         _rpmlibdir /usr/lib/rpm
269 %define         _noautocompressdoc      RPM-GPG-KEY
270
271 %description
272 RPM is a powerful package manager, which can be used to build,
273 install, query, verify, update, and uninstall individual software
274 packages. A package consists of an archive of files, and package
275 information, including name, version, and description.
276
277 %description -l de.UTF-8
278 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
279 Installation, Anfrage, Verifizierung, Aktualisierung und
280 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
281 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
282 Beschreibung.
283
284 %description -l es.UTF-8
285 RPM es un poderoso administrador de paquetes, que puede ser usado para
286 construir, instalar, pesquisar, verificar, actualizar y desinstalar
287 paquetes individuales de software. Un paquete consiste en un
288 almacenaje de archivos, y información sobre el paquete, incluyendo
289 nombre, versión y descripción.
290
291 %description -l pl.UTF-8
292 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
293 przebudowanie, instalację czy weryfikację dowolnego pakietu.
294 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
295 plików wchodzących w skład pakietu, zależności od innych pakietów, są
296 przechowywane w bazie danych i można je uzyskać za pomocą opcji
297 odpytywania programu rpm.
298
299 %description -l pt_BR.UTF-8
300 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
301 construir, instalar, pesquisar, verificar, atualizar e desinstalar
302 pacotes individuais de software. Um pacote consiste de um conjunto de
303 arquivos e informações adicionais, incluindo nome, versão e descrição
304 do pacote, permissões dos arquivos, etc.
305
306 %description -l ru.UTF-8
307 RPM - это мощный менеджер пакетов, который может быть использован для
308 создания, инсталляции, запросов (query), проверки, обновления и
309 удаления программных пакетов. Пакет состоит из файлового архива и
310 служебной информации, включающей название, версию, описание и другие
311 данные о пакете.
312
313 %description -l uk.UTF-8
314 RPM - це потужний менеджер пакетів, що може бути використаний для
315 створення, інсталяції, запитів (query), перевірки, поновлення та
316 видалення програмних пакетів. Пакет складається з файлового архіву та
317 службової інформації, що містить назву, версію, опис та іншу
318 інформацію про пакет.
319
320 %package base
321 Summary:        RPM base package - scripts used by rpm packages themselves
322 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
323 Group:          Base
324 Requires:       filesystem
325 Obsoletes:      rpm-scripts
326 Obsoletes:      vserver-rpm
327
328 %description base
329 The RPM base package contains scripts used by rpm packages themselves.
330 These include:
331 - scripts for adding/removing groups and users needed for rpm
332   packages,
333 - banner.sh to display %%banner messages from rpm scriptlets.
334
335 %description base -l pl.UTF-8
336 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
337 Zawiera on:
338 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
339 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
340
341 %package lib
342 Summary:        RPMs library
343 Summary(pl.UTF-8):      Biblioteki RPM-a
344 Group:          Libraries
345 Requires:       %{reqdb_pkg} >= %{reqdb_pkgver}
346 %if %{with sqlite}
347 Requires:       sqlite3 >= %{sqlite_build_version}
348 %else
349 Requires:       %{reqdb_pkg}-sql >= %{reqdb_pkgver}
350 %endif
351 Requires:       beecrypt >= %{beecrypt_ver}
352 Requires:       libmagic >= 1.15-2
353 %{?with_selinux:Requires:       libselinux >= 2.1.0}
354 Requires:       popt >= %{reqpopt_ver}
355 Obsoletes:      rpm-libs
356 # avoid SEGV caused by mixed db versions
357 Conflicts:      poldek < 0.18.1-16
358
359 %description lib
360 RPMs library.
361
362 %description lib -l pl.UTF-8
363 Biblioteki RPM-a.
364
365 %package devel
366 Summary:        Header files for rpm libraries
367 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
368 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
369 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
370 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
371 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
372 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
373 Group:          Development/Libraries
374 Requires:       %{name}-lib = %{version}-%{release}
375 Requires:       %{reqdb_pkg}-devel >= %{reqdb_pkgver}
376 Requires:       beecrypt-devel >= %{beecrypt_ver}
377 Requires:       bzip2-devel
378 Requires:       elfutils-devel
379 %{?with_keyutils:Requires:      keyutils-devel}
380 Requires:       libmagic-devel
381 %if %{with selinux}
382 Requires:       libselinux-devel
383 Requires:       libsemanage-devel
384 Requires:       libsepol-devel
385 %endif
386 Requires:       popt-devel >= %{reqpopt_ver}
387 Requires:       zlib-devel
388
389 %description devel
390 The RPM packaging system includes C libraries that make it easy to
391 manipulate RPM packages and databases. They are intended to ease the
392 creation of graphical package managers and other tools that need
393 intimate knowledge of RPM packages. This package contains header files
394 for these libraries.
395
396 %description devel -l de.UTF-8
397 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
398 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
399 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
400 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
401
402 %description devel -l es.UTF-8
403 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
404 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
405 facilitar la creación de administradores gráficos de paquetes y otras
406 herramientas que necesiten un conocimiento profundo de paquetes RPM.
407
408 %description devel -l pl.UTF-8
409 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
410 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
411 graficznych programów zarządzających pakietami oraz innych narzędzi,
412 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
413 zawiera pliki nagłówkowe wspomnianych bibliotek.
414
415 %description devel -l pt_BR.UTF-8
416 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
417 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
418 facilitar a criação de gerenciadores gráficos de pacotes e outras
419 ferramentas que precisem de conhecimento profundo de pacotes RPM.
420
421 %description devel -l ru.UTF-8
422 Система управления пакетами RPM содержит библиотеку C, которая
423 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
424 Эта библиотека предназначена для облегчения создания графических
425 пакетных менеджеров и других утилит, которым необходимо работать с
426 пакетами RPM.
427
428 %description devel -l uk.UTF-8
429 Система керування пакетами RPM містить бібліотеку C, котра спрощує
430 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
431 призначена для полегшення створення графічних пакетних менеджерів та
432 інших утиліт, що працюють з пакетами RPM.
433
434 %package static
435 Summary:        RPM static libraries
436 Summary(de.UTF-8):      RPMs statische Libraries
437 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
438 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
439 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
440 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
441 Group:          Development/Libraries
442 Requires:       %{name}-devel = %{version}-%{release}
443 Requires:       %{reqdb_pkg}-static >= %{reqdb_pkgver}
444 Requires:       beecrypt-static >= %{beecrypt_ver}
445 Requires:       bzip2-static
446 Requires:       elfutils-static
447 %{?with_keyutils:Requires:      keyutils-static}
448 Requires:       libmagic-static
449 %if %{with selinux}
450 Requires:       libselinux-static
451 Requires:       libsemanage-static
452 Requires:       libsepol-static
453 %endif
454 Requires:       popt-static >= %{reqpopt_ver}
455 Requires:       zlib-static
456
457 %description static
458 RPM static libraries.
459
460 %description static -l de.UTF-8
461 RPMs statische Libraries.
462
463 %description static -l pl.UTF-8
464 Biblioteki statyczne RPM-a.
465
466 %description static -l pt_BR.UTF-8
467 Bibliotecas estáticas para desenvolvimento.
468
469 %description static -l ru.UTF-8
470 Система управления пакетами RPM содержит библиотеку C, которая
471 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
472 Это статическая библиотека RPM.
473
474 %description static -l uk.UTF-8
475 Система керування пакетами RPM містить бібліотеку C, котра спрощує
476 роботу з пакетами RPM та відповідними базами даних. Це статична
477 бібліотека RPM.
478
479 %package utils
480 Summary:        Additional utilities for managing RPM packages and database
481 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
482 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
483 Group:          Applications/File
484 Requires:       %{name} = %{version}-%{release}
485 Requires:       popt >= %{reqpopt_ver}
486 %if %{with suggest_tags}
487 Suggests:       bzip2
488 Suggests:       gzip
489 %endif
490 Conflicts:      filesystem-debuginfo < 3.0-16
491
492 %description utils
493 Additional utilities for managing RPM packages and database.
494
495 %description utils -l de.UTF-8
496 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
497
498 %description utils -l pl.UTF-8
499 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
500
501 %package utils-perl
502 Summary:        Additional utilities for managing RPM packages and database
503 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
504 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
505 Group:          Applications/File
506 Requires:       %{name}-utils = %{version}-%{release}
507 Requires:       popt >= %{reqpopt_ver}
508
509 %description utils-perl
510 Additional utilities for managing RPM packages and database.
511
512 %description utils-perl -l de.UTF-8
513 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
514
515 %description utils-perl -l pl.UTF-8
516 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
517
518 %package utils-static
519 Summary:        Static rpm utilities
520 Summary(pl.UTF-8):      Statyczne narzędzia rpm
521 Group:          Applications/System
522 Requires:       %{name} = %{version}-%{release}
523
524 %description utils-static
525 Static rpm utilities for repairing system in case something with
526 shared libraries used by rpm become broken. Currently it contains rpmi
527 binary, which can be used to install/upgrade/remove packages without
528 using shared libraries (well, in fact with exception of NSS modules).
529
530 %description utils-static -l pl.UTF-8
531 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
532 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
533 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
534 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
535 (z wyjątkiem modułów NSS).
536
537 %package build
538 Summary:        Scripts for building binary RPM packages
539 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
540 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
541 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
542 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
543 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
544 Group:          Applications/File
545 Requires(pretrans):     coreutils
546 Requires(pretrans):     findutils
547 Requires:       %{name}-build-macros >= 1.712
548 Requires:       %{name}-utils = %{version}-%{release}
549 Requires:       /bin/id
550 Requires:       awk
551 Requires:       bzip2
552 Requires:       chrpath >= 0.10-4
553 Requires:       cpio
554 Requires:       diffutils
555 Requires:       elfutils
556 Requires:       file >= 4.17
557 Requires:       fileutils
558 Requires:       findutils
559 %ifarch athlon
560 Requires:       gcc >= 3.0.3
561 %else
562 Requires:       gcc
563 %endif
564 Requires:       glibc-devel
565 Requires:       grep
566 Requires:       gzip
567 Requires:       make
568 Requires:       patch
569 Requires:       sed >= 4.0
570 Requires:       sh-utils
571 Requires:       tar >= 1:1.22
572 Requires:       textutils
573 Requires:       which
574 Requires:       xz
575 Provides:       rpmbuild(monoautodeps)
576 Provides:       rpmbuild(noauto) = 3
577 %ifarch %{x8664}
578 Conflicts:      automake < 1:1.7.9-2
579 Conflicts:      libtool < 2:1.5-13
580 %endif
581
582 %description build
583 Scripts for building binary RPM packages.
584
585 %description build -l de.UTF-8
586 Scripts fürs Bauen binärer RPM-Pakete.
587
588 %description build -l pl.UTF-8
589 Skrypty pomocnicze do budowania binarnych RPM-ów.
590
591 %description build -l pt_BR.UTF-8
592 Este pacote contém scripts e programas executáveis que são usados para
593 construir pacotes usando o RPM.
594
595 %description build -l ru.UTF-8
596 Различные вспомогательные скрипты и исполняемые программы, которые
597 используются для сборки RPM'ов.
598
599 %description build -l uk.UTF-8
600 Різноманітні допоміжні скрипти та утиліти, які використовуються для
601 побудови RPM'ів.
602
603 %package javaprov
604 Summary:        Additional utilities for checking Java provides/requires in RPM packages
605 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
606 Group:          Applications/File
607 Requires:       %{name} = %{version}-%{release}
608 Requires:       file
609 Requires:       findutils >= 1:4.2.26
610 Requires:       mktemp
611 Requires:       unzip
612
613 %description javaprov
614 Additional utilities for checking Java provides/requires in RPM
615 packages.
616
617 %description javaprov -l pl.UTF-8
618 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
619 RPM.
620
621 %package perlprov
622 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
623 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
624 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
625 Group:          Applications/File
626 Requires:       %{name} = %{version}-%{release}
627 Requires:       perl-Encode
628 Requires:       perl-devel
629 Requires:       perl-modules
630
631 %description perlprov
632 Additional utilities for checking Perl provides/requires in RPM
633 packages.
634
635 %description perlprov -l de.UTF-8
636 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
637
638 %description perlprov -l pl.UTF-8
639 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
640 pakietach RPM.
641
642 %package pythonprov
643 Summary:        Python macros, which simplifies creation of RPM packages with Python software
644 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
645 Group:          Applications/File
646 Requires:       %{name} = %{version}-%{release}
647 Requires:       python
648 Requires:       python-setuptools
649 Requires:       python-modules
650
651 %description pythonprov
652 Python macros, which simplifies creation of RPM packages with Python
653 software.
654
655 %description pythonprov -l pl.UTF-8
656 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
657 Pythonie.
658
659 %package php-pearprov
660 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
661 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
662 Group:          Applications/File
663 Requires:       %{name} = %{version}-%{release}
664 Requires:       sed >= 4.0
665 Suggests:       php-pear-PHP_CompatInfo
666
667 %description php-pearprov
668 Additional utilities for checking PHP PEAR provides/requires in RPM
669 packages.
670
671 %description php-pearprov -l pl.UTF-8
672 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
673 pakietach RPM.
674
675 %package rubyprov
676 Summary:        Ruby tools, which simplify creation of RPM packages with Ruby software
677 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
678 Group:          Applications/File
679 Requires:       %{name} = %{version}-%{release}
680 Requires:       ruby
681 Requires:       ruby-modules
682 Requires:       ruby-rubygems
683
684 %description rubyprov
685 Ruby tools, which simplifies creation of RPM packages with Ruby
686 software.
687
688 %description rubyprov -l pl.UTF-8
689 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
690 Ruby.
691
692 %package -n python-rpm
693 Summary:        Python interface to RPM library
694 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
695 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
696 Group:          Development/Languages/Python
697 Requires:       %{name} = %{version}-%{release}
698 Requires:       python
699 Obsoletes:      rpm-python
700
701 %description -n python-rpm
702 The rpm-python package contains a module which permits applications
703 written in the Python programming language to use the interface
704 supplied by RPM (RPM Package Manager) libraries.
705
706 This package should be installed if you want to develop Python
707 programs that will manipulate RPM packages and databases.
708
709 %description -n python-rpm -l pl.UTF-8
710 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
711 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
712
713 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
714 Pythonie programy manipulujące pakietami i bazami danych rpm.
715
716 %description -n python-rpm -l pt_BR.UTF-8
717 O pacote rpm-python contém um módulo que permite que aplicações
718 escritas em Python utilizem a interface fornecida pelas bibliotecas
719 RPM (RPM Package Manager).
720
721 Esse pacote deve ser instalado se você quiser desenvolver programas em
722 Python para manipular pacotes e bancos de dados RPM.
723
724 %package apidocs
725 Summary:        RPM API documentation and guides
726 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
727 Group:          Documentation
728 %if "%{_rpmversion}" >= "5"
729 BuildArch:      noarch
730 %endif
731
732 %description apidocs
733 Documentation for RPM API and guides in HTML format generated from rpm
734 sources by doxygen.
735
736 %description apidocs -l pl.UTF-8
737 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
738 źrodeł RPM-a przez doxygen.
739
740 %prep
741 %setup -q -n %{name}-%{version}%{?subver}
742 install -d platform
743 cd platform
744 ar x %{SOURCE100}
745 cd -
746
747 #patch0 -p1
748 %patch1 -p1
749 %patch2 -p1
750 %patch4 -p1
751 %patch5 -p1
752 %patch6 -p1
753 #%patch7 -p1
754 %{?with_system_lua:%patch9 -p1}
755 %patch14 -p0
756 %patch15 -p1
757 %patch16 -p1
758 %patch17 -p1
759 %patch18 -p1
760 %patch19 -p1
761 %patch20 -p1
762 %patch21 -p1
763 %ifarch sparc64
764 %patch22 -p1
765 %endif
766 %patch23 -p1
767 %patch24 -p1
768 %patch25 -p1
769 %patch26 -p1
770 %patch27 -p1
771 %patch28 -p1
772 %patch29 -p1
773 %patch30 -p1
774 %patch31 -p1
775 %patch32 -p1
776 %patch33 -p1
777 %patch34 -p1
778 %patch35 -p1
779 %patch36 -p1
780 %patch37 -p1
781 %patch38 -p1
782 %patch39 -p1
783 %patch40 -p1
784 %{?with_db61:%patch41 -p1}
785 %patch42 -p1
786 %patch43 -p1
787 %patch44 -p1
788 %patch45 -p1
789 %patch46 -p1
790 %patch47 -p1
791 %patch48 -p1
792 %patch49 -p1
793 %patch50 -p1
794 %patch51 -p1
795 %patch52 -p0
796 %patch53 -p1
797 %patch54 -p1
798 %patch55 -p1
799 %patch56 -p1
800 %{!?with_db61:%patch57 -p1}
801 %patch58 -p1
802 %patch59 -p1
803 %patch60 -p1
804 %patch61 -p1
805 %patch62 -p1
806 %patch63 -p1
807 %patch64 -p1
808 %patch65 -p1
809 %patch66 -p1
810 %patch67 -p1
811 %patch68 -p1
812 %patch70 -p1
813 %patch71 -p1
814 %patch72 -p1
815 %patch74 -p1
816 %patch75 -p1
817 %patch77 -p0
818 %patch78 -p1
819 %patch79 -p1
820 %patch80 -p1
821 %patch81 -p0
822 %patch82 -p1
823 %patch84 -p1
824 %patch85 -p1
825 %patch86 -p1
826 %patch87 -p1
827 %patch88 -p1
828 %patch89 -p1
829 %patch90 -p1
830 %patch91 -p1
831 %patch99 -p1
832
833 %patch83 -p1
834 %patch92 -p1
835 %patch93 -p1
836 %patch94 -p1
837 %patch95 -p1
838 %patch96 -p1
839 %patch97 -p1
840 %patch98 -p1
841
842 %patch100 -p1
843
844 install %{SOURCE2} macros/pld.in
845 #install %{SOURCE8} scripts/php.prov.in
846 #install %{SOURCE9} scripts/php.req.in
847 install %{SOURCE11} scripts/perl.prov.in
848 cp -p %{SOURCE30} scripts/rubygems.rb
849 cp -p %{SOURCE31} scripts/gem_helper.rb
850
851 rm scripts/find-php*
852
853 %{__mv} -f scripts/perl.req{,.in}
854
855 # generate Group translations to *.po
856 awk -f %{SOURCE6} %{SOURCE1}
857
858 install %{SOURCE26} tools/rpmdb_checkversion.c
859 install %{SOURCE28} tools/rpmdb_reset.c
860
861 for extlib in beecrypt neon %{?with_system_pcre:pcre} popt; do
862         [ -d $extlib ] && %{__rm} -r $extlib
863 done
864
865 %build
866 %{__libtoolize}
867 #%{__autopoint}
868 %{__aclocal}
869 %{__autoheader}
870 %{__autoconf}
871 %{__automake}
872
873 # rpm checks for CPU type at runtime, but it looks better
874 sed -i \
875         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
876         -e 's|@host_cpu@|%{_target_cpu}|' \
877         -e 's|@host_os@|%{_target_os}|' \
878         macros/macros.in
879
880 %{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
881 %configure \
882         WITH_PERL_VERSION=no \
883         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
884         __GPG=%{_bindir}/gpg \
885         --disable-silent-rules \
886         --enable-shared \
887         --enable-static \
888         %{!?with_apidocs:--without-apidocs} \
889         --with-beecrypt=external \
890         --with-bugreport="http://bugs.pld-linux.org/" \
891         --with-bzip2=external \
892         --with-db=external \
893         --with-dbapi=db \
894         --with-file=external \
895         --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
896         --with-libelf \
897         --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
898         --with-lzma=external \
899         --with-neon=%{?with_neon:external}%{!?with_neon:no} \
900         --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/%%{_target}/macros:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
901         --without-path-versioned \
902         --with-pcre=%{!?with_system_pcre:internal}%{?with_system_pcre:external} \
903         --with-popt=external \
904         %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
905         %{!?with_python:--without-python} \
906         --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
907         --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
908         --with-sepol=%{!?with_selinux:no}%{?with_selinux:external} \
909         --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
910         --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
911         --with-vendor=pld \
912         --with-xz=external \
913         --with-zlib=external
914
915 %{__make} -j1
916
917 %{?with_apidocs:%{__make} apidocs}
918
919 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
920         -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
921 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
922         -o tools/rpmdb_reset -ldb-%{reqdb_ver}
923
924 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
925         echo "Error linking rpmdb tools!"
926         exit 1
927 fi
928 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
929         echo "Error linking rpmdb tools!"
930         exit 1
931 fi
932
933 %install
934 rm -rf $RPM_BUILD_ROOT
935 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
936         $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
937
938 install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
939
940 %{__make} -j1 install \
941         pkgconfigdir=%{_pkgconfigdir} \
942         DESTDIR=$RPM_BUILD_ROOT
943
944 # install platform macros
945 for f in platform/*macros; do
946         bn=${f#*/}
947         fn=${bn%.macros}/macros
948         install -m644 $f -D %{buildroot}%{_rpmlibdir}/$fn
949 done
950
951 # cleanup
952 %ifnarch %{ix86} %{x8664} x32
953 rm $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
954 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
955 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
956 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
957 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
958 rm $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
959 rm $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
960 %endif
961
962 %ifnarch %{x8664} x32
963 rm $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
964 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
965 rm $RPM_BUILD_ROOT%{_rpmlibdir}/x32-linux/macros
966 rm $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
967 %endif
968
969 %ifnarch %{ppc}
970 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
971 %endif
972
973 rm $RPM_BUILD_ROOT%{_rpmlibdir}/alpha*-linux/macros
974 rm $RPM_BUILD_ROOT%{_rpmlibdir}/arm*-linux/macros
975 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ia64-linux/macros
976 rm $RPM_BUILD_ROOT%{_rpmlibdir}/k6-linux/macros
977 rm $RPM_BUILD_ROOT%{_rpmlibdir}/mips*-linux/macros
978 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc*series-linux/macros
979 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc64*-linux/macros
980 rm $RPM_BUILD_ROOT%{_rpmlibdir}/s390*-linux/macros
981 rm $RPM_BUILD_ROOT%{_rpmlibdir}/sparc*-linux/macros
982
983 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
984 # first platform file entry can't contain regexps
985 %ifarch x32
986 %{_target_cpu}-%{_target_vendor}-linux-gnux32
987 %else
988 %{_target_cpu}-%{_target_vendor}-linux
989 %endif
990
991 %ifarch x86_64
992 x86_64-[^-]*-[Ll]inux(-gnu)?
993 amd64-[^-]*-[Ll]inux(-gnu)?
994 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
995 %endif
996 %ifarch amd64
997 amd64-[^-]*-[Ll]inux(-gnu)?
998 x86_64-[^-]*-[Ll]inux(-gnu)?
999 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
1000 %endif
1001 %ifarch ia32e
1002 ia32e-[^-]*-[Ll]inux(-gnu)?
1003 x86_64-[^-]*-[Ll]inux(-gnu)?
1004 %endif
1005 %ifarch x32
1006 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
1007 x86_64-[^-]*-[Ll]inux(-gnu)?
1008 amd64-[^-]*-[Ll]inux(-gnu)?
1009 %endif
1010
1011 %ifarch athlon %{x8664} x32
1012 athlon-[^-]*-[Ll]inux(-gnu)?
1013 %endif
1014 %ifarch pentium4 athlon %{x8664} x32
1015 pentium4-[^-]*-[Ll]inux(-gnu)?
1016 %endif
1017 %ifarch pentium3 pentium4 athlon %{x8664} x32
1018 pentium3-[^-]*-[Ll]inux(-gnu)?
1019 %endif
1020 %ifarch i686 pentium3 pentium4 athlon %{x8664} x32
1021 i686-[^-]*-[Ll]inux(-gnu)?
1022 %endif
1023 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664} x32
1024 i586-[^-]*-[Ll]inux(-gnu)?
1025 %endif
1026 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664} x32
1027 i486-[^-]*-[Ll]inux(-gnu)?
1028 %endif
1029 %ifarch %{ix86} %{x8664} x32
1030 i386-[^-]*-[Ll]inux(-gnu)?
1031 %endif
1032
1033 %ifarch alpha
1034 alpha-[^-]*-[Ll]inux(-gnu)?
1035 %endif
1036
1037 %ifarch ia64
1038 ia64-[^-]*-[Ll]inux(-gnu)?
1039 %endif
1040
1041 %ifarch ppc64
1042 powerpc64-[^-]*-[Ll]inux(-gnu)?
1043 ppc64-[^-]*-[Ll]inux(-gnu)?
1044 %endif
1045 %ifarch %{ppc} ppc64
1046 powerpc-[^-]*-[Ll]inux(-gnu)?
1047 ppc-[^-]*-[Ll]inux(-gnu)?
1048 %endif
1049
1050 %ifarch s390x
1051 s390x-[^-]*-[Ll]inux(-gnu)?
1052 %endif
1053 %ifarch s390 s390x
1054 s390-[^-]*-[Ll]inux(-gnu)?
1055 %endif
1056
1057 %ifarch sparc64
1058 sparc64-[^-]*-[Ll]inux(-gnu)?
1059 sparcv8-[^-]*-[Ll]inux(-gnu)?
1060 sparcv9-[^-]*-[Ll]inux(-gnu)?
1061 %endif
1062 %ifarch sparcv9
1063 sparcv8-[^-]*-[Ll]inux(-gnu)?
1064 sparcv9-[^-]*-[Ll]inux(-gnu)?
1065 %endif
1066 %ifarch sparc sparcv9 sparc64
1067 sparc-[^-]*-[Ll]inux(-gnu)?
1068 %endif
1069
1070 noarch-[^-]*-.*
1071 EOF
1072
1073 # Squash Extra Blank Lines
1074 %{__sed} -i -e '/./,/^$/!d' $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
1075
1076 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1077 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1078 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
1079 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
1080 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.a
1081 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.la
1082 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-provides
1083 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-requires
1084
1085 # not installed since 4.4.8 (-tools-perl subpackage)
1086 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1087
1088 install %{SOURCE1} doc/manual/groups
1089 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
1090 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1091 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
1092 install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1093 install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
1094 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
1095 cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
1096 install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
1097 install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
1098 install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
1099
1100 install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
1101
1102 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1103
1104 install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
1105 install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
1106 install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1107 install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1108 install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1109 install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
1110 install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
1111
1112 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1113 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
1114 install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
1115 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1116 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1117 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
1118
1119 install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1120 install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1121 install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
1122
1123 # create macro loading wrappers for backward compatibility
1124 for m in gstreamer java mono perl php python; do
1125         echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
1126 done
1127
1128 # moved to rpm-build-macros 1.699
1129 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/macros.d/kernel
1130
1131 # for rpm -e|-U --repackage
1132 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1133 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
1134
1135 # move rpm to /bin
1136 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1137 # move essential libs to /lib (libs that /bin/rpm links to)
1138 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
1139         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1140         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
1141 done
1142
1143 # Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1144 mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1145
1146 %if %{with python}
1147 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1148 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
1149
1150 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
1151 %endif
1152
1153 # wrong location, not used anyway
1154 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
1155 # utils dropped in 5.4 -- their manuals
1156 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
1157 # script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1158 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
1159
1160 %find_lang %{name}
1161
1162 %{__rm} -rf manual
1163 cp -a doc/manual manual
1164 %{__rm} -f manual/Makefile*
1165
1166 %clean
1167 rm -rf $RPM_BUILD_ROOT
1168
1169 %pretrans
1170 # this needs to be a dir
1171 if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
1172         umask 022
1173         mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1174         mkdir %{_sysconfdir}/rpm/sysinfo
1175 fi
1176
1177 %posttrans
1178 if [ -e /var/lib/rpm/Packages ] && \
1179                 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
1180         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
1181                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
1182                 echo
1183                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
1184                 echo
1185         fi
1186         echo
1187         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
1188         echo 'you should ignore it and restart poldek'
1189         echo
1190         %{_rpmlibdir}/bin/dbupgrade.sh
1191 fi
1192
1193 %triggerpostun -- %{name} < 4.4.9-44
1194 %{_rpmlibdir}/hrmib-cache
1195
1196 %post   lib -p /sbin/ldconfig
1197 %postun lib -p /sbin/ldconfig
1198
1199 %pretrans build
1200 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
1201
1202 %files -f %{name}.lang
1203 %defattr(644,root,root,755)
1204 %doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
1205
1206 %dir /etc/pki/rpm-gpg
1207 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1208
1209 %attr(755,root,root) /bin/rpm
1210
1211 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
1212 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
1213 %dir %{_sysconfdir}/rpm/sysinfo
1214 # these are ok to be replaced
1215 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
1216 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1217
1218 %{_mandir}/man8/rpm.8*
1219 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1220 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1221 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1222 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1223 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1224
1225 %dir /var/lib/rpm
1226 %dir /var/lib/rpm/log
1227 %dir /var/lib/rpm/tmp
1228 %config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
1229 %dir %attr(700,root,root) /var/spool/repackage
1230 %dir /var/lock/rpm
1231 /var/lock/rpm/transaction
1232
1233 # exported package NVRA (stamped with install tid)
1234 # net-snmp hrSWInstalledName queries, bash-completions
1235 %dir /var/cache/hrmib
1236
1237 %{_rpmlibdir}/qf
1238 %{_rpmlibdir}/rpmpopt*
1239 %{_rpmlibdir}/macros
1240 %dir %{_rpmlibdir}/macros.d
1241 %{_rpmlibdir}/macros.d/pld
1242 %{_rpmlibdir}/cpuinfo.yaml
1243 %{_rpmlibdir}/noarch-*
1244 %ifarch %{ix86} %{x8664} x32
1245 %{_rpmlibdir}/i?86*
1246 %{_rpmlibdir}/pentium*
1247 %{_rpmlibdir}/athlon*
1248 %endif
1249 %ifarch alpha
1250 %{_rpmlibdir}/alpha*
1251 %endif
1252 %ifarch ia64
1253 %{_rpmlibdir}/ia64*
1254 %endif
1255 %ifarch mips mipsel mips64 mips64el
1256 %{_rpmlibdir}/mips*
1257 %endif
1258 %ifarch %{ppc}
1259 %{_rpmlibdir}/ppc*
1260 %endif
1261 %ifarch sparc sparc64
1262 %{_rpmlibdir}/sparc*
1263 %endif
1264 %ifarch %{x8664} x32
1265 %{_rpmlibdir}/amd64*
1266 %{_rpmlibdir}/ia32e*
1267 %{_rpmlibdir}/x86_64*
1268 %{_rpmlibdir}/x32*
1269 %endif
1270
1271 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1272
1273 %dir %{_rpmlibdir}/bin
1274 %attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
1275 %attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
1276 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
1277 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
1278 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdbchk
1279
1280 %files base
1281 %defattr(644,root,root,755)
1282 %dir %{_sysconfdir}/rpm
1283 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1284 %dir %{_rpmlibdir}
1285 %attr(755,root,root) %{_bindir}/banner.sh
1286 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1287 %dir /var/lib/banner
1288
1289 %files lib
1290 %defattr(644,root,root,755)
1291 %attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1292 %attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1293 %attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1294 %attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
1295 %attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
1296 %attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
1297
1298 %files devel
1299 %defattr(644,root,root,755)
1300 %attr(755,root,root) %{_libdir}/librpm.so
1301 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1302 %attr(755,root,root) %{_libdir}/librpmbuild.so
1303 %attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
1304 %attr(755,root,root) %{_libdir}/librpmconstant.so
1305 %attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
1306 %attr(755,root,root) %{_libdir}/librpmdb.so
1307 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1308 %attr(755,root,root) %{_libdir}/librpmio.so
1309 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1310 %attr(755,root,root) %{_libdir}/librpmmisc.so
1311 %attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
1312 %{_libdir}/librpm*.la
1313 %{_includedir}/rpm
1314 %{_pkgconfigdir}/*.pc
1315
1316 %files static
1317 %defattr(644,root,root,755)
1318 %{_libdir}/librpm*.a
1319
1320 %files utils
1321 %defattr(644,root,root,755)
1322 %attr(755,root,root) %{_bindir}/rpm2cpio
1323 %attr(755,root,root) %{_bindir}/rpmconstant
1324 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1325 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1326 %attr(755,root,root) %{_rpmlibdir}/tgpg
1327 %attr(755,root,root) %{_rpmlibdir}/bin/chroot
1328 %attr(755,root,root) %{_rpmlibdir}/bin/cp
1329 %attr(755,root,root) %{_rpmlibdir}/bin/debugedit
1330 %attr(755,root,root) %{_rpmlibdir}/bin/find
1331 %attr(755,root,root) %{_rpmlibdir}/bin/mgo
1332 %attr(755,root,root) %{_rpmlibdir}/bin/mtree
1333 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1334 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1335 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1336 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
1337 %if %{with selinux}
1338 %attr(755,root,root) %{_rpmlibdir}/bin/semodule
1339 %attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1340 %endif
1341 %if %{without system_lua}
1342 %attr(755,root,root) %{_rpmlibdir}/bin/lua
1343 %attr(755,root,root) %{_rpmlibdir}/bin/luac
1344 %attr(755,root,root) %{_rpmlibdir}/bin/rpmlua
1345 %attr(755,root,root) %{_rpmlibdir}/bin/rpmluac
1346 %endif
1347 %{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
1348 %attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
1349 %{_mandir}/man8/rpm2cpio.8*
1350 %{_mandir}/man8/rpmconstant.8*
1351 %{_mandir}/man8/rpmdeps.8*
1352 %{_mandir}/man8/rpmmtree.8*
1353 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1354 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1355 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1356 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1357
1358 %files utils-perl
1359 %defattr(644,root,root,755)
1360 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1361
1362 %if %{with static}
1363 %files utils-static
1364 %defattr(644,root,root,755)
1365 %attr(755,root,root) %{_bindir}/rpm[ieu]
1366 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1367 %endif
1368
1369 %files build
1370 %defattr(644,root,root,755)
1371 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1372 %attr(755,root,root) %{_rpmlibdir}/brp-*
1373 %attr(755,root,root) %{_rpmlibdir}/check-files
1374 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1375 %attr(755,root,root) %{_rpmlibdir}/cross-build
1376 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1377 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1378 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1379 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1380 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1381 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1382 %attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
1383 # needs hacked pkg-config to return anything
1384 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1385 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1386 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
1387 %{!?with_sqlite:%attr(755,root,root) %{_rpmlibdir}/bin/dbsql}
1388 %attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1389 %attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
1390 %attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1391 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspec
1392 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1393 %attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1394 %attr(755,root,root) %{_rpmlibdir}/bin/wget
1395 %attr(755,root,root) %{_rpmlibdir}/vcheck
1396 # not used yet ... these six depend on perl
1397 %attr(755,root,root) %{_rpmlibdir}/http.req
1398 # we always used scripts provided by mono-devel, maybe move them here
1399 #%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1400 #%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
1401
1402 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
1403 # must be here for "Requires: rpm-*prov" to work
1404 %{_rpmlibdir}/macros.d/cmake
1405 %{_rpmlibdir}/macros.d/gstreamer
1406 %{_rpmlibdir}/macros.d/java
1407 %{_rpmlibdir}/macros.d/libtool
1408 %{_rpmlibdir}/macros.d/mono
1409 %{_rpmlibdir}/macros.d/perl
1410 %{_rpmlibdir}/macros.d/php
1411 %{_rpmlibdir}/macros.d/pkgconfig
1412 %{_rpmlibdir}/macros.d/python
1413 %{_rpmlibdir}/macros.d/ruby
1414 %{_rpmlibdir}/macros.d/selinux
1415 %{_rpmlibdir}/macros.d/tcl
1416 %{_rpmlibdir}/macros.rpmbuild
1417 # compat wrappers
1418 %{_rpmlibdir}/macros.gstreamer
1419 %{_rpmlibdir}/macros.java
1420 %{_rpmlibdir}/macros.mono
1421 %{_rpmlibdir}/macros.perl
1422 %{_rpmlibdir}/macros.php
1423 %{_rpmlibdir}/macros.python
1424
1425 %attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1426 %attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1427
1428 %attr(755,root,root) %{_bindir}/gendiff
1429 %attr(755,root,root) %{_bindir}/rpmbuild
1430
1431 %dir %{_rpmlibdir}/helpers
1432 %attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
1433
1434 %{_mandir}/man1/gendiff.1*
1435 %{_mandir}/man8/rpmbuild.8*
1436 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1437 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1438 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1439
1440 %files javaprov
1441 %defattr(644,root,root,755)
1442 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1443 # needs jar (any jdk), jcf-dump (gcc-java) to work
1444 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1445
1446 %files rubyprov
1447 %defattr(644,root,root,755)
1448 %attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1449 %attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1450
1451 %files perlprov
1452 %defattr(644,root,root,755)
1453 %attr(755,root,root) %{_rpmlibdir}/perl.*
1454 %attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1455 %attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1456
1457 %files pythonprov
1458 %defattr(644,root,root,755)
1459 %attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
1460 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1461
1462 %files php-pearprov
1463 %defattr(644,root,root,755)
1464 %attr(755,root,root) %{_rpmlibdir}/php.prov
1465 %attr(755,root,root) %{_rpmlibdir}/php.req
1466 %attr(755,root,root) %{_rpmlibdir}/php.req.php
1467
1468 %if %{with python}
1469 %files -n python-rpm
1470 %defattr(644,root,root,755)
1471 %dir %{py_sitedir}/rpm
1472 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1473 %{py_sitedir}/rpm/*.py[co]
1474 %endif
1475
1476 %if %{with apidocs}
1477 %files apidocs
1478 %defattr(644,root,root,755)
1479 %doc apidocs
1480 %endif
This page took 0.345164 seconds and 3 git commands to generate.