fix pythondist provides for noarch packages
[packages/rpm.git] / rpm-noarch_py_prov.patch
1 diff --color -urN rpm-4.16.0.orig/fileattrs/pythondist.attr rpm-4.16.0/fileattrs/pythondist.attr
2 --- rpm-4.16.0.orig/fileattrs/pythondist.attr   2020-12-09 12:38:21.203961862 +0100
3 +++ rpm-4.16.0/fileattrs/pythondist.attr        2020-12-09 12:58:43.178952892 +0100
4 @@ -1,3 +1,3 @@
5  %__pythondist_provides %{_rpmconfigdir}/pythondistdeps.py --provides --majorver-provides
6  %__pythondist_requires %{_rpmconfigdir}/pythondistdeps.py --requires
7 -%__pythondist_path             /lib(64|x32)?/python[[:digit:]]\\.[[:digit:]]+/site-packages/[^/]+\\.(dist-info|egg-info|egg-link)$
8 +%__pythondist_path             /(lib(64|x32)?|share)/python[[:digit:]]\\.[[:digit:]]+/site-packages/[^/]+\\.(dist-info|egg-info|egg-link)$
This page took 0.057055 seconds and 3 git commands to generate.