]> git.pld-linux.org Git - packages/rpm.git/blob - rpm-helperEVR-noassert.patch
- added helperEVR-noassert patch (replace assert by error message;
[packages/rpm.git] / rpm-helperEVR-noassert.patch
1 --- rpm-4.5/lib/rpmfc.c.orig    2012-02-13 20:28:52.564758176 +0100
2 +++ rpm-4.5/lib/rpmfc.c 2012-02-14 19:01:50.810809655 +0100
3 @@ -472,7 +472,10 @@
4                 }
5                 i++;
6                 EVR = pav[i];
7 -assert(EVR != NULL);
8 +               if(EVR == NULL) {
9 +                       rpmMessage(RPMMESS_ERROR, _("%s helper returned empty version info for %s, omitting\n"), nsdep, N);
10 +                       continue;
11 +               }
12             }
13  /*@=branchstate@*/
14  
This page took 0.058214 seconds and 3 git commands to generate.