]> git.pld-linux.org Git - packages/rpm.git/blame_incremental - rpm.spec
- ugly gcc hack not needed.
[packages/rpm.git] / rpm.spec
... / ...
CommitLineData
1#
2# TODO:
3# - python(abi) cap is not provided automatically (because /usr/bin/python matches
4# ELF first; it should be provided by python-libs not binary anyway)
5# - consider using system libmagic not internal libfmagic
6# (but internal has different method of passing output)
7# - after ac drop amd64 patch and make x86_64 generic arch + subarchs amd64 and ia32e
8#
9# Conditional build:
10%bcond_with static # build static rpmi (not supported at the moment)
11%bcond_without apidocs # don't generate documentation with doxygen
12%bcond_with pkgnameinautoreq # don't put package name in autogenerated dependancy
13%bcond_without python # don't build python bindings
14%bcond_without selinux # dont enable selinux support
15# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
16# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
17# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
18
19# versions of required libraries
20%define reqdb_ver 4.3.27-1
21%define reqpopt_ver 1.10.1
22%define beecrypt_ver 2:4.1.0
23%define rpm_macros_rev 1.197
24Summary: RPM Package Manager
25Summary(de): RPM Packet-Manager
26Summary(es): Gestor de paquetes RPM
27