]> git.pld-linux.org Git - packages/rpm.git/blame_incremental - rpm.spec
- pl.po updates (in pl.po,etc_dir,build-failure-error patches)
[packages/rpm.git] / rpm.spec
... / ...
CommitLineData
1#
2# TODO:
3# - python(abi) cap is not provided automatically (because /usr/bin/python matches
4# ELF first; it should be provided by python-libs not binary anyway)
5# - repackaging when lzma is not installed (todo: fix digest signature of header)
6#
7# Conditional build:
8%bcond_with static # build static rpm+rpmi
9%bcond_without apidocs # don't generate documentation with doxygen
10%bcond_with autoreqdep # autogenerate package name deps in addition to sonames/perl(X)
11%bcond_without python # don't build python bindings
12%bcond_without selinux # build without selinux support
13%bcond_without system_libmagic # don't use system libmagic
14%bcond_with neon # build with HTTP/WebDAV support (neon library)
15# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
16# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
17# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
18
19# versions of required libraries
20%define reqdb_ver 4.4.20
21%define reqpopt_ver 1.10.6
22%define beecrypt_ver 2:4.1.2-4
23%define sover 4.4
24Summary: RPM Package Manager
25Summary(de): RPM Packet-Manager
26Summary(es): Gestor de paquetes RPM
27