]> git.pld-linux.org Git - packages/rpm.git/blame_incremental - rpm.spec
- add -f for pear_package_setup, allow package.xml outside subdir
[packages/rpm.git] / rpm.spec
... / ...
CommitLineData
1#
2# TODO:
3# - python(abi) cap is not provided automatically (because /usr/bin/python matches
4# ELF first; it should be provided by python-libs not binary anyway)
5#
6# Conditional build:
7%bcond_with static # build static rpmi (not supported at the moment)
8%bcond_without apidocs # don't generate documentation with doxygen
9%bcond_with autoreqdep # autogenerate package name deps in addition to sonames/perl(X)
10%bcond_without python # don't build python bindings
11%bcond_without selinux # build without selinux support
12%bcond_without system_libmagic # don't use system libmagic
13%bcond_with neon # build with HTTP/WebDAV support (neon library)
14# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
15# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
16# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
17
18# versions of required libraries
19%define reqdb_ver 4.3.27-1
20%define reqpopt_ver 1.10.2
21%define beecrypt_ver 2:4.1.2-4
22%define rpm_macros_rev 1.238
23Summary: RPM Package Manager
24Summary(de): RPM Packet-Manager
25Summary(es): Gestor de paquetes RPM
26