]> git.pld-linux.org Git - packages/rpm.git/blame_incremental - rpm.spec
- fixed non working backslah, strange
[packages/rpm.git] / rpm.spec
... / ...
CommitLineData
1#
2# TODO:
3# - detected Requires lists are not printed at the end of build (Provides etc. are)
4# - fix pythondeps detection (*.py[co] should belong to python class; autodetect P(abi))
5# - consider using system libmagic not internal libfmagic
6# (but internal has different method of passing output)
7# - after ac drop amd64 patch and make x86_64 generic arch + subarchs amd64 and ia32e
8#
9# Conditional build:
10%bcond_with distver # build with distversion field
11%bcond_with static # build static rpmi (not supported at the moment)
12%bcond_without apidocs # don't generate documentation with doxygen
13%bcond_with pkgnameinautoreq # don't put package name in autogenerated dependancy
14%bcond_without python # don't build python bindings
15%bcond_without selinux # dont enable selinux support
16# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
17# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
18# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
19
20%define snap 20041121
21# versions of required libraries
22%define reqdb_ver 4.3.27-1
23%define reqpopt_ver 1.10.1
24%define beecrypt_ver 2:4.1.0
25%define rpm_macros_rev 1.195
26Summary: RPM Package Manager
27Summary(de): RPM Packet-Manager
28Summary(es): Gestor de paquetes RPM
29