]> git.pld-linux.org Git - packages/rpm.git/blame_incremental - rpm.spec
- allow to build rpm api documentation with doxygen.
[packages/rpm.git] / rpm.spec
... / ...
CommitLineData
1#
2# TODO:
3# - consider using system libmagic not internal libfmagic
4# (but internal has different method of passing output)
5# - after ac drop amd64 patch and make x86_64 generic arch + subarchs amd64 and ia32e
6# - ? make putting packages names in autogenerating dependacies as runtime option
7#
8# Conditional build:
9%bcond_with static # build static rpmi (not supported at the moment)
10%bcond_without pkgnameinautoreq # don't put package name in autogenerated dependancy
11%bcond_without doc # don't generate documentation with doxygen
12%bcond_without python # don't build python bindings
13%bcond_without selinux # dont enable selinux support
14# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
15# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
16# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
17
18%define snap 20040614
19# versions of required libraries
20%define reqdb_ver 4.2.50-1
21%define reqpopt_ver 1.9
22%define beecrypt_ver 2:4.0.0
23%define rpm_macros_rev 1.162
24Summary: RPM Package Manager
25Summary(de): RPM Packet-Manager
26Summary(es): Gestor de paquetes RPM
27