- fix build with semanage and no other embedded interpreters
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
d0ee0933
JR
3# - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4# returns -ENOSYS
9fb5ee9e 5# - add macros for some ppc, mipsel, alpha and sparc
a0c0c9ca 6#
c296fee0 7# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 8#
89427592 9# Conditional build:
01d7a578 10%bcond_with static # build static rpm+rpmi
0a1ccab0 11%bcond_without apidocs # don't generate documentation with doxygen
4af66a2c
JB
12%bcond_without python # don't build python bindings
13%bcond_without selinux # build without selinux support
0dc47449 14%bcond_without suggest_tags # build without Suggest tag (bootstrapping)
7f47af9c 15%bcond_with db61 # use DB 6.1 instead of 5.2
34befcc5 16%bcond_with neon # build with HTTP/WebDAV support (neon library)
6f6c7465 17%bcond_with sqlite # build with SQLite support
70df63f3 18%bcond_with system_lua # use system lua
a22a4387 19%bcond_without system_pcre # use system pcre
d0ee0933 20%bcond_with keyutils # build with keyutils support
89427592
JB
21# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
22# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
23# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
858aa7d0 24#
858aa7d0 25
ba7bedbb
JR
26%if %{with sqlite}
27# Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
28%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
29%endif
30
003a039e 31# versions of required libraries
7f47af9c
JB
32%if %{with db61}
33%define reqdb_pkg db6.1
34%define reqdb_ver 6.1
35%define reqdb_pkgver 6.1.19
5f3f5bd6 36%else
bf728d07 37%define reqdb_pkg db5.2
cf169f7c
JR
38%define reqdb_ver 5.2
39%define reqdb_pkgver 5.2.36.0-4
5f3f5bd6 40%endif
ec44785a 41%define reqpopt_ver 1.15
7f11791f 42%define beecrypt_ver 2:4.2.0
70f8787d 43%define sover 5.4
fc60c9f3 44
e5f02e49 45Summary: RPM Package Manager
4ea2ed33
ER
46Summary(de.UTF-8): RPM Packet-Manager
47Summary(es.UTF-8): Gestor de paquetes RPM
48Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
49Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
50Summary(ru.UTF-8): Менеджер пакетов от RPM
51Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 52Name: rpm
b5280b8b 53Version: 5.4.15
e9576b98 54Release: 39
4e2db228 55License: LGPL v2.1
76214164 56Group: Base
b5280b8b 57# http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
afb55538 58Source0: %{name}-%{version}.tar.gz
b5280b8b 59# Source0-md5: 4067f83ca8b5bf1a21e443c0cff3efa0
c546a4d6
ER
60# See README.cpu-os-macros how to update cpu-os-macros.a
61Source100: cpu-os-macros.a
62Source101: README.cpu-os-macros
ff7bc1e6 63Source1: %{name}.groups
08697680 64Source2: macros.pld.in
ff7bc1e6 65Source3: %{name}-install-tree
80b8a1f9 66Source4: %{name}-find-spec-bcond
cf709a39 67Source5: %{name}-hrmib-cache
80b8a1f9
JB
68Source6: %{name}-groups-po.awk
69Source7: %{name}-compress-doc
0bf34f68
JR
70Source8: %{name}-php-provides
71Source9: %{name}-php-requires
72Source10: %{name}.sysinfo
73Source11: perl.prov
74Source12: %{name}-user_group.sh
75Source13: %{name}.sysconfig
76Source14: %{name}-java-requires
a4b7ef27 77# http://svn.pld-linux.org/banner.sh/
0bf34f68 78Source15: banner.sh
34f36471 79Source16: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
e1b97821 80# Source16-md5: 23914bb49fafe7153cee87126d966461
0bf34f68
JR
81Source17: %{name}-mimetypedeps
82Source18: macros.local
f09b01ac
ER
83Source19: %{name}.noautocompressdoc
84Source20: %{name}.noautoprov
85Source21: %{name}.noautoprovfiles
86Source22: %{name}.noautoreq
f09b01ac 87Source24: %{name}.noautoreqfiles
0bf34f68 88Source25: %{name}-php-requires.php
f09b01ac 89Source26: %{name}db_checkversion.c
b1541d4c 90Source27: macros.lang
f09b01ac 91Source28: %{name}db_reset.c
14138aba 92Source29: dbupgrade.sh
e2489d8e 93Source30: rubygems.rb
63194730 94Source31: gem_helper.rb
f05db907 95Patch0: %{name}-branch.patch
2f0ee4ec 96Patch1: %{name}-man_pl.patch
38e53563 97Patch2: %{name}-popt-aliases.patch
c0fe6b09 98Patch3: %{name}-nosetproctitle.patch
3465efba 99Patch4: %{name}-perl-macros.patch
c1768ce2 100Patch5: %{name}-perl-req-perlfile.patch
3c7590cc
JR
101Patch6: %{name}-scripts-closefds.patch
102Patch7: %{name}-php-macros.patch
103Patch8: %{name}-gettext-in-header.patch
044171ea 104Patch9: %{name}-lua.patch
9ee75c3c
JR
105Patch10: %{name}-php-deps.patch
106Patch11: %{name}-notsc.patch
107Patch12: %{name}-hack-norpmlibdep.patch
06405080 108Patch13: %{name}-dont-copy-descriptive-tags.patch
9ee75c3c
JR
109Patch14: %{name}-perl_req-INC_dirs.patch
110Patch15: %{name}-debuginfo.patch
111Patch16: vendor-pld.patch
112Patch17: %{name}-old-fileconflicts-behaviour.patch
113Patch18: %{name}-javadeps.patch
114Patch19: %{name}-truncate-cvslog.patch
115Patch20: %{name}-libtool-deps.patch
116Patch21: %{name}-mimetype.patch
117Patch22: %{name}-sparc64.patch
118Patch23: %{name}-gendiff.patch
119Patch24: openmp.patch
120Patch25: %{name}-URPM-build-fix.patch
ec7b8d8f 121Patch26: %{name}-semanage.patch
9ee75c3c
JR
122Patch27: %{name}-helperEVR-noassert.patch
123Patch28: %{name}-unglobal.patch
124Patch29: %{name}-builddir-readlink.patch
125Patch30: %{name}-changelog_order_check_nonfatal.patch
126Patch31: %{name}-cleanbody.patch
127Patch32: %{name}-dirdeps-macro.patch
128Patch33: %{name}-installbeforeerase.patch
129Patch34: %{name}-libmagic-locale.patch
130Patch35: %{name}-namespace-compare.patch
131Patch36: %{name}-popt-coreutils.patch
132Patch37: %{name}-postun-nofail.patch
133Patch38: %{name}-silence-RPM_CHAR_TYPE.patch
134Patch39: %{name}-fix-missing-types-in-headers.patch
135Patch40: %{name}-fix--p-interpreter-and-empty-script.patch
136Patch41: %{name}-db_buffer_small.patch
137Patch42: %{name}-pattern_Release.patch
138Patch43: %{name}-fix-___build_pre-macro.patch
139Patch44: %{name}-missing-patch-file-fails-build.patch
140Patch45: %{name}-remove-misleading-missing-patch-message.patch
141Patch46: %{name}-file-magic-can-be-mixed-case.patch
0b0a7839 142Patch47: %{name}-query-always-noisy.patch
7f7a3f24 143Patch48: %{name}-verify-ghosts-broken-logic.patch
295c267a 144Patch49: %{name}-python-enable-compat-RPMSENSE.patch
d6a36788 145Patch50: %{name}-dont-treat-gstreamer-modules-as-font.patch
bba1059c 146Patch51: %{name}-gst-inspect-typo.patch
1fcc9b69 147Patch52: %{name}-null-term-ascii-digest.patch
70df63f3 148Patch53: %{name}-lua-enable-extra-libs.patch
330093fa 149Patch54: %{name}-fix-filedigests-verify.patch
9158f140 150Patch55: %{name}-disable-hmac-verify.patch
f09b01ac 151Patch56: %{name}-macros.patch
f7779567 152Patch57: %{name}-db5.2.patch
c4861085 153Patch58: %{name}-preserve-iterator.patch
b10643ac 154Patch60: %{name}-python-sitescriptdir.patch
a6170fd4 155Patch61: %{name}-clean-docdir.patch
108e9711 156Patch62: %{name}-DB_CONFIG.patch
fb11a0dd 157Patch63: %{name}-pythoneggs.patch
80e5119e 158Patch64: %{name}-fix-compress-doc.patch
94807250 159Patch65: %{name}-parseSpec-skip-empty-tags.patch
10526c23 160Patch66: %{name}-payload-use-hashed-inode.patch
4e2db228 161Patch67: %{name}-repackage-dont-force-max-compression.patch
4e2db228 162Patch70: python-%{name}sense-missingok.patch
497556c4 163Patch71: %{name}-changelog-encoding.patch
c065c1c1 164Patch72: %{name}-preserve-tag-type.patch
68dafc6c
ER
165Patch74: %{name}-fix-internal-lua-build.patch
166Patch75: %{name}-double_check_file_deps.patch
5666ceed 167Patch77: %{name}-lua-expat.patch
3a3e476f 168Patch78: %{name}-double_check_unpackaged_subdirs.patch
5131d1d1 169Patch79: %{name}-rpmspec.patch
6d1e99c9 170Patch80: %{name}-revert-gpg-argv-parsing.patch
9d486499 171Patch81: %{name}-perl-magic.patch
64b1e365 172Patch82: %{name}-5.4.15-use-DSA-sig.patch
10a92209 173Patch83: %{name}-ignore-missing-macro-files.patch
321b78b0 174Patch84: x32.patch
8dc5e023
JR
175Patch85: rpm-CVE-2013-6435.patch
176Patch86: rpm-CVE-2014-8118.patch
0959ed6d 177Patch87: %{name}-file-output-for-ELF.patch
1c02955f 178Patch88: %{name}-rpmtdnext.patch
8b6cca9f 179Patch89: disable-header-verification.patch
a98c8118 180Patch90: %{name}-cppcompat.patch
d397adc8 181Patch91: py-disable-fetch.patch
8029452c 182Patch92: fast_python_deps.patch
b5cd30d4 183Patch93: python2_explicit.patch
7d0a808e 184Patch94: do_not_write_before_macro_buffer.patch
211e3eab 185Patch95: rpm-python-spec-header.patch
8c28fc02 186Patch96: skip-ldconfig-optimization.patch
70f8787d
JR
187
188# Patches imported from Mandriva
189
190# status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
191# would basically just mean backporting it..
f09b01ac 192Patch1000: %{name}-5.4.4-add-_specfile-macro.patch
70f8787d
JR
193# status: needs to be cleaned up and properly reviewed together with rest
194# of the patches related to dependency generation
f09b01ac 195Patch1001: %{name}-5.4.9-avoid-dependencies-on-self.patch
70f8787d 196# status: probably ready to merge
f09b01ac 197Patch1002: %{name}-5.4.4-pkgconfigdeps-check-path.patch
70f8787d 198# status: probably okay to merge, but discuss on rpm-devel first
f09b01ac 199Patch1003: %{name}-5.4.4-glob-wildcards-for-loading-macro-files.patch
70f8787d 200# status: needs to be discussed
f09b01ac 201Patch1004: %{name}-5.4.4-allow-installation-of-repackaged-rpms.patch
70f8787d 202# status: ready to merge
f09b01ac 203Patch1005: %{name}-5.4.8-dont-show-suggests-with-requires.patch
70f8787d 204# status: ready for merge
f09b01ac 205Patch1006: %{name}-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
70f8787d 206# status: probably okay to merge, but discuss on rpm-devel first
f09b01ac 207Patch1007: %{name}-5.4.10-duplicate_files_terminate_build.patch
70f8787d 208# status: same as above
f09b01ac 209Patch1008: %{name}-5.4.10-unpackaged_subdirs_terminate_build.patch
70f8787d
JR
210# mdvbz#64898
211# status: uncertain, might be okay to merge, discuss on rpm-devel first
f09b01ac 212Patch1009: %{name}-5.4.4-rpmbuild-withoutclean.patch
70f8787d
JR
213# no sense in having an additional dependency on 'pkgconfig' on all packages that
214# have a pkgconfig file, it's not needed for them to be made useful and anything
215# actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
216# status: might be okay to merge, but discuss on rpm-devel first
f09b01ac 217Patch1010: %{name}-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
70f8787d 218# status: ready for merge
f09b01ac 219Patch1011: %{name}-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
70f8787d
JR
220# $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
221# %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
222# status: needs to be discussed and investigated a bit better..
f09b01ac 223Patch1012: %{name}-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
70f8787d 224# status: probably okay to merge, but discuss on rpm-devel first
f09b01ac 225Patch1013: %{name}-5.4.10-files-listed-twice-terminates-build.patch
70f8787d 226# status: probably okay to merge
f09b01ac 227Patch1014: %{name}-5.4.9-ruby1.9-fixes.patch
70f8787d 228# status: keep locally
f09b01ac 229Patch1015: %{name}-5.4.9-keep-loading-script-macros.patch
70f8787d 230# status: same as for other dep gen patches
f09b01ac 231Patch1016: %{name}-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
70f8787d 232# status: idem
f09b01ac 233Patch1017: %{name}-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
70f8787d 234# status: probably okay to merge
f09b01ac 235Patch1019: %{name}-5.4.5-python-export-spec-macros.patch
70f8787d 236# status: idem
f09b01ac 237Patch1020: %{name}-5.4.9-font-provides.patch
70f8787d 238# stauus: idem
f09b01ac 239Patch1021: %{name}-5.4.7-kmod-dependencies.patch
70f8787d 240# status: probably okay to merge, discuss on rpm-devel first
f09b01ac 241Patch1022: %{name}-5.4.5-skip-dependencies-for-character-devices.patch
70f8787d 242# status: probably okay to merge
f09b01ac 243Patch1024: %{name}-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
70f8787d 244# status: probably okay to merge
f09b01ac 245Patch1026: %{name}-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
70f8787d 246# status: ready
f09b01ac 247Patch1027: %{name}-5.4.7-fix-generation-of-ruby-abi-provides.patch
70f8787d
JR
248# crash reproducable with 'rpm -qa --triggers'
249# status: ready
f09b01ac 250Patch1028: %{name}-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
70f8787d 251# status: same as for other dep gen patches
f09b01ac 252Patch1029: %{name}-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
70f8787d 253# status: ready
f09b01ac 254Patch1030: %{name}-5.4.7-fix-minor-memleaks.patch
70f8787d 255# status: ready
f09b01ac 256Patch1031: %{name}-5.4.9-mire-fix-strings-lacking-null-terminator.patch
70f8787d 257# status: ready
f09b01ac 258Patch1032: %{name}-5.4.9-rpmpython-fix-input.patch
70f8787d 259# status: ready
f09b01ac 260Patch1033: %{name}-5.4.7-no-seqid_init-on-rdonly-database.patch
70f8787d 261# status: probably ready for merging
f09b01ac 262Patch1034: %{name}-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
70f8787d 263# status: probably ready to merge, discuss on rpm-devel first
f09b01ac 264Patch1035: %{name}-5.4.9-fix-verify-segfault.patch
70f8787d
JR
265# Due to rpmdav/neon being written in a different fashion than other rpmio clients,
266# the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
267# with the result being that when unable to download files, neon will save error
268# page as the target file.
269# status: should go upstream, but uncertain about "correct" fix, ie. this is
270# more of a workaround, while rewriting rpmdav code to behave consistently
271# would be "the right thing to do". Yet I'm not fully able to grasp all of the
272# code and don't want to spend more time just to get the API..
f09b01ac 273Patch1037: %{name}-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
70f8787d
JR
274# As the transaction flags for ignoring arch & os are no longer used, there's
275# currently no way to ignore arch & os of packages anymore. This patch adds
276# support for doing this again by defining rpm variables and overriding
277# --ignorearch & --ignoreos to set these.
278# status: needs to be discussed upstream before thinking about merging
f09b01ac 279Patch1038: %{name}-5.4.10-support-ignore-arch-and-os-again.patch
9f9190ed 280# status: ready for merge
f09b01ac 281Patch1039: %{name}-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
e85b33bb 282# we want that patch too, a bit of builder infrastructure relies on NOSIGNATURES
f09b01ac 283Patch1040: %{name}-5.4.9-support-signatures-and-digest-disablers.patch
5555c3a0
JR
284# lack insight on actual functionality, which anyways seems broken, so let's
285# disable it to avoid errors from berkeley db..
286# status: keep locally
f09b01ac 287Patch1041: %{name}-5.4.9-disable-l10ndir.patch
dfd6cb49 288# status: ready for merge
f09b01ac 289Patch1042: %{name}-5.4.9-fix-rpm_qa-pattern.patch
221ad213
JR
290# warning: introduces memory leak
291Patch1043: %{name}-5.4.12-copy-Value-string.patch
7d3aa060 292Patch1044: %{name}-5.4.12-fix-rpmlua-print.patch
846d6870 293Patch1045: %{name}-5.4.12-fix-rpmpython-module-import-init.patch
6608973b 294Patch1046: %{name}-5.4.12-truncate-output-buffer-after-use.patch
a32fd84f 295Patch1047: %{name}-5.4.13-perl-bindings-do-not-use-xmalloc.patch
0004e9b0
ER
296# proyvind:
297# there's a rpmdbchk tool I wrote a while back, which might help you. although
298# the incidents it's able to deal with is rather limited ATM... it might help
299# you out, if not and you'll be able to solve yer problem, you could take a
300# stab at adding support for fixing your specific problem to the util ;)
301# https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-rpmdbchk.patch
302Patch1048: %{name}-5.4.14-rpmdbchk.patch
303# https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-no-assert-abort-with-broken-headers.patch
304Patch1049: %{name}-5.4.14-no-assert-abort-with-broken-headers.patch
70f8787d 305
883e0fac
WF
306Patch1050: python-libx32.patch
307
955f2725 308URL: http://rpm5.org/
cf169f7c 309BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
6f6c7465
JR
310%if %{with sqlite}
311BuildRequires: sqlite3-devel
312%else
cf169f7c 313BuildRequires: %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
6f6c7465 314%endif
29855fc2 315BuildRequires: autoconf >= 2.63
644d8958 316BuildRequires: automake >= 1.4
87ef0d95 317BuildRequires: beecrypt-devel >= %{beecrypt_ver}
33be5db0 318BuildRequires: bzip2-devel >= 1.0.2-17
33be5db0 319BuildRequires: elfutils-devel >= 0.108
3e70c06e 320BuildRequires: gettext-tools >= 0.19.2
d0ee0933 321%{?with_keyutils:BuildRequires: keyutils-devel}
241257bf 322BuildRequires: libmagic-devel
6e115b23
JR
323%if %{with selinux}
324BuildRequires: libselinux-devel >= 2.1.0
6e115b23 325BuildRequires: libsemanage-devel >= 2.1.0
3acb62f3 326BuildRequires: libsepol-devel >= 2.1.0
6e115b23 327%endif
84cdee7a
JB
328# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
329BuildRequires: libstdc++-devel
b60c74c3 330BuildRequires: libtool >= 1:1.4.2-9
33be5db0 331%if %{with neon}
fe861705 332BuildRequires: libxml2-devel
83d6a3fe 333BuildRequires: neon-devel >= 0.25.5
33be5db0 334%endif
95bd7348 335%{?with_system_lua:BuildRequires: lua52-devel >= 5.2.2}
127a0b3c 336BuildRequires: ossp-uuid-devel
7973b351 337BuildRequires: patch >= 2.2
1d49ffbc 338BuildRequires: popt-devel >= %{reqpopt_ver}
950eead3
ER
339%{?with_python:BuildRequires: python-devel >= 1:2.3}
340BuildRequires: python-modules >= 1:2.3
2a813afe 341%{?with_python:BuildRequires: rpm-pythonprov}
e56a10a9 342BuildRequires: tcl
77fcdbf7 343BuildRequires: xz-devel
3acb62f3 344BuildRequires: zlib-devel
5c2ab5c7
AM
345%if %{with apidocs}
346BuildRequires: doxygen
347BuildRequires: ghostscript
348BuildRequires: graphviz
349BuildRequires: tetex-pdftex
350%endif
a6e56ce4 351%if %{with static}
e6090a7b 352# Require static library only for static build
cf169f7c 353BuildRequires: %{reqdb_pkg}-static >= %{reqdb_pkgver}
87ef0d95 354BuildRequires: beecrypt-static >= %{beecrypt_ver}
33be5db0 355BuildRequires: bzip2-static >= 1.0.2-17
290c1c30 356BuildRequires: elfutils-static
10abbd40 357BuildRequires: glibc-static >= 2.2.94
241257bf 358BuildRequires: libmagic-static
6e115b23
JR
359%if %{with selinux}
360BuildRequires: libselinux-static >= 2.1.0
6e115b23 361BuildRequires: libsemanage-static >= 2.1.0
3acb62f3 362BuildRequires: libsepol-static >= 2.1.0
6e115b23 363%endif
003a039e 364BuildRequires: popt-static >= %{reqpopt_ver}
1d49ffbc 365BuildRequires: zlib-static
7a9d72ce 366%endif
d25ec6ea 367Requires(posttrans): coreutils
66edd895 368Requires: %{name}-base = %{version}-%{release}
b26a9709 369Requires: %{name}-lib = %{version}-%{release}
10abbd40
ER
370Requires: beecrypt >= %{beecrypt_ver}
371Requires: popt >= %{reqpopt_ver}
0229a8b9
AM
372Provides: rpm-db-ver = %{reqdb_ver}
373Obsoletes: rpm-getdeps
4adb7d05 374%{!?with_static:Obsoletes: rpm-utils-static}
874f4c9a 375Conflicts: glibc < 2.2.92
8ee1c72c
AM
376# db4.6 poldek needed
377Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
378# segfaults with lzma 0.42.2
379Conflicts: lzma-libs < 4.999.3
e4084afd 380Conflicts: util-vserver < 0.30.216-1.pre3034.7
1d49ffbc 381BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 382
4adb7d05 383%define _binary_payload w9.gzdio
6d82b332 384
4cd84746
JB
385# don't require very fresh rpm.macros to build
386%define __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
950eead3 387%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
9f517079 388%define ix86 i386 i486 i586 i686 athlon pentium3 pentium4
80e9f34d 389%define ppc ppc ppc7400 ppc7450
9f517079 390%define x8664 amd64 ia32e x86_64
4cd84746 391
89427592 392# stabilize new build environment
866e45c8 393%ifnarch x32
f9ac32aa
AM
394%define __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
395%define __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
396%define __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
866e45c8
JR
397%else
398# x32 is a very special case
399%define __newcc %{?force_cc}%{!?force_cc:x86_64-pld-linux-gnux32-gcc}
400%define __newcxx %{?force_cxx}%{!?force_cxx:x86_64-pld-linux-gnux32-g++}
401%define __newcpp %{?force_cpp}%{!?force_cpp:x86_64-pld-linux-gnux32-gcc -E}
402%endif
89427592 403
d755a548 404%define _rpmlibdir /usr/lib/rpm
950eead3 405%define _noautocompressdoc RPM-GPG-KEY
d755a548 406
ff7bc1e6 407%description
408RPM is a powerful package manager, which can be used to build,
409install, query, verify, update, and uninstall individual software
cf6faebc 410packages. A package consists of an archive of files, and package
fed73700 411information, including name, version, and description.
412
dd85fadc
JR
413%description -l de.UTF-8
414RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 415Installation, Anfrage, Verifizierung, Aktualisierung und
416Uninstallation individueller Softwarepakete. Ein Paket besteht aus
417einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 418Beschreibung.
419
dd85fadc 420%description -l es.UTF-8
313a4d1a 421RPM es un poderoso administrador de paquetes, que puede ser usado para
422construir, instalar, pesquisar, verificar, actualizar y desinstalar
423paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
424almacenaje de archivos, y información sobre el paquete, incluyendo
425nombre, versión y descripción.
426
427%description -l pl.UTF-8
428RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
429przebudowanie, instalację czy weryfikację dowolnego pakietu.
430Informacje dotyczące każdego pakietu, takie jak jego opis, lista
431plików wchodzących w skład pakietu, zależności od innych pakietów, są
432przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 433odpytywania programu rpm.
434
dd85fadc
JR
435%description -l pt_BR.UTF-8
436RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 437construir, instalar, pesquisar, verificar, atualizar e desinstalar
438pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
439arquivos e informações adicionais, incluindo nome, versão e descrição
440do pacote, permissões dos arquivos, etc.
441
442%description -l ru.UTF-8
443RPM - это мощный менеджер пакетов, который может быть использован для
444создания, инсталляции, запросов (query), проверки, обновления и
445удаления программных пакетов. Пакет состоит из файлового архива и
446служебной информации, включающей название, версию, описание и другие
447данные о пакете.
448
449%description -l uk.UTF-8
450RPM - це потужний менеджер пакетів, що може бути використаний для
451створення, інсталяції, запитів (query), перевірки, поновлення та
452видалення програмних пакетів. Пакет складається з файлового архіву та
453службової інформації, що містить назву, версію, опис та іншу
454інформацію про пакет.
7c6dc55f 455
66edd895
JB
456%package base
457Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 458Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 459Group: Base
1d9ca0c1 460Requires: filesystem
950eead3 461Obsoletes: rpm-scripts
66edd895
JB
462Obsoletes: vserver-rpm
463
464%description base
465The RPM base package contains scripts used by rpm packages themselves.
466These include:
467- scripts for adding/removing groups and users needed for rpm
468 packages,
469- banner.sh to display %%banner messages from rpm scriptlets.
470
dd85fadc
JR
471%description base -l pl.UTF-8
472Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 473Zawiera on:
dd85fadc
JR
474- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
475- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 476
69131f1a
JB
477%package lib
478Summary: RPMs library
4ea2ed33 479Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 480Group: Libraries
cf169f7c 481Requires: %{reqdb_pkg} >= %{reqdb_pkgver}
6f6c7465
JR
482%if %{with sqlite}
483Requires: sqlite3 >= %{sqlite_build_version}
484%else
cf169f7c 485Requires: %{reqdb_pkg}-sql >= %{reqdb_pkgver}
6f6c7465 486%endif
3acb62f3 487Requires: beecrypt >= %{beecrypt_ver}
241257bf 488Requires: libmagic >= 1.15-2
6e115b23 489%{?with_selinux:Requires: libselinux >= 2.1.0}
69131f1a 490Requires: popt >= %{reqpopt_ver}
d1795eb0 491Obsoletes: rpm-libs
69131f1a
JB
492# avoid SEGV caused by mixed db versions
493Conflicts: poldek < 0.18.1-16
494
495%description lib
496RPMs library.
497
dd85fadc 498%description lib -l pl.UTF-8
69131f1a
JB
499Biblioteki RPM-a.
500
fed73700 501%package devel
3f2d796a 502Summary: Header files for rpm libraries
4ea2ed33
ER
503Summary(de.UTF-8): Header-Dateien für rpm Libraries
504Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
505Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
506Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
507Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
508Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 509Group: Development/Libraries
153e5706 510Requires: %{name}-lib = %{version}-%{release}
cf169f7c 511Requires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
87ef0d95 512Requires: beecrypt-devel >= %{beecrypt_ver}
fea3cb89 513Requires: bzip2-devel
5c583f90 514Requires: elfutils-devel
d0ee0933 515%{?with_keyutils:Requires: keyutils-devel}
241257bf 516Requires: libmagic-devel
c7b2d5f9
KK
517%if %{with selinux}
518Requires: libselinux-devel
519Requires: libsemanage-devel
520Requires: libsepol-devel
521%endif
a998ac11 522Requires: popt-devel >= %{reqpopt_ver}
fea3cb89 523Requires: zlib-devel
cf6faebc 524
525%description devel
3f2d796a
JB
526The RPM packaging system includes C libraries that make it easy to
527manipulate RPM packages and databases. They are intended to ease the
cf6faebc 528creation of graphical package managers and other tools that need
3f2d796a
JB
529intimate knowledge of RPM packages. This package contains header files
530for these libraries.
fed73700 531
dd85fadc
JR
532%description devel -l de.UTF-8
533Der RPM-Packensystem enthält eine C-Library, die macht es einfach
534RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 535Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 536Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
537
dd85fadc 538%description devel -l es.UTF-8
313a4d1a 539El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
540fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
541facilitar la creación de administradores gráficos de paquetes y otras
20f89981 542herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 543
dd85fadc
JR
544%description devel -l pl.UTF-8
545System RPM zawiera biblioteki C, które ułatwiają manipulowanie
546pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
547graficznych programów zarządzających pakietami oraz innych narzędzi,
548które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
549zawiera pliki nagłówkowe wspomnianych bibliotek.
550
551%description devel -l pt_BR.UTF-8
552O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
553a manipulação de pacotes e bases de dados RPM. Seu objetivo é
554facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 555ferramentas que precisem de conhecimento profundo de pacotes RPM.
556
dd85fadc
JR
557%description devel -l ru.UTF-8
558Система управления пакетами RPM содержит библиотеку C, которая
559упрощает манипуляцию пакетами RPM и соответствующими базами данных.
560Эта библиотека предназначена для облегчения создания графических
561пакетных менеджеров и других утилит, которым необходимо работать с
562пакетами RPM.
7c6dc55f 563
dd85fadc
JR
564%description devel -l uk.UTF-8
565Система керування пакетами RPM містить бібліотеку C, котра спрощує
566роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
567призначена для полегшення створення графічних пакетних менеджерів та
568інших утиліт, що працюють з пакетами RPM.
7c6dc55f 569
fed73700 570%package static
9e42d68a 571Summary: RPM static libraries
4ea2ed33
ER
572Summary(de.UTF-8): RPMs statische Libraries
573Summary(pl.UTF-8): Biblioteki statyczne RPM-a
574Summary(pt_BR.UTF-8): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
575Summary(ru.UTF-8): Статическая библиотека для программ, работающих с rpm-пакетами
576Summary(uk.UTF-8): Статична бібліотека для програм, що працюють з пакетами rpm
edacdf8f 577Group: Development/Libraries
153e5706 578Requires: %{name}-devel = %{version}-%{release}
cf169f7c 579Requires: %{reqdb_pkg}-static >= %{reqdb_pkgver}
87ef0d95 580Requires: beecrypt-static >= %{beecrypt_ver}
df76dbd9 581Requires: bzip2-static
ff03e01a 582Requires: elfutils-static
d0ee0933 583%{?with_keyutils:Requires: keyutils-static}
241257bf 584Requires: libmagic-static
c7b2d5f9
KK
585%if %{with selinux}
586Requires: libselinux-static
587Requires: libsemanage-static
588Requires: libsepol-static
589%endif
a998ac11 590Requires: popt-static >= %{reqpopt_ver}
df76dbd9 591Requires: zlib-static
edacdf8f 592
593%description static
20f89981 594RPM static libraries.
fed73700 595
dd85fadc 596%description static -l de.UTF-8
20f89981 597RPMs statische Libraries.
9e42d68a 598
dd85fadc 599%description static -l pl.UTF-8
0a7ae9bc 600Biblioteki statyczne RPM-a.
313a4d1a 601
dd85fadc
JR
602%description static -l pt_BR.UTF-8
603Bibliotecas estáticas para desenvolvimento.
edacdf8f 604
dd85fadc
JR
605%description static -l ru.UTF-8
606Система управления пакетами RPM содержит библиотеку C, которая
607упрощает манипуляцию пакетами RPM и соответствующими базами данных.
608Это статическая библиотека RPM.
7c6dc55f 609
dd85fadc
JR
610%description static -l uk.UTF-8
611Система керування пакетами RPM містить бібліотеку C, котра спрощує
612роботу з пакетами RPM та відповідними базами даних. Це статична
613бібліотека RPM.
7c6dc55f 614
fed73700 615%package utils
8482995c 616Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
617Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
618Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 619Group: Applications/File
153e5706 620Requires: %{name} = %{version}-%{release}
a998ac11 621Requires: popt >= %{reqpopt_ver}
86b85368
AG
622%if %{with suggest_tags}
623Suggests: bzip2
624Suggests: gzip
86b85368 625%endif
695e60ad 626Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 627
628%description utils
8482995c 629Additional utilities for managing RPM packages and database.
fed73700 630
dd85fadc
JR
631%description utils -l de.UTF-8
632Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 633
dd85fadc
JR
634%description utils -l pl.UTF-8
635Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 636
92b3f576 637%package utils-perl
8482995c 638Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
639Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
640Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
92b3f576 641Group: Applications/File
153e5706 642Requires: %{name}-utils = %{version}-%{release}
92b3f576 643Requires: popt >= %{reqpopt_ver}
644
645%description utils-perl
8482995c 646Additional utilities for managing RPM packages and database.
92b3f576 647
dd85fadc
JR
648%description utils-perl -l de.UTF-8
649Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
92b3f576 650
dd85fadc
JR
651%description utils-perl -l pl.UTF-8
652Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
92b3f576 653
a00926bc
JB
654%package utils-static
655Summary: Static rpm utilities
4ea2ed33 656Summary(pl.UTF-8): Statyczne narzędzia rpm
a00926bc 657Group: Applications/System
153e5706 658Requires: %{name} = %{version}-%{release}
a00926bc
JB
659
660%description utils-static
661Static rpm utilities for repairing system in case something with
662shared libraries used by rpm become broken. Currently it contains rpmi
663binary, which can be used to install/upgrade/remove packages without
664using shared libraries (well, in fact with exception of NSS modules).
665
dd85fadc
JR
666%description utils-static -l pl.UTF-8
667Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
668związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
669Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
670uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
671(z wyjątkiem modułów NSS).
a00926bc 672
fed73700 673%package build
e191287c 674Summary: Scripts for building binary RPM packages
4ea2ed33
ER
675Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
676Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
677Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
678Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
679Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 680Group: Applications/File
f15ca8ca
ER
681Requires(pretrans): coreutils
682Requires(pretrans): findutils
716fe3ca 683Requires: %{name}-build-macros >= 1.712
153e5706 684Requires: %{name}-utils = %{version}-%{release}
e191287c 685Requires: /bin/id
686Requires: awk
cfa7898a 687Requires: bzip2
e950a6d7 688Requires: chrpath >= 0.10-4
b6547e10 689Requires: cpio
e191287c 690Requires: diffutils
195f647c 691Requires: elfutils
583135b4 692Requires: file >= 4.17
e191287c 693Requires: fileutils
694Requires: findutils
950eead3
ER
695%ifarch athlon
696Requires: gcc >= 3.0.3
697%else
698Requires: gcc
699%endif
e191287c 700Requires: glibc-devel
701Requires: grep
702Requires: gzip
703Requires: make
704Requires: patch
adbd4815 705Requires: sed >= 4.0
e191287c 706Requires: sh-utils
adbd4815 707Requires: tar >= 1:1.22
e191287c 708Requires: textutils
3acb62f3 709Requires: which
adbd4815 710Requires: xz
ca3648b1 711Provides: rpmbuild(monoautodeps)
37ea389a 712Provides: rpmbuild(noauto) = 3
02d17bf9 713%ifarch %{x8664}
195f647c
JB
714Conflicts: automake < 1:1.7.9-2
715Conflicts: libtool < 2:1.5-13
716%endif
0096c5cd 717
e2025ad1 718%description build
58399c37 719Scripts for building binary RPM packages.
fed73700 720
dd85fadc
JR
721%description build -l de.UTF-8
722Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 723
dd85fadc
JR
724%description build -l pl.UTF-8
725Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 726
dd85fadc
JR
727%description build -l pt_BR.UTF-8
728Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 729construir pacotes usando o RPM.
e73478cd 730
dd85fadc
JR
731%description build -l ru.UTF-8
732Различные вспомогательные скрипты и исполняемые программы, которые
733используются для сборки RPM'ов.
7c6dc55f 734
dd85fadc
JR
735%description build -l uk.UTF-8
736Різноманітні допоміжні скрипти та утиліти, які використовуються для
737побудови RPM'ів.
7c6dc55f 738
8482995c
JB
739%package javaprov
740Summary: Additional utilities for checking Java provides/requires in RPM packages
741Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
742Group: Applications/File
743Requires: %{name} = %{version}-%{release}
744Requires: file
745Requires: findutils >= 1:4.2.26
746Requires: mktemp
747Requires: unzip
748
749%description javaprov
750Additional utilities for checking Java provides/requires in RPM
751packages.
752
753%description javaprov -l pl.UTF-8
754Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
755RPM.
756
69131f1a 757%package perlprov
8482995c 758Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 759Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 760Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a
JB
761Group: Applications/File
762Requires: %{name} = %{version}-%{release}
b82853ee 763Requires: perl-Encode
69131f1a
JB
764Requires: perl-devel
765Requires: perl-modules
766
767%description perlprov
8482995c 768Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
769packages.
770
dd85fadc
JR
771%description perlprov -l de.UTF-8
772Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 773
dd85fadc 774%description perlprov -l pl.UTF-8
8482995c
JB
775Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
776pakietach RPM.
69131f1a
JB
777
778%package pythonprov
8482995c
JB
779Summary: Python macros, which simplifies creation of RPM packages with Python software
780Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a
JB
781Group: Applications/File
782Requires: %{name} = %{version}-%{release}
cd800b3c 783Requires: python
cfbc7086 784Requires: python-setuptools
3acb62f3 785Requires: python-modules
69131f1a
JB
786
787%description pythonprov
8482995c 788Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
789software.
790
dd85fadc 791%description pythonprov -l pl.UTF-8
8482995c 792Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
793Pythonie.
794
795%package php-pearprov
8482995c
JB
796Summary: Additional utilities for checking PHP PEAR provides/requires in RPM packages
797Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
69131f1a
JB
798Group: Applications/File
799Requires: %{name} = %{version}-%{release}
632f1b5c 800Requires: sed >= 4.0
1b39d378 801Suggests: php-pear-PHP_CompatInfo
69131f1a
JB
802
803%description php-pearprov
8482995c 804Additional utilities for checking PHP PEAR provides/requires in RPM
69131f1a
JB
805packages.
806
dd85fadc 807%description php-pearprov -l pl.UTF-8
8482995c
JB
808Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
809pakietach RPM.
69131f1a 810
ec49e9fb
ER
811%package rubyprov
812Summary: Ruby tools, which simplify creation of RPM packages with Ruby software
813Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
814Group: Applications/File
815Requires: %{name} = %{version}-%{release}
816Requires: ruby
817Requires: ruby-modules
b53b1f84 818Requires: ruby-rubygems
ec49e9fb
ER
819
820%description rubyprov
821Ruby tools, which simplifies creation of RPM packages with Ruby
822software.
823
824%description rubyprov -l pl.UTF-8
825Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
826Ruby.
827
69131f1a
JB
828%package -n python-rpm
829Summary: Python interface to RPM library
4ea2ed33
ER
830Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
831Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a
JB
832Group: Development/Languages/Python
833Requires: %{name} = %{version}-%{release}
3acb62f3 834Requires: python
69131f1a
JB
835Obsoletes: rpm-python
836
837%description -n python-rpm
838The rpm-python package contains a module which permits applications
839written in the Python programming language to use the interface
840supplied by RPM (RPM Package Manager) libraries.
841
842This package should be installed if you want to develop Python
843programs that will manipulate RPM packages and databases.
844
dd85fadc
JR
845%description -n python-rpm -l pl.UTF-8
846Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
847Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 848
dd85fadc
JR
849Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
850Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 851
dd85fadc
JR
852%description -n python-rpm -l pt_BR.UTF-8
853O pacote rpm-python contém um módulo que permite que aplicações
69131f1a
JB
854escritas em Python utilizem a interface fornecida pelas bibliotecas
855RPM (RPM Package Manager).
856
dd85fadc 857Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
858Python para manipular pacotes e bancos de dados RPM.
859
5c2ab5c7
AM
860%package apidocs
861Summary: RPM API documentation and guides
862Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
863Group: Documentation
d308de4c
ER
864%if "%{_rpmversion}" >= "5"
865BuildArch: noarch
866%endif
5c2ab5c7
AM
867
868%description apidocs
869Documentation for RPM API and guides in HTML format generated from rpm
870sources by doxygen.
871
872%description apidocs -l pl.UTF-8
873Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
874źrodeł RPM-a przez doxygen.
875
e2025ad1 876%prep
c546a4d6
ER
877%setup -q -n %{name}-%{version}%{?subver}
878install -d platform
879cd platform
880ar x %{SOURCE100}
881cd -
882
317ef122 883#patch0 -p1
2f0ee4ec 884%patch1 -p1
4d5b8e4c 885%patch2 -p1
c0fe6b09 886%patch3 -p1
7a3b1f24
AM
887%patch4 -p1
888%patch5 -p1
3c7590cc 889%patch6 -p1
c1768ce2 890%patch7 -p1
7a3b1f24 891%patch8 -p1
3c7590cc 892%{?with_system_lua:%patch9 -p1}
9ee75c3c 893%patch10 -p1
686b0204
JR
894%ifnarch i386 i486
895# enable TSC for capable archs
9ee75c3c 896%patch11 -p1
3c7590cc 897%endif
9ee75c3c
JR
898%patch12 -p1
899%patch13 -p1
900%patch14 -p0
7033e976 901%patch15 -p1
9ee75c3c 902%patch16 -p1
3c7590cc
JR
903%patch17 -p1
904%patch18 -p1
905%patch19 -p1
906%patch20 -p1
907%patch21 -p1
9ee75c3c 908%ifarch sparc64
3c7590cc 909%patch22 -p1
9ee75c3c 910%endif
3c7590cc 911%patch23 -p1
3c7590cc 912%patch24 -p1
3c7590cc 913%patch25 -p1
ec7b8d8f 914%patch26 -p1
24123ddd 915%patch27 -p1
3c7590cc
JR
916%patch28 -p1
917%patch29 -p1
918%patch30 -p1
919%patch31 -p1
920%patch32 -p1
921%patch33 -p1
950eead3 922%patch34 -p1
3c7590cc 923%patch35 -p1
148c9957 924%patch36 -p1
3c7590cc
JR
925%patch37 -p1
926%patch38 -p1
927%patch39 -p1
928%patch40 -p1
7f47af9c 929%{?with_db61:%patch41 -p1}
9ee75c3c 930%patch42 -p1
9f9190ed 931%patch43 -p1
1d20bd4e 932%patch44 -p1
e94735a5 933%patch45 -p1
7070b427 934%patch46 -p1
358bccd1 935%patch47 -p1
7f7a3f24 936%patch48 -p1
295c267a 937%patch49 -p1
d6a36788 938%patch50 -p1
bba1059c 939%patch51 -p1
1fcc9b69 940%patch52 -p0
70df63f3 941%patch53 -p1
330093fa 942%patch54 -p1
9158f140 943%patch55 -p1
267d7641 944%patch56 -p1
7f47af9c 945%{!?with_db61:%patch57 -p1}
c4861085 946%patch58 -p1
b10643ac 947%patch60 -p1
a6170fd4 948%patch61 -p1
108e9711 949%patch62 -p1
fb11a0dd 950%patch63 -p1
80e5119e 951%patch64 -p1
94807250 952%patch65 -p1
10526c23 953%patch66 -p1
2f067477 954%patch67 -p1
4cfbd61f 955%patch70 -p1
497556c4 956%patch71 -p1
c065c1c1 957%patch72 -p1
1af80494 958%patch74 -p1
900eb2ad 959%patch75 -p1
5666ceed 960%patch77 -p0
3a3e476f 961%patch78 -p1
5131d1d1 962%patch79 -p1
6d1e99c9 963%patch80 -p1
9d486499 964%patch81 -p0
64b1e365 965%patch82 -p1
321b78b0 966%patch84 -p1
8dc5e023
JR
967%patch85 -p1
968%patch86 -p1
0959ed6d 969%patch87 -p1
1c02955f 970%patch88 -p1
8b6cca9f 971%patch89 -p1
a98c8118 972%patch90 -p1
d397adc8 973%patch91 -p1
765b7c41 974
70f8787d
JR
975%patch1000 -p1
976%patch1001 -p1
977%patch1002 -p1
978%patch1003 -p1
979%patch1004 -p1
980%patch1005 -p1
981%patch1006 -p1
982%patch1007 -p1
983%patch1008 -p1
984%patch1009 -p1
985%patch1010 -p1
986%patch1011 -p1
987%patch1012 -p1
988%patch1013 -p1
989%patch1014 -p1
990%patch1015 -p1
991%patch1016 -p1
992%patch1017 -p1
70f8787d
JR
993%patch1019 -p1
994%patch1020 -p1
995%patch1021 -p1
996%patch1022 -p1
70f8787d 997%patch1024 -p1
70f8787d
JR
998%patch1026 -p1
999%patch1027 -p1
1000%patch1028 -p1
1001%patch1029 -p1
1002%patch1030 -p1
1003%patch1031 -p1
1004%patch1032 -p1
1005%patch1033 -p1
1006%patch1034 -p1
1007%patch1035 -p1
85771a72 1008%patch1037 -p1
70f8787d 1009%patch1038 -p1
9f9190ed 1010%patch1039 -p1
e85b33bb 1011%patch1040 -p1
b5280b8b
JR
1012# don't delete, may be usefull if jbj descides to enable this again
1013#%patch1041 -p1
dfd6cb49 1014%patch1042 -p1
221ad213 1015%patch1043 -p1
7d3aa060 1016%patch1044 -p1
846d6870 1017%patch1045 -p1
6608973b 1018%patch1046 -p1
a32fd84f 1019%patch1047 -p1
0004e9b0
ER
1020%patch1048 -p1
1021%patch1049 -p1
70f8787d 1022
10a92209 1023%patch83 -p1
8029452c 1024%patch92 -p1
b5cd30d4 1025%patch93 -p1
7d0a808e 1026%patch94 -p1
211e3eab 1027%patch95 -p1
8c28fc02 1028%patch96 -p1
10a92209 1029
883e0fac
WF
1030%patch1050 -p1
1031
70f8787d 1032install %{SOURCE2} macros/pld.in
0bf34f68
JR
1033install %{SOURCE8} scripts/php.prov.in
1034install %{SOURCE9} scripts/php.req.in
1035install %{SOURCE11} scripts/perl.prov.in
e2489d8e 1036cp -p %{SOURCE30} scripts/rubygems.rb
63194730 1037cp -p %{SOURCE31} scripts/gem_helper.rb
08697680 1038
9d09e076
ER
1039rm scripts/find-php*
1040
70f8787d 1041%{__mv} -f scripts/perl.req{,.in}
633d1e9e 1042
cd86db2e 1043# generate Group translations to *.po
80b8a1f9 1044awk -f %{SOURCE6} %{SOURCE1}
fefe9d30 1045
91ee86a9 1046install %{SOURCE26} tools/rpmdb_checkversion.c
8e8746c0 1047install %{SOURCE28} tools/rpmdb_reset.c
91ee86a9 1048
f012e16d 1049for extlib in beecrypt neon %{?with_system_pcre:pcre} popt; do
95bd7348
JR
1050 [ -d $extlib ] && %{__rm} -r $extlib
1051done
1052
87ef0d95 1053%build
ea816ea6 1054%{__libtoolize}
c0a9be8f 1055#%{__autopoint}
ceaaacee 1056%{__aclocal}
4cd84746 1057%{__autoheader}
7a9d72ce 1058%{__autoconf}
7a9d72ce 1059%{__automake}
7a9d72ce 1060
048d06f8
JR
1061# rpm checks for CPU type at runtime, but it looks better
1062sed -i \
1063 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
1064 -e 's|@host_cpu@|%{_target_cpu}|' \
1065 -e 's|@host_os@|%{_target_os}|' \
3f84726d 1066 macros/macros.in
048d06f8 1067
d268a169 1068%{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
89427592 1069# pass CC and CXX too in case of building with some older configure macro
624f96ff 1070%configure \
f9ac32aa
AM
1071 CC="%{__newcc}" \
1072 CXX="%{__newcxx}" \
1073 CPP="%{__newcpp}" \
01d7a578 1074 WITH_PERL_VERSION=no \
bba1059c 1075 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
3a3e476f 1076 --disable-silent-rules \
cd86db2e 1077 --enable-shared \
874f4c9a 1078 --enable-static \
5c2ab5c7 1079 %{!?with_apidocs:--without-apidocs} \
241257bf 1080 --with-beecrypt=external \
3a3e476f
JB
1081 --with-bugreport="http://bugs.pld-linux.org/" \
1082 --with-bzip2=external \
57256551
JR
1083 --with-db=external \
1084 --with-dbapi=db \
3a3e476f
JB
1085 --with-file=external \
1086 --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
1087 --with-libelf \
6a8612bc 1088 --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
3a3e476f
JB
1089 --with-lzma=external \
1090 --with-neon=%{?with_neon:external}%{!?with_neon:no} \
8a13e4c4 1091 --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/%%{_target}/macros:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
3a3e476f 1092 --without-path-versioned \
f012e16d 1093 --with-pcre=%{!?with_system_pcre:internal}%{?with_system_pcre:external} \
3a3e476f
JB
1094 --with-popt=external \
1095 %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
1096 %{!?with_python:--without-python} \
1097 --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
1098 --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
1099 --with-sepol=%{!?with_selinux:no}%{?with_selinux:external} \
1100 --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
127a0b3c 1101 --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
3a3e476f
JB
1102 --with-vendor=pld \
1103 --with-xz=external \
1104 --with-zlib=external
cf6faebc 1105
25e974c7 1106%{__make} -j1 \
f9ac32aa
AM
1107 CC="%{__cc}" \
1108 CXX="%{__cxx}" \
241257bf 1109 CPP="%{__cpp}"
33be5db0 1110
5c2ab5c7
AM
1111%{?with_apidocs:%{__make} apidocs}
1112
fb95de52
JR
1113%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
1114 -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
8e8746c0
JR
1115%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
1116 -o tools/rpmdb_reset -ldb-%{reqdb_ver}
fb95de52
JR
1117
1118if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
1119 echo "Error linking rpmdb tools!"
1120 exit 1
1121fi
8e8746c0
JR
1122if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
1123 echo "Error linking rpmdb tools!"
1124 exit 1
1125fi
91ee86a9 1126
b064b8e6 1127%install
ff7bc1e6 1128rm -rf $RPM_BUILD_ROOT
e9eb00af 1129install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
51081e43 1130 $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
54eb1770 1131
0bf34f68 1132install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 1133
26a5bf70 1134%{__make} -j1 install \
241257bf
AM
1135 pkgconfigdir=%{_pkgconfigdir} \
1136 DESTDIR=$RPM_BUILD_ROOT
718426e1 1137
c546a4d6
ER
1138# install platform macros
1139for f in platform/*macros; do
1140 bn=${f#*/}
1141 fn=${bn%.macros}/macros
1142 install -m644 $f -D %{buildroot}%{_rpmlibdir}/$fn
1143done
1144
1145# cleanup
c2683840 1146%ifnarch %{ix86} %{x8664} x32
c546a4d6
ER
1147rm $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
1148rm $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
1149rm $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
1150rm $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
1151rm $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
1152rm $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
1153rm $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
25ac75ae
AM
1154%endif
1155
c2683840 1156%ifnarch %{x8664} x32
c546a4d6 1157rm $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
851689fd 1158rm $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
c2683840 1159rm $RPM_BUILD_ROOT%{_rpmlibdir}/x32-linux/macros
851689fd 1160rm $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
25ac75ae
AM
1161%endif
1162
c546a4d6
ER
1163%ifnarch %{ppc}
1164rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
25ac75ae
AM
1165%endif
1166
c546a4d6
ER
1167rm $RPM_BUILD_ROOT%{_rpmlibdir}/alpha*-linux/macros
1168rm $RPM_BUILD_ROOT%{_rpmlibdir}/arm*-linux/macros
1169rm $RPM_BUILD_ROOT%{_rpmlibdir}/ia64-linux/macros
1170rm $RPM_BUILD_ROOT%{_rpmlibdir}/k6-linux/macros
1171rm $RPM_BUILD_ROOT%{_rpmlibdir}/mips*-linux/macros
1172rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc*series-linux/macros
1173rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc64*-linux/macros
1174rm $RPM_BUILD_ROOT%{_rpmlibdir}/s390*-linux/macros
1175rm $RPM_BUILD_ROOT%{_rpmlibdir}/sparc*-linux/macros
c546a4d6 1176
2eb9303e 1177cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
ca076ee5 1178# first platform file entry can't contain regexps
c2683840
JR
1179%ifarch x32
1180%{_target_cpu}-%{_target_vendor}-linux-gnux32
1181%else
2eb9303e 1182%{_target_cpu}-%{_target_vendor}-linux
c2683840 1183%endif
caf453d4 1184
2d8ae03e 1185%ifarch x86_64
53fd58bc 1186x86_64-[^-]*-[Ll]inux(-gnu)?
9cfcb6c8 1187amd64-[^-]*-[Ll]inux(-gnu)?
c2683840 1188x32-[^-]*-[Ll]inux(-gnu(x32)?)?
2d8ae03e 1189%endif
2d8ae03e 1190%ifarch amd64
53fd58bc
AM
1191amd64-[^-]*-[Ll]inux(-gnu)?
1192x86_64-[^-]*-[Ll]inux(-gnu)?
c2683840 1193x32-[^-]*-[Ll]inux(-gnu(x32)?)?
2d8ae03e 1194%endif
2d8ae03e 1195%ifarch ia32e
53fd58bc
AM
1196ia32e-[^-]*-[Ll]inux(-gnu)?
1197x86_64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1198%endif
c2683840
JR
1199%ifarch x32
1200x32-[^-]*-[Ll]inux(-gnu(x32)?)?
1201x86_64-[^-]*-[Ll]inux(-gnu)?
1202amd64-[^-]*-[Ll]inux(-gnu)?
1203%endif
2d8ae03e 1204
c2683840 1205%ifarch athlon %{x8664} x32
53fd58bc 1206athlon-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1207%endif
c2683840 1208%ifarch pentium4 athlon %{x8664} x32
53fd58bc 1209pentium4-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1210%endif
c2683840 1211%ifarch pentium3 pentium4 athlon %{x8664} x32
53fd58bc 1212pentium3-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1213%endif
c2683840 1214%ifarch i686 pentium3 pentium4 athlon %{x8664} x32
53fd58bc 1215i686-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1216%endif
c2683840 1217%ifarch i586 i686 pentium3 pentium4 athlon %{x8664} x32
53fd58bc 1218i586-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1219%endif
c2683840 1220%ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664} x32
53fd58bc 1221i486-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1222%endif
c2683840 1223%ifarch %{ix86} %{x8664} x32
53fd58bc 1224i386-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1225%endif
1226
5074eba9 1227%ifarch alpha
53fd58bc 1228alpha-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1229%endif
1230
1231%ifarch ia64
53fd58bc 1232ia64-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1233%endif
1234
1235%ifarch ppc64
53fd58bc
AM
1236powerpc64-[^-]*-[Ll]inux(-gnu)?
1237ppc64-[^-]*-[Ll]inux(-gnu)?
5074eba9 1238%endif
950eead3 1239%ifarch %{ppc} ppc64
53fd58bc
AM
1240powerpc-[^-]*-[Ll]inux(-gnu)?
1241ppc-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1242%endif
1243
1244%ifarch s390x
53fd58bc 1245s390x-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1246%endif
1247%ifarch s390 s390x
53fd58bc 1248s390-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1249%endif
1250
1251%ifarch sparc64
53fd58bc
AM
1252sparc64-[^-]*-[Ll]inux(-gnu)?
1253sparcv8-[^-]*-[Ll]inux(-gnu)?
1254sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1255%endif
1256%ifarch sparcv9
53fd58bc
AM
1257sparcv8-[^-]*-[Ll]inux(-gnu)?
1258sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1259%endif
1260%ifarch sparc sparcv9 sparc64
53fd58bc 1261sparc-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1262%endif
1263
2eb9303e
ER
1264noarch-[^-]*-.*
1265EOF
2d8ae03e 1266
e5486255
ER
1267# Squash Extra Blank Lines
1268%{__sed} -i -e '/./,/^$/!d' $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
1269
3a3e476f
JB
1270%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1271%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1272%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
1273%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
1274%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.a
1275%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.la
1276%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-provides
1277%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-requires
7cf857f2 1278
644d8958
JB
1279# not installed since 4.4.8 (-tools-perl subpackage)
1280install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1281
61f7e1b3 1282install %{SOURCE1} doc/manual/groups
d755a548 1283install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
80b8a1f9
JB
1284install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1285install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
0bf34f68
JR
1286install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1287install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
d755a548 1288install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
0bf34f68
JR
1289cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
1290install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
cf709a39 1291install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
0bf34f68 1292install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 1293
0bf34f68 1294install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 1295
950eead3
ER
1296install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1297
0bf34f68 1298install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
b1541d4c 1299install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
0bf34f68
JR
1300install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1301install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1302install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1303install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
0bf34f68 1304install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 1305
950eead3
ER
1306touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1307touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
0bf34f68 1308install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
950eead3
ER
1309touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1310touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1311touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
fbc0ff35 1312
91ee86a9 1313install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
345a6923 1314install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
14138aba 1315install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
91ee86a9 1316
9776a251
JR
1317# create macro loading wrappers for backward compatibility
1318for m in gstreamer java mono perl php python; do
b279f099 1319 echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
9776a251
JR
1320done
1321
e1bd88ba
JB
1322# moved to rpm-build-macros 1.699
1323%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/macros.d/kernel
1324
f3fd387a 1325# for rpm -e|-U --repackage
a11e0e27
AM
1326install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1327touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
f3fd387a 1328
950eead3
ER
1329# move rpm to /bin
1330mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1331# move essential libs to /lib (libs that /bin/rpm links to)
ece880e2 1332for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
50dc9ac0
JK
1333 mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1334 ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
c2673e18
AF
1335done
1336
950eead3
ER
1337# Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1338mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1339
dae5e1a8 1340%if %{with python}
6f18cdb7
AF
1341%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1342%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1343
08697680 1344%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
dae5e1a8 1345%endif
01d7a578 1346
01d7a578 1347# wrong location, not used anyway
08697680 1348%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
e86bfbff 1349# utils dropped in 5.4 -- their manuals
854562c1 1350%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
e86bfbff
JR
1351# script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1352%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
01d7a578 1353
90b03dd6 1354%find_lang %{name}
cf6faebc 1355
08697680 1356%{__rm} -rf manual
a998ac11 1357cp -a doc/manual manual
08697680 1358%{__rm} -f manual/Makefile*
874f4c9a 1359
13eb5ebf 1360%clean
d7df46b8 1361rm -rf $RPM_BUILD_ROOT
76214164 1362
cc1a4992
ER
1363%pretrans
1364# this needs to be a dir
1365if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
c1097150 1366 umask 022
cc1a4992
ER
1367 mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1368 mkdir %{_sysconfdir}/rpm/sysinfo
1369fi
1370
be4d3036 1371%posttrans
d25ec6ea 1372if [ -e /var/lib/rpm/Packages ] && \
6a934782 1373 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
d25ec6ea 1374 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
6a934782 1375 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 1376 echo
e4dd6a34 1377 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
1378 echo
1379 fi
3ca91ccd
JR
1380 echo
1381 echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
1382 echo 'you should ignore it and restart poldek'
1383 echo
3fc92bf7 1384 %{_rpmlibdir}/bin/dbupgrade.sh
be4d3036 1385fi
f7779567 1386
b7ee97ef
JR
1387%triggerpostun -- %{name} < 4.4.9-44
1388%{_rpmlibdir}/hrmib-cache
1389
ceaaacee
JB
1390%post lib -p /sbin/ldconfig
1391%postun lib -p /sbin/ldconfig
76214164 1392
37a5a2fc 1393%pretrans build
d755a548 1394find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 1395
3684d90f
JB
1396%files -f %{name}.lang
1397%defattr(644,root,root,755)
241257bf 1398%doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
3684d90f 1399
3acb62f3
ER
1400%dir /etc/pki/rpm-gpg
1401/etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
54eb1770 1402
7a9d72ce 1403%attr(755,root,root) /bin/rpm
e73478cd 1404
66edd895 1405%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 1406%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
950eead3 1407%dir %{_sysconfdir}/rpm/sysinfo
caf453d4 1408# these are ok to be replaced
950eead3 1409%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
caf453d4
AM
1410%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1411
09bb810c 1412%{_mandir}/man8/rpm.8*
feb1f12e 1413%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 1414%lang(ja) %{_mandir}/ja/man8/rpm.8*
ff7bc1e6 1415%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 1416%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 1417%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 1418
e2025ad1 1419%dir /var/lib/rpm
74a997bd
JR
1420%dir /var/lib/rpm/log
1421%dir /var/lib/rpm/tmp
1422%config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
f3fd387a 1423%dir %attr(700,root,root) /var/spool/repackage
a11e0e27
AM
1424%dir /var/lock/rpm
1425/var/lock/rpm/transaction
4acac5de 1426
cf709a39
ER
1427# exported package NVRA (stamped with install tid)
1428# net-snmp hrSWInstalledName queries, bash-completions
1429%dir /var/cache/hrmib
1430
ec44785a 1431%{_rpmlibdir}/qf
d755a548
JK
1432%{_rpmlibdir}/rpmpopt*
1433%{_rpmlibdir}/macros
08697680
JR
1434%dir %{_rpmlibdir}/macros.d
1435%{_rpmlibdir}/macros.d/pld
9282ffe4 1436%{_rpmlibdir}/cpuinfo.yaml
e23edf35 1437%{_rpmlibdir}/noarch-*
c2683840 1438%ifarch %{ix86} %{x8664} x32
e23edf35
JR
1439%{_rpmlibdir}/i?86*
1440%{_rpmlibdir}/pentium*
1441%{_rpmlibdir}/athlon*
1442%endif
1443%ifarch alpha
1444%{_rpmlibdir}/alpha*
1445%endif
1446%ifarch ia64
1447%{_rpmlibdir}/ia64*
1448%endif
1449%ifarch mips mipsel mips64 mips64el
1450%{_rpmlibdir}/mips*
1451%endif
1452%ifarch %{ppc}
1453%{_rpmlibdir}/ppc*
1454%endif
1455%ifarch sparc sparc64
1456%{_rpmlibdir}/sparc*
1457%endif
c2683840 1458%ifarch %{x8664} x32
e23edf35
JR
1459%{_rpmlibdir}/amd64*
1460%{_rpmlibdir}/ia32e*
1461%{_rpmlibdir}/x86_64*
c2683840 1462%{_rpmlibdir}/x32*
e23edf35 1463%endif
3684d90f 1464
cf709a39
ER
1465%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1466
df50421f
JR
1467%dir %{_rpmlibdir}/bin
1468%attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
14138aba 1469%attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
91ee86a9 1470%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
345a6923 1471%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
0004e9b0 1472%attr(755,root,root) %{_rpmlibdir}/bin/rpmdbchk
df50421f 1473
66edd895
JB
1474%files base
1475%defattr(644,root,root,755)
492a2bd4 1476%dir %{_sysconfdir}/rpm
66edd895
JB
1477%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1478%dir %{_rpmlibdir}
1479%attr(755,root,root) %{_bindir}/banner.sh
1480%attr(755,root,root) %{_rpmlibdir}/user_group.sh
1481%dir /var/lib/banner
1482
874f4c9a
MM
1483%files lib
1484%defattr(644,root,root,755)
950eead3
ER
1485%attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1486%attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1487%attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1488%attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
a434679c 1489%attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
ece880e2 1490%attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
874f4c9a 1491
69131f1a
JB
1492%files devel
1493%defattr(644,root,root,755)
69131f1a
JB
1494%attr(755,root,root) %{_libdir}/librpm.so
1495%attr(755,root,root) %{_libdir}/librpm-%{sover}.so
950eead3
ER
1496%attr(755,root,root) %{_libdir}/librpmbuild.so
1497%attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
02510ee8
AM
1498%attr(755,root,root) %{_libdir}/librpmconstant.so
1499%attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
950eead3
ER
1500%attr(755,root,root) %{_libdir}/librpmdb.so
1501%attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
69131f1a
JB
1502%attr(755,root,root) %{_libdir}/librpmio.so
1503%attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
02510ee8
AM
1504%attr(755,root,root) %{_libdir}/librpmmisc.so
1505%attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
950eead3
ER
1506%{_libdir}/librpm*.la
1507%{_includedir}/rpm
1508%{_pkgconfigdir}/*.pc
69131f1a
JB
1509
1510%files static
1511%defattr(644,root,root,755)
1512%{_libdir}/librpm*.a
1513
1514%files utils
1515%defattr(644,root,root,755)
69131f1a 1516%attr(755,root,root) %{_bindir}/rpm2cpio
25e974c7 1517%attr(755,root,root) %{_bindir}/rpmconstant
69131f1a 1518%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
69131f1a 1519%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
25e974c7 1520%attr(755,root,root) %{_rpmlibdir}/tgpg
df50421f
JR
1521%attr(755,root,root) %{_rpmlibdir}/bin/chroot
1522%attr(755,root,root) %{_rpmlibdir}/bin/cp
9282ffe4 1523%attr(755,root,root) %{_rpmlibdir}/bin/debugedit
df50421f
JR
1524%attr(755,root,root) %{_rpmlibdir}/bin/find
1525%attr(755,root,root) %{_rpmlibdir}/bin/mgo
9282ffe4
AF
1526%attr(755,root,root) %{_rpmlibdir}/bin/mtree
1527%attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1528%attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1529%attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1530%attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
6e115b23
JR
1531%if %{with selinux}
1532%attr(755,root,root) %{_rpmlibdir}/bin/semodule
1533%attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1534%endif
70df63f3
JR
1535%if %{without system_lua}
1536%attr(755,root,root) %{_rpmlibdir}/bin/lua
1537%attr(755,root,root) %{_rpmlibdir}/bin/luac
1538%attr(755,root,root) %{_rpmlibdir}/bin/rpmlua
1539%attr(755,root,root) %{_rpmlibdir}/bin/rpmluac
1540%endif
d0ee0933 1541%{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
9282ffe4 1542%attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
69131f1a 1543%{_mandir}/man8/rpm2cpio.8*
ec44785a 1544%{_mandir}/man8/rpmconstant.8*
69131f1a 1545%{_mandir}/man8/rpmdeps.8*
c0a9be8f 1546%{_mandir}/man8/rpmmtree.8*
69131f1a 1547%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
69131f1a
JB
1548%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1549%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
69131f1a
JB
1550%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1551
1552%files utils-perl
1553%defattr(644,root,root,755)
1554%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
69131f1a
JB
1555
1556%if %{with static}
1557%files utils-static
1558%defattr(644,root,root,755)
1559%attr(755,root,root) %{_bindir}/rpm[ieu]
1560%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1561%endif
1562
3684d90f 1563%files build
a45ae6d8 1564%defattr(644,root,root,755)
66edd895 1565%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
1566%attr(755,root,root) %{_rpmlibdir}/brp-*
1567%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548
JK
1568%attr(755,root,root) %{_rpmlibdir}/compress-doc
1569%attr(755,root,root) %{_rpmlibdir}/cross-build
d755a548 1570%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
d755a548
JK
1571%attr(755,root,root) %{_rpmlibdir}/getpo.sh
1572%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d755a548 1573%attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
01d7a578 1574%attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
01d7a578 1575%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
c75b3936 1576%attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
01d7a578
JB
1577# needs hacked pkg-config to return anything
1578%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
df50421f
JR
1579%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1580%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
ac8ac881 1581%{!?with_sqlite:%attr(755,root,root) %{_rpmlibdir}/bin/dbsql}
77fcdbf7
AF
1582%attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1583%attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
df50421f 1584%attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
5131d1d1 1585%attr(755,root,root) %{_rpmlibdir}/bin/rpmspec
df50421f
JR
1586%attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1587%attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1588%attr(755,root,root) %{_rpmlibdir}/bin/wget
ec44785a 1589%attr(755,root,root) %{_rpmlibdir}/vcheck
410dd742 1590# not used yet ... these six depend on perl
ec44785a 1591%attr(755,root,root) %{_rpmlibdir}/http.req
428645e9
JR
1592# we always used scripts provided by mono-devel, maybe move them here
1593#%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1594#%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
37e965e8 1595
70f8787d 1596%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 1597# must be here for "Requires: rpm-*prov" to work
df50421f
JR
1598%{_rpmlibdir}/macros.d/cmake
1599%{_rpmlibdir}/macros.d/gstreamer
77fcdbf7
AF
1600%{_rpmlibdir}/macros.d/java
1601%{_rpmlibdir}/macros.d/libtool
1602%{_rpmlibdir}/macros.d/mono
1603%{_rpmlibdir}/macros.d/perl
1604%{_rpmlibdir}/macros.d/php
1605%{_rpmlibdir}/macros.d/pkgconfig
1606%{_rpmlibdir}/macros.d/python
3b644c29 1607%{_rpmlibdir}/macros.d/ruby
77fcdbf7 1608%{_rpmlibdir}/macros.d/selinux
df50421f 1609%{_rpmlibdir}/macros.d/tcl
77fcdbf7 1610%{_rpmlibdir}/macros.rpmbuild
9776a251
JR
1611# compat wrappers
1612%{_rpmlibdir}/macros.gstreamer
1613%{_rpmlibdir}/macros.java
1614%{_rpmlibdir}/macros.mono
1615%{_rpmlibdir}/macros.perl
1616%{_rpmlibdir}/macros.php
1617%{_rpmlibdir}/macros.python
77fcdbf7 1618
df50421f
JR
1619%attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1620%attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
df50421f 1621
874f4c9a
MM
1622%attr(755,root,root) %{_bindir}/gendiff
1623%attr(755,root,root) %{_bindir}/rpmbuild
ec44785a
BZ
1624
1625%dir %{_rpmlibdir}/helpers
1626%attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
874f4c9a 1627
a00926bc 1628%{_mandir}/man1/gendiff.1*
874f4c9a 1629%{_mandir}/man8/rpmbuild.8*
fefe9d30
JB
1630%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1631%lang(pl) %{_mandir}/pl/man1/gendiff.1*
1632%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
f3fe287f 1633
7d8492bb
JB
1634%files javaprov
1635%defattr(644,root,root,755)
1636%attr(755,root,root) %{_rpmlibdir}/java-find-requires
1637# needs jar (any jdk), jcf-dump (gcc-java) to work
1638%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1639
ec49e9fb
ER
1640%files rubyprov
1641%defattr(644,root,root,755)
1642%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1643%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1644
89334051
AF
1645%files perlprov
1646%defattr(644,root,root,755)
d755a548 1647%attr(755,root,root) %{_rpmlibdir}/perl.*
ec44785a
BZ
1648%attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1649%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
9805fd6d 1650
80d3b868 1651%files pythonprov
d8fcb9b0 1652%defattr(644,root,root,755)
bdbae303 1653%attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
25d296e1 1654%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
09bb810c 1655
d36cb682
PG
1656%files php-pearprov
1657%defattr(644,root,root,755)
9d09e076
ER
1658%attr(755,root,root) %{_rpmlibdir}/php.prov
1659%attr(755,root,root) %{_rpmlibdir}/php.req
1660%attr(755,root,root) %{_rpmlibdir}/php.req.php
d36cb682 1661
50dc9ac0 1662%if %{with python}
cf6faebc 1663%files -n python-rpm
42a0025c 1664%defattr(644,root,root,755)
b33910fe 1665%dir %{py_sitedir}/rpm
6f18cdb7 1666%attr(755,root,root) %{py_sitedir}/rpm/*.so
8c99b39a 1667%{py_sitedir}/rpm/*.py[co]
50dc9ac0 1668%endif
5c2ab5c7
AM
1669
1670%if %{with apidocs}
1671%files apidocs
1672%defattr(644,root,root,755)
1673%doc apidocs
1674%endif
This page took 1.093928 seconds and 4 git commands to generate.