]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
add rpm-rubyprov package
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
d0ee0933
JR
3# - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4# returns -ENOSYS
9fb5ee9e 5# - add macros for some ppc, mipsel, alpha and sparc
a0c0c9ca 6#
c296fee0 7# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 8#
89427592 9# Conditional build:
01d7a578 10%bcond_with static # build static rpm+rpmi
0a1ccab0 11%bcond_without apidocs # don't generate documentation with doxygen
4af66a2c
JB
12%bcond_without python # don't build python bindings
13%bcond_without selinux # build without selinux support
0dc47449 14%bcond_without suggest_tags # build without Suggest tag (bootstrapping)
34befcc5 15%bcond_with neon # build with HTTP/WebDAV support (neon library)
858aa7d0 16%bcond_without db # BerkeleyDB
77fcdbf7 17%bcond_without sqlite # build with SQLite support
858aa7d0 18%bcond_with sqlite_dbapi # default database backend is sqlite
70df63f3 19%bcond_with system_lua # use system lua
d0ee0933 20%bcond_with keyutils # build with keyutils support
89427592
JB
21# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
22# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
23# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
858aa7d0
AM
24#
25%if %{with sqlite_dbapi}
26%define with_sqlite 1
27%endif
54bfdf99 28
858aa7d0 29%if %{without db} && %{without sqlite}
25ac75ae 30%{error:Need db or sqlite}
858aa7d0
AM
31ERROR
32%endif
33
ba7bedbb
JR
34%if %{with sqlite}
35# Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
36%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
37%endif
38
003a039e 39# versions of required libraries
bf728d07
JR
40%define reqdb_pkg db5.2
41%define reqdb_ver 5.2
ec44785a 42%define reqpopt_ver 1.15
fc60c9f3 43%define beecrypt_ver 2:4.1.2-4
70f8787d 44%define sover 5.4
fc60c9f3 45
e5f02e49 46Summary: RPM Package Manager
4ea2ed33
ER
47Summary(de.UTF-8): RPM Packet-Manager
48Summary(es.UTF-8): Gestor de paquetes RPM
49Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
50Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
51Summary(ru.UTF-8): Менеджер пакетов от RPM
52Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 53Name: rpm
afb55538 54Version: 5.4.10
60a7d3ea 55Release: 44
b0434f77 56License: LGPL
76214164 57Group: Base
afb55538
JR
58# http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.10-0.20120706.src.rpm
59Source0: %{name}-%{version}.tar.gz
60# Source0-md5: 5d099161bdd3203265ab32ffad3360b5
d38aed81
JR
61Source100: cpu-os-macros.tar.gz
62# Source100-md5: 928034a5bdceb398881bc14b5f29973b
ff7bc1e6 63Source1: %{name}.groups
08697680 64Source2: macros.pld.in
ff7bc1e6 65Source3: %{name}-install-tree
80b8a1f9 66Source4: %{name}-find-spec-bcond
cf709a39 67Source5: %{name}-hrmib-cache
80b8a1f9
JB
68Source6: %{name}-groups-po.awk
69Source7: %{name}-compress-doc
0bf34f68
JR
70Source8: %{name}-php-provides
71Source9: %{name}-php-requires
72Source10: %{name}.sysinfo
73Source11: perl.prov
74Source12: %{name}-user_group.sh
75Source13: %{name}.sysconfig
76Source14: %{name}-java-requires
a4b7ef27 77# http://svn.pld-linux.org/banner.sh/
0bf34f68
JR
78Source15: banner.sh
79Source16: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
80# Source16-md5: 08b29584dd349aac9caa7610131a0a88
81Source17: %{name}-mimetypedeps
82Source18: macros.local
83Source19: rpm.noautocompressdoc
84Source20: rpm.noautoprov
85Source21: rpm.noautoprovfiles
86Source22: rpm.noautoreq
87Source23: rpm.noautoreqdep
88Source24: rpm.noautoreqfiles
89Source25: %{name}-php-requires.php
91ee86a9 90Source26: rpmdb_checkversion.c
b1541d4c 91Source27: macros.lang
8e8746c0 92Source28: rpmdb_reset.c
14138aba 93Source29: dbupgrade.sh
f05db907 94Patch0: %{name}-branch.patch
2f0ee4ec 95Patch1: %{name}-man_pl.patch
38e53563 96Patch2: %{name}-popt-aliases.patch
3465efba 97Patch4: %{name}-perl-macros.patch
c1768ce2 98Patch5: %{name}-perl-req-perlfile.patch
3c7590cc
JR
99Patch6: %{name}-scripts-closefds.patch
100Patch7: %{name}-php-macros.patch
101Patch8: %{name}-gettext-in-header.patch
044171ea 102Patch9: %{name}-lua.patch
9ee75c3c
JR
103Patch10: %{name}-php-deps.patch
104Patch11: %{name}-notsc.patch
105Patch12: %{name}-hack-norpmlibdep.patch
06405080 106Patch13: %{name}-dont-copy-descriptive-tags.patch
9ee75c3c
JR
107Patch14: %{name}-perl_req-INC_dirs.patch
108Patch15: %{name}-debuginfo.patch
109Patch16: vendor-pld.patch
110Patch17: %{name}-old-fileconflicts-behaviour.patch
111Patch18: %{name}-javadeps.patch
112Patch19: %{name}-truncate-cvslog.patch
113Patch20: %{name}-libtool-deps.patch
114Patch21: %{name}-mimetype.patch
115Patch22: %{name}-sparc64.patch
116Patch23: %{name}-gendiff.patch
117Patch24: openmp.patch
118Patch25: %{name}-URPM-build-fix.patch
f7779567 119Patch26: %{name}-db5.3.patch
9ee75c3c
JR
120Patch27: %{name}-helperEVR-noassert.patch
121Patch28: %{name}-unglobal.patch
122Patch29: %{name}-builddir-readlink.patch
123Patch30: %{name}-changelog_order_check_nonfatal.patch
124Patch31: %{name}-cleanbody.patch
125Patch32: %{name}-dirdeps-macro.patch
126Patch33: %{name}-installbeforeerase.patch
127Patch34: %{name}-libmagic-locale.patch
128Patch35: %{name}-namespace-compare.patch
129Patch36: %{name}-popt-coreutils.patch
130Patch37: %{name}-postun-nofail.patch
131Patch38: %{name}-silence-RPM_CHAR_TYPE.patch
132Patch39: %{name}-fix-missing-types-in-headers.patch
133Patch40: %{name}-fix--p-interpreter-and-empty-script.patch
134Patch41: %{name}-db_buffer_small.patch
135Patch42: %{name}-pattern_Release.patch
136Patch43: %{name}-fix-___build_pre-macro.patch
137Patch44: %{name}-missing-patch-file-fails-build.patch
138Patch45: %{name}-remove-misleading-missing-patch-message.patch
139Patch46: %{name}-file-magic-can-be-mixed-case.patch
0b0a7839 140Patch47: %{name}-query-always-noisy.patch
7f7a3f24 141Patch48: %{name}-verify-ghosts-broken-logic.patch
295c267a 142Patch49: %{name}-python-enable-compat-RPMSENSE.patch
d6a36788 143Patch50: %{name}-dont-treat-gstreamer-modules-as-font.patch
bba1059c 144Patch51: %{name}-gst-inspect-typo.patch
1fcc9b69 145Patch52: %{name}-null-term-ascii-digest.patch
70df63f3 146Patch53: %{name}-lua-enable-extra-libs.patch
330093fa 147Patch54: %{name}-fix-filedigests-verify.patch
9158f140 148Patch55: %{name}-disable-hmac-verify.patch
267d7641 149Patch56: rpm-macros.patch
f7779567 150Patch57: %{name}-db5.2.patch
c4861085 151Patch58: %{name}-preserve-iterator.patch
9e6f2e68 152Patch59: %{name}-triggerin-compat.patch
b10643ac 153Patch60: %{name}-python-sitescriptdir.patch
a6170fd4 154Patch61: %{name}-clean-docdir.patch
108e9711 155Patch62: %{name}-DB_CONFIG.patch
fb11a0dd 156Patch63: %{name}-pythoneggs.patch
80e5119e 157Patch64: %{name}-fix-compress-doc.patch
94807250 158Patch65: %{name}-parseSpec-skip-empty-tags.patch
10526c23 159Patch66: %{name}-payload-use-hashed-inode.patch
70f8787d
JR
160
161# Patches imported from Mandriva
162
163# status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
164# would basically just mean backporting it..
165Patch1000: rpm-5.4.4-add-_specfile-macro.patch
166# status: needs to be cleaned up and properly reviewed together with rest
167# of the patches related to dependency generation
168Patch1001: rpm-5.4.9-avoid-dependencies-on-self.patch
169# status: probably ready to merge
170Patch1002: rpm-5.4.4-pkgconfigdeps-check-path.patch
171# status: probably okay to merge, but discuss on rpm-devel first
172Patch1003: rpm-5.4.4-glob-wildcards-for-loading-macro-files.patch
173# status: needs to be discussed
174Patch1004: rpm-5.4.4-allow-installation-of-repackaged-rpms.patch
175# status: ready to merge
176Patch1005: rpm-5.4.8-dont-show-suggests-with-requires.patch
177# status: ready for merge
178Patch1006: rpm-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
179# status: probably okay to merge, but discuss on rpm-devel first
180Patch1007: rpm-5.4.10-duplicate_files_terminate_build.patch
181# status: same as above
182Patch1008: rpm-5.4.10-unpackaged_subdirs_terminate_build.patch
183# mdvbz#64898
184# status: uncertain, might be okay to merge, discuss on rpm-devel first
185Patch1009: rpm-5.4.4-rpmbuild-withoutclean.patch
186# no sense in having an additional dependency on 'pkgconfig' on all packages that
187# have a pkgconfig file, it's not needed for them to be made useful and anything
188# actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
189# status: might be okay to merge, but discuss on rpm-devel first
190Patch1010: rpm-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
191# status: ready for merge
192Patch1011: rpm-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
193# $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
194# %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
195# status: needs to be discussed and investigated a bit better..
196Patch1012: rpm-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
197# status: probably okay to merge, but discuss on rpm-devel first
198Patch1013: rpm-5.4.10-files-listed-twice-terminates-build.patch
199# status: probably okay to merge
200Patch1014: rpm-5.4.9-ruby1.9-fixes.patch
201# status: keep locally
202Patch1015: rpm-5.4.9-keep-loading-script-macros.patch
203# status: same as for other dep gen patches
204Patch1016: rpm-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
205# status: idem
206Patch1017: rpm-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
207# status: ready for merge
208Patch1018: rpm-5.4.5-rubygems-add-missing-newline.patch
209# status: probably okay to merge
210Patch1019: rpm-5.4.5-python-export-spec-macros.patch
211# status: idem
212Patch1020: rpm-5.4.9-font-provides.patch
213# stauus: idem
214Patch1021: rpm-5.4.7-kmod-dependencies.patch
215# status: probably okay to merge, discuss on rpm-devel first
216Patch1022: rpm-5.4.5-skip-dependencies-for-character-devices.patch
217# status: ready to merge
218Patch1023: rpm-5.4.5-rpmfc-use-strlen-not-sizeof.patch
219# status: probably okay to merge
220Patch1024: rpm-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
221# status: ready to merge
222Patch1025: rpm-5.4.7-rpmfc-fix-invalid-free-if-not-_defaultdocdir-set.patch
223# status: probably okay to merge
224Patch1026: rpm-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
225# status: ready
226Patch1027: rpm-5.4.7-fix-generation-of-ruby-abi-provides.patch
227# crash reproducable with 'rpm -qa --triggers'
228# status: ready
229Patch1028: rpm-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
230# status: same as for other dep gen patches
231Patch1029: rpm-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
232# status: ready
233Patch1030: rpm-5.4.7-fix-minor-memleaks.patch
234# status: ready
235Patch1031: rpm-5.4.9-mire-fix-strings-lacking-null-terminator.patch
236# status: ready
237Patch1032: rpm-5.4.9-rpmpython-fix-input.patch
238# status: ready
239Patch1033: rpm-5.4.7-no-seqid_init-on-rdonly-database.patch
240# status: probably ready for merging
241Patch1034: rpm-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
242# status: probably ready to merge, discuss on rpm-devel first
243Patch1035: rpm-5.4.9-fix-verify-segfault.patch
244# status: ready and should be merged
245Patch1036: rpm-5.4.9-fix-typo-in-rpmtag-header.patch
246# Due to rpmdav/neon being written in a different fashion than other rpmio clients,
247# the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
248# with the result being that when unable to download files, neon will save error
249# page as the target file.
250# status: should go upstream, but uncertain about "correct" fix, ie. this is
251# more of a workaround, while rewriting rpmdav code to behave consistently
252# would be "the right thing to do". Yet I'm not fully able to grasp all of the
253# code and don't want to spend more time just to get the API..
254Patch1037: rpm-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
255# As the transaction flags for ignoring arch & os are no longer used, there's
256# currently no way to ignore arch & os of packages anymore. This patch adds
257# support for doing this again by defining rpm variables and overriding
258# --ignorearch & --ignoreos to set these.
259# status: needs to be discussed upstream before thinking about merging
260Patch1038: rpm-5.4.10-support-ignore-arch-and-os-again.patch
9f9190ed
JR
261# status: ready for merge
262Patch1039: rpm-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
e85b33bb
JR
263# we want that patch too, a bit of builder infrastructure relies on NOSIGNATURES
264Patch1040: rpm-5.4.9-support-signatures-and-digest-disablers.patch
5555c3a0
JR
265# lack insight on actual functionality, which anyways seems broken, so let's
266# disable it to avoid errors from berkeley db..
267# status: keep locally
268Patch1041: rpm-5.4.9-disable-l10ndir.patch
dfd6cb49
JR
269# status: ready for merge
270Patch1042: rpm-5.4.9-fix-rpm_qa-pattern.patch
70f8787d 271
955f2725 272URL: http://rpm5.org/
6a8612bc 273BuildRequires: autoconf >= 2.60
644d8958 274BuildRequires: automake >= 1.4
87ef0d95 275BuildRequires: beecrypt-devel >= %{beecrypt_ver}
33be5db0 276BuildRequires: bzip2-devel >= 1.0.2-17
7ef0925f 277%{?with_db:BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_ver}}
33be5db0 278BuildRequires: elfutils-devel >= 0.108
0ef6aeae 279#BuildRequires: gettext-autopoint >= 0.11.4-2
d1795eb0 280BuildRequires: gettext-devel >= 0.11.4-2
d0ee0933 281%{?with_keyutils:BuildRequires: keyutils-devel}
241257bf 282BuildRequires: libmagic-devel
6e115b23
JR
283%if %{with selinux}
284BuildRequires: libselinux-devel >= 2.1.0
6e115b23 285BuildRequires: libsemanage-devel >= 2.1.0
3acb62f3 286BuildRequires: libsepol-devel >= 2.1.0
6e115b23 287%endif
84cdee7a
JB
288# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
289BuildRequires: libstdc++-devel
b60c74c3 290BuildRequires: libtool >= 1:1.4.2-9
33be5db0 291%if %{with neon}
fe861705 292BuildRequires: libxml2-devel
83d6a3fe 293BuildRequires: neon-devel >= 0.25.5
33be5db0 294%endif
3acb62f3 295%{?with_system_lua:BuildRequires: lua51-devel >= 5.1.2}
127a0b3c 296BuildRequires: ossp-uuid-devel
7973b351 297BuildRequires: patch >= 2.2
1d49ffbc 298BuildRequires: popt-devel >= %{reqpopt_ver}
950eead3
ER
299%{?with_python:BuildRequires: python-devel >= 1:2.3}
300BuildRequires: python-modules >= 1:2.3
2a813afe 301%{?with_python:BuildRequires: rpm-pythonprov}
241257bf 302%{?with_sqlite:BuildRequires: sqlite3-devel}
e56a10a9 303BuildRequires: tcl
77fcdbf7 304BuildRequires: xz-devel
3acb62f3 305BuildRequires: zlib-devel
5c2ab5c7
AM
306%if %{with apidocs}
307BuildRequires: doxygen
308BuildRequires: ghostscript
309BuildRequires: graphviz
310BuildRequires: tetex-pdftex
311%endif
a6e56ce4 312%if %{with static}
e6090a7b 313# Require static library only for static build
3acb62f3 314%{?with_db:BuildRequires: %{reqdb_pkg}-static >= %{reqdb_ver}}
87ef0d95 315BuildRequires: beecrypt-static >= %{beecrypt_ver}
33be5db0 316BuildRequires: bzip2-static >= 1.0.2-17
290c1c30 317BuildRequires: elfutils-static
10abbd40 318BuildRequires: glibc-static >= 2.2.94
241257bf 319BuildRequires: libmagic-static
6e115b23
JR
320%if %{with selinux}
321BuildRequires: libselinux-static >= 2.1.0
6e115b23 322BuildRequires: libsemanage-static >= 2.1.0
3acb62f3 323BuildRequires: libsepol-static >= 2.1.0
6e115b23 324%endif
003a039e 325BuildRequires: popt-static >= %{reqpopt_ver}
1d49ffbc 326BuildRequires: zlib-static
7a9d72ce 327%endif
d25ec6ea 328Requires(posttrans): coreutils
66edd895 329Requires: %{name}-base = %{version}-%{release}
b26a9709 330Requires: %{name}-lib = %{version}-%{release}
10abbd40
ER
331Requires: beecrypt >= %{beecrypt_ver}
332Requires: popt >= %{reqpopt_ver}
0229a8b9
AM
333Provides: rpm-db-ver = %{reqdb_ver}
334Obsoletes: rpm-getdeps
4adb7d05 335%{!?with_static:Obsoletes: rpm-utils-static}
874f4c9a 336Conflicts: glibc < 2.2.92
8ee1c72c
AM
337# db4.6 poldek needed
338Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
339# segfaults with lzma 0.42.2
340Conflicts: lzma-libs < 4.999.3
e4084afd 341Conflicts: util-vserver < 0.30.216-1.pre3034.7
1d49ffbc 342BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 343
4adb7d05 344%define _binary_payload w9.gzdio
6d82b332 345
4cd84746
JB
346# don't require very fresh rpm.macros to build
347%define __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
950eead3 348%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
9f517079 349%define ix86 i386 i486 i586 i686 athlon pentium3 pentium4
80e9f34d 350%define ppc ppc ppc7400 ppc7450
9f517079 351%define x8664 amd64 ia32e x86_64
4cd84746 352
89427592 353# stabilize new build environment
f9ac32aa
AM
354%define __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
355%define __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
356%define __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
89427592 357
d755a548 358%define _rpmlibdir /usr/lib/rpm
950eead3 359%define _noautocompressdoc RPM-GPG-KEY
d755a548 360
ff7bc1e6 361%description
362RPM is a powerful package manager, which can be used to build,
363install, query, verify, update, and uninstall individual software
cf6faebc 364packages. A package consists of an archive of files, and package
fed73700 365information, including name, version, and description.
366
dd85fadc
JR
367%description -l de.UTF-8
368RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 369Installation, Anfrage, Verifizierung, Aktualisierung und
370Uninstallation individueller Softwarepakete. Ein Paket besteht aus
371einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 372Beschreibung.
373
dd85fadc 374%description -l es.UTF-8
313a4d1a 375RPM es un poderoso administrador de paquetes, que puede ser usado para
376construir, instalar, pesquisar, verificar, actualizar y desinstalar
377paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
378almacenaje de archivos, y información sobre el paquete, incluyendo
379nombre, versión y descripción.
380
381%description -l pl.UTF-8
382RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
383przebudowanie, instalację czy weryfikację dowolnego pakietu.
384Informacje dotyczące każdego pakietu, takie jak jego opis, lista
385plików wchodzących w skład pakietu, zależności od innych pakietów, są
386przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 387odpytywania programu rpm.
388
dd85fadc
JR
389%description -l pt_BR.UTF-8
390RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 391construir, instalar, pesquisar, verificar, atualizar e desinstalar
392pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
393arquivos e informações adicionais, incluindo nome, versão e descrição
394do pacote, permissões dos arquivos, etc.
395
396%description -l ru.UTF-8
397RPM - это мощный менеджер пакетов, который может быть использован для
398создания, инсталляции, запросов (query), проверки, обновления и
399удаления программных пакетов. Пакет состоит из файлового архива и
400служебной информации, включающей название, версию, описание и другие
401данные о пакете.
402
403%description -l uk.UTF-8
404RPM - це потужний менеджер пакетів, що може бути використаний для
405створення, інсталяції, запитів (query), перевірки, поновлення та
406видалення програмних пакетів. Пакет складається з файлового архіву та
407службової інформації, що містить назву, версію, опис та іншу
408інформацію про пакет.
7c6dc55f 409
66edd895
JB
410%package base
411Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 412Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 413Group: Base
1d9ca0c1 414Requires: filesystem
950eead3 415Obsoletes: rpm-scripts
66edd895
JB
416Obsoletes: vserver-rpm
417
418%description base
419The RPM base package contains scripts used by rpm packages themselves.
420These include:
421- scripts for adding/removing groups and users needed for rpm
422 packages,
423- banner.sh to display %%banner messages from rpm scriptlets.
424
dd85fadc
JR
425%description base -l pl.UTF-8
426Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 427Zawiera on:
dd85fadc
JR
428- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
429- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 430
69131f1a
JB
431%package lib
432Summary: RPMs library
4ea2ed33 433Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 434Group: Libraries
62eceee6 435%{?with_db:Requires: %{reqdb_pkg} >= %{reqdb_ver}}
3acb62f3 436Requires: beecrypt >= %{beecrypt_ver}
241257bf 437Requires: libmagic >= 1.15-2
6e115b23 438%{?with_selinux:Requires: libselinux >= 2.1.0}
69131f1a 439Requires: popt >= %{reqpopt_ver}
ba7bedbb 440%{?with_sqlite:Requires: sqlite3 >= %{sqlite_build_version}}
d1795eb0 441Obsoletes: rpm-libs
69131f1a
JB
442# avoid SEGV caused by mixed db versions
443Conflicts: poldek < 0.18.1-16
444
445%description lib
446RPMs library.
447
dd85fadc 448%description lib -l pl.UTF-8
69131f1a
JB
449Biblioteki RPM-a.
450
fed73700 451%package devel
3f2d796a 452Summary: Header files for rpm libraries
4ea2ed33
ER
453Summary(de.UTF-8): Header-Dateien für rpm Libraries
454Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
455Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
456Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
457Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
458Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 459Group: Development/Libraries
153e5706 460Requires: %{name}-lib = %{version}-%{release}
3acb62f3 461%{?with_db:Requires: %{reqdb_pkg}-devel >= %{reqdb_ver}}
87ef0d95 462Requires: beecrypt-devel >= %{beecrypt_ver}
fea3cb89 463Requires: bzip2-devel
5c583f90 464Requires: elfutils-devel
d0ee0933 465%{?with_keyutils:Requires: keyutils-devel}
241257bf 466Requires: libmagic-devel
10abbd40 467%{?with_selinux:Requires: libselinux-devel}
a998ac11 468Requires: popt-devel >= %{reqpopt_ver}
fea3cb89 469Requires: zlib-devel
cf6faebc 470
471%description devel
3f2d796a
JB
472The RPM packaging system includes C libraries that make it easy to
473manipulate RPM packages and databases. They are intended to ease the
cf6faebc 474creation of graphical package managers and other tools that need
3f2d796a
JB
475intimate knowledge of RPM packages. This package contains header files
476for these libraries.
fed73700 477
dd85fadc
JR
478%description devel -l de.UTF-8
479Der RPM-Packensystem enthält eine C-Library, die macht es einfach
480RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 481Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 482Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
483
dd85fadc 484%description devel -l es.UTF-8
313a4d1a 485El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
486fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
487facilitar la creación de administradores gráficos de paquetes y otras
20f89981 488herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 489
dd85fadc
JR
490%description devel -l pl.UTF-8
491System RPM zawiera biblioteki C, które ułatwiają manipulowanie
492pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
493graficznych programów zarządzających pakietami oraz innych narzędzi,
494które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
495zawiera pliki nagłówkowe wspomnianych bibliotek.
496
497%description devel -l pt_BR.UTF-8
498O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
499a manipulação de pacotes e bases de dados RPM. Seu objetivo é
500facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 501ferramentas que precisem de conhecimento profundo de pacotes RPM.
502
dd85fadc
JR
503%description devel -l ru.UTF-8
504Система управления пакетами RPM содержит библиотеку C, которая
505упрощает манипуляцию пакетами RPM и соответствующими базами данных.
506Эта библиотека предназначена для облегчения создания графических
507пакетных менеджеров и других утилит, которым необходимо работать с
508пакетами RPM.
7c6dc55f 509
dd85fadc
JR
510%description devel -l uk.UTF-8
511Система керування пакетами RPM містить бібліотеку C, котра спрощує
512роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
513призначена для полегшення створення графічних пакетних менеджерів та
514інших утиліт, що працюють з пакетами RPM.
7c6dc55f 515
fed73700 516%package static
9e42d68a 517Summary: RPM static libraries
4ea2ed33
ER
518Summary(de.UTF-8): RPMs statische Libraries
519Summary(pl.UTF-8): Biblioteki statyczne RPM-a
520Summary(pt_BR.UTF-8): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
521Summary(ru.UTF-8): Статическая библиотека для программ, работающих с rpm-пакетами
522Summary(uk.UTF-8): Статична бібліотека для програм, що працюють з пакетами rpm
edacdf8f 523Group: Development/Libraries
153e5706 524Requires: %{name}-devel = %{version}-%{release}
3acb62f3 525%{?with_db:Requires: %{reqdb_pkg}-static >= %{reqdb_ver}}
87ef0d95 526Requires: beecrypt-static >= %{beecrypt_ver}
df76dbd9 527Requires: bzip2-static
ff03e01a 528Requires: elfutils-static
d0ee0933 529%{?with_keyutils:Requires: keyutils-static}
241257bf 530Requires: libmagic-static
a998ac11 531Requires: popt-static >= %{reqpopt_ver}
df76dbd9 532Requires: zlib-static
edacdf8f 533
534%description static
20f89981 535RPM static libraries.
fed73700 536
dd85fadc 537%description static -l de.UTF-8
20f89981 538RPMs statische Libraries.
9e42d68a 539
dd85fadc 540%description static -l pl.UTF-8
0a7ae9bc 541Biblioteki statyczne RPM-a.
313a4d1a 542
dd85fadc
JR
543%description static -l pt_BR.UTF-8
544Bibliotecas estáticas para desenvolvimento.
edacdf8f 545
dd85fadc
JR
546%description static -l ru.UTF-8
547Система управления пакетами RPM содержит библиотеку C, которая
548упрощает манипуляцию пакетами RPM и соответствующими базами данных.
549Это статическая библиотека RPM.
7c6dc55f 550
dd85fadc
JR
551%description static -l uk.UTF-8
552Система керування пакетами RPM містить бібліотеку C, котра спрощує
553роботу з пакетами RPM та відповідними базами даних. Це статична
554бібліотека RPM.
7c6dc55f 555
fed73700 556%package utils
8482995c 557Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
558Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
559Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 560Group: Applications/File
153e5706 561Requires: %{name} = %{version}-%{release}
a998ac11 562Requires: popt >= %{reqpopt_ver}
86b85368
AG
563%if %{with suggest_tags}
564Suggests: bzip2
565Suggests: gzip
86b85368 566%endif
695e60ad 567Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 568
569%description utils
8482995c 570Additional utilities for managing RPM packages and database.
fed73700 571
dd85fadc
JR
572%description utils -l de.UTF-8
573Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 574
dd85fadc
JR
575%description utils -l pl.UTF-8
576Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 577
92b3f576 578%package utils-perl
8482995c 579Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
580Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
581Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
92b3f576 582Group: Applications/File
153e5706 583Requires: %{name}-utils = %{version}-%{release}
92b3f576 584Requires: popt >= %{reqpopt_ver}
585
586%description utils-perl
8482995c 587Additional utilities for managing RPM packages and database.
92b3f576 588
dd85fadc
JR
589%description utils-perl -l de.UTF-8
590Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
92b3f576 591
dd85fadc
JR
592%description utils-perl -l pl.UTF-8
593Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
92b3f576 594
a00926bc
JB
595%package utils-static
596Summary: Static rpm utilities
4ea2ed33 597Summary(pl.UTF-8): Statyczne narzędzia rpm
a00926bc 598Group: Applications/System
153e5706 599Requires: %{name} = %{version}-%{release}
a00926bc
JB
600
601%description utils-static
602Static rpm utilities for repairing system in case something with
603shared libraries used by rpm become broken. Currently it contains rpmi
604binary, which can be used to install/upgrade/remove packages without
605using shared libraries (well, in fact with exception of NSS modules).
606
dd85fadc
JR
607%description utils-static -l pl.UTF-8
608Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
609związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
610Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
611uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
612(z wyjątkiem modułów NSS).
a00926bc 613
fed73700 614%package build
e191287c 615Summary: Scripts for building binary RPM packages
4ea2ed33
ER
616Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
617Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
618Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
619Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
620Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 621Group: Applications/File
8f76a271 622Requires(pre): findutils
8f3e4798 623Requires: %{name}-build-macros >= 1.653
153e5706 624Requires: %{name}-utils = %{version}-%{release}
e191287c 625Requires: /bin/id
626Requires: awk
cfa7898a 627Requires: bzip2
e950a6d7 628Requires: chrpath >= 0.10-4
b6547e10 629Requires: cpio
e191287c 630Requires: diffutils
195f647c 631Requires: elfutils
583135b4 632Requires: file >= 4.17
e191287c 633Requires: fileutils
634Requires: findutils
950eead3
ER
635%ifarch athlon
636Requires: gcc >= 3.0.3
637%else
638Requires: gcc
639%endif
e191287c 640Requires: glibc-devel
641Requires: grep
642Requires: gzip
643Requires: make
644Requires: patch
adbd4815 645Requires: sed >= 4.0
e191287c 646Requires: sh-utils
adbd4815 647Requires: tar >= 1:1.22
e191287c 648Requires: textutils
3acb62f3 649Requires: which
adbd4815 650Requires: xz
ca3648b1 651Provides: rpmbuild(monoautodeps)
37ea389a 652Provides: rpmbuild(noauto) = 3
02d17bf9 653%ifarch %{x8664}
195f647c
JB
654Conflicts: automake < 1:1.7.9-2
655Conflicts: libtool < 2:1.5-13
656%endif
0096c5cd 657
e2025ad1 658%description build
58399c37 659Scripts for building binary RPM packages.
fed73700 660
dd85fadc
JR
661%description build -l de.UTF-8
662Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 663
dd85fadc
JR
664%description build -l pl.UTF-8
665Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 666
dd85fadc
JR
667%description build -l pt_BR.UTF-8
668Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 669construir pacotes usando o RPM.
e73478cd 670
dd85fadc
JR
671%description build -l ru.UTF-8
672Различные вспомогательные скрипты и исполняемые программы, которые
673используются для сборки RPM'ов.
7c6dc55f 674
dd85fadc
JR
675%description build -l uk.UTF-8
676Різноманітні допоміжні скрипти та утиліти, які використовуються для
677побудови RPM'ів.
7c6dc55f 678
8482995c
JB
679%package javaprov
680Summary: Additional utilities for checking Java provides/requires in RPM packages
681Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
682Group: Applications/File
683Requires: %{name} = %{version}-%{release}
684Requires: file
685Requires: findutils >= 1:4.2.26
686Requires: mktemp
687Requires: unzip
688
689%description javaprov
690Additional utilities for checking Java provides/requires in RPM
691packages.
692
693%description javaprov -l pl.UTF-8
694Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
695RPM.
696
69131f1a 697%package perlprov
8482995c 698Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 699Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 700Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a
JB
701Group: Applications/File
702Requires: %{name} = %{version}-%{release}
703Requires: perl-devel
704Requires: perl-modules
705
706%description perlprov
8482995c 707Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
708packages.
709
dd85fadc
JR
710%description perlprov -l de.UTF-8
711Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 712
dd85fadc 713%description perlprov -l pl.UTF-8
8482995c
JB
714Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
715pakietach RPM.
69131f1a
JB
716
717%package pythonprov
8482995c
JB
718Summary: Python macros, which simplifies creation of RPM packages with Python software
719Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a
JB
720Group: Applications/File
721Requires: %{name} = %{version}-%{release}
cd800b3c 722Requires: python
bdbae303 723Requires: python-distribute
3acb62f3 724Requires: python-modules
69131f1a
JB
725
726%description pythonprov
8482995c 727Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
728software.
729
dd85fadc 730%description pythonprov -l pl.UTF-8
8482995c 731Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
732Pythonie.
733
734%package php-pearprov
8482995c
JB
735Summary: Additional utilities for checking PHP PEAR provides/requires in RPM packages
736Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
69131f1a
JB
737Group: Applications/File
738Requires: %{name} = %{version}-%{release}
632f1b5c 739Requires: sed >= 4.0
69131f1a
JB
740
741%description php-pearprov
8482995c 742Additional utilities for checking PHP PEAR provides/requires in RPM
69131f1a
JB
743packages.
744
dd85fadc 745%description php-pearprov -l pl.UTF-8
8482995c
JB
746Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
747pakietach RPM.
69131f1a 748
ec49e9fb
ER
749%package rubyprov
750Summary: Ruby tools, which simplify creation of RPM packages with Ruby software
751Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
752Group: Applications/File
753Requires: %{name} = %{version}-%{release}
754Requires: ruby
755Requires: ruby-modules
756
757%description rubyprov
758Ruby tools, which simplifies creation of RPM packages with Ruby
759software.
760
761%description rubyprov -l pl.UTF-8
762Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
763Ruby.
764
69131f1a
JB
765%package -n python-rpm
766Summary: Python interface to RPM library
4ea2ed33
ER
767Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
768Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a
JB
769Group: Development/Languages/Python
770Requires: %{name} = %{version}-%{release}
3acb62f3 771Requires: python
69131f1a
JB
772Obsoletes: rpm-python
773
774%description -n python-rpm
775The rpm-python package contains a module which permits applications
776written in the Python programming language to use the interface
777supplied by RPM (RPM Package Manager) libraries.
778
779This package should be installed if you want to develop Python
780programs that will manipulate RPM packages and databases.
781
dd85fadc
JR
782%description -n python-rpm -l pl.UTF-8
783Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
784Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 785
dd85fadc
JR
786Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
787Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 788
dd85fadc
JR
789%description -n python-rpm -l pt_BR.UTF-8
790O pacote rpm-python contém um módulo que permite que aplicações
69131f1a
JB
791escritas em Python utilizem a interface fornecida pelas bibliotecas
792RPM (RPM Package Manager).
793
dd85fadc 794Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
795Python para manipular pacotes e bancos de dados RPM.
796
5c2ab5c7
AM
797%package apidocs
798Summary: RPM API documentation and guides
799Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
800Group: Documentation
801
802%description apidocs
803Documentation for RPM API and guides in HTML format generated from rpm
804sources by doxygen.
805
806%description apidocs -l pl.UTF-8
807Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
808źrodeł RPM-a przez doxygen.
809
e2025ad1 810%prep
d38aed81 811%setup -q -n %{name}-%{version}%{?subver} -a100
317ef122 812#patch0 -p1
2f0ee4ec 813%patch1 -p1
4d5b8e4c 814%patch2 -p1
7a3b1f24
AM
815%patch4 -p1
816%patch5 -p1
3c7590cc 817%patch6 -p1
c1768ce2 818%patch7 -p1
7a3b1f24 819%patch8 -p1
3c7590cc 820%{?with_system_lua:%patch9 -p1}
9ee75c3c 821%patch10 -p1
686b0204
JR
822%ifnarch i386 i486
823# enable TSC for capable archs
9ee75c3c 824%patch11 -p1
3c7590cc 825%endif
9ee75c3c
JR
826%patch12 -p1
827%patch13 -p1
828%patch14 -p0
7033e976 829%patch15 -p1
9ee75c3c 830%patch16 -p1
3c7590cc
JR
831%patch17 -p1
832%patch18 -p1
833%patch19 -p1
834%patch20 -p1
835%patch21 -p1
9ee75c3c 836%ifarch sparc64
3c7590cc 837%patch22 -p1
9ee75c3c 838%endif
3c7590cc 839%patch23 -p1
3c7590cc 840%patch24 -p1
3c7590cc 841%patch25 -p1
f7779567 842####%patch26 -p1
24123ddd 843%patch27 -p1
3c7590cc
JR
844%patch28 -p1
845%patch29 -p1
846%patch30 -p1
847%patch31 -p1
848%patch32 -p1
849%patch33 -p1
950eead3 850%patch34 -p1
3c7590cc 851%patch35 -p1
148c9957 852%patch36 -p1
3c7590cc
JR
853%patch37 -p1
854%patch38 -p1
855%patch39 -p1
856%patch40 -p1
f7779567 857####%patch41 -p1
9ee75c3c 858%patch42 -p1
9f9190ed 859%patch43 -p1
1d20bd4e 860%patch44 -p1
e94735a5 861%patch45 -p1
7070b427 862%patch46 -p1
358bccd1 863%patch47 -p1
7f7a3f24 864%patch48 -p1
295c267a 865%patch49 -p1
d6a36788 866%patch50 -p1
bba1059c 867%patch51 -p1
1fcc9b69 868%patch52 -p0
70df63f3 869%patch53 -p1
330093fa 870%patch54 -p1
9158f140 871%patch55 -p1
267d7641 872%patch56 -p1
f7779567 873%patch57 -p1
c4861085 874%patch58 -p1
9e6f2e68 875%patch59 -p1
b10643ac 876%patch60 -p1
a6170fd4 877%patch61 -p1
108e9711 878%patch62 -p1
fb11a0dd 879%patch63 -p1
80e5119e 880%patch64 -p1
94807250 881%patch65 -p1
10526c23 882%patch66 -p1
765b7c41 883
70f8787d
JR
884%patch1000 -p1
885%patch1001 -p1
886%patch1002 -p1
887%patch1003 -p1
888%patch1004 -p1
889%patch1005 -p1
890%patch1006 -p1
891%patch1007 -p1
892%patch1008 -p1
893%patch1009 -p1
894%patch1010 -p1
895%patch1011 -p1
896%patch1012 -p1
897%patch1013 -p1
898%patch1014 -p1
899%patch1015 -p1
900%patch1016 -p1
901%patch1017 -p1
902%patch1018 -p1
903%patch1019 -p1
904%patch1020 -p1
905%patch1021 -p1
906%patch1022 -p1
907%patch1023 -p1
908%patch1024 -p1
909%patch1025 -p1
910%patch1026 -p1
911%patch1027 -p1
912%patch1028 -p1
913%patch1029 -p1
914%patch1030 -p1
915%patch1031 -p1
916%patch1032 -p1
917%patch1033 -p1
918%patch1034 -p1
919%patch1035 -p1
920%patch1036 -p1
85771a72 921%patch1037 -p1
70f8787d 922%patch1038 -p1
9f9190ed 923%patch1039 -p1
e85b33bb 924%patch1040 -p1
5555c3a0 925%patch1041 -p1
dfd6cb49 926%patch1042 -p1
70f8787d
JR
927
928install %{SOURCE2} macros/pld.in
0bf34f68
JR
929install %{SOURCE8} scripts/php.prov.in
930install %{SOURCE9} scripts/php.req.in
931install %{SOURCE11} scripts/perl.prov.in
08697680 932
70f8787d 933%{__mv} -f scripts/perl.req{,.in}
633d1e9e 934
cd86db2e 935# generate Group translations to *.po
80b8a1f9 936awk -f %{SOURCE6} %{SOURCE1}
fefe9d30 937
91ee86a9 938install %{SOURCE26} tools/rpmdb_checkversion.c
8e8746c0 939install %{SOURCE28} tools/rpmdb_reset.c
91ee86a9 940
87ef0d95 941%build
ea816ea6 942%{__libtoolize}
c0a9be8f 943#%{__autopoint}
ceaaacee 944%{__aclocal}
4cd84746 945%{__autoheader}
7a9d72ce 946%{__autoconf}
7a9d72ce 947%{__automake}
7a9d72ce 948
048d06f8
JR
949# rpm checks for CPU type at runtime, but it looks better
950sed -i \
951 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
952 -e 's|@host_cpu@|%{_target_cpu}|' \
953 -e 's|@host_os@|%{_target_os}|' \
3f84726d 954 macros/macros.in
048d06f8 955
d268a169 956%{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
89427592 957# pass CC and CXX too in case of building with some older configure macro
624f96ff 958%configure \
f9ac32aa
AM
959 CC="%{__newcc}" \
960 CXX="%{__newcxx}" \
961 CPP="%{__newcpp}" \
01d7a578 962 WITH_PERL_VERSION=no \
bba1059c 963 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
cd86db2e 964 --enable-shared \
874f4c9a 965 --enable-static \
5c2ab5c7 966 %{!?with_apidocs:--without-apidocs} \
f3cb8244 967 %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
a6e56ce4 968 %{!?with_python:--without-python} \
6e115b23
JR
969 --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
970 --with-sepol=%{!?with_selinux:not}%{?with_selinux:external} \
971 --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
241257bf
AM
972 --with-libelf \
973 --with-zlib=external \
974 --with-bzip2=external \
975 --with-beecrypt=external \
1afa05ce 976 --with-lzma=external \
77fcdbf7 977 --with-xz=external \
241257bf
AM
978 --with-neon=%{?with_neon:external}%{!?with_neon:no} \
979 --with-file=external \
980 --with-popt=external \
afb55538 981 --with-db=%{?with_db:external}%{!?with_db:no} \
77fcdbf7 982 --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
950eead3 983 --with-dbapi=%{!?with_sqlite_dbapi:db}%{?with_sqlite_dbapi:sqlite} \
6a8612bc 984 --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
77fcdbf7 985 --with-pcre=external \
d0ee0933 986 --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
127a0b3c 987 --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
241257bf 988 --without-path-versioned \
adbd4815 989 --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/%{_target}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
08697680
JR
990 --with-bugreport="http://bugs.pld-linux.org/" \
991 --with-vendor=pld
cf6faebc 992
25e974c7 993%{__make} -j1 \
f9ac32aa
AM
994 CC="%{__cc}" \
995 CXX="%{__cxx}" \
241257bf 996 CPP="%{__cpp}"
33be5db0 997
5c2ab5c7
AM
998%{?with_apidocs:%{__make} apidocs}
999
fb95de52
JR
1000%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
1001 -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
8e8746c0
JR
1002%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
1003 -o tools/rpmdb_reset -ldb-%{reqdb_ver}
fb95de52
JR
1004
1005if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
1006 echo "Error linking rpmdb tools!"
1007 exit 1
1008fi
8e8746c0
JR
1009if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
1010 echo "Error linking rpmdb tools!"
1011 exit 1
1012fi
91ee86a9 1013
b064b8e6 1014%install
ff7bc1e6 1015rm -rf $RPM_BUILD_ROOT
e9eb00af 1016install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
51081e43 1017 $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
54eb1770 1018
0bf34f68 1019install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 1020
a5e7fb84 1021%{__make} install \
241257bf
AM
1022 pkgconfigdir=%{_pkgconfigdir} \
1023 DESTDIR=$RPM_BUILD_ROOT
718426e1 1024
25ac75ae
AM
1025# install ARCH macros
1026install -d $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux
d38aed81 1027install cpu-os-macros/noarch-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
25ac75ae
AM
1028
1029%ifarch %{ix86}
1030install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{i386,i486,i586,i686,athlon,pentium3,pentium4}-linux
d38aed81
JR
1031install cpu-os-macros/athlon-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
1032install cpu-os-macros/i386-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
1033install cpu-os-macros/i486-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
1034install cpu-os-macros/i586-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
1035install cpu-os-macros/i686-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
1036install cpu-os-macros/pentium3-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
1037install cpu-os-macros/pentium4-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
25ac75ae
AM
1038%endif
1039
1040%ifarch %{x8664}
1041install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{x86_64,ia32e,amd64}-linux
d38aed81
JR
1042install cpu-os-macros/x86_64-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
1043install cpu-os-macros/ia32e-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
1044install cpu-os-macros/amd64-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
25ac75ae
AM
1045%endif
1046
1047%ifarch %{ppc}
1048install -d $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux
d38aed81 1049install cpu-os-macros/ppc-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
25ac75ae
AM
1050%endif
1051
2eb9303e 1052cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
ca076ee5 1053# first platform file entry can't contain regexps
2eb9303e 1054%{_target_cpu}-%{_target_vendor}-linux
caf453d4 1055
2d8ae03e
AM
1056# x86_64 things
1057%ifarch x86_64
53fd58bc 1058x86_64-[^-]*-[Ll]inux(-gnu)?
9cfcb6c8 1059amd64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1060%endif
2d8ae03e 1061%ifarch amd64
53fd58bc
AM
1062amd64-[^-]*-[Ll]inux(-gnu)?
1063x86_64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1064%endif
2d8ae03e 1065%ifarch ia32e
53fd58bc
AM
1066ia32e-[^-]*-[Ll]inux(-gnu)?
1067x86_64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1068%endif
1069
1070# x86 things
06bd38df 1071%ifarch athlon %{x8664}
53fd58bc 1072athlon-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1073%endif
06bd38df 1074%ifarch pentium4 athlon %{x8664}
53fd58bc 1075pentium4-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1076%endif
06bd38df 1077%ifarch pentium3 pentium4 athlon %{x8664}
53fd58bc 1078pentium3-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1079%endif
06bd38df 1080%ifarch i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 1081i686-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1082%endif
06bd38df 1083%ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 1084i586-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1085%endif
06bd38df 1086%ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 1087i486-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1088%endif
06bd38df 1089%ifarch %{ix86} %{x8664}
53fd58bc 1090i386-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1091%endif
1092
5074eba9 1093%ifarch alpha
53fd58bc 1094alpha-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1095%endif
1096
1097%ifarch ia64
53fd58bc 1098ia64-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1099%endif
1100
1101%ifarch ppc64
53fd58bc
AM
1102powerpc64-[^-]*-[Ll]inux(-gnu)?
1103ppc64-[^-]*-[Ll]inux(-gnu)?
5074eba9 1104%endif
950eead3 1105%ifarch %{ppc} ppc64
53fd58bc
AM
1106powerpc-[^-]*-[Ll]inux(-gnu)?
1107ppc-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1108%endif
1109
1110%ifarch s390x
53fd58bc 1111s390x-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1112%endif
1113%ifarch s390 s390x
53fd58bc 1114s390-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1115%endif
1116
1117%ifarch sparc64
53fd58bc
AM
1118sparc64-[^-]*-[Ll]inux(-gnu)?
1119sparcv8-[^-]*-[Ll]inux(-gnu)?
1120sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1121%endif
1122%ifarch sparcv9
53fd58bc
AM
1123sparcv8-[^-]*-[Ll]inux(-gnu)?
1124sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1125%endif
1126%ifarch sparc sparcv9 sparc64
53fd58bc 1127sparc-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1128%endif
1129
1130# noarch
2eb9303e
ER
1131noarch-[^-]*-.*
1132EOF
2d8ae03e 1133
02919de5
JK
1134rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1135rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1136rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
950eead3 1137rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
02919de5 1138
644d8958
JB
1139# not installed since 4.4.8 (-tools-perl subpackage)
1140install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1141
61f7e1b3 1142install %{SOURCE1} doc/manual/groups
d755a548 1143install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
80b8a1f9
JB
1144install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1145install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
0bf34f68
JR
1146install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1147install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
d755a548
JK
1148install scripts/find-php* $RPM_BUILD_ROOT%{_rpmlibdir}
1149install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
0bf34f68
JR
1150cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
1151install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
cf709a39 1152install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
0bf34f68 1153install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 1154
0bf34f68 1155install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 1156
950eead3
ER
1157install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1158
0bf34f68 1159install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
b1541d4c 1160install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
0bf34f68
JR
1161install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1162install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1163install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1164install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
1165install %{SOURCE23} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep
1166install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 1167
950eead3
ER
1168touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1169touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
0bf34f68 1170install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
950eead3
ER
1171touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1172touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1173touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
fbc0ff35 1174
91ee86a9 1175install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
345a6923 1176install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
14138aba 1177install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
91ee86a9 1178
9776a251
JR
1179# create macro loading wrappers for backward compatibility
1180for m in gstreamer java mono perl php python; do
b279f099 1181 echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
9776a251
JR
1182done
1183
f3fd387a 1184# for rpm -e|-U --repackage
a11e0e27
AM
1185install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1186touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
f3fd387a 1187
950eead3
ER
1188# move rpm to /bin
1189mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1190# move essential libs to /lib (libs that /bin/rpm links to)
ece880e2 1191for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
50dc9ac0
JK
1192 mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1193 ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
c2673e18
AF
1194done
1195
950eead3
ER
1196# Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1197mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1198
dae5e1a8 1199%if %{with python}
6f18cdb7
AF
1200%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1201%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1202
08697680 1203%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
dae5e1a8 1204%endif
01d7a578 1205
01d7a578 1206# wrong location, not used anyway
08697680 1207%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
950eead3 1208# utils dropped in 4.4.8 -- their manuals
08697680 1209%{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man8/rpmgraph.8
e86bfbff 1210# utils dropped in 5.4 -- their manuals
854562c1 1211%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
e86bfbff
JR
1212# script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1213%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
01d7a578 1214
90b03dd6 1215%find_lang %{name}
cf6faebc 1216
08697680 1217%{__rm} -rf manual
a998ac11 1218cp -a doc/manual manual
08697680 1219%{__rm} -f manual/Makefile*
874f4c9a 1220
13eb5ebf 1221%clean
d7df46b8 1222rm -rf $RPM_BUILD_ROOT
76214164 1223
cc1a4992
ER
1224%pretrans
1225# this needs to be a dir
1226if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
c1097150 1227 umask 022
cc1a4992
ER
1228 mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1229 mkdir %{_sysconfdir}/rpm/sysinfo
1230fi
1231
be4d3036 1232%posttrans
d25ec6ea 1233if [ -e /var/lib/rpm/Packages ] && \
6a934782 1234 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
d25ec6ea 1235 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
6a934782 1236 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 1237 echo
e4dd6a34 1238 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
1239 echo
1240 fi
3ca91ccd
JR
1241 echo
1242 echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
1243 echo 'you should ignore it and restart poldek'
1244 echo
3fc92bf7 1245 %{_rpmlibdir}/bin/dbupgrade.sh
be4d3036 1246fi
f7779567 1247
b7ee97ef
JR
1248%triggerpostun -- %{name} < 4.4.9-44
1249%{_rpmlibdir}/hrmib-cache
1250
ceaaacee
JB
1251%post lib -p /sbin/ldconfig
1252%postun lib -p /sbin/ldconfig
76214164 1253
37a5a2fc 1254%pretrans build
d755a548 1255find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 1256
3684d90f
JB
1257%files -f %{name}.lang
1258%defattr(644,root,root,755)
241257bf 1259%doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
3684d90f 1260
3acb62f3
ER
1261%dir /etc/pki/rpm-gpg
1262/etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
54eb1770 1263
7a9d72ce 1264%attr(755,root,root) /bin/rpm
e73478cd 1265
66edd895 1266%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 1267%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
950eead3 1268%dir %{_sysconfdir}/rpm/sysinfo
caf453d4 1269# these are ok to be replaced
950eead3 1270%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
caf453d4
AM
1271%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1272
09bb810c 1273%{_mandir}/man8/rpm.8*
feb1f12e 1274%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 1275%lang(ja) %{_mandir}/ja/man8/rpm.8*
1162bdc1 1276%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 1277%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 1278%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 1279%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 1280
e2025ad1 1281%dir /var/lib/rpm
74a997bd
JR
1282%dir /var/lib/rpm/log
1283%dir /var/lib/rpm/tmp
1284%config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
f3fd387a 1285%dir %attr(700,root,root) /var/spool/repackage
a11e0e27
AM
1286%dir /var/lock/rpm
1287/var/lock/rpm/transaction
4acac5de 1288
cf709a39
ER
1289# exported package NVRA (stamped with install tid)
1290# net-snmp hrSWInstalledName queries, bash-completions
1291%dir /var/cache/hrmib
1292
ec44785a 1293%{_rpmlibdir}/qf
d755a548
JK
1294%{_rpmlibdir}/rpmpopt*
1295%{_rpmlibdir}/macros
08697680
JR
1296%dir %{_rpmlibdir}/macros.d
1297%{_rpmlibdir}/macros.d/pld
9282ffe4 1298%{_rpmlibdir}/cpuinfo.yaml
3684d90f 1299
cf709a39
ER
1300%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1301
df50421f
JR
1302%dir %{_rpmlibdir}/bin
1303%attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
14138aba 1304%attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
91ee86a9 1305%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
345a6923 1306%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
df50421f 1307
66edd895
JB
1308%files base
1309%defattr(644,root,root,755)
492a2bd4 1310%dir %{_sysconfdir}/rpm
66edd895
JB
1311%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1312%dir %{_rpmlibdir}
1313%attr(755,root,root) %{_bindir}/banner.sh
df50421f 1314%attr(755,root,root) %{_bindir}/multiarch-dispatch
66edd895
JB
1315%attr(755,root,root) %{_rpmlibdir}/user_group.sh
1316%dir /var/lib/banner
1317
874f4c9a
MM
1318%files lib
1319%defattr(644,root,root,755)
950eead3
ER
1320%attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1321%attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1322%attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1323%attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
a434679c 1324%attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
ece880e2 1325%attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
874f4c9a 1326
69131f1a
JB
1327%files devel
1328%defattr(644,root,root,755)
69131f1a
JB
1329%attr(755,root,root) %{_libdir}/librpm.so
1330%attr(755,root,root) %{_libdir}/librpm-%{sover}.so
950eead3
ER
1331%attr(755,root,root) %{_libdir}/librpmbuild.so
1332%attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
02510ee8
AM
1333%attr(755,root,root) %{_libdir}/librpmconstant.so
1334%attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
950eead3
ER
1335%attr(755,root,root) %{_libdir}/librpmdb.so
1336%attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
69131f1a
JB
1337%attr(755,root,root) %{_libdir}/librpmio.so
1338%attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
02510ee8
AM
1339%attr(755,root,root) %{_libdir}/librpmmisc.so
1340%attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
950eead3
ER
1341%{_libdir}/librpm*.la
1342%{_includedir}/rpm
df50421f 1343%{_includedir}/multiarch-dispatch.h
950eead3 1344%{_pkgconfigdir}/*.pc
69131f1a
JB
1345
1346%files static
1347%defattr(644,root,root,755)
1348%{_libdir}/librpm*.a
1349
1350%files utils
1351%defattr(644,root,root,755)
69131f1a 1352%attr(755,root,root) %{_bindir}/rpm2cpio
25e974c7 1353%attr(755,root,root) %{_bindir}/rpmconstant
69131f1a 1354%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
69131f1a 1355%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
25e974c7 1356%attr(755,root,root) %{_rpmlibdir}/tgpg
df50421f
JR
1357%attr(755,root,root) %{_rpmlibdir}/bin/chroot
1358%attr(755,root,root) %{_rpmlibdir}/bin/cp
9282ffe4 1359%attr(755,root,root) %{_rpmlibdir}/bin/debugedit
df50421f
JR
1360%attr(755,root,root) %{_rpmlibdir}/bin/find
1361%attr(755,root,root) %{_rpmlibdir}/bin/mgo
9282ffe4
AF
1362%attr(755,root,root) %{_rpmlibdir}/bin/mtree
1363%attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1364%attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1365%attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1366%attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
6e115b23
JR
1367%if %{with selinux}
1368%attr(755,root,root) %{_rpmlibdir}/bin/semodule
1369%attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1370%endif
70df63f3
JR
1371%if %{without system_lua}
1372%attr(755,root,root) %{_rpmlibdir}/bin/lua
1373%attr(755,root,root) %{_rpmlibdir}/bin/luac
1374%attr(755,root,root) %{_rpmlibdir}/bin/rpmlua
1375%attr(755,root,root) %{_rpmlibdir}/bin/rpmluac
1376%endif
d0ee0933 1377%{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
9282ffe4 1378%attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
69131f1a 1379%{_mandir}/man8/rpm2cpio.8*
950eead3 1380%{_mandir}/man8/rpmcache.8*
ec44785a 1381%{_mandir}/man8/rpmconstant.8*
69131f1a 1382%{_mandir}/man8/rpmdeps.8*
c0a9be8f 1383%{_mandir}/man8/rpmmtree.8*
69131f1a 1384%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
950eead3 1385%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
69131f1a
JB
1386%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1387%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
950eead3 1388%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
69131f1a 1389%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
69131f1a
JB
1390%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1391
1392%files utils-perl
1393%defattr(644,root,root,755)
1394%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
69131f1a
JB
1395
1396%if %{with static}
1397%files utils-static
1398%defattr(644,root,root,755)
1399%attr(755,root,root) %{_bindir}/rpm[ieu]
1400%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1401%endif
1402
3684d90f 1403%files build
a45ae6d8 1404%defattr(644,root,root,755)
66edd895 1405%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
1406%attr(755,root,root) %{_rpmlibdir}/brp-*
1407%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548
JK
1408%attr(755,root,root) %{_rpmlibdir}/compress-doc
1409%attr(755,root,root) %{_rpmlibdir}/cross-build
d755a548 1410%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
d755a548
JK
1411%attr(755,root,root) %{_rpmlibdir}/getpo.sh
1412%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d755a548 1413%attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
01d7a578 1414%attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
01d7a578 1415%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
c75b3936 1416%attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
01d7a578
JB
1417# needs hacked pkg-config to return anything
1418%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
df50421f
JR
1419%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1420%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
77fcdbf7
AF
1421%attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1422%attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
df50421f
JR
1423%attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1424%attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1425%attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1426%attr(755,root,root) %{_rpmlibdir}/bin/wget
ec44785a 1427%attr(755,root,root) %{_rpmlibdir}/vcheck
d755a548 1428%{_rpmlibdir}/noarch-*
e9fe9fc5 1429%ifarch %{ix86}
d755a548 1430%{_rpmlibdir}/i?86*
e9fe9fc5 1431%{_rpmlibdir}/pentium*
d755a548
JK
1432%{_rpmlibdir}/athlon*
1433%endif
ad628734
JB
1434%ifarch alpha
1435%{_rpmlibdir}/alpha*
1436%endif
ad628734
JB
1437%ifarch ia64
1438%{_rpmlibdir}/ia64*
8f76a271 1439%endif
410dd742 1440%ifarch mips mipsel mips64 mips64el
1441%{_rpmlibdir}/mips*
1442%endif
80e9f34d 1443%ifarch %{ppc}
410dd742 1444%{_rpmlibdir}/ppc*
1445%endif
1446%ifarch sparc sparc64
1447%{_rpmlibdir}/sparc*
1448%endif
9f517079 1449%ifarch %{x8664}
206b32be
JB
1450%{_rpmlibdir}/amd64*
1451%{_rpmlibdir}/ia32e*
cedf1bfa
PS
1452%{_rpmlibdir}/x86_64*
1453%endif
410dd742 1454# not used yet ... these six depend on perl
ec44785a 1455%attr(755,root,root) %{_rpmlibdir}/http.req
428645e9
JR
1456# we always used scripts provided by mono-devel, maybe move them here
1457#%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1458#%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
37e965e8 1459
70f8787d 1460%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 1461# must be here for "Requires: rpm-*prov" to work
df50421f
JR
1462%{_rpmlibdir}/macros.d/cmake
1463%{_rpmlibdir}/macros.d/gstreamer
77fcdbf7 1464%{_rpmlibdir}/macros.d/java
df50421f 1465%{_rpmlibdir}/macros.d/kernel
77fcdbf7
AF
1466%{_rpmlibdir}/macros.d/libtool
1467%{_rpmlibdir}/macros.d/mono
1468%{_rpmlibdir}/macros.d/perl
1469%{_rpmlibdir}/macros.d/php
1470%{_rpmlibdir}/macros.d/pkgconfig
1471%{_rpmlibdir}/macros.d/python
df50421f 1472%{_rpmlibdir}/macros.d/ruby
77fcdbf7 1473%{_rpmlibdir}/macros.d/selinux
df50421f 1474%{_rpmlibdir}/macros.d/tcl
77fcdbf7 1475%{_rpmlibdir}/macros.rpmbuild
9776a251
JR
1476# compat wrappers
1477%{_rpmlibdir}/macros.gstreamer
1478%{_rpmlibdir}/macros.java
1479%{_rpmlibdir}/macros.mono
1480%{_rpmlibdir}/macros.perl
1481%{_rpmlibdir}/macros.php
1482%{_rpmlibdir}/macros.python
77fcdbf7 1483
df50421f 1484%attr(755,root,root) %{_rpmlibdir}/check-multiarch-files
df50421f
JR
1485%attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1486%attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1487%attr(755,root,root) %{_rpmlibdir}/mkmultiarch
df50421f 1488
874f4c9a 1489%attr(755,root,root) %{_bindir}/gendiff
df50421f 1490%attr(755,root,root) %{_bindir}/multiarch-platform
874f4c9a 1491%attr(755,root,root) %{_bindir}/rpmbuild
ec44785a
BZ
1492
1493%dir %{_rpmlibdir}/helpers
1494%attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
874f4c9a 1495
a00926bc 1496%{_mandir}/man1/gendiff.1*
874f4c9a 1497%{_mandir}/man8/rpmbuild.8*
fefe9d30
JB
1498%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1499%lang(pl) %{_mandir}/pl/man1/gendiff.1*
1500%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
f3fe287f 1501
7d8492bb
JB
1502%files javaprov
1503%defattr(644,root,root,755)
1504%attr(755,root,root) %{_rpmlibdir}/java-find-requires
1505# needs jar (any jdk), jcf-dump (gcc-java) to work
1506%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1507
ec49e9fb
ER
1508%files rubyprov
1509%defattr(644,root,root,755)
1510%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1511%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1512
89334051
AF
1513%files perlprov
1514%defattr(644,root,root,755)
d755a548 1515%attr(755,root,root) %{_rpmlibdir}/perl.*
ec44785a
BZ
1516%attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1517%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
9805fd6d 1518
80d3b868 1519%files pythonprov
d8fcb9b0 1520%defattr(644,root,root,755)
bdbae303 1521%attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
25d296e1 1522%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
09bb810c 1523
d36cb682
PG
1524%files php-pearprov
1525%defattr(644,root,root,755)
d755a548
JK
1526%attr(755,root,root) %{_rpmlibdir}/php*
1527%attr(755,root,root) %{_rpmlibdir}/find-php*
d36cb682 1528
50dc9ac0 1529%if %{with python}
cf6faebc 1530%files -n python-rpm
42a0025c 1531%defattr(644,root,root,755)
b33910fe 1532%dir %{py_sitedir}/rpm
6f18cdb7 1533%attr(755,root,root) %{py_sitedir}/rpm/*.so
8c99b39a 1534%{py_sitedir}/rpm/*.py[co]
50dc9ac0 1535%endif
5c2ab5c7
AM
1536
1537%if %{with apidocs}
1538%files apidocs
1539%defattr(644,root,root,755)
1540%doc apidocs
1541%endif
This page took 1.159909 seconds and 4 git commands to generate.