]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- hrmib is not supported by rpm4, don't pretend it is
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
c296fee0 3# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 4#
89427592 5# Conditional build:
0a1ccab0 6%bcond_without apidocs # don't generate documentation with doxygen
f9d0e5f6 7%bcond_without python3 # don't build python bindings
b0333243 8%bcond_without plugins # build plugins
af0cc499 9%bcond_without recommends_tags # build without Recommends tag (bootstrapping)
85c29998 10%bcond_with imaevm # build with IMA/EVM support (requires libimaevm from ima-evm-utils)
858aa7d0 11
6f068494
JR
12%define db_ver 5.3.28.0
13%define popt_ver 1.15
24b1f498 14%define sover 9.1.0
fc60c9f3 15
7bf81d56
JR
16%if "%{_rpmversion}" >= "4.12" && "%{_rpmversion}" < "5"
17%define with_recommends_tags 1
18%endif
8a4b67ac 19
e5f02e49 20Summary: RPM Package Manager
4ea2ed33
ER
21Summary(de.UTF-8): RPM Packet-Manager
22Summary(es.UTF-8): Gestor de paquetes RPM
23Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
24Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
25Summary(ru.UTF-8): Менеджер пакетов от RPM
26Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 27Name: rpm
24b1f498 28Version: 4.16.0
2aa7d974 29Release: 0.7
9fe07969 30Epoch: 1
98d9fc8e 31License: GPL v2 / LGPL v2.1
76214164 32Group: Base
24b1f498
JR
33Source0: http://ftp.rpm.org/releases/rpm-4.16.x/%{name}-%{version}.tar.bz2
34# Source0-md5: 434e166a812e35ef181f6dd176326920
faba01eb
JR
35Source1: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
36# Source1-md5: 23914bb49fafe7153cee87126d966461
37Source2: macros.local
38Source3: macros.lang
39Source4: %{name}.sysconfig
40Source5: %{name}.groups
80b8a1f9 41Source6: %{name}-groups-po.awk
faba01eb 42Source7: %{name}-install-tree
faba01eb 43Source9: %{name}-user_group.sh
a4b7ef27 44# http://svn.pld-linux.org/banner.sh/
faba01eb 45Source10: banner.sh
b2d6b731
JR
46Source11: %{name}.noautoprov
47Source12: %{name}.noautoprovfiles
48Source13: %{name}.noautoreq
49Source14: %{name}.noautoreqfiles
50Source15: perl.prov
51Source16: %{name}db_checkversion.c
52Source17: %{name}db_reset.c
53Source18: dbupgrade.sh
af0cc499
JR
54Patch0: %{name}-man_pl.patch
55Patch1: %{name}-popt-aliases.patch
56Patch2: %{name}-perl-macros.patch
57Patch3: %{name}-perl-req-perlfile.patch
58Patch4: %{name}-scripts-closefds.patch
cbab0cbf
JR
59Patch6: %{name}-perl_req-INC_dirs.patch
60Patch7: %{name}-debuginfo.patch
61Patch8: %{name}-libtool-deps.patch
62Patch9: %{name}-builddir-readlink.patch
63Patch10: %{name}-changelog_order_check_nonfatal.patch
64Patch11: %{name}-postun-nofail.patch
65Patch12: %{name}-clean-docdir.patch
66Patch13: %{name}-perl-magic.patch
67Patch14: %{name}-ignore-missing-macro-files.patch
68Patch15: x32.patch
b2d6b731
JR
69Patch16: rpm5-db-compat.patch
70Patch17: python-internal-build.patch
5570f8e6 71Patch18: rpmversion.patch
837ad262 72Patch19: pkgconfig.patch
f16801b5 73Patch20: uname-deps.patch
7f5abfc0 74Patch21: aarch64.patch
5c979c25 75Patch22: ix86-platforms.patch
d727501f 76Patch23: shortcircuited-deps.patch
2aa7d974
JR
77Patch24: cpuinfo-deps.patch
78Patch25: rpmio-read-proc-files.patch
681ee2f6 79URL: https://rpm.org/
ee163f1b 80BuildRequires: acl-devel
6f068494 81BuildRequires: db-devel >= %{db_ver}
29855fc2 82BuildRequires: autoconf >= 2.63
644d8958 83BuildRequires: automake >= 1.4
33be5db0 84BuildRequires: bzip2-devel >= 1.0.2-17
33be5db0 85BuildRequires: elfutils-devel >= 0.108
3e70c06e 86BuildRequires: gettext-tools >= 0.19.2
af0cc499 87BuildRequires: libarchive-devel
ee163f1b 88BuildRequires: libcap-devel
241257bf 89BuildRequires: libmagic-devel
0d108dc8 90BuildRequires: libgcrypt-devel
b0333243
JR
91%if %{with plugins}
92BuildRequires: audit-libs-devel
93BuildRequires: dbus-devel
85c29998 94%{?with_imaevm:BuildRequires: libimaevm-devel >= 1.0}
6e115b23 95BuildRequires: libselinux-devel >= 2.1.0
6e115b23 96%endif
84cdee7a
JB
97# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
98BuildRequires: libstdc++-devel
b60c74c3 99BuildRequires: libtool >= 1:1.4.2-9
127a0b3c 100BuildRequires: ossp-uuid-devel
7973b351 101BuildRequires: patch >= 2.2
ae228405 102BuildRequires: pkgconfig(lua) >= 5.1
6f068494 103BuildRequires: popt-devel >= %{popt_ver}
85c29998
JR
104BuildRequires: python3-modules
105%if %{with python3}
106BuildRequires: python3-devel
f9d0e5f6 107BuildRequires: rpm-pythonprov
3d169da3 108BuildRequires: rpmbuild(macros) >= 1.750
f9d0e5f6 109%endif
85c29998 110BuildRequires: sqlite3-devel >= 3.22.0
e56a10a9 111BuildRequires: tcl
77fcdbf7 112BuildRequires: xz-devel
3acb62f3 113BuildRequires: zlib-devel
34865f27 114BuildRequires: zstd-devel
5c2ab5c7
AM
115%if %{with apidocs}
116BuildRequires: doxygen
117BuildRequires: ghostscript
118BuildRequires: graphviz
119BuildRequires: tetex-pdftex
120%endif
d25ec6ea 121Requires(posttrans): coreutils
9fe07969
JR
122Requires: %{name}-base = %{epoch}:%{version}-%{release}
123Requires: %{name}-lib = %{epoch}:%{version}-%{release}
3de8e4a9 124Requires: rpm-pld-macros >= 1.744
d1f5e279 125Requires: FHS >= 3.0-2
0d108dc8 126Requires: libgcrypt
6f068494 127Requires: popt >= %{popt_ver}
b0333243
JR
128%if %{with recommends_tags}
129Recommends: rpm-plugin-audit
130Recommends: rpm-plugin-prioreset
131Recommends: rpm-plugin-syslog
132Recommends: rpm-plugin-systemd-inhibit
133%endif
d1f5e279 134Obsoletes: rpm-utils-perl
f57f030d 135Obsoletes: rpm-utils-static
874f4c9a 136Conflicts: glibc < 2.2.92
8ee1c72c
AM
137# db4.6 poldek needed
138Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
139# segfaults with lzma 0.42.2
140Conflicts: lzma-libs < 4.999.3
e4084afd 141Conflicts: util-vserver < 0.30.216-1.pre3034.7
1d49ffbc 142BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 143
4adb7d05 144%define _binary_payload w9.gzdio
6d82b332 145
4cd84746 146# don't require very fresh rpm.macros to build
950eead3 147%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
af0cc499 148%define ix86 i386 i486 i586 i686 athlon geode pentium3 pentium4
80e9f34d 149%define ppc ppc ppc7400 ppc7450
9f517079 150%define x8664 amd64 ia32e x86_64
4cd84746 151
d755a548
JK
152%define _rpmlibdir /usr/lib/rpm
153
ff7bc1e6 154%description
155RPM is a powerful package manager, which can be used to build,
156install, query, verify, update, and uninstall individual software
cf6faebc 157packages. A package consists of an archive of files, and package
fed73700 158information, including name, version, and description.
159
dd85fadc
JR
160%description -l de.UTF-8
161RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 162Installation, Anfrage, Verifizierung, Aktualisierung und
163Uninstallation individueller Softwarepakete. Ein Paket besteht aus
164einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 165Beschreibung.
166
dd85fadc 167%description -l es.UTF-8
313a4d1a 168RPM es un poderoso administrador de paquetes, que puede ser usado para
169construir, instalar, pesquisar, verificar, actualizar y desinstalar
170paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
171almacenaje de archivos, y información sobre el paquete, incluyendo
172nombre, versión y descripción.
173
174%description -l pl.UTF-8
175RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
176przebudowanie, instalację czy weryfikację dowolnego pakietu.
177Informacje dotyczące każdego pakietu, takie jak jego opis, lista
178plików wchodzących w skład pakietu, zależności od innych pakietów, są
179przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 180odpytywania programu rpm.
181
dd85fadc
JR
182%description -l pt_BR.UTF-8
183RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 184construir, instalar, pesquisar, verificar, atualizar e desinstalar
185pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
186arquivos e informações adicionais, incluindo nome, versão e descrição
187do pacote, permissões dos arquivos, etc.
188
189%description -l ru.UTF-8
190RPM - это мощный менеджер пакетов, который может быть использован для
191создания, инсталляции, запросов (query), проверки, обновления и
192удаления программных пакетов. Пакет состоит из файлового архива и
193служебной информации, включающей название, версию, описание и другие
194данные о пакете.
195
196%description -l uk.UTF-8
197RPM - це потужний менеджер пакетів, що може бути використаний для
198створення, інсталяції, запитів (query), перевірки, поновлення та
199видалення програмних пакетів. Пакет складається з файлового архіву та
200службової інформації, що містить назву, версію, опис та іншу
201інформацію про пакет.
7c6dc55f 202
66edd895
JB
203%package base
204Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 205Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 206Group: Base
1d9ca0c1 207Requires: filesystem
950eead3 208Obsoletes: rpm-scripts
66edd895
JB
209Obsoletes: vserver-rpm
210
211%description base
212The RPM base package contains scripts used by rpm packages themselves.
213These include:
214- scripts for adding/removing groups and users needed for rpm
215 packages,
216- banner.sh to display %%banner messages from rpm scriptlets.
217
dd85fadc
JR
218%description base -l pl.UTF-8
219Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 220Zawiera on:
dd85fadc
JR
221- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
222- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 223
69131f1a
JB
224%package lib
225Summary: RPMs library
4ea2ed33 226Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 227Group: Libraries
6f068494 228Requires: db >= %{db_ver}
241257bf 229Requires: libmagic >= 1.15-2
6f068494 230Requires: popt >= %{popt_ver}
d1795eb0 231Obsoletes: rpm-libs
69131f1a
JB
232# avoid SEGV caused by mixed db versions
233Conflicts: poldek < 0.18.1-16
234
235%description lib
236RPMs library.
237
dd85fadc 238%description lib -l pl.UTF-8
69131f1a
JB
239Biblioteki RPM-a.
240
fed73700 241%package devel
3f2d796a 242Summary: Header files for rpm libraries
4ea2ed33
ER
243Summary(de.UTF-8): Header-Dateien für rpm Libraries
244Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
245Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
246Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
247Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
248Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 249Group: Development/Libraries
9fe07969 250Requires: %{name}-lib = %{epoch}:%{version}-%{release}
fea3cb89 251Requires: bzip2-devel
24b1f498 252Requires: db-devel >= %{db_ver}
5c583f90 253Requires: elfutils-devel
241257bf 254Requires: libmagic-devel
0d108dc8 255Requires: libgcrypt-devel
c7b2d5f9
KK
256%if %{with selinux}
257Requires: libselinux-devel
258Requires: libsemanage-devel
259Requires: libsepol-devel
260%endif
6f068494 261Requires: popt-devel >= %{popt_ver}
fea3cb89 262Requires: zlib-devel
cf6faebc 263
264%description devel
3f2d796a
JB
265The RPM packaging system includes C libraries that make it easy to
266manipulate RPM packages and databases. They are intended to ease the
cf6faebc 267creation of graphical package managers and other tools that need
3f2d796a
JB
268intimate knowledge of RPM packages. This package contains header files
269for these libraries.
fed73700 270
dd85fadc
JR
271%description devel -l de.UTF-8
272Der RPM-Packensystem enthält eine C-Library, die macht es einfach
273RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 274Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 275Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
276
dd85fadc 277%description devel -l es.UTF-8
313a4d1a 278El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
279fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
280facilitar la creación de administradores gráficos de paquetes y otras
20f89981 281herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 282
dd85fadc
JR
283%description devel -l pl.UTF-8
284System RPM zawiera biblioteki C, które ułatwiają manipulowanie
285pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
286graficznych programów zarządzających pakietami oraz innych narzędzi,
287które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
288zawiera pliki nagłówkowe wspomnianych bibliotek.
289
290%description devel -l pt_BR.UTF-8
291O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
292a manipulação de pacotes e bases de dados RPM. Seu objetivo é
293facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 294ferramentas que precisem de conhecimento profundo de pacotes RPM.
295
dd85fadc
JR
296%description devel -l ru.UTF-8
297Система управления пакетами RPM содержит библиотеку C, которая
298упрощает манипуляцию пакетами RPM и соответствующими базами данных.
299Эта библиотека предназначена для облегчения создания графических
300пакетных менеджеров и других утилит, которым необходимо работать с
301пакетами RPM.
7c6dc55f 302
dd85fadc
JR
303%description devel -l uk.UTF-8
304Система керування пакетами RPM містить бібліотеку C, котра спрощує
305роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
306призначена для полегшення створення графічних пакетних менеджерів та
307інших утиліт, що працюють з пакетами RPM.
7c6dc55f 308
fed73700 309%package utils
8482995c 310Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
311Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
312Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 313Group: Applications/File
9fe07969 314Requires: %{name} = %{epoch}:%{version}-%{release}
6f068494 315Requires: popt >= %{popt_ver}
af0cc499
JR
316%if %{with recommends_tags}
317Recommends: bzip2
318Recommends: gzip
86b85368 319%endif
695e60ad 320Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 321
322%description utils
8482995c 323Additional utilities for managing RPM packages and database.
fed73700 324
dd85fadc
JR
325%description utils -l de.UTF-8
326Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 327
dd85fadc
JR
328%description utils -l pl.UTF-8
329Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 330
fed73700 331%package build
e191287c 332Summary: Scripts for building binary RPM packages
4ea2ed33
ER
333Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
334Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
335Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
336Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
337Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 338Group: Applications/File
f15ca8ca
ER
339Requires(pretrans): coreutils
340Requires(pretrans): findutils
9fe07969 341Requires: %{name}-utils = %{epoch}:%{version}-%{release}
3de8e4a9 342Requires: rpm-pld-macros-build >= 1.744
e191287c 343Requires: /bin/id
344Requires: awk
cfa7898a 345Requires: bzip2
e950a6d7 346Requires: chrpath >= 0.10-4
b6547e10 347Requires: cpio
e191287c 348Requires: diffutils
195f647c 349Requires: elfutils
583135b4 350Requires: file >= 4.17
e191287c 351Requires: fileutils
352Requires: findutils
950eead3
ER
353%ifarch athlon
354Requires: gcc >= 3.0.3
355%else
356Requires: gcc
357%endif
e191287c 358Requires: glibc-devel
359Requires: grep
360Requires: gzip
361Requires: make
362Requires: patch
adbd4815 363Requires: sed >= 4.0
e191287c 364Requires: sh-utils
adbd4815 365Requires: tar >= 1:1.22
e191287c 366Requires: textutils
3acb62f3 367Requires: which
adbd4815 368Requires: xz
37ea389a 369Provides: rpmbuild(noauto) = 3
02d17bf9 370%ifarch %{x8664}
195f647c
JB
371Conflicts: automake < 1:1.7.9-2
372Conflicts: libtool < 2:1.5-13
373%endif
0096c5cd 374
e2025ad1 375%description build
58399c37 376Scripts for building binary RPM packages.
fed73700 377
dd85fadc
JR
378%description build -l de.UTF-8
379Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 380
dd85fadc
JR
381%description build -l pl.UTF-8
382Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 383
dd85fadc
JR
384%description build -l pt_BR.UTF-8
385Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 386construir pacotes usando o RPM.
e73478cd 387
dd85fadc
JR
388%description build -l ru.UTF-8
389Различные вспомогательные скрипты и исполняемые программы, которые
390используются для сборки RPM'ов.
7c6dc55f 391
dd85fadc
JR
392%description build -l uk.UTF-8
393Різноманітні допоміжні скрипти та утиліти, які використовуються для
394побудови RPM'ів.
7c6dc55f 395
69131f1a 396%package perlprov
8482995c 397Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 398Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 399Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a 400Group: Applications/File
9fe07969 401Requires: %{name} = %{epoch}:%{version}-%{release}
b82853ee 402Requires: perl-Encode
69131f1a
JB
403Requires: perl-devel
404Requires: perl-modules
405
406%description perlprov
8482995c 407Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
408packages.
409
dd85fadc
JR
410%description perlprov -l de.UTF-8
411Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 412
dd85fadc 413%description perlprov -l pl.UTF-8
8482995c
JB
414Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
415pakietach RPM.
69131f1a
JB
416
417%package pythonprov
8482995c
JB
418Summary: Python macros, which simplifies creation of RPM packages with Python software
419Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a 420Group: Applications/File
9fe07969 421Requires: %{name} = %{epoch}:%{version}-%{release}
85c29998
JR
422Requires: python3
423Requires: python3-modules
424Requires: python3-setuptools
69131f1a
JB
425
426%description pythonprov
8482995c 427Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
428software.
429
dd85fadc 430%description pythonprov -l pl.UTF-8
8482995c 431Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
432Pythonie.
433
f9d0e5f6
JR
434%package -n python3-rpm
435Summary: Python 3 interface to RPM library
436Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki RPM-a
437Summary(pt_BR.UTF-8): Módulo Python 3 para aplicativos que manipulam pacotes RPM
438Group: Development/Languages/Python
9fe07969 439Requires: %{name} = %{epoch}:%{version}-%{release}
f9d0e5f6 440Requires: python3
85c29998
JR
441Obsoletes: python-rpm < 1:4.16.0
442Obsoletes: rpm-python
f9d0e5f6
JR
443
444%description -n python3-rpm
445The python3-rpm package contains a module which permits applications
446written in the Python 3 programming language to use the interface
447supplied by RPM (RPM Package Manager) libraries.
448
449This package should be installed if you want to develop Python 3
450programs that will manipulate RPM packages and databases.
451
452%description -n python3-rpm -l pl.UTF-8
453Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
24b1f498
JR
454Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki
455RPM-a.
f9d0e5f6
JR
456
457Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
458Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
459
460%description -n python3-rpm -l pt_BR.UTF-8
461O pacote python3-rpm contém um módulo que permite que aplicações
462escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
463RPM (RPM Package Manager).
464
465Esse pacote deve ser instalado se você quiser desenvolver programas em
466Python 3 para manipular pacotes e bancos de dados RPM.
467
b0333243
JR
468%package plugin-audit
469Summary: Plugin for logging audit events on package operations
24b1f498 470Group: Base
9fe07969 471Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
472
473%description plugin-audit
474Plugin for libaudit support
475
476%package plugin-syslog
477Summary: Plugin for syslog functionality
24b1f498 478Group: Base
9fe07969 479Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
480
481%description plugin-syslog
482This plugin exports RPM actions to the system log.
483
484%package plugin-systemd-inhibit
485Summary: Plugin for systemd inhibit functionality
24b1f498 486Group: Base
9fe07969 487Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
488
489%description plugin-systemd-inhibit
490This plugin blocks systemd from entering idle, sleep or shutdown while
491an rpm transaction is running using the systemd-inhibit mechanism.
492
493%package plugin-ima
494Summary: Plugin for IMA file signatures
495Group: Base
9fe07969 496Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
497
498%description plugin-ima
499This plugin adds support for enforcing and verifying IMA file
500signatures in an rpm.
501
502%package plugin-prioreset
503Summary: Plugin for resetting scriptlet priorities for SysV init
504Group: Base
9fe07969 505Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
506
507%description plugin-prioreset
508This plugin is useful on legacy SysV init systems if you run rpm
509transactions with nice/ionice priorities. Should not be used on
510systemd systems.
511
512%package plugin-selinux
513Summary: Plugin for SELinux functionality
8191f3c5 514Group: Base
9fe07969 515Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
516Requires: libselinux >= 2.1.0
517
518%description plugin-selinux
519Plugin for SELinux functionality.
520
8191f3c5
JR
521%package sign
522Summary: Package signing support
523Group: Base
9fe07969 524Requires: %{name}-lib = %{epoch}:%{version}-%{release}
8191f3c5
JR
525
526%description sign
527This package contains support for digitally signing RPM packages.
528
5c2ab5c7
AM
529%package apidocs
530Summary: RPM API documentation and guides
531Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
532Group: Documentation
d308de4c 533BuildArch: noarch
5c2ab5c7
AM
534
535%description apidocs
536Documentation for RPM API and guides in HTML format generated from rpm
537sources by doxygen.
538
539%description apidocs -l pl.UTF-8
540Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
541źrodeł RPM-a przez doxygen.
542
e2025ad1 543%prep
c546a4d6 544%setup -q -n %{name}-%{version}%{?subver}
af0cc499 545%patch0 -p1
2f0ee4ec 546%patch1 -p1
4d5b8e4c 547%patch2 -p1
af0cc499 548%patch3 -p1
7a3b1f24 549%patch4 -p1
cbab0cbf
JR
550%patch6 -p0
551%patch7 -p1
af0cc499 552%patch8 -p1
cbab0cbf 553%patch9 -p1
af0cc499
JR
554%patch10 -p1
555%patch11 -p1
556%patch12 -p1
557%patch13 -p1
558%patch14 -p1
7033e976 559%patch15 -p1
af0cc499
JR
560%patch16 -p1
561%patch17 -p1
5570f8e6 562%patch18 -p1
837ad262 563%patch19 -p1
f16801b5 564%patch20 -p1
7f5abfc0 565%patch21 -p1
5c979c25 566%patch22 -p1
de65aff6 567%patch23 -p1
2aa7d974
JR
568%patch24 -p1
569%patch25 -p1
883e0fac 570
b2d6b731 571install %{SOURCE15} scripts/perl.prov.in
08697680 572
70f8787d 573%{__mv} -f scripts/perl.req{,.in}
633d1e9e 574
cd86db2e 575# generate Group translations to *.po
faba01eb 576awk -f %{SOURCE6} %{SOURCE5}
fefe9d30 577
b2d6b731
JR
578install %{SOURCE16} tools/rpmdb_checkversion.c
579install %{SOURCE17} tools/rpmdb_reset.c
91ee86a9 580
24b1f498 581%{__sed} -i -e '1s,/usr/bin/python,%{__python3},' scripts/pythondistdeps.py
40675133 582
87ef0d95 583%build
ea816ea6 584%{__libtoolize}
ceaaacee 585%{__aclocal}
4cd84746 586%{__autoheader}
7a9d72ce 587%{__autoconf}
7a9d72ce 588%{__automake}
7a9d72ce 589
048d06f8
JR
590# rpm checks for CPU type at runtime, but it looks better
591sed -i \
592 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
593 -e 's|@host_cpu@|%{_target_cpu}|' \
594 -e 's|@host_os@|%{_target_os}|' \
fb35e2d9 595 macros.in
048d06f8 596
624f96ff 597%configure \
01d7a578 598 WITH_PERL_VERSION=no \
bba1059c 599 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
dcf91c25 600 __GPG=%{_bindir}/gpg \
85c29998
JR
601%if %{with python3}
602 PYTHON=python3 \
603 --enable-python \
604%endif
3a3e476f 605 --disable-silent-rules \
cd86db2e 606 --enable-shared \
34865f27 607 --enable-bdb \
8fa0ac2f 608 --enable-bdb-ro \
85c29998
JR
609 --enable-ndb \
610 --enable-sqlite \
af0cc499 611 --enable-zstd \
c38bf1df 612 --with-lua \
85c29998 613 %{?with_imaevm:--with-imaevm} \
34865f27
JR
614 --with-cap \
615 --with-acl \
616 --with-audit \
af0cc499 617 --with-archive \
b0333243
JR
618 --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
619 %{!?with_plugins:--disable-plugins} \
34865f27
JR
620 --with-vendor=pld
621
5c767dc1 622%{__make}
5c2ab5c7 623
6f068494
JR
624%{__cc} %{rpmcflags} tools/rpmdb_checkversion.c -o tools/rpmdb_checkversion -ldb
625%{__cc} %{rpmcflags} tools/rpmdb_reset.c -o tools/rpmdb_reset -ldb
fb95de52
JR
626
627if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
628 echo "Error linking rpmdb tools!"
629 exit 1
630fi
8e8746c0
JR
631if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
632 echo "Error linking rpmdb tools!"
633 exit 1
634fi
91ee86a9 635
f9d0e5f6
JR
636%if %{with python3}
637cd python
638%py3_build
639%endif
640
b064b8e6 641%install
ff7bc1e6 642rm -rf $RPM_BUILD_ROOT
d1f5e279 643install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
dbbb9b40 644 $RPM_BUILD_ROOT/var/lib/{banner,rpm}
54eb1770 645
faba01eb 646cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 647
d1f5e279 648%{__make} install \
241257bf
AM
649 pkgconfigdir=%{_pkgconfigdir} \
650 DESTDIR=$RPM_BUILD_ROOT
718426e1 651
c546a4d6 652# cleanup
c2683840 653%ifnarch %{ix86} %{x8664} x32
2f409bb7 654rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
34865f27 655rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
2f409bb7
JR
656rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
657rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
658rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
659rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
660rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
661rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
25ac75ae
AM
662%endif
663
c2683840 664%ifnarch %{x8664} x32
2f409bb7
JR
665rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
666rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
667rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
668rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
25ac75ae
AM
669%endif
670
c546a4d6 671%ifnarch %{ppc}
34865f27
JR
672rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
673rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
674rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
675rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
676rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
2f409bb7 677rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
34865f27 678rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
25ac75ae
AM
679%endif
680
7f5abfc0 681%ifnarch aarch64
34865f27 682rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
7f5abfc0
JP
683%endif
684
2f409bb7
JR
685rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
686rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
687rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
688rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
34865f27 689rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
2f409bb7 690rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
34865f27 691rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
2f409bb7 692rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
c546a4d6 693
0727c61e
JR
694cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
695%ifarch x32
696%{_target_cpu}-%{_target_vendor}-linux-gnux32
697%else
698%{_target_cpu}-%{_target_vendor}-linux
699%endif
700EOF
701
3a3e476f 702%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
644d8958 703
396a7387 704install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
396a7387 705
faba01eb
JR
706cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
707cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
faba01eb 708cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 709
faba01eb 710cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 711
faba01eb
JR
712cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
713cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
b2d6b731
JR
714cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
715cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
716cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
717cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 718
f9d0e5f6
JR
719cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
720cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
b2d6b731 721cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
9776a251 722
950eead3 723# move rpm to /bin
8191f3c5
JR
724%{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
725ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
726ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
727
950eead3 728# move essential libs to /lib (libs that /bin/rpm links to)
40675133
JR
729for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
730 mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
731 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
c2673e18
AF
732done
733
7d12560f
JR
734#./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
735
85c29998
JR
736# Make sure we have bdb set a default backend
737grep -qE "db_backend[[:blank:]]+bdb" $RPM_BUILD_ROOT%{_rpmlibdir}/macros
6f18cdb7 738
f9d0e5f6
JR
739%if %{with python3}
740# Remove anything that rpm make install might put there
741%{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
742cd python
743%py3_install
744cd ..
dae5e1a8 745%endif
01d7a578 746
d1f5e279
JR
747%{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
748
01d7a578 749# wrong location, not used anyway
2f409bb7 750%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
01d7a578 751
90b03dd6 752%find_lang %{name}
cf6faebc 753
13eb5ebf 754%clean
d7df46b8 755rm -rf $RPM_BUILD_ROOT
76214164 756
be4d3036 757%posttrans
d25ec6ea 758if [ -e /var/lib/rpm/Packages ] && \
f9d0e5f6 759 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
d25ec6ea 760 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
6a934782 761 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 762 echo
e4dd6a34 763 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
764 echo
765 fi
3ca91ccd
JR
766 echo
767 echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
768 echo 'you should ignore it and restart poldek'
769 echo
f9d0e5f6 770 %{_rpmlibdir}/dbupgrade.sh
be4d3036 771fi
f7779567 772
ceaaacee
JB
773%post lib -p /sbin/ldconfig
774%postun lib -p /sbin/ldconfig
76214164 775
37a5a2fc 776%pretrans build
d755a548 777find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 778
3684d90f
JB
779%files -f %{name}.lang
780%defattr(644,root,root,755)
d1f5e279 781%doc ChangeLog CREDITS README
3684d90f 782
3acb62f3
ER
783%dir /etc/pki/rpm-gpg
784/etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
54eb1770 785
7a9d72ce 786%attr(755,root,root) /bin/rpm
8191f3c5
JR
787%attr(755,root,root) %{_bindir}/rpmdb
788%attr(755,root,root) %{_bindir}/rpmkeys
789%attr(755,root,root) %{_bindir}/rpmquery
790%attr(755,root,root) %{_bindir}/rpmverify
e73478cd 791
66edd895 792%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 793%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
0727c61e
JR
794# this is ok to be replaced
795%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
caf453d4 796
09bb810c 797%{_mandir}/man8/rpm.8*
8191f3c5
JR
798%{_mandir}/man8/rpmdb.8*
799%{_mandir}/man8/rpmkeys.8*
800%{_mandir}/man8/rpm-misc.8*
24b1f498 801%{?with_plugins:%{_mandir}/man8/rpm-plugins.8*}
feb1f12e 802%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 803%lang(ja) %{_mandir}/ja/man8/rpm.8*
d1f5e279 804%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 805%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 806%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 807%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 808
7d12560f 809%dir /var/lib/rpm
4acac5de 810
d755a548 811%{_rpmlibdir}/rpmpopt*
8191f3c5 812%{_rpmlibdir}/rpmrc
d755a548 813%{_rpmlibdir}/macros
08697680 814%dir %{_rpmlibdir}/macros.d
e8836e1f 815%dir %{_rpmlibdir}/platform
40675133 816%{_rpmlibdir}/platform/noarch-*
c2683840 817%ifarch %{ix86} %{x8664} x32
34865f27
JR
818%{_rpmlibdir}/platform/athlon*
819%{_rpmlibdir}/platform/geode*
40675133
JR
820%{_rpmlibdir}/platform/i?86*
821%{_rpmlibdir}/platform/pentium*
34865f27
JR
822%endif
823%ifarch %{x8664} x32
824%{_rpmlibdir}/platform/amd64*
825%{_rpmlibdir}/platform/ia32e*
826%{_rpmlibdir}/platform/x86_64*
83a0601a 827%{_rpmlibdir}/platform/x32*
e23edf35
JR
828%endif
829%ifarch alpha
40675133 830%{_rpmlibdir}/platform/alpha*
e23edf35 831%endif
7f5abfc0
JP
832%ifarch aarch64
833%{_rpmlibdir}/platform/aarch64*
834%endif
e23edf35 835%ifarch ia64
40675133 836%{_rpmlibdir}/platform/ia64*
e23edf35
JR
837%endif
838%ifarch mips mipsel mips64 mips64el
40675133 839%{_rpmlibdir}/platform/mips*
e23edf35
JR
840%endif
841%ifarch %{ppc}
40675133 842%{_rpmlibdir}/platform/ppc*
e23edf35
JR
843%endif
844%ifarch sparc sparc64
40675133 845%{_rpmlibdir}/platform/sparc*
e23edf35 846%endif
3684d90f 847
3de8e4a9 848%dir %{_rpmlibdir}/pld
396a7387 849
f9d0e5f6
JR
850%attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
851%attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
852%attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
24b1f498
JR
853%attr(755,root,root) %{_rpmlibdir}/rpmdb_dump
854%attr(755,root,root) %{_rpmlibdir}/rpmdb_load
df50421f 855
7d12560f
JR
856# valgrind suppression file for rpm
857%{_rpmlibdir}/rpm.supp
858
66edd895
JB
859%files base
860%defattr(644,root,root,755)
492a2bd4 861%dir %{_sysconfdir}/rpm
66edd895
JB
862%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
863%dir %{_rpmlibdir}
864%attr(755,root,root) %{_bindir}/banner.sh
865%attr(755,root,root) %{_rpmlibdir}/user_group.sh
866%dir /var/lib/banner
867
874f4c9a
MM
868%files lib
869%defattr(644,root,root,755)
40675133
JR
870%attr(755,root,root) /%{_lib}/librpm.so.9
871%attr(755,root,root) /%{_lib}/librpm.so.%{sover}
872%attr(755,root,root) /%{_lib}/librpmbuild.so.9
873%attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
874%attr(755,root,root) /%{_lib}/librpmio.so.9
875%attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
876%attr(755,root,root) /%{_lib}/librpmsign.so.9
877%attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
b0333243 878%{?with_plugins:%dir %{_libdir}/rpm-plugins}
874f4c9a 879
69131f1a
JB
880%files devel
881%defattr(644,root,root,755)
69131f1a 882%attr(755,root,root) %{_libdir}/librpm.so
950eead3 883%attr(755,root,root) %{_libdir}/librpmbuild.so
69131f1a 884%attr(755,root,root) %{_libdir}/librpmio.so
40675133 885%attr(755,root,root) %{_libdir}/librpmsign.so
950eead3
ER
886%{_libdir}/librpm*.la
887%{_includedir}/rpm
888%{_pkgconfigdir}/*.pc
69131f1a 889
69131f1a
JB
890%files utils
891%defattr(644,root,root,755)
d1f5e279 892%attr(755,root,root) %{_bindir}/rpm2archive
69131f1a 893%attr(755,root,root) %{_bindir}/rpm2cpio
fc36dfd5 894%attr(755,root,root) %{_bindir}/rpmgraph
d1f5e279 895%attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
69131f1a 896%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
25e974c7 897%attr(755,root,root) %{_rpmlibdir}/tgpg
d1f5e279
JR
898%attr(755,root,root) %{_rpmlibdir}/debugedit
899%attr(755,root,root) %{_rpmlibdir}/rpmdeps
24b1f498 900%{_mandir}/man8/rpm2archive.8*
69131f1a
JB
901%{_mandir}/man8/rpm2cpio.8*
902%{_mandir}/man8/rpmdeps.8*
fc36dfd5 903%{_mandir}/man8/rpmgraph.8*
69131f1a 904%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
d1f5e279 905%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
69131f1a 906%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
69131f1a 907%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
d1f5e279 908%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
fc36dfd5
JR
909%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
910%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
69131f1a 911
3684d90f 912%files build
a45ae6d8 913%defattr(644,root,root,755)
66edd895 914%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
915%attr(755,root,root) %{_rpmlibdir}/brp-*
916%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548 917%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d1f5e279 918%attr(755,root,root) %{_rpmlibdir}/elfdeps
01d7a578
JB
919%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
920# needs hacked pkg-config to return anything
921%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
d1f5e279 922%attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
37e965e8 923
70f8787d 924%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 925# must be here for "Requires: rpm-*prov" to work
40675133
JR
926#%{_rpmlibdir}/macros.d/cmake
927#%{_rpmlibdir}/macros.d/gstreamer
40675133 928#%{_rpmlibdir}/macros.d/libtool
40675133 929#%{_rpmlibdir}/macros.d/perl
40675133
JR
930#%{_rpmlibdir}/macros.d/pkgconfig
931#%{_rpmlibdir}/macros.d/python
40675133
JR
932#%{_rpmlibdir}/macros.d/selinux
933#%{_rpmlibdir}/macros.d/tcl
934#%{_rpmlibdir}/macros.rpmbuild
f9d0e5f6 935
7d12560f
JR
936%attr(755,root,root) %{_rpmlibdir}/check-buildroot
937%attr(755,root,root) %{_rpmlibdir}/check-prereqs
938%attr(755,root,root) %{_rpmlibdir}/check-rpaths
939%attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
7d12560f
JR
940%attr(755,root,root) %{_rpmlibdir}/find-provides
941%attr(755,root,root) %{_rpmlibdir}/find-requires
24b1f498 942%attr(755,root,root) %{_rpmlibdir}/ocamldeps.sh
7d12560f
JR
943%attr(755,root,root) %{_rpmlibdir}/script.req
944%attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
7d12560f 945
f9d0e5f6
JR
946%dir %{_rpmlibdir}/fileattrs
947%{_rpmlibdir}/fileattrs/debuginfo.attr
948%{_rpmlibdir}/fileattrs/desktop.attr
949%{_rpmlibdir}/fileattrs/elf.attr
950%{_rpmlibdir}/fileattrs/font.attr
951%{_rpmlibdir}/fileattrs/libtool.attr
952%{_rpmlibdir}/fileattrs/metainfo.attr
953%{_rpmlibdir}/fileattrs/ocaml.attr
954%{_rpmlibdir}/fileattrs/perl.attr
955%{_rpmlibdir}/fileattrs/perllib.attr
f9d0e5f6
JR
956%{_rpmlibdir}/fileattrs/pkgconfig.attr
957%{_rpmlibdir}/fileattrs/python.attr
958%{_rpmlibdir}/fileattrs/pythondist.attr
959%{_rpmlibdir}/fileattrs/script.attr
77fcdbf7 960
874f4c9a
MM
961%attr(755,root,root) %{_bindir}/gendiff
962%attr(755,root,root) %{_bindir}/rpmbuild
d1f5e279 963%attr(755,root,root) %{_bindir}/rpmspec
874f4c9a 964
a00926bc 965%{_mandir}/man1/gendiff.1*
d1f5e279 966%lang(pl) %{_mandir}/pl/man1/gendiff.1*
874f4c9a 967%{_mandir}/man8/rpmbuild.8*
fefe9d30 968%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
fefe9d30 969%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
d1f5e279 970%{_mandir}/man8/rpmspec.8*
f3fe287f 971
89334051
AF
972%files perlprov
973%defattr(644,root,root,755)
d755a548 974%attr(755,root,root) %{_rpmlibdir}/perl.*
9805fd6d 975
80d3b868 976%files pythonprov
d8fcb9b0 977%defattr(644,root,root,755)
d1f5e279 978%attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
09bb810c 979
f9d0e5f6
JR
980%if %{with python3}
981%files -n python3-rpm
982%defattr(644,root,root,755)
983%dir %{py3_sitedir}/rpm
984%attr(755,root,root) %{py3_sitedir}/rpm/*.so
985%{py3_sitedir}/rpm/*.py
986%{py3_sitedir}/rpm-%{version}-py*.egg-info
987%{py3_sitedir}/rpm/__pycache__
50dc9ac0 988%endif
5c2ab5c7 989
b0333243
JR
990%if %{with plugins}
991%files plugin-audit
992%defattr(644,root,root,755)
993%attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
24b1f498 994%{_mandir}/man8/rpm-plugin-audit.8*
b0333243
JR
995
996%files plugin-syslog
997%defattr(644,root,root,755)
998%attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
24b1f498 999%{_mandir}/man8/rpm-plugin-syslog.8*
b0333243
JR
1000
1001%files plugin-systemd-inhibit
1002%defattr(644,root,root,755)
1003%attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
1004%{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
1005
1006%files plugin-ima
1007%defattr(644,root,root,755)
1008%attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
24b1f498 1009%{_mandir}/man8/rpm-plugin-ima.8*
b0333243
JR
1010
1011%files plugin-prioreset
1012%defattr(644,root,root,755)
1013%attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
24b1f498 1014%{_mandir}/man8/rpm-plugin-prioreset.8*
b0333243
JR
1015
1016%files plugin-selinux
1017%defattr(644,root,root,755)
1018%attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
24b1f498 1019%{_mandir}/man8/rpm-plugin-selinux.8*
b0333243
JR
1020%endif
1021
8191f3c5
JR
1022%files sign
1023%defattr(644,root,root,755)
1024%attr(755,root,root) %{_bindir}/rpmsign
1025%{_mandir}/man8/rpmsign.8*
1026
5c2ab5c7
AM
1027%if %{with apidocs}
1028%files apidocs
1029%defattr(644,root,root,755)
d1f5e279
JR
1030%doc doc/librpm/html/*
1031%endif
This page took 1.202694 seconds and 4 git commands to generate.