]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- ugid.h is installed now
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
644d8958
JB
3# - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
4# matches ELF first
a245b6ce 5# - repackaging when lzma is not installed (todo: fix digest signature of header)
351a0199
JB
6# rpmbuild computes digest when writing package to temporary file, then adds a few
7# tags (incl. digest) and writes whole package to destination file;
8# repackaging uses unchanged "immutable header" image from original rpm, also
9# preserving payload format and compressor from original rpm, _not_ current settings
10abbd40 10#
89427592 11# Conditional build:
01d7a578 12%bcond_with static # build static rpm+rpmi
4af66a2c
JB
13%bcond_without apidocs # don't generate documentation with doxygen
14%bcond_with autoreqdep # autogenerate package name deps in addition to sonames/perl(X)
15%bcond_without python # don't build python bindings
16%bcond_without selinux # build without selinux support
632f1b5c 17%bcond_without system_libmagic # don't use system libmagic
0dc47449 18%bcond_without suggest_tags # build without Suggest tag (bootstrapping)
33be5db0 19%bcond_with neon # build with HTTP/WebDAV support (neon library)
89427592
JB
20# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
21# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
22# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
54bfdf99 23
003a039e 24# versions of required libraries
644d8958
JB
25%define reqdb_ver 4.5.20
26%define reqpopt_ver 1.10.8
33be5db0 27%define beecrypt_ver 2:4.1.2-4
10abbd40 28%define sover 4.4
e5f02e49 29Summary: RPM Package Manager
4ea2ed33
ER
30Summary(de.UTF-8): RPM Packet-Manager
31Summary(es.UTF-8): Gestor de paquetes RPM
32Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
33Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
34Summary(ru.UTF-8): Менеджер пакетов от RPM
35Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 36Name: rpm
4617e0e8
AM
37Version: 4.4.9
38Release: 0.1
9c5bc9ad 39License: GPL
76214164 40Group: Base
4711b7e8 41Source0: ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
4617e0e8 42# Source0-md5: 210b768006e7d88dd8a3bcd498ea27f6
ff7bc1e6 43Source1: %{name}.groups
c2673e18 44Source2: %{name}.platform
ff7bc1e6 45Source3: %{name}-install-tree
80b8a1f9
JB
46Source4: %{name}-find-spec-bcond
47Source5: %{name}-find-lang
48Source6: %{name}-groups-po.awk
49Source7: %{name}-compress-doc
50Source8: %{name}-check-files
51Source9: %{name}-php-provides
52Source10: %{name}-php-requires
fbc0ff35 53Source11: %{name}.sysinfo
80b8a1f9 54Source12: perl.prov
d0370fe5 55Source13: %{name}-user_group.sh
56Source14: %{name}.sysconfig
1f625675
JB
57Source15: %{name}-macros.java
58Source16: %{name}-java-requires
7c6dc55f 59Source30: builder
60Source31: adapter.awk
61Source32: pldnotify.awk
a4b7ef27 62# http://svn.pld-linux.org/banner.sh/
63Source33: banner.sh
f14234e4 64Patch0: %{name}-pl.po.patch
b174986a 65Patch1: %{name}-rpmrc.patch
3465efba 66Patch2: %{name}-arch.patch
b174986a 67Patch3: %{name}-rpmpopt.patch
3465efba 68Patch4: %{name}-perl-macros.patch
c1768ce2 69Patch5: %{name}-perl-req-perlfile.patch
f14234e4
JB
70Patch6: %{name}-noexpand.patch
71Patch7: %{name}-scripts-closefds.patch
72Patch8: %{name}-python-macros.patch
73Patch9: %{name}-gettext-in-header.patch
74Patch10: %{name}-compress-doc.patch
82687d05 75
f14234e4
JB
76Patch12: %{name}-system_libs.patch
77Patch13: %{name}-bb-and-short-circuit.patch
78Patch14: %{name}-etc_dir.patch
79Patch15: %{name}-system_libs-more.patch
80Patch16: %{name}-php-deps.patch
81Patch17: %{name}-ldconfig-always.patch
82Patch18: %{name}-perl_req.patch
8b053168 83Patch19: %{name}-link.patch
f14234e4
JB
84Patch20: %{name}-magic-usesystem.patch
85Patch21: %{name}-dontneedutils.patch
86Patch22: %{name}-provides-dont-obsolete.patch
644d8958 87Patch23: %{name}-pkgconfigdeps.patch
f14234e4 88Patch24: %{name}-po.patch
e24da480 89
f14234e4
JB
90Patch26: %{name}-notsc.patch
91Patch27: %{name}-hack-norpmlibdep.patch
92Patch28: %{name}-makefile-no_myLDADD_deps.patch
82687d05 93
f14234e4
JB
94Patch31: %{name}-missing-prototypes.patch
95Patch32: %{name}-pld-autodep.patch
374b40ea 96Patch33: %{name}-arch-x86_64.patch
f14234e4
JB
97Patch34: %{name}-epoch0.patch
98Patch35: %{name}-perl_req-INC_dirs.patch
99Patch36: %{name}-debuginfo.patch
100Patch37: %{name}-doxygen_hack.patch
82687d05 101
65f4f2e2 102Patch41: %{name}-reduce-stack-usage.patch
bb98669b 103Patch42: %{name}-old-fileconflicts-behaviour.patch
644d8958 104
33be5db0
JB
105Patch44: %{name}-no-neon.patch
106Patch45: %{name}-no-sqlite.patch
5790b583 107Patch46: %{name}-mono.patch
fbc0ff35 108
5faf69a1 109Patch49: %{name}-p4.patch
b02ce76b 110Patch50: %{name}-macros.patch
bc8eaf36 111Patch51: %{name}-cleanlibdirs.patch
80e9f34d 112Patch52: %{name}-morearchs.patch
644d8958 113
d6080f70 114Patch55: %{name}-truncate-cvslog.patch
644d8958 115
2748102f 116Patch57: %{name}-as_needed-fix.patch
a245b6ce 117Patch58: %{name}-repackage-wo-lzma.patch
59a562c2 118Patch59: %{name}-libtool-deps.patch
322f70c6 119URL: http://wraptastic.org/
b60c74c3 120BuildRequires: autoconf >= 2.57
644d8958 121BuildRequires: automake >= 1.4
87ef0d95 122BuildRequires: beecrypt-devel >= %{beecrypt_ver}
33be5db0 123BuildRequires: bzip2-devel >= 1.0.2-17
1d34a9ca 124BuildRequires: db-devel >= %{reqdb_ver}
33be5db0 125BuildRequires: elfutils-devel >= 0.108
b59d7b6c 126BuildRequires: gettext-devel >= 0.11.4-2
632f1b5c 127%{?with_system_libmagic:BuildRequires: libmagic-devel}
8e159d42 128%{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
84cdee7a
JB
129# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
130BuildRequires: libstdc++-devel
b60c74c3 131BuildRequires: libtool >= 1:1.4.2-9
33be5db0 132%if %{with neon}
fe861705 133BuildRequires: libxml2-devel
83d6a3fe 134BuildRequires: neon-devel >= 0.25.5
33be5db0 135%endif
7973b351 136BuildRequires: patch >= 2.2
1d49ffbc 137BuildRequires: popt-devel >= %{reqpopt_ver}
849b65cd 138%{?with_python:BuildRequires: python-devel >= 1:2.5}
139BuildRequires: python-modules >= 1:2.5
3cfc33fc 140BuildRequires: rpm-perlprov
2a813afe 141%{?with_python:BuildRequires: rpm-pythonprov}
874f4c9a 142BuildRequires: zlib-devel
b0a177d4 143%if %{with apidocs}
144BuildRequires: doxygen
145BuildRequires: ghostscript
146BuildRequires: graphviz
147BuildRequires: tetex-pdftex
148%endif
a6e56ce4 149%if %{with static}
e6090a7b 150# Require static library only for static build
87ef0d95 151BuildRequires: beecrypt-static >= %{beecrypt_ver}
33be5db0 152BuildRequires: bzip2-static >= 1.0.2-17
1d34a9ca 153BuildRequires: db-static >= %{reqdb_ver}
290c1c30 154BuildRequires: elfutils-static
10abbd40 155BuildRequires: glibc-static >= 2.2.94
b9e030ac 156%{?with_system_libmagic:BuildRequires: libmagic-static}
8e159d42 157%{?with_selinux:BuildRequires: libselinux-static >= 1.18}
003a039e 158BuildRequires: popt-static >= %{reqpopt_ver}
1d49ffbc 159BuildRequires: zlib-static
7a9d72ce 160%endif
66edd895 161Requires: %{name}-base = %{version}-%{release}
b26a9709 162Requires: %{name}-lib = %{version}-%{release}
10abbd40
ER
163Requires: beecrypt >= %{beecrypt_ver}
164Requires: popt >= %{reqpopt_ver}
4adb7d05 165%{!?with_static:Obsoletes: rpm-utils-static}
874f4c9a 166Conflicts: glibc < 2.2.92
bcf1e12e
AM
167# ABI changes in rpm, new poldek needed
168Conflicts: poldek < 0.20.1-0.20070105.0
1d49ffbc 169BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 170
4adb7d05
JB
171%define _binary_payload w9.gzdio
172%define _noPayloadPrefix 1
6d82b332 173
4cd84746
JB
174# don't require very fresh rpm.macros to build
175%define __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
9f517079 176%define ix86 i386 i486 i586 i686 athlon pentium3 pentium4
80e9f34d 177%define ppc ppc ppc7400 ppc7450
9f517079 178%define x8664 amd64 ia32e x86_64
4cd84746 179
89427592 180# stabilize new build environment
f9ac32aa
AM
181%define __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
182%define __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
183%define __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
89427592 184
d755a548
JK
185%define _rpmlibdir /usr/lib/rpm
186
573e40e1
PS
187%define specflags -fno-strict-aliasing
188
ff7bc1e6 189%description
190RPM is a powerful package manager, which can be used to build,
191install, query, verify, update, and uninstall individual software
cf6faebc 192packages. A package consists of an archive of files, and package
fed73700 193information, including name, version, and description.
194
dd85fadc
JR
195%description -l de.UTF-8
196RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 197Installation, Anfrage, Verifizierung, Aktualisierung und
198Uninstallation individueller Softwarepakete. Ein Paket besteht aus
199einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 200Beschreibung.
201
dd85fadc 202%description -l es.UTF-8
313a4d1a 203RPM es un poderoso administrador de paquetes, que puede ser usado para
204construir, instalar, pesquisar, verificar, actualizar y desinstalar
205paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
206almacenaje de archivos, y información sobre el paquete, incluyendo
207nombre, versión y descripción.
208
209%description -l pl.UTF-8
210RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
211przebudowanie, instalację czy weryfikację dowolnego pakietu.
212Informacje dotyczące każdego pakietu, takie jak jego opis, lista
213plików wchodzących w skład pakietu, zależności od innych pakietów, są
214przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 215odpytywania programu rpm.
216
dd85fadc
JR
217%description -l pt_BR.UTF-8
218RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 219construir, instalar, pesquisar, verificar, atualizar e desinstalar
220pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
221arquivos e informações adicionais, incluindo nome, versão e descrição
222do pacote, permissões dos arquivos, etc.
223
224%description -l ru.UTF-8
225RPM - это мощный менеджер пакетов, который может быть использован для
226создания, инсталляции, запросов (query), проверки, обновления и
227удаления программных пакетов. Пакет состоит из файлового архива и
228служебной информации, включающей название, версию, описание и другие
229данные о пакете.
230
231%description -l uk.UTF-8
232RPM - це потужний менеджер пакетів, що може бути використаний для
233створення, інсталяції, запитів (query), перевірки, поновлення та
234видалення програмних пакетів. Пакет складається з файлового архіву та
235службової інформації, що містить назву, версію, опис та іншу
236інформацію про пакет.
7c6dc55f 237
66edd895
JB
238%package base
239Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 240Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 241Group: Base
1d9ca0c1 242Requires: filesystem
66edd895
JB
243Obsoletes: vserver-rpm
244
245%description base
246The RPM base package contains scripts used by rpm packages themselves.
247These include:
248- scripts for adding/removing groups and users needed for rpm
249 packages,
250- banner.sh to display %%banner messages from rpm scriptlets.
251
dd85fadc
JR
252%description base -l pl.UTF-8
253Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 254Zawiera on:
dd85fadc
JR
255- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
256- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 257
69131f1a
JB
258%package lib
259Summary: RPMs library
4ea2ed33 260Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 261Group: Libraries
33be5db0 262Requires: beecrypt >= %{beecrypt_ver}
1d34a9ca 263Requires: db >= %{reqdb_ver}
33be5db0 264%{?with_selinux:Requires: libselinux >= 1.18}
632f1b5c 265%{?with_system_libmagic:Requires: libmagic >= 1.15-2}
69131f1a 266Requires: popt >= %{reqpopt_ver}
33be5db0 267Obsoletes: rpm-libs
69131f1a
JB
268# avoid SEGV caused by mixed db versions
269Conflicts: poldek < 0.18.1-16
0dc47449 270%{?with_suggest_tags:Suggests: lzma}
69131f1a
JB
271
272%description lib
273RPMs library.
274
dd85fadc 275%description lib -l pl.UTF-8
69131f1a
JB
276Biblioteki RPM-a.
277
fed73700 278%package devel
3f2d796a 279Summary: Header files for rpm libraries
4ea2ed33
ER
280Summary(de.UTF-8): Header-Dateien für rpm Libraries
281Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
282Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
283Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
284Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
285Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 286Group: Development/Libraries
153e5706 287Requires: %{name}-lib = %{version}-%{release}
87ef0d95 288Requires: beecrypt-devel >= %{beecrypt_ver}
fea3cb89 289Requires: bzip2-devel
1d34a9ca 290Requires: db-devel >= %{reqdb_ver}
5c583f90 291Requires: elfutils-devel
632f1b5c 292%{?with_system_libmagic:Requires: libmagic-devel}
10abbd40 293%{?with_selinux:Requires: libselinux-devel}
a998ac11 294Requires: popt-devel >= %{reqpopt_ver}
fea3cb89 295Requires: zlib-devel
cf6faebc 296
297%description devel
3f2d796a
JB
298The RPM packaging system includes C libraries that make it easy to
299manipulate RPM packages and databases. They are intended to ease the
cf6faebc 300creation of graphical package managers and other tools that need
3f2d796a
JB
301intimate knowledge of RPM packages. This package contains header files
302for these libraries.
fed73700 303
dd85fadc
JR
304%description devel -l de.UTF-8
305Der RPM-Packensystem enthält eine C-Library, die macht es einfach
306RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 307Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 308Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
309
dd85fadc 310%description devel -l es.UTF-8
313a4d1a 311El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
312fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
313facilitar la creación de administradores gráficos de paquetes y otras
20f89981 314herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 315
dd85fadc
JR
316%description devel -l pl.UTF-8
317System RPM zawiera biblioteki C, które ułatwiają manipulowanie
318pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
319graficznych programów zarządzających pakietami oraz innych narzędzi,
320które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
321zawiera pliki nagłówkowe wspomnianych bibliotek.
322
323%description devel -l pt_BR.UTF-8
324O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
325a manipulação de pacotes e bases de dados RPM. Seu objetivo é
326facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 327ferramentas que precisem de conhecimento profundo de pacotes RPM.
328
dd85fadc
JR
329%description devel -l ru.UTF-8
330Система управления пакетами RPM содержит библиотеку C, которая
331упрощает манипуляцию пакетами RPM и соответствующими базами данных.
332Эта библиотека предназначена для облегчения создания графических
333пакетных менеджеров и других утилит, которым необходимо работать с
334пакетами RPM.
7c6dc55f 335
dd85fadc
JR
336%description devel -l uk.UTF-8
337Система керування пакетами RPM містить бібліотеку C, котра спрощує
338роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
339призначена для полегшення створення графічних пакетних менеджерів та
340інших утиліт, що працюють з пакетами RPM.
7c6dc55f 341
fed73700 342%package static
9e42d68a 343Summary: RPM static libraries
4ea2ed33
ER
344Summary(de.UTF-8): RPMs statische Libraries
345Summary(pl.UTF-8): Biblioteki statyczne RPM-a
346Summary(pt_BR.UTF-8): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
347Summary(ru.UTF-8): Статическая библиотека для программ, работающих с rpm-пакетами
348Summary(uk.UTF-8): Статична бібліотека для програм, що працюють з пакетами rpm
edacdf8f 349Group: Development/Libraries
153e5706 350Requires: %{name}-devel = %{version}-%{release}
87ef0d95 351Requires: beecrypt-static >= %{beecrypt_ver}
df76dbd9 352Requires: bzip2-static
1d34a9ca 353Requires: db-static >= %{reqdb_ver}
ff03e01a 354Requires: elfutils-static
632f1b5c 355%{?with_system_libmagic:Requires: libmagic-static}
a998ac11 356Requires: popt-static >= %{reqpopt_ver}
df76dbd9 357Requires: zlib-static
edacdf8f 358
359%description static
20f89981 360RPM static libraries.
fed73700 361
dd85fadc 362%description static -l de.UTF-8
20f89981 363RPMs statische Libraries.
9e42d68a 364
dd85fadc 365%description static -l pl.UTF-8
0a7ae9bc 366Biblioteki statyczne RPM-a.
313a4d1a 367
dd85fadc
JR
368%description static -l pt_BR.UTF-8
369Bibliotecas estáticas para desenvolvimento.
edacdf8f 370
dd85fadc
JR
371%description static -l ru.UTF-8
372Система управления пакетами RPM содержит библиотеку C, которая
373упрощает манипуляцию пакетами RPM и соответствующими базами данных.
374Это статическая библиотека RPM.
7c6dc55f 375
dd85fadc
JR
376%description static -l uk.UTF-8
377Система керування пакетами RPM містить бібліотеку C, котра спрощує
378роботу з пакетами RPM та відповідними базами даних. Це статична
379бібліотека RPM.
7c6dc55f 380
fed73700 381%package utils
9e42d68a 382Summary: Additional utilities for managing rpm packages and database
4ea2ed33
ER
383Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
384Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 385Group: Applications/File
153e5706 386Requires: %{name} = %{version}-%{release}
a998ac11 387Requires: popt >= %{reqpopt_ver}
edacdf8f 388
389%description utils
20f89981 390Additional utilities for managing rpm packages and database.
fed73700 391
dd85fadc
JR
392%description utils -l de.UTF-8
393Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 394
dd85fadc
JR
395%description utils -l pl.UTF-8
396Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 397
92b3f576 398%package utils-perl
399Summary: Additional utilities for managing rpm packages and database
4ea2ed33
ER
400Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
401Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
92b3f576 402Group: Applications/File
153e5706 403Requires: %{name}-utils = %{version}-%{release}
92b3f576 404Requires: popt >= %{reqpopt_ver}
405
406%description utils-perl
407Additional utilities for managing rpm packages and database.
408
dd85fadc
JR
409%description utils-perl -l de.UTF-8
410Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
92b3f576 411
dd85fadc
JR
412%description utils-perl -l pl.UTF-8
413Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
92b3f576 414
a00926bc
JB
415%package utils-static
416Summary: Static rpm utilities
4ea2ed33 417Summary(pl.UTF-8): Statyczne narzędzia rpm
a00926bc 418Group: Applications/System
153e5706 419Requires: %{name} = %{version}-%{release}
a00926bc
JB
420
421%description utils-static
422Static rpm utilities for repairing system in case something with
423shared libraries used by rpm become broken. Currently it contains rpmi
424binary, which can be used to install/upgrade/remove packages without
425using shared libraries (well, in fact with exception of NSS modules).
426
dd85fadc
JR
427%description utils-static -l pl.UTF-8
428Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
429związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
430Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
431uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
432(z wyjątkiem modułów NSS).
a00926bc 433
fed73700 434%package build
e191287c 435Summary: Scripts for building binary RPM packages
4ea2ed33
ER
436Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
437Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
438Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
439Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
440Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 441Group: Applications/File
8f76a271 442Requires(pre): findutils
b0a177d4 443Requires: %{name}-build-macros >= 1.314
153e5706 444Requires: %{name}-utils = %{version}-%{release}
e191287c 445Requires: /bin/id
446Requires: awk
b6754a7e
PS
447# we need fixed binutils for -feliminate-dwarf2-dups
448Requires: binutils >= 3:2.17.50.0.3-2
cfa7898a 449Requires: bzip2
e950a6d7 450Requires: chrpath >= 0.10-4
b6547e10 451Requires: cpio
e191287c 452Requires: diffutils
195f647c 453Requires: elfutils
583135b4 454Requires: file >= 4.17
e191287c 455Requires: fileutils
456Requires: findutils
120d96b6 457Requires: gcc >= 5:3.4
e191287c 458Requires: glibc-devel
459Requires: grep
460Requires: gzip
e93003df 461Requires: lzma
e191287c 462Requires: make
463Requires: patch
e191287c 464Requires: sed
465Requires: sh-utils
466Requires: tar
467Requires: textutils
ca3648b1 468Provides: rpmbuild(monoautodeps)
37ea389a 469Provides: rpmbuild(noauto) = 3
02d17bf9 470%ifarch %{x8664}
195f647c
JB
471Conflicts: automake < 1:1.7.9-2
472Conflicts: libtool < 2:1.5-13
473%endif
0096c5cd 474
e2025ad1 475%description build
58399c37 476Scripts for building binary RPM packages.
fed73700 477
dd85fadc
JR
478%description build -l de.UTF-8
479Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 480
dd85fadc
JR
481%description build -l pl.UTF-8
482Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 483
dd85fadc
JR
484%description build -l pt_BR.UTF-8
485Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 486construir pacotes usando o RPM.
e73478cd 487
dd85fadc
JR
488%description build -l ru.UTF-8
489Различные вспомогательные скрипты и исполняемые программы, которые
490используются для сборки RPM'ов.
7c6dc55f 491
dd85fadc
JR
492%description build -l uk.UTF-8
493Різноманітні допоміжні скрипти та утиліти, які використовуються для
494побудови RPM'ів.
7c6dc55f 495
496%package build-tools
497Summary: Scripts for managing .spec files and building RPM packages
4ea2ed33
ER
498Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
499Summary(pl.UTF-8): Skrypty pomocnicze do zarządznia plikami .spec i budowania RPM-ów
500Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
501Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
502Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
7c6dc55f 503Group: Applications/File
153e5706 504Requires: %{name}-build = %{version}-%{release}
7c6dc55f 505# these are optional
506#Requires: cvs
c76eeb55 507Requires: wget
7c6dc55f 508
509%description build-tools
510Scripts for managing .spec files and building RPM packages.
511
dd85fadc
JR
512%description build-tools -l de.UTF-8
513Scripts fürs Bauen RPM-Pakete.
7c6dc55f 514
dd85fadc
JR
515%description build-tools -l pl.UTF-8
516Skrypty pomocnicze do zarządzania plikami .spec i do budowania RPM-ów.
7c6dc55f 517
dd85fadc
JR
518%description build-tools -l pt_BR.UTF-8
519Este pacote contém scripts e programas executáveis que são usados para
7c6dc55f 520construir pacotes usando o RPM.
521
dd85fadc
JR
522%description build-tools -l ru.UTF-8
523Различные вспомогательные скрипты и исполняемые программы, которые
524используются для сборки RPM'ов.
7c6dc55f 525
dd85fadc
JR
526%description build-tools -l uk.UTF-8
527Різноманітні допоміжні скрипти та утиліти, які використовуються для
528побудови RPM'ів.
7c6dc55f 529
69131f1a
JB
530%package perlprov
531Summary: Additional utilities for checking perl provides/requires in rpm packages
4ea2ed33
ER
532Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
533Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów perla w pakietach rpm
69131f1a
JB
534Group: Applications/File
535Requires: %{name} = %{version}-%{release}
536Requires: perl-devel
537Requires: perl-modules
538
539%description perlprov
540Additional utilities for checking perl provides/requires in rpm
541packages.
542
dd85fadc
JR
543%description perlprov -l de.UTF-8
544Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 545
dd85fadc
JR
546%description perlprov -l pl.UTF-8
547Dodatkowe narzędzia do sprawdzenia zależności skryptów perla w
69131f1a
JB
548pakietach rpm.
549
550%package pythonprov
551Summary: Python macros, which simplifies creation of rpm packages with Python software
4ea2ed33 552Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów rpm z programami napisanymi w Pythonie
69131f1a
JB
553Group: Applications/File
554Requires: %{name} = %{version}-%{release}
cd800b3c 555Requires: python
243c6264 556Requires: python-modules
69131f1a
JB
557
558%description pythonprov
559Python macros, which simplifies creation of rpm packages with Python
560software.
561
dd85fadc
JR
562%description pythonprov -l pl.UTF-8
563Makra ułatwiające tworzenie pakietów rpm z programami napisanymi w
69131f1a
JB
564Pythonie.
565
566%package php-pearprov
567Summary: Additional utilities for managing rpm packages and database
4ea2ed33 568Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności skryptów php w rpm
69131f1a
JB
569Group: Applications/File
570Requires: %{name} = %{version}-%{release}
632f1b5c 571Requires: sed >= 4.0
69131f1a
JB
572
573%description php-pearprov
574Additional utilities for checking php pear provides/requires in rpm
575packages.
576
dd85fadc
JR
577%description php-pearprov -l pl.UTF-8
578Dodatkowe narzędzia do sprawdzenia zależności skryptów php pear w
69131f1a
JB
579pakietach rpm.
580
581%package -n python-rpm
582Summary: Python interface to RPM library
4ea2ed33
ER
583Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
584Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a
JB
585Group: Development/Languages/Python
586Requires: %{name} = %{version}-%{release}
587%pyrequires_eq python
588Obsoletes: rpm-python
589
590%description -n python-rpm
591The rpm-python package contains a module which permits applications
592written in the Python programming language to use the interface
593supplied by RPM (RPM Package Manager) libraries.
594
595This package should be installed if you want to develop Python
596programs that will manipulate RPM packages and databases.
597
dd85fadc
JR
598%description -n python-rpm -l pl.UTF-8
599Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
600Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 601
dd85fadc
JR
602Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
603Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 604
dd85fadc
JR
605%description -n python-rpm -l pt_BR.UTF-8
606O pacote rpm-python contém um módulo que permite que aplicações
69131f1a
JB
607escritas em Python utilizem a interface fornecida pelas bibliotecas
608RPM (RPM Package Manager).
609
dd85fadc 610Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
611Python para manipular pacotes e bancos de dados RPM.
612
d6dddf74
JB
613%package apidocs
614Summary: RPM API documentation and guides
4ea2ed33 615Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
10abbd40 616Group: Documentation
b2ae427d 617
618%description apidocs
e93003df
ER
619Documentation for RPM API and guides in HTML format generated from rpm
620sources by doxygen.
31f4a5bc 621
dd85fadc 622%description apidocs -l pl.UTF-8
e93003df 623Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
dd85fadc 624źrodeł RPM-a przez doxygen.
b2ae427d 625
e2025ad1 626%prep
2065c1cd 627%setup -q
82687d05 628%patch0 -p1
db88c593 629%patch1 -p1
243e72f3 630%patch2 -p1
01d7a578 631%patch3 -p1
e2025ad1 632%patch4 -p1
c1768ce2 633%patch5 -p1
f14234e4 634%patch6 -p1
c1768ce2 635%patch7 -p1
fefe9d30
JB
636%patch8 -p1
637%patch9 -p1
638%patch10 -p1
c7def65c 639%patch12 -p1
7a9d72ce 640%patch13 -p1
9a8d811d 641%patch14 -p1
f14234e4 642%patch15 -p1
fefe9d30
JB
643%patch16 -p1
644%patch17 -p1
f14234e4 645%patch18 -p1
feb1f12e 646sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
1fcb29e9 647#cp -f platform.in macros.pld.in # what for?
8e989934 648echo '%%define __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
649echo '%%define __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
c2673e18 650echo '# obsoleted file' > macros.python
ac090b0f
ER
651echo '%%define __php_provides /usr/lib/rpm/php.prov' > macros.php
652echo '%%define __php_requires /usr/lib/rpm/php.req' >> macros.php
120d96b6 653echo '%%define __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
654echo '%%define __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
80b8a1f9
JB
655install %{SOURCE5} scripts/find-lang.sh
656install %{SOURCE9} scripts/php.prov.in
657install %{SOURCE10} scripts/php.req.in
658install %{SOURCE12} scripts/perl.prov
82687d05 659%patch19 -p1
f14234e4
JB
660%patch20 -p1
661%patch21 -p1
c7def65c 662%patch22 -p1
663%patch23 -p1
82687d05 664%patch24 -p1
fefe9d30 665%patch26 -p1
24123ddd 666%patch27 -p1
8432f0c5 667%patch28 -p1
c7def65c 668%patch31 -p1
e24da480 669%patch32 -p1
82687d05 670# needed? I doubt
4617e0e8 671# %patch33 -p1
f14234e4
JB
672%patch34 -p1
673%patch35 -p0
5f7fdcd9 674%patch36 -p1
e24da480 675%patch37 -p1
65f4f2e2 676%patch41 -p1
bb98669b 677%patch42 -p1
374b40ea 678%{!?with_neon:%patch44 -p1}
e24da480 679%patch45 -p1
5790b583 680%patch46 -p1
5faf69a1 681%patch49 -p1
b02ce76b 682%patch50 -p1
bc8eaf36 683%patch51 -p1
a05b34dc 684#%patch52 -p1
d6080f70 685%patch55 -p1
2748102f 686%patch57 -p1
a245b6ce 687%patch58 -p1
59a562c2 688%patch59 -p1
d36cb682 689
bcdcbb03 690cd scripts
37550797 691mv -f perl.req perl.req.in
874f4c9a
MM
692mv -f perl.prov perl.prov.in
693cd ..
633d1e9e 694
4adb7d05
JB
695mv -f po/{no,nb}.po
696mv -f po/{sr,sr@Latn}.po
697
33be5db0 698rm -rf sqlite zlib db db3 popt rpmdb/db.h
633d1e9e 699
cd86db2e 700# generate Group translations to *.po
80b8a1f9 701awk -f %{SOURCE6} %{SOURCE1}
fefe9d30
JB
702
703# update macros paths
704for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
705 sed -e 's@lib/rpm/redhat@lib/rpm/pld@g' $f > ${f}.tmp
706 mv -f ${f}.tmp $f
707done
0d76071c 708
87ef0d95 709%build
a63662c4 710%if %{with system_libmagic}
711rm -rf file
712%else
87ef0d95 713cd file
ea816ea6 714%{__libtoolize}
ceaaacee
JB
715%{__aclocal}
716%{__autoheader}
0b35155a 717%{__autoconf}
edacdf8f 718%{__automake}
72be9ffe 719cd ..
a63662c4 720%endif
a998ac11 721
ea816ea6 722%{__libtoolize}
c222dedc 723%{__gettextize}
ceaaacee 724%{__aclocal}
4cd84746 725%{__autoheader}
7a9d72ce 726%{__autoconf}
7a9d72ce 727%{__automake}
7a9d72ce 728
cd86db2e 729# config.guess doesn't handle athlon, so we have to change it by hand.
730# rpm checks for CPU type at runtime, but it looks better
7c9ace12 731sed -i -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' -e 's|@host_cpu@|%{_target_cpu}|' macros.in
7a9d72ce 732
89427592 733# pass CC and CXX too in case of building with some older configure macro
01d7a578 734# disable perl-RPM2 build, we have it in separate spec
624f96ff 735%configure \
f9ac32aa
AM
736 CC="%{__newcc}" \
737 CXX="%{__newcxx}" \
738 CPP="%{__newcpp}" \
01d7a578 739 WITH_PERL_VERSION=no \
33be5db0 740 %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
cd86db2e 741 --enable-shared \
874f4c9a 742 --enable-static \
2e6b4088 743 %{!?with_apidocs:--without-apidocs} \
849b65cd 744 %{?with_python:--with-python=2.5} \
a6e56ce4 745 %{!?with_python:--without-python} \
c6abc173 746 %{!?with_selinux:--without-selinux} \
874f4c9a 747 --without-db
cf6faebc 748
4adb7d05 749# file_LDFLAGS, debugedit_LDADD - no need to link "file" and "debugedit" statically
874f4c9a 750%{__make} \
f9ac32aa
AM
751 CC="%{__cc}" \
752 CXX="%{__cxx}" \
753 CPP="%{__cpp}" \
e8d70bea 754 pylibdir=%{py_libdir} \
4adb7d05
JB
755 myLDFLAGS="%{rpmldflags}" \
756 file_LDFLAGS= \
01d7a578
JB
757 debugedit_LDADD="\$(WITH_LIBELF_LIB) -lpopt" \
758 staticLDFLAGS=%{?with_static:-all-static}
33be5db0 759
796d4a88 760%{?with_apidocs:%{__make} doxygen}
e05585d0 761
b064b8e6 762%install
ff7bc1e6 763rm -rf $RPM_BUILD_ROOT
66edd895 764install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/banner}
76214164 765
a5e7fb84 766%{__make} install \
9805fd6d 767 DESTDIR=$RPM_BUILD_ROOT \
c34a847a 768 staticLDFLAGS=%{?with_static:-all-static} \
e8d70bea 769 pylibdir=%{py_libdir} \
cf6faebc 770 pkgbindir="%{_bindir}"
718426e1 771
caf453d4
AM
772echo "%{_target_cpu}-%{_target_vendor}-linux-gnu" > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
773
137e2891 774%ifarch %{ppc}
a05b34dc 775#sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
776# -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
137e2891 777%endif
778
02919de5
JK
779rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
780rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
781rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
782
644d8958
JB
783# not installed since 4.4.8 (-tools-perl subpackage)
784install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
785
d755a548
JK
786install macros.perl $RPM_BUILD_ROOT%{_rpmlibdir}/macros.perl
787install macros.python $RPM_BUILD_ROOT%{_rpmlibdir}/macros.python
788install macros.php $RPM_BUILD_ROOT%{_rpmlibdir}/macros.php
5790b583 789install macros.mono $RPM_BUILD_ROOT%{_rpmlibdir}/macros.mono
1f625675 790install %{SOURCE15} $RPM_BUILD_ROOT%{_rpmlibdir}/macros.java
7ba63f26 791
61f7e1b3 792install %{SOURCE1} doc/manual/groups
d755a548 793install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
80b8a1f9
JB
794install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
795install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
796install %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/check-files
d0370fe5 797install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1f625675 798install %{SOURCE16} $RPM_BUILD_ROOT%{_rpmlibdir}/find-java-requires
d755a548
JK
799install scripts/find-php* $RPM_BUILD_ROOT%{_rpmlibdir}
800install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
d0370fe5 801install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 802
7c6dc55f 803install %{SOURCE30} $RPM_BUILD_ROOT%{_bindir}/builder
804install %{SOURCE31} $RPM_BUILD_ROOT%{_bindir}/adapter.awk
805install %{SOURCE32} $RPM_BUILD_ROOT%{_bindir}/pldnotify.awk
a4b7ef27 806install %{SOURCE33} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 807
fbc0ff35
AM
808install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
809
d23a99cc
AM
810# obsolete but still installed
811rm $RPM_BUILD_ROOT%{_rpmlibdir}/rpmrc
720f06f0 812
e663e5ff
JB
813cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
814# customized rpm macros - global for host
815#
40c1ea77
AF
816#%%_install_langs pl_PL:en_US
817%%distribution PLD
541eacd3
JB
818#
819# remove or replace with file_contexts path if you want to use custom
820# SELinux file contexts policy instead of one stored in packages payload
31858397
JB
821%%_install_file_context_path %%{nil}
822%%_verify_file_context_path %%{nil}
627d5615
ER
823
824# If non-zero, all erasures will be automagically repackaged.
825#%%_repackage_all_erasures 1
09bb810c
AF
826EOF
827
3d9806c2 828cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles <<EOF
99a3012c 829# global list of files (regexps) which don't generate Provides
3d9806c2
JB
830EOF
831cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov <<EOF
99a3012c 832# global list of script capabilities (regexps) not to be used in Provides
3d9806c2
JB
833EOF
834cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles <<EOF
99a3012c 835# global list of files (regexps) which don't generate Requires
e93003df
ER
836^%{_examplesdir}/
837^%{_docdir}/
3d9806c2
JB
838EOF
839cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq <<EOF
99a3012c 840# global list of script capabilities (regexps) not to be used in Requires
3d9806c2
JB
841EOF
842cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
99a3012c 843# global list of capabilities (SONAME, perl(module), php(module) regexps)
3d9806c2 844# which don't generate dependencies on package NAMES
195f647c 845# -- OpenGL implementation
f694a4d9
JB
846^libGL.so.1
847^libGLU.so.1
195f647c
JB
848^libOSMesa.so
849# -- Glide
f694a4d9 850^libglide3.so.3
195f647c 851# -- mozilla
f694a4d9
JB
852^libgtkmozembed.so
853^libgtksuperwin.so
854^libxpcom.so
195f647c
JB
855# -- X11 implementation
856^libFS.so
857^libI810XvMC.so
858^libICE.so
859^libSM.so
860^libX11.so
861^libXRes.so
862^libXTrap.so
863^libXaw.so
8c3b25a7 864^libXcomposite.so
195f647c 865^libXcursor.so
8c3b25a7
JB
866^libXdamage.so
867^libXdmcp.so
868^libXevie.so
195f647c 869^libXext.so
8c3b25a7 870^libXfixes.so
195f647c
JB
871^libXfont.so
872^libXfontcache.so
873^libXft.so
874^libXi.so
875^libXinerama.so
876^libXmu.so
877^libXmuu.so
878^libXp.so
879^libXpm.so
880^libXrandr.so
881^libXrender.so
882^libXss.so
883^libXt.so
884^libXtst.so
885^libXv.so
886^libXvMC.so
887^libXxf86dga.so
888^libXxf86misc.so
889^libXxf86rush.so
890^libXxf86vm.so
37ea389a
JB
891^libdps.so
892^libdpstk.so
195f647c 893^libfontenc.so
37ea389a 894^libpsres.so
195f647c
JB
895^libxkbfile.so
896^libxkbui.so
eec3b202
JB
897# -- fam / gamin
898^libfam.so.0
3d9806c2 899EOF
a4852742
JB
900cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
901# global list of file masks not to be compressed in DOCDIR
902EOF
3d9806c2 903
f3fd387a 904# for rpm -e|-U --repackage
a11e0e27
AM
905install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
906touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
f3fd387a 907
c2673e18 908# move libs to /lib
a11e0e27 909for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so ; do
50dc9ac0
JK
910 mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
911 ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
c2673e18
AF
912done
913
fca52ae1 914# remove arch dependant macros which have no use on noarch
627d5615 915%{__sed} -i -e '
fca52ae1
ER
916/{__spec_install_post_strip}/d
917/{__spec_install_post_chrpath}/d
918/{__spec_install_post_compress_modules}/d
919' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
920
6f18cdb7
AF
921%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
922%py_comp $RPM_BUILD_ROOT%{py_sitedir}
923
01d7a578
JB
924rm -f $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
925
926# (currently) not used or supported in PLD
927rm -f $RPM_BUILD_ROOT%{_rpmlibdir}/{Specfile.pm,cpanflute,cpanflute2,find-provides,find-requires,freshen.sh,http.req,magic.prov,magic.req,perldeps.pl,sql.prov,sql.req,tcl.req}
928# wrong location, not used anyway
929rm -f $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
644d8958
JB
930# manuals for utils dropped in 4.4.8 (?)
931#rm -f $RPM_BUILD_ROOT%{_mandir}/{,*/}/man8/{rpmcache,rpmgraph}.8
01d7a578 932
90b03dd6 933%find_lang %{name}
cf6faebc 934
c2673e18 935rm -rf manual
a998ac11
AF
936cp -a doc/manual manual
937rm -f manual/Makefile*
874f4c9a 938
13eb5ebf 939%clean
d7df46b8 940rm -rf $RPM_BUILD_ROOT
76214164 941
ceaaacee
JB
942%post lib -p /sbin/ldconfig
943%postun lib -p /sbin/ldconfig
76214164 944
8f76a271 945%pre build
d755a548 946find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 947
3684d90f
JB
948%files -f %{name}.lang
949%defattr(644,root,root,755)
644d8958 950%doc CHANGES CREDITS README wdj/JBJ-GPG-KEY manual/*
3684d90f 951
7a9d72ce 952%attr(755,root,root) /bin/rpm
35a6f2f9
JB
953#%attr(755,root,root) %{_bindir}/rpmdb
954#%attr(755,root,root) %{_bindir}/rpmquery
955#%attr(755,root,root) %{_bindir}/rpmsign
956#%attr(755,root,root) %{_bindir}/rpmverify
e73478cd 957
958%dir %{_sysconfdir}/rpm
66edd895 959%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
caf453d4
AM
960# these are ok to be replaced
961%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo
962%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
963
e73478cd 964
09bb810c 965%{_mandir}/man8/rpm.8*
feb1f12e 966%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 967%lang(ja) %{_mandir}/ja/man8/rpm.8*
1162bdc1 968%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 969%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 970%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 971%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 972
e2025ad1 973%dir /var/lib/rpm
f3fd387a 974%dir %attr(700,root,root) /var/spool/repackage
a11e0e27
AM
975%dir /var/lock/rpm
976/var/lock/rpm/transaction
4acac5de 977
4acac5de 978#%attr(755,root,root) %{_rpmlibdir}/rpmd
4adb7d05 979#%{!?with_static:%attr(755,root,root) %{_rpmlibdir}/rpm[eiu]}
4acac5de
JB
980#%attr(755,root,root) %{_rpmlibdir}/rpmk
981#%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
e2025ad1 982
d755a548
JK
983%{_rpmlibdir}/rpmpopt*
984%{_rpmlibdir}/macros
3684d90f 985
66edd895
JB
986%files base
987%defattr(644,root,root,755)
988%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
989%dir %{_rpmlibdir}
990%attr(755,root,root) %{_bindir}/banner.sh
991%attr(755,root,root) %{_rpmlibdir}/user_group.sh
992%dir /var/lib/banner
993
874f4c9a
MM
994%files lib
995%defattr(644,root,root,755)
50dc9ac0 996%attr(755,root,root) /%{_lib}/librpm*-*.so
874f4c9a
MM
997%attr(755,root,root) %{_libdir}/librpm*-*.so
998
69131f1a
JB
999%files devel
1000%defattr(644,root,root,755)
1001%{_includedir}/rpm
1002%{_libdir}/librpm*.la
1003%attr(755,root,root) %{_libdir}/librpm.so
1004%attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1005%attr(755,root,root) %{_libdir}/librpmio.so
1006%attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1007%attr(755,root,root) %{_libdir}/librpmdb.so
1008%attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1009%attr(755,root,root) %{_libdir}/librpmbuild.so
1010
1011%files static
1012%defattr(644,root,root,755)
1013%{_libdir}/librpm*.a
1014
1015%files utils
1016%defattr(644,root,root,755)
1017%attr(755,root,root) %{_bindir}/debugedit
1018%attr(755,root,root) %{_bindir}/rpm2cpio
69131f1a 1019%attr(755,root,root) %{_bindir}/rpmdeps
a63662c4 1020%{!?with_system_libmagic:%attr(755,root,root) %{_bindir}/rpmfile}
69131f1a 1021%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
69131f1a
JB
1022%attr(755,root,root) %{_rpmlibdir}/tgpg
1023%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1024%{_mandir}/man8/rpm2cpio.8*
1025%{_mandir}/man8/rpmdeps.8*
644d8958
JB
1026#%{_mandir}/man8/rpmcache.8*
1027#%{_mandir}/man8/rpmgraph.8*
69131f1a 1028%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
644d8958
JB
1029#%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
1030#%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
69131f1a
JB
1031%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1032%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1033%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
644d8958
JB
1034#%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
1035#%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
69131f1a
JB
1036%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1037
1038%files utils-perl
1039%defattr(644,root,root,755)
1040%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
69131f1a
JB
1041
1042%if %{with static}
1043%files utils-static
1044%defattr(644,root,root,755)
1045%attr(755,root,root) %{_bindir}/rpm[ieu]
1046%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1047%endif
1048
3684d90f 1049%files build
a45ae6d8 1050%defattr(644,root,root,755)
66edd895 1051%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
1052%attr(755,root,root) %{_rpmlibdir}/brp-*
1053%attr(755,root,root) %{_rpmlibdir}/check-files
374b40ea 1054# %attr(755,root,root) %{_rpmlibdir}/check-prereqs
d755a548 1055%attr(755,root,root) %{_rpmlibdir}/compress-doc
01d7a578 1056%attr(755,root,root) %{_rpmlibdir}/config.*
d755a548 1057%attr(755,root,root) %{_rpmlibdir}/cross-build
d755a548
JK
1058%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1059%attr(755,root,root) %{_rpmlibdir}/find-lang.sh
d755a548
JK
1060%attr(755,root,root) %{_rpmlibdir}/getpo.sh
1061%attr(755,root,root) %{_rpmlibdir}/install-build-tree
01d7a578 1062%attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
d755a548 1063%attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
01d7a578
JB
1064%attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1065# needs jar (any jdk), jcf-dump (gcc-java) to work
1066%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1067%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1068# needs hacked pkg-config to return anything
1069%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
d755a548
JK
1070%attr(755,root,root) %{_rpmlibdir}/rpmb
1071%attr(755,root,root) %{_rpmlibdir}/rpmt
1072%{_rpmlibdir}/noarch-*
e9fe9fc5 1073%ifarch %{ix86}
d755a548 1074%{_rpmlibdir}/i?86*
e9fe9fc5 1075%{_rpmlibdir}/pentium*
d755a548
JK
1076%{_rpmlibdir}/athlon*
1077%endif
ad628734
JB
1078%ifarch alpha
1079%{_rpmlibdir}/alpha*
1080%endif
ad628734
JB
1081%ifarch ia64
1082%{_rpmlibdir}/ia64*
8f76a271 1083%endif
410dd742 1084%ifarch mips mipsel mips64 mips64el
1085%{_rpmlibdir}/mips*
1086%endif
80e9f34d 1087%ifarch %{ppc}
410dd742 1088%{_rpmlibdir}/ppc*
1089%endif
1090%ifarch sparc sparc64
1091%{_rpmlibdir}/sparc*
1092%endif
9f517079 1093%ifarch %{x8664}
cedf1bfa
PS
1094%{_rpmlibdir}/x86_64*
1095%endif
410dd742 1096# must be here for "Requires: rpm-*prov" to work
5790b583 1097%{_rpmlibdir}/macros.mono
410dd742 1098%{_rpmlibdir}/macros.perl
1099%{_rpmlibdir}/macros.php
1100# not used yet ... these six depend on perl
1101#%attr(755,root,root) %{_rpmlibdir}/http.req
591cc005
JB
1102#%attr(755,root,root) %{_rpmlibdir}/magic.prov
1103#%attr(755,root,root) %{_rpmlibdir}/magic.req
1104#%{_rpmlibdir}/sql.prov
1105#%{_rpmlibdir}/sql.req
1106#%{_rpmlibdir}/tcl.req
7a9d72ce 1107
874f4c9a
MM
1108%attr(755,root,root) %{_bindir}/gendiff
1109%attr(755,root,root) %{_bindir}/rpmbuild
1110
a00926bc 1111%{_mandir}/man1/gendiff.1*
874f4c9a 1112%{_mandir}/man8/rpmbuild.8*
fefe9d30
JB
1113%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1114%lang(pl) %{_mandir}/pl/man1/gendiff.1*
1115%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
f3fe287f 1116
69131f1a 1117%files build-tools
a00926bc 1118%defattr(644,root,root,755)
69131f1a
JB
1119%attr(755,root,root) %{_bindir}/builder
1120%attr(755,root,root) %{_bindir}/adapter.awk
1121%attr(755,root,root) %{_bindir}/pldnotify.awk
a00926bc 1122
89334051
AF
1123%files perlprov
1124%defattr(644,root,root,755)
d755a548
JK
1125%attr(755,root,root) %{_rpmlibdir}/perl.*
1126#%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1127#%attr(755,root,root) %{_rpmlibdir}/find-perl-*
02919de5
JK
1128#%attr(755,root,root) %{_rpmlibdir}/find-*.perl
1129#%attr(755,root,root) %{_rpmlibdir}/find-prov.pl
1130#%attr(755,root,root) %{_rpmlibdir}/find-req.pl
374b40ea 1131#%attr(755,root,root) %{_rpmlibdir}/get_magic.pl
9805fd6d 1132
80d3b868 1133%files pythonprov
d8fcb9b0 1134%defattr(644,root,root,755)
d755a548 1135%{_rpmlibdir}/macros.python
25d296e1 1136%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
09bb810c 1137
d36cb682
PG
1138%files php-pearprov
1139%defattr(644,root,root,755)
d755a548
JK
1140%attr(755,root,root) %{_rpmlibdir}/php*
1141%attr(755,root,root) %{_rpmlibdir}/find-php*
d36cb682 1142
50dc9ac0 1143%if %{with python}
cf6faebc 1144%files -n python-rpm
42a0025c 1145%defattr(644,root,root,755)
b33910fe 1146%dir %{py_sitedir}/rpm
6f18cdb7 1147%attr(755,root,root) %{py_sitedir}/rpm/*.so
8c99b39a 1148%{py_sitedir}/rpm/*.py[co]
50dc9ac0 1149%endif
874f4c9a 1150
b2ae427d 1151%if %{with apidocs}
1152%files apidocs
1153%defattr(644,root,root,755)
1154%doc apidocs
1155%endif
This page took 0.714406 seconds and 4 git commands to generate.