]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
Release: 29
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
d0ee0933
JR
3# - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4# returns -ENOSYS
9fb5ee9e 5# - add macros for some ppc, mipsel, alpha and sparc
a0c0c9ca 6#
c296fee0 7# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 8#
89427592 9# Conditional build:
01d7a578 10%bcond_with static # build static rpm+rpmi
0a1ccab0 11%bcond_without apidocs # don't generate documentation with doxygen
4af66a2c
JB
12%bcond_without python # don't build python bindings
13%bcond_without selinux # build without selinux support
0dc47449 14%bcond_without suggest_tags # build without Suggest tag (bootstrapping)
7f47af9c 15%bcond_with db61 # use DB 6.1 instead of 5.2
34befcc5 16%bcond_with neon # build with HTTP/WebDAV support (neon library)
6f6c7465 17%bcond_with sqlite # build with SQLite support
70df63f3 18%bcond_with system_lua # use system lua
a22a4387 19%bcond_without system_pcre # use system pcre
d0ee0933 20%bcond_with keyutils # build with keyutils support
89427592
JB
21# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
22# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
23# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
858aa7d0 24#
858aa7d0 25
ba7bedbb
JR
26%if %{with sqlite}
27# Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
28%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
29%endif
30
003a039e 31# versions of required libraries
7f47af9c
JB
32%if %{with db61}
33%define reqdb_pkg db6.1
34%define reqdb_ver 6.1
35%define reqdb_pkgver 6.1.19
5f3f5bd6 36%else
bf728d07 37%define reqdb_pkg db5.2
cf169f7c
JR
38%define reqdb_ver 5.2
39%define reqdb_pkgver 5.2.36.0-4
5f3f5bd6 40%endif
ec44785a 41%define reqpopt_ver 1.15
7f11791f 42%define beecrypt_ver 2:4.2.0
70f8787d 43%define sover 5.4
fc60c9f3 44
e5f02e49 45Summary: RPM Package Manager
4ea2ed33
ER
46Summary(de.UTF-8): RPM Packet-Manager
47Summary(es.UTF-8): Gestor de paquetes RPM
48Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
49Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
50Summary(ru.UTF-8): Менеджер пакетов от RPM
51Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 52Name: rpm
b5280b8b 53Version: 5.4.15
9b07f84b 54Release: 29
4e2db228 55License: LGPL v2.1
76214164 56Group: Base
b5280b8b 57# http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
afb55538 58Source0: %{name}-%{version}.tar.gz
b5280b8b 59# Source0-md5: 4067f83ca8b5bf1a21e443c0cff3efa0
c546a4d6
ER
60# See README.cpu-os-macros how to update cpu-os-macros.a
61Source100: cpu-os-macros.a
62Source101: README.cpu-os-macros
ff7bc1e6 63Source1: %{name}.groups
08697680 64Source2: macros.pld.in
ff7bc1e6 65Source3: %{name}-install-tree
80b8a1f9 66Source4: %{name}-find-spec-bcond
cf709a39 67Source5: %{name}-hrmib-cache
80b8a1f9
JB
68Source6: %{name}-groups-po.awk
69Source7: %{name}-compress-doc
0bf34f68
JR
70Source8: %{name}-php-provides
71Source9: %{name}-php-requires
72Source10: %{name}.sysinfo
73Source11: perl.prov
74Source12: %{name}-user_group.sh
75Source13: %{name}.sysconfig
76Source14: %{name}-java-requires
a4b7ef27 77# http://svn.pld-linux.org/banner.sh/
0bf34f68
JR
78Source15: banner.sh
79Source16: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
80# Source16-md5: 08b29584dd349aac9caa7610131a0a88
81Source17: %{name}-mimetypedeps
82Source18: macros.local
f09b01ac
ER
83Source19: %{name}.noautocompressdoc
84Source20: %{name}.noautoprov
85Source21: %{name}.noautoprovfiles
86Source22: %{name}.noautoreq
f09b01ac 87Source24: %{name}.noautoreqfiles
0bf34f68 88Source25: %{name}-php-requires.php
f09b01ac 89Source26: %{name}db_checkversion.c
b1541d4c 90Source27: macros.lang
f09b01ac 91Source28: %{name}db_reset.c
14138aba 92Source29: dbupgrade.sh
e2489d8e 93Source30: rubygems.rb
63194730 94Source31: gem_helper.rb
f05db907 95Patch0: %{name}-branch.patch
2f0ee4ec 96Patch1: %{name}-man_pl.patch
38e53563 97Patch2: %{name}-popt-aliases.patch
c0fe6b09 98Patch3: %{name}-nosetproctitle.patch
3465efba 99Patch4: %{name}-perl-macros.patch
c1768ce2 100Patch5: %{name}-perl-req-perlfile.patch
3c7590cc
JR
101Patch6: %{name}-scripts-closefds.patch
102Patch7: %{name}-php-macros.patch
103Patch8: %{name}-gettext-in-header.patch
044171ea 104Patch9: %{name}-lua.patch
9ee75c3c
JR
105Patch10: %{name}-php-deps.patch
106Patch11: %{name}-notsc.patch
107Patch12: %{name}-hack-norpmlibdep.patch
06405080 108Patch13: %{name}-dont-copy-descriptive-tags.patch
9ee75c3c
JR
109Patch14: %{name}-perl_req-INC_dirs.patch
110Patch15: %{name}-debuginfo.patch
111Patch16: vendor-pld.patch
112Patch17: %{name}-old-fileconflicts-behaviour.patch
113Patch18: %{name}-javadeps.patch
114Patch19: %{name}-truncate-cvslog.patch
115Patch20: %{name}-libtool-deps.patch
116Patch21: %{name}-mimetype.patch
117Patch22: %{name}-sparc64.patch
118Patch23: %{name}-gendiff.patch
119Patch24: openmp.patch
120Patch25: %{name}-URPM-build-fix.patch
9ee75c3c
JR
121Patch27: %{name}-helperEVR-noassert.patch
122Patch28: %{name}-unglobal.patch
123Patch29: %{name}-builddir-readlink.patch
124Patch30: %{name}-changelog_order_check_nonfatal.patch
125Patch31: %{name}-cleanbody.patch
126Patch32: %{name}-dirdeps-macro.patch
127Patch33: %{name}-installbeforeerase.patch
128Patch34: %{name}-libmagic-locale.patch
129Patch35: %{name}-namespace-compare.patch
130Patch36: %{name}-popt-coreutils.patch
131Patch37: %{name}-postun-nofail.patch
132Patch38: %{name}-silence-RPM_CHAR_TYPE.patch
133Patch39: %{name}-fix-missing-types-in-headers.patch
134Patch40: %{name}-fix--p-interpreter-and-empty-script.patch
135Patch41: %{name}-db_buffer_small.patch
136Patch42: %{name}-pattern_Release.patch
137Patch43: %{name}-fix-___build_pre-macro.patch
138Patch44: %{name}-missing-patch-file-fails-build.patch
139Patch45: %{name}-remove-misleading-missing-patch-message.patch
140Patch46: %{name}-file-magic-can-be-mixed-case.patch
0b0a7839 141Patch47: %{name}-query-always-noisy.patch
7f7a3f24 142Patch48: %{name}-verify-ghosts-broken-logic.patch
295c267a 143Patch49: %{name}-python-enable-compat-RPMSENSE.patch
d6a36788 144Patch50: %{name}-dont-treat-gstreamer-modules-as-font.patch
bba1059c 145Patch51: %{name}-gst-inspect-typo.patch
1fcc9b69 146Patch52: %{name}-null-term-ascii-digest.patch
70df63f3 147Patch53: %{name}-lua-enable-extra-libs.patch
330093fa 148Patch54: %{name}-fix-filedigests-verify.patch
9158f140 149Patch55: %{name}-disable-hmac-verify.patch
f09b01ac 150Patch56: %{name}-macros.patch
f7779567 151Patch57: %{name}-db5.2.patch
c4861085 152Patch58: %{name}-preserve-iterator.patch
b10643ac 153Patch60: %{name}-python-sitescriptdir.patch
a6170fd4 154Patch61: %{name}-clean-docdir.patch
108e9711 155Patch62: %{name}-DB_CONFIG.patch
fb11a0dd 156Patch63: %{name}-pythoneggs.patch
80e5119e 157Patch64: %{name}-fix-compress-doc.patch
94807250 158Patch65: %{name}-parseSpec-skip-empty-tags.patch
10526c23 159Patch66: %{name}-payload-use-hashed-inode.patch
4e2db228 160Patch67: %{name}-repackage-dont-force-max-compression.patch
4e2db228 161Patch70: python-%{name}sense-missingok.patch
497556c4 162Patch71: %{name}-changelog-encoding.patch
c065c1c1 163Patch72: %{name}-preserve-tag-type.patch
68dafc6c
ER
164Patch74: %{name}-fix-internal-lua-build.patch
165Patch75: %{name}-double_check_file_deps.patch
5666ceed 166Patch77: %{name}-lua-expat.patch
3a3e476f 167Patch78: %{name}-double_check_unpackaged_subdirs.patch
5131d1d1 168Patch79: %{name}-rpmspec.patch
6d1e99c9 169Patch80: %{name}-revert-gpg-argv-parsing.patch
9d486499 170Patch81: %{name}-perl-magic.patch
64b1e365 171Patch82: %{name}-5.4.15-use-DSA-sig.patch
10a92209 172Patch83: %{name}-ignore-missing-macro-files.patch
321b78b0 173Patch84: x32.patch
8dc5e023
JR
174Patch85: rpm-CVE-2013-6435.patch
175Patch86: rpm-CVE-2014-8118.patch
0959ed6d 176Patch87: %{name}-file-output-for-ELF.patch
1c02955f 177Patch88: %{name}-rpmtdnext.patch
8b6cca9f 178Patch89: disable-header-verification.patch
a98c8118 179Patch90: %{name}-cppcompat.patch
d397adc8 180Patch91: py-disable-fetch.patch
8029452c 181Patch92: fast_python_deps.patch
b5cd30d4 182Patch93: python2_explicit.patch
7d0a808e 183Patch94: do_not_write_before_macro_buffer.patch
70f8787d
JR
184
185# Patches imported from Mandriva
186
187# status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
188# would basically just mean backporting it..
f09b01ac 189Patch1000: %{name}-5.4.4-add-_specfile-macro.patch
70f8787d
JR
190# status: needs to be cleaned up and properly reviewed together with rest
191# of the patches related to dependency generation
f09b01ac 192Patch1001: %{name}-5.4.9-avoid-dependencies-on-self.patch
70f8787d 193# status: probably ready to merge
f09b01ac 194Patch1002: %{name}-5.4.4-pkgconfigdeps-check-path.patch
70f8787d 195# status: probably okay to merge, but discuss on rpm-devel first
f09b01ac 196Patch1003: %{name}-5.4.4-glob-wildcards-for-loading-macro-files.patch
70f8787d 197# status: needs to be discussed
f09b01ac 198Patch1004: %{name}-5.4.4-allow-installation-of-repackaged-rpms.patch
70f8787d 199# status: ready to merge
f09b01ac 200Patch1005: %{name}-5.4.8-dont-show-suggests-with-requires.patch
70f8787d 201# status: ready for merge
f09b01ac 202Patch1006: %{name}-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
70f8787d 203# status: probably okay to merge, but discuss on rpm-devel first
f09b01ac 204Patch1007: %{name}-5.4.10-duplicate_files_terminate_build.patch
70f8787d 205# status: same as above
f09b01ac 206Patch1008: %{name}-5.4.10-unpackaged_subdirs_terminate_build.patch
70f8787d
JR
207# mdvbz#64898
208# status: uncertain, might be okay to merge, discuss on rpm-devel first
f09b01ac 209Patch1009: %{name}-5.4.4-rpmbuild-withoutclean.patch
70f8787d
JR
210# no sense in having an additional dependency on 'pkgconfig' on all packages that
211# have a pkgconfig file, it's not needed for them to be made useful and anything
212# actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
213# status: might be okay to merge, but discuss on rpm-devel first
f09b01ac 214Patch1010: %{name}-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
70f8787d 215# status: ready for merge
f09b01ac 216Patch1011: %{name}-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
70f8787d
JR
217# $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
218# %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
219# status: needs to be discussed and investigated a bit better..
f09b01ac 220Patch1012: %{name}-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
70f8787d 221# status: probably okay to merge, but discuss on rpm-devel first
f09b01ac 222Patch1013: %{name}-5.4.10-files-listed-twice-terminates-build.patch
70f8787d 223# status: probably okay to merge
f09b01ac 224Patch1014: %{name}-5.4.9-ruby1.9-fixes.patch
70f8787d 225# status: keep locally
f09b01ac 226Patch1015: %{name}-5.4.9-keep-loading-script-macros.patch
70f8787d 227# status: same as for other dep gen patches
f09b01ac 228Patch1016: %{name}-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
70f8787d 229# status: idem
f09b01ac 230Patch1017: %{name}-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
70f8787d 231# status: probably okay to merge
f09b01ac 232Patch1019: %{name}-5.4.5-python-export-spec-macros.patch
70f8787d 233# status: idem
f09b01ac 234Patch1020: %{name}-5.4.9-font-provides.patch
70f8787d 235# stauus: idem
f09b01ac 236Patch1021: %{name}-5.4.7-kmod-dependencies.patch
70f8787d 237# status: probably okay to merge, discuss on rpm-devel first
f09b01ac 238Patch1022: %{name}-5.4.5-skip-dependencies-for-character-devices.patch
70f8787d 239# status: probably okay to merge
f09b01ac 240Patch1024: %{name}-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
70f8787d 241# status: probably okay to merge
f09b01ac 242Patch1026: %{name}-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
70f8787d 243# status: ready
f09b01ac 244Patch1027: %{name}-5.4.7-fix-generation-of-ruby-abi-provides.patch
70f8787d
JR
245# crash reproducable with 'rpm -qa --triggers'
246# status: ready
f09b01ac 247Patch1028: %{name}-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
70f8787d 248# status: same as for other dep gen patches
f09b01ac 249Patch1029: %{name}-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
70f8787d 250# status: ready
f09b01ac 251Patch1030: %{name}-5.4.7-fix-minor-memleaks.patch
70f8787d 252# status: ready
f09b01ac 253Patch1031: %{name}-5.4.9-mire-fix-strings-lacking-null-terminator.patch
70f8787d 254# status: ready
f09b01ac 255Patch1032: %{name}-5.4.9-rpmpython-fix-input.patch
70f8787d 256# status: ready
f09b01ac 257Patch1033: %{name}-5.4.7-no-seqid_init-on-rdonly-database.patch
70f8787d 258# status: probably ready for merging
f09b01ac 259Patch1034: %{name}-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
70f8787d 260# status: probably ready to merge, discuss on rpm-devel first
f09b01ac 261Patch1035: %{name}-5.4.9-fix-verify-segfault.patch
70f8787d
JR
262# Due to rpmdav/neon being written in a different fashion than other rpmio clients,
263# the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
264# with the result being that when unable to download files, neon will save error
265# page as the target file.
266# status: should go upstream, but uncertain about "correct" fix, ie. this is
267# more of a workaround, while rewriting rpmdav code to behave consistently
268# would be "the right thing to do". Yet I'm not fully able to grasp all of the
269# code and don't want to spend more time just to get the API..
f09b01ac 270Patch1037: %{name}-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
70f8787d
JR
271# As the transaction flags for ignoring arch & os are no longer used, there's
272# currently no way to ignore arch & os of packages anymore. This patch adds
273# support for doing this again by defining rpm variables and overriding
274# --ignorearch & --ignoreos to set these.
275# status: needs to be discussed upstream before thinking about merging
f09b01ac 276Patch1038: %{name}-5.4.10-support-ignore-arch-and-os-again.patch
9f9190ed 277# status: ready for merge
f09b01ac 278Patch1039: %{name}-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
e85b33bb 279# we want that patch too, a bit of builder infrastructure relies on NOSIGNATURES
f09b01ac 280Patch1040: %{name}-5.4.9-support-signatures-and-digest-disablers.patch
5555c3a0
JR
281# lack insight on actual functionality, which anyways seems broken, so let's
282# disable it to avoid errors from berkeley db..
283# status: keep locally
f09b01ac 284Patch1041: %{name}-5.4.9-disable-l10ndir.patch
dfd6cb49 285# status: ready for merge
f09b01ac 286Patch1042: %{name}-5.4.9-fix-rpm_qa-pattern.patch
221ad213
JR
287# warning: introduces memory leak
288Patch1043: %{name}-5.4.12-copy-Value-string.patch
7d3aa060 289Patch1044: %{name}-5.4.12-fix-rpmlua-print.patch
846d6870 290Patch1045: %{name}-5.4.12-fix-rpmpython-module-import-init.patch
6608973b 291Patch1046: %{name}-5.4.12-truncate-output-buffer-after-use.patch
a32fd84f 292Patch1047: %{name}-5.4.13-perl-bindings-do-not-use-xmalloc.patch
0004e9b0
ER
293# proyvind:
294# there's a rpmdbchk tool I wrote a while back, which might help you. although
295# the incidents it's able to deal with is rather limited ATM... it might help
296# you out, if not and you'll be able to solve yer problem, you could take a
297# stab at adding support for fixing your specific problem to the util ;)
298# https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-rpmdbchk.patch
299Patch1048: %{name}-5.4.14-rpmdbchk.patch
300# https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-no-assert-abort-with-broken-headers.patch
301Patch1049: %{name}-5.4.14-no-assert-abort-with-broken-headers.patch
70f8787d 302
883e0fac
WF
303Patch1050: python-libx32.patch
304
955f2725 305URL: http://rpm5.org/
cf169f7c 306BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
6f6c7465
JR
307%if %{with sqlite}
308BuildRequires: sqlite3-devel
309%else
cf169f7c 310BuildRequires: %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
6f6c7465 311%endif
29855fc2 312BuildRequires: autoconf >= 2.63
644d8958 313BuildRequires: automake >= 1.4
87ef0d95 314BuildRequires: beecrypt-devel >= %{beecrypt_ver}
33be5db0 315BuildRequires: bzip2-devel >= 1.0.2-17
33be5db0 316BuildRequires: elfutils-devel >= 0.108
3e70c06e 317BuildRequires: gettext-tools >= 0.19.2
d0ee0933 318%{?with_keyutils:BuildRequires: keyutils-devel}
241257bf 319BuildRequires: libmagic-devel
6e115b23
JR
320%if %{with selinux}
321BuildRequires: libselinux-devel >= 2.1.0
6e115b23 322BuildRequires: libsemanage-devel >= 2.1.0
3acb62f3 323BuildRequires: libsepol-devel >= 2.1.0
6e115b23 324%endif
84cdee7a
JB
325# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
326BuildRequires: libstdc++-devel
b60c74c3 327BuildRequires: libtool >= 1:1.4.2-9
33be5db0 328%if %{with neon}
fe861705 329BuildRequires: libxml2-devel
83d6a3fe 330BuildRequires: neon-devel >= 0.25.5
33be5db0 331%endif
95bd7348 332%{?with_system_lua:BuildRequires: lua52-devel >= 5.2.2}
127a0b3c 333BuildRequires: ossp-uuid-devel
7973b351 334BuildRequires: patch >= 2.2
1d49ffbc 335BuildRequires: popt-devel >= %{reqpopt_ver}
950eead3
ER
336%{?with_python:BuildRequires: python-devel >= 1:2.3}
337BuildRequires: python-modules >= 1:2.3
2a813afe 338%{?with_python:BuildRequires: rpm-pythonprov}
e56a10a9 339BuildRequires: tcl
77fcdbf7 340BuildRequires: xz-devel
3acb62f3 341BuildRequires: zlib-devel
5c2ab5c7
AM
342%if %{with apidocs}
343BuildRequires: doxygen
344BuildRequires: ghostscript
345BuildRequires: graphviz
346BuildRequires: tetex-pdftex
347%endif
a6e56ce4 348%if %{with static}
e6090a7b 349# Require static library only for static build
cf169f7c 350BuildRequires: %{reqdb_pkg}-static >= %{reqdb_pkgver}
87ef0d95 351BuildRequires: beecrypt-static >= %{beecrypt_ver}
33be5db0 352BuildRequires: bzip2-static >= 1.0.2-17
290c1c30 353BuildRequires: elfutils-static
10abbd40 354BuildRequires: glibc-static >= 2.2.94
241257bf 355BuildRequires: libmagic-static
6e115b23
JR
356%if %{with selinux}
357BuildRequires: libselinux-static >= 2.1.0
6e115b23 358BuildRequires: libsemanage-static >= 2.1.0
3acb62f3 359BuildRequires: libsepol-static >= 2.1.0
6e115b23 360%endif
003a039e 361BuildRequires: popt-static >= %{reqpopt_ver}
1d49ffbc 362BuildRequires: zlib-static
7a9d72ce 363%endif
d25ec6ea 364Requires(posttrans): coreutils
66edd895 365Requires: %{name}-base = %{version}-%{release}
b26a9709 366Requires: %{name}-lib = %{version}-%{release}
10abbd40
ER
367Requires: beecrypt >= %{beecrypt_ver}
368Requires: popt >= %{reqpopt_ver}
0229a8b9
AM
369Provides: rpm-db-ver = %{reqdb_ver}
370Obsoletes: rpm-getdeps
4adb7d05 371%{!?with_static:Obsoletes: rpm-utils-static}
874f4c9a 372Conflicts: glibc < 2.2.92
8ee1c72c
AM
373# db4.6 poldek needed
374Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
375# segfaults with lzma 0.42.2
376Conflicts: lzma-libs < 4.999.3
e4084afd 377Conflicts: util-vserver < 0.30.216-1.pre3034.7
1d49ffbc 378BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 379
4adb7d05 380%define _binary_payload w9.gzdio
6d82b332 381
4cd84746
JB
382# don't require very fresh rpm.macros to build
383%define __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
950eead3 384%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
9f517079 385%define ix86 i386 i486 i586 i686 athlon pentium3 pentium4
80e9f34d 386%define ppc ppc ppc7400 ppc7450
9f517079 387%define x8664 amd64 ia32e x86_64
4cd84746 388
89427592 389# stabilize new build environment
866e45c8 390%ifnarch x32
f9ac32aa
AM
391%define __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
392%define __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
393%define __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
866e45c8
JR
394%else
395# x32 is a very special case
396%define __newcc %{?force_cc}%{!?force_cc:x86_64-pld-linux-gnux32-gcc}
397%define __newcxx %{?force_cxx}%{!?force_cxx:x86_64-pld-linux-gnux32-g++}
398%define __newcpp %{?force_cpp}%{!?force_cpp:x86_64-pld-linux-gnux32-gcc -E}
399%endif
89427592 400
d755a548 401%define _rpmlibdir /usr/lib/rpm
950eead3 402%define _noautocompressdoc RPM-GPG-KEY
d755a548 403
ff7bc1e6 404%description
405RPM is a powerful package manager, which can be used to build,
406install, query, verify, update, and uninstall individual software
cf6faebc 407packages. A package consists of an archive of files, and package
fed73700 408information, including name, version, and description.
409
dd85fadc
JR
410%description -l de.UTF-8
411RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 412Installation, Anfrage, Verifizierung, Aktualisierung und
413Uninstallation individueller Softwarepakete. Ein Paket besteht aus
414einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 415Beschreibung.
416
dd85fadc 417%description -l es.UTF-8
313a4d1a 418RPM es un poderoso administrador de paquetes, que puede ser usado para
419construir, instalar, pesquisar, verificar, actualizar y desinstalar
420paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
421almacenaje de archivos, y información sobre el paquete, incluyendo
422nombre, versión y descripción.
423
424%description -l pl.UTF-8
425RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
426przebudowanie, instalację czy weryfikację dowolnego pakietu.
427Informacje dotyczące każdego pakietu, takie jak jego opis, lista
428plików wchodzących w skład pakietu, zależności od innych pakietów, są
429przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 430odpytywania programu rpm.
431
dd85fadc
JR
432%description -l pt_BR.UTF-8
433RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 434construir, instalar, pesquisar, verificar, atualizar e desinstalar
435pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
436arquivos e informações adicionais, incluindo nome, versão e descrição
437do pacote, permissões dos arquivos, etc.
438
439%description -l ru.UTF-8
440RPM - это мощный менеджер пакетов, который может быть использован для
441создания, инсталляции, запросов (query), проверки, обновления и
442удаления программных пакетов. Пакет состоит из файлового архива и
443служебной информации, включающей название, версию, описание и другие
444данные о пакете.
445
446%description -l uk.UTF-8
447RPM - це потужний менеджер пакетів, що може бути використаний для
448створення, інсталяції, запитів (query), перевірки, поновлення та
449видалення програмних пакетів. Пакет складається з файлового архіву та
450службової інформації, що містить назву, версію, опис та іншу
451інформацію про пакет.
7c6dc55f 452
66edd895
JB
453%package base
454Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 455Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 456Group: Base
1d9ca0c1 457Requires: filesystem
950eead3 458Obsoletes: rpm-scripts
66edd895
JB
459Obsoletes: vserver-rpm
460
461%description base
462The RPM base package contains scripts used by rpm packages themselves.
463These include:
464- scripts for adding/removing groups and users needed for rpm
465 packages,
466- banner.sh to display %%banner messages from rpm scriptlets.
467
dd85fadc
JR
468%description base -l pl.UTF-8
469Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 470Zawiera on:
dd85fadc
JR
471- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
472- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 473
69131f1a
JB
474%package lib
475Summary: RPMs library
4ea2ed33 476Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 477Group: Libraries
cf169f7c 478Requires: %{reqdb_pkg} >= %{reqdb_pkgver}
6f6c7465
JR
479%if %{with sqlite}
480Requires: sqlite3 >= %{sqlite_build_version}
481%else
cf169f7c 482Requires: %{reqdb_pkg}-sql >= %{reqdb_pkgver}
6f6c7465 483%endif
3acb62f3 484Requires: beecrypt >= %{beecrypt_ver}
241257bf 485Requires: libmagic >= 1.15-2
6e115b23 486%{?with_selinux:Requires: libselinux >= 2.1.0}
69131f1a 487Requires: popt >= %{reqpopt_ver}
d1795eb0 488Obsoletes: rpm-libs
69131f1a
JB
489# avoid SEGV caused by mixed db versions
490Conflicts: poldek < 0.18.1-16
491
492%description lib
493RPMs library.
494
dd85fadc 495%description lib -l pl.UTF-8
69131f1a
JB
496Biblioteki RPM-a.
497
fed73700 498%package devel
3f2d796a 499Summary: Header files for rpm libraries
4ea2ed33
ER
500Summary(de.UTF-8): Header-Dateien für rpm Libraries
501Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
502Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
503Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
504Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
505Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 506Group: Development/Libraries
153e5706 507Requires: %{name}-lib = %{version}-%{release}
cf169f7c 508Requires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
87ef0d95 509Requires: beecrypt-devel >= %{beecrypt_ver}
fea3cb89 510Requires: bzip2-devel
5c583f90 511Requires: elfutils-devel
d0ee0933 512%{?with_keyutils:Requires: keyutils-devel}
241257bf 513Requires: libmagic-devel
c7b2d5f9
KK
514%if %{with selinux}
515Requires: libselinux-devel
516Requires: libsemanage-devel
517Requires: libsepol-devel
518%endif
a998ac11 519Requires: popt-devel >= %{reqpopt_ver}
fea3cb89 520Requires: zlib-devel
cf6faebc 521
522%description devel
3f2d796a
JB
523The RPM packaging system includes C libraries that make it easy to
524manipulate RPM packages and databases. They are intended to ease the
cf6faebc 525creation of graphical package managers and other tools that need
3f2d796a
JB
526intimate knowledge of RPM packages. This package contains header files
527for these libraries.
fed73700 528
dd85fadc
JR
529%description devel -l de.UTF-8
530Der RPM-Packensystem enthält eine C-Library, die macht es einfach
531RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 532Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 533Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
534
dd85fadc 535%description devel -l es.UTF-8
313a4d1a 536El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
537fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
538facilitar la creación de administradores gráficos de paquetes y otras
20f89981 539herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 540
dd85fadc
JR
541%description devel -l pl.UTF-8
542System RPM zawiera biblioteki C, które ułatwiają manipulowanie
543pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
544graficznych programów zarządzających pakietami oraz innych narzędzi,
545które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
546zawiera pliki nagłówkowe wspomnianych bibliotek.
547
548%description devel -l pt_BR.UTF-8
549O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
550a manipulação de pacotes e bases de dados RPM. Seu objetivo é
551facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 552ferramentas que precisem de conhecimento profundo de pacotes RPM.
553
dd85fadc
JR
554%description devel -l ru.UTF-8
555Система управления пакетами RPM содержит библиотеку C, которая
556упрощает манипуляцию пакетами RPM и соответствующими базами данных.
557Эта библиотека предназначена для облегчения создания графических
558пакетных менеджеров и других утилит, которым необходимо работать с
559пакетами RPM.
7c6dc55f 560
dd85fadc
JR
561%description devel -l uk.UTF-8
562Система керування пакетами RPM містить бібліотеку C, котра спрощує
563роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
564призначена для полегшення створення графічних пакетних менеджерів та
565інших утиліт, що працюють з пакетами RPM.
7c6dc55f 566
fed73700 567%package static
9e42d68a 568Summary: RPM static libraries
4ea2ed33
ER
569Summary(de.UTF-8): RPMs statische Libraries
570Summary(pl.UTF-8): Biblioteki statyczne RPM-a
571Summary(pt_BR.UTF-8): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
572Summary(ru.UTF-8): Статическая библиотека для программ, работающих с rpm-пакетами
573Summary(uk.UTF-8): Статична бібліотека для програм, що працюють з пакетами rpm
edacdf8f 574Group: Development/Libraries
153e5706 575Requires: %{name}-devel = %{version}-%{release}
cf169f7c 576Requires: %{reqdb_pkg}-static >= %{reqdb_pkgver}
87ef0d95 577Requires: beecrypt-static >= %{beecrypt_ver}
df76dbd9 578Requires: bzip2-static
ff03e01a 579Requires: elfutils-static
d0ee0933 580%{?with_keyutils:Requires: keyutils-static}
241257bf 581Requires: libmagic-static
c7b2d5f9
KK
582%if %{with selinux}
583Requires: libselinux-static
584Requires: libsemanage-static
585Requires: libsepol-static
586%endif
a998ac11 587Requires: popt-static >= %{reqpopt_ver}
df76dbd9 588Requires: zlib-static
edacdf8f 589
590%description static
20f89981 591RPM static libraries.
fed73700 592
dd85fadc 593%description static -l de.UTF-8
20f89981 594RPMs statische Libraries.
9e42d68a 595
dd85fadc 596%description static -l pl.UTF-8
0a7ae9bc 597Biblioteki statyczne RPM-a.
313a4d1a 598
dd85fadc
JR
599%description static -l pt_BR.UTF-8
600Bibliotecas estáticas para desenvolvimento.
edacdf8f 601
dd85fadc
JR
602%description static -l ru.UTF-8
603Система управления пакетами RPM содержит библиотеку C, которая
604упрощает манипуляцию пакетами RPM и соответствующими базами данных.
605Это статическая библиотека RPM.
7c6dc55f 606
dd85fadc
JR
607%description static -l uk.UTF-8
608Система керування пакетами RPM містить бібліотеку C, котра спрощує
609роботу з пакетами RPM та відповідними базами даних. Це статична
610бібліотека RPM.
7c6dc55f 611
fed73700 612%package utils
8482995c 613Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
614Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
615Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 616Group: Applications/File
153e5706 617Requires: %{name} = %{version}-%{release}
a998ac11 618Requires: popt >= %{reqpopt_ver}
86b85368
AG
619%if %{with suggest_tags}
620Suggests: bzip2
621Suggests: gzip
86b85368 622%endif
695e60ad 623Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 624
625%description utils
8482995c 626Additional utilities for managing RPM packages and database.
fed73700 627
dd85fadc
JR
628%description utils -l de.UTF-8
629Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 630
dd85fadc
JR
631%description utils -l pl.UTF-8
632Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 633
92b3f576 634%package utils-perl
8482995c 635Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
636Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
637Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
92b3f576 638Group: Applications/File
153e5706 639Requires: %{name}-utils = %{version}-%{release}
92b3f576 640Requires: popt >= %{reqpopt_ver}
641
642%description utils-perl
8482995c 643Additional utilities for managing RPM packages and database.
92b3f576 644
dd85fadc
JR
645%description utils-perl -l de.UTF-8
646Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
92b3f576 647
dd85fadc
JR
648%description utils-perl -l pl.UTF-8
649Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
92b3f576 650
a00926bc
JB
651%package utils-static
652Summary: Static rpm utilities
4ea2ed33 653Summary(pl.UTF-8): Statyczne narzędzia rpm
a00926bc 654Group: Applications/System
153e5706 655Requires: %{name} = %{version}-%{release}
a00926bc
JB
656
657%description utils-static
658Static rpm utilities for repairing system in case something with
659shared libraries used by rpm become broken. Currently it contains rpmi
660binary, which can be used to install/upgrade/remove packages without
661using shared libraries (well, in fact with exception of NSS modules).
662
dd85fadc
JR
663%description utils-static -l pl.UTF-8
664Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
665związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
666Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
667uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
668(z wyjątkiem modułów NSS).
a00926bc 669
fed73700 670%package build
e191287c 671Summary: Scripts for building binary RPM packages
4ea2ed33
ER
672Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
673Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
674Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
675Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
676Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 677Group: Applications/File
f15ca8ca
ER
678Requires(pretrans): coreutils
679Requires(pretrans): findutils
adde3998 680Requires: %{name}-build-macros >= 1.699
153e5706 681Requires: %{name}-utils = %{version}-%{release}
e191287c 682Requires: /bin/id
683Requires: awk
cfa7898a 684Requires: bzip2
e950a6d7 685Requires: chrpath >= 0.10-4
b6547e10 686Requires: cpio
e191287c 687Requires: diffutils
195f647c 688Requires: elfutils
583135b4 689Requires: file >= 4.17
e191287c 690Requires: fileutils
691Requires: findutils
950eead3
ER
692%ifarch athlon
693Requires: gcc >= 3.0.3
694%else
695Requires: gcc
696%endif
e191287c 697Requires: glibc-devel
698Requires: grep
699Requires: gzip
700Requires: make
701Requires: patch
adbd4815 702Requires: sed >= 4.0
e191287c 703Requires: sh-utils
adbd4815 704Requires: tar >= 1:1.22
e191287c 705Requires: textutils
3acb62f3 706Requires: which
adbd4815 707Requires: xz
ca3648b1 708Provides: rpmbuild(monoautodeps)
37ea389a 709Provides: rpmbuild(noauto) = 3
02d17bf9 710%ifarch %{x8664}
195f647c
JB
711Conflicts: automake < 1:1.7.9-2
712Conflicts: libtool < 2:1.5-13
713%endif
0096c5cd 714
e2025ad1 715%description build
58399c37 716Scripts for building binary RPM packages.
fed73700 717
dd85fadc
JR
718%description build -l de.UTF-8
719Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 720
dd85fadc
JR
721%description build -l pl.UTF-8
722Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 723
dd85fadc
JR
724%description build -l pt_BR.UTF-8
725Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 726construir pacotes usando o RPM.
e73478cd 727
dd85fadc
JR
728%description build -l ru.UTF-8
729Различные вспомогательные скрипты и исполняемые программы, которые
730используются для сборки RPM'ов.
7c6dc55f 731
dd85fadc
JR
732%description build -l uk.UTF-8
733Різноманітні допоміжні скрипти та утиліти, які використовуються для
734побудови RPM'ів.
7c6dc55f 735
8482995c
JB
736%package javaprov
737Summary: Additional utilities for checking Java provides/requires in RPM packages
738Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
739Group: Applications/File
740Requires: %{name} = %{version}-%{release}
741Requires: file
742Requires: findutils >= 1:4.2.26
743Requires: mktemp
744Requires: unzip
745
746%description javaprov
747Additional utilities for checking Java provides/requires in RPM
748packages.
749
750%description javaprov -l pl.UTF-8
751Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
752RPM.
753
69131f1a 754%package perlprov
8482995c 755Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 756Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 757Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a
JB
758Group: Applications/File
759Requires: %{name} = %{version}-%{release}
b82853ee 760Requires: perl-Encode
69131f1a
JB
761Requires: perl-devel
762Requires: perl-modules
763
764%description perlprov
8482995c 765Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
766packages.
767
dd85fadc
JR
768%description perlprov -l de.UTF-8
769Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 770
dd85fadc 771%description perlprov -l pl.UTF-8
8482995c
JB
772Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
773pakietach RPM.
69131f1a
JB
774
775%package pythonprov
8482995c
JB
776Summary: Python macros, which simplifies creation of RPM packages with Python software
777Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a
JB
778Group: Applications/File
779Requires: %{name} = %{version}-%{release}
cd800b3c 780Requires: python
cfbc7086 781Requires: python-setuptools
3acb62f3 782Requires: python-modules
69131f1a
JB
783
784%description pythonprov
8482995c 785Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
786software.
787
dd85fadc 788%description pythonprov -l pl.UTF-8
8482995c 789Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
790Pythonie.
791
792%package php-pearprov
8482995c
JB
793Summary: Additional utilities for checking PHP PEAR provides/requires in RPM packages
794Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
69131f1a
JB
795Group: Applications/File
796Requires: %{name} = %{version}-%{release}
632f1b5c 797Requires: sed >= 4.0
1b39d378 798Suggests: php-pear-PHP_CompatInfo
69131f1a
JB
799
800%description php-pearprov
8482995c 801Additional utilities for checking PHP PEAR provides/requires in RPM
69131f1a
JB
802packages.
803
dd85fadc 804%description php-pearprov -l pl.UTF-8
8482995c
JB
805Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
806pakietach RPM.
69131f1a 807
ec49e9fb
ER
808%package rubyprov
809Summary: Ruby tools, which simplify creation of RPM packages with Ruby software
810Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
811Group: Applications/File
812Requires: %{name} = %{version}-%{release}
813Requires: ruby
814Requires: ruby-modules
b53b1f84 815Requires: ruby-rubygems
ec49e9fb
ER
816
817%description rubyprov
818Ruby tools, which simplifies creation of RPM packages with Ruby
819software.
820
821%description rubyprov -l pl.UTF-8
822Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
823Ruby.
824
69131f1a
JB
825%package -n python-rpm
826Summary: Python interface to RPM library
4ea2ed33
ER
827Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
828Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a
JB
829Group: Development/Languages/Python
830Requires: %{name} = %{version}-%{release}
3acb62f3 831Requires: python
69131f1a
JB
832Obsoletes: rpm-python
833
834%description -n python-rpm
835The rpm-python package contains a module which permits applications
836written in the Python programming language to use the interface
837supplied by RPM (RPM Package Manager) libraries.
838
839This package should be installed if you want to develop Python
840programs that will manipulate RPM packages and databases.
841
dd85fadc
JR
842%description -n python-rpm -l pl.UTF-8
843Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
844Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 845
dd85fadc
JR
846Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
847Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 848
dd85fadc
JR
849%description -n python-rpm -l pt_BR.UTF-8
850O pacote rpm-python contém um módulo que permite que aplicações
69131f1a
JB
851escritas em Python utilizem a interface fornecida pelas bibliotecas
852RPM (RPM Package Manager).
853
dd85fadc 854Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
855Python para manipular pacotes e bancos de dados RPM.
856
5c2ab5c7
AM
857%package apidocs
858Summary: RPM API documentation and guides
859Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
860Group: Documentation
d308de4c
ER
861%if "%{_rpmversion}" >= "5"
862BuildArch: noarch
863%endif
5c2ab5c7
AM
864
865%description apidocs
866Documentation for RPM API and guides in HTML format generated from rpm
867sources by doxygen.
868
869%description apidocs -l pl.UTF-8
870Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
871źrodeł RPM-a przez doxygen.
872
e2025ad1 873%prep
c546a4d6
ER
874%setup -q -n %{name}-%{version}%{?subver}
875install -d platform
876cd platform
877ar x %{SOURCE100}
878cd -
879
317ef122 880#patch0 -p1
2f0ee4ec 881%patch1 -p1
4d5b8e4c 882%patch2 -p1
c0fe6b09 883%patch3 -p1
7a3b1f24
AM
884%patch4 -p1
885%patch5 -p1
3c7590cc 886%patch6 -p1
c1768ce2 887%patch7 -p1
7a3b1f24 888%patch8 -p1
3c7590cc 889%{?with_system_lua:%patch9 -p1}
9ee75c3c 890%patch10 -p1
686b0204
JR
891%ifnarch i386 i486
892# enable TSC for capable archs
9ee75c3c 893%patch11 -p1
3c7590cc 894%endif
9ee75c3c
JR
895%patch12 -p1
896%patch13 -p1
897%patch14 -p0
7033e976 898%patch15 -p1
9ee75c3c 899%patch16 -p1
3c7590cc
JR
900%patch17 -p1
901%patch18 -p1
902%patch19 -p1
903%patch20 -p1
904%patch21 -p1
9ee75c3c 905%ifarch sparc64
3c7590cc 906%patch22 -p1
9ee75c3c 907%endif
3c7590cc 908%patch23 -p1
3c7590cc 909%patch24 -p1
3c7590cc 910%patch25 -p1
24123ddd 911%patch27 -p1
3c7590cc
JR
912%patch28 -p1
913%patch29 -p1
914%patch30 -p1
915%patch31 -p1
916%patch32 -p1
917%patch33 -p1
950eead3 918%patch34 -p1
3c7590cc 919%patch35 -p1
148c9957 920%patch36 -p1
3c7590cc
JR
921%patch37 -p1
922%patch38 -p1
923%patch39 -p1
924%patch40 -p1
7f47af9c 925%{?with_db61:%patch41 -p1}
9ee75c3c 926%patch42 -p1
9f9190ed 927%patch43 -p1
1d20bd4e 928%patch44 -p1
e94735a5 929%patch45 -p1
7070b427 930%patch46 -p1
358bccd1 931%patch47 -p1
7f7a3f24 932%patch48 -p1
295c267a 933%patch49 -p1
d6a36788 934%patch50 -p1
bba1059c 935%patch51 -p1
1fcc9b69 936%patch52 -p0
70df63f3 937%patch53 -p1
330093fa 938%patch54 -p1
9158f140 939%patch55 -p1
267d7641 940%patch56 -p1
7f47af9c 941%{!?with_db61:%patch57 -p1}
c4861085 942%patch58 -p1
b10643ac 943%patch60 -p1
a6170fd4 944%patch61 -p1
108e9711 945%patch62 -p1
fb11a0dd 946%patch63 -p1
80e5119e 947%patch64 -p1
94807250 948%patch65 -p1
10526c23 949%patch66 -p1
2f067477 950%patch67 -p1
4cfbd61f 951%patch70 -p1
497556c4 952%patch71 -p1
c065c1c1 953%patch72 -p1
1af80494 954%patch74 -p1
900eb2ad 955%patch75 -p1
5666ceed 956%patch77 -p0
3a3e476f 957%patch78 -p1
5131d1d1 958%patch79 -p1
6d1e99c9 959%patch80 -p1
9d486499 960%patch81 -p0
64b1e365 961%patch82 -p1
321b78b0 962%patch84 -p1
8dc5e023
JR
963%patch85 -p1
964%patch86 -p1
0959ed6d 965%patch87 -p1
1c02955f 966%patch88 -p1
8b6cca9f 967%patch89 -p1
a98c8118 968%patch90 -p1
d397adc8 969%patch91 -p1
765b7c41 970
70f8787d
JR
971%patch1000 -p1
972%patch1001 -p1
973%patch1002 -p1
974%patch1003 -p1
975%patch1004 -p1
976%patch1005 -p1
977%patch1006 -p1
978%patch1007 -p1
979%patch1008 -p1
980%patch1009 -p1
981%patch1010 -p1
982%patch1011 -p1
983%patch1012 -p1
984%patch1013 -p1
985%patch1014 -p1
986%patch1015 -p1
987%patch1016 -p1
988%patch1017 -p1
70f8787d
JR
989%patch1019 -p1
990%patch1020 -p1
991%patch1021 -p1
992%patch1022 -p1
70f8787d 993%patch1024 -p1
70f8787d
JR
994%patch1026 -p1
995%patch1027 -p1
996%patch1028 -p1
997%patch1029 -p1
998%patch1030 -p1
999%patch1031 -p1
1000%patch1032 -p1
1001%patch1033 -p1
1002%patch1034 -p1
1003%patch1035 -p1
85771a72 1004%patch1037 -p1
70f8787d 1005%patch1038 -p1
9f9190ed 1006%patch1039 -p1
e85b33bb 1007%patch1040 -p1
b5280b8b
JR
1008# don't delete, may be usefull if jbj descides to enable this again
1009#%patch1041 -p1
dfd6cb49 1010%patch1042 -p1
221ad213 1011%patch1043 -p1
7d3aa060 1012%patch1044 -p1
846d6870 1013%patch1045 -p1
6608973b 1014%patch1046 -p1
a32fd84f 1015%patch1047 -p1
0004e9b0
ER
1016%patch1048 -p1
1017%patch1049 -p1
70f8787d 1018
10a92209 1019%patch83 -p1
8029452c 1020%patch92 -p1
b5cd30d4 1021%patch93 -p1
7d0a808e 1022%patch94 -p1
10a92209 1023
883e0fac
WF
1024%patch1050 -p1
1025
70f8787d 1026install %{SOURCE2} macros/pld.in
0bf34f68
JR
1027install %{SOURCE8} scripts/php.prov.in
1028install %{SOURCE9} scripts/php.req.in
1029install %{SOURCE11} scripts/perl.prov.in
e2489d8e 1030cp -p %{SOURCE30} scripts/rubygems.rb
63194730 1031cp -p %{SOURCE31} scripts/gem_helper.rb
08697680 1032
9d09e076
ER
1033rm scripts/find-php*
1034
70f8787d 1035%{__mv} -f scripts/perl.req{,.in}
633d1e9e 1036
cd86db2e 1037# generate Group translations to *.po
80b8a1f9 1038awk -f %{SOURCE6} %{SOURCE1}
fefe9d30 1039
91ee86a9 1040install %{SOURCE26} tools/rpmdb_checkversion.c
8e8746c0 1041install %{SOURCE28} tools/rpmdb_reset.c
91ee86a9 1042
f012e16d 1043for extlib in beecrypt neon %{?with_system_pcre:pcre} popt; do
95bd7348
JR
1044 [ -d $extlib ] && %{__rm} -r $extlib
1045done
1046
87ef0d95 1047%build
ea816ea6 1048%{__libtoolize}
c0a9be8f 1049#%{__autopoint}
ceaaacee 1050%{__aclocal}
4cd84746 1051%{__autoheader}
7a9d72ce 1052%{__autoconf}
7a9d72ce 1053%{__automake}
7a9d72ce 1054
048d06f8
JR
1055# rpm checks for CPU type at runtime, but it looks better
1056sed -i \
1057 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
1058 -e 's|@host_cpu@|%{_target_cpu}|' \
1059 -e 's|@host_os@|%{_target_os}|' \
3f84726d 1060 macros/macros.in
048d06f8 1061
d268a169 1062%{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
89427592 1063# pass CC and CXX too in case of building with some older configure macro
624f96ff 1064%configure \
f9ac32aa
AM
1065 CC="%{__newcc}" \
1066 CXX="%{__newcxx}" \
1067 CPP="%{__newcpp}" \
01d7a578 1068 WITH_PERL_VERSION=no \
bba1059c 1069 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
3a3e476f 1070 --disable-silent-rules \
cd86db2e 1071 --enable-shared \
874f4c9a 1072 --enable-static \
5c2ab5c7 1073 %{!?with_apidocs:--without-apidocs} \
241257bf 1074 --with-beecrypt=external \
3a3e476f
JB
1075 --with-bugreport="http://bugs.pld-linux.org/" \
1076 --with-bzip2=external \
57256551
JR
1077 --with-db=external \
1078 --with-dbapi=db \
3a3e476f
JB
1079 --with-file=external \
1080 --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
1081 --with-libelf \
6a8612bc 1082 --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
3a3e476f
JB
1083 --with-lzma=external \
1084 --with-neon=%{?with_neon:external}%{!?with_neon:no} \
8a13e4c4 1085 --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/%%{_target}/macros:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
3a3e476f 1086 --without-path-versioned \
f012e16d 1087 --with-pcre=%{!?with_system_pcre:internal}%{?with_system_pcre:external} \
3a3e476f
JB
1088 --with-popt=external \
1089 %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
1090 %{!?with_python:--without-python} \
1091 --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
1092 --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
1093 --with-sepol=%{!?with_selinux:no}%{?with_selinux:external} \
1094 --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
127a0b3c 1095 --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
3a3e476f
JB
1096 --with-vendor=pld \
1097 --with-xz=external \
1098 --with-zlib=external
cf6faebc 1099
25e974c7 1100%{__make} -j1 \
f9ac32aa
AM
1101 CC="%{__cc}" \
1102 CXX="%{__cxx}" \
241257bf 1103 CPP="%{__cpp}"
33be5db0 1104
5c2ab5c7
AM
1105%{?with_apidocs:%{__make} apidocs}
1106
fb95de52
JR
1107%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
1108 -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
8e8746c0
JR
1109%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
1110 -o tools/rpmdb_reset -ldb-%{reqdb_ver}
fb95de52
JR
1111
1112if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
1113 echo "Error linking rpmdb tools!"
1114 exit 1
1115fi
8e8746c0
JR
1116if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
1117 echo "Error linking rpmdb tools!"
1118 exit 1
1119fi
91ee86a9 1120
b064b8e6 1121%install
ff7bc1e6 1122rm -rf $RPM_BUILD_ROOT
e9eb00af 1123install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
51081e43 1124 $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
54eb1770 1125
0bf34f68 1126install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 1127
26a5bf70 1128%{__make} -j1 install \
241257bf
AM
1129 pkgconfigdir=%{_pkgconfigdir} \
1130 DESTDIR=$RPM_BUILD_ROOT
718426e1 1131
c546a4d6
ER
1132# install platform macros
1133for f in platform/*macros; do
1134 bn=${f#*/}
1135 fn=${bn%.macros}/macros
1136 install -m644 $f -D %{buildroot}%{_rpmlibdir}/$fn
1137done
1138
1139# cleanup
c2683840 1140%ifnarch %{ix86} %{x8664} x32
c546a4d6
ER
1141rm $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
1142rm $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
1143rm $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
1144rm $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
1145rm $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
1146rm $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
1147rm $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
25ac75ae
AM
1148%endif
1149
c2683840 1150%ifnarch %{x8664} x32
c546a4d6 1151rm $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
851689fd 1152rm $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
c2683840 1153rm $RPM_BUILD_ROOT%{_rpmlibdir}/x32-linux/macros
851689fd 1154rm $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
25ac75ae
AM
1155%endif
1156
c546a4d6
ER
1157%ifnarch %{ppc}
1158rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
25ac75ae
AM
1159%endif
1160
c546a4d6
ER
1161rm $RPM_BUILD_ROOT%{_rpmlibdir}/alpha*-linux/macros
1162rm $RPM_BUILD_ROOT%{_rpmlibdir}/arm*-linux/macros
1163rm $RPM_BUILD_ROOT%{_rpmlibdir}/ia64-linux/macros
1164rm $RPM_BUILD_ROOT%{_rpmlibdir}/k6-linux/macros
1165rm $RPM_BUILD_ROOT%{_rpmlibdir}/mips*-linux/macros
1166rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc*series-linux/macros
1167rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc64*-linux/macros
1168rm $RPM_BUILD_ROOT%{_rpmlibdir}/s390*-linux/macros
1169rm $RPM_BUILD_ROOT%{_rpmlibdir}/sparc*-linux/macros
c546a4d6 1170
2eb9303e 1171cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
ca076ee5 1172# first platform file entry can't contain regexps
c2683840
JR
1173%ifarch x32
1174%{_target_cpu}-%{_target_vendor}-linux-gnux32
1175%else
2eb9303e 1176%{_target_cpu}-%{_target_vendor}-linux
c2683840 1177%endif
caf453d4 1178
2d8ae03e 1179%ifarch x86_64
53fd58bc 1180x86_64-[^-]*-[Ll]inux(-gnu)?
9cfcb6c8 1181amd64-[^-]*-[Ll]inux(-gnu)?
c2683840 1182x32-[^-]*-[Ll]inux(-gnu(x32)?)?
2d8ae03e 1183%endif
2d8ae03e 1184%ifarch amd64
53fd58bc
AM
1185amd64-[^-]*-[Ll]inux(-gnu)?
1186x86_64-[^-]*-[Ll]inux(-gnu)?
c2683840 1187x32-[^-]*-[Ll]inux(-gnu(x32)?)?
2d8ae03e 1188%endif
2d8ae03e 1189%ifarch ia32e
53fd58bc
AM
1190ia32e-[^-]*-[Ll]inux(-gnu)?
1191x86_64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1192%endif
c2683840
JR
1193%ifarch x32
1194x32-[^-]*-[Ll]inux(-gnu(x32)?)?
1195x86_64-[^-]*-[Ll]inux(-gnu)?
1196amd64-[^-]*-[Ll]inux(-gnu)?
1197%endif
2d8ae03e 1198
c2683840 1199%ifarch athlon %{x8664} x32
53fd58bc 1200athlon-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1201%endif
c2683840 1202%ifarch pentium4 athlon %{x8664} x32
53fd58bc 1203pentium4-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1204%endif
c2683840 1205%ifarch pentium3 pentium4 athlon %{x8664} x32
53fd58bc 1206pentium3-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1207%endif
c2683840 1208%ifarch i686 pentium3 pentium4 athlon %{x8664} x32
53fd58bc 1209i686-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1210%endif
c2683840 1211%ifarch i586 i686 pentium3 pentium4 athlon %{x8664} x32
53fd58bc 1212i586-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1213%endif
c2683840 1214%ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664} x32
53fd58bc 1215i486-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1216%endif
c2683840 1217%ifarch %{ix86} %{x8664} x32
53fd58bc 1218i386-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1219%endif
1220
5074eba9 1221%ifarch alpha
53fd58bc 1222alpha-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1223%endif
1224
1225%ifarch ia64
53fd58bc 1226ia64-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1227%endif
1228
1229%ifarch ppc64
53fd58bc
AM
1230powerpc64-[^-]*-[Ll]inux(-gnu)?
1231ppc64-[^-]*-[Ll]inux(-gnu)?
5074eba9 1232%endif
950eead3 1233%ifarch %{ppc} ppc64
53fd58bc
AM
1234powerpc-[^-]*-[Ll]inux(-gnu)?
1235ppc-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1236%endif
1237
1238%ifarch s390x
53fd58bc 1239s390x-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1240%endif
1241%ifarch s390 s390x
53fd58bc 1242s390-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1243%endif
1244
1245%ifarch sparc64
53fd58bc
AM
1246sparc64-[^-]*-[Ll]inux(-gnu)?
1247sparcv8-[^-]*-[Ll]inux(-gnu)?
1248sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1249%endif
1250%ifarch sparcv9
53fd58bc
AM
1251sparcv8-[^-]*-[Ll]inux(-gnu)?
1252sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1253%endif
1254%ifarch sparc sparcv9 sparc64
53fd58bc 1255sparc-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1256%endif
1257
2eb9303e
ER
1258noarch-[^-]*-.*
1259EOF
2d8ae03e 1260
e5486255
ER
1261# Squash Extra Blank Lines
1262%{__sed} -i -e '/./,/^$/!d' $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
1263
3a3e476f
JB
1264%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1265%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1266%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
1267%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
1268%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.a
1269%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.la
1270%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-provides
1271%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-requires
7cf857f2 1272
644d8958
JB
1273# not installed since 4.4.8 (-tools-perl subpackage)
1274install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1275
61f7e1b3 1276install %{SOURCE1} doc/manual/groups
d755a548 1277install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
80b8a1f9
JB
1278install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1279install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
0bf34f68
JR
1280install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1281install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
d755a548 1282install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
0bf34f68
JR
1283cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
1284install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
cf709a39 1285install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
0bf34f68 1286install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 1287
0bf34f68 1288install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 1289
950eead3
ER
1290install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1291
0bf34f68 1292install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
b1541d4c 1293install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
0bf34f68
JR
1294install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1295install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1296install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1297install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
0bf34f68 1298install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 1299
950eead3
ER
1300touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1301touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
0bf34f68 1302install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
950eead3
ER
1303touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1304touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1305touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
fbc0ff35 1306
91ee86a9 1307install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
345a6923 1308install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
14138aba 1309install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
91ee86a9 1310
9776a251
JR
1311# create macro loading wrappers for backward compatibility
1312for m in gstreamer java mono perl php python; do
b279f099 1313 echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
9776a251
JR
1314done
1315
e1bd88ba
JB
1316# moved to rpm-build-macros 1.699
1317%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/macros.d/kernel
1318
f3fd387a 1319# for rpm -e|-U --repackage
a11e0e27
AM
1320install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1321touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
f3fd387a 1322
950eead3
ER
1323# move rpm to /bin
1324mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1325# move essential libs to /lib (libs that /bin/rpm links to)
ece880e2 1326for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
50dc9ac0
JK
1327 mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1328 ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
c2673e18
AF
1329done
1330
950eead3
ER
1331# Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1332mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1333
dae5e1a8 1334%if %{with python}
6f18cdb7
AF
1335%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1336%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1337
08697680 1338%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
dae5e1a8 1339%endif
01d7a578 1340
01d7a578 1341# wrong location, not used anyway
08697680 1342%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
e86bfbff 1343# utils dropped in 5.4 -- their manuals
854562c1 1344%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
e86bfbff
JR
1345# script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1346%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
01d7a578 1347
90b03dd6 1348%find_lang %{name}
cf6faebc 1349
08697680 1350%{__rm} -rf manual
a998ac11 1351cp -a doc/manual manual
08697680 1352%{__rm} -f manual/Makefile*
874f4c9a 1353
13eb5ebf 1354%clean
d7df46b8 1355rm -rf $RPM_BUILD_ROOT
76214164 1356
cc1a4992
ER
1357%pretrans
1358# this needs to be a dir
1359if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
c1097150 1360 umask 022
cc1a4992
ER
1361 mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1362 mkdir %{_sysconfdir}/rpm/sysinfo
1363fi
1364
be4d3036 1365%posttrans
d25ec6ea 1366if [ -e /var/lib/rpm/Packages ] && \
6a934782 1367 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
d25ec6ea 1368 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
6a934782 1369 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 1370 echo
e4dd6a34 1371 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
1372 echo
1373 fi
3ca91ccd
JR
1374 echo
1375 echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
1376 echo 'you should ignore it and restart poldek'
1377 echo
3fc92bf7 1378 %{_rpmlibdir}/bin/dbupgrade.sh
be4d3036 1379fi
f7779567 1380
b7ee97ef
JR
1381%triggerpostun -- %{name} < 4.4.9-44
1382%{_rpmlibdir}/hrmib-cache
1383
ceaaacee
JB
1384%post lib -p /sbin/ldconfig
1385%postun lib -p /sbin/ldconfig
76214164 1386
37a5a2fc 1387%pretrans build
d755a548 1388find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 1389
3684d90f
JB
1390%files -f %{name}.lang
1391%defattr(644,root,root,755)
241257bf 1392%doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
3684d90f 1393
3acb62f3
ER
1394%dir /etc/pki/rpm-gpg
1395/etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
54eb1770 1396
7a9d72ce 1397%attr(755,root,root) /bin/rpm
e73478cd 1398
66edd895 1399%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 1400%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
950eead3 1401%dir %{_sysconfdir}/rpm/sysinfo
caf453d4 1402# these are ok to be replaced
950eead3 1403%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
caf453d4
AM
1404%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1405
09bb810c 1406%{_mandir}/man8/rpm.8*
feb1f12e 1407%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 1408%lang(ja) %{_mandir}/ja/man8/rpm.8*
ff7bc1e6 1409%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 1410%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 1411%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 1412
e2025ad1 1413%dir /var/lib/rpm
74a997bd
JR
1414%dir /var/lib/rpm/log
1415%dir /var/lib/rpm/tmp
1416%config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
f3fd387a 1417%dir %attr(700,root,root) /var/spool/repackage
a11e0e27
AM
1418%dir /var/lock/rpm
1419/var/lock/rpm/transaction
4acac5de 1420
cf709a39
ER
1421# exported package NVRA (stamped with install tid)
1422# net-snmp hrSWInstalledName queries, bash-completions
1423%dir /var/cache/hrmib
1424
ec44785a 1425%{_rpmlibdir}/qf
d755a548
JK
1426%{_rpmlibdir}/rpmpopt*
1427%{_rpmlibdir}/macros
08697680
JR
1428%dir %{_rpmlibdir}/macros.d
1429%{_rpmlibdir}/macros.d/pld
9282ffe4 1430%{_rpmlibdir}/cpuinfo.yaml
e23edf35 1431%{_rpmlibdir}/noarch-*
c2683840 1432%ifarch %{ix86} %{x8664} x32
e23edf35
JR
1433%{_rpmlibdir}/i?86*
1434%{_rpmlibdir}/pentium*
1435%{_rpmlibdir}/athlon*
1436%endif
1437%ifarch alpha
1438%{_rpmlibdir}/alpha*
1439%endif
1440%ifarch ia64
1441%{_rpmlibdir}/ia64*
1442%endif
1443%ifarch mips mipsel mips64 mips64el
1444%{_rpmlibdir}/mips*
1445%endif
1446%ifarch %{ppc}
1447%{_rpmlibdir}/ppc*
1448%endif
1449%ifarch sparc sparc64
1450%{_rpmlibdir}/sparc*
1451%endif
c2683840 1452%ifarch %{x8664} x32
e23edf35
JR
1453%{_rpmlibdir}/amd64*
1454%{_rpmlibdir}/ia32e*
1455%{_rpmlibdir}/x86_64*
c2683840 1456%{_rpmlibdir}/x32*
e23edf35 1457%endif
3684d90f 1458
cf709a39
ER
1459%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1460
df50421f
JR
1461%dir %{_rpmlibdir}/bin
1462%attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
14138aba 1463%attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
91ee86a9 1464%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
345a6923 1465%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
0004e9b0 1466%attr(755,root,root) %{_rpmlibdir}/bin/rpmdbchk
df50421f 1467
66edd895
JB
1468%files base
1469%defattr(644,root,root,755)
492a2bd4 1470%dir %{_sysconfdir}/rpm
66edd895
JB
1471%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1472%dir %{_rpmlibdir}
1473%attr(755,root,root) %{_bindir}/banner.sh
1474%attr(755,root,root) %{_rpmlibdir}/user_group.sh
1475%dir /var/lib/banner
1476
874f4c9a
MM
1477%files lib
1478%defattr(644,root,root,755)
950eead3
ER
1479%attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1480%attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1481%attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1482%attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
a434679c 1483%attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
ece880e2 1484%attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
874f4c9a 1485
69131f1a
JB
1486%files devel
1487%defattr(644,root,root,755)
69131f1a
JB
1488%attr(755,root,root) %{_libdir}/librpm.so
1489%attr(755,root,root) %{_libdir}/librpm-%{sover}.so
950eead3
ER
1490%attr(755,root,root) %{_libdir}/librpmbuild.so
1491%attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
02510ee8
AM
1492%attr(755,root,root) %{_libdir}/librpmconstant.so
1493%attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
950eead3
ER
1494%attr(755,root,root) %{_libdir}/librpmdb.so
1495%attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
69131f1a
JB
1496%attr(755,root,root) %{_libdir}/librpmio.so
1497%attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
02510ee8
AM
1498%attr(755,root,root) %{_libdir}/librpmmisc.so
1499%attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
950eead3
ER
1500%{_libdir}/librpm*.la
1501%{_includedir}/rpm
1502%{_pkgconfigdir}/*.pc
69131f1a
JB
1503
1504%files static
1505%defattr(644,root,root,755)
1506%{_libdir}/librpm*.a
1507
1508%files utils
1509%defattr(644,root,root,755)
69131f1a 1510%attr(755,root,root) %{_bindir}/rpm2cpio
25e974c7 1511%attr(755,root,root) %{_bindir}/rpmconstant
69131f1a 1512%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
69131f1a 1513%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
25e974c7 1514%attr(755,root,root) %{_rpmlibdir}/tgpg
df50421f
JR
1515%attr(755,root,root) %{_rpmlibdir}/bin/chroot
1516%attr(755,root,root) %{_rpmlibdir}/bin/cp
9282ffe4 1517%attr(755,root,root) %{_rpmlibdir}/bin/debugedit
df50421f
JR
1518%attr(755,root,root) %{_rpmlibdir}/bin/find
1519%attr(755,root,root) %{_rpmlibdir}/bin/mgo
9282ffe4
AF
1520%attr(755,root,root) %{_rpmlibdir}/bin/mtree
1521%attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1522%attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1523%attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1524%attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
6e115b23
JR
1525%if %{with selinux}
1526%attr(755,root,root) %{_rpmlibdir}/bin/semodule
1527%attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1528%endif
70df63f3
JR
1529%if %{without system_lua}
1530%attr(755,root,root) %{_rpmlibdir}/bin/lua
1531%attr(755,root,root) %{_rpmlibdir}/bin/luac
1532%attr(755,root,root) %{_rpmlibdir}/bin/rpmlua
1533%attr(755,root,root) %{_rpmlibdir}/bin/rpmluac
1534%endif
d0ee0933 1535%{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
9282ffe4 1536%attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
69131f1a 1537%{_mandir}/man8/rpm2cpio.8*
ec44785a 1538%{_mandir}/man8/rpmconstant.8*
69131f1a 1539%{_mandir}/man8/rpmdeps.8*
c0a9be8f 1540%{_mandir}/man8/rpmmtree.8*
69131f1a 1541%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
69131f1a
JB
1542%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1543%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
69131f1a
JB
1544%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1545
1546%files utils-perl
1547%defattr(644,root,root,755)
1548%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
69131f1a
JB
1549
1550%if %{with static}
1551%files utils-static
1552%defattr(644,root,root,755)
1553%attr(755,root,root) %{_bindir}/rpm[ieu]
1554%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1555%endif
1556
3684d90f 1557%files build
a45ae6d8 1558%defattr(644,root,root,755)
66edd895 1559%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
1560%attr(755,root,root) %{_rpmlibdir}/brp-*
1561%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548
JK
1562%attr(755,root,root) %{_rpmlibdir}/compress-doc
1563%attr(755,root,root) %{_rpmlibdir}/cross-build
d755a548 1564%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
d755a548
JK
1565%attr(755,root,root) %{_rpmlibdir}/getpo.sh
1566%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d755a548 1567%attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
01d7a578 1568%attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
01d7a578 1569%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
c75b3936 1570%attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
01d7a578
JB
1571# needs hacked pkg-config to return anything
1572%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
df50421f
JR
1573%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1574%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
ac8ac881 1575%{!?with_sqlite:%attr(755,root,root) %{_rpmlibdir}/bin/dbsql}
77fcdbf7
AF
1576%attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1577%attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
df50421f 1578%attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
5131d1d1 1579%attr(755,root,root) %{_rpmlibdir}/bin/rpmspec
df50421f
JR
1580%attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1581%attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1582%attr(755,root,root) %{_rpmlibdir}/bin/wget
ec44785a 1583%attr(755,root,root) %{_rpmlibdir}/vcheck
410dd742 1584# not used yet ... these six depend on perl
ec44785a 1585%attr(755,root,root) %{_rpmlibdir}/http.req
428645e9
JR
1586# we always used scripts provided by mono-devel, maybe move them here
1587#%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1588#%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
37e965e8 1589
70f8787d 1590%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 1591# must be here for "Requires: rpm-*prov" to work
df50421f
JR
1592%{_rpmlibdir}/macros.d/cmake
1593%{_rpmlibdir}/macros.d/gstreamer
77fcdbf7
AF
1594%{_rpmlibdir}/macros.d/java
1595%{_rpmlibdir}/macros.d/libtool
1596%{_rpmlibdir}/macros.d/mono
1597%{_rpmlibdir}/macros.d/perl
1598%{_rpmlibdir}/macros.d/php
1599%{_rpmlibdir}/macros.d/pkgconfig
1600%{_rpmlibdir}/macros.d/python
3b644c29 1601%{_rpmlibdir}/macros.d/ruby
77fcdbf7 1602%{_rpmlibdir}/macros.d/selinux
df50421f 1603%{_rpmlibdir}/macros.d/tcl
77fcdbf7 1604%{_rpmlibdir}/macros.rpmbuild
9776a251
JR
1605# compat wrappers
1606%{_rpmlibdir}/macros.gstreamer
1607%{_rpmlibdir}/macros.java
1608%{_rpmlibdir}/macros.mono
1609%{_rpmlibdir}/macros.perl
1610%{_rpmlibdir}/macros.php
1611%{_rpmlibdir}/macros.python
77fcdbf7 1612
df50421f
JR
1613%attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1614%attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
df50421f 1615
874f4c9a
MM
1616%attr(755,root,root) %{_bindir}/gendiff
1617%attr(755,root,root) %{_bindir}/rpmbuild
ec44785a
BZ
1618
1619%dir %{_rpmlibdir}/helpers
1620%attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
874f4c9a 1621
a00926bc 1622%{_mandir}/man1/gendiff.1*
874f4c9a 1623%{_mandir}/man8/rpmbuild.8*
fefe9d30
JB
1624%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1625%lang(pl) %{_mandir}/pl/man1/gendiff.1*
1626%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
f3fe287f 1627
7d8492bb
JB
1628%files javaprov
1629%defattr(644,root,root,755)
1630%attr(755,root,root) %{_rpmlibdir}/java-find-requires
1631# needs jar (any jdk), jcf-dump (gcc-java) to work
1632%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1633
ec49e9fb
ER
1634%files rubyprov
1635%defattr(644,root,root,755)
1636%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1637%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1638
89334051
AF
1639%files perlprov
1640%defattr(644,root,root,755)
d755a548 1641%attr(755,root,root) %{_rpmlibdir}/perl.*
ec44785a
BZ
1642%attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1643%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
9805fd6d 1644
80d3b868 1645%files pythonprov
d8fcb9b0 1646%defattr(644,root,root,755)
bdbae303 1647%attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
25d296e1 1648%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
09bb810c 1649
d36cb682
PG
1650%files php-pearprov
1651%defattr(644,root,root,755)
9d09e076
ER
1652%attr(755,root,root) %{_rpmlibdir}/php.prov
1653%attr(755,root,root) %{_rpmlibdir}/php.req
1654%attr(755,root,root) %{_rpmlibdir}/php.req.php
d36cb682 1655
50dc9ac0 1656%if %{with python}
cf6faebc 1657%files -n python-rpm
42a0025c 1658%defattr(644,root,root,755)
b33910fe 1659%dir %{py_sitedir}/rpm
6f18cdb7 1660%attr(755,root,root) %{py_sitedir}/rpm/*.so
8c99b39a 1661%{py_sitedir}/rpm/*.py[co]
50dc9ac0 1662%endif
5c2ab5c7
AM
1663
1664%if %{with apidocs}
1665%files apidocs
1666%defattr(644,root,root,755)
1667%doc apidocs
1668%endif
This page took 1.118996 seconds and 4 git commands to generate.