- pl.po updates (in pl.po,etc_dir,build-failure-error patches)
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
76f35df6
JB
3# - python(abi) cap is not provided automatically (because /usr/bin/python matches
4# ELF first; it should be provided by python-libs not binary anyway)
a245b6ce 5# - repackaging when lzma is not installed (todo: fix digest signature of header)
10abbd40 6#
89427592 7# Conditional build:
01d7a578 8%bcond_with static # build static rpm+rpmi
4af66a2c
JB
9%bcond_without apidocs # don't generate documentation with doxygen
10%bcond_with autoreqdep # autogenerate package name deps in addition to sonames/perl(X)
11%bcond_without python # don't build python bindings
12%bcond_without selinux # build without selinux support
632f1b5c 13%bcond_without system_libmagic # don't use system libmagic
33be5db0 14%bcond_with neon # build with HTTP/WebDAV support (neon library)
89427592
JB
15# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
16# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
17# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
54bfdf99 18
003a039e 19# versions of required libraries
83d6a3fe 20%define reqdb_ver 4.4.20
b60c74c3 21%define reqpopt_ver 1.10.6
33be5db0 22%define beecrypt_ver 2:4.1.2-4
10abbd40 23%define sover 4.4
e5f02e49
AM
24Summary: RPM Package Manager
25Summary(de): RPM Packet-Manager
313a4d1a 26Summary(es): Gestor de paquetes RPM
609cc585 27