]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- updated pl.po,link,po,arch-x86_64 patches
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
644d8958
JB
3# - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
4# matches ELF first
a245b6ce 5# - repackaging when lzma is not installed (todo: fix digest signature of header)
351a0199
JB
6# rpmbuild computes digest when writing package to temporary file, then adds a few
7# tags (incl. digest) and writes whole package to destination file;
8# repackaging uses unchanged "immutable header" image from original rpm, also
9# preserving payload format and compressor from original rpm, _not_ current settings
10abbd40 10#
89427592 11# Conditional build:
01d7a578 12%bcond_with static # build static rpm+rpmi
4af66a2c
JB
13%bcond_without apidocs # don't generate documentation with doxygen
14%bcond_with autoreqdep # autogenerate package name deps in addition to sonames/perl(X)
15%bcond_without python # don't build python bindings
16%bcond_without selinux # build without selinux support
632f1b5c 17%bcond_without system_libmagic # don't use system libmagic
0dc47449 18%bcond_without suggest_tags # build without Suggest tag (bootstrapping)
33be5db0 19%bcond_with neon # build with HTTP/WebDAV support (neon library)
89427592
JB
20# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
21# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
22# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
54bfdf99 23
003a039e 24# versions of required libraries
644d8958
JB
25%define reqdb_ver 4.5.20
26%define reqpopt_ver 1.10.8
33be5db0 27%define beecrypt_ver 2:4.1.2-4
10abbd40 28%define sover 4.4
e5f02e49 29Summary: RPM Package Manager
4ea2ed33
ER
30Summary(de.UTF-8): RPM Packet-Manager
31Summary(es.UTF-8): Gestor de paquetes RPM
32Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
33Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
34Summary(ru.UTF-8): Менеджер пакетов от RPM
35Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 36Name: rpm
4617e0e8
AM
37Version: 4.4.9
38Release: 0.1
9c5bc9ad 39License: GPL
76214164 40Group: Base
4711b7e8 41Source0: ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
4617e0e8 42# Source0-md5: 210b768006e7d88dd8a3bcd498ea27f6
ff7bc1e6 43Source1: %{name}.groups
c2673e18 44Source2: %{name}.platform
ff7bc1e6 45Source3: %{name}-install-tree
80b8a1f9
JB
46Source4: %{name}-find-spec-bcond
47Source5: %{name}-find-lang
48Source6: %{name}-groups-po.awk
49Source7: %{name}-compress-doc
50Source8: %{name}-check-files
51Source9: %{name}-php-provides
52Source10: %{name}-php-requires
fbc0ff35 53Source11: %{name}.sysinfo
80b8a1f9 54Source12: perl.prov
d0370fe5 55Source13: %{name}-user_group.sh
56Source14: %{name}.sysconfig
7c6dc55f 57Source30: builder
58Source31: adapter.awk
59Source32: pldnotify.awk
a4b7ef27 60# http://svn.pld-linux.org/banner.sh/
61Source33: banner.sh
f14234e4 62Patch0: %{name}-pl.po.patch
b174986a 63Patch1: %{name}-rpmrc.patch
3465efba 64Patch2: %{name}-arch.patch
b174986a 65Patch3: %{name}-rpmpopt.patch
3465efba 66Patch4: %{name}-perl-macros.patch
c1768ce2 67Patch5: %{name}-perl-req-perlfile.patch
f14234e4
JB
68Patch6: %{name}-noexpand.patch
69Patch7: %{name}-scripts-closefds.patch
70Patch8: %{name}-python-macros.patch
71Patch9: %{name}-gettext-in-header.patch
72Patch10: %{name}-compress-doc.patch
82687d05 73
f14234e4
JB
74Patch12: %{name}-system_libs.patch
75Patch13: %{name}-bb-and-short-circuit.patch
76Patch14: %{name}-etc_dir.patch
77Patch15: %{name}-system_libs-more.patch
78Patch16: %{name}-php-deps.patch
79Patch17: %{name}-ldconfig-always.patch
80Patch18: %{name}-perl_req.patch
8b053168 81Patch19: %{name}-link.patch
f14234e4
JB
82Patch20: %{name}-magic-usesystem.patch
83Patch21: %{name}-dontneedutils.patch
84Patch22: %{name}-provides-dont-obsolete.patch
644d8958 85Patch23: %{name}-pkgconfigdeps.patch
f14234e4 86Patch24: %{name}-po.patch
b5bcc83b 87Patch25: %{name}-glob.patch
f14234e4
JB
88Patch26: %{name}-notsc.patch
89Patch27: %{name}-hack-norpmlibdep.patch
90Patch28: %{name}-makefile-no_myLDADD_deps.patch
82687d05 91
f14234e4
JB
92Patch31: %{name}-missing-prototypes.patch
93Patch32: %{name}-pld-autodep.patch
374b40ea 94Patch33: %{name}-arch-x86_64.patch
f14234e4
JB
95Patch34: %{name}-epoch0.patch
96Patch35: %{name}-perl_req-INC_dirs.patch
97Patch36: %{name}-debuginfo.patch
98Patch37: %{name}-doxygen_hack.patch
82687d05 99
65f4f2e2 100Patch41: %{name}-reduce-stack-usage.patch
bb98669b 101Patch42: %{name}-old-fileconflicts-behaviour.patch
644d8958 102
33be5db0
JB
103Patch44: %{name}-no-neon.patch
104Patch45: %{name}-no-sqlite.patch
5790b583 105Patch46: %{name}-mono.patch
fbc0ff35 106
5faf69a1 107Patch49: %{name}-p4.patch
b02ce76b 108Patch50: %{name}-macros.patch
bc8eaf36 109Patch51: %{name}-cleanlibdirs.patch
80e9f34d 110Patch52: %{name}-morearchs.patch
644d8958 111
d6080f70 112Patch55: %{name}-truncate-cvslog.patch
644d8958 113
2748102f 114Patch57: %{name}-as_needed-fix.patch
a245b6ce 115Patch58: %{name}-repackage-wo-lzma.patch
59a562c2 116Patch59: %{name}-libtool-deps.patch
322f70c6 117URL: http://wraptastic.org/
b60c74c3 118BuildRequires: autoconf >= 2.57
644d8958 119BuildRequires: automake >= 1.4
87ef0d95 120BuildRequires: beecrypt-devel >= %{beecrypt_ver}
33be5db0 121BuildRequires: bzip2-devel >= 1.0.2-17
1d34a9ca 122BuildRequires: db-devel >= %{reqdb_ver}
33be5db0 123BuildRequires: elfutils-devel >= 0.108
b59d7b6c 124BuildRequires: gettext-devel >= 0.11.4-2
632f1b5c 125%{?with_system_libmagic:BuildRequires: libmagic-devel}
8e159d42 126%{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
84cdee7a
JB
127# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
128BuildRequires: libstdc++-devel
b60c74c3 129BuildRequires: libtool >= 1:1.4.2-9
33be5db0 130%if %{with neon}
fe861705 131BuildRequires: libxml2-devel
83d6a3fe 132BuildRequires: neon-devel >= 0.25.5
33be5db0 133%endif
7973b351 134BuildRequires: patch >= 2.2
1d49ffbc 135BuildRequires: popt-devel >= %{reqpopt_ver}
849b65cd 136%{?with_python:BuildRequires: python-devel >= 1:2.5}
137BuildRequires: python-modules >= 1:2.5
3cfc33fc 138BuildRequires: rpm-perlprov
2a813afe 139%{?with_python:BuildRequires: rpm-pythonprov}
874f4c9a 140BuildRequires: zlib-devel
b0a177d4 141%if %{with apidocs}
142BuildRequires: doxygen
143BuildRequires: ghostscript
144BuildRequires: graphviz
145BuildRequires: tetex-pdftex
146%endif
a6e56ce4 147%if %{with static}
e6090a7b 148# Require static library only for static build
87ef0d95 149BuildRequires: beecrypt-static >= %{beecrypt_ver}
33be5db0 150BuildRequires: bzip2-static >= 1.0.2-17
1d34a9ca 151BuildRequires: db-static >= %{reqdb_ver}
290c1c30 152BuildRequires: elfutils-static
10abbd40 153BuildRequires: glibc-static >= 2.2.94
b9e030ac 154%{?with_system_libmagic:BuildRequires: libmagic-static}
8e159d42 155%{?with_selinux:BuildRequires: libselinux-static >= 1.18}
003a039e 156BuildRequires: popt-static >= %{reqpopt_ver}
1d49ffbc 157BuildRequires: zlib-static
7a9d72ce 158%endif
66edd895 159Requires: %{name}-base = %{version}-%{release}
b26a9709 160Requires: %{name}-lib = %{version}-%{release}
10abbd40
ER
161Requires: beecrypt >= %{beecrypt_ver}
162Requires: popt >= %{reqpopt_ver}
4adb7d05 163%{!?with_static:Obsoletes: rpm-utils-static}
874f4c9a 164Conflicts: glibc < 2.2.92
bcf1e12e
AM
165# ABI changes in rpm, new poldek needed
166Conflicts: poldek < 0.20.1-0.20070105.0
1d49ffbc 167BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 168
4adb7d05
JB
169%define _binary_payload w9.gzdio
170%define _noPayloadPrefix 1
6d82b332 171
4cd84746
JB
172# don't require very fresh rpm.macros to build
173%define __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
9f517079 174%define ix86 i386 i486 i586 i686 athlon pentium3 pentium4
80e9f34d 175%define ppc ppc ppc7400 ppc7450
9f517079 176%define x8664 amd64 ia32e x86_64
4cd84746 177
89427592 178# stabilize new build environment
f9ac32aa
AM
179%define __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
180%define __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
181%define __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
89427592 182
d755a548
JK
183%define _rpmlibdir /usr/lib/rpm
184
573e40e1
PS
185%define specflags -fno-strict-aliasing
186
ff7bc1e6 187%description
188RPM is a powerful package manager, which can be used to build,
189install, query, verify, update, and uninstall individual software
cf6faebc 190packages. A package consists of an archive of files, and package
fed73700 191information, including name, version, and description.
192
dd85fadc
JR
193%description -l de.UTF-8
194RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 195Installation, Anfrage, Verifizierung, Aktualisierung und
196Uninstallation individueller Softwarepakete. Ein Paket besteht aus
197einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 198Beschreibung.
199
dd85fadc 200%description -l es.UTF-8
313a4d1a 201RPM es un poderoso administrador de paquetes, que puede ser usado para
202construir, instalar, pesquisar, verificar, actualizar y desinstalar
203paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
204almacenaje de archivos, y información sobre el paquete, incluyendo
205nombre, versión y descripción.
206
207%description -l pl.UTF-8
208RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
209przebudowanie, instalację czy weryfikację dowolnego pakietu.
210Informacje dotyczące każdego pakietu, takie jak jego opis, lista
211plików wchodzących w skład pakietu, zależności od innych pakietów, są
212przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 213odpytywania programu rpm.
214
dd85fadc
JR
215%description -l pt_BR.UTF-8
216RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 217construir, instalar, pesquisar, verificar, atualizar e desinstalar
218pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
219arquivos e informações adicionais, incluindo nome, versão e descrição
220do pacote, permissões dos arquivos, etc.
221
222%description -l ru.UTF-8
223RPM - это мощный менеджер пакетов, который может быть использован для
224создания, инсталляции, запросов (query), проверки, обновления и
225удаления программных пакетов. Пакет состоит из файлового архива и
226служебной информации, включающей название, версию, описание и другие
227данные о пакете.
228
229%description -l uk.UTF-8
230RPM - це потужний менеджер пакетів, що може бути використаний для
231створення, інсталяції, запитів (query), перевірки, поновлення та
232видалення програмних пакетів. Пакет складається з файлового архіву та
233службової інформації, що містить назву, версію, опис та іншу
234інформацію про пакет.
7c6dc55f 235
66edd895
JB
236%package base
237Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 238Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 239Group: Base
1d9ca0c1 240Requires: filesystem
66edd895
JB
241Obsoletes: vserver-rpm
242
243%description base
244The RPM base package contains scripts used by rpm packages themselves.
245These include:
246- scripts for adding/removing groups and users needed for rpm
247 packages,
248- banner.sh to display %%banner messages from rpm scriptlets.
249
dd85fadc
JR
250%description base -l pl.UTF-8
251Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 252Zawiera on:
dd85fadc
JR
253- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
254- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 255
69131f1a
JB
256%package lib
257Summary: RPMs library
4ea2ed33 258Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 259Group: Libraries
33be5db0 260Requires: beecrypt >= %{beecrypt_ver}
1d34a9ca 261Requires: db >= %{reqdb_ver}
33be5db0 262%{?with_selinux:Requires: libselinux >= 1.18}
632f1b5c 263%{?with_system_libmagic:Requires: libmagic >= 1.15-2}
69131f1a 264Requires: popt >= %{reqpopt_ver}
33be5db0 265Obsoletes: rpm-libs
69131f1a
JB
266# avoid SEGV caused by mixed db versions
267Conflicts: poldek < 0.18.1-16
0dc47449 268%{?with_suggest_tags:Suggests: lzma}
69131f1a
JB
269
270%description lib
271RPMs library.
272
dd85fadc 273%description lib -l pl.UTF-8
69131f1a
JB
274Biblioteki RPM-a.
275
fed73700 276%package devel
3f2d796a 277Summary: Header files for rpm libraries
4ea2ed33
ER
278Summary(de.UTF-8): Header-Dateien für rpm Libraries
279Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
280Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
281Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
282Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
283Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 284Group: Development/Libraries
153e5706 285Requires: %{name}-lib = %{version}-%{release}
87ef0d95 286Requires: beecrypt-devel >= %{beecrypt_ver}
fea3cb89 287Requires: bzip2-devel
1d34a9ca 288Requires: db-devel >= %{reqdb_ver}
5c583f90 289Requires: elfutils-devel
632f1b5c 290%{?with_system_libmagic:Requires: libmagic-devel}
10abbd40 291%{?with_selinux:Requires: libselinux-devel}
a998ac11 292Requires: popt-devel >= %{reqpopt_ver}
fea3cb89 293Requires: zlib-devel
cf6faebc 294
295%description devel
3f2d796a
JB
296The RPM packaging system includes C libraries that make it easy to
297manipulate RPM packages and databases. They are intended to ease the
cf6faebc 298creation of graphical package managers and other tools that need
3f2d796a
JB
299intimate knowledge of RPM packages. This package contains header files
300for these libraries.
fed73700 301
dd85fadc
JR
302%description devel -l de.UTF-8
303Der RPM-Packensystem enthält eine C-Library, die macht es einfach
304RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 305Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 306Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
307
dd85fadc 308%description devel -l es.UTF-8
313a4d1a 309El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
310fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
311facilitar la creación de administradores gráficos de paquetes y otras
20f89981 312herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 313
dd85fadc
JR
314%description devel -l pl.UTF-8
315System RPM zawiera biblioteki C, które ułatwiają manipulowanie
316pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
317graficznych programów zarządzających pakietami oraz innych narzędzi,
318które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
319zawiera pliki nagłówkowe wspomnianych bibliotek.
320
321%description devel -l pt_BR.UTF-8
322O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
323a manipulação de pacotes e bases de dados RPM. Seu objetivo é
324facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 325ferramentas que precisem de conhecimento profundo de pacotes RPM.
326
dd85fadc
JR
327%description devel -l ru.UTF-8
328Система управления пакетами RPM содержит библиотеку C, которая
329упрощает манипуляцию пакетами RPM и соответствующими базами данных.
330Эта библиотека предназначена для облегчения создания графических
331пакетных менеджеров и других утилит, которым необходимо работать с
332пакетами RPM.
7c6dc55f 333
dd85fadc
JR
334%description devel -l uk.UTF-8
335Система керування пакетами RPM містить бібліотеку C, котра спрощує
336роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
337призначена для полегшення створення графічних пакетних менеджерів та
338інших утиліт, що працюють з пакетами RPM.
7c6dc55f 339
fed73700 340%package static
9e42d68a 341Summary: RPM static libraries
4ea2ed33
ER
342Summary(de.UTF-8): RPMs statische Libraries
343Summary(pl.UTF-8): Biblioteki statyczne RPM-a
344Summary(pt_BR.UTF-8): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
345Summary(ru.UTF-8): Статическая библиотека для программ, работающих с rpm-пакетами
346Summary(uk.UTF-8): Статична бібліотека для програм, що працюють з пакетами rpm
edacdf8f 347Group: Development/Libraries
153e5706 348Requires: %{name}-devel = %{version}-%{release}
87ef0d95 349Requires: beecrypt-static >= %{beecrypt_ver}
df76dbd9 350Requires: bzip2-static
1d34a9ca 351Requires: db-static >= %{reqdb_ver}
ff03e01a 352Requires: elfutils-static
632f1b5c 353%{?with_system_libmagic:Requires: libmagic-static}
a998ac11 354Requires: popt-static >= %{reqpopt_ver}
df76dbd9 355Requires: zlib-static
edacdf8f 356
357%description static
20f89981 358RPM static libraries.
fed73700 359
dd85fadc 360%description static -l de.UTF-8
20f89981 361RPMs statische Libraries.
9e42d68a 362
dd85fadc 363%description static -l pl.UTF-8
0a7ae9bc 364Biblioteki statyczne RPM-a.
313a4d1a 365
dd85fadc
JR
366%description static -l pt_BR.UTF-8
367Bibliotecas estáticas para desenvolvimento.
edacdf8f 368
dd85fadc
JR
369%description static -l ru.UTF-8
370Система управления пакетами RPM содержит библиотеку C, которая
371упрощает манипуляцию пакетами RPM и соответствующими базами данных.
372Это статическая библиотека RPM.
7c6dc55f 373
dd85fadc
JR
374%description static -l uk.UTF-8
375Система керування пакетами RPM містить бібліотеку C, котра спрощує
376роботу з пакетами RPM та відповідними базами даних. Це статична
377бібліотека RPM.
7c6dc55f 378
fed73700 379%package utils
9e42d68a 380Summary: Additional utilities for managing rpm packages and database
4ea2ed33
ER
381Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
382Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 383Group: Applications/File
153e5706 384Requires: %{name} = %{version}-%{release}
a998ac11 385Requires: popt >= %{reqpopt_ver}
edacdf8f 386
387%description utils
20f89981 388Additional utilities for managing rpm packages and database.
fed73700 389
dd85fadc
JR
390%description utils -l de.UTF-8
391Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 392
dd85fadc
JR
393%description utils -l pl.UTF-8
394Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 395
92b3f576 396%package utils-perl
397Summary: Additional utilities for managing rpm packages and database
4ea2ed33
ER
398Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
399Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
92b3f576 400Group: Applications/File
153e5706 401Requires: %{name}-utils = %{version}-%{release}
92b3f576 402Requires: popt >= %{reqpopt_ver}
403
404%description utils-perl
405Additional utilities for managing rpm packages and database.
406
dd85fadc
JR
407%description utils-perl -l de.UTF-8
408Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
92b3f576 409
dd85fadc
JR
410%description utils-perl -l pl.UTF-8
411Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
92b3f576 412
a00926bc
JB
413%package utils-static
414Summary: Static rpm utilities
4ea2ed33 415Summary(pl.UTF-8): Statyczne narzędzia rpm
a00926bc 416Group: Applications/System
153e5706 417Requires: %{name} = %{version}-%{release}
a00926bc
JB
418
419%description utils-static
420Static rpm utilities for repairing system in case something with
421shared libraries used by rpm become broken. Currently it contains rpmi
422binary, which can be used to install/upgrade/remove packages without
423using shared libraries (well, in fact with exception of NSS modules).
424
dd85fadc
JR
425%description utils-static -l pl.UTF-8
426Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
427związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
428Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
429uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
430(z wyjątkiem modułów NSS).
a00926bc 431
fed73700 432%package build
e191287c 433Summary: Scripts for building binary RPM packages
4ea2ed33
ER
434Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
435Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
436Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
437Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
438Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 439Group: Applications/File
8f76a271 440Requires(pre): findutils
b0a177d4 441Requires: %{name}-build-macros >= 1.314
153e5706 442Requires: %{name}-utils = %{version}-%{release}
e191287c 443Requires: /bin/id
444Requires: awk
b6754a7e
PS
445# we need fixed binutils for -feliminate-dwarf2-dups
446Requires: binutils >= 3:2.17.50.0.3-2
cfa7898a 447Requires: bzip2
e950a6d7 448Requires: chrpath >= 0.10-4
b6547e10 449Requires: cpio
e191287c 450Requires: diffutils
195f647c 451Requires: elfutils
583135b4 452Requires: file >= 4.17
e191287c 453Requires: fileutils
454Requires: findutils
120d96b6 455Requires: gcc >= 5:3.4
e191287c 456Requires: glibc-devel
457Requires: grep
458Requires: gzip
e93003df 459Requires: lzma
e191287c 460Requires: make
461Requires: patch
e191287c 462Requires: sed
463Requires: sh-utils
464Requires: tar
465Requires: textutils
ca3648b1 466Provides: rpmbuild(monoautodeps)
37ea389a 467Provides: rpmbuild(noauto) = 3
02d17bf9 468%ifarch %{x8664}
195f647c
JB
469Conflicts: automake < 1:1.7.9-2
470Conflicts: libtool < 2:1.5-13
471%endif
0096c5cd 472
e2025ad1 473%description build
58399c37 474Scripts for building binary RPM packages.
fed73700 475
dd85fadc
JR
476%description build -l de.UTF-8
477Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 478
dd85fadc
JR
479%description build -l pl.UTF-8
480Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 481
dd85fadc
JR
482%description build -l pt_BR.UTF-8
483Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 484construir pacotes usando o RPM.
e73478cd 485
dd85fadc
JR
486%description build -l ru.UTF-8
487Различные вспомогательные скрипты и исполняемые программы, которые
488используются для сборки RPM'ов.
7c6dc55f 489
dd85fadc
JR
490%description build -l uk.UTF-8
491Різноманітні допоміжні скрипти та утиліти, які використовуються для
492побудови RPM'ів.
7c6dc55f 493
494%package build-tools
495Summary: Scripts for managing .spec files and building RPM packages
4ea2ed33
ER
496Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
497Summary(pl.UTF-8): Skrypty pomocnicze do zarządznia plikami .spec i budowania RPM-ów
498Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
499Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
500Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
7c6dc55f 501Group: Applications/File
153e5706 502Requires: %{name}-build = %{version}-%{release}
7c6dc55f 503# these are optional
504#Requires: cvs
c76eeb55 505Requires: wget
7c6dc55f 506
507%description build-tools
508Scripts for managing .spec files and building RPM packages.
509
dd85fadc
JR
510%description build-tools -l de.UTF-8
511Scripts fürs Bauen RPM-Pakete.
7c6dc55f 512
dd85fadc
JR
513%description build-tools -l pl.UTF-8
514Skrypty pomocnicze do zarządzania plikami .spec i do budowania RPM-ów.
7c6dc55f 515
dd85fadc
JR
516%description build-tools -l pt_BR.UTF-8
517Este pacote contém scripts e programas executáveis que são usados para
7c6dc55f 518construir pacotes usando o RPM.
519
dd85fadc
JR
520%description build-tools -l ru.UTF-8
521Различные вспомогательные скрипты и исполняемые программы, которые
522используются для сборки RPM'ов.
7c6dc55f 523
dd85fadc
JR
524%description build-tools -l uk.UTF-8
525Різноманітні допоміжні скрипти та утиліти, які використовуються для
526побудови RPM'ів.
7c6dc55f 527
69131f1a
JB
528%package perlprov
529Summary: Additional utilities for checking perl provides/requires in rpm packages
4ea2ed33
ER
530Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
531Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów perla w pakietach rpm
69131f1a
JB
532Group: Applications/File
533Requires: %{name} = %{version}-%{release}
534Requires: perl-devel
535Requires: perl-modules
536
537%description perlprov
538Additional utilities for checking perl provides/requires in rpm
539packages.
540
dd85fadc
JR
541%description perlprov -l de.UTF-8
542Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 543
dd85fadc
JR
544%description perlprov -l pl.UTF-8
545Dodatkowe narzędzia do sprawdzenia zależności skryptów perla w
69131f1a
JB
546pakietach rpm.
547
548%package pythonprov
549Summary: Python macros, which simplifies creation of rpm packages with Python software
4ea2ed33 550Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów rpm z programami napisanymi w Pythonie
69131f1a
JB
551Group: Applications/File
552Requires: %{name} = %{version}-%{release}
cd800b3c 553Requires: python
243c6264 554Requires: python-modules
69131f1a
JB
555
556%description pythonprov
557Python macros, which simplifies creation of rpm packages with Python
558software.
559
dd85fadc
JR
560%description pythonprov -l pl.UTF-8
561Makra ułatwiające tworzenie pakietów rpm z programami napisanymi w
69131f1a
JB
562Pythonie.
563
564%package php-pearprov
565Summary: Additional utilities for managing rpm packages and database
4ea2ed33 566Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności skryptów php w rpm
69131f1a
JB
567Group: Applications/File
568Requires: %{name} = %{version}-%{release}
632f1b5c 569Requires: sed >= 4.0
69131f1a
JB
570
571%description php-pearprov
572Additional utilities for checking php pear provides/requires in rpm
573packages.
574
dd85fadc
JR
575%description php-pearprov -l pl.UTF-8
576Dodatkowe narzędzia do sprawdzenia zależności skryptów php pear w
69131f1a
JB
577pakietach rpm.
578
579%package -n python-rpm
580Summary: Python interface to RPM library
4ea2ed33
ER
581Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
582Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a
JB
583Group: Development/Languages/Python
584Requires: %{name} = %{version}-%{release}
585%pyrequires_eq python
586Obsoletes: rpm-python
587
588%description -n python-rpm
589The rpm-python package contains a module which permits applications
590written in the Python programming language to use the interface
591supplied by RPM (RPM Package Manager) libraries.
592
593This package should be installed if you want to develop Python
594programs that will manipulate RPM packages and databases.
595
dd85fadc
JR
596%description -n python-rpm -l pl.UTF-8
597Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
598Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 599
dd85fadc
JR
600Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
601Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 602
dd85fadc
JR
603%description -n python-rpm -l pt_BR.UTF-8
604O pacote rpm-python contém um módulo que permite que aplicações
69131f1a
JB
605escritas em Python utilizem a interface fornecida pelas bibliotecas
606RPM (RPM Package Manager).
607
dd85fadc 608Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
609Python para manipular pacotes e bancos de dados RPM.
610
d6dddf74
JB
611%package apidocs
612Summary: RPM API documentation and guides
4ea2ed33 613Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
10abbd40 614Group: Documentation
b2ae427d 615
616%description apidocs
e93003df
ER
617Documentation for RPM API and guides in HTML format generated from rpm
618sources by doxygen.
31f4a5bc 619
dd85fadc 620%description apidocs -l pl.UTF-8
e93003df 621Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
dd85fadc 622źrodeł RPM-a przez doxygen.
b2ae427d 623
e2025ad1 624%prep
2065c1cd 625%setup -q
82687d05 626%patch0 -p1
db88c593 627%patch1 -p1
243e72f3 628%patch2 -p1
01d7a578 629%patch3 -p1
e2025ad1 630%patch4 -p1
c1768ce2 631%patch5 -p1
f14234e4 632%patch6 -p1
c1768ce2 633%patch7 -p1
fefe9d30
JB
634%patch8 -p1
635%patch9 -p1
636%patch10 -p1
c7def65c 637%patch12 -p1
7a9d72ce 638%patch13 -p1
9a8d811d 639%patch14 -p1
f14234e4 640%patch15 -p1
fefe9d30
JB
641%patch16 -p1
642%patch17 -p1
f14234e4 643%patch18 -p1
feb1f12e 644sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
1fcb29e9 645#cp -f platform.in macros.pld.in # what for?
8e989934 646echo '%%define __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
647echo '%%define __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
c2673e18 648echo '# obsoleted file' > macros.python
ac090b0f
ER
649echo '%%define __php_provides /usr/lib/rpm/php.prov' > macros.php
650echo '%%define __php_requires /usr/lib/rpm/php.req' >> macros.php
120d96b6 651echo '%%define __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
652echo '%%define __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
80b8a1f9
JB
653install %{SOURCE5} scripts/find-lang.sh
654install %{SOURCE9} scripts/php.prov.in
655install %{SOURCE10} scripts/php.req.in
656install %{SOURCE12} scripts/perl.prov
82687d05 657%patch19 -p1
f14234e4
JB
658%patch20 -p1
659%patch21 -p1
c7def65c 660%patch22 -p1
661%patch23 -p1
82687d05
JB
662%patch24 -p1
663# obsolete?
4617e0e8 664#%patch25 -p1
fefe9d30 665%patch26 -p1
24123ddd 666%patch27 -p1
8432f0c5 667%patch28 -p1
c7def65c 668%patch31 -p1
4617e0e8
AM
669# FIXME!
670# %patch32 -p1
82687d05 671# needed? I doubt
4617e0e8 672# %patch33 -p1
f14234e4
JB
673%patch34 -p1
674%patch35 -p0
5f7fdcd9 675%patch36 -p1
4617e0e8
AM
676# FIXME
677#%patch37 -p1
65f4f2e2 678%patch41 -p1
bb98669b 679%patch42 -p1
374b40ea 680%{!?with_neon:%patch44 -p1}
82687d05 681# UPDATEME
4617e0e8 682#%patch45 -p1
5790b583 683%patch46 -p1
5faf69a1 684%patch49 -p1
b02ce76b 685%patch50 -p1
bc8eaf36 686%patch51 -p1
a05b34dc 687#%patch52 -p1
d6080f70 688%patch55 -p1
2748102f 689%patch57 -p1
a245b6ce 690%patch58 -p1
59a562c2 691%patch59 -p1
d36cb682 692
bcdcbb03 693cd scripts
37550797 694mv -f perl.req perl.req.in
874f4c9a
MM
695mv -f perl.prov perl.prov.in
696cd ..
633d1e9e 697
4adb7d05
JB
698mv -f po/{no,nb}.po
699mv -f po/{sr,sr@Latn}.po
700
33be5db0 701rm -rf sqlite zlib db db3 popt rpmdb/db.h
633d1e9e 702
cd86db2e 703# generate Group translations to *.po
80b8a1f9 704awk -f %{SOURCE6} %{SOURCE1}
fefe9d30
JB
705
706# update macros paths
707for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
708 sed -e 's@lib/rpm/redhat@lib/rpm/pld@g' $f > ${f}.tmp
709 mv -f ${f}.tmp $f
710done
0d76071c 711
87ef0d95 712%build
a63662c4 713%if %{with system_libmagic}
714rm -rf file
715%else
87ef0d95 716cd file
ea816ea6 717%{__libtoolize}
ceaaacee
JB
718%{__aclocal}
719%{__autoheader}
0b35155a 720%{__autoconf}
edacdf8f 721%{__automake}
72be9ffe 722cd ..
a63662c4 723%endif
a998ac11 724
ea816ea6 725%{__libtoolize}
c222dedc 726%{__gettextize}
ceaaacee 727%{__aclocal}
4cd84746 728%{__autoheader}
7a9d72ce 729%{__autoconf}
7a9d72ce 730%{__automake}
7a9d72ce 731
cd86db2e 732# config.guess doesn't handle athlon, so we have to change it by hand.
733# rpm checks for CPU type at runtime, but it looks better
7c9ace12 734sed -i -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' -e 's|@host_cpu@|%{_target_cpu}|' macros.in
7a9d72ce 735
89427592 736# pass CC and CXX too in case of building with some older configure macro
01d7a578 737# disable perl-RPM2 build, we have it in separate spec
624f96ff 738%configure \
f9ac32aa
AM
739 CC="%{__newcc}" \
740 CXX="%{__newcxx}" \
741 CPP="%{__newcpp}" \
01d7a578 742 WITH_PERL_VERSION=no \
33be5db0 743 %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
cd86db2e 744 --enable-shared \
874f4c9a 745 --enable-static \
2e6b4088 746 %{!?with_apidocs:--without-apidocs} \
849b65cd 747 %{?with_python:--with-python=2.5} \
a6e56ce4 748 %{!?with_python:--without-python} \
c6abc173 749 %{!?with_selinux:--without-selinux} \
874f4c9a 750 --without-db
cf6faebc 751
4adb7d05 752# file_LDFLAGS, debugedit_LDADD - no need to link "file" and "debugedit" statically
874f4c9a 753%{__make} \
f9ac32aa
AM
754 CC="%{__cc}" \
755 CXX="%{__cxx}" \
756 CPP="%{__cpp}" \
e8d70bea 757 pylibdir=%{py_libdir} \
4adb7d05
JB
758 myLDFLAGS="%{rpmldflags}" \
759 file_LDFLAGS= \
01d7a578
JB
760 debugedit_LDADD="\$(WITH_LIBELF_LIB) -lpopt" \
761 staticLDFLAGS=%{?with_static:-all-static}
33be5db0 762
796d4a88 763%{?with_apidocs:%{__make} doxygen}
e05585d0 764
b064b8e6 765%install
ff7bc1e6 766rm -rf $RPM_BUILD_ROOT
66edd895 767install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/banner}
76214164 768
a5e7fb84 769%{__make} install \
9805fd6d 770 DESTDIR=$RPM_BUILD_ROOT \
c34a847a 771 staticLDFLAGS=%{?with_static:-all-static} \
e8d70bea 772 pylibdir=%{py_libdir} \
cf6faebc 773 pkgbindir="%{_bindir}"
718426e1 774
caf453d4
AM
775echo "%{_target_cpu}-%{_target_vendor}-linux-gnu" > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
776
137e2891 777%ifarch %{ppc}
a05b34dc 778#sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
779# -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
137e2891 780%endif
781
02919de5
JK
782rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
783rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
784rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
785
644d8958
JB
786# not installed since 4.4.8 (-tools-perl subpackage)
787install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
788
d755a548
JK
789install macros.perl $RPM_BUILD_ROOT%{_rpmlibdir}/macros.perl
790install macros.python $RPM_BUILD_ROOT%{_rpmlibdir}/macros.python
791install macros.php $RPM_BUILD_ROOT%{_rpmlibdir}/macros.php
5790b583 792install macros.mono $RPM_BUILD_ROOT%{_rpmlibdir}/macros.mono
7ba63f26 793
61f7e1b3 794install %{SOURCE1} doc/manual/groups
d755a548 795install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
80b8a1f9
JB
796install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
797install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
798install %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/check-files
d0370fe5 799install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
d755a548
JK
800install scripts/find-php* $RPM_BUILD_ROOT%{_rpmlibdir}
801install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
d0370fe5 802install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 803
7c6dc55f 804install %{SOURCE30} $RPM_BUILD_ROOT%{_bindir}/builder
805install %{SOURCE31} $RPM_BUILD_ROOT%{_bindir}/adapter.awk
806install %{SOURCE32} $RPM_BUILD_ROOT%{_bindir}/pldnotify.awk
a4b7ef27 807install %{SOURCE33} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 808
fbc0ff35
AM
809install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
810
e663e5ff
JB
811install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
812
d23a99cc
AM
813# obsolete but still installed
814rm $RPM_BUILD_ROOT%{_rpmlibdir}/rpmrc
720f06f0 815
e663e5ff
JB
816cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
817# customized rpm macros - global for host
818#
40c1ea77
AF
819#%%_install_langs pl_PL:en_US
820%%distribution PLD
541eacd3
JB
821#
822# remove or replace with file_contexts path if you want to use custom
823# SELinux file contexts policy instead of one stored in packages payload
31858397
JB
824%%_install_file_context_path %%{nil}
825%%_verify_file_context_path %%{nil}
627d5615
ER
826
827# If non-zero, all erasures will be automagically repackaged.
828#%%_repackage_all_erasures 1
09bb810c
AF
829EOF
830
3d9806c2 831cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles <<EOF
99a3012c 832# global list of files (regexps) which don't generate Provides
3d9806c2
JB
833EOF
834cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov <<EOF
99a3012c 835# global list of script capabilities (regexps) not to be used in Provides
3d9806c2
JB
836EOF
837cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles <<EOF
99a3012c 838# global list of files (regexps) which don't generate Requires
e93003df
ER
839^%{_examplesdir}/
840^%{_docdir}/
3d9806c2
JB
841EOF
842cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq <<EOF
99a3012c 843# global list of script capabilities (regexps) not to be used in Requires
3d9806c2
JB
844EOF
845cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
99a3012c 846# global list of capabilities (SONAME, perl(module), php(module) regexps)
3d9806c2 847# which don't generate dependencies on package NAMES
195f647c 848# -- OpenGL implementation
f694a4d9
JB
849^libGL.so.1
850^libGLU.so.1
195f647c
JB
851^libOSMesa.so
852# -- Glide
f694a4d9 853^libglide3.so.3
195f647c 854# -- mozilla
f694a4d9
JB
855^libgtkmozembed.so
856^libgtksuperwin.so
857^libxpcom.so
195f647c
JB
858# -- X11 implementation
859^libFS.so
860^libI810XvMC.so
861^libICE.so
862^libSM.so
863^libX11.so
864^libXRes.so
865^libXTrap.so
866^libXaw.so
8c3b25a7 867^libXcomposite.so
195f647c 868^libXcursor.so
8c3b25a7
JB
869^libXdamage.so
870^libXdmcp.so
871^libXevie.so
195f647c 872^libXext.so
8c3b25a7 873^libXfixes.so
195f647c
JB
874^libXfont.so
875^libXfontcache.so
876^libXft.so
877^libXi.so
878^libXinerama.so
879^libXmu.so
880^libXmuu.so
881^libXp.so
882^libXpm.so
883^libXrandr.so
884^libXrender.so
885^libXss.so
886^libXt.so
887^libXtst.so
888^libXv.so
889^libXvMC.so
890^libXxf86dga.so
891^libXxf86misc.so
892^libXxf86rush.so
893^libXxf86vm.so
37ea389a
JB
894^libdps.so
895^libdpstk.so
195f647c 896^libfontenc.so
37ea389a 897^libpsres.so
195f647c
JB
898^libxkbfile.so
899^libxkbui.so
eec3b202
JB
900# -- fam / gamin
901^libfam.so.0
3d9806c2 902EOF
a4852742
JB
903cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
904# global list of file masks not to be compressed in DOCDIR
905EOF
3d9806c2 906
f3fd387a 907# for rpm -e|-U --repackage
a11e0e27
AM
908install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
909touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
f3fd387a 910
c2673e18 911# move libs to /lib
a11e0e27 912for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so ; do
50dc9ac0
JK
913 mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
914 ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
c2673e18
AF
915done
916
fca52ae1 917# remove arch dependant macros which have no use on noarch
627d5615 918%{__sed} -i -e '
fca52ae1
ER
919/{__spec_install_post_strip}/d
920/{__spec_install_post_chrpath}/d
921/{__spec_install_post_compress_modules}/d
922' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
923
6f18cdb7
AF
924%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
925%py_comp $RPM_BUILD_ROOT%{py_sitedir}
926
01d7a578
JB
927rm -f $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
928
929# (currently) not used or supported in PLD
930rm -f $RPM_BUILD_ROOT%{_rpmlibdir}/{Specfile.pm,cpanflute,cpanflute2,find-provides,find-requires,freshen.sh,http.req,magic.prov,magic.req,perldeps.pl,sql.prov,sql.req,tcl.req}
931# wrong location, not used anyway
932rm -f $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
644d8958
JB
933# manuals for utils dropped in 4.4.8 (?)
934#rm -f $RPM_BUILD_ROOT%{_mandir}/{,*/}/man8/{rpmcache,rpmgraph}.8
01d7a578 935
90b03dd6 936%find_lang %{name}
cf6faebc 937
c2673e18 938rm -rf manual
a998ac11
AF
939cp -a doc/manual manual
940rm -f manual/Makefile*
874f4c9a 941
13eb5ebf 942%clean
d7df46b8 943rm -rf $RPM_BUILD_ROOT
76214164 944
ceaaacee
JB
945%post lib -p /sbin/ldconfig
946%postun lib -p /sbin/ldconfig
76214164 947
8f76a271 948%pre build
d755a548 949find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 950
3684d90f
JB
951%files -f %{name}.lang
952%defattr(644,root,root,755)
644d8958 953%doc CHANGES CREDITS README wdj/JBJ-GPG-KEY manual/*
3684d90f 954
7a9d72ce 955%attr(755,root,root) /bin/rpm
35a6f2f9
JB
956#%attr(755,root,root) %{_bindir}/rpmdb
957#%attr(755,root,root) %{_bindir}/rpmquery
958#%attr(755,root,root) %{_bindir}/rpmsign
959#%attr(755,root,root) %{_bindir}/rpmverify
e73478cd 960
961%dir %{_sysconfdir}/rpm
66edd895 962%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
caf453d4
AM
963# these are ok to be replaced
964%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo
965%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
966
e73478cd 967
09bb810c 968%{_mandir}/man8/rpm.8*
feb1f12e 969%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 970%lang(ja) %{_mandir}/ja/man8/rpm.8*
1162bdc1 971%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 972%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 973%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 974%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 975
e2025ad1 976%dir /var/lib/rpm
f3fd387a 977%dir %attr(700,root,root) /var/spool/repackage
a11e0e27
AM
978%dir /var/lock/rpm
979/var/lock/rpm/transaction
4acac5de 980
4acac5de 981#%attr(755,root,root) %{_rpmlibdir}/rpmd
4adb7d05 982#%{!?with_static:%attr(755,root,root) %{_rpmlibdir}/rpm[eiu]}
4acac5de
JB
983#%attr(755,root,root) %{_rpmlibdir}/rpmk
984#%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
e2025ad1 985
d755a548
JK
986%{_rpmlibdir}/rpmpopt*
987%{_rpmlibdir}/macros
3684d90f 988
66edd895
JB
989%files base
990%defattr(644,root,root,755)
991%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
992%dir %{_rpmlibdir}
993%attr(755,root,root) %{_bindir}/banner.sh
994%attr(755,root,root) %{_rpmlibdir}/user_group.sh
995%dir /var/lib/banner
996
874f4c9a
MM
997%files lib
998%defattr(644,root,root,755)
50dc9ac0 999%attr(755,root,root) /%{_lib}/librpm*-*.so
874f4c9a
MM
1000%attr(755,root,root) %{_libdir}/librpm*-*.so
1001
69131f1a
JB
1002%files devel
1003%defattr(644,root,root,755)
1004%{_includedir}/rpm
1005%{_libdir}/librpm*.la
1006%attr(755,root,root) %{_libdir}/librpm.so
1007%attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1008%attr(755,root,root) %{_libdir}/librpmio.so
1009%attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1010%attr(755,root,root) %{_libdir}/librpmdb.so
1011%attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1012%attr(755,root,root) %{_libdir}/librpmbuild.so
1013
1014%files static
1015%defattr(644,root,root,755)
1016%{_libdir}/librpm*.a
1017
1018%files utils
1019%defattr(644,root,root,755)
1020%attr(755,root,root) %{_bindir}/debugedit
1021%attr(755,root,root) %{_bindir}/rpm2cpio
69131f1a 1022%attr(755,root,root) %{_bindir}/rpmdeps
a63662c4 1023%{!?with_system_libmagic:%attr(755,root,root) %{_bindir}/rpmfile}
69131f1a
JB
1024%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1025%attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
1026%attr(755,root,root) %{_rpmlibdir}/tgpg
1027%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1028%{_mandir}/man8/rpm2cpio.8*
1029%{_mandir}/man8/rpmdeps.8*
644d8958
JB
1030#%{_mandir}/man8/rpmcache.8*
1031#%{_mandir}/man8/rpmgraph.8*
69131f1a 1032%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
644d8958
JB
1033#%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
1034#%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
69131f1a
JB
1035%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1036%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1037%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
644d8958
JB
1038#%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
1039#%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
69131f1a
JB
1040%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1041
1042%files utils-perl
1043%defattr(644,root,root,755)
1044%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
69131f1a
JB
1045
1046%if %{with static}
1047%files utils-static
1048%defattr(644,root,root,755)
1049%attr(755,root,root) %{_bindir}/rpm[ieu]
1050%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1051%endif
1052
3684d90f 1053%files build
a45ae6d8 1054%defattr(644,root,root,755)
66edd895 1055%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
1056%attr(755,root,root) %{_rpmlibdir}/brp-*
1057%attr(755,root,root) %{_rpmlibdir}/check-files
374b40ea 1058# %attr(755,root,root) %{_rpmlibdir}/check-prereqs
d755a548 1059%attr(755,root,root) %{_rpmlibdir}/compress-doc
01d7a578 1060%attr(755,root,root) %{_rpmlibdir}/config.*
d755a548 1061%attr(755,root,root) %{_rpmlibdir}/cross-build
d755a548
JK
1062%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1063%attr(755,root,root) %{_rpmlibdir}/find-lang.sh
d755a548
JK
1064%attr(755,root,root) %{_rpmlibdir}/getpo.sh
1065%attr(755,root,root) %{_rpmlibdir}/install-build-tree
01d7a578 1066%attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
d755a548 1067%attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
01d7a578
JB
1068%attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1069# needs jar (any jdk), jcf-dump (gcc-java) to work
1070%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1071%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1072# needs hacked pkg-config to return anything
1073%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
d755a548
JK
1074%attr(755,root,root) %{_rpmlibdir}/rpmb
1075%attr(755,root,root) %{_rpmlibdir}/rpmt
1076%{_rpmlibdir}/noarch-*
e9fe9fc5 1077%ifarch %{ix86}
d755a548 1078%{_rpmlibdir}/i?86*
e9fe9fc5 1079%{_rpmlibdir}/pentium*
d755a548
JK
1080%{_rpmlibdir}/athlon*
1081%endif
ad628734
JB
1082%ifarch alpha
1083%{_rpmlibdir}/alpha*
1084%endif
ad628734
JB
1085%ifarch ia64
1086%{_rpmlibdir}/ia64*
8f76a271 1087%endif
410dd742 1088%ifarch mips mipsel mips64 mips64el
1089%{_rpmlibdir}/mips*
1090%endif
80e9f34d 1091%ifarch %{ppc}
410dd742 1092%{_rpmlibdir}/ppc*
1093%endif
1094%ifarch sparc sparc64
1095%{_rpmlibdir}/sparc*
1096%endif
9f517079 1097%ifarch %{x8664}
cedf1bfa
PS
1098%{_rpmlibdir}/x86_64*
1099%endif
410dd742 1100# must be here for "Requires: rpm-*prov" to work
5790b583 1101%{_rpmlibdir}/macros.mono
410dd742 1102%{_rpmlibdir}/macros.perl
1103%{_rpmlibdir}/macros.php
1104# not used yet ... these six depend on perl
1105#%attr(755,root,root) %{_rpmlibdir}/http.req
591cc005
JB
1106#%attr(755,root,root) %{_rpmlibdir}/magic.prov
1107#%attr(755,root,root) %{_rpmlibdir}/magic.req
1108#%{_rpmlibdir}/sql.prov
1109#%{_rpmlibdir}/sql.req
1110#%{_rpmlibdir}/tcl.req
7a9d72ce 1111
874f4c9a
MM
1112%attr(755,root,root) %{_bindir}/gendiff
1113%attr(755,root,root) %{_bindir}/rpmbuild
1114
a00926bc 1115%{_mandir}/man1/gendiff.1*
874f4c9a 1116%{_mandir}/man8/rpmbuild.8*
fefe9d30
JB
1117%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1118%lang(pl) %{_mandir}/pl/man1/gendiff.1*
1119%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
f3fe287f 1120
69131f1a 1121%files build-tools
a00926bc 1122%defattr(644,root,root,755)
69131f1a
JB
1123%attr(755,root,root) %{_bindir}/builder
1124%attr(755,root,root) %{_bindir}/adapter.awk
1125%attr(755,root,root) %{_bindir}/pldnotify.awk
a00926bc 1126
89334051
AF
1127%files perlprov
1128%defattr(644,root,root,755)
d755a548
JK
1129%attr(755,root,root) %{_rpmlibdir}/perl.*
1130#%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1131#%attr(755,root,root) %{_rpmlibdir}/find-perl-*
02919de5
JK
1132#%attr(755,root,root) %{_rpmlibdir}/find-*.perl
1133#%attr(755,root,root) %{_rpmlibdir}/find-prov.pl
1134#%attr(755,root,root) %{_rpmlibdir}/find-req.pl
374b40ea 1135#%attr(755,root,root) %{_rpmlibdir}/get_magic.pl
9805fd6d 1136
80d3b868 1137%files pythonprov
d8fcb9b0 1138%defattr(644,root,root,755)
d755a548 1139%{_rpmlibdir}/macros.python
25d296e1 1140%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
09bb810c 1141
d36cb682
PG
1142%files php-pearprov
1143%defattr(644,root,root,755)
d755a548
JK
1144%attr(755,root,root) %{_rpmlibdir}/php*
1145%attr(755,root,root) %{_rpmlibdir}/find-php*
d36cb682 1146
50dc9ac0 1147%if %{with python}
cf6faebc 1148%files -n python-rpm
42a0025c 1149%defattr(644,root,root,755)
b33910fe 1150%dir %{py_sitedir}/rpm
6f18cdb7 1151%attr(755,root,root) %{py_sitedir}/rpm/*.so
8c99b39a 1152%{py_sitedir}/rpm/*.py[co]
50dc9ac0 1153%endif
874f4c9a 1154
b2ae427d 1155%if %{with apidocs}
1156%files apidocs
1157%defattr(644,root,root,755)
1158%doc apidocs
1159%endif
This page took 0.688509 seconds and 4 git commands to generate.