]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- install pld macros in the right place
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
e8836e1f 3# - rebuild database after upgrading from rpm5
c296fee0 4# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 5#
89427592 6# Conditional build:
0a1ccab0 7%bcond_without apidocs # don't generate documentation with doxygen
f9d0e5f6
JR
8%bcond_without python2 # don't build python bindings
9%bcond_without python3 # don't build python bindings
b0333243 10%bcond_without plugins # build plugins
af0cc499 11%bcond_without recommends_tags # build without Recommends tag (bootstrapping)
fb35e2d9 12%bcond_with db61 # use DB 6.1 instead of 5.3
858aa7d0 13
003a039e 14# versions of required libraries
7f47af9c
JB
15%if %{with db61}
16%define reqdb_pkg db6.1
17%define reqdb_ver 6.1
18%define reqdb_pkgver 6.1.19
5f3f5bd6 19%else
fb35e2d9
JR
20%define reqdb_pkg db5.3
21%define reqdb_ver 5.3
22%define reqdb_pkgver 5.3.28.0
5f3f5bd6 23%endif
ec44785a 24%define reqpopt_ver 1.15
fb35e2d9 25%define openssl_ver 1.1.1d
2f409bb7 26%define sover 9.0.1
fc60c9f3 27
e5f02e49 28Summary: RPM Package Manager
4ea2ed33
ER
29Summary(de.UTF-8): RPM Packet-Manager
30Summary(es.UTF-8): Gestor de paquetes RPM
31Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
32Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
33Summary(ru.UTF-8): Менеджер пакетов от RPM
34Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 35Name: rpm
6ecfe7c2 36Version: 4.15.1
98d9fc8e 37Release: 0.1
9fe07969 38Epoch: 1
98d9fc8e 39License: GPL v2 / LGPL v2.1
76214164 40Group: Base
6ecfe7c2
JR
41Source0: http://ftp.rpm.org/releases/rpm-4.15.x/%{name}-%{version}.tar.bz2
42# Source0-md5: ed72147451a5ed93b2a48e2f8f5413c3
ff7bc1e6 43Source1: %{name}.groups
396a7387 44Source2: macros.pld
ff7bc1e6 45Source3: %{name}-install-tree
80b8a1f9 46Source4: %{name}-find-spec-bcond
cf709a39 47Source5: %{name}-hrmib-cache
80b8a1f9
JB
48Source6: %{name}-groups-po.awk
49Source7: %{name}-compress-doc
0bf34f68
JR
50Source8: %{name}-php-provides
51Source9: %{name}-php-requires
52Source10: %{name}.sysinfo
53Source11: perl.prov
54Source12: %{name}-user_group.sh
55Source13: %{name}.sysconfig
56Source14: %{name}-java-requires
a4b7ef27 57# http://svn.pld-linux.org/banner.sh/
0bf34f68 58Source15: banner.sh
34f36471 59Source16: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
e1b97821 60# Source16-md5: 23914bb49fafe7153cee87126d966461
0bf34f68
JR
61Source17: %{name}-mimetypedeps
62Source18: macros.local
f09b01ac
ER
63Source19: %{name}.noautocompressdoc
64Source20: %{name}.noautoprov
65Source21: %{name}.noautoprovfiles
66Source22: %{name}.noautoreq
f09b01ac 67Source24: %{name}.noautoreqfiles
0bf34f68 68Source25: %{name}-php-requires.php
f09b01ac 69Source26: %{name}db_checkversion.c
b1541d4c 70Source27: macros.lang
f09b01ac 71Source28: %{name}db_reset.c
14138aba 72Source29: dbupgrade.sh
e2489d8e 73Source30: rubygems.rb
63194730 74Source31: gem_helper.rb
af0cc499
JR
75Patch0: %{name}-man_pl.patch
76Patch1: %{name}-popt-aliases.patch
77Patch2: %{name}-perl-macros.patch
78Patch3: %{name}-perl-req-perlfile.patch
79Patch4: %{name}-scripts-closefds.patch
80Patch5: %{name}-php-macros.patch
81Patch6: %{name}-lua.patch
82Patch7: %{name}-perl_req-INC_dirs.patch
83Patch8: %{name}-debuginfo.patch
84Patch9: %{name}-javadeps.patch
85Patch10: %{name}-libtool-deps.patch
86Patch11: %{name}-builddir-readlink.patch
87Patch12: %{name}-changelog_order_check_nonfatal.patch
88Patch13: %{name}-postun-nofail.patch
89Patch14: %{name}-clean-docdir.patch
90Patch15: %{name}-perl-magic.patch
91Patch16: %{name}-ignore-missing-macro-files.patch
92Patch17: x32.patch
93Patch18: %{name}-fix-compress-doc.patch
e8836e1f 94Patch20: rpm5-db-compat.patch
dc049f22 95Patch21: python-internal-build.patch
681ee2f6 96URL: https://rpm.org/
cf169f7c 97BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
cf169f7c 98BuildRequires: %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
29855fc2 99BuildRequires: autoconf >= 2.63
644d8958 100BuildRequires: automake >= 1.4
33be5db0 101BuildRequires: bzip2-devel >= 1.0.2-17
33be5db0 102BuildRequires: elfutils-devel >= 0.108
3e70c06e 103BuildRequires: gettext-tools >= 0.19.2
af0cc499 104BuildRequires: libarchive-devel
241257bf 105BuildRequires: libmagic-devel
d1f5e279 106BuildRequires: openssl-devel >= %{openssl_ver}
b0333243
JR
107%if %{with plugins}
108BuildRequires: audit-libs-devel
109BuildRequires: dbus-devel
6e115b23 110BuildRequires: libselinux-devel >= 2.1.0
6e115b23 111%endif
84cdee7a
JB
112# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
113BuildRequires: libstdc++-devel
b60c74c3 114BuildRequires: libtool >= 1:1.4.2-9
5c767dc1 115BuildRequires: lua53-devel >= 5.3.5
127a0b3c 116BuildRequires: ossp-uuid-devel
7973b351 117BuildRequires: patch >= 2.2
1d49ffbc 118BuildRequires: popt-devel >= %{reqpopt_ver}
f9d0e5f6
JR
119%{?with_python2:BuildRequires: python-devel >= 1:2.3}
120%{?with_python3:BuildRequires: python3-devel}
950eead3 121BuildRequires: python-modules >= 1:2.3
f9d0e5f6
JR
122%if %{with python2} || %{with python3}
123BuildRequires: rpm-pythonprov
124%endif
e56a10a9 125BuildRequires: tcl
77fcdbf7 126BuildRequires: xz-devel
3acb62f3 127BuildRequires: zlib-devel
34865f27 128BuildRequires: zstd-devel
5c2ab5c7
AM
129%if %{with apidocs}
130BuildRequires: doxygen
131BuildRequires: ghostscript
132BuildRequires: graphviz
133BuildRequires: tetex-pdftex
134%endif
d25ec6ea 135Requires(posttrans): coreutils
9fe07969
JR
136Requires: %{name}-base = %{epoch}:%{version}-%{release}
137Requires: %{name}-lib = %{epoch}:%{version}-%{release}
d1f5e279 138Requires: FHS >= 3.0-2
fb35e2d9 139Requires: openssl >= %{openssl_ver}
10abbd40 140Requires: popt >= %{reqpopt_ver}
b0333243
JR
141%if %{with recommends_tags}
142Recommends: rpm-plugin-audit
143Recommends: rpm-plugin-prioreset
144Recommends: rpm-plugin-syslog
145Recommends: rpm-plugin-systemd-inhibit
146%endif
0229a8b9
AM
147Provides: rpm-db-ver = %{reqdb_ver}
148Obsoletes: rpm-getdeps
d1f5e279 149Obsoletes: rpm-utils-perl
f57f030d 150Obsoletes: rpm-utils-static
874f4c9a 151Conflicts: glibc < 2.2.92
8ee1c72c
AM
152# db4.6 poldek needed
153Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
154# segfaults with lzma 0.42.2
155Conflicts: lzma-libs < 4.999.3
e4084afd 156Conflicts: util-vserver < 0.30.216-1.pre3034.7
1d49ffbc 157BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 158
4adb7d05 159%define _binary_payload w9.gzdio
6d82b332 160
4cd84746 161# don't require very fresh rpm.macros to build
950eead3 162%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
af0cc499 163%define ix86 i386 i486 i586 i686 athlon geode pentium3 pentium4
80e9f34d 164%define ppc ppc ppc7400 ppc7450
9f517079 165%define x8664 amd64 ia32e x86_64
4cd84746 166
d755a548 167%define _rpmlibdir /usr/lib/rpm
950eead3 168%define _noautocompressdoc RPM-GPG-KEY
d755a548 169
ff7bc1e6 170%description
171RPM is a powerful package manager, which can be used to build,
172install, query, verify, update, and uninstall individual software
cf6faebc 173packages. A package consists of an archive of files, and package
fed73700 174information, including name, version, and description.
175
dd85fadc
JR
176%description -l de.UTF-8
177RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 178Installation, Anfrage, Verifizierung, Aktualisierung und
179Uninstallation individueller Softwarepakete. Ein Paket besteht aus
180einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 181Beschreibung.
182
dd85fadc 183%description -l es.UTF-8
313a4d1a 184RPM es un poderoso administrador de paquetes, que puede ser usado para
185construir, instalar, pesquisar, verificar, actualizar y desinstalar
186paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
187almacenaje de archivos, y información sobre el paquete, incluyendo
188nombre, versión y descripción.
189
190%description -l pl.UTF-8
191RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
192przebudowanie, instalację czy weryfikację dowolnego pakietu.
193Informacje dotyczące każdego pakietu, takie jak jego opis, lista
194plików wchodzących w skład pakietu, zależności od innych pakietów, są
195przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 196odpytywania programu rpm.
197
dd85fadc
JR
198%description -l pt_BR.UTF-8
199RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 200construir, instalar, pesquisar, verificar, atualizar e desinstalar
201pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
202arquivos e informações adicionais, incluindo nome, versão e descrição
203do pacote, permissões dos arquivos, etc.
204
205%description -l ru.UTF-8
206RPM - это мощный менеджер пакетов, который может быть использован для
207создания, инсталляции, запросов (query), проверки, обновления и
208удаления программных пакетов. Пакет состоит из файлового архива и
209служебной информации, включающей название, версию, описание и другие
210данные о пакете.
211
212%description -l uk.UTF-8
213RPM - це потужний менеджер пакетів, що може бути використаний для
214створення, інсталяції, запитів (query), перевірки, поновлення та
215видалення програмних пакетів. Пакет складається з файлового архіву та
216службової інформації, що містить назву, версію, опис та іншу
217інформацію про пакет.
7c6dc55f 218
66edd895
JB
219%package base
220Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 221Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 222Group: Base
1d9ca0c1 223Requires: filesystem
950eead3 224Obsoletes: rpm-scripts
66edd895
JB
225Obsoletes: vserver-rpm
226
227%description base
228The RPM base package contains scripts used by rpm packages themselves.
229These include:
230- scripts for adding/removing groups and users needed for rpm
231 packages,
232- banner.sh to display %%banner messages from rpm scriptlets.
233
dd85fadc
JR
234%description base -l pl.UTF-8
235Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 236Zawiera on:
dd85fadc
JR
237- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
238- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 239
69131f1a
JB
240%package lib
241Summary: RPMs library
4ea2ed33 242Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 243Group: Libraries
cf169f7c 244Requires: %{reqdb_pkg} >= %{reqdb_pkgver}
cf169f7c 245Requires: %{reqdb_pkg}-sql >= %{reqdb_pkgver}
241257bf 246Requires: libmagic >= 1.15-2
d1f5e279 247Requires: openssl >= %{openssl_ver}
69131f1a 248Requires: popt >= %{reqpopt_ver}
d1795eb0 249Obsoletes: rpm-libs
69131f1a
JB
250# avoid SEGV caused by mixed db versions
251Conflicts: poldek < 0.18.1-16
252
253%description lib
254RPMs library.
255
dd85fadc 256%description lib -l pl.UTF-8
69131f1a
JB
257Biblioteki RPM-a.
258
fed73700 259%package devel
3f2d796a 260Summary: Header files for rpm libraries
4ea2ed33
ER
261Summary(de.UTF-8): Header-Dateien für rpm Libraries
262Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
263Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
264Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
265Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
266Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 267Group: Development/Libraries
9fe07969 268Requires: %{name}-lib = %{epoch}:%{version}-%{release}
cf169f7c 269Requires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
fea3cb89 270Requires: bzip2-devel
5c583f90 271Requires: elfutils-devel
241257bf 272Requires: libmagic-devel
d1f5e279 273Requires: openssl-devel >= %{openssl_ver}
c7b2d5f9
KK
274%if %{with selinux}
275Requires: libselinux-devel
276Requires: libsemanage-devel
277Requires: libsepol-devel
278%endif
a998ac11 279Requires: popt-devel >= %{reqpopt_ver}
fea3cb89 280Requires: zlib-devel
cf6faebc 281
282%description devel
3f2d796a
JB
283The RPM packaging system includes C libraries that make it easy to
284manipulate RPM packages and databases. They are intended to ease the
cf6faebc 285creation of graphical package managers and other tools that need
3f2d796a
JB
286intimate knowledge of RPM packages. This package contains header files
287for these libraries.
fed73700 288
dd85fadc
JR
289%description devel -l de.UTF-8
290Der RPM-Packensystem enthält eine C-Library, die macht es einfach
291RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 292Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 293Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
294
dd85fadc 295%description devel -l es.UTF-8
313a4d1a 296El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
297fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
298facilitar la creación de administradores gráficos de paquetes y otras
20f89981 299herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 300
dd85fadc
JR
301%description devel -l pl.UTF-8
302System RPM zawiera biblioteki C, które ułatwiają manipulowanie
303pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
304graficznych programów zarządzających pakietami oraz innych narzędzi,
305które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
306zawiera pliki nagłówkowe wspomnianych bibliotek.
307
308%description devel -l pt_BR.UTF-8
309O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
310a manipulação de pacotes e bases de dados RPM. Seu objetivo é
311facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 312ferramentas que precisem de conhecimento profundo de pacotes RPM.
313
dd85fadc
JR
314%description devel -l ru.UTF-8
315Система управления пакетами RPM содержит библиотеку C, которая
316упрощает манипуляцию пакетами RPM и соответствующими базами данных.
317Эта библиотека предназначена для облегчения создания графических
318пакетных менеджеров и других утилит, которым необходимо работать с
319пакетами RPM.
7c6dc55f 320
dd85fadc
JR
321%description devel -l uk.UTF-8
322Система керування пакетами RPM містить бібліотеку C, котра спрощує
323роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
324призначена для полегшення створення графічних пакетних менеджерів та
325інших утиліт, що працюють з пакетами RPM.
7c6dc55f 326
fed73700 327%package utils
8482995c 328Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
329Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
330Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 331Group: Applications/File
9fe07969 332Requires: %{name} = %{epoch}:%{version}-%{release}
a998ac11 333Requires: popt >= %{reqpopt_ver}
af0cc499
JR
334%if %{with recommends_tags}
335Recommends: bzip2
336Recommends: gzip
86b85368 337%endif
695e60ad 338Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 339
340%description utils
8482995c 341Additional utilities for managing RPM packages and database.
fed73700 342
dd85fadc
JR
343%description utils -l de.UTF-8
344Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 345
dd85fadc
JR
346%description utils -l pl.UTF-8
347Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 348
fed73700 349%package build
e191287c 350Summary: Scripts for building binary RPM packages
4ea2ed33
ER
351Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
352Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
353Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
354Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
355Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 356Group: Applications/File
f15ca8ca
ER
357Requires(pretrans): coreutils
358Requires(pretrans): findutils
716fe3ca 359Requires: %{name}-build-macros >= 1.712
9fe07969 360Requires: %{name}-utils = %{epoch}:%{version}-%{release}
e191287c 361Requires: /bin/id
362Requires: awk
cfa7898a 363Requires: bzip2
e950a6d7 364Requires: chrpath >= 0.10-4
b6547e10 365Requires: cpio
e191287c 366Requires: diffutils
195f647c 367Requires: elfutils
583135b4 368Requires: file >= 4.17
e191287c 369Requires: fileutils
370Requires: findutils
950eead3
ER
371%ifarch athlon
372Requires: gcc >= 3.0.3
373%else
374Requires: gcc
375%endif
e191287c 376Requires: glibc-devel
377Requires: grep
378Requires: gzip
379Requires: make
380Requires: patch
adbd4815 381Requires: sed >= 4.0
e191287c 382Requires: sh-utils
adbd4815 383Requires: tar >= 1:1.22
e191287c 384Requires: textutils
3acb62f3 385Requires: which
adbd4815 386Requires: xz
ca3648b1 387Provides: rpmbuild(monoautodeps)
37ea389a 388Provides: rpmbuild(noauto) = 3
02d17bf9 389%ifarch %{x8664}
195f647c
JB
390Conflicts: automake < 1:1.7.9-2
391Conflicts: libtool < 2:1.5-13
392%endif
0096c5cd 393
e2025ad1 394%description build
58399c37 395Scripts for building binary RPM packages.
fed73700 396
dd85fadc
JR
397%description build -l de.UTF-8
398Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 399
dd85fadc
JR
400%description build -l pl.UTF-8
401Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 402
dd85fadc
JR
403%description build -l pt_BR.UTF-8
404Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 405construir pacotes usando o RPM.
e73478cd 406
dd85fadc
JR
407%description build -l ru.UTF-8
408Различные вспомогательные скрипты и исполняемые программы, которые
409используются для сборки RPM'ов.
7c6dc55f 410
dd85fadc
JR
411%description build -l uk.UTF-8
412Різноманітні допоміжні скрипти та утиліти, які використовуються для
413побудови RPM'ів.
7c6dc55f 414
8482995c
JB
415%package javaprov
416Summary: Additional utilities for checking Java provides/requires in RPM packages
417Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
418Group: Applications/File
9fe07969 419Requires: %{name} = %{epoch}:%{version}-%{release}
8482995c
JB
420Requires: file
421Requires: findutils >= 1:4.2.26
422Requires: mktemp
423Requires: unzip
424
425%description javaprov
426Additional utilities for checking Java provides/requires in RPM
427packages.
428
429%description javaprov -l pl.UTF-8
430Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
431RPM.
432
69131f1a 433%package perlprov
8482995c 434Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 435Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 436Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a 437Group: Applications/File
9fe07969 438Requires: %{name} = %{epoch}:%{version}-%{release}
b82853ee 439Requires: perl-Encode
69131f1a
JB
440Requires: perl-devel
441Requires: perl-modules
442
443%description perlprov
8482995c 444Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
445packages.
446
dd85fadc
JR
447%description perlprov -l de.UTF-8
448Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 449
dd85fadc 450%description perlprov -l pl.UTF-8
8482995c
JB
451Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
452pakietach RPM.
69131f1a
JB
453
454%package pythonprov
8482995c
JB
455Summary: Python macros, which simplifies creation of RPM packages with Python software
456Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a 457Group: Applications/File
9fe07969 458Requires: %{name} = %{epoch}:%{version}-%{release}
cd800b3c 459Requires: python
3acb62f3 460Requires: python-modules
d1f5e279 461Requires: python-setuptools
69131f1a
JB
462
463%description pythonprov
8482995c 464Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
465software.
466
dd85fadc 467%description pythonprov -l pl.UTF-8
8482995c 468Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
469Pythonie.
470
471%package php-pearprov
8482995c
JB
472Summary: Additional utilities for checking PHP PEAR provides/requires in RPM packages
473Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
69131f1a 474Group: Applications/File
9fe07969 475Requires: %{name} = %{epoch}:%{version}-%{release}
632f1b5c 476Requires: sed >= 4.0
1b39d378 477Suggests: php-pear-PHP_CompatInfo
69131f1a
JB
478
479%description php-pearprov
8482995c 480Additional utilities for checking PHP PEAR provides/requires in RPM
69131f1a
JB
481packages.
482
dd85fadc 483%description php-pearprov -l pl.UTF-8
8482995c
JB
484Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
485pakietach RPM.
69131f1a 486
ec49e9fb
ER
487%package rubyprov
488Summary: Ruby tools, which simplify creation of RPM packages with Ruby software
489Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
490Group: Applications/File
9fe07969 491Requires: %{name} = %{epoch}:%{version}-%{release}
ec49e9fb
ER
492Requires: ruby
493Requires: ruby-modules
b53b1f84 494Requires: ruby-rubygems
ec49e9fb
ER
495
496%description rubyprov
497Ruby tools, which simplifies creation of RPM packages with Ruby
498software.
499
500%description rubyprov -l pl.UTF-8
501Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
502Ruby.
503
69131f1a
JB
504%package -n python-rpm
505Summary: Python interface to RPM library
4ea2ed33
ER
506Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
507Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a 508Group: Development/Languages/Python
9fe07969 509Requires: %{name} = %{epoch}:%{version}-%{release}
3acb62f3 510Requires: python
69131f1a
JB
511Obsoletes: rpm-python
512
513%description -n python-rpm
f9d0e5f6 514The python-rpm package contains a module which permits applications
69131f1a
JB
515written in the Python programming language to use the interface
516supplied by RPM (RPM Package Manager) libraries.
517
518This package should be installed if you want to develop Python
519programs that will manipulate RPM packages and databases.
520
dd85fadc 521%description -n python-rpm -l pl.UTF-8
f9d0e5f6 522Pakiet python-rpm zawiera moduł, który pozwala aplikacjom napisanym w
dd85fadc 523Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 524
dd85fadc
JR
525Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
526Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 527
dd85fadc 528%description -n python-rpm -l pt_BR.UTF-8
f9d0e5f6 529O pacote python-rpm contém um módulo que permite que aplicações
69131f1a
JB
530escritas em Python utilizem a interface fornecida pelas bibliotecas
531RPM (RPM Package Manager).
532
dd85fadc 533Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
534Python para manipular pacotes e bancos de dados RPM.
535
f9d0e5f6
JR
536%package -n python3-rpm
537Summary: Python 3 interface to RPM library
538Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki RPM-a
539Summary(pt_BR.UTF-8): Módulo Python 3 para aplicativos que manipulam pacotes RPM
540Group: Development/Languages/Python
9fe07969 541Requires: %{name} = %{epoch}:%{version}-%{release}
f9d0e5f6
JR
542Requires: python3
543
544%description -n python3-rpm
545The python3-rpm package contains a module which permits applications
546written in the Python 3 programming language to use the interface
547supplied by RPM (RPM Package Manager) libraries.
548
549This package should be installed if you want to develop Python 3
550programs that will manipulate RPM packages and databases.
551
552%description -n python3-rpm -l pl.UTF-8
553Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
554Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki RPM-a.
555
556Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
557Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
558
559%description -n python3-rpm -l pt_BR.UTF-8
560O pacote python3-rpm contém um módulo que permite que aplicações
561escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
562RPM (RPM Package Manager).
563
564Esse pacote deve ser instalado se você quiser desenvolver programas em
565Python 3 para manipular pacotes e bancos de dados RPM.
566
b0333243
JR
567%package plugin-audit
568Summary: Plugin for logging audit events on package operations
569Group: System/Base
9fe07969 570Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
571
572%description plugin-audit
573Plugin for libaudit support
574
575%package plugin-syslog
576Summary: Plugin for syslog functionality
577Group: System/Base
9fe07969 578Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
579
580%description plugin-syslog
581This plugin exports RPM actions to the system log.
582
583%package plugin-systemd-inhibit
584Summary: Plugin for systemd inhibit functionality
585Group: System/Base
9fe07969 586Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
587
588%description plugin-systemd-inhibit
589This plugin blocks systemd from entering idle, sleep or shutdown while
590an rpm transaction is running using the systemd-inhibit mechanism.
591
592%package plugin-ima
593Summary: Plugin for IMA file signatures
594Group: Base
9fe07969 595Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
596
597%description plugin-ima
598This plugin adds support for enforcing and verifying IMA file
599signatures in an rpm.
600
601%package plugin-prioreset
602Summary: Plugin for resetting scriptlet priorities for SysV init
603Group: Base
9fe07969 604Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
605
606%description plugin-prioreset
607This plugin is useful on legacy SysV init systems if you run rpm
608transactions with nice/ionice priorities. Should not be used on
609systemd systems.
610
611%package plugin-selinux
612Summary: Plugin for SELinux functionality
8191f3c5 613Group: Base
9fe07969 614Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
615Requires: libselinux >= 2.1.0
616
617%description plugin-selinux
618Plugin for SELinux functionality.
619
8191f3c5
JR
620%package sign
621Summary: Package signing support
622Group: Base
9fe07969 623Requires: %{name}-lib = %{epoch}:%{version}-%{release}
8191f3c5
JR
624
625%description sign
626This package contains support for digitally signing RPM packages.
627
5c2ab5c7
AM
628%package apidocs
629Summary: RPM API documentation and guides
630Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
631Group: Documentation
d308de4c 632BuildArch: noarch
5c2ab5c7
AM
633
634%description apidocs
635Documentation for RPM API and guides in HTML format generated from rpm
636sources by doxygen.
637
638%description apidocs -l pl.UTF-8
639Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
640źrodeł RPM-a przez doxygen.
641
e2025ad1 642%prep
c546a4d6 643%setup -q -n %{name}-%{version}%{?subver}
af0cc499 644%patch0 -p1
2f0ee4ec 645%patch1 -p1
4d5b8e4c 646%patch2 -p1
af0cc499 647%patch3 -p1
7a3b1f24
AM
648%patch4 -p1
649%patch5 -p1
3c7590cc 650%patch6 -p1
af0cc499
JR
651%patch7 -p0
652%patch8 -p1
c38bf1df 653%patch9 -p1
af0cc499
JR
654%patch10 -p1
655%patch11 -p1
656%patch12 -p1
657%patch13 -p1
658%patch14 -p1
7033e976 659%patch15 -p1
af0cc499
JR
660%patch16 -p1
661%patch17 -p1
662#%patch18 -p1
e8836e1f 663%patch20 -p1
dc049f22 664%patch21 -p1
883e0fac 665
34865f27
JR
666install %{SOURCE8} scripts/php.prov.in
667install %{SOURCE9} scripts/php.req.in
0bf34f68 668install %{SOURCE11} scripts/perl.prov.in
e2489d8e 669cp -p %{SOURCE30} scripts/rubygems.rb
63194730 670cp -p %{SOURCE31} scripts/gem_helper.rb
08697680 671
70f8787d 672%{__mv} -f scripts/perl.req{,.in}
633d1e9e 673
cd86db2e 674# generate Group translations to *.po
80b8a1f9 675awk -f %{SOURCE6} %{SOURCE1}
fefe9d30 676
91ee86a9 677install %{SOURCE26} tools/rpmdb_checkversion.c
8e8746c0 678install %{SOURCE28} tools/rpmdb_reset.c
91ee86a9 679
40675133
JR
680%{__sed} -i -e '1s,/usr/bin/python,%{__python},' scripts/pythondistdeps.py
681
87ef0d95 682%build
ea816ea6 683%{__libtoolize}
ceaaacee 684%{__aclocal}
4cd84746 685%{__autoheader}
7a9d72ce 686%{__autoconf}
7a9d72ce 687%{__automake}
7a9d72ce 688
048d06f8
JR
689# rpm checks for CPU type at runtime, but it looks better
690sed -i \
691 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
692 -e 's|@host_cpu@|%{_target_cpu}|' \
693 -e 's|@host_os@|%{_target_os}|' \
fb35e2d9 694 macros.in
048d06f8 695
5c767dc1 696CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
624f96ff 697%configure \
01d7a578 698 WITH_PERL_VERSION=no \
bba1059c 699 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
dcf91c25 700 __GPG=%{_bindir}/gpg \
f9d0e5f6
JR
701 %{?with_python3:PYTHON=python3} \
702 %{!?with_python3:%{?with_python2:PYTHON=python2}} \
3a3e476f 703 --disable-silent-rules \
cd86db2e 704 --enable-shared \
34865f27 705 --enable-bdb \
af0cc499 706 --enable-zstd \
fb35e2d9 707 --with-crypto=openssl \
c38bf1df 708 --with-lua \
34865f27
JR
709 --with-cap \
710 --with-acl \
711 --with-audit \
af0cc499 712 --with-archive \
f9d0e5f6
JR
713%if %{with python2} || %{with python3}
714 --enable-python \
715%endif
b0333243
JR
716 --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
717 %{!?with_plugins:--disable-plugins} \
34865f27
JR
718 --with-vendor=pld
719
34865f27
JR
720# --enable-ndb (EXPERIMENTAL) enable the new rpm database format
721# --enable-lmdb=[yes/no/auto] (EXPERIMENTAL) build with LMDB rpm database format support (default=auto)
34865f27 722# --with-imaevm build with imaevm support
cf6faebc 723
5c767dc1 724%{__make}
5c2ab5c7 725
fb95de52
JR
726%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
727 -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
8e8746c0
JR
728%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
729 -o tools/rpmdb_reset -ldb-%{reqdb_ver}
fb95de52
JR
730
731if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
732 echo "Error linking rpmdb tools!"
733 exit 1
734fi
8e8746c0
JR
735if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
736 echo "Error linking rpmdb tools!"
737 exit 1
738fi
91ee86a9 739
f9d0e5f6
JR
740%if %{with python2}
741cd python
742%py_build
743cd ..
744%endif
745
746%if %{with python3}
747cd python
748%py3_build
749%endif
750
b064b8e6 751%install
ff7bc1e6 752rm -rf $RPM_BUILD_ROOT
d1f5e279 753install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
7d12560f 754 $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/var/cache/hrmib}
54eb1770 755
d1f5e279 756cp -p %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 757
d1f5e279 758%{__make} install \
241257bf
AM
759 pkgconfigdir=%{_pkgconfigdir} \
760 DESTDIR=$RPM_BUILD_ROOT
718426e1 761
c546a4d6 762# cleanup
c2683840 763%ifnarch %{ix86} %{x8664} x32
2f409bb7 764rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
34865f27 765rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
2f409bb7
JR
766rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
767rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
768rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
769rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
770rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
771rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
25ac75ae
AM
772%endif
773
c2683840 774%ifnarch %{x8664} x32
2f409bb7
JR
775rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
776rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
777rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
778rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
25ac75ae
AM
779%endif
780
c546a4d6 781%ifnarch %{ppc}
34865f27
JR
782rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
783rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
784rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
785rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
786rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
2f409bb7 787rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
34865f27 788rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
25ac75ae
AM
789%endif
790
34865f27 791rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
2f409bb7
JR
792rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
793rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
794rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
795rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
34865f27 796rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
2f409bb7 797rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
34865f27 798rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
2f409bb7 799rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
c546a4d6 800
3a3e476f 801%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
644d8958 802
396a7387
JR
803install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
804cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_rpmlibdir}/pld/macros
805
d1f5e279
JR
806cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
807cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
808cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
809cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
810cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
811cp -p scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
0bf34f68 812cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
d1f5e279
JR
813cp -p %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
814cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
815cp -p %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 816
d1f5e279 817cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 818
950eead3
ER
819install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
820
d1f5e279
JR
821cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
822cp -p %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
823cp -p %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
824cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
825cp -p %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
826cp -p %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
827cp -p %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 828
950eead3
ER
829touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
830touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
d1f5e279 831cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
950eead3
ER
832touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
833touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
834touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
fbc0ff35 835
f9d0e5f6
JR
836cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
837cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
838cp -p %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
9776a251 839
950eead3 840# move rpm to /bin
8191f3c5
JR
841%{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
842ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
843ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
844
950eead3 845# move essential libs to /lib (libs that /bin/rpm links to)
40675133
JR
846for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
847 mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
848 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
c2673e18
AF
849done
850
7d12560f
JR
851#./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
852
f9d0e5f6
JR
853%if %{with python2}
854# Remove anything that rpm make install might put there
855%{__rm} -rf $RPM_BUILD_ROOT%{py_sitedir}
856cd python
857%py_install
858%py_postclean
859cd ..
860%endif
6f18cdb7 861
f9d0e5f6
JR
862%if %{with python3}
863# Remove anything that rpm make install might put there
864%{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
865cd python
866%py3_install
867cd ..
dae5e1a8 868%endif
01d7a578 869
d1f5e279
JR
870%{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
871
01d7a578 872# wrong location, not used anyway
2f409bb7 873%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
01d7a578 874
90b03dd6 875%find_lang %{name}
cf6faebc 876
13eb5ebf 877%clean
d7df46b8 878rm -rf $RPM_BUILD_ROOT
76214164 879
cc1a4992
ER
880%pretrans
881# this needs to be a dir
882if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
c1097150 883 umask 022
cc1a4992
ER
884 mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
885 mkdir %{_sysconfdir}/rpm/sysinfo
886fi
887
be4d3036 888%posttrans
d25ec6ea 889if [ -e /var/lib/rpm/Packages ] && \
f9d0e5f6 890 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
d25ec6ea 891 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
6a934782 892 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 893 echo
e4dd6a34 894 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
895 echo
896 fi
3ca91ccd
JR
897 echo
898 echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
899 echo 'you should ignore it and restart poldek'
900 echo
f9d0e5f6 901 %{_rpmlibdir}/dbupgrade.sh
be4d3036 902fi
f7779567 903
b7ee97ef
JR
904%triggerpostun -- %{name} < 4.4.9-44
905%{_rpmlibdir}/hrmib-cache
906
ceaaacee
JB
907%post lib -p /sbin/ldconfig
908%postun lib -p /sbin/ldconfig
76214164 909
37a5a2fc 910%pretrans build
d755a548 911find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 912
3684d90f
JB
913%files -f %{name}.lang
914%defattr(644,root,root,755)
d1f5e279 915%doc ChangeLog CREDITS README
3684d90f 916
3acb62f3
ER
917%dir /etc/pki/rpm-gpg
918/etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
54eb1770 919
7a9d72ce 920%attr(755,root,root) /bin/rpm
8191f3c5
JR
921%attr(755,root,root) %{_bindir}/rpmdb
922%attr(755,root,root) %{_bindir}/rpmkeys
923%attr(755,root,root) %{_bindir}/rpmquery
924%attr(755,root,root) %{_bindir}/rpmverify
e73478cd 925
66edd895 926%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 927%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
950eead3 928%dir %{_sysconfdir}/rpm/sysinfo
caf453d4 929# these are ok to be replaced
950eead3 930%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
caf453d4 931
09bb810c 932%{_mandir}/man8/rpm.8*
8191f3c5
JR
933%{_mandir}/man8/rpmdb.8*
934%{_mandir}/man8/rpmkeys.8*
935%{_mandir}/man8/rpm-misc.8*
feb1f12e 936%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 937%lang(ja) %{_mandir}/ja/man8/rpm.8*
d1f5e279 938%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 939%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 940%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 941%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 942
7d12560f 943%dir /var/lib/rpm
4acac5de 944
cf709a39
ER
945# exported package NVRA (stamped with install tid)
946# net-snmp hrSWInstalledName queries, bash-completions
947%dir /var/cache/hrmib
948
d755a548 949%{_rpmlibdir}/rpmpopt*
8191f3c5 950%{_rpmlibdir}/rpmrc
d755a548 951%{_rpmlibdir}/macros
08697680 952%dir %{_rpmlibdir}/macros.d
e8836e1f 953%dir %{_rpmlibdir}/platform
40675133 954%{_rpmlibdir}/platform/noarch-*
c2683840 955%ifarch %{ix86} %{x8664} x32
34865f27
JR
956%{_rpmlibdir}/platform/athlon*
957%{_rpmlibdir}/platform/geode*
40675133
JR
958%{_rpmlibdir}/platform/i?86*
959%{_rpmlibdir}/platform/pentium*
34865f27
JR
960%endif
961%ifarch %{x8664} x32
962%{_rpmlibdir}/platform/amd64*
963%{_rpmlibdir}/platform/ia32e*
964%{_rpmlibdir}/platform/x86_64*
83a0601a 965%{_rpmlibdir}/platform/x32*
e23edf35
JR
966%endif
967%ifarch alpha
40675133 968%{_rpmlibdir}/platform/alpha*
e23edf35
JR
969%endif
970%ifarch ia64
40675133 971%{_rpmlibdir}/platform/ia64*
e23edf35
JR
972%endif
973%ifarch mips mipsel mips64 mips64el
40675133 974%{_rpmlibdir}/platform/mips*
e23edf35
JR
975%endif
976%ifarch %{ppc}
40675133 977%{_rpmlibdir}/platform/ppc*
e23edf35
JR
978%endif
979%ifarch sparc sparc64
40675133 980%{_rpmlibdir}/platform/sparc*
e23edf35 981%endif
3684d90f 982
396a7387
JR
983%{_rpmlibdir}/pld/macros
984
cf709a39
ER
985%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
986
f9d0e5f6
JR
987%attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
988%attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
989%attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
df50421f 990
7d12560f
JR
991# valgrind suppression file for rpm
992%{_rpmlibdir}/rpm.supp
993
66edd895
JB
994%files base
995%defattr(644,root,root,755)
492a2bd4 996%dir %{_sysconfdir}/rpm
66edd895
JB
997%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
998%dir %{_rpmlibdir}
999%attr(755,root,root) %{_bindir}/banner.sh
1000%attr(755,root,root) %{_rpmlibdir}/user_group.sh
1001%dir /var/lib/banner
1002
874f4c9a
MM
1003%files lib
1004%defattr(644,root,root,755)
40675133
JR
1005%attr(755,root,root) /%{_lib}/librpm.so.9
1006%attr(755,root,root) /%{_lib}/librpm.so.%{sover}
1007%attr(755,root,root) /%{_lib}/librpmbuild.so.9
1008%attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
1009%attr(755,root,root) /%{_lib}/librpmio.so.9
1010%attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
1011%attr(755,root,root) /%{_lib}/librpmsign.so.9
1012%attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
b0333243 1013%{?with_plugins:%dir %{_libdir}/rpm-plugins}
874f4c9a 1014
69131f1a
JB
1015%files devel
1016%defattr(644,root,root,755)
69131f1a 1017%attr(755,root,root) %{_libdir}/librpm.so
950eead3 1018%attr(755,root,root) %{_libdir}/librpmbuild.so
69131f1a 1019%attr(755,root,root) %{_libdir}/librpmio.so
40675133 1020%attr(755,root,root) %{_libdir}/librpmsign.so
950eead3
ER
1021%{_libdir}/librpm*.la
1022%{_includedir}/rpm
1023%{_pkgconfigdir}/*.pc
69131f1a 1024
69131f1a
JB
1025%files utils
1026%defattr(644,root,root,755)
d1f5e279 1027%attr(755,root,root) %{_bindir}/rpm2archive
69131f1a 1028%attr(755,root,root) %{_bindir}/rpm2cpio
fc36dfd5 1029%attr(755,root,root) %{_bindir}/rpmgraph
d1f5e279 1030%attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
69131f1a 1031%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
69131f1a 1032%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
25e974c7 1033%attr(755,root,root) %{_rpmlibdir}/tgpg
d1f5e279
JR
1034%attr(755,root,root) %{_rpmlibdir}/debugedit
1035%attr(755,root,root) %{_rpmlibdir}/rpmdeps
69131f1a
JB
1036%{_mandir}/man8/rpm2cpio.8*
1037%{_mandir}/man8/rpmdeps.8*
fc36dfd5 1038%{_mandir}/man8/rpmgraph.8*
69131f1a 1039%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
d1f5e279 1040%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
69131f1a 1041%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
69131f1a 1042%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
d1f5e279 1043%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
fc36dfd5
JR
1044%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
1045%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
69131f1a 1046
3684d90f 1047%files build
a45ae6d8 1048%defattr(644,root,root,755)
66edd895 1049%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
1050%attr(755,root,root) %{_rpmlibdir}/brp-*
1051%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548 1052%attr(755,root,root) %{_rpmlibdir}/compress-doc
d755a548 1053%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
d755a548 1054%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d1f5e279 1055%attr(755,root,root) %{_rpmlibdir}/elfdeps
01d7a578 1056%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
c75b3936 1057%attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
01d7a578
JB
1058# needs hacked pkg-config to return anything
1059%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
d1f5e279 1060%attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
428645e9
JR
1061# we always used scripts provided by mono-devel, maybe move them here
1062#%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1063#%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
37e965e8 1064
70f8787d 1065%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 1066# must be here for "Requires: rpm-*prov" to work
40675133
JR
1067#%{_rpmlibdir}/macros.d/cmake
1068#%{_rpmlibdir}/macros.d/gstreamer
1069#%{_rpmlibdir}/macros.d/java
1070#%{_rpmlibdir}/macros.d/libtool
1071#%{_rpmlibdir}/macros.d/mono
1072#%{_rpmlibdir}/macros.d/perl
1073#%{_rpmlibdir}/macros.d/php
1074#%{_rpmlibdir}/macros.d/pkgconfig
1075#%{_rpmlibdir}/macros.d/python
1076#%{_rpmlibdir}/macros.d/ruby
1077#%{_rpmlibdir}/macros.d/selinux
1078#%{_rpmlibdir}/macros.d/tcl
1079#%{_rpmlibdir}/macros.rpmbuild
f9d0e5f6 1080
7d12560f
JR
1081%attr(755,root,root) %{_rpmlibdir}/check-buildroot
1082%attr(755,root,root) %{_rpmlibdir}/check-prereqs
1083%attr(755,root,root) %{_rpmlibdir}/check-rpaths
1084%attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
1085%attr(755,root,root) %{_rpmlibdir}/debuginfo.prov
1086%attr(755,root,root) %{_rpmlibdir}/desktop-file.prov
1087%attr(755,root,root) %{_rpmlibdir}/find-provides
1088%attr(755,root,root) %{_rpmlibdir}/find-requires
1089%attr(755,root,root) %{_rpmlibdir}/metainfo.prov
1090%attr(755,root,root) %{_rpmlibdir}/ocaml-find-provides.sh
1091%attr(755,root,root) %{_rpmlibdir}/ocaml-find-requires.sh
1092%attr(755,root,root) %{_rpmlibdir}/script.req
1093%attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
1094# Fedora has this in -build, but shouldn't this be in -devel?
1095%attr(755,root,root) %{_rpmlibdir}/config.guess
1096%attr(755,root,root) %{_rpmlibdir}/config.sub
1097
f9d0e5f6
JR
1098%dir %{_rpmlibdir}/fileattrs
1099%{_rpmlibdir}/fileattrs/debuginfo.attr
1100%{_rpmlibdir}/fileattrs/desktop.attr
1101%{_rpmlibdir}/fileattrs/elf.attr
1102%{_rpmlibdir}/fileattrs/font.attr
b85e185e 1103%{_rpmlibdir}/fileattrs/java.attr
f9d0e5f6
JR
1104%{_rpmlibdir}/fileattrs/libtool.attr
1105%{_rpmlibdir}/fileattrs/metainfo.attr
1106%{_rpmlibdir}/fileattrs/ocaml.attr
1107%{_rpmlibdir}/fileattrs/perl.attr
1108%{_rpmlibdir}/fileattrs/perllib.attr
1109%{_rpmlibdir}/fileattrs/php.attr
1110%{_rpmlibdir}/fileattrs/pkgconfig.attr
1111%{_rpmlibdir}/fileattrs/python.attr
1112%{_rpmlibdir}/fileattrs/pythondist.attr
1113%{_rpmlibdir}/fileattrs/script.attr
77fcdbf7 1114
874f4c9a
MM
1115%attr(755,root,root) %{_bindir}/gendiff
1116%attr(755,root,root) %{_bindir}/rpmbuild
d1f5e279 1117%attr(755,root,root) %{_bindir}/rpmspec
874f4c9a 1118
a00926bc 1119%{_mandir}/man1/gendiff.1*
d1f5e279 1120%lang(pl) %{_mandir}/pl/man1/gendiff.1*
874f4c9a 1121%{_mandir}/man8/rpmbuild.8*
fefe9d30 1122%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
fefe9d30 1123%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
d1f5e279 1124%{_mandir}/man8/rpmspec.8*
f3fe287f 1125
7d8492bb
JB
1126%files javaprov
1127%defattr(644,root,root,755)
1128%attr(755,root,root) %{_rpmlibdir}/java-find-requires
1129# needs jar (any jdk), jcf-dump (gcc-java) to work
40675133 1130#%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
7d8492bb 1131
ec49e9fb
ER
1132%files rubyprov
1133%defattr(644,root,root,755)
40675133
JR
1134#%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1135#%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
ec49e9fb 1136
89334051
AF
1137%files perlprov
1138%defattr(644,root,root,755)
d755a548 1139%attr(755,root,root) %{_rpmlibdir}/perl.*
9805fd6d 1140
80d3b868 1141%files pythonprov
d8fcb9b0 1142%defattr(644,root,root,755)
25d296e1 1143%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
d1f5e279 1144%attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
09bb810c 1145
d36cb682
PG
1146%files php-pearprov
1147%defattr(644,root,root,755)
34865f27
JR
1148%attr(755,root,root) %{_rpmlibdir}/php.prov
1149%attr(755,root,root) %{_rpmlibdir}/php.req
9d09e076 1150%attr(755,root,root) %{_rpmlibdir}/php.req.php
d36cb682 1151
f9d0e5f6 1152%if %{with python2}
cf6faebc 1153%files -n python-rpm
42a0025c 1154%defattr(644,root,root,755)
34865f27
JR
1155%dir %{py_sitedir}/rpm
1156%attr(755,root,root) %{py_sitedir}/rpm/*.so
1157%{py_sitedir}/rpm/*.py[co]
f9d0e5f6
JR
1158%{py_sitedir}/rpm-%{version}-py*.egg-info
1159%endif
1160
1161%if %{with python3}
1162%files -n python3-rpm
1163%defattr(644,root,root,755)
1164%dir %{py3_sitedir}/rpm
1165%attr(755,root,root) %{py3_sitedir}/rpm/*.so
1166%{py3_sitedir}/rpm/*.py
1167%{py3_sitedir}/rpm-%{version}-py*.egg-info
1168%{py3_sitedir}/rpm/__pycache__
50dc9ac0 1169%endif
5c2ab5c7 1170
b0333243
JR
1171%if %{with plugins}
1172%files plugin-audit
1173%defattr(644,root,root,755)
1174%attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
1175
1176%files plugin-syslog
1177%defattr(644,root,root,755)
1178%attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
1179
1180%files plugin-systemd-inhibit
1181%defattr(644,root,root,755)
1182%attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
1183%{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
1184
1185%files plugin-ima
1186%defattr(644,root,root,755)
1187%attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
1188
1189%files plugin-prioreset
1190%defattr(644,root,root,755)
1191%attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
1192
1193%files plugin-selinux
1194%defattr(644,root,root,755)
1195%attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
1196%endif
1197
8191f3c5
JR
1198%files sign
1199%defattr(644,root,root,755)
1200%attr(755,root,root) %{_bindir}/rpmsign
1201%{_mandir}/man8/rpmsign.8*
1202
5c2ab5c7
AM
1203%if %{with apidocs}
1204%files apidocs
1205%defattr(644,root,root,755)
d1f5e279
JR
1206%doc doc/librpm/html/*
1207%endif
This page took 1.29102 seconds and 4 git commands to generate.