]> git.pld-linux.org Git - packages/rpm.git/blame - rpm-perl_req.patch
- handle different forms of "require version"
[packages/rpm.git] / rpm-perl_req.patch
CommitLineData
986c2b93
JB
1--- rpm-4.4.3/scripts/perl.req.orig 2005-11-18 23:00:58.604519312 +0100
2+++ rpm-4.4.3/scripts/perl.req 2005-11-18 23:03:17.506403016 +0100
6ac8ddc0 3@@ -57,7 +57,7 @@
4 foreach $module (sort keys %require) {
5 if (length($require{$module}) == 0) {
6 if ($module =~ /^[0-9._]+$/) {
7- print "perl >= $module\n";
8+ print "perl-base >= $module\n";
9 } else {
10 print "perl($module)\n";
11 }
986c2b93 12@@ -255,11 +255,11 @@
c913cae8 13
986c2b93
JB
14 my $ver=$1;
15 if ($ver =~ /5.00/) {
16- print "perl >= 0:$ver\n";
17+ print "perl-base >= 0:$ver\n";
c913cae8 18 next;
19 }
20 else {
986c2b93
JB
21- print "perl >= 1:$ver\n";
22+ print "perl-base >= 1:$ver\n";
c913cae8 23 next;
24 }
25
This page took 0.090954 seconds and 4 git commands to generate.