]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
- handle github archive url (bitcoin.spec as example)
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 29 Apr 2013 20:43:08 +0000 (22:43 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 29 Apr 2013 20:43:08 +0000 (22:43 +0200)
pldnotify.awk

index 5ad01fb0ee6efb514e2535ef4068e41ad7495247..c16e7599b5eab69080c6d57e286e979b3e331223 100755 (executable)
@@ -278,6 +278,11 @@ function get_links(url,filename,   errno,link,oneline,retval,odp,wholeodp,lowero
                d("github tarball url, mungled url to: " url)
        }
 
+       if (url ~/^(http|https):\/\/github.com\/.*\/(.*)\/archive\//) {
+               gsub("\/archive\/.*", "/tags", url)
+               d("github archive url, mungled url to: " url)
+       }
+
        if (url ~/^(http|https):\/\/cgit\..*\/(.*)\/snapshot\//) {
                gsub("\/snapshot\/.*", "/", url)
                d("cgit snapshot tarball url, mungled url to: " url)
This page took 0.063491 seconds and 4 git commands to generate.