]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
Fallback to /tmp.
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 14 Mar 2021 08:39:45 +0000 (09:39 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 14 Mar 2021 08:39:45 +0000 (09:39 +0100)
rediff-patches.py

index beba06da881d2c0ba896385c51cc2efc9fbfe17e..d09c9ee93be8a4aac21e01088491f6acf1e118ee 100755 (executable)
@@ -128,7 +128,10 @@ def main():
     specfile = args.spec
     appsourcedir = os.path.dirname(os.path.abspath(specfile))
 
-    tempdir = tempfile.TemporaryDirectory(dir="/dev/shm")
+    try:
+        tempdir = tempfile.TemporaryDirectory(dir="/dev/shm")
+    except FileNotFoundError as e:
+        tempdir = tempfile.TemporaryDirectory(dir="/tmp")
     topdir = tempdir.name
     builddir = os.path.join(topdir, 'BUILD')
 
This page took 0.113725 seconds and 4 git commands to generate.