builder: unbreak rpm5 detection
authorJan Palus <atler@pld-linux.org>
Sun, 22 Nov 2020 10:50:43 +0000 (11:50 +0100)
committerJan Palus <atler@pld-linux.org>
Sun, 22 Nov 2020 10:50:43 +0000 (11:50 +0100)
builder.sh

index ed2184b002f16c5cff79919780d4d2f9a473eb27..b657e0daa28899f5eba613debc8c691805c19e47 100755 (executable)
@@ -480,7 +480,7 @@ is_rpmorg() {
 
        v=$(rpm --version 2>&1)
        v=${v#RPM version } # rpm 4
-       v=${v#rpm (RPM) } # rpm 5
+       v=${v#rpm \(RPM\) } # rpm 5
 
        case "$v" in
                4.5|5.*)
@@ -489,6 +489,9 @@ is_rpmorg() {
                4.*)
                        return 0;
                        ;;
+               *)
+                       echo "ERROR: unsupported RPM version $v" >&2
+                       exit 1
        esac
 }
 
This page took 0.07892 seconds and 4 git commands to generate.