]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
- autotag: strip branches from pkgs before cvs status -v
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 8 Dec 2010 12:40:27 +0000 (12:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm-build.sh -> 1.65

rpm-build.sh

index 97a110d8facdf9ec39692870496064be12738349..472d6c1d97afa51bc174d274340a2f61936fc759 100644 (file)
@@ -112,9 +112,12 @@ dist-verify() {
 
 # displays latest used tag for a specfile
 autotag() {
-       local out
-       for a in "$@"; do
-               s=${a%.spec}.spec
+       local out s
+       for s in "$@"; do
+               # strip branches
+               s=${s%:*}
+               # ensure package ends with .spec
+               s=${s%.spec}.spec
                out=$(cvs status -v $s | awk "!/Sticky/&&/auto-$dist-/{if (!a++) print \$1}")
                echo "$s:$out"
        done
This page took 0.127765 seconds and 4 git commands to generate.