]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
- assume SPECNAME == PACKAGE_NAME for _{spec,source}dir definition,
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 13 May 2007 14:57:45 +0000 (14:57 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  that't preliminary change if we switch repo to directory per package format

Changed files:
    builder.sh -> 1.503

builder.sh

index b509e8b637960558fc34cef6c84f3728219068bd..0b761866ef8c7ce706764ee1ad65997ef0965c38 100644 (file)
@@ -79,6 +79,7 @@ ICONS=""
 PACKAGE_RELEASE=""
 PACKAGE_VERSION=""
 PACKAGE_NAME=""
+ASSUMED_NAME=""
 PROTOCOL="ftp"
 WGET_RETRIES=${MAX_WGET_RETRIES:-0}
 CVS_RETRIES=${MAX_CVS_RETRIES:-1000}
@@ -597,8 +598,8 @@ init_builder()
        fi
 
        if [ "$NOINIT" != "yes" ] ; then
-               SOURCE_DIR="`eval $RPM $RPMOPTS --eval '%{_sourcedir}'`"
-               SPECS_DIR="`eval $RPM $RPMOPTS --eval '%{_specdir}'`"
+               SOURCE_DIR="`eval $RPM $RPMOPTS --define "name $ASSUMED_NAME" --eval '%{_sourcedir}'`"
+               SPECS_DIR="`eval $RPM $RPMOPTS --define "name $ASSUMED_NAME" --eval '%{_specdir}'`"
        else
                SOURCE_DIR="."
                SPECS_DIR="."
@@ -2068,6 +2069,7 @@ while [ $# -gt 0 ]; do
                                CVSTAG="${SPECFILE##*:}"
                                SPECFILE="${SPECFILE%%:*}"
                        fi
+                       ASSUMED_NAME="${SPECFILE%%:.spec}"
                        shift
        esac
 done
This page took 0.071117 seconds and 4 git commands to generate.