]> git.pld-linux.org Git - packages/rpm-build-macros.git/commitdiff
- 1.723; fix compressing man pages with spaces inside filenames auto/th/rpm-build-macros-1.723-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 1 Jan 2017 11:18:08 +0000 (12:18 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 1 Jan 2017 11:18:08 +0000 (12:18 +0100)
rpm-build-macros.spec
rpm.macros

index 765d69b4915aefb45beb2a04d4aafef13f2a9b3a..079bec14eb2ab5990f770e16b941663aa730fd4b 100644 (file)
@@ -1,4 +1,4 @@
-%define                rpm_macros_rev  1.722
+%define                rpm_macros_rev  1.723
 %define                find_lang_rev   1.38
 Summary:       PLD Linux RPM build macros
 Summary(pl.UTF-8):     Makra do budowania pakietów RPM dla Linuksa PLD
index 1c2a813abbb799558de73b6dbe60220d2fe798f5..1efd2fdd0a5dbbc3388182a3ef7ffcf2f7ed4af1 100644 (file)
@@ -512,8 +512,8 @@ Provides: %{1} = %{?epoch:%{epoch}:}%{?version:%{version}}%{?release:-%{release}
        for i in /usr/share/man /usr/X11R6/man; do \
                if [ -d "$RPM_BUILD_ROOT$i" ]; then \
                        echo "Compress man pages: $i"; \
-                       find "$RPM_BUILD_ROOT$i" -name '*.bz2' -print | xargs -r %{__bzip2} -df; \
-                       find "$RPM_BUILD_ROOT$i" -name '*.gz' -print | xargs -r %{__gzip} -dnf; \
+                       find "$RPM_BUILD_ROOT$i" -name '*.bz2' -print0 | xargs -0 -r %{__bzip2} -df; \
+                       find "$RPM_BUILD_ROOT$i" -name '*.gz' -print0 | xargs -0 -r %{__gzip} -dnf; \
                        find $RPM_BUILD_ROOT$i -type l | while read a; do \
                                m=$(readlink "$a"); \
                                if [[ "$m" = */* ]]; then \
@@ -543,14 +543,14 @@ Provides: %{1} = %{?epoch:%{epoch}:}%{?version:%{version}}%{?release:-%{release}
                                test -e $RPM_BUILD_ROOT$i/$l || test -e $d/$(basename $l) || echo "  ${doc#$RPM_BUILD_ROOT} points to inexistent manpage: $l"; \
                        done); \
                        test "$err" != "" && { echo >&2 "Man page link errors:"; echo >&2 "$err"; exit 1; }; \
-                       find "$RPM_BUILD_ROOT$i" -type f -size +%{_min_compress_bytes}c -print | xargs -r %{__gzip} -9nf; \
+                       find "$RPM_BUILD_ROOT$i" -type f -size +%{_min_compress_bytes}c -print0 | xargs -0 -r %{__gzip} -9nf; \
                fi; \
        done; \
        if [ -d "$RPM_BUILD_ROOT%{_infodir}" ]; then \
                echo "Compress info pages: %{_infodir}"; \
-               find "$RPM_BUILD_ROOT%{_infodir}" -name '*.bz2' -print | xargs -r %{__bzip2} -df; \
-               find "$RPM_BUILD_ROOT%{_infodir}" -name '*.gz' -print | xargs -r %{__gzip} -dnf; \
-               find "$RPM_BUILD_ROOT%{_infodir}" -name '*.info*' -type f -size +%{_min_compress_bytes}c -print | xargs -r %{__gzip} -9nf; \
+               find "$RPM_BUILD_ROOT%{_infodir}" -name '*.bz2' -print0 | xargs -0 -r %{__bzip2} -df; \
+               find "$RPM_BUILD_ROOT%{_infodir}" -name '*.gz' -print0 | xargs -0 -r %{__gzip} -dnf; \
+               find "$RPM_BUILD_ROOT%{_infodir}" -name '*.info*' -type f -size +%{_min_compress_bytes}c -print0 | xargs -0 -r %{__gzip} -9nf; \
        fi; \
 }; __spec_install_post_compress_docs } }
 
This page took 0.058855 seconds and 4 git commands to generate.