]> git.pld-linux.org Git - packages/rpm-build-macros.git/commitdiff
autotag: make git complatible (however needs to be in package dir)
authorElan Ruusamäe <glen@delfi.ee>
Thu, 2 Aug 2012 19:29:53 +0000 (22:29 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 2 Aug 2012 19:29:53 +0000 (22:29 +0300)
rpm-build.sh

index b39ea7063c8357e959c462656f95d07230d3c110..1a6ef686650aadebde05e0c72fdcf9eeedb70a3b 100755 (executable)
@@ -120,7 +120,7 @@ autotag() {
                s=${s%:*}
                # ensure package ends with .spec
                s=${s%.spec}.spec
-               out=$(cvs status -v $s | awk "!/Sticky/&&/auto-$dist-/{if (!a++) print \$1}")
+               out=$(git tag | awk "/auto\/$dist\//{if (!a++) print \$1}")
                echo "$s:$out"
        done
 }
This page took 0.034109 seconds and 4 git commands to generate.